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Welcome

Avenza welcomes you to mapmaking in the 21st century!

Combined with Adobe Illustrator,  MAPublisher has revolutionized the art of mapmaking by allowing spatial data 
files to be used to create maps inside a vector graphics program.  MAPublisher allows all your cartographic tasks to 
be performed where they should be done;  in a powerful graphics environment.

MAPublisher 6 improves on the already powerful tools of previous versions by adding additional file support,  
additional tools and improvements to existing tools.

This manual assumes that the user is familiar with Adobe Illustrator 10 or CS and has at least a basic understanding 
of geographic information systems (GIS) terminology and concepts.  Please refer to your Adobe Illustrator user 
guide for more information on using Adobe Illustrator.  A glossary of GIS terms is included at the back of this 
manual.

By following this manual you will learn how to create maps using the MAPublisher filters in Adobe Illustrator.  This 
manual covers the concepts necessary to build a map and perform fundamental cartographic and GIS tasks.  A 
variety of GIS data has been provided on your MAPublisher 6 CD for use with this guide and the Tutorials PDF (see 
Appendix 2),  however we do encourage you to experiment with your own data to gain additional experience with 
MAPublisher’s tools and functions.  

Together MAPublisher and Adobe Illustrator will give you a totally integrated cartographic design software system 
with graphics tools and geographic functions present in the same work environment.

So join first class mapping organizations from around the world and experience modern day map-making by 
reading this user guide,  going through the tutorials and experimenting with MAPublisher 6.
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What’s New in MAPublisher 6

Please read the following section if you are familiar with MAPublisher prior to version 6.0.

FEATURE MANIPULATION ENGINE

Avenza has teamed with Safe Software (http://www.safe.com) to introduce core FME functionality into MAPublisher.  
FME is capable of converting GIS data between a variety of different file formats and also hosts an extensive library 
of projections and datums.  Subsequently the number of supported import and export formats have increased 
again in this version of MAPublisher.  Furthermore MAPublisher 6 supports over 4500 coordinate systems with 
which you can transform your data.

IMPORTING MAP DATA

MAPublisher 6 introduces many more supported import formats.  Please see the Map Data File Formats section on 
pages 20-22 for an overview of the formats supported in this version.

The Import process itself has undergone some major changes.  In MAPublisher 6 there are two new GIS Import 
mechanisms named Simple Import and Advanced Import.  Simple Import is designed to provide a fast way 
to import one file,  or several files of the same data type and projection,  whereas Advanced Import provides 
functionality to import a number of files of differing data types and/or projections.  Advanced Import also 
provides the ability to reproject files prior to import by selecting from a projection list,  by using a listed file,  or by 
reprojecting to match existing MAP Layers.  You can also specify projections prior to import in both the import 
filters.  The new Importers are now located under the File menu,  replacing the Import Map and Import Points filters 
that existed in previous versions.  

IMPORT AUTO-GRAIN

MAPublisher 6 will apply grain values automatically if the points per path contained in the incoming data exceeds 
the limitations of Adobe Illustrator.  This function replaces the need to specify these values manually,  and will only 
be activated if it is required.

MAP VIEWS

There are two key elements to Map Data in MAPublisher 6.  The first change is that MAP Layers will now carry a 
unique feature type,  meaning that only one MAPublisher feature type will be recognized (Area,  Line,  Point,  Text or 
Legend) on a single layer.  The second is that MAP Layers will be held inside distinct MAP Views,  which are distinct 
coordinate systems either automatically created via the import process or manually by the user.

The MAP Views palette,  which is new in version 6,  and similar to Illustrator Layers palette,  will display the unique 
coordinate systems in the document.  All MAP Layers will be shown as being hosted by a particular MAP View.  If you 
have multiple coordinate systems in your document,  you can drag layers from one MAP View to another,  providing 
the means to quickly reproject your data.  Additionally new layers can be dragged into existing MAP Views,  which 
will automatically give the layer and its data georeferencing and MAPublisher status (thereby replacing the MAP 
Creation functions in previous versions).  When dragging new layers into MAP Views,  you will be prompted to set 
the feature type of that layer.  Note that if you wish to create Grids,  Legends,  Scalebars and North Arrows,  you must 
now create a new layer to host this data.  The feature type of this layer should be set to ‘Legend’ when you drag it to 
your desired MAP View.  Similarly to label features you must have a Text layer available on which the labels will be 
placed.

What’s New in MAPublisher 6



viii ix

As all MAP Layers will now carry a unique feature type,  the layers created via import will be appended with a suffix 
to indicate the feature type of that layer.  Additionally these feature types will be preceded with an icon depicting 
the feature type in the MAP Views palette and the majority of MAPublisher dialogs.

The MAP Views palette hosts additional options which replace certain tools from previous versions:
1. MAP View Editor: This contains the options that were formerly found in the Input and Output sections of the  
 Projection Editor,  and both the Transform Scale and Add MAP Parameters filters.  It also allows you to specify and  
 change the name of the selected MAP View.
2. Source Projection: This option was formerly Store Projection in MAPublisher 5.0’s Projection Editor.
3. Export: Formerly found within the host program’s Export option.  MAPublisher 6 provides many more supported  
 export formats.  Please see the Map Data File Formats section on pages 20-22.

MAP STYLESHEETS

MAP Stylesheets is new to MAPublisher 6,  and will allow you to quickly create and apply legends based on the 
Styles and Symbols that exist in these respective Illustrator palettes.  Stylesheets are created inside a MAPublisher 
dialog,  where specific values contained in the attribute table for the related layer are assigned to Illustrator 
symbology.  The MAP Stylesheets tool operates on a one to one basis,  where specific attribute values are assigned 
with a specific style or symbol (e.g.  Attribute Value A = Style 1).  Attribute value ranges and boolean expressions are 
not supported by MAP Stylesheets.  Stylesheets will be listed in a MAP Stylesheets palette,  so that more than one 
stylesheet can be used.

For value ranges and boolean expressions,  Assign Legend Info and Auto Assign Legend Info can continue to be used 
as in previous versions.

POINT DATA

Point Data is now based on vector symbology rather than by text as in previous versions.  Point Plot uses symbols 
which are available in the Illustrator Symbols palette.  ASCII Delimited Text Files imported as points will be created 
as a circular point which will be added to the Illustrator Symbols palette.  The symbol used for your points can be 
changed via the use of the Legend filters or MAP Stylesheets.  The geographic coordinate of points created via 
import or through Point Plot,  is coincident with the centre of the symbol.  

Note that the text anchor point,  denoting the geographic location of points in previous versions,  will be used to 
determine the centre of point symbols after legacy files have been converted to the MAPublisher 6 format.  See 
page 13 for information on Legacy Conversion.

SECURITY

MAPublisher 6 incorporates a new licensing system that is designed to deter casual,  unauthorized copying of 
the software.  Activation protects the intellectual property and innovation at the heart of the software industry.  
Avenza is committed to eliminating unauthorized use of its software and is doing so in a manner designed to have 
a minimal effect on licensed users.  Activation maintains customer privacy and does not change the terms of the 
existing Product License Agreement.  Please refer to page 15 for more information on Licensing procedures in 
MAPublisher 6.

What’s New in MAPublisher 6
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NEW IN MAPUBLISHER 6.1

Please read the following section for information on the major new functions incorporated into MAPublisher since 
the release of MAPublisher 6.0.

SINGLE PLUG-IN

MAPublisher 6.1 is a single plug-in,  thus dramatically increasing speed and performance.

JOIN POINTS

New to MAPublisher in version 6.1 is a filter to join symbols based on attribute values.  This tool will generate a line 
string joining common points,  and is ideal for GPS data.  Please see pages 95-96.

EDIT COLUMN:  GRAPHICAL PROPERTIES

The Edit Column filter has been modified to enable the scaling and rotation of point symbols based on a specified 
variable or by the contents of an attribute column.  This filter will also allow text objects to be rotated.  See pages 42-
44 for guidelines on how to use this new function.

SEARCH PROJECTION 

A new search tool has been added to all occurrences of the MAP View Editor and Source Projection, allowing you 
to perform a keyword search of the 4500 supported coordinate systems to find the projection that you require.  For 
more information on this tool see pages 51 and 53 of this guide.

MAP LOCATION TOOL:  COPY COORDINATES

Also new to the MAP Location Tool in MAPublisher 6.1 is the ability to copy the coordinates of a known point by 
simply holding down the shift key and clicking on the page.  This function is ideal for quickly building point files.  
Please see page 37 for more information.

MAP VIEWS PALETTE:  REMOVE MAPUBLISHER INFO

MAPublisher 6.1 contains functionality to quickly remove all MAPublisher information from your file.  At the end 
of the project cycle it may be useful to remove all georeferencing and attribute information in the document to 
reduce file size.  This can now be accomplished by simply dragging your MAP Layer(s) to the [Non-map layers] 
category in the MAP Views palette.

IMPORTING MAP DATA:  LAYER SORT

Multi-feature imports are now automatically sorted by feature type.  For example ArcInfo Export,  AutoCAD and 
Microstation files may contain more than one feature type.  Such files are now imported with text layers first,  point 
layers second,  line layers third,  and area layers fourth in the layer hierarchy.
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Before using MAPublisher please read this section to 
ensure that you have a suitable hardware environment,  
become familiar with the installation procedure,  and 
adequately prepare your system and workspace to make 
maps with Adobe Illustrator and MAPublisher 6.

The topics covered in this section are as follows:
System Requirements
MAPublisher Compatibility Notes
Installation Instructions
Registration and Licensing
The MAPublisher Tools
Preparing the Workspace

Chapter 1

Getting Started
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System Requirements

Before installing MAPublisher 6.1,  please ensure that you have sufficient system resources,  as outlined below:

WINDOWS

Minimum Requirements for MAPublisher 6.1 with Adobe Illustrator CS
• Adobe Illustrator CS
• Intel Pentium III or 4 processor,  or equivalent
• Windows 2000 with Service Pack 3,  or Windows XP
• 256 MB of RAM
• 300 MB of available hard-disk space
• CD-ROM Drive

Minimum Requirements for MAPublisher 6.1 with Adobe Illustrator 10*
• Adobe Illustrator 10.x
• Intel Pentium III or 4 processor,  or equivalent
• Windows 2000 with Service Pack 3,  or Windows XP
• 256 MB of RAM
• 300 MB of available hard-disk space
• CD-ROM Drive

MACINTOSH

Minimum Requirements for MAPublisher 6.1 with Adobe Illustrator CS
• Adobe Illustrator CS
• PowerPC G4 or above
• Mac OSX 10.2.8 or higher
• 256 MB of RAM
• 300 MB of available hard-disk space
• CD-ROM drive

Minimum Requirements for MAPublisher 6.1 with Adobe Illustrator 10*
• Adobe Illustrator 10.x
• PowerPC G4 or above
• Mac OSX 10.2.8 or higher
• 256 MB of RAM
• 300 MB of available hard-disk space
• CD-ROM drive

*  Note:  Certain non-English versions of Adobe Illustrator 10 are not supported by MAPublisher 6.1.  
 Please contact support@avenza.com for more information.

Getting Started:  System Requirements
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Illustrator CS

MAPublisher Compatibility Notes

MAPublisher 6 is compatible with both Adobe Illustrator 10 and CS.  Due to fundamental changes in MAPublisher 
with version 6,  it is imperative that you read the following important compatibility information.

BACKWARDS COMPATIBILITY

MAPublisher 6 documents are not backwards compatible with previous versions of MAPublisher.  Consequently,  
attribute and georeferencing information will be lost if a MAPublisher 6 document is opened with MAPublisher 5.0 
or earlier.  Furthermore,  due to Adobe’s redesigned text technology for Illustrator CS,  MAPublisher 6 documents 
created in Illustrator CS are not backwards compatible to MAPublisher 6 in Illustrator 10.

LEGACY DOCUMENT CONVERSION

Due to MAPublisher’s new standards on dealing with Point Data,  opening legacy files in MAPublisher 6 will 
automatically convert font based points to symbols.  However,  Illustrator CS has new methods of dealing with text,  
which is therefore an additional part of the MAPublisher conversion process.

MAPublisher 6 / Illustrator CS:  If the Illustrator Legacy Text Conversion dialog is activated when opening a 
legacy document,  you must click ‘OK’.  This will allow MAPublisher to use its own conversion utility to update text 
items.  If you click ‘Update’ the document will be opened,  however all attributes associated with this text will be lost.   
If you receive the MAPublisher Legacy Text Conversion dialog,  you must make one of the following choices:

 ‘All text art’ to convert both MAPublisher text and regular Illustrator text to the new Illustrator text format.
 ‘MAPublisher text art only’ to convert only MAPublisher text to the new Illustrator text format.
 ‘Nothing’  to open the file but lose attribute information associated with MAPublisher text elements.

Getting Started:  MAPublisher Compatibility Notes

Illustrator 10 Illustrator 9 or 8.01 Illustrator 9 or 8.01 Illustrator 7

Illustrator Legacy Text dialog

Loss of Text
attributes

MAPublisher Legacy Text dialog

Typical Legacy Document Format

New Document Format

Opened in Illustrator 10 with 
MAPublisher 6 installed

Illustrator 10

Opened in Illustrator CS with 
MAPublisher 6 installed
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Installation Instructions

WINDOWS

1.   Make sure that you have Adobe Illustrator 10.x or Adobe Illustrator CS installed on your computer.  If Adobe  
 Illustrator is running,  exit the program.

2.   If you planning to install MAPublisher 6.1 to Illustrator 10 and currently have MAPublisher 5.0 installed,  remove  
 MAPublisher 5.0 from your Adobe Illustrator 10 ‘Plug-ins’  folder.  This can be accomplished by running the ‘Add  
 or Remove Programs’ utility from the Control Panel.  Alternatively you can navigate to the ‘MAPublisher50’  folder  
 located in the Illustrator 10 ‘Plug-ins’ folder and then press the delete key,  or drag the folder to the Recycle Bin.

3.   CD version:  Insert the MAPublisher 6.1 CD into your CD-ROM drive.  If Autorun is disabled on your system,   
 navigate to the ‘MAPublisher 6.1’  directory on the CD,  and double click the ‘Setup.exe’ file.
 Electronic version:  Double click the ‘mp61wi-e.exe’  file to open the WinZip self extractor.  When you have  
 unzipped the files proceed to the ‘MAPublisher 6.1’  directory and double click the ‘Setup.exe’ file.

4.   Proceed through the installation screens as instructed.  Note that you can install to both Illustrator CS and  
 Illustrator 10 simultaneously if you desire.  
 Note that you will have options to install documentation and tutorial data.  If you choose to install these  
 components these files can be subsequently be found in the Program Files\Avenza\MAPublisher directory.   
 Additionally you may access the documentation from the Windows Start menu.  Go to ‘All Programs’,  and  
 then navigate to the  ‘MAPublisher’ folder.

5.   Launch Adobe Illustrator. 
 Please proceed to the section on Registration and Licensing on the following page.

MACINTOSH

1.   Make sure that you have Adobe Illustrator 10.x or Adobe Illustrator CS installed on your computer.  If Adobe  
 Illustrator is running,  exit the program.

2.   If you planning to install MAPublisher 6.1 to Illustrator 10 and currently have MAPublisher 5.0 installed,  remove  
 MAPublisher 5.0 from your Adobe Illustrator 10 ‘Plug-ins’  folder.  This can be accomplished by navigating to the  
 ‘MAPublisher50’  folder located in the Illustrator 10 ‘Plug-ins’ folder and then pressing the command + delete  
 keys,  or by dragging the folder to the Trash.  

3.   CD version:  Insert the MAPublisher 6.1 CD into your CD-ROM drive.  Navigate to the ‘MAPublisher 6.1’  directory  
 on the CD,  and double click the ‘Install MAPublisher 6.1’ icon.
 Electronic version:  Unstuff the  ‘mp61mi-e.sit’  file if this operation has not been completed automatically.  Then  
 proceed to the ‘MAPublisher 6.1’  folder and double click the ‘Install MAPublisher 6.1’ icon.

4.   Proceed through the installation screens as instructed.  
 Note that documentation and tutorial data will also be installed.  After installation,  these files can be found in  
 the Applications\Avenza\MAPublisher directory.  You can also choose to create an Alias to this folder at the end  
 of the installation process which will be placed on your desktop.

5.   Launch Adobe Illustrator. 
 Please proceed to the section on Registration and Licensing on the following page.

Getting Started:  Installation Instructions
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Registration and Licensing

Avenza offers both single-user and floating licensing for MAPublisher 6.  Floating licenses are designed to allow an 
organisation to buy a set number of licenses that can be used on any number of computers over a network.  If you 
have purchased such a license system,  you will have also received instructions on how to install the license server 
on your network and how to work with the Checkout License function.

The instructions below detail how to activate a single-user copy of MAPublisher 6.  Note that MAPublisher will fail to 
function until you activate the software.

ACTIVATING A PURCHASED COPY OF MAPUBLISHER

1. To activate MAPublisher 6 you must supply Avenza Systems with the Serial Number which was supplied to
   you by Avenza when you purchased the product.  The following guidelines can also be used to re-activate if  
 you have inadvertently deleted your license file from your hard drive.

2. After installation of MAPublisher 6,  launch the version of Adobe Illustrator you installed to.  The Activation  
  Wizard will appear automatically.  
 If you wish to continue to use Illustrator without MAPublisher,  you can cancel this wizard and activate MAPublisher  
 later by navigating to the Help menu in Adobe Illustrator and then to MAP Security > Register.
  
 If you have an Internet connection,  select the ‘I want to activate the software over the internet’  option and click 
 the ‘Next’  button.  At the second screen,  select the option for  ‘I have already purchased MAPublisher and want  
 to activate it now’  and then proceed through the wizard as instructed to complete the activation.

 If you do not have an Internet connection,  select the ‘I want to activate the software by telephone’  option and  
 click the ‘Next’  button.  Then phone Avenza to supply us with the Machine ID you see on the Finish screen.  We  
 will then send you an email with a zipped licence file attachment.  You must unzip this attachment and save  
 the *.lic file to your MAPublisher Plug-in folder.  This will be inside the Illustrator Plug-ins folder of your 
 appropriate version(s).

ACTIVATING AN EVALUATION VERSION OF MAPUBLISHER

1. After installation of the MAPublisher 6 Demo,  launch the version of Adobe Illustrator you installed to.  The  
 Activation Wizard will appear automatically.  
 If you wish to delay the start of your 14 day evaluation period,  you can cancel this wizard.  When you are ready to  
 activate MAPublisher,  navigate to the Help menu in Adobe Illustrator and then to MAP Security > Register.
 
 If you have an Internet connection,  select the ‘I want to activate the software over the internet’  option and click  
 the  ‘Next’  button.  At the second screen,  select the option for  ‘I want to activate a 14 day evaluation version’  and  
 then proceed through the wizard as instructed to complete the activation.

 If you do not have an Internet connection,  select the ‘I want to activate the software by telephone’  option and  
 click the ‘Next’  button.  Then phone Avenza to supply us with the Machine ID you see on the Finish screen.  We 
 will then send you an email with a zipped licence file attachment.  You must unzip this attachment and save  
 the *.lic file to your MAPublisher Plug-in folder.  This will be inside the Illustrator Plug-ins folder of your 
 appropriate version(s).

2. When you are ready to purchase the software you can re-open the Activation Wizard at MAP Security >  
 Register and follow the instructions listed on the second screen.

Getting Started:  Registration and Licensing
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e MAP Tools

Getting Started:  The MAP Tools

MAPublisher’s tools can be found at a number of locations in Adobe Illustrator. 

The MAPublisher Importers can 
be found under the File menu

MAPublisher’s Copy and Paste functions 
can be found under the Object menu

The MAPublisher floating palettes can be 
found under the Window menu
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4 MAPublisher tools can 
be found in the main 
Illustrator Tools palette

The majority of MAPublisher’s tools are grouped 
into 5 categories under the Filter menu
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Preparing the Workspace

Before you can start using MAPublisher,  you must first set up your Adobe Illustrator document.  It is at this point 
that you define your page size and units,  set your print orientation and generally prepare your Adobe Illustrator 
workspace.

SETTING UP YOUR DOCUMENT

1.  Create a new Illustrator document by selecting File > New,  or Select File > Document Setup if you already have a  
 blank document open
 - The Adobe Illustrator Document Setup window appears

2.  Select the size to use for your page.  Letter (8.5”x11”) is the default size*.  You may wish to change the orientation  
 to landscape for some files.  For example,  a map of Chile may be best displayed in Portrait but a map of Indonesia  
 may be best displayed in Landscape.

3.  If you have changed the page orientation in the previous step,  you should also select File > Print Setup,  and  
 change the orientation in the print settings as well.

4.  Select your desired page units.  The default unit type is Points.

5.  Ensure the page origin is at 0,0.  To do this,  select View > Show Rulers.  Click the top left corner of the workspace   
 where the vertical and horizontal rulers intersect and drag the cursor to the bottom left corner of the page.  You  
 may also double-click in the small square where the two page rulers intersect.

For more information and details regarding these operations please refer to your Adobe Illustrator User Guide.

* In step 2 the default page size of 8.5” x 11” is for North American versions of Adobe Illustrator.  Other language 
versions of Adobe Illustrator may have different default page sizes.  Consult your Adobe Illustrator User Guide for more 
information.

Getting Started:  Preparing the Workspace



18 19

The key to making maps with MAPublisher is the GIS data 
file formats it supports.  GIS files are precise geographic 
data files that contain vector information and associated 
data attribute tables.  

MAPublisher 6 will import AND export most of the 
industry leading vector file formats:

Import Formats
AutoCAD (*.dxf ) (*.dwg)
ESRI ArcInfo Export (*.e00)
ESRI ArcInfo Generate (*.gen)
ESRI Shapefile (*.shp)
MapInfo Interchange (*.mif / *.mid)
MapInfo Table (*.tab)
Microstation (*.dgn)
TIGER/Line (*.rt1) (*.bw1)
USGS Digital Line Graph (*.dlg) (*.opt)
USGS SDTS (*.ddf )
ASCII Point (*.txt) (*.csv) (*.dat)

Export Formats
AutoCAD (*.dxf ) (*.dwg)
ESRI ArcInfo Export (*.e00)
ESRI ArcInfo Generate (*.gen)
ESRI Shapefile (*.shp)
MapInfo Interchange (*.mif / *.mid)
MapInfo Table (*.tab)
Microstation (*.dgn)

This section will provide and overview of the formats 
outlined above,  as well as additional considerations 
when using GIS data with MAPublisher.  

For an in-depth analysis of further considerations when 
using these formats during Import,  such as supported 
version numbers,  supported colours and strokes,  etc,  
please see pages A1/2 to A1/9.

Chapter 2

Map Data File Formats
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AutoCAD Drawing (*dwg) and Drawing Exchange (*.dxf)
Import and Export

These file types are most commonly created by Autodesk’s AutoCAD product,  though other software programs 
such as Bentley MicroStation and various other computer-aided design (CAD) programs are capable of creating 
files in this format.  There are two formats used by AutoCAD:  DXF (drawing exchange format) files,  which 
are large, and ASCII representations of the binary DWG (drawing) files.  Logically,  both files are identical and,  
therefore,  MAPublisher treats both file types in the same manner.  AutoCAD files consist of drawing settings and 
configurations,  as well as a series of entities,  or graphic elements,  organized into layers.  MAPublisher provides 
broad support for many AutoCAD entity types and options.  

Multi-feature imports are automatically sorted by feature type.  AutoCAD files are imported with text layers first,  point 
layers second,  line layers third,  and area layers fourth in the layer hierarchy.

ESRI ArcInfo Export (*.e00)
Import and Export

ArcInfo Export files are created by ESRI’s ArcInfo product.  A single E00 file describes a complete ArcInfo coverage.  
The file itself is actually an archive of several smaller files,  or sub files,  which will have fixed names and follow a 
predefined data format.  MAPublisher will reproduce these sub files as distinct Illustrator layers on import.  Therefore  
importing a single e00 import can result in the generation of point,  area,  line and text layers.

Multi-feature imports are automatically sorted by feature type.  ArcInfo Export files are imported with text layers first,  
point layers second,  line layers third,  and area layers fourth in the layer hierarchy.

ESRI ArcInfo Generate (*.gen)
Import and Export

ArcInfo Generate files are created by ESRI’s ArcInfo product,  and have a simple ASCII ‘from x-y to x-y’ format.  Due 
to its simplicity you can also use a text editor such as Notepad to create text files and save them with a *.gen 
extension,  which can then be imported with MAPublisher.  

ESRI Shapefile (*.shp)
Import and Export

Shapefiles are most commonly created by ESRI’s ArcView product although other products,  including MAPublisher,  
are capable of generating files in this format.  Shapefiles store both geometry and attributes for features,  and a 
single shapefile will consist of at least three physical files.  The .shp portion contains the geometric data,  the .dbf 
contains attributes for the geometric data,  and the .shx contains the index information.  All three files are required 
in order to successfully import a shapefile to Adobe Illustrator using MAPublisher.  There is also usually a .prj file,  
which holds the projection information of the shapefile and will automatically be read by MAPublisher on import.  If 
your shapefile folder does not contain a .prj file you will be required to specify the projection in order to fully utilize 
MAPublisher.  The important things to remember when importing shapefiles are that the .shp file must be the one 
that is selected through the MAPublisher import filter and that all its component files must be in the same folder.  
You may also find that your shapefile directory comes with two extra files,  a .sbn and a .sbx,  which hold the spatial 
index for the geometric data.  These two files will not exist unless the shapefile was created with an ESRI product,  
and are not necessary for successful import with MAPublisher.

Map Data File Formats
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MapInfo Interchange (*.mif/*.mid)
Import and Export

Files of this type are most commonly created by the MapInfo product,  though other products,  including 
MAPublisher,  are also capable of generating files in this format.  These files exist in pairs where each file has the 
same name but ends in either a .mif or .mid.  file extension.  The .mif portion contains the vector geometric data,  
and the .mid contains the associated attributes.  Both files are required in order to successfully import a file of this 
format to Adobe Illustrator using MAPublisher.  The important things to remember when importing MapInfo files 
are that the .mif file must be the one that is selected through the MAPublisher import filter and that both files must 
be in the same folder.  MAPublisher will automatically locate and deal with the .mid file.  

MapInfo Table (*.tab)
Import and Export

The TAB format is a simple,  non-topological format for storing the geometric location and attribute information 
of geographic features,  and is an integral part of the MapInfo product.  The TAB format defines the geometry and 
attributes of geographically-referenced features in several files with specific file extensions that are stored in the 
same folder on disk.  They are:
.tab – main file: table structure in ASCII format.
.map - the file that stores the feature geometry.
.id - the file that stores the index of the feature geometry.
.dat - the dBASE file that stores the attribute information of features.
.ind - table field indexes (if necessary)
The geometry of each feature is stored as a shape that comprises a set of vector coordinates.  The attributes for each 
feature are stored as a record in a dBASE table (.dat) associated with the shapefile (.map).  There is one record in the 
dBASE table for each feature in the map file.
To ensure successful import,  select the .tab component in the MAPublisher importers.

Microstation Design (*.dgn)
Import and Export

Microstation Design files (.dgn) are the native files created by Bentley Systems Inc’s (and formerly Intergraph’s) 
Microstation product.  Design Files consist of a header,  followed by a series of elements.  The header contains global 
information including the transformation equation from design units to user coordinates,  as well as the dimension 
of the elements in the file.  Each element contains standard display information,  such as its colour,  level,  class,  and 
style,  as well as a number of attributes specific to its element type.

During the import process MAPublisher will reproduce .dgn ‘levels’ as distinct Illustrator layers.  Therefore a typical 
single import will produce one layer for each Level that exists in the Microstation Design File.

MAPublisher supports the import of Microstation J (version 7) and V8 files.  Files are exported to DGN from 
MAPublisher as Microstation J files.

Multi-feature imports are automatically sorted by feature type.  Microstation files are imported with text layers first,  point 
layers second,  line layers third,  and area layers fourth in the layer hierarchy.

Map Data File Formats
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TIGER/Line (*.rt1) (*.bw1)
Import only

‘TIGER’ is an abbreviation of ‘Topologically Integrated Geographic Encoding and Reference System’,  and was 
developed by the U.S.  Census Bureau.  TIGER/Line files are a digital database of geographic features,  such as roads,  
railroads,  rivers,  lakes,  political boundaries,  census statistical boundaries,  etc.,  that cover the entire United States.  
The database contains information about these features such as their location in latitude and longitude,  the name,  
the type of feature,  address ranges for most streets,  the geographic relationship to other features,  and other 
related information.  TIGER/Line files are the public product created from the Census Bureau’s TIGER database of 
geographic formation.  TIGER was developed in order to support the mapping and related geographic activities 
required by the census and sample survey programs.  More information on the TIGER/Line file format and data 
product can be found on the U.S.  Census web page at:  http://www.census.gov/geo/www/tiger/

MAPublisher considers the .rt1 or .bw1 file as the Tiger dataset.  Even though each county will consist of a series of 
files with a common base name,  there may be a number of different extensions.  Remember to select the .rt1 or 
.bw1 file when importing Tiger data.  

USGS Digital Line Graph (*.dlg) (*.opt)
Import only

The United States Geological Survey’s DLG file structure is designed to accommodate categories of spatial data 
represented on a conventional line map.  Node (point),  line,  and area data types are accepted.  The attribute coding 
scheme is designed to accommodate basic cartographic data categories such as hypsography,  hydrography,  or 
political and cultural features,  as well as additional thematic data categories.

USGS SDTS (*catd.ddf)
Import only

Digital cartographic products of the USGS are available in the Spatial Data Transfer Standard format,  and are 
generally distributed over the Internet as a means of promoting the standard.  For SDTS import,  select the ‘catd’ file 
(xxxxcatd.ddf ),  which is the index file that contains a description of the other files in the SDTS transfer.  Individual 
DDF files cannot be imported.  Generally all SDTS downloads will contain the CATD file.

ASCII Point (*.txt) (*.csv) (*.dat)
Import only

MAPublisher also supports the import of ASCII data held in a variety of tabular file formats,  as long as the data 
contains coordinate values.  File types supported are Text (.txt),  Data (.dat) and Comma Separated (.csv) files.

Import Settings dialog: In order to import point data with MAPublisher you must set parameters by clicking the 
‘Settings’ button.  This operation is required to choose the columns of the selected attribute file that will be used to 
derive the X and Y coordinates of the data,  and ensure correct georeferencing.  These and further settings will be 
discussed in the ASCII Point Data Settings section on page 27.

Map Data File Formats
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DATA CONSIDERATIONS

When obtaining GIS data for use with MAPublisher,  whether from an online source,  commercial vendor,  
government office or from an internal source within your organization,  there are a number of important 
considerations to keep in mind.

First and foremost you should always endeavour to obtain data in one of the formats supported by the MAPublisher 
Importers (see pages 20-22).  In cases where the file format native to a particular mapping application is not 
supported by MAPublisher,  you can often request the data provider to export a file in one of the supported formats.

When obtaining data you should acquire as much meta-data about the files as possible.  MAPublisher deals with 
data in the following manner:  Unprojected data will be imported by MAPublisher with latitude and longitude map 
anchors,  which will therefore range from (x) -180 to 180,  (y) -90 to 90.  Unprojected data will also import with a non-
earth scale.

If you receive projected data you should be aware of the following.  MAPublisher will import projected data with 
a true scale and appropriate map anchors.  Unlike unprojected data,  these map anchors will not be in lat/long,  
but rather in a coordinate system appropriate for the particular projection.  For most file formats the name of 
the projection,  datum,  and units will be recognized by MAPublisher.  However if the program cannot find this 
information in the data,  and you wish to subsequently reproject your data,  you will be required to specify the 
coordinate system.

Additionally,  please be aware that MAPublisher is a 2D mapping program.  Therefore if you attempt to import 3D 
data with MAPublisher it will be converted to two dimensional artwork by the importers.

Map Data File Formats
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The Import filters are the main starting point for most 
users wanting to work with GIS map data in Adobe 
Illustrator.   These are the filters that must be used to 
import GIS data files,  set the initial map scale and define 
your cartographic workspace to start making maps.

MAPublisher supports the Import of the following GIS 
data formats:
AutoCAD (*.dxf ) (*.dwg)
ESRI ArcInfo Export (*.e00)
ESRI ArcInfo Generate (*.gen)
ESRI Shapefile (*.shp)
MapInfo Interchange (*.mif / *.mid)
MapInfo Table (*.tab)
Microstation (*.dgn)
TIGER/Line (*.rt1) (*.bw1)
USGS Digital Line Graph (*.dlg) (*.opt)
USGS SDTS (*.ddf )
ASCII Point (*.txt) (*.csv) (*.dat)
See pages 20 to 22 for a description of these formats.  

There are two Import filters available,  which will be 
discussed in detail in this section:

Simple Import:  This filter is designed to provide a fast 
way to import one file,  or several files of the same data 
format and projection,  into Adobe Illustrator.

Advanced Import:  This filter provides functionality to 
import a number of files of differing data type and/or 
projections into Adobe Illustrator.

Chapter 3

Importing Map Data
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Search Projection  - Click this 
button to open the Search 
Projection dialog (Page 49),  
enabling you to search for 
projections by specifying a 
text string.  Results of the 
search are displayed in 
the ‘Search Results’ category.

Projection List - Choose the 
known projection from this list.

Details - View the parameters 
of a selected projection.

Resize - Drag the lower right 
corner of the palette down to 
expand the Projection List.

Simple Import
File > Import Map Data > Simple

OK - Clicking this button will import 
the selected file(s) into Illustrator.

Add to - Add the incoming data file to 
a matching MAP View in MAPublisher.

Resize MAP View to fit - Check 
this box to rescale the matching data so 

that both the selected layer and the 
incoming data fit inside the page extents.

Format - Select the data type you 
wish to import.  This dropdown 

lists the names of all MAPublisher 
supported data types.

Dataset - Displays the directory path 
and filename for the currently 

selected file(s).  You can also manually 
type in the dataset location here.

Settings - Opens a Settings dialog 
if the file format requires the input 
of extra parameters,  such as for the 
import of DGN,  DXF,  DWG,  E00 and 
ASCII Point Data (see facing page).

Edit - If the coordinate system of the selected file(s) is known,  
but it was not automatically generated by the program,  click 

here.  This will open the Source Projection dialog (below).

Source MAP View - Provides a 
description of the coordinate system

and units detected in the data source.

Browse - Opens a Data Source 
browser to enable the selection 
of files for import.

Matching MAP View

MAP View dropdown - Select the matching 
coordinate system that you wish to align the 
incoming data to.

Fit to page based on new MAP View - Both the 
matching coordinate system and incoming data 
will be treated separately in terms of page scaling.

Source Projection

Projection Category - 
Choose a category from this 

dropdown appropriate to the 
data to be imported.  For all 

the projections in the database 
select ‘All Projections’.  For a 

list of the last 20 projections 
used,  select ‘Recently Used’.

Same as - Check this option 
in order to assign a projection 

that matches that of an 
existing MAP View.

Importing Map Data: Simple Import

Related Tools

This dialog will automatically open after clicking the Edit button.

This dialog will automatically open if there is already a coordinate 
system in your document which matches the incoming data.
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Group Entities By - Group 
entities by layer Name,  

geometry or build AutoCAD 
schema by scanning 

extended entity data.

Blocks - Check this box if you 
want to explode blocks and 
return the entities that form 

the components of the block 
as separate features.

Visual Attributes - Check this 
box if you want each visible 

attribute to be returned as a 
single text feature.  

Paper Space - Setting to ‘Read’ 
will instruct MAPublisher to 

also read the entities from 
paper space.  By default,  

MAPublisher will only read the 
entities from model space.

Enable - Specify if you require the 
creation of a layer holding the 

registration control points.  If you 
enable this option an extra layer will 

be created appended with ‘_tic_point’.

AutoCAD DXF/DWG Settings

ESRI ArcInfo Export
Settings

Group Elements - 
Choose how you want to group 

the elements.  If you group the 
elements by level,  it may result in 

a large number of output files.

Coordinate Units - Specifies 
how feature coordinates will be

interpreted and converted.

Create black background -
Check this option to incorporate 

a layer containing a black 
background,  to mimic the 

Microstation environment.

Expand cells - Check this box 
if you want the cells expanded 

into separate features.

Microstation Design Settings

Linkage Extraction - Linkage 
Extraction boxes allows you to extract 
MSLinks and/or FRAMME attribute 
linkage values from the Source 
Design File.  Only the first three
linkage values will be extracted.

Complex Strings - Check ‘Drop’ 
if you want each component of a 
complex chain to be returned as its 
own feature.  Otherwise all elements 
of the complex chain will be merged 
into a single linear feature.  Check 
‘Propagate Member Linkages’ if you 
want the linkages attached to the 
first component of the complex chain 
to be returned on the MAPublisher 
feature,  supplementing any existing 
linkages.

Import Settings

ASCII Point Data Settings

X/Y Columns - These two dropdown lists hold the 
names of all the numeric columns in the selected file.  
Select the columns from which the X coordinates and 

the Y coordinates for each point will be read.

Multipliers - Click this 
button to open the 
Multipliers dialog.

Multiply coordinates X/Y - You may 
enter a value by which all X values and,  
or,  all Y values for each point will be 
multiplied by before they are imported.

Use first line as a header - If 
the first line of the text file you 
are importing contains column 
headings,  check this box.

Importing Map Data: Settings Dialogs

Bulge Handling - Determines how AutoCAD curves are handled 
on import.  By default, the arcs are approximated by splitting them 

into a series of connected segments (vectorized).  In rare cases when 
the number of points on the map becomes a critical consideration, 

an approximation with smooth Bezier curves can be specified.

Display tags - Check this box to display tags.  Elements 
in a design file may have user-defined attributes (tags) 
attached to them which can be read by MAPublisher.
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SIMPLE IMPORT FUNCTIONALITY

The Simple Import dialog provides a fast,  uncomplicated method of importing map data into Adobe Illustrator.  Its 
focus is for the mapmaker who has a single piece of map data,  or several smaller files comprising one dataset of the 
same format and projection,  that they wish to simply import quickly.

PREREQUISITES

In order to import data via Simple Import,  you must first set up your Illustrator document.  Plan for the data that 
you will subsequently bring in,  and set up your Illustrator document accordingly.  For instance a map of the world 
would fit well into a page with a Landscape orientation,  whereas a map of South America would fit best into a page 
with a Portrait orientation.  Also plan for the output of the map document if necessary,  to ensure that your page 
dimensions are close to the required size that the document will be printed.  It is far easier to set up the page before 
the map data has been imported,  as MAPublisher will interpret these dimensions in the Importer,  and calculate a 
map scale for your document accordingly.  If you do edit the size of your document,  remember to reset your rulers 
before opening either Importer in order for MAPublisher to correctly fit the data into the page extents.

Once your page has been set up you can access the MAPublisher Simple Import dialog under the File menu,  at the 
Import Map Data pullout.  

USING SIMPLE IMPORT

DIALOG OVERVIEW

The dialog itself is split into two sections.  The upper section allows you to choose a file format,  select the file 
you wish to import,  and enter any additional settings that may be required.  The lower section will display the 
coordinate system of the selected file and allow you to specify this manually if the program has not detected a 
projection.

ADDING FILES

In order to select a file or files for import you can either leave the Format dropdown Blank,  or set the dropdown to 
the file type you wish to import.  If this dropdown is left with no selection when you search for your GIS file to open,  
ALL files will be displayed.   It is often easier therefore to set the Format dropdown at the required format to ease 
navigation and file selection.

When you have chosen the format,  click the Browse button to select your file(s) and then click Open.  Alternatively 
you can type in the full path of the file(s) in the Dataset field.  Note that the import of multiple of ASCII Point files is not 
supported.

SOURCE MAP VIEW

Once the Dataset field has been populated with a valid path,  the program will read the file(s) to determine the 
coordinate system and display this in the Source MAP View section (see MAP Views on pages 45 to 53).

If the program returns the message ‘<not detected>’ for the coordinate system,  you may click the Edit button to 
specify it (MAPublisher will read the projection automatically if the file format supports projection information).   In 
the Source Projection dialog,  projections are separated into Projection category to ease the process of choosing a 

Importing Map Data: Simple Import
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projection.  All Projections will list all the projections in the database.  If you wish to view the parameters of a 
certain projection,  you can click the Details button to view them.  You can also assign a projection based on an 
existing MAP View in your document by using the Same as dropdown.  For an overview of Projections and Datums 
see pages A1/27 to A1/31.

FORMAT SPECIFIC SETTINGS

Certain file formats will offer additional configuration parameters which can be accessed by clicking the Settings 
button.  These file formats are ArcInfo Export,  AutoCAD DWG/DXF,  Microstation DGN,  and ASCII Point Data*.  
Select your file(s) first.  If the format accepts additional settings the Settings button will be enabled.  Study the 
Import Settings guide (page 27) for an overview of the meanings of these options.  
*Note that only for the import of ASCII Point Data are additional Settings mandatory.

ASCII POINT DATA SETTINGS

MAPublisher also allows for the import of delimited ASCII text files as point data provided they contain coordinate 
values.   MAPublisher 6 supports the import of delimited ASCII files that contain any of the following delimiters 
between data values: comma,  return,  end of line and tab.  

To import ASCII data,  you must choose the Columns to use for your X & Y coordinates from the two dropdowns.  
Note that only numerical columns will be listed to ease the process of determining the columns to use.  If the first 
line of the text file you are importing contains column headings,  check the Use first line as a header checkbox,  
though MAPublisher will generally automatically detect if this is the case.  If the file does not appear to contain 
column headers,  MAPublisher will assign the default headers “Column1”,  “Column2” to the attribute columns on 
import.  

You may also choose to multiply your coordinate values by a specified value.  For example if a Point has a coordinate 
value of 2.5 by 6.2,  entering a Multiplication value of 10 would result in its coordinate being 25 by 62 after import.  
To enter such values,  click the Multiply button and enter your values into the X and Y fields.

IMPORTING DATA

When you have your file(s) selected,  and if necessary specified the coordinate system and/or extra settings,  you can 
click OK to import.  

If MAPublisher finds there is a coordinate system already in your document which matches the incoming data,  the 
Matching MAP View dialog will open (see MAP Views,  on page 45).  If this dialog opens you must choose to either 
add the incoming data file to a specified MAP View,  or create a new MAP View to hold the incoming data.

1.   If you specify Add to,  choose the MAP View from the listbox to add your incoming data to.  This option will also   
 allow you to rescale the existing and incoming data which will comprise this MAP View in order to fit them all
 inside the page extents.  To achieve rescaling,  check the Resize MAP View to fit option.  If you do not check this  
 option,  some of your data may be imported outside of the page extents.
2.   If you specify Fit to page based on new MAP View,  the incoming data will be treated separately from the  
 matching data,  as if it was the first import.

Importing Map Data: Simple Import
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RESULTS

The data will be imported into Adobe Illustrator,  and will be generated as Illustrator layers,  one for each feature 
type in the import.  The name of these layers will be a direct reproduction of the name(s) of the imported data.  For 
instance importing a single polygon file named world.mif would produce a single Illustrator layer called world_area,  
which contains the imported file.  Furthermore this layer can be seen as part of a MAP View,  where Illustrator layers 
are automatically placed as sub features of specific coordinate systems.

SIMPLE IMPORT TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
3-i ...  Importing a Single Map File
3-ii ...  Importing Multiple Map Files at Once
3-iii ...  Importing Map Files to Match an Existing Layer
3-iv ...  Importing Map Files with Auto-Grain
3-v ...  Importing GIS Formats that Require Optional Settings
3-vi ...  Importing Points
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Advanced Import
File > Import Map Data > Advanced

File List - This is a table where all 
files selected for import are listed.

Remove - Allows removal of 
selected files from the list.

Edit - Allows the Edit of the 
selected file by re-opening the 
Advanced Import Data 
Source dialog (see below).

Details - Displays details of 
currently selected file: Coordinate 
System,  Unit,  Page Anchors,  
Scale,  Map Anchors and Rotation.

Format - Select the data type you 
wish to import.  This dropdown lists all 

MAPublisher supported data types.

Dataset - Displays the directory path 
and filename for the currently selected 

file(s).  You can also manually type in 
the dataset location here.

Source Projection - This section 
allows the manual selection of the 

coordinate system if this information 
is not held in the data source.  

Projection List - A list of the 
projections available for selection,  

based on the choice of Category.

Same as - Check this option in order 
to assign a projection that matches 

that of an existing MAP View.

Advanced Import Data Source dialog

Import Settings
See page 27.

Importing Map Data: Advanced Import

Settings - Opens a Settings dialog 
if the file format requires the input 
of extra parameters,  such as for the 
import of DGN,  DXF,  DWG,  E00 and 
ASCII Point Data (see page 27).

Browse - Opens a Data Source 
browser to enable the selection of 
files for import.

Search Projection  - Click this button 
to open the Search Projection 
dialog (Page 51),  enabling you to 
search for projections by specifying 
a text string.  Results of the search 
are displayed in the ‘Search Results’ 
category.

Details - Click this button to view the 
parameters of a selected projection.

Resize - Drag the lower right corner 
to expand the Projection List.

File Name - The directory path of 
the map file(s) to be imported.

File Numbers - Allows the 
selection of individual files in 
order to activate the Edit and 

Remove buttons.

Add - Allows the selection of 
files for import by opening the 

Advanced Import Data 
Source dialog (below).

New based on - Allows you 
to import all of the files in a 

projection contained in a 
file in the File List.

Use existing - Allows you to 
import all of the files in a 

projection that already exists 
in a MAP View in the document.

Create new - Allows you to 
import all of the files in a new 

projection.  Clicking the ‘Editor’ 
button opens the MAP View 

Editor (see page 51).

Related Tools

This dialog will automatically open after clicking the Add or Edit button.

Auto scale - If you have multiple files in the File List,  and 
have selected the ‘New Based On’ option,  check this box to 
ensure all the files fit inside the page extents when imported.
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ADVANCED IMPORT FUNCTIONALITY

Advanced Import provides an alternative method of importing map data into Adobe Illustrator.  Its focus is for the 
mapmaker who has a collection of map data,  that they wish to import into Adobe Illustrator at the same time.  This 
function can deal with import of multiple formats and varying projections,  with the dialog providing a list of files 
flagged for import.  

PREREQUISITES

In order to import data via Advanced Import,  you must first set up your Illustrator document.  Please see the 
guidelines for setting up your page that are included in Using Simple Import (page 28)

Once your page has been set up you can open MAPublisher Advanced Import.  This is located under the File menu,  
at the Import Map Data pullout.  

USING ADVANCED IMPORT

DIALOG OVERVIEW

The dialog itself is comprised of a list box  for the display of currently selected files;  buttons to Add,  Remove,  or Edit 
files for Import; and a section for the specification of an output projection,  whether this be a projection contained 
in one of the files in the list,  a projection in the current document,  or a new user specified projection.

ADDING FILES

In order to select a file or files for import first click the Add button.  In the Advanced Import Data Source dialog 
you can either leave the Format dropdown blank or set the dropdown to the file type you wish to import.  If this 
dropdown is left with no selection,  when you search for your GIS file to open ALL files will be displayed.   It is often 
easier therefore to set the Format dropdown at the required format to ease navigation.

When you have chosen the format,  click the Browse button to select your file(s) and then click Open (only one file 
format can be opened from this Open dialog).  Alternatively you can enter the path of the file(s) in the Dataset field.  
Note that the import of multiple of ASCII Point files is not supported.   

SOURCE PROJECTION

If you are aware that your selected files do not contain Coordinate System information,  you can either specify it 
within the Advanced Import Data Source dialog,  or you can assign a projection based on an existing MAP View in 
your document by using the Same As dropdown.  Additionally if you wish to view the parameters of a certain listed 
projection,  you can click the Details button to view them.  For an overview of Projections and Datums see pages 
A1/27 to A1/31.  Generally most users should ignore the Known Projection section when choosing the Import files,  
as the program will read the projection automatically if the file format supports projection information.  You can 
always return to this dialog later to edit the choices you have made.
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FORMAT SPECIFIC SETTINGS

Certain file formats will offer additional configuration parameters which can be accessed by clicking the Settings 
button.  These file formats are ArcInfo Export,  AutoCAD DWG/DXF,  Microstation DGN,  and ASCII Point Data*.  
Select your file(s) first.  If the format accepts additional settings the Settings button will be enabled.  Study the 
Import Settings guide (page 27) for an overview of the meanings of these options.  
*Note that only for the import of ASCII Point Data are additional Settings mandatory.

ASCII POINT DATA SETTINGS

MAPublisher also allows for the import of delimited ASCII text files as point data provided they contain coordinate 
values.   MAPublisher 6 supports the import of delimited ASCII files that contain any of the following delimiters 
between data values: comma,  return,  end of line and tab.  

To import ASCII data,  you must choose the Columns to use for your X & Y coordinates from the two dropdowns.  
Note that only numerical columns will be listed to ease the process of determining the columns to use.  If the first 
line of the text file you are importing contains column headings,  check the Use first line as a header checkbox,  
though MAPublisher will generally automatically detect if this is the case.  If the file does not appear to contain 
column headers,  MAPublisher will assign the default headers “Column1”,  “Column2” to the attribute columns on 
import.  

You may also choose to multiply your coordinate values by a specified value.  For example if a Point has a coordinate 
value of 2.5 by 6.2,  entering a Multiplication value of 10 would result in its coordinate being 25 by 62 after import.  
To enter such values,  click the Multiply button and enter your values into the X and Y fields.

ADVANCED IMPORT FILE LIST

Once the Dataset field has been populated with a valid path and you have clicked OK,  the program will close the 
Advanced Import Data Source dialog and either read the selected file(s) to determine the coordinate system,  or 
attach your specified projection to the files.  The file(s) will now be listed in the Advanced Import dialog. 

You can now add more files to this list (for instance adding the next file format) by re-clicking the Add button and 
proceeding in the same manner as specified above.

There are two columns present in the Advanced Import list.  The first will display the full path of each file,  and the 
second will display the projection that has either been automatically read by the program or assigned manually.  
Each file added to the Import list will have a row number that can be clicked in order to select it.  This function will 
allow you to remove a selected file from the Import list; or edit a selected file.  Therefore to remove a selected file or 
number of selected files from the Import list click the Remove button.

EDITING COORDINATE SYSTEMS PRIOR TO IMPORT

If the program displays Unknown Projection for the Coordinate System of a file,  you may select the row and click 
the Edit button to specify it by returning you to the Advanced Import Data Source dialog.

Note that you can only import the listed files in a single projection,  even though they may comprise of several.  
Therefore the Destination MAP View section holds the details of which projection the listed files will be imported 
in.  The projection the file(s) will be imported in will be displayed in the panel in this section,  and will show the 
Name of the Projection,  its Map & Page Anchors,  Scale and Angle for the selected file.  These settings will be 
discussed more in Attributes and Georeferencing on page 36.

Importing Map Data: Advanced Import



34 35

You have three choices when deciding a Destination MAP View:

1. You can choose to import all of the listed files in the projection and parameters that exists in one of the listed  
 files.  Click New based on and then select one of the files in the projection you require.  If you have multiple  
 files in the File List,  you can check the Auto scale option to ensure that when the data is imported,  it is scaled to
  fit the current page extents.  If you do not check this option,  some of your data may fall outside of the page  
 extents during the import process.

2. You can choose to import all of the listed files in the projection and parameters that currently exists in the  
 document (for example via a previous import).  In this case select Use existing and then select the MAP View  
 containing the desired projection.

3. Finally you can choose to assign another projection completely by first selecting the Create new option,   and  
 then clicking Editor.  This will open the MAP View Editor,  allowing you to specify a projection from a projection  
 list and make numerous page scaling edits.  For an in depth look at this tool,  see pages 51 to 53.

RESULTS

When you have your file(s) selected,  and if necessary specified the coordinate system and/or extra settings,  you 
can click OK to import.  The data will be imported to Adobe Illustrator,  and will be gathered as Illustrator layers,  
one for each feature type in the import.  The name of these layers will be a direct reproduction of the name(s) of 
the imported data.  For instance importing a polygon file named county.mif and a line file named roads.shp,  would 
produce two Illustrator layers named county_area and roads_line,  which contain the imported files.  Furthermore 
these layers will be seen as part of a MAPublisher View,  where the Illustrator layers will be automatically placed as 
sub features of a single coordinate system,  being the singular coordinate system specified in the Destination MAP 
View section of the Advanced Import dialog.

ADVANCED IMPORT TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
3vii ...  Importing Multiple File Types
3viii ...  Importing Map Files in Multiple Projections
3ix ...  Importing Map Files to Match an Existing Layer’s Projection
3x ...  Assigning a Projection Prior to Import
3xi ...  Changing a Projection Prior to Import

Importing Map Data: Advanced Import
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MAPublisher’s ability to import GIS files into Illustrator 
while retaining both geographic vector and attribute 
information makes it very easy to produce high quality 
maps.  

This section will explain the principles of georeferencing 
and attribute information and how these are maintained 
within MAPublisher.  The following related tools will be 
examined:
MAP Location Tool
MAP Attributes
MAP Columns
Select by Attribute
Edit Column

Chapter 4

Attributes and
Georeferencing
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Attributes & Georeferencing - Foreword

GEOREFERENCING

Georeferencing in MAPublisher is based in part on the relationship between Page Anchors and Map Anchors.  
MAPublisher bases its georeferencing on a tie in point within Adobe Illustrator.  During the import process,  the 
software will treat the point at (0,0) in the document (Page Anchors) as being coincident to the lower left corner 
of the data in real world coordinates (Map Anchors).  MAPublisher will use this anchor point in subsequent data 
transformations,  such as rescaling and reprojecting,  and will also be used in the creation of grids and to maintain 
georeferencing on export.  

The most common way to set up an Illustrator page is to set the (0,0) point as being the coincident with the lower 
left corner of the document.  When you open a new document in Illustrator,  and choose to view the rulers,  you will 
see that the point at (0,0) in document units is at this location.  Therefore when MAPublisher imports a GIS file,  it will 
place a lower left point with real world coordinates at this (0,0) point.  Consequently a map of the world in Latitude/
Longitude,  imported into a new Illustrator document with the units set to inches,  would produce a tie in point of 
X = 0”,   Y = 0”  for the Page Anchors,  and X = -180°,  Y= -90°  for the Map Anchors.  From this point on these two 
points are dynamically linked.  Note that in MAPublisher dialogs,  Map Units are displayed in the coordinate system 
of the layer.

ATTRIBUTE INFORMATION

The attribute table that forms part of a GIS map file is one of the most important parts of any data set.  It is in the 
attribute table that we find important information such as street names for lines,  zoning or zip code numbers for 
areas and elevations for points to go along with our vector line,  area or point data.  Along with vector line,  area 
and point data imported as explained in the previous sections,  MAPublisher also imports the attribute data table 
associated with any vector map file that it supports.

During the import process MAPublisher will automatically generate extra attribute columns that relate to the 
feature type of the current Illustrator layer.  For files that contain closed areas,  MAPublisher will generate two extra 
columns on the ‘_area’ layer,  named ‘MPArea’ and ‘MPPerimeter’.  For files that contain line elements,  MAPublisher 
will generate a single extra column named ‘MPLength’.  These extra attribute columns will hold precise values for 
the elements in the units of the imported file and are displayed in the MAP Attribute window.

MAPublisher is able to use map attribute data to search for and select items,  create and place labels,  and create 
map legends based upon attribute values or value ranges.  The software also provides tools and dialogs for 
accessing,  viewing,  editing and adding to map attribute tables.

Important note regarding ‘MPArea’ values:  Certain polygons may be displayed as negative areas in the ‘MPArea’ 
column of the MAP Attribute window.  Data that was originally digitized counterclockwise will contain negative 
values.  If you are exporting areas to GIS formats you must check for negative values in this column prior to export.  
The MAPublisher ‘Flip Selected Lines’  filter can be used to convert negative values into positive values.  Please refer to 
the Export section (page 54) for further details.

MAP LAYERS

Throughout this guide,  an Illustrator Layer containing georeferencing and/or attribute Information will be referred 
to as a MAP Layer.

Attributes and Georeferencing: Foreword
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MAP Location Tool
Main Toolbar > MAP Location Tool    or

Window > MAPublisher Statistics > Location

WX/WY - The X & Y coordinates 
of the cursor in Map Units.

Scale 1: - Scale of 
the current layer.

Map X/Y - Map Anchors.

Units - Units of the 
Projection,  if specified.

FUNCTIONALITY

The MAPublisher Location Tool displays the coordinates of the mouse cursor in the Map Units of the currently 
selected Illustrator layer.  When no map units are present (i.e.  the layer has no georeferencing information) the 
window will display the coordinates in Page Units.  The window will also display the Map and Page Anchors,  the 
Scale,  Angle of rotation,  and the Projection and Units of the MAP Layer.

The MAP Location Tool also enables the X and Y position of  the cursor in Map Units to be copied to the clipboard.  
An example of a use of this function is that it enables you to build point files in an external text editor;  files which 
can then be re-imported with MAPublisher.  Coordinates are copied with the X value first and Y value second,  and 
are delimited by a comma.  For example:   -79.396527,43.631979

USING THE MAP LOCATION TOOL

To use the MAP Location Tool,  click on the    icon in Illustrator’s Main Toolbar.  With the cursor scroll around 
your map document,  and note how the Map Units update with the location of the mouse.  If you wish to stop the 
location values from updating in the MAP Location window as you move the mouse hold down the Apple key 
(Mac) or Ctrl key (Windows).

To copy the coordinates of a specific location,  ensure you have the appropriate layer selected in the Illustrator 
Layers palette,  and then with the location cursor determine the exact position you wish to copy.  Then hold down 
the Shift key and click on the document.  The X and Y position in Map Units will be copied to the clipboard.  You can 
now paste the values into any text editor.  Note that you can only copy one set of coordinates.  When you shift-click 
again,  the values copied previously will be overwritten.

MAP LOCATION TOOL TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
4-i ...  Determining the Coordinates of a Specific Location

Angle - Angle of Rotation. 

Page X/Y - Page Anchors.

Projection - Projection of 
the layer,  if specified.

Attributes and Georeferencing: MAP Location Tool

Copy Notification - When the location cursor is 
active you will see this text,  enabling you to copy 
the current X & Y coordinates of the mouse cursor.

Displays the parameters of the currently selected Layer.
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MAP Attributes / MAP Columns
Window > MAPublisher Tables > MAP Attributes
Window > MAPublisher Tables > MAP Columns

Column List - List of columns that 
comprise the attribute table on the 

current selected layer.

Layer Selection - The name of 
the currently selected MAP Layer.

MAP Attributes - This is 
the area in which the MAP 

Attributes are displayed.

Layer Selection - If data 
is selected on a number of 

layers,  select the map layer 
containing the attributes you 

wish to view with this list.

MAP Attributes window

MAP Columns window

Name - Specify or Edit the 
name of the column here.

Width - Specify or Edit a width 
in characters for the column.

New/Edit Column

Attributes and Georeferencing: MAP Attributes and MAP Columns

New Column - Click this 
button to begin adding 

a new column.

Delete Columns - Click 
this button to delete the 
currently selected column(s).

New Column - Select this option to 
begin adding a new column.

Delete Columns - Select this option to 
delete the currently selected column(s).

Edit Column - Select this option to edit 
a selected column.

Type - Specify the type of column* 
(Character,  Integer,  Real,  Boolean) 
to create (* Can only specify when 
creating a new column).

This dialog will open when clicking 
‘New Column’ or ‘Edit Column’.

Click and drag to 
resize the columns.

Apply - If you have made 
any changes to the 
attribute table,  you must 
click here to apply them,  
otherwise any changes 
you made will be discarded 
when the window is closed.
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MAP ATTRIBUTES & MAP COLUMNS FUNCTIONALITY

The MAP Attributes window lets you display the attribute records for your map layer or for selected parts of it,  
which are linked to the map’s graphic elements.  Only the attributes of selected map features on a single layer will 
be displayed in the window at a given time.   The MAP Columns window allows you to view,  edit,  create and delete 
map attribute columns on the currently selected layer.  Any changes made will instantly update the MAP Attributes 
window.  

USING THE MAP ATTRIBUTES WINDOW

If features are selected on multiple layers,  you can toggle between these layers by choosing from the Layer 
dropdown.   The attribute values displayed in the MAP Attributes window may be sorted according to column value 
by double-clicking on the column heading,  and the widths of the columns may be changed by clicking on the 
column separator and dragging it as desired.

MAPublisher’s MAP Attributes window is a fully editable spreadsheet environment.  All attribute values,  except  
those created by MAPublisher (MPArea,  MPPerimeter,  MPLength) can be edited.  To change the value of a cell 
double-click on the cell and enter the new value such as you would in a spreadsheet program.  Keep in mind that 
you must enter values that correspond with a column’s type (i.e.  only enter numbers into a column of type “Real” 
or “Integer”).  After making the changes click the Apply button to set the edits permanently into the map file’s 
database record.  Closing the window without clicking Apply will discard any changes you have made.  
Note:  Mac users only - After making edits to cell values within the MAP Attributes window you should click in an alternate 
cell in the MAP Attributes window before clicking the Apply button,  otherwise the edits may not be recorded.

USING THE MAP COLUMNS WINDOW

Imported files containing attributes will have up to four types of attribute columns,  and these principals must be 
considered if you add columns to an attribute table using the New Column function: 

Character columns can contain attributes that are both alpha and numeric.  
Integer columns contain only whole numbers.  
Real columns contain numbers carrying decimal values.  
Boolean columns contain purely True or False values.  

In terms of using MAPublisher to calculate values of new columns based on existing columns,  or to use ranges of 
values in creating legends,  only Real and Integer columns can be used for these purposes.  Note that if you decide 
to edit the properties of a column via the Edit Column palette option,  you will be unable to change the column 
type.

MAP ATTRIBUTES & MAP COLUMNS TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
4-ii ...  Viewing and Editing MAP Attributes
4-iii ...  Adding a New Column to a MAP Attribute Table
4-iv ...  Changing a MAP Column’s Properties

Attributes and Georeferencing: MAP Attributes and MAP Columns
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Select by Attribute
Filter > MAP Attributes > Select by Attribute

Column - Select the 
column on which you 

wish to base your query. 

Build Expression 
- Displays the current 

expression.  This will 
update if you change the 
expression’s parameters.

Final Expression - After 
clicking Insert,  the Build 

Expression is moved here.  
This is the final expression 

that will be assigned to 
the selected elements 

when you click OK.

Display number selected
 - When this option is 
enabled,  the SelStats 

window will be opened 
after the query is made.

a value from the list or 
enter one manually in the 
textbox.

Value B - These are only 
made available if the 
selected comparison is a 
“Between” type in which 
case the second value will 
be entered here.

Insert - Moves the build 
expression into the 
Expression box.

Boolean Operators - You 
can use brackets,  AND,  
OR and NOT operators to 
create a more complex 
expression involving 
multiple inserts of build 
expressions.

Clear Expression - Clears 
the expression box allowing 
you to insert a new 
expression.

Selection Type - There are 4 types of selections you can make - Initial 
(used when nothing is currently selected),  Add to (used when you need 
to add to the current selection),  Remove from (used when you need to 
remove features from the current selection),  and Select from (where 
you limit the features being searched to those already selected).

MAP Layer - Displays 
the current map layer.

Comparison - A list of operators to 
help you build your expression - i.e.  
Equal to,  Greater than,  etc.

Value A - There are two parts to this parameter - a 
textbox and a dropdown list containing all unique 
values from the selected column.  You can select

Ignore case in strings
 - If this is checked,  any 

expression that compares 
string (non-numeric) values 

will be case insensitive.

FUNCTIONALITY

The MAPublisher Select by Attribute filter allows you to select map features based upon their attribute information.  
A particular column is selected and then a logical expression is built defining the desired features for selection.  For 
example,  “Select all roads that have 2 lanes and are more than 5 kilometres long” is a kind of query you could make 
depending on the attribute data associated with your map layer.

USING SELECT BY ATTRIBUTE

To use Select by Attribute you must first click on the MAP Layer in the Illustrator Layers palette,  which will 
determine the attribute table and feature type to be used for the operation.  

In the Select by Attribute dialog you must select a Column of the attribute table,  a Comparison,  and a choice of 
Values,  in order to build an Expression.  Values can either be entered manually or by choosing from the dropdowns.  

When the expression has been built you must click the Insert button.  The Boolean Operator Buttons can be used 
if you wish to use multiple columns or values in order to generate an expression.  If you make a mistake at any time,  
click the Clear Expression button.
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This filter has 4 selection options:
Initial selection is used when there is no current selection.  
Add to selection will add the results of the query to any currently selected features.  
Remove from selection will remove the results of the query from the current selection.
Select from selection will only query those features that have already been selected.

Select by Attribute also has an option to Ignore case in strings.  If this option is checked,  any expression that 
compares non-numeric values will not differentiate between characters in upper and lower case.  

If you wish to open the SelStats window (see page 86) as part of the selection process in order to view the number 
of elements selected,  tick the Display number selected checkbox 

When the OK button is clicked,  MAPublisher will select data based on the expression you have built.

SELECT BY ATTRIBUTE TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
4-vi ...  Making a Selection with Select by Attribute 
4-vii ...  Using Select by Attribute to Add to an Existing Selection
4-viii ...  Using Select by Attribute for Advanced Selections
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Edit Column
Filter > MAP Attributes > Edit Column

MAP Layer - Select the 
map layer containing the 
columns you wish to edit.

Expression Column - Using 
the list box you can add the 
values of one or more map 

columns into the Expression.

Result Type - Select the 
‘Attributes’  option to 

calculate new values for 
existing attribute columns.  

Calculator Buttons - You 
must use the calculator 
buttons to build your 
mathematical expression.

Clear Expression - Allows 
you to clear the entire 
expression and start over if 
you have made a mistake.

The Edit Column filter has two functionalities,  based on the choice made in the  ‘Result Type’  section of the dialog.

Editing Attributes:  The filter provides for the editing of attributes for multiple features in a single step and for the 
creation of attribute values for a column based upon values in other columns.  

Editing Properties:  Edit Column also provides for the editing of the rotation or scale of elements,  based on the 
values found in an associated attribute column,  providing a one-step process to possibly transform different 
objects by many hundreds of unique rotation or scale values. 

Editing Attributes

Result Column - Using the list box 
select the column where the results 
of the expression will be placed.

Edit Expression - This is where the expression you have built for the 
selected result column is displayed.  Do not type into this field; use only the 
Calculator Buttons and Expression Column list box to build the expression.

‘EDIT ATTRIBUTES’ FUNCTIONALITY

The Edit Column filter can be used to populate a new column with values based upon calculations using existing 
columns.  Editing attribute data using Edit Column is achieved by building an expression which accesses and 
manipulates values from other columns.  The attributes of    Area,   Line,   Point, or   Text layers can be 
edited with this filter,  though only numeric columns can be used.

‘EDIT ATTRIBUTES’ PREREQUISITES

To use this filter for the editing of attributes,  a new column must be created before running the Edit Column filter 
via the MAP Columns window.  Only selected objects in the Illustrator document will have these calculations 
applied.  Access the dialog by navigating to Filter > MAP Attributes > Edit Column. 

You must first specify the Layer on which you need to calculate your new values.  Then select the Attributes option 
in the  ‘Result Type’ section to use Edit Column for the calculation of new attributes.
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USING EDIT COLUMN FOR EDITING ATTRIBUTES

This filter works like a scientific calculator.  A Result Column must be set,  which is normally the column you have 
just created to hold your results.  Finally,  the Expression Column dropdown and the Calculator Buttons are used to 
create the expression.  Only the listboxes and calculator buttons in the Edit Column dialog should be used to build 
expressions,  and not your keyboard.  The Expression dropdown can be accessed more than once if you wish to use 
multiple columns to generate an expression.  The expression you build will be displayed in the Edit Expression field.  
You can clear this at any stage by clicking the Clear Expression button.

When you have finalized your expression click the OK button.  The new values will be displayed for the selected 
objects in the MAP Attributes window.

‘EDIT ATTRIBUTES’ TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
4-v ...  Editing the Values of a MAP Column

‘EDIT PROPERTIES’ FUNCTIONALITY

Edit Column also provides for the assignment of a rotation or scale to elements,  based on the values found in an 
associated attribute column.  For example geological point files may contain such columns as  ‘Dip Direction’,  
‘Inclination’  etc.  The values contained in these columns can be used to rotate or scale elements on such layers,  
providing a one-step process to possibly transform objects by many hundreds of unique rotation or scale values.  
Text objects can be rotated using this filter,  and Point Symbols can be rotated or scaled.  Therefore only   Point or  

 Text layers can be edited with this option,  and only numeric columns can be used to assign transformations.

MAP Layer - Select the point 
or text layer containing the 

elements you wish to modify.

Expression Column - Using 
the list box you can add the 
values of one or more map 

columns into the Expression.

Result Type - Select the 
‘Properties’  option to 

change the scale or rotation 
of selected items.  

Calculator Buttons - You 
must use the calculator 
buttons to build your 
mathematical expression.

Clear Expression - Allows 
you to clear the entire 
expression and start over if 
you have made a mistake.

Editing Properties

Result Property - Choose ‘Scale’  or  
‘Rotation’.  Note only  ‘Rotation’  can 
be specified for text items.

Edit Expression - This is where the expression you have built for the 
selected result column is displayed.  Do not type into this field;  use only the 
Calculator Buttons and Expression Column list box to build the expression.

Attributes and Georeferencing:  Edit Column
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‘EDIT PROPERTIES’ PREREQUISITES

The Edit Column filter assigns rotations or scales to objects based upon calculations using existing columns.  
There must be at least one column which contains suitable values in the layer on which you wish to perform the 
transformations.  Only selected objects in the Illustrator document will have these calculations applied.

Note that scaling can not be applied to points that already exist in a MAP Stylesheet.  You must first remove the 
Point Layer from the Point Stylesheet.

Access the dialog by navigating to Filter > MAP Attributes > Edit Column. 

You must first specify the Point or Text  Layer on which you need to calculate your new rotation or scale values.  
Then select the Properties option in the  ‘Result Type’  section to use Edit Column for the calculation of new 
properties.

USING EDIT COLUMN FOR EDITING PROPERTIES

This filter works like a scientific calculator.  You must first specify the Layer on which you need to apply your new 
properties.  The  ‘Properties’  option will only be enabled when a   Point or   Text layer is selected.

A  Result Property  must be set,  which is  ‘Rotation’ or  ‘Scale’  for Points,  or  ‘Rotation’ only for text items.  The 
Expression Column dropdown should be used to choose the column which contains your rotation or scale values.  
If you need to apply further numeric values to your expression,  the Calculator Buttons can be used to add to the 
expression.  Only the listboxes and calculator buttons in the Edit Column dialog should be used to build expressions,  
and not your keyboard.  The Expression dropdown can be accessed more than once if you wish to use multiple 
columns to generate an expression.  The expression you build will be displayed in the Edit Expression field.  You can 
clear this at any stage by clicking the Clear Expression button.

When you have finalized your expression click the OK button.  The new rotation or scale values will be applied to the 
selected objects.  Note that scales will not be applied to points that already exist in a MAP Stylesheet.  

The transformations that are applied are absolute values.  The filter will only apply scales or rotations to objects 
based on their original orientation,  and will not add to established scales or rotations.

Attributes and Georeferencing:  Edit Column
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The MAP Views dialog is the hub from which you can 
access many additional MAPublisher features.  The palette 
itself will display the Illustrator layers that exist in the 
current document as sub layers of distinct coordinate 
systems,  or ‘MAP Views’.  From this palette you can specify 
projections for Illustrator layers,  reproject data,  edit 
scales and data placement,  merge layers,  and export to 
GIS formats.

During a standard Import process,  an Illustrator layer will 
be created for each feature type automatically,  and will 
be automatically appended with a _point,  _line,  _area,  
or _text suffix in the Illustrator layers palette.  Certain file 
types will generate multiple layers,  such as the levels 
found in DGN or DXF,  but they will be similarly split up by 
feature type.  A single import will furthermore produce a 
single MAPublisher View,  as an import can only occur in 
a single projection.  You may also create your own MAP 
Views in order to georeference existing Illustrator artwork.

The following pages will deal with the creation and 
management of MAP Views,  specifying and changing 
a projection,  editing scales and data placement on the 
page,  merging Illustrator layers,  and exporting to GIS 
formats,  via the use of the following tools:
MAP Views palette
Search & Replace
Merge Layers
Source Projection
MAP View Editor
Export

Chapter 5

MAP Views
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MAP Views palette
Window> MAPublisher Palettes > MAP Views

MAP Views [M] - List of the  
unique coordinate systems 

in the document.

Undefined Layer dialog

MAP View Options ...

New MAP View - Allows you to create a New MAP View 
and specify its name and coordinate information.

Duplicate MAP View - Will create a Duplicate of the 
currently selected MAP View.

Edit MAP View - Allows you to edit the name and 
coordinate system of the currently selected MAP View.

Delete MAP View - Allows you to delete the currently 
selected MAP View provided it does not contain any 
Illustrator layers.

Specify Anchors - For manually establishing the ‘tie-in’ 
point between Map and Page Anchors (should only 
be used for new  MAP Views or for the correction of 
georeferencing errors).

Source Projection - Allows you to specify the coordinate 
system of the currently selected MAP View.

MAP Layer Options ...

Export Layer - Enables the export of the selected 
MAP Layer to various GIS formats.

Merge Layers - Allows the combining of two or more 
MAP Layers,  as long as their attribute structures match.  
Ctrl select the layers in the MAP Views palette.

Layer Name Search & Replace - To search for text 
within layer names and specify an alternative.  
Useful for multi-layer imports.

MAP Layers  [A] [L] [P] [T] [O]
 - An alphabetical list of the layers 

that comprise each MAP View,  
symbolised by feature type.

Non-map layers [/] - Lists 
the Illustrator Layers that are 

not part of a specified MAP 
View,  and do not contain 

georeferencing information.

This dialog will automatically open when dragging 
a ‘Non-map layer’ into a specified MAP View.

Apply to all - If you are 
dragging a number of layers 
of the same feature type to 
a specified MAP View,  you 
should check this box.

New MAP View button - 
Allows you to create a New 

MAP View and specify its name 
and coordinate information.

Delete MAP View button - 
Allows you to delete the currently 
selected MAP View provided it does 
not contain any Illustrator layers.

MAP Views: MAP Views palette

Lock button - Click this 
button to lock or unlock 

the Layer (mirrored in the 
Illustrator Layers palette).

Missing Projection dialog
This dialog will automatically open when dragging a MAP Layer to an alternate MAP View,  

and either the source or destination MAP View has an unspecified coordinate system.

Related Tools

Feature type - Select the 
type of feature that exists

 on the layer being dragged.  
This dropdown presents a 

choice of Area,  Line,  Point,  
Text,  or Legend layer types.

Specify custom 
projection - 
Check this 
option and then 
click the Select 
button to specify 
the coordinate 
system of the 
named MAP View 
via the Source 
Projection dialog 
(page 50).  Once 
selected,  the 
Projection will be 
displayed below.

Same as -  Check this option in order to assign a projection to the 
named MAP View that matches that of an existing MAP View.  The 
projection of the selected MAP View will be displayed below.
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OVERVIEW

The MAP Views palette is a new function in MAPublisher 6.  In the list box will be entries for each defined coordinate 
system in the current document.  All Illustrator layers will be shown in this palette as belonging to a certain 
MAP View,  and at least one ‘MAP View’ will be created with each import.  For Illustrator layers that do not have 
georeferencing information,  these will be placed in the default MAP View entitled  “Non-map layers”.

Each Illustrator layer that belongs to a MAP View will be symbolized with an icon depicting its feature type:

MAP View containing georeferencing information

Default category,  which does not contain georeferencing information.  
This category is known as [Non-map layers].

Area layer (e.g.  county boundaries,  urban areas,  country outlines etc.)

MAP Views are symbolized in the following manner:

Point layer (e.g.  town and city symbols,  railway stations etc) 

Line layer (e.g.  rivers,  roads,  railways)

Text layer (e.g.  text labels)

Legend layer (for MAPublisher Legend items:  North Arrows,  Scale Bars,  Grids,  and for 
  the hosting of legend information for the MAPublisher Legend filters)

MAP Views: MAP Views palette

FUNCTIONALITY

MAP Views are designed to provide an easy method of accessing dialogs for the specifying and changing of 
projections,  for editing scales and data placement on the page,  and for exporting to GIS formats.  Within the MAP 
Views palette itself you are just a few clicks away from merging Illustrator layers,  georeferencing existing Illustrator 
artwork,  changing layer names in bulk,  and reprojecting data on the fly.

Layer Name Search & Replace

Specify Anchors
This dialog should only be accessed if you are creating a new MAP 

View,  or you are correcting inaccurate georeferencing information. 
Caution: editing anchors can damage the accuracy of your data.

Map Anchors  - 
The location of 

the Map Anchors 
in the units of the 

current projection.  
Page Anchors - 
The location of 
the Page Anchors 
in the units of the 
current document.

Find what  - Type in the 
variable contained in the 
current layer names on 
which you wish to search.

Replace with  - Type in the 
variable you wish to change 

the  layer names to.
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USING THE MAP VIEWS PALETTE

REPROJECTING MAP LAYERS BY ‘DRAG AND DROP’

Using the MAP View Editor will be discussed in detail later in this section.  By using the MAP Views palette you can 
drag Illustrator layers from one MAP View to another,  enabling you to reproject vector art* quickly.  For instance two 
imports may produce two very different coordinate systems.  In this case you can reproject without having to access 
a dialog,  by simply dragging an Illustrator layer from one MAP View to another in the MAP Views palette.   *Note 
that raster imagery can not be reprojected with MAPublisher.

For example if you have two imported data layers,  one in UTM Projection,  and the other in Latitude/Longitude,  
MAPublisher will produce two distinct MAP Views,  each holding the associated MAP Layer.  If you wish to reproject 
the layer which is in UTM into Lat/Long,  simply drag it from the UTM MAP View and drop it into the Lat/Long MAP 
View.  MAPublisher will automatically reproject the layer to match the destination MAP View.
If you are reprojecting in this manner,  and either the origin or destination MAP View does not contain a coordinate 
system,  you will be presented with the Missing Projection dialog after you drag and drop.  In essence both MAP 
Views must contain a coordinate system.  Therefore this window will allow you to specify one of the following:
1. ‘Specify custom projection’ allows you to specify the projection of the named MAP View,  via the Source   
 Projection function (see page 48)
2. ‘Same as’  allows you to specify the projection of the named MAP View by choosing a coordinate system which  
 already exists in a MAP View in your document.

Important note:  Many transformations will inherently cause the loss of precision by the very nature of the complex 
mathematical calculations that must be performed.  Additionally there are differences in precision between 
MAPublisher and Illustrator.  MAPublisher’s calculations are in 64 bit for accuracy,  but the results still must be stored 
as 32 bit for Illustrator.  As a result,  please be aware that you may lose precision if you drag repeatedly from one 
coordinate system to another.  When determining a coordinate system to use via the drag method,  we strongly 
recommend you use Edit > Undo to revert coordinate systems until you find the appropriate system for your data.  

LAYER NAME SEARCH & REPLACE

The MAP Views Options list also provides a Search and Replace function,  enabling the quick change of names of 
multiple Illustrator layers.  For example e00,  dgn or AutoCAD imports may contain a large number of similar named 
layers.  This option will allow you to quickly change the names of all layers that contain a specified variable. 

MERGE LAYERS

This palette also provides a fast way of merging Illustrator layers.  If you have more than one layer in a MAP View 
that contains the same attribute structure and data type,  this option will allow you to merge them into a single 
layer.  For example your data may have been received in segments,  and you therefore find it occupying multiple 
layers in Illustrator.  Simply ctrl-select these layers in the MAP Views palette and click the option for Merge Layers.  
The layers will then be merged to provide a single layer holding your data and its associated attributes.

ASSIGNING GEOREFERENCING INFORMATION TO ILLUSTRATOR LAYERS

Illustrator layers that do not contain georeferencing or attribute information will also appear in this palette,  under 
the default MAP View entitled Non-map layers.  Therefore these layers can be quickly moved into a specified MAP 
View with a matching coordinate system.  When moving a ‘non-map layer’ into a specified MAP View you will be 
prompted to specify the feature type of the layer you are moving in the Undefined Layer dialog.  This functionality 
allows you,  for example,  to manually trace features on a non-map layer and quickly assign georeferencing 

MAP Views: MAP Views palette
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information to the layer by dragging it to an existing MAP View.  You can also select multiple layers and drag them 
to a specified map view by using the ‘Apply to all’  function in the Undefined Layer dialog.

CREATING NEW LAYERS TO HOLD ADDITIONAL FEATURES

In order to plot points,  generate text,  use legends,  or plot grids,  scalebars and north arrows,  you will first be 
required to create extra Illustrator layers to hold this information.  This is due to the fact that layers cannot contain 
more than one feature type.  Therefore prior to generating these additional map features,  you need to first create 
a layer in the Illustrator layers palette on which these features will be held.  Subsequently in the MAP Views palette 
you should drag these layers into the MAP View which contains the coordinate system you require to plot the extra 
features.  The Feature Type you should specify for these features in the Undefined Layer dialog are as follows: 

  for Text items.  Feature Text Label & MAP Tagger (pages 71-76) require you have a Text Layer for output.  

  for Point symbols.  Point Plot  (page 58) will not function without a Point Layer selected.

  for Legend items.  Assign Legend Info and Auto Assign Legend Info require that you place   
 Legend criteria onto a Legend Layer.  Grid Generator (page 78),  Scale Bar (page 98) and North Arrow (page  
 100) require you have a Legend Layer selected before opening these tools.

DUPLICATING AND DELETING MAP VIEWS

MAP Views can be duplicated if you wish to make placement or projection edits to certain Illustrator layers,  while 
leaving the others alone.  This way you could drag the Illustrator layers you wish to edit into the Duplicate MAP 
View.  Additionally MAP Views that do not contain any Illustrator layers can be deleted.  Both of these tools can be 
accessed in the Options section of the MAP Views dialog.  You can also delete a MAP View by clicking the Delete 
button at the base of the palette.  Note that these functions act on MAP View parameters only,  and not MAP Layers.

CREATING NEW MAP VIEWS

You are able to create new MAP Views by selecting New MAP View under the Options arrow.,  or by clicking the New 
button at the base of the palette.  This will automatically open the MAP View Editor,  which will be discussed in the 
MAP View Editor section (page 51),  allowing you to set up a coordinate system,  and enter values for scale,  rotation,  
and page anchors.  After you have created a new MAP View,  you must use the Specify Anchors option from the 
MAP Views palette to define the tie-in point between Map Anchors and Page Anchors (see page 36).  Note that 
you must enter Map Anchor values that are indicative of the unit of measurement used in the chosen coordinate 
system,  which may mean these values are not in degrees or Lat/Longs.  

REMOVING MAPUBLISHER INFORMATION

At the end of the project cycle it may be useful to permanently remove all georeferencing and attribute information 
in the current document.  This can now be accomplished by simply dragging your MAP Layer(s) to the [Non-map 
layers] category in the MAP Views palette.  Note that this function must only be used as a final step.

MAP VIEWS PALETTE TUTORIALS

Please refer to the exercises 5-i to 5-vii  in the Tutorials PDF for the following topics:
“The Creation of MAP Views via Import”,  “Duplicating and Deleting MAP Views”,  “Reprojecting by Dragging MAP Layers 
into Alternate MAP Views”,  “Dragging a New Illustrator Layer into Similar Coordinate Systems”,  “Dragging New Illustrator 
Layers into Different Coordinate Systems”,  “Editing Layer Names Using Search and Replace”,  and  “Merging MAP Layers”.

MAP Views: MAP Views palette
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Source Projection
MAP Views > Options > Source Projection,  and

MAP View Editor > Source Projection

Projection Category
 - Choose an area of the 

world from this dropdown 
appropriate to the data to 

be imported.  For a list of 
the last 20 projections used,  

select  ‘Recently Used’.

Same as - Check this option 
in order to set a projection 

that matches that of an 
existing MAP View.

Search Projection  - Click this 
button to open the Search 
Projection dialog (Page 51),  
enabling you to search for 
projections by specifying a text 
string.  Results of the search are 
displayed in the ‘Search Results’ 
category.

Projection List - Choose the 
known projection from this list.

Details - View the parameters 
of a selected projection.

Resize - Drag the lower right 
corner of the palette down to 
expand the Projection List.

FUNCTIONALITY

There are three possible scenarios in which you would need to use this function: 
1.  If you imported a file even though the program returned a message of <not detected> for the Coordinate  
  System during the import process.  
2.  If you had incorrectly specified the coordinate system during the Import process,  and wish to remedy this.
3.  If you have created a new MAP View and wish to assign a projection to it.

If you wish to maximize the functionality of MAPublisher,  it is important that all of your MAP Views contain accurate 
projection information.  For example,  if you need to subsequently reproject your data,  this will be impossible 
without first specifying an Input projection.  If you do not know the projection of your data you must consult your 
data provider to obtain this information.

USING SOURCE PROJECTION

To specify a projection you must first select the appropriate MAP View in the MAP Views palette,  and then select 
Source Projection located under the Options arrow in the upper right corner of the palette.

Projections are separated into Projection Category to ease the process of choosing a projection.  All Projections will 
list all of the projections in the database.  If you cannot find the projection you require,  you can conduct a keyword 
search via the Search Projection function by clicking the    icon  (see page 53).  If you wish to view the parameters 
of a certain projection,  you can click the Details button to view them.  For an overview of Projections and Datums 
see pages A1/27 to A1/31.

The Source Projection dialog also offers a checkbox to enable you to select a projection that already exists in the 
document.  The Same as dropdown will allow you to select from a list of existing georeferenced MAP Views.  

SOURCE PROJECTION TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
4-viii ...  Specifying a Projection for an Imported File

MAP Views: Source Projection
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FUNCTIONALITY

The MAP View Editor can be accessed as part of the Advanced Import 
process (page 31) or from the MAP Views palette (page 46).  

To access via the Advanced Import process,  click the Create new radio 
button in the Destination Coordinate System section,  and then click the 
Editor button to open the dialog.  

From the MAP Views palette select the MAP View you wish to edit,  and then select Edit under the Options arrow in 
the upper right corner of the palette.  Conversely you can double click the MAP View to open the MAP View Editor.

The function has a variety of purposes.  It will allow you to reproject data,  transform scales,  edit data positioning in 
the document,  change rotation values,  and rename MAP Views.  Any or all of these functions can be achieved with 
a single visit to the MAP View Editor.  There is also a preview pane where you can see how the edits made to data 
will affect its extents in the document.  

MAP View Editor
MAP Views > Options > Edit,  

MAP Views > Options > New MAP View,  and
Advanced Import > Create New > Editor

Preview Pane - Displays the 
data extents of the MAP View:

White rectangle - page extents.

Arrow - current orientation 
of the MAP View.

Green rectangle - data extents.

Blue crosshair - location of the 
current Map & Page Anchors.

Name - The editable name 
of the current MAP View. 

LL Corner - The location of 
the lower left corner of the 

data in the units of the current 
document,  which are editable.

Alignment Control - Click on 
the respective anchor point 
to set the Page Anchors to a 

graphically designated location.

Same as - Check this option 
in order to set a projection 

that matches that of an 
existing MAP View.

View Anchors - Click this button to 
view or hide the Map Anchors and 
Page Anchors in the Preview Pane.

Source Projection - If your MAP 
View does not currently contain 
a projection,  click here to assign 
one. This will open the Source 
Projection dialog (see page 50).

Scale - The scale of the MAP View.  
Edit the scale manually or by 
using the Up and Down arrows to 
increase or decrease scale by one 
whole number. Click the ‘Auto Scale’ 
button to rescale the data to fit the 
page extents.

Angle - The rotation of the MAP 
View.  Edit the angle manually or 
by using the ‘clock hand’ in the 
rotation control graphic.

Projection Category - To edit a 
projection choose an area of the 
world from this dropdown 
appropriate to the current MAP 
View.  For a list of the last 20 
projections used in the product,  
select ‘Recently Used’.

Details - Click this button for the 
parameters of a selected projection.

MAP Views: MAP View Editor

Projection List - A list of the projections 
available for selection,  based on the 

choice of Projection Category.  The current 
projection is selected automatically.

Search Projection  - Click this 
button to open the Search 
Projection dialog (right),  
enabling you to search for 
projections by specifying a text 
string.  Results of the search are 
displayed in the ‘Search Results’ 
category.

Where - Select the 
properties on which to 
perform the search (‘All’,  
‘Datums’,  ‘Ellipsoids’,  
‘Projection names/types’,  
or ‘Units’).

Find what  - Type in the 
text on which to search.

Search Projection  
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USING THE MAP VIEW EDITOR

PREVIEW PANE

The Preview Pane symbolizes the data extents by a green rectangle,  and the orientation with an arrow.  You can 
click on this rectangle to move the data to a more suitable position in the document if you desire.  

MAP VIEW NAME

When you open the dialog you will see the current name of the MAP View in the Name field,  which you can edit if 
desired.  Whether the MAP View Editor is accessed via Advanced Import,  or from the MAP Views palette,  editing the 
name here will change the name of the resultant or existing MAP View.

PAGE ANCHORS

Current Page Anchors are displayed in the LL (Lower Left) Corner X/Y fields,  in the current document units.  As 
discussed in the section on Georeferencing on page 36,  the default Page Anchors are 0,0 in document units.  
Editing the Page Anchor values will move the data relative to the lower left location of the data.  Entering negative 
values will move the data to the left or down,  entering positive values will move the data to the right or up.  
There are also two graphical ways to edit Page Anchors.  Firstly the data can be ‘glued’ to respective positions in 
the document by clicking on a respective Alignment Control button,  of which there are nine positional options.  
Conversely dragging the green data preview rectangle around the page in the Preview Pane will update the Page 
Anchor values accordingly.  Note that editing Page Anchors will not affect data integrity.  It simply means that the 
lower left corner of the data in coordinate units (Map Anchors) is located at this new document position.

SCALE

The Scale of the current MAP View (or files to be imported) is shown in the Scale field.  Generally,  MAP Views 
carrying projected data (i.e.  not in Lat/Long format) will carry real world scales.  This field is editable allowing you 
to quickly specify an alternate scale.  Furthermore the up and down buttons will allow you to fine tune scales by 
increasing or decreasing a scale by a single whole number.  The Auto Scale button will allow you to quickly fit the 
data to the page extents if this is required.  Clicking this button will edit the scale and page anchors so that it is 
located in the centre of document.

REPROJECTING

The MAP View Editor provides a fast and intuitive reprojection utility.  Projections are separated into Projection 
categories,  applicable to specific projection types or areas of the world,  to ease the process of choosing a 
projection.  The Projection list will show the projections that belong to the specified Projection Category.  All 
Projections will list all of the projections in the database and if you choose this category,  it may take some time to 
choose the one relevant to your MAP View.  If you wish to view the parameters of a certain projection,  you can click 
the Details button to view them.  For an overview of Projections and Datums see pages A1/27 to A1/35.  

The dialog also offers a checkbox to enable you to select a projection that already exists in the document.  The 
Same as dropdown will allow you to select from a list of existing georeferenced MAP Views.  This function is useful 
when a series of MAP Views exist of different areas,  but even though they have different coordinate systems (i.e.  
position on the page),  you require them all to be in the same projection.  Again the Preview Pane will display the 
new data extents for any new projections specified in the MAP View Editor.

MAP Views: MAP View Editor
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To match projections and coordinate systems across a number of MAP Views,  simply drag the Illustrator layers into 
the MAP View containing the coordinate system you require,  as discussed in the MAP Views palette section.

ASSIGNING A PROJECTION

If you wish to set the current projection of the data,  rather than change projection,  you can click the Source 
Projection button.  You must use caution,  as this option will set source projections only,  and not serve to reproject 
your data.  Therefore data integrity may be lost if you overwrite the current projection of the MAP View via the use 
of this utility.  Please see page 50 for a description of this function.

SEARCHING FOR A PROJECTION

The Search Projection tool,  which is available in all occurrences of the Source Projection and MAP View Editor 
dialogs,  allows you to search for projections based on an entered text string.  Searches can be performed on the 
whole database,  or solely in Datums,  Ellipsoids,  Projection Names,  Projection Types,  or Units.  To access the Search 
Projection dialog,  click the    icon in the MAP View Editor or in Source Projection.

In the ‘Find what’ field enter the text on which to search.  For example to find coordinate systems with ‘NAD83’ 
properties,  enter ‘NAD83’ .  From the ‘Where’ dropdown,  select an area of the database in which to search.  For 
example to find ‘NAD83’ in the name only,  select ‘Projection names’.

When you have entered the search criteria click the ‘OK’ button.  If the search has returned results,  these results 
will be displayed in the MAP View Editor or Source Projection in the ‘Search Results’ category,  and can be immediately 
selected in order to reproject your data or to assign a projection.  Search results will be stored in this category until 
you restart Illustrator or perform another ‘Search Projection’.

ROTATION

A rotation figure can be applied or edited by specifying an angle in the entry field,  or by using the ‘clock hand’ to 
rotate the MAP View graphically.  Notice that changes to rotation will be automatically previewed in the Preview 
Pane,  with the green rectangle and arrow depicting the new orientation of the data.

NEW MAP VIEWS

Finally the MAP View Editor is opened by default when creating a New MAP View.  This will enable you to quickly 
specify the name,  coordinate system and page scaling for your New MAP View.  This functionality will be discussed 
in detail in How to Georeference an Illustrator file on page A1/38.  After you have created a new MAP View,  you 
must use the Specify Anchors option from the MAP Views palette to define the tie-in point between Map Anchors 
and Page Anchors (see page 36).  Note that you must enter Map Anchor values that are indicative of the unit of 
measurement used in the chosen coordinate system,  which may mean these values are not in degrees or Lat/Longs.    

MAP VIEW EDITOR TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
5-ix ...  Reprojecting using the MAP View Editor
5-x ...  Editing Scale and Positioning
5-xi ...  Copying a Projection from One Layer to Another
5-xii ...  Creating a New MAP View

MAP Views: MAP View Editor
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Export
MAP Views > Options > Export

Format - Select the data type to 
which you wish to export.  This 

dropdown lists the names of all 
MAPublisher supported data types.  

Release Version - Specify the AutoCAD 
version number you wish to export to.

AutoCAD Settings

Keep format extension - Tick this 
option to export the layer with its feature 
extension (_area,  _line,  _point,  or _text) 

which was automatically appended to 
layer names during import.

MAP Views: Export

Settings - Opens a Settings 
dialog for the input of extra 
parameters (see below).

Browse - Opens a Data Source 
browser to enable the selection 
of a directory* for export.

Dataset - Displays the directory path* for the export of the currently 
selected layer.  You can also manually type in the dataset location here.
*Export to AutoCAD or Microstation will require you to specify a 
file name and directory.

General Settings

Microstation Settings

Export Settings

Export MP attributes - Tick this option 
to include the ‘MPArea’,  ‘MPPerimeter’ 
or ‘MPLength’ attribute columns in the 
exported layer’s attribute table.

Seed file parameters - Automatically adjust the origin and scaling of
the layer to provide an optimum set of parameters for a seed file.

Area Fills - Controls whether or not fill linkages will be written out for ellipses,  
shapes,  and solids.

Coordinate Units - Specifies how feature coordinates will be
interpreted and converted (Master,  Sub or Units of Resolution).
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FUNCTIONALITY

MAPublisher supports the export of MAP Layers to various GIS formats,  maintaining all georeferencing and 
attribute information.  The following export formats are supported:
AutoCAD (*.dxf ) (*.dwg)
ESRI ArcInfo Export (*.e00)
ESRI ArcInfo Generate (*.gen)
ESRI Shapefile (*.shp)
MapInfo Interchange (*.mif / *.mid)
MapInfo Table (*.tab)
Microstation (*.dgn)
Please view the descriptions of these Export formats on pages 20 to 22.

PREREQUISITES

The Export function will export any Illustrator layers that are contained in a specified MAP View.  Therefore 
both imported and user created MAP Views will contain MAP Layers that are suitable for export to GIS formats.  
MAPublisher will automatically export layers in the feature type of the selected layer.

When exporting Area layers to GIS formats,  polygon outlines must have a positive ‘MPArea’ value,  whereas holes 
held inside compound paths (or ‘complex shapes’) must have a negative ‘MPArea’ value.  If you have values for 
polygons in the ‘MPArea’ column of your MAP Attribute table which contradict these guidelines,  you can use Flip 
Selected Lines (page 89) to convert the MAPublisher area calculation from a negative to a positive value or vice versa.  
For the correction of simple closed areas,  use Select by Attribute to select all elements that have an ‘MPArea’ of less 
than zero.  Then go to Filter > Flip Selected Lines.

To open the Export dialog,  first select the layer you wish to export in the MAP Views palette.  Note only MAP Layers 
(and not MAP Views) can be exported.  Then click on the Options arrow in the upper right corner of the dialog and 
select Export (layer name).

USING MAP EXPORT

Within the dialog select the Export Format you require,  and then click the Settings button.  

FEATURE TYPE EXTENSION SETTING

The MAP Layer you are exporting will be the default name of the exported file.  However the feature type text (i.e.  
_area,  _line,  _point,  or _text) appended to Illustrator layers by MAPublisher in the Import process,  will be removed 
during the export process,  unless you specify that you wish to keep this.  If you wish to keep the feature type text,  
check the Keep format extension option

MP ATTRIBUTES SETTING

You can also choose to export the MP Attribute columns which form part of the attribute table in MAPublisher.  
These columns are named ‘MPArea’ and ‘MPPerimeter’ for Area layers,  and  ‘MPLength’ for Line layers (see page 36).  
If you wish to add these columns to the exported data table,  check the Export MP attributes option.

MAP Views: Export
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AUTOCAD SETTINGS

For AutoCAD exports click the Settings button to specify the AutoCAD version.

CHOOSING A DESTINATION FOLDER

Most of the export formats will require you to select a destination folder only.  Subsequently for export to ESRI or 
MapInfo formats,  simply click the Browse button to specify a destination folder.  Click the OK button to export your 
MAP Layer.
 
In the case of exporting to AutoCAD format you will be required to specify a name for the exported file,  and 
clarify the file extension (DXF or DWG)  to be used.  For Microstation you will be required to specify a name for the 
exported file.  Therefore if you wish to export to either of these formats,  click the Browse button to name the export 
file,  and then choose the file format from the Format dropdown.  

MAP EXPORT TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
5-xiii ...  Exporting Data to GIS Formats
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Having the ability to place points onto a map is 
a fundamental part of cartography.  Points can 
represent the locations of towns and cities,  shops and 
malls,  airports and train stations to name but a few.  
MAPublisher 6 provides the functionality to create or plot 
points in vector format.  

There may be times when you wish to quickly add a 
point or a small group of points to your map but you 
do not have a GIS or ASCII file containing these points 
ready for import.  Alternatively your map may be in a 
projection that holds coordinates in distance units,  yet 
the coordinates of your point locations are in Latitude 
and Longitude.  

Providing you have a fully specified MAP View,  and know 
the coordinates (in either Decimal Degrees or Degrees,  
Minutes and Seconds) for the locations you wish to plot,  
you can use the MAPublisher Point Plotter to have your 
points automatically added at their correct locations.

Chapter 6

Plotting Points
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Point Plotter
Window > MAPublisher Palettes > MAP Point Plotter

Coordinate Entry Boxes - Enter the 
coordinates of the point to be 

plotted in either Decimal Degrees 
OR Degrees,  Minutes & Seconds.

Scale - Change the size of the chosen 
symbol if required.  The arrow keys 
will increase or decrease the scale 

value by 10% increments.

PREREQUISITES

In order to plot points using the Point Plotter,  you must first have a fully georeferenced MAP View in your 
document,  as this function will use the coordinate system of that MAP View in order to generate points.  
Furthermore you must create a new Illustrator layer in which your points will be placed,  as the software will not 
support multiple feature types on the same layer.  Remember once you have created a Point layer,  you must drag it 
into the desired MAP View,  specifying  Point in the Undefined Layer dialog.

When you have a Point layer created in the correct MAP View,  and a Symbols palette you will find useful for this 
function,  you can open the Point Plotter.  This palette is located under Window > MAPublisher Palettes.

USING POINT PLOT

SETTING UP THE SYMBOL SELECTION

The symbols used by Point Plotter are a direct reproduction of those that exist in the Illustrator Symbols palette.  To 
open the Illustrator symbols palette go to Window > Symbols.  If you wish to add points to this palette,  create your 
symbols as closed Illustrator objects and simply drag them into this palette.  Alternatively open the MAP Symbols 
file in the Utilities folder on your MAPublisher CD,  and drag the symbols into your Illustrator Symbols palette.

ENTERING COORDINATES

Coordinate values can be entered in either Decimal Degrees (DD.dd),  or Degrees,  Minutes and Seconds (DMS.ss).  
These values are entered into the Latitude and Longitude fields.  Lines of Latitude run North-South (the Equator is 
an example),  whereas Lines of Longitude run East-West (the Greenwich Meridian is an example).  Positive Degree 
values are Latitude North and Longitude East.  Negative Degree values are Latitude South and Longitude West.  

Symbol Selection - Choose a symbol to 
use.  The symbols displayed here will be the 
same as in the Illustrator Symbols palette.

Create - Click to plot a point using the 
entered values.

Plotting Points: Point Plotter
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Example Decimal Degree values:

Latitude Values:  12.3456
  -12.3456 

Longitude Values:  12.3456
  -12.3456

CHOOSING A SYMBOL AND SCALE

When you have entered your values select an appropriate symbol to use.  Again the symbols displayed are the 
symbols that currently exist in the Illustrator Symbols palette.  If you wish to scale the symbol used,  edit the Scale 
entry field.  Clicking the Up and Down arrows will increase or decrease the value by 10%.

PLOTTING POINTS

Click Create to plot the point in the designated MAP View.  To plot subsequent points,  edit the Latitude and 
Longitude,  and also choose different points if required.

POINT PLOTTER TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
6-i ...  Plotting Points in Decimal Degree or DMS Format

= 12.3456 Degrees North
= 12.3456 Degrees South

= 12.3456 Degrees East
= 12.3456 Degrees West

Example Degrees,  Minutes and Seconds values:

Latitude Values:  12d34’56.78”N 
  12d34’56”S 

Longitude Values:  12d34’56.78”E 
  12d34’56”W 

= 12 Degrees,  34 Minutes,  56.78 Seconds North
= 12 Degrees,  34 Minutes,  56 Seconds South

= 12 Degrees,  34 Minutes,  56.78 Seconds East
= 12 Degrees,  34 Minutes,  56 Seconds West
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MAPublisher provides extensive tools for quickly,  easily 
and accurately creating point,  line and area legends from 
your map data.  The MAPublisher Stylesheet and Legend 
functions are able to read and work with the data found 
in the MAP Attribute tables and to apply strokes,  fills and 
symbols to map elements according to the legend criteria 
you specify.

There are three legend functions in MAPublisher 6,  which 
will be discussed in this section: 

MAP Stylesheets is a new function allowing you to 
quickly create and apply legends on a one to one ratio 
with Illustrator Styles and Symbols.  

Assign Legend Info and Auto Assign Legend Info are 
designed to enable the application of legends on a one 
to one or value range basis,  based on custom legend 
artwork that you have created in your map document.

Chapter 7

Legends and 
Stylesheets
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MAP Stylesheets
Window > MAPublisher Palettes > MAP Stylesheets

MAP Stylesheet List - An 
alphabetical list of the MAP 
Stylesheets and component 

MAP Layers in the current 
document.  Both are depicted 

with their feature type.

Lock button - Click this button  
to lock or unlock the Layer.

Other MAP Layers- Lists the MAP  
Layers which are not components 

of any MAP Stylesheet,  therefore 
belonging to a Stylesheet of ‘None’.

New MAP Stylesheet button
  - Opens the New Stylesheet 

dialog to specify a name and 
feature type for the new stylesheet.

MAP Stylesheets palette

Name - Specify a 
name for the new 

MAP Stylesheet.

New Stylesheet dialog

Name - The editable name of 
the current MAP Stylesheet.

Attribute - List the columns 
of the attribute table(s) in the 

associated MAP Layer(s).

Value - Lists the attribute 
values for the selected 

attribute column.

Style - Lists the Styles that exist 
in the Illustrator Styles palette 
(for Area and Line stylesheets) 

or in the Symbols palette (for 
Point stylesheets).

Scale - Allows you to scale the 
symbols for Point legends,  and 
stroke or style weights for Area 
and Line legends.  Enter a scale 

directly in into the entry field 
or drag the slider to increase or 

decrease.  Clicking next to the 
slider will increase or decrease 

in 10% increments.

Edit MAP Stylesheet dialog

Legends and Stylesheets: MAP Stylesheets

Options Menu...

New MAP Stylesheet - Opens the New 
Stylesheet dialog to specify a name and 
feature type for the new stylesheet.

Duplicate MAP Stylesheet - Will create a 
Duplicate of the selected MAP Stylesheet.

Edit MAP Stylesheet - Will open the Edit MAP Stylesheet dialog.

Delete MAP Stylesheet - Allows you to delete the selected MAP Stylesheet.

OK - Will apply the current MAP 
Stylesheet to the associated 
MAP Layer(s).

Apply - Will apply any changes 
to the current MAP Stylesheet 
and update the associated MAP 
Layer.  Edits can be previewed 
prior to exiting the dialog.

New - Clicking this button will 
create a new style rule in the 
MAP Stylesheet,  and activate 
the fields for Attribute,  Value,  
Style,  and Scale.

Remove - Will remove the 
selected style rule.

Move Up/Down - Will move 
the selected style rule up or 
down the list.

Resize - Drag the lower right 
corner of the horizontally 
or vertically to expand the 
Stylesheet List.

Delete MAP Stylesheet button
  - To delete the selected Stylesheet. Feature Type - Allows you to 

specify the Feature Type for the 
MAP Stylesheet.  This can be 
Area,  Line,  Point or Text.
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FUNCTIONALITY

MAP Stylesheets is a new function in MAPublisher 6,  which will allow you to quickly create and apply legends 
based on the Styles and Symbols that exist in the respective Illustrator palettes.  Stylesheets are created inside 
a MAPublisher dialog,  where specific values contained in the attribute table for the related layer are assigned 
Illustrator symbology.  The MAP Stylesheet function operates on a one to one basis,  where specific attribute values 
are assigned with a specific style or symbol (i.e.  Attribute Value A = Style 1).  Attribute value ranges (i.e.  Greater than 
Value A) are not supported by MAP Stylesheets.  Stylesheet information will be saved in the Map Document so that 
the MAP Stylesheet can be quickly edited later.

USING MAP STYLESHEETS

THE MAP STYLESHEETS PALETTE

This is the starting point for working with MAP Stylesheets,  and is opened by going to Window > MAPublisher 
Palettes > MAP Stylesheets.

In the list box of the MAP Stylesheets palette will be entries for each Illustrator layer that 
a) belong to a specified MAP View,  and 
b) are of a feature type supported by MAP Stylesheets.  

In Illustrator 10 you can create MAP Stylesheets for Area,  Line,  and Point layers.
In Illustrator CS you can create MAP Stylesheets for Area,  Line,  Point and Text layers.

As in MAP Views,  the icons used for these layers are:

  Area layer  Line layer

  Point layer  Text layer

By default all MAP Layers will be listed as belonging to a Stylesheet of  [None].  When you have created a new 
Stylesheet you can drag a MAP Layer into it,  in order to specify the attributes and symbology you require.

LOADING SYMBOLS AND STYLES

The symbology used by MAP Stylesheets is directly related to the Symbols and Styles which exist in native Illustrator 
palettes.  In order to correctly function,  the MAP Stylesheets tool requires that symbology appropriate to the 
feature type is established in the following Illustrator palettes:

Legends and Stylesheets: MAP Stylesheets

‘Symbols’  palette (Window > Symbols) for Point Stylesheets.

‘Styles’ palette (Window > Styles) for Area and Line Stylesheets.

Illustrator 10:

 

 

‘Symbols’  palette (Window > Symbols) for Point Stylesheets.

‘Graphic Styles’ palette (Window > Graphic Styles) for Area and Line Stylesheets.

‘Character Styles’ (Window > Type > Character Styles) for Text Stylesheets.

Illustrator CS:
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Symbology can be quickly added to these palettes by dragging and dropping artwork from the Illustrator page,  or 
by dragging and dropping symbology from custom libraries.

As an example under Window > (Graphic) Style Libraries > Other Library… navigate to the Utilities folder on your 
MAPublisher CD and load either  MAP_AreaStyles.ai or MAP_LineStyles.ai.  Then shift-select these styles in the 
new MAP_Styles palette and drag them into the Illustrator Styles palette for use in Area and Line Stylesheets.  

Similarly you can navigate to Window > Symbol Libraries > Other Library… and load MAP_PointSymbols.ai.  Then 
shift-select these symbols and drag them into the Symbols palette for use in Point Stylesheets.

CREATING A NEW STYLESHEET

To create new MAP Stylesheets you must first select New MAP Stylesheet… under the Options menu,  or click the 
New button at the base of the palette.  This will open the New Stylesheet dialog,  where you are required to specify 
the name and feature type for the new MAP Stylesheet.  Clicking OK will place the new stylesheet in the palette and 
assign it with the appropriate icon.  It is possible to now drag a MAP Layer with a matching feature type into this 
stylesheet.  You can drag more than one layer into a MAP Stylesheet,  as long as all the MAP Layers are of a feature 
type which matches the MAP Stylesheet.  If your data is held across a number of layers,  all of these layers can be 
placed inside the same stylesheet for quick update.  Note that they do not need to contain the same attribute 
structures.  As long as they are all of a matching feature type they can be placed inside one MAP Stylesheet.

ACCESSING THE EDIT MAP STYLESHEET DIALOG

When you have a MAP Stylesheet created which hosts at least one MAP Layer of the same type,  click on the 
stylesheet name,  and go to Options > Edit…  Alternatively double-click the new MAP Stylesheet.  This will open the 
Edit MAP Stylesheet dialog.

The Name of the current MAP Stylesheet will be displayed at the top of this dialog,  which is editable.  Also a feature 
type icon will be displayed.  To begin,  click the New button to create the first element in your MAP Stylesheet.  

SELECTING ATTRIBUTE COLUMNS AND VALUES

The Attribute dropdown will contain the names of the attribute columns that exist in all attribute tables on 
associated MAP Layers (see more on the MAP Attributes window on page 38).  Using the dropdown you must select 
a Column on which to base the symbology for the first style rule.  Subsequently,  the Value dropdown will contain 
the unique values that exist in the selected attribute column.  Again you must make a selection from this dropdown.  
If you are aware of the column structure and values you wish to specify,  you are able to manually type into the 
Attribute and Value fields,  rather than choosing from the dropdowns.

SELECTING STYLES AND SYMBOLS

The Style field will contain a list of styles that currently exist in the Illustrator (Graphic) Styles palette (for Area and 
Line stylesheets),  in the Illustrator Symbols palette (for Point stylesheets),  or in the Illustrator Character Styles 
palette (for Text stylesheets).  For the expression you have built in the Attribute and Value fields,  choose a style or 
symbol to use.  Note that you can only use a specified style once in a single stylesheet.  The Move Up and Move 
Down buttons will move the priority of the selected style up or down the list.

ASSIGNING AN SCALE

The Scale default is 100%.  Editing the scale will alter the symbol size or stroke weight depending on feature type.

Legends and Stylesheets: MAP Stylesheets
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BUILDING THE STYLESHEET

For subsequent style rules proceed in the same manner.  Click New,  and then specify an Attribute column,  Value,  
Style and Scale.  You can click Apply at any time to preview the results at any stage of building a stylesheet,  and 
also return to edit settings you have made for individual style rules.  In order to delete a legend item from the list,  
click anywhere in its row and click the Remove button.

Click OK to exit the dialog and to assign the MAP Stylesheet to the associated MAP Layers.

DELETING AND DUPLICATING STYLESHEETS

You can create as many MAP Stylesheets as you wish within the document.  Note that under the Options in the MAP 
Stylesheets palette there are functions to Delete and Duplicate Stylesheets.  

You can delete the selected MAP Stylesheets by clicking the Delete button at the base of the palette or by selecting 
Delete Stylesheet under the Options menu.   If you wish to delete a stylesheet you must first drag associated MAP 
Layer(s) out of the stylesheet,  such as into a Stylesheet of [None] or into another Stylesheet.  Only at this stage 
will the Delete option be activated.  Note that moving a stylesheet to [None] will not restore the data to its default 
symbology;  it will simply remove the relationship between attribute value and style/symbol.

Select Duplicate Stylesheet to create a copy of the selected MAP Stylesheet.  Duplicating Stylesheets can be used 
to create copies of existing stylesheets.  Even though the copy will not contain a MAP Layer at first,  the style rules 
which exist between attributes of the original layer and the symbology will be retained.  Simply by editing the styles 
that relate to each value in each stylesheet,  you can drag a MAP Layer from one MAP Stylesheet to another in order 
to output different versions of a map.

IMPORTANT NOTES

A point to note is that once a MAP Stylesheet has been assigned with styles and symbols,  those styles and symbols 
are dynamically linked to their attribute values in the MAP Stylesheet.  Applying a style manually (i.e.  changing 
a style for a polygon directly from the Styles palette) will assign the attribute value of that style rule in the MAP 
Stylesheet.  Therefore caution should be used with manually editing the styles of artwork after MAP Stylesheets 
have been applied.

As styles and symbols which exist in these Illustrator palettes are linked to the related MAP Stylesheet entries,  using 
these styles and symbols to create new artwork will automatically assign the related attribute value to these objects. 

Regarding the editing of Point Data,  you must use either MAP Stylesheets or the MAPublisher Legend filters to 
change symbology.  As point data is linked dynamically to the symbols which exist in the Symbols palette,  you 
cannot edit graphical properties manually.  Choosing  ‘Break Link to Symbol’ from the Symbols palette options will 
result in the loss of attributes for your point data.

MAP STYLESHEETS TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
7-i ...  Creating an Area Stylesheet
7-ii ...  Creating a Line Stylesheet
7-iii ...  Creating a Point Stylesheet
7-iv ...  Duplicating Stylesheets
7-v ...  Editing Styles to Change Attributes

Legends and Stylesheets: MAP Stylesheets
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Assign Legend Info
Filter > MAP Legend > Assign Legend Info

MAP Layer - Select the layer on 
which to create your legend.

Column - Select the attribute column 
on which you wish to base your legend.

Build Expression - Displays the 
current expression.  This will update if 

you change any parameters.

Final Expression - After clicking Insert,  
the Build Expression is moved into this 

box.  This is the final expression that 
will be assigned to the selected legend 

element when you click OK.

Ignore case in strings - If this is 
checked,  any expression that 

compares string (non-numeric) 
values will be case insensitive.

FUNCTIONALITY

The Assign Legend Info filter allows you to create a custom legend for your map based on its attribute information 
using user-defined parameters.  This filter assigns legend criteria to map elements that exist in a single related 
MAP Layer.  Legend elements are plotted using Illustrator’s tools in the MAP Document itself.  Assign Legend Info 
operates on both a one to one basis (i.e.   Value A = Legend Item 1) or with attribute value ranges (i.e.  Greater than 
Value A,  Between Values A & B etc).  Legend information will be saved in the legend elements within the document.

PREREQUISITES

In order to use the Assign Legend Info filter you must first create your legend elements in the document,  and place 
them on a MAP Layer with a feature type of  Legend.

Create a new layer in your Illustrator layers palette to hold the legend.  In the MAP Views palette drag this layer into 
the MAP View holding the MAP Layer that you wish to apply the legend to.  You can construct legends for Area,  
Line Point and Text layers.  When you drag the new layer into the MAP View,  set the feature type to ‘Legend’.  With 
the Legend layer selected in the Illustrator layers palette,  construct the number of unique legend items that you 
require.  Area legends should be symbolized with closed shapes,  line legends with line strings,  and Point legends 
with symbols.  As long as these legend elements are on a Legend Layer,  they can be assigned legend information.

When you have created your legend elements,  each element is assigned legend information via Assign Legend 
Info.  When all legend elements have this information,  the map can be quickly updated.  Therefore with one legend 
element selected on the Legend Layer,  go to Filter > MAP Legend > Assign Legend Info to open the dialog.

Comparison - A list of comparison 
operators to help you build your expression 

- i.e.  Equal to,  Greater than,  Less than etc.

Value A - There are two parts to this parameter - a textbox and a 
dropdown list containing all unique values from the selected column.  
You can select a value from the list or enter one manually in the textbox.

Boolean Operators - You can use brackets,  AND,  OR 
& NOT operators to create a more complex expression 

involving multiple inserts of build expressions.

Insert - Moves the 
Build Expression into 

the  Final Expression box.

Value B - These are only made available if the 
selected comparison is a “Between” type in which 
case the second value will be entered here.

Legends and Stylesheets: Assign Legend Info

Clear Expression - Clears the 
expression box allowing you to 
insert a new expression.
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USING ASSIGN LEGEND INFO

DIALOG OVERVIEW

The filter is very similar to Select by Attribute,  though this time you assign attribute information to legend items.  
First you choose the MAP Layer on which you wish to apply the legend.  This will populate the Column dropdown 
list with that layer’s attribute structure.  A particular column is selected and then a logical expression is built 
defining the desired attributes or attribute range to assign to the legend element.  For example,  “Assign populations 
between 100,000 and 200,000” is typical legend criteria you could assign depending upon the attribute data 
associated with your MAP Layer.

BUILDING AN EXPRESSION

To use Assign Legend Info you must first determine the MAP Layer to be used for the legend,  which will load the 
related attribute table into this dialog.  You can then select a Column of the attribute table,  a Comparison,  and a 
choice of Values from the dropdowns in order to build an expression.  When the expression has been built you must 
click the Insert button.  The Boolean operator buttons can be used if you wish to use multiple columns or values in 
order to generate an expression.

When the expression is complete and has been inserted into the Expression field,  click OK to apply the rule to the 
selected legend item.  

UPDATING THE MAP

Proceed with your other legend items in the same manner.   When you have assigned legend information to all the 
legend items,  select them all,  and go to Filter > MAP Legend > Draw Legend Layer.  This will update the associated 
MAP Layer so that the map elements reflect the legend items.

If you wish to change the symbology assigned to legend elements,  simply change these using Illustrator’s object-
editing options.  Then reselect the legend elements and again click on Draw Legend Layer to update the MAP Layer.

LABELING LEGEND ITEMS

The MAP Tagger Tool (see page 74) can be used to label your legend items in order to display the attribute 
expressions that have been assigned to them.

SELECTING ARTWORK BASED ON LEGEND VALUES

The Legend Matching Features filter can be used to quickly select all features on a MAP Layer corresponding to 
a particular legend element.  In order to use this function,  you must have already created a legend using Assign 
Legend Info or Auto Assign Legend Info.   To use this feature select one or more of the Areas,  Lines or Points you 
used for your legend,  then go to Filter > MAP Legend > Legend Matching Features.  The map features associated with 
the selected legend items will be subsequently selected.

ASSIGN LEGEND INFO TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
7-vi ...  Building an Area Legend using Assign Legend Info
7-vii ...  Building a Point Legend using Assign Legend Info

Legends and Stylesheets: Assign Legend Info
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Auto Assign Legend Info
Filter > MAP Legend > Auto Assign Legend Info

MAP Layer - Select the layer on 
which to create your legend.

Column - Select the attribute 
column on which you wish 

to base your legend.

Value range - Creates the legend by 
splitting the values from the selected 

column into equal divisions.  The 
number of divisions is determined 
by the number of legend elements 

selected and the interval entered.

Round values to nearest - By 
checking this box and entering a 
value in the adjacent textbox,  All 
values in the selected column will 
be rounded off before their value 
is calculated for the legend (only 
applies to Value Range legends).

FUNCTIONALITY

The Auto Assign Legend Info filter allows you to automatically create a custom legend for your map based on 
its attribute information.  This filter works similarly to Assign Legend Info,  but this time assigns legend criteria 
automatically to map elements by determining a method to divide your data according to the number of legend 
elements you wish to use.  

PREREQUISITES

In order to use the Auto Assign Legend Info filter you must first create your legend elements in the document,  and 
place them on a MAP Layer with a feature type of  Legend.

Create a new layer in your Illustrator layers palette to hold the legend.  In the MAP Views palette drag this layer into 
the MAP View holding the MAP Layer that you wish to apply the legend to.  You can construct legends for Area,  Line 
and Point layers When you drag the new layer into the MAP View,  set the feature type to ‘Legend’.

With the Legend layer selected in the Illustrator layers palette,  construct the number of legend items that you 
require.  Area legends should be symbolized with closed shapes,  line legends with line strings,  and Point legends 
with symbols.  As long as these legend elements are on a Legend Layer,  they can be assigned legend information.

When you have created your legend elements,  all elements are assigned legend information automatically via Auto 
Assign Legend Info.  When the legend elements have this information,  the map can be quickly updated.  Therefore 
with all the legend elements selected on the Legend Layer,  go to Filter > MAP Legend > Auto Assign Legend Info to 
open the dialog.

Legends and Stylesheets: Auto Assign Legend Info

Unique occurrences - Creates the 
legend such that every unique value in 
the selected column will be assigned 
to one of the selected legend elements.  
There is a maximum of 200 unique 
values in an attribute column that can 
be processed when creating a legend 
using the Unique Occurrences option.

Reverse order - By default,  the legend 
will be built in descending order.  Check
this box to build in an ascending order.

Sort - If you have drawn your legend elements 
vertically,  select ‘Vertical’.  If you have drawn 
them horizontally,  select ‘Horizontal’.
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USING ASSIGN LEGEND INFO

DIALOG OVERVIEW

To use Auto Assign Legend Info you must first determine the MAP Layer to be used for the legend,  which will load 
the related attribute table into this dialog.  You should then select a Column of this attribute table on which to base 
the assigning of legend values.  There are two options available for auto assigning legends: Unique occurrences and 
Value range.  

UNIQUE OCCURRENCES

If you select this option,  each unique value in the selected column will be assigned to each of the selected legend 
elements.  For Example,  if a column contains either an a,  b,  or c,  three different legend elements will each be 
assigned a single value.  This option is most often used with text and alphanumeric type attributes (i.e.  Road Class = 
A41 or Zoning = Park).

VALUE RANGE

Value Range works by splitting the selected column’s values into sections.  The number of sections depends on the 
number of legend elements.  For example,  if you have four legend elements drawn and the column had a value 
range of 0 - 100,  the first element would be associated with all features where that column had a value between 0 
and 25.  The second element would be associated with all features where the column had a value between 26 and 
50 and so on.  This option can only be used with numeric attributes (i.e.  Population = 12,000,432 or Area = 6,666).  

If you are unsure of the number of legend elements to create when using the value range option,  you can quickly 
open the Auto Assign Legend Info window and see how many unique value occurrences there are in the data 
column.  You can then simply decide on a number of legend elements that is a factor of the total number of unique 
values.

The Value Range option also provides the option to Round values to the nearest specified number.  Enter a value in 
this field in order to round off all values in the selected column before their values are calculated for the legend.

SORT OPTIONS

The Sort option will determine how the generated legend criteria will be applied to your legend elements.  For 
example,  if you have drawn your legend vertically,  select Vertical.  

The legend will be built in descending order as a default.  If you wish to assign the legend values to your legend 
elements in an ascending order,  check the Reverse order option.

UPDATING THE MAP

Proceed with your other legend items in the same manner.   When you have assigned legend information to all the 
legend items,  select them all,  and go to Filter > MAP Legend > Draw Legend Layer.  This will update the associated 
MAP Layer so that the map elements reflect the legend items.

If you wish to change the symbology assigned to legend elements,  simply change these using Illustrator’s object-
editing options.  Then reselect the legend elements and again click on Draw Legend Layer to update the MAP Layer.

Legends and Stylesheets: Auto Assign Legend Info
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LABELING LEGEND ITEMS

The MAP Tagger Tool (see page 74) can be used to label your legend items in order to display the attribute 
expressions that have been assigned to them.

SELECTING ARTWORK BASED ON LEGEND VALUES

The Legend Matching Features filter can be used to quickly select all features on a MAP Layer corresponding to 
a particular legend element.  In order to use this function,  you must have already created a legend using Assign 
Legend Info or Auto Assign Legend Info.   To use this feature Select one or more of the Areas,  Lines or Points you 
used for your legend,  then go to Filter > MAP Legend > Legend Matching Features.  The map features associated with 
the selected legend items will be subsequently selected.

AUTO ASSIGN LEGEND INFO TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
7-viii ...  Auto Assigning Legend Values - Unique Occurrences
7-ix ...  Auto Assigning Legend Values - Value Range
7-x ...  Selecting Features Based on Legend Attributes
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One of the most useful features of MAPublisher is the 
ability to create labels for map objects using values from 
the attribute tables.  Manually entering and placing labels 
is not necessary provided that the labeling information is 
included in the map database of the layer being labeled.

MAPublisher provides two methods of adding labels to 
your map,  both of which are very simple to use.

One way to create feature labels is to first select all the 
features you want to be labeled and use the Feature Text 
Label filter to label all of them by a specified attribute 
value.  

An alternate method involves using the MAP Tagger 
Tool to apply labels individually.  Both these methods are 
discussed in the following sections.

Both of these tools will be examined in this section.

Chapter 8

Text Creation
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Feature Text Label
Filter > MAP Legend > Feature Text Label

Source Layer - Select the 
MAP Layer containing the 
artwork you wish to label.

Source Column - Select the column 
that contains the values you wish 

to use to label the selected features.

Follow lines - This option only applies 
if the selected layer is a Line MAP Layer.  

Checking this box will make the labels 
follow along the lines. 

Keep text above lines - Check this 
box to ensure that all labels appear 

above the line feature they belong to.

FUNCTIONALITY

The Feature Text Label filter allows labels to be added to your map based on the attribute data of the features.  Line,  
Point or Area MAP Layers containing attribute information can be labeled using this filter.   All selected features on 
MAP Layers,  which contain appropriate attribute information,  can be labeled using this tool.

PREREQUISITES

Before using this filter you must create a  Text Layer in your MAP Views palette.  Create a new Illustrator layer,  
and then drag it to the MAP View holding the features you wish to label.  Set the feature type to ‘Text’ when 
prompted.

Furthermore it is often useful to set you default text size,  justification and font at this stage,  as MAPublisher will 
generate labels based on these settings.  Then simply select the features that you want to label and go to Filter > 
MAP Legend > Feature Text Label to open the dialog.

USING FEATURE TEXT LABEL

LABEL SOURCE

You must first set the options for MAPublisher to determine the attributes that will be converted to text labels.  In 
the Source section,  select the MAP Layer holding the attribute data you wish to use to label the features.  This is the 
same MAP Layer that holds the vector data.  Based on the layer you select,  the Column dropdown will be populated 
with the attribute structure of this MAP Layer.  You must choose a column that holds the attributes you wish to label 
the data with.

Target Layer - Select the text layer 
you wish to place the generated text 
labels on.

Percent along line - The value entered 
here determines at which point along 
the line the text label will begin.  This 
option only applies if the Follow Lines 
option has been selected.

Text Creation: Feature Text Label
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‘TARGET’ SECTION

In the Target section you must specify a Text MAP Layer that the labels will be output to.  This should be the text 
layer you created prior to opening the dialog.

LINE OPTIONS

If you are labeling Line features,  you have a number of additional options to consider:

You can choose to have the labels follow along the line paths by selecting the Follow lines option.   If this option is 
used,  MAPublisher will create a path for each line object in the selected MAP Layer,  and place the text along this 
path.  The labels can then be dragged and positioned at any position along a line.  If the Follow Lines option is not 
selected,  the labels will appear horizontal to the page at the mid-point of the line feature.

Check the Keep text above lines box if you wish to ensure that all labels appear above the line feature they belong 
to.  Depending upon the manner in which the linework was originally digitized,  some labels may be placed upside 
down if this box is not checked.

A specific value for the label’s position can be entered in the Percent along line box.  This option only applies if the 
Follow lines option has been selected.  The value entered here determines at which point along the line the text 
label will begin.

RESULTS

When you have set all your options,  click the OK button to label your features.

Labels applied using Feature Text Label will  appear in the current default colour,  font and font size.  For later text 
edits,  the stroke,  fill,  font and size of text labels can be changed at any time using Adobe Illustrator’s tools.

FEATURE TEXT TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
8-i ...  Generating Labels for a Line Layer using Feature Text Label

Text Creation: Feature Text Label
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MAP Tagger Tool
Main Toolbar > MAP Tagger Tool  

Source Layer - Select the 
MAP Layer containing the 
artwork you wish to label.

Output Layer - Select the 
text layer you wish to place 

the generated text labels on.

Enable leader lines - This option 
will allow you to create leader 

lines from the label to the object.

FUNCTIONALITY

The MAP Tagger Tool allows labels to be added to your map based on the attribute data of the features.  All types of 
MAP Layers (Line,  Point,  Area,  Text and Legend) containing attribute information can be labeled using this filter.  

This tool functions similarly to the Feature Text Label filter.  However,  instead of having to select the features 
beforehand,  you can simply click on any feature you want labeled and the label will appear.  You also have greater 
control over the initial placement of the label with this tool because the label is placed where you click rather 
than in the centre of the feature.  The MAP Tagger Tool also provides the ability to create leader lines for labeling 
congested areas of the map.  

PREREQUISITES

Before using this filter you must create a  Text Layer in your Illustrator layers palette.  Create a new layer,  and 
then drag this to the MAP View that hosts the features you wish to label,  remembering to set the feature type to 
Text.  

Furthermore it is often useful to set you default text size,  justification and font at this stage,  as MAPublisher will 
generate labels based on these settings.  Labels placed using the MAP Tagger tool will appear in the stroke and fill 
defined in the Adobe Illustrator colour palette.

The MAP Tagger Tool can be found towards the bottom of The Adobe Illustrator tools palette.  If the Adobe 
Illustrator tools palette is not visible you can activate it by selecting Window > Tools.  Simply double click the  
MAP Tagger Tool in the Illustrator Tools palette to access the MAP Tagger Settings dialog.  

Text Creation: MAP Tagger Tool

Source Column(s) - Select the 
column that contains the values 
you wish to use to label the 
selected features.  You may also 
select multiple columns to 
generate a label based on a 
number of attribute criteria.

Follow lines - This option only applies 
if the selected layer is a Line Layer.  
Checking this box will make the labels 
follow the orientation of the lines. 
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MAP TAGGER TOOL SETTINGS

LABEL SOURCE

You must first set the options for MAPublisher to determine the attributes that will be converted to text labels.  In 
the Label Source section,  select the MAP Layer holding the attribute data you wish to use to label the features.  This 
is the same MAP Layer that holds the vector data.  Based on the layer you select,  the Column dropdown will be 
populated with the attribute structure of this MAP Layer.  You must choose a column that holds the attributes you 
wish to label the data with.  Note that you can select more than one column if you require that labels use criteria 
across a number of attribute columns.

‘OUTPUT’ SECTION

In the Output section you must specify a Text MAP Layer.  This should be the text layer you created prior to opening 
the dialog.

An option called Enable leader lines is available in the MAP Tagger Tool.  This will allow you to create leader lines 
that run from the label to the object.  

LINE OPTIONS

If you are labeling Line features,  you have a number of additional options to consider:

You can choose to have the label follow the general orientation of the line path by selecting the Follow lines option.   
If this option is used,  MAPublisher will create a single text item in the selected MAP Layer,  which is at a similar angle 
to the path that is ‘tagged’.  The labels can then be repositioned as appropriate.  If the Follow Lines option is not 
selected,  the labels will appear horizontal to the page at the point that is clicked.

USING THE MAP TAGGER TOOL

When you have set all your options,  click the OK button to exit the dialog.

With the Tagger Tool selected click on the map object to label it based on your settings.  If you used Enable leader 
lines,  click and hold with the mouse when you select the object,  and then drag away to the point at which you 
wish your text label to appear.  A leader line will be generated linking the feature to the label.  

In order to label an area by this method,  you must click on the area’s boundary unless the area has a fill.  If the area 
has been filled,  then a label may be placed by clicking anywhere inside the area.

If you wish to return to the MAP Tagger dialog to edit your settings,  double click the tool.

For later text edits,  the stroke,  fill,  font and size of text labels can be changed at any time using Illustrator’s tools.

Text Creation: MAP Tagger Tool
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LABELING LEGEND ITEMS

The MAP Tagger Tool may also be used to label or query legend elements that were generated via Assign or Auto 
Assign Legend Info.  To label or query a legend element simply follow the procedure above,  using values that 
pertain to your particular legend and click on the legend element you wish to label or query.  A label identifying the 
expression used in either of the legend creation filters will be placed next to the legend element.

MAP TAGGER TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
8-ii ...  Generating Labels for an Area Layer using the MAP Tagger Tool

Text Creation: MAP Tagger Tool
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MAPublisher contains tools for easily creating map grids 
and map indexes.  Grids can be created for reference 
purposes,  or to follow designated lines such as latitude 
and longitude,  and can also be labeled for indexing.  
When a labeled grid has been established,  MAPublisher 
is able to generate index files,  containing the location of 
text objects in MAP Layers.

This section of the user guide details the use of the 
MAPublisher Grid Generator and Make Index filters for 
quickly and easily creating accurate grids and indexes for 
your map.

Chapter 9

Grids and Indexes
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Grid Generator
Filter > MAP Legend > Grid Generator

Grid Units - You can choose to create your 
grid based on Map Units (i.e.  meters,  miles 

etc) or Page Units (points,  inches etc).

Lower Left X/Y - These are the X and Y 
values of the lower left extent of the grid.

Upper Right X/Y - These are the X and Y 
values of the upper right extent of the grid.

Width/Height - Enter the size you want each 
grid cell to be.  The values will be based on 

either page or map units,  depending on 
which you have selected.  If you have 

selected Map Units,  it is also dependant on 
the value selected for Cell Size Units.

Columns/Rows - Enter the number of 
columns and rows you want your grid 

to have into these boxes.

Calculate Parameter - This list contains 
three items: ‘Grid Upper Right’,  ‘Grid 

Columns/Rows’ and ‘Grid Width/Height’.  
The parameter chosen here is the 
parameter that will be calculated 

when the Calculate button is clicked.

Label Ordering -
Choose the syntax of the index as being 

either Row-column or Column-row.

Label Location -
Choose where the index labels will be placed.  
“Place grid center” will place the labels in the 

centre of each grid cell.  “Place off grid” will 
place the labels around the frame of the grid.

Page Scaling Information - This 
section displays all the scaling 
parameters for the current layer.

Lines/Rectangles - You can 
choose to create the grid using 

either lines or rectangles.

Vertices - When your grid is created,  this 
value will determine how many vertices 
will be used to create each rectangle or line.

Calculate - Clicking this button will calculate the 
parameter selected in the adjacent dropdown list 
based on the values of the other parameters.

Generate index labels - 
You can create indexing labels for your grid by 
checking this box.  There are three options for the 
labels.  Labels can only be generated for grids 
that are created using rectangles.  

Label Style -
Choose whether columns will be labeled 
alphabetically & rows numerically,  or vice versa.

Offset value -
This is the offset value (in page units) by which 
index labels placed off the grid will be located.

Index Label Options
See inset.

Map Units - If you have chosen 
to base your grid on Map Units,  
you must select the type of unit 

(i.e.  meter,  mile etc) to use.

Grids and Indexes: Grid Generator
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FUNCTIONALITY

MAPublisher’s Grid Generator will plot either grid lines or cells based on user-defined settings.  Grids can be plotted 
in either Map Units,  where the grid dimensions can be entered in a choice of distance units,  or in Page Units,  where 
the dimensions are read from the current document units.  In order to subsequently use the Make Index filter,  a 
grid must have been created with this tool,  and that the grid must be constructed as  ‘Cells’,  each containing an 
alphanumeric grid reference label.

PREREQUISITES

Before using this filter you must create a  Legend Layer in your Illustrator layers palette.  Create a new layer,  and 
then drag this to the MAP View holding the features on which you wish to plot a grid,  remembering to set the 
feature type to Legend.  

Furthermore MAPublisher will use the current stroke and text settings when generating the grid and if applicable,  
its index labels.  It is therefore useful for you to set your default text size,  justification and font,  as well as your stroke 
colour and weight at this stage.  Then,  with the Grid layer highlighted in your Illustrator layers palette,  you should 
then open the dialog via Filter > MAP Legend > Grid Generator.

If you wish to create a Grid based on Page Units,  use your rulers to determine coordinates in document units to use 
for both the lower left corner and the upper right corner of the grid.

If you wish to create a Grid based on Map Units,  use the MAP Location Tool (see page 37) to determine coordinates 
in map units to use for both the lower left corner and the upper right corner of the grid.

USING THE GRID GENERATOR: PLACEMENT OPTIONS

PAGE SCALING INFORMATION

The current Page Scaling information is displayed in the lower portion of the dialog,  which will assist you in 
deciding which options and values to use in constructing your grid.

GRID UNITS

The first element to consider is if you wish to construct a grid based on Page Units or Map Units.  

Calculating cell sizes in Page (document) Units can be useful if your MAP View does not contain georeferencing 
information or you are unsure of the real-world distance from one point to another.  

Calculating cell sizes in Map Units can be useful for creating grids at actual lines of Latitude & Longitude,  or in unit 
measurements that may otherwise be difficult to calculate.  As long as your MAP View contains georeferencing 
information,  you will be able to use this option to calculate grid cell sizes.  MAPublisher offers a choice from over 30 
units of measurement for the Map Unit category.  However you should select the same Map Unit as is used in the 
coordinate system for your current MAP View,  which is displayed in the lower part of the dialog.

Grids and Indexes: Grid Generator
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ENTERING VALUES

The following paragraphs will deal with the input of values into the four pairs of entry boxes labeled Lower Left X/Y,  
Upper Right X/Y,  Columns/Rows,  and Width/Height.

The two key points to remember is that a minimum of three pairs of entry fields must be completed,  of which only 
the Lower Left X/Y field pair is mandatory.  The fourth entry can be calculated automatically by using the Calculate 
button with its adjacent dropdown.  This Calculate Parameter listbox will display Grid Upper Right,  Grid Columns/
Rows,  and Grid Width/Height as options.  This will enable you to calculate the parameters for the fourth blank entry 
field pair,  whether this is Upper Right X/Y,  Columns/Rows,  or Width/Height respectively.

LOWER LEFT AND UPPER RIGHT VALUES

Entries for the Lower Left and Upper Right coordinates should be entered in the unit type you chose at the top of 
the dialog,  therefore being in Page Units or your selected Map Units.  The Lower Left X and Y values for the grid will 
be automatically set to the current Page or Map Anchors (see page 36).  

If the units set are Map Units,  the Lower Left X and Y values for the grid will be automatically set to the Map 
Anchors in the unit in which they currently reside.  Normally your choice of Map Units should be the same as 
the unit of the current MAP View,  which is displayed in the lower part of the dialog.  This will ease the effort of 
calculating values for the lower left and upper right corners of the grid.  

If you wish to change the Lower Left coordinate for your intended grid you can type over the values displayed in the 
Lower Left X/Y fields.  Subsequently if you know the Upper Right coordinates you should enter them in the Upper 
Right X/Y fields.  

Note that you can calculate the Upper Right coordinates by selecting Grid Upper Right from the dropdown and 
clicking the Calculate button,  if you have entered valid figures for Width/Height and Columns/Rows.

COLUMNS AND ROWS

The Columns and Rows entry fields relate to the number of cells which will comprise your intended grid in east-
west and north-south directions respectively.  Enter the values you require in these ‘Cell Numbers’ fields.  

Note that you can calculate the number of cells by selecting Grid Columns/Rows from the dropdown and clicking 
the Calculate button,  if you have entered valid figures for the Width/Height and Upper Right X/Y.

CELL SIZE

The Width and Height entry fields relate to the size of each cell that will comprise your intended grid.  

If you are entering values in Map Units,  these sizes will need to be entered in the unit you have chosen at the top of 
the dialog.  If you are entering values in Page Units,  these sizes should be entered in document units.  

Note that you can calculate the cell size by selecting Grid Width/Height from the dropdown and clicking the 
Calculate button,  if you have entered valid figures for Columns/Rows and Upper Right X/Y.

Grids and Indexes: Grid Generator
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USING THE GRID GENERATOR: GRID OPTIONS

GRID TYPE

When you have completed all of the Placement Options,  you need to decide if you wish to generate a grid based on 
Lines or Rectangles.  This choice can be specified in the Grid Type section.  Either option will place the lines,  or cell 
edges in the same locations on the layer therefore creating the same visible effect.  
Note:  if you wish to export your Grid using the MAPublisher Export function,  you must generate your Grid as Areas.

Rectangles must be used if you are planning to create an Index through the use of your grid,  as in order to locate 
text elements they must be inside a closed cell that has an alphanumeric identifier.  As a consequence,  the Index 
Label Options will only be active if the Grid Type is set to Rectangles.  

Lines can be used if you wish to create a graticule effect,  and do not wish to generate an index.  It is also ideal if you 
plan to reproject the MAP View.  

The Vertices field will allow you to enter the number of nodes that will comprise each Line or Rectangle.  The 
default number for Rectangle is 5 nodes,  whereas the default for Lines is 2,  which correspond to the least amount 
of points that are required to build these elements.  If you are planning to reproject your grid layer you should set 
the number of vertices to a high number,  so this will mimic the curves composing a projected grid.

INDEX LABELS

The Generate index labels checkbox will only be enabled if the Grid Options are set to Rectangles,  as to locate 
text items for an index requires that the grid is created as shapes,  and each cell has a separate reference identity.  
Checking this option will subsequently activate the Index Label Options.

This section requires that you make three choices.  The grid will be labeled alphabetically in one direction,  and 
numerically in another.  This will mean that each cell composing the grid has a unique identifier.

First choose if you wish to label your grid rows with letters and your columns with numbers,  or vice versa,  by 
selecting the appropriate option in the Rows alpha / Cols numeric OR Rows numeric / Cols alpha section.

Then choose if you wish labels to be placed in the centre of each grid cell,  or have letters and numbers placed at 
the left and lower edges of your grid as identifiers.  Select the option you desire in the Place grid center OR Place 
off grid section.  If you choose to place identifiers around the edges of your grid,  you can also specify the distance 
away from the edge of the grid that the text items will be placed.  The value entered here must be in Points.

If you have chosen to place labels Grid Center,  you can choose the format of these labels in the Row-column OR 
Column-row section.  For example if you have chosen a Rows alpha / Columns numeric format,  checking Row-
column,  would produce labels such as A-1.  If you have chosen a Rows numeric / Columns alpha format,  checking 
Row-column,  would produce labels such as 1-A.

RESULTS

When you have set all the options in the Grid Generator,  click OK to plot the grid.  The grid will be plotted using the 
current settings for Fill and Stroke.  If applicable,  the labels will be created using the current Text settings.  Both can 
be changed using Illustrator’s tools.

Grids and Indexes: Grid Generator



82 83

GRID GENERATOR TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
9-i ...  Creating a Grid: Map Units / Auto Calculate Grid Cell Numbers
9ii ...  Creating a Grid: Page Units / Auto Calculate Grid Upper Right

Grids and Indexes: Grid Generator
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Make Index
Filter > MAP Legend > Make Index

Text Layer - Select which MAP Layer 
you want to base the index on.

Grid Layer - Select the layer you 
have created your grid on. 

Remove duplicate entries - If this box is 
checked,  any duplicate index entries will 

be removed from the generated file.

Include layer name - If this box is 
checked the name of the MAP Layer 

that the index is being based on will be 
included as part of each index entry.

Sort Output File - You can choose to 
sort the entries in the index file by 

either feature label or grid cell address.

FUNCTIONALITY

The MAPublisher Grid Generator filter contains options to subsequently generate an index for your map.   Index 
files generated using this function are produced as a simple text file,  and a typical file would be formatted as 
follows:

 High Street A-4
 King Road A-5
 New Avenue B-4
 Church Lane B-5

PREREQUISITES

In order to facilitate the creation of a map index using this filter you must have created a grid that is constructed as 
Rectangles,  and is labeled with alphanumeric identifiers.  This grid must exist on a  Legend Layer.  

The Make Index filter will index text labels that appear inside the rectangles of the grid,  with the function exporting 
a text file containing the locations of these text items.  Text labels to be indexed must be on a  Text Layer.  

Open the dialog by going to Filter > MAP Legend > Make Index.  

USING MAKE INDEX

‘INDEX ENTRIES’ SECTION

You should first choose the MAP Layer on which your text labels reside,  and the MAP Layer on which your Grid 
resides.  These choices should be made by using the Text Layer and Grid Layer listboxes respectively.

You have two options by which to index:  By Text Objects,  or By Feature.

Grids and Indexes: Make Index

Save As - Click here to choose the location 
and to save the index to a text file.

Index by text objects / feature - 
Select whether you want the index to be 
text-based or feature-based.

Attribute to match - If you chose a 
feature-based index,  select the MAP 
Layer and the attribute column that 
you used to generate your text.

Entry Delimiter - You can select a delimiter 
for the index file - Tabs,  Commas or Other.  
If you choose Other,  you can type the 
desired delimiter into the adjacent entry 
field.
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INDEX BY TEXT OBJECTS

Select the By text objects radio button to generate an index using this method.  Text Label indexing functions by 
referencing the grid cells where each text label is found.  For example if the label “High Street” was found in Grid Cell 
A-4,  the entry in the index file would appear as follows:

 High Street A-4

INDEX BY FEATURES

Select the By feature radio button to generate an index using this method.  Feature based indexing functions by 
referencing every grid cell that the feature that is labeled passes through.  Note that only features that have labels 
can be indexed.  For example if  “High Street” passes through Grid Cells A-3,  A-4 and A-5,  there would be several 
entries in the Index file:

 High Street A-3
 High Street A-4
 High Street A-5

In the adjacent list box select the MAP Layer that was used to originally generate the labels,  whether this was via 
Feature Text Label or MAP Tagger Tool.  In the Attribute to match listbox,  select the attribute column of the selected 
MAP Layer,  which matches the labels you are indexing.

INDEX FILE FORMATTING OPTIONS

If you require the software to remove entries that are duplicates (i.e.  street names named twice in the same grid 
cell) you should click the option to Remove duplicate entries.  If you are required to produce an index for several 
layers,  you can choose to Include layer name when saving out the current layer.  Each index entry will then have 
the name of the text layer included.

You must choose an option to Sort Output File by.  This will be the ordering of your index entries.  The default is 
the feature label itself,  meaning for example,  countries starting with ‘A’ will be listed first.  Alternatively,  you can 
choose to index by grid cell,  meaning labels inside the cell marked ‘A-1’ will be listed first.  

The Index maker also provides an option to specify an Entry Delimeter,  being the form of the separator between 
grid cell and text label for each index entry.  You can choose from Tab,  Comma,  or specify a custom (Other) 
delimeter (such as a dash or colon).

SAVING THE INDEX FILE

When you have set all of your Index options,  click the Save As button.  This will allow you specify a name for the text 
file,  and the location where it will be saved.  You can open this file in a text editor,  or place it back into document 
using Illustrator’s Place function.

MAKE INDEX TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
9-iii ...  Creating an Index: Feature Based
9-iv ...  Creating an Index: Text Based

Grids and Indexes: Make Index
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MAPublisher contains a tool for selecting data and 
viewing selection statistics graphically.  

The SelStats tool can be used for quickly selecting all 
features contained in a MAP Layer,  for viewing how many 
objects are selected at a given time,  to save selections 
and to reverse selections.

Chapter 10

Selection Statistics
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SelStats
Window > MAPublisher Statistics > SelStats

USING THE SELSTATS WINDOW

Open the Selection Statistics window by going to Window > MAPublisher Statistics > SelStats.  This window can also 
be opened by checking the ‘Display Number Selected’  option in the Select by Attribute dialog (see pages 40 to 41).

LAYER STATISTICS

On initial opening,  this palette will display the total number of Map features that exist on the current MAP Layer,  
as well as how many are currently selected.  As only one feature type is supported per MAP Layer,  in MAPublisher 
6,  this dialog will only display the current feature type.  Only MAPublisher objects will be displayed in the SelStats 
window.  Objects that are in a [Non-map layer] in the MAP Views palette,  will not be recognized in this window.

Selecting objects manually or via Select by Attribute will update the left hand field in this dialog.  The right hand 
field will display the total number of Map features that exist on the current MAP Layer.  

ALL OR REVERSE

The dialog offers a quick way to select all map features on the current layer.  Simply click the A (All) button to select 
all the Map features on the current layer.

Clicking the R (Reverse) button will reverse the current selection,  i.e.  all the features that were selected will be 
deselected,  and the features that were deselected will be selected.

SAVING SELECTIONS

The Save button will save the current selection to memory,  allowing you to retrieve your selection again later.  
Only one selection can be saved,  and it is limited to the current Illustrator session.  A subsequent click on the Save 
button will overwrite the original saved selection.  

Clicking Recall will perform the selection that is saved to memory.  Clicking Clear on the other hand,  will remove 
the saved selection from memory.

Layer - The current MAP Layer and feature type.

Number Selected/Number Existing - The field 
on the left represents the number of selected 

objects on the active MAP Layer.  The field on the 
right displays the total number of objects of a 

given feature on the active MAP Layer.

Save - Save the current selection to 
memory so that it can be recalled later.

M OR - Selects both the saved and 
currently selected features. 

A and R - All and Reverse.  You can choose to 
either select all of the features on the selected 
MAP Layer,  or reverse the current selection.

Recall - Restores a selection that 
has  been saved to memory.

Clear - Removes the saved selection 
from memory.

M XOR - Selects both the saved and currently 
selected features,  but also removes from the 
selection any features that are both saved 
and selected.

M AND - Selects the saved 
features that are also 

currently selected.

Selection Statistics: SelStats
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ADDITIONAL SELECTION OPTIONS

This window also offers additional selection tools: M OR,  M AND,  & M XOR.    

Clicking the M OR button will select both the currently selected 
objects and the saved selection.    

SELSTATS TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
10-i ...  Making Selections with SelStats

The M AND button will select the map features in the current selection which 
are included in the saved selection.

The M XOR button will select both the currently selected features and the  
saved selection if these selections do not overlap.  However if the current  
selection includes any features that are part of the saved selection,  those will 
be deselected when this button will is clicked.

Current
Selection

Current
Selection

Current
Selection

Saved
Selection

Saved
Selection

Saved
Selection

Resulting
Selection

Resulting
Selection

Resulting
Selection

M OR

M AND

M XOR
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MAPublisher contains several tools for working with Map 
Line segments.  

As the graphics environment offers much more flexibility 
when working with vector artwork,  MAPublisher offers 
graphics specific line tools,  which will be discussed in 
detail in this chapter.

Buffer Selected Lines will allow you to create a buffer 
around current lines at designated distances in Map Units.  

Flip Selected Lines can be used to swap the start and 
end points of lines if these line strings were not originally 
digitized in a preferable manner.  

Spline Selected Lines will allow you to add Bezier 
curves to selected lines to assist in the manipulation and 
subsequent smoothing of paths.  

Join Lines can be used to connect line segments into 
continuous line strings based on a specified attribute 
column.

Simplify Lines will allow you to remove points and 
add Bezier curves to all or selected lines based on 
mathematical formulae.

Join Points will allow you to join point symbols based 
on attribute values.  This tool will generate a line string 
joining common points,  and is ideal for GPS data.

Chapter 11

Line Functions
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By Entered Value - If you want to enter a 
specific value to buffer the selected lines 
by,  click this radio button and enter the 

value in the adjacent entry field.

Target Layer - Use this dropdown 
to select the Area Layer which will 

hold the buffered objects.

Buffer Selected Lines
Filter > MAP Lines > Buffer Selected Lines

FUNCTIONALITY

The MAPublisher Buffer Selected Lines filter creates buffer ‘Area’ objects around the linework.  This can be useful if 
you are attempting to calculate distances on each side of a line.  An example where you would use this tool could 
be in the planning of new roads,  where the actual width of the highway is a major consideration.

PREREQUISITES

Your MAP Layer must be a  Line Layer to use Buffer Selected Lines.

Before using this filter you must create an  Area Layer in your Illustrator layers palette.  Create a new layer,  and 
then drag this to the MAP View which holds linework you wish to buffer,  remembering to set the feature type to 
Area.  

To use this tool,  select the line(s) you wish to buffer,  and then go to Filter > MAP Lines > Buffer Selected Lines.

USING BUFFER SELECTED LINES

You can choose to buffer lines by entering a value in the current Map Units of the layer,  or by selecting an attribute 
column that contains buffer values in Map Units.  The buffering value specified designates the total width of the 
new area object.  For example,  a value of 10 would create a buffer of 5 on either side of the selected line.  This works 
on individual lines or a selected set of vectors.  The buffer width will be calculated and created assuming the units of 
measurement to be the current map units.

When the Buffer Selected Lines filter is run with the By Column Value option checked,  an area width is calculated 
based on the value(s) related to the selected object(s) in the attribute table.  The area will then be constructed 
based on the line’s attribute value.

When the filter based is run based on an Entered Value,  an Area object is created as calculated by the specified 
value,  in map units.  

Finally choose your  Area Layer in the Target Layer section to place the buffered area object(s) on this layer. 

BUFFER LINES TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
11-i ...  Buffering Lines Using an Entered Value

Line Functions: Buffer Selected Lines

By Column Value - It your line data has a 
column in its attribute table that contains 
buffering values,  click this radio button and 
select the column containing the value.
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Flip Selected Lines
Filter > MAP Lines > Flip Selected Lines

FUNCTIONALITY

The MAPublisher Flip Selected Lines filter switches the beginning and end points of a line.  

Labeling linework in Adobe Illustrator is designed to position labels starting at the beginning of a line,  and the 
orientation of the text depends on the starting point of the line or arc being labeled.  As a result,  cases can occur 
where labels are placed upside down or backwards from where you would like them.  

In order for the labels to be consistent for a group of lines,  flipping some of the lines may be necessary.  
MAPublisher’s Feature Text Label (page 72) and MAP Tagger Tool (page 74) provide an option to Keep Text 
Above Lines.  However,  there may be situations where you wish to flip these lines manually;  for example if you are 
manually entering text on your lines.

You can flip lines on  Line Layers and  Area Layers.  In order to use this filter,  select the lines you wish to flip,  
and then go to Filter > MAP Lines > Flip Selected Lines

Note that if you have negative values for polygons in the ‘MPArea’ column of your MAP Attribute table,  you can use 
Flip Selected Lines to convert the MAPublisher area calculation to a positive value.  When exporting Area layers to 
GIS formats,  polygon outlines must have a positive ‘MPArea’ value.

FLIP LINES TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
11-ii ...  Flipping Lines

Spline Selected Lines
Filter > MAP Lines > Spline Selected Lines

FUNCTIONALITY

The Spline Selected Lines filter improves the smoothness of curved lines and modifies the points on a line in order 
to add extended handles.  These handles can be used to modify the shape of the lines,  more commonly referred to 
as Bezier curves.  Your MAP Layer must be a  Line Layer to use this filter.

First select the lines you wish to spline,  and then go to Filter > MAP Lines > Spline Selected Lines.  The filter acts 
immediately to convert the selected lines to Bezier curves allowing them to be modified by dragging the handles 
that extend from each point.

SPLINE LINES TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
11-iv ...  Smoothing Lines

Line Functions: Flip Selected Lines & Spline Selected Lines
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All Lines / Selected Lines - You can choose to 
join only those lines that have been selected 

or all lines on the selected MAP Layer.

Target Layer - Use this dropdown to select the 
MAP Layer containing the lines you wish to join.

Column - Select the column you wish to base the 
join on.  All lines within the selected proximity 

with matching column values will be joined.

Join Lines
Filter > MAP Lines > Join Lines

FUNCTIONALITY

The Join Lines filter lets you join a set of linear features based on a common value within an attribute column.  For 
example,  it may be desirable to join all segments of a particular street by the common attribute of street name in 
order to create a single line element representing that street.  When the Join Lines filter is run a new layer is created 
containing the joined lines in order to avoid deleting other attributes within the original street layer.  The new MAP 
Layer contains the joined lines with an attribute column representing the joined column.  

Join Lines can be very useful for reducing the size of a data file by joining related lines and thus reducing the 
number of segments and associated data present in the file.  It is also very useful to run Join Lines prior to labeling 
with Feature Text Label in order to eliminate the occurrence of duplicate labels.

PREREQUISITES

Join Lines can only function with  Line Layers,  and can be used on both currently selected lines or all the lines 
on the currently selected layer.  To open the dialog,  go to Filter > MAP Lines > Join Lines.

Output Layer - Enter the name of the 
output layer.  This new layer will contain 
the newly joined lines.

Proximity - This value determines how 
close together (in map units) the lines 
must be in order to be joined.

Line Functions: Join Lines



92 93

USING JOIN LINES

From the Layer dropdown,  select the Line Layer containing the lines you wish to join.  Then specify if you wish to 
join All Lines,  or just the Selected Lines on this layer.  This can be achieved by clicking the appropriate radio button.

In the Column dropdown,  select the attribute column containing the attributes you wish to join together.  For 
example to join lines based on street name,  you should select the column containing the street names.  This will 
result in line segments containing the same street name being joined together*.   

In the Output Layer field you should specify a name for the new  Line Layer that MAPublisher will create to hold 
your joined lines.

A Proximity value should be entered.  This value should be entered in the current units of your Line Layer.  Note that 
entering a proximity value of zero,  will only join line segments that are touching.  
*If the distance between the end of a segment,  and the start of another is greater than the proximity value you enter,  
these lines will not be joined.

When you have entered your preferences for the join click the OK button.  On the newly created Line Layer view 
the layer’s attributes in the MAP Attributes window.  Note that the only attribute columns present are the default 
MPLength column and the attribute column you specified for your join.

JOIN LINES TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
11-iii ...  Joining Lines Based on Attribute Value

Line Functions: Join Lines
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Feature Type - Select the feature type 
(line or area) that you want to simplify.

Selected/All lines - Select whether to 
simplify all the features on the MAP Layer 

or only those that are currently selected.

Proximity Units - Select either page or 
map units to be used for proximity values.

Use bezier curves - Check 
to have simplified lines 

generated as Bezier curves.

Simplify Lines
Filter > MAP Lines > Simplify Lines

FUNCTIONALITY

The MAPublisher Simplify Lines filter allows for the simplification or generalization of imported vector data based 
upon map or page units.  The Simplify Lines function uses the popular Douglas-Peucker algorithm for removing 
nodes and vertices during simplification.  For more information on the Douglas-Peucker algorithm see page A1/40.

Simplify Lines is used to reduce the number of points required to represent a vector-encoded digitized line where 
the lines are approximated by a stream of X-Y coordinates.  The function can be used on  Line or  Area layers 
and removes nodes based upon a proximity value in either Map or Page Units.

The simplify tolerance (proximity value) is based on the vertical difference between the begin-end line and points 
off a line,  NOT the distance between anchor points on the line.  The Douglas-Peucker algorithm takes the proximity 
value you give it and iterates through the line vertices to determine the points that fall within the specified 
tolerance distance off the line and removes those vertices.  Once all vertices are determined to be greater than the 
proximity value off the line the processing ends.  A smaller proximity value will generally result in a fewer number of 
nodes being removed.

USING SIMPLIFY LINES

To open the dialog go to Filter > MAP Lines > Simplify Lines.  Specify if the Feature Type is Line or Area,  and if you 
wish to simplify All Lines on the current layer,  or just the Selected Lines.  Decide if you wish to enter a proximity 
value in Page Units or Map Units.  If you select Map Units you can select the unit from the dropdown.  Page Units 
will be simply the units of the current document.  Enter a proximity value in the units you have specified.  

Check Use bezier curves if you wish to generate curves where nodes have been removed.  Note that many GIS 
applications do not support bezier curves.  If you are planning to export your map to GIS formats you may need to use 
Illustrator’s Add Anchor Points function.

It is always a good idea to experiment with different proximity values in order to achieve the desired results 
particular to your scale and coverage area.

SIMPLIFY LINES TUTORIAL

Please refer to exercise 11-v: “Simplifying Lines”  in the Tutorials PDF.

Line Functions: Simplify Lines

Proximity - Enter the proximity value in the 
selected units for the simplification process.  This 
value represents the minimum distance off the 
line for point removal.  Entering a higher value 
will result in more nodes being removed.

Map units - If you have selected  ‘Map units’  
for the Proximity,  select a map unit to 
use with the specified proximity value.
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Join Points
Filter > MAP Lines > Join Points

 Input Layer - Use this dropdown 
to select the Point Layer containing 

the symbols you wish to join.

All Points / Selected Points
 - You can choose to join only those 

points that have been selected or all 
points on the selected MAP Layer.

Close paths - Check this option to 
generate  an Area layer.  If unchecked,  

a Line layer will be generated.

Sort By Available Columns - Select 
an attribute column containing 

ascending values to sort by.  Then 
click the  ‘Add’  button to add the 

column to the Sort Order.

Output Layer - Enter the name 
of the output layer.  This new 
layer will contain the new lines.

Group By - Specify the attribute 
column containing similar values 
to determine each group of points.

Sort Order - Contains a hierarchical 
list of the columns specified to sort by.  
To remove a column from the Sort 
Order,  click the  ‘Remove’  button.

Move Up / Move Down - You can 
move columns up and down the 
Sort Order hierarchy by clicking 
the appropriate button .  

FUNCTIONALITY

The new Join Points filter lets you join a set of point symbols with a line string based on sorting criteria which exist 
in the attribute structure of the point layer.  For example,  it may be desirable to join points that were originally 
generated by a GPS device,  in order to create line elements connecting these points.  When the Join Points filter is 
run a new layer is created containing a line linking each set of common points,  with the generated layer containing 
the same common attribute column that was used to group the points together.  

PREREQUISITES

Join Points can only function on  Point layers,  and can be used on both currently selected point symbols or all 
the point symbols on a specified layer.  There must be at least two attribute columns on the specified point layer in 
order to use Join Points.  To open the dialog,  go to Filter > MAP Lines > Join Points.

USING JOIN POINTS

From the Input Layer dropdown,  select the Point Layer containing the points you wish to join.  Then specify if you 
wish to join All Points,  or just the Selected Points on this layer,  by clicking the appropriate radio button.  

Specify a name for the Output Layer that this function will generate.  By default,  the program will generate a 
 Line layer.  To generate an  Area layer (by linking the line end to the start) check the Close paths option. 

In the Group By Column dropdown,  select the attribute column containing the common attributes you wish to join 
together.  For example to join points based on a unique ID,  you should select the column containing the common 
ID names.  This will result in point symbols containing the same name being joined together.   
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As each point that is joined will be represented by a node in a line string you must now specify a logical order by 
which the points will be joined.  For example,  it is logical that the point which was captured by a GPS unit first 
should be at the first node in the line string,  with the second and third points being located at the second and third 
nodes.  In order to specify these parameters,  you must choose columns by which to sort your points.  These should 
be attribute columns which contain rising alphabetical or numerical values.  

In the Sort By Available Columns list,  select the primary sorting column.  This should be the attribute column that 
contains the best fit for rising alphabetical or numerical values.  For example if points have rising values from 1 - 10,  
the point with a value equal to 1 will be at the start of the generated line,  and the point with a value equal to 10 will 
be at the end of the line.  When you have selected the column,  click the Add button to place the column into the 
Sort Order list.  If all the values contained in the first  ‘Sort By’  column are unique,  you will not be required to set a 
secondary column.  

If the first  ‘Sort By’  column contained any similar values,  you must specify a secondary column.  Again click on a 
column in the Sort By Available Columns list,  and then click the Add button to place the column in the Sort Order 
list.  Similarly third,  fourth and fifth  ‘Sort By’  columns can be specified in the same manner if previous columns 
contain similar values.  Note that the  ‘Sort By’  columns are a hierarchy with the  topmost specified column being 
used for the primary sort,  then the second,  then third etc.  

To move columns up or down the hierarchy after they have been specified,  simply select the appropriate column in 
the Sort Order list and click either the Up or Down button. 

To remove any  ‘Sort By’  columns from the hierarchy,  select the column in the Sort Order list and click the Remove 
button.  

Note that a maximum of 5 columns can be used to sort points into a logical order.  If the columns specified to sort 
by do not distinguish an ordering between certain points,  the order of these points in the attribute table  (i.e.  the 
order in which they were digitized)  will be used to determine the order of the nodes in the generated line string.

RESULTS

When you have set all your options,  click the OK button to join the points on the specified layer.  An  Area  or 
  Line layer will be generated,  depending on the specified output layer type,  which will be placed in the same 

MAP View as the Input Point layer which has been joined.
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Chapter 12

Scale Bars and
North Arrows

MAPublisher contains tools for plotting accurate scale 
bars and north arrows onto your map.  

Both the Scale Bar and North Arrow tools offer a 
number of different designs that you can choose from,  
and can be placed into your MAP View by using the 
parameters of the current coordinate system.
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Map units for captions/
intervals - Select the desired 
map units to be displayed in 

the caption of your scale bar.  
The text in brackets indicates 

the units of the map data layer.

Page units for captions and 
bar height - Select the desired 

page units to be used for the 
captions in your scale bar and 

to determine the bar height. 

Bar height - Enter the 
desired height of your 

scale bar in page units.

Number of labeled intervals 
- Enter the desired number of 

intervals for the scale bar.

Number of sub-intervals
 - Select the number of sub-

intervals for each subdivided 
scale bar interval. 

Scale Bar
Filter > MAP Legend > Scale Bar

FUNCTIONALITY

MAPublisher contains seven different Scale Bar designs that you may incorporate into your map.  All MAPublisher 
Scale Bars are grouped text and vector art and can be edited as desired.  

PREREQUISITES

To accurately place a Scale Bar your selected layer must contain accurate georeferencing information.  The MAP 
Layer on which you intend to place your Scale Bar must be a  Legend Layer,  and be selected and unlocked.  It is 
also advisable to set your default text size and font before opening this dialog.

The Scale Bar dialog can be accessed by selecting Filter > MAP Legend > Scale Bar.  

ADDING A SCALE BAR

STYLE

Use the Previous and Next buttons to select the Scale Bar design you require.  

Scale Bars and North Arrows: Scale Bar

Select Style - Use the Previous 
& Next buttons along with the 
Scale Bar Preview Panel to 
select the desired scale bar.

Number of horizontal lines - 
Select the desired number of 
horizontal lines to be included 
in the scale bar.  Used with 
certain scale bar styles only.

Label interval - Enter the 
desired interval for the scale 
bar labels in map units.

Number of intervals to 
subdivide - Enter the number 
of scale bar intervals to be 
subdivided.

Add interval left of zero - 
Check this box to have an 
interval placed on the scale bar 
to the left of the zero mark.

Caption Options - Select the 
desired display format for the 
scale bar caption along with
the location (above or below 
the scale bar) of the caption.
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APPEARANCE OPTIONS

In the Map Units for captions/intervals listbox specify the units that you wish the Scale Bar to be based on.  By 
default the captions and intervals in the Scale Bar will be in the units of your current layer.  However you can change 
them here if desired.  The choice you make here will affect your choices in the Interval Options section.

In the Page Units for captions and bar height,  specify Inch,  Centimeter or Millimeter.  This unit is used to specify 
the height of the scale bar,  and also the comparative scale text that you can choose to add to the Scale Bar in 
Caption Options.  

Using the Page Unit you specified,  specify a height for your Scale Bar in the Bar height field.  Depending on the 
style of Scale Bar you have chosen,  you can also specify 1,  2,  or 3,  as the Number of horizontal lines that will 
compose the Scale Bar.

INTERVAL OPTIONS

In the Label interval field,  specify a real-world distance that each interval of the Scale Bar will represent.  This figure 
will be in the Unit you specified in the Map Units dropdown.   

Specify the number of intervals or cells in the Scale Bar by entering a figure in the Number of labeled intervals 
entry field.  

If you wish some of the intervals or cells in the Scale Bar to be additionally subdivided,  choose a figure from the 
Number of intervals to subdivide listbox.  The subdivided cells will begin from the left of the Scale Bar.  The Number 
of sub-intervals that compose these cells can be specified in the next dropdown,  and you can choose to subdivide 
by up to 10 segments.  

You can also choose to Add an interval left of zero by checking that option.

CAPTION OPTIONS

The Caption Options section allows you to add extra information to the generated Scale Bar.  The text that will be 
generated by this tool is indicated in this section.  Other than the option to post the Map Units to the right of the 
labels,  all other caption options can be placed Above or Below the Scale Bar by clicking the appropriate radio 
button.

RESULTS

When you click OK the selected Scale Bar will be placed on the currently selected layer.  You can use Illustrator’s 
editing tools to move the Scale Bar to a desirable location,  and to change its colours,  fonts etc.

SCALE BAR TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
12-i ...  Creating a Scale Bar

Scale Bars and North Arrows: Scale Bar
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Select Style - Use the Previous and Next 
buttons along with the North Arrow Display 

Window to select the desired North Arrow.

North Arrow
Filter > MAP Legend > North Arrow

FUNCTIONALITY

MAPublisher contains eleven different North Arrow styles that you may incorporate into your map.  All MAPublisher 
North Arrows are pieces of grouped vector art and can be edited as desired.  

PREREQUISITES

The MAP Layer on which you intend to place your North Arrow must be a  Legend layer,  and be selected and 
unlocked.   This Legend layer must be hosted by the MAP View that you wish to base the alignment of your North 
Arrow on.  The North Arrow dialog can be accessed by selecting Filter > MAP Legend > North Arrow.  

ADDING A NORTH ARROW

Use the Previous and Next buttons select the North Arrow design you require.  When you click OK the selected 
North Arrow will be placed on the currently selected layer.  The coordinate system of the host MAP View will be used 
to align the North Arrow correctly.

NORTH ARROW TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
12-ii ...  Creating a North Arrow

Scale Bars and North Arrows: North Arrow

North Arrow Display - The selected 
North Arrow is displayed here.
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Chapter 13

Working With Images

MAPublisher contains tools for working with geographic 
raster images such as aerial photography and satellite 
imagery.

The Register Image filter allows you to accurately 
register raster images,  with or without georeferencing 
information,  to your vector map data.  

The Export Image filter provides the functionality to 
export raster images with georeferencing information 
attached.

Georeferencing information for such images are usually 
stored in a separate text file (except GeoTIFF) where the 
image and its associated reference file have the same file 
name but a different file extension.  

The reference file formats that can be read by Register 
Image,  or written to by Export Image are:
Image Report (*.irp) 
TIF World (*.tfw)
JPEG World (*.jpw) (Register Image only)

Table (*.tab)
Listgeo (*.lgo)
GeoTIFF (*.tif ) (a single file containing both the image 
and its reference data)
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Upper Left X/Y - The coordinates 
(in map units) of the upper left 

corner of the raster image. 

Lower Left X/Y - The co-ordinates 
(in map units) of the lower left 

corner of the raster image.

Register Image
Filter > MAP Images > Register Image

FUNCTIONALITY

The Register Image filter is used to accurately register raster imagery to your vector data.   MAPublisher will study 
the parameters of the raster image,  and the coordinate system of a selected MAP Layer,  in the registration process.

PREREQUISITES

In order for this filter to be functional the raster image MUST be in the same projection as the MAP Layer you wish 
to register it to.  You must therefore check the projection of your imagery with your data provider before attempting 
to use Register Image.  It is possible to reproject vector data in MAPublisher first (see the MAP View Editor on page 
49),  if you require your linework to match your imagery.

When you are certain that both your MAP Layer and your raster image are in matching projections,  you can place 
the image into Illustrator.  It is often useful to first set up a special layer to hold your images.  Therefore create a 
new layer and drag it into the MAP View containing your vector layers.  As this new layer will be holding the Image 
only,  you can assign any feature type when you drag the layer to your intended MAP View.  Use Illustrator’s Place 
function (File > Place) to select the image and place it onto your new MAP Layer at a default location.

With the image selected go to Filter > MAP Images > Register Image to open the dialog.

USING REGISTER IMAGE

THE DIALOG AT A GLANCE

The dialog is split into two halves.  The top half requires the input of parameters for the image.  The lower half of the 
dialog will display the georeferencing information of the selected MAP Layer.

Upper Right X/Y - The coordinates 
(in map units) of the upper right 
corner of the raster image.

Pixel Size - The value for the 
pixel size.  This is the relationship 
between one pixel in the image 
and its corresponding real world 
measurements.

Calculate - Automatically 
calculates the coordinates of up 
to two unspecified corners based 
upon the known input coordinates 
and the pixel size.

From File - This button will allow 
you to choose a file containing 
the reference information for 
the selected raster image.  The 
information from the file will be 
inserted into the appropriate fields.

Page Scaling Information - This 
section displays all the scaling 

parameters for the selected layer.

Select Layer - This allows you to 
select the layer that you wish to 

register the image to.

Working With Images:  Register Image
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‘PAGE SCALING INFORMATION’ SECTION

To begin,  select the MAP Layer that contains the coordinate system you wish to register your image to.  This can be 
achieved by selecting a layer from the dropdown in the Page Scaling Information section.

‘IMAGE PARAMETERS’ SECTION

In this section you have three choices.  You can either:

a) Select a Reference file containing the georeferencing information for the image by clicking the From File button.
b) Manually enter the Upper Left,  Lower Left and Upper Right coordinates for the corners of the Image,  as well as 
the Pixel Size.
c) Manually enter the coordinates for one corner of the Image as well as the Pixel Size for the Image.  Leave the 
fields for the other two corners empty and click the Calculate button.

To Select a Reference file click the From File button and navigate to the folder containing your reference file.  The 
reference file will normally be of the same name as your image,  but will have the extension .irp,  .tfw,  .jfw,  .tab,  .lgo,  
or.  tif.  If your image is a GeoTiff you should select your image file in order to retrieve georeferencing information,  
as files of this type will contain both the image and its reference data.  Select your reference file and click Open.  The 
values contained in this reference file will be entered automatically into the Image Parameters section.

If you are aware of the coordinates of the Upper Left,  Lower Left and Upper Right corners of your image you can 
enter them manually in this section.  However you must also enter a Pixel Size,  which is the scale factor of one pixel 
to its corresponding real world measurements.

If you are aware of the coordinates of one corner of your image and the pixel size of the image you can enter these 
values into the dialog.  Click the radio button next to your known corner and clear the values from the X and Y fields 
for the other two corners.  Then simply click the Calculate button.  MAPublisher will then automatically calculate 
parameters for the other two corners based on the values you have entered.

RESULTS

When you are confident that all values have been entered correctly into the Image Parameters section,  and the 
values in the Page Scaling Information are correct for your related MAP Layer,  you can click the OK button.

Providing the coordinate systems of the raster image and the MAP Layer match,  and the values you have either 
entered manually or via a reference file are correct,  the image will be scaled and positioned to coincide with your 
vector data.

REGISTER IMAGE TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
13-i ...  Registering an Image with a Reference File
13-ii ...  Registering an Image without a Reference File

Working With Images:  Register Image
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Store Geography As - Select the 
output format for the georeferencing 

information for the selected image.

Pixel Size X,Y - Enter the X and Y
pixel size values for the selected 

image or use the values for the MAP 
Layer that contains the image.

Byte Order - Select the byte 
order according to the OS 

format for the exported image.

Export Image
Filter > MAP Images > Export Image

FUNCTIONALITY

MAPublisher 6 offers the ability to export previously placed raster files as georeferenced images for use in other 
programs and/or for archival purposes.  This can be useful in a number of ways.  For example,  when working with 
an image for which there is no georeferencing file you can use the MAPublisher Export Image function to create a 
GeoTiff or other georeferenced image file based upon the coordinate system of the host MAP View.

The Register Image filter can be used to accurately position imagery to your vector data.  Alternatively you 
can manually move,  scale or rotate imagery to align with artwork in a designated MAP View.  If your host MAP 
View contains accurate georeferencing information,  you can use Export Image to save out raster data to a fully 
georeferenced image format.  It is also possible to convert your vector artwork to a georeferenced raster image,  
which will be discussed in Tutorial #2 of this section.  

MAPublisher will export the selected image as a TIF,  with a choice of the five reference file formats as discussed at 
the start of the Working With Images section.  

PREREQUISITES

Before attempting to export your image you should check that the Colour Mode of your document is set to the 
desired colour mode that you wish to export your image to.  Therefore any image exported using Export Image will 
be created in either RGB or CMYK.  With the Image selected go to Filter > MAP Images > Export Image.  

Working With Images:  Export Image

Save As -  Choose a destination name 
and directory for the exported image.

X,Y Position - Enter the X and Y 
position values for the upper left 
corner of the image or use the 
values for the MAP Layer that
contains the image.

Rotation X,Y - Enter the X and Y pixel 
rotation angles for the selected image
or use the values for the MAP Layer 
that contains the image.

Color Mode - This is the colour mode (RGB or 
CMYK) for the exported image that is drawn 
from the document colour mode.
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USING EXPORT IMAGE

PIXEL SIZE AND ROTATION VALUE SETTINGS

The dialog will automatically populate the Pixel Size X and Y,  the X and Y Positions,  and the Rotation X and Y fields 
with the parameters of the selected image in the current coordinate system of the MAP Layer on which the image 
is placed.  You can also enter these values manually if you require.

The Pixel Size X and Y fields refer to the scale factor of one pixel to its corresponding real world measurements.  

The X and Y Position fields are for the input of the Upper Left corner of the image in the coordinate system of the 
host MAP Layer.  

The Rotation X and Y fields should contain rotation values for the selected image if these apply.

COLOUR MODE AND BYTE ORDER SETTINGS

The current document colour mode is displayed in the Color Mode field.  This will be the designated colour mode 
that the image will be exported in,  and should not be edited.  The image will always be exported in the current 
colour mode of the document,  whether this is RGB or CMYK.  

The Byte Order will be set by default depending on whether you are using the Mac or Windows version of 
MAPublisher.  You can change this if the image is to be used in the alternative operating system.

‘STORE GEOGRAPHY AS’

The Store Geography as dropdown will list the five available reference file formats.  A regular TIF file will be 
generated with a reference file carrying the extension TFW,  IRP,  TAB or LGO if you choose one of these formats.  If 
you select GeoTiff from this dropdown only the TIF file will be produced,  as this will carry both the image and the 
georeferencing information.

RESULTS

When you have set all of your export options,  click the Save As button.  This will allow you specify a name for the TIF 
file,  and the location where it will be saved.  If the format is a TIF and reference file combination,  the reference file 
will carry the same file name and will be saved to the same location as the TIF.

You can subsequently use this image file in other GIS applications or in other Illustrator documents using 
MAPublisher.

EXPORT IMAGE TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
13-iii ...  Exporting a Placed Image as a Georeferenced Raster File
13-iv ...  Converting an Illustrator Vector File to a Geo-Image

Working With Images:  Export Image
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Chapter 14

Working With Tables

MAPublisher includes several filters and tools for 
importing and viewing external data tables and for 
joining external tables with pre-existing map attribute 
tables.  If,  for example,  you had a map of areas 
representing postal zones and an external data file 
containing sales or population figures by postal zone,  the 
MAPublisher table filters would be used to import the 
external file and join it with the pre-existing postal zone 
map so that the sales or population figures would form 
part of the map attributes table for that layer.

MAPublisher will automatically generate an MPTables 
layer that will store all imported or created tables.  Note 
that deleting the MPTables layer will result in the deletion 
of all currently stored tables.

The following pages will deal with the creation,  viewing 
and management of tables,  as well as the joining of 
external tables to the attribute table of the map data via 
the use of the following tools:
Import Table
Table Records
Table Columns
Join Table
Select Table Records
Create Table
Delete Table
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File Type - Select the type of file you 
are going to import.  The options are 

DBase,  .ddf (SDTS),  and 
ASCII Comma Delimited.

File Name - This is where the name 
of the file that you have selected 

will be displayed.

Table Name - Enter the name you 
wish to use for your table here.  Note 

that this name cannot contain spaces.

Import Table
Filter > MAP Tables > Import Table

FUNCTIONALITY

The MAPublisher Import Table filter lets you import external data tables to merge with existing map data attribute 
tables in order to create a single extended table comprised of the elements of both tables.  

The MAPublisher Import Table filter provides support for three of the most common table formats as follows:
• DBase (*.dbf )
• USGS SDTS (*.ddf )
• ASCII Comma Delimited (*.csv) (*.dat) (*.asc) (*.txt)

USING IMPORT A TABLE

To import a table go to Filter > MAP Tables > Import Table.  

Select the type of file you wish to import from the Type dropdown,  and then click Browse.  This will open a browser 
allowing you to navigate to and select the file you wish to import.  Select your file and click Open to return to the 
Import a Table dialog.  The file you are importing will be shown in the File Name field.

The Table Name entry field will be populated with a default name based on the file selected for import.  You can 
edit this field if required.  Note that table names cannot contain spaces.  If you require a space you must use the 
underscore (_) instead.  

If your table contains column names as headers,  click the Process field header on first line checkbox.  If your file 
does not contain headers do not select this option,  which will result in the default of Column1,  Column2,  etc,  
being the names of the columns that compose the imported table.

Click OK to import the selected table.  MAPublisher will create an MPTables layer in your Illustrator layers palette,  
which will hold the imported table.  You can view the attributes and column structure of your table in the Table 
Records and Table Columns windows (see page 107).

IMPORT TABLE TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
14-i ...  Importing a Table

Browse - Click this button to 
bring up an open file dialog 
where you can locate and select 
the table you want to import.

Process field header on first line – In an ASCII comma delimited 
file,  you may or may not have field headers in the first line of the 
file.  If you do,  checking this box will allow the headers to be used.

Working With Tables:  Import Table
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Table Records / Table Columns
Window > MAPublisher Tables > Table Records

Window > MAPublisher Tables > Table Columns

Working With Tables:  Table Records and Table Columns

Column List - List of columns that 
comprise the currently selected table. 

Table Selection - If you have 
imported or created a number 

of tables,  select the table you 
wish to view with this list.

Table Records - This is the 
area in which the Table 

Records are displayed.

Row Number - A unique 
number for each table entry.  

Click the row number to select 
a row or shift select a number 

of rows in order to delete.

Table Selection - If you have 
imported or created a number 

of tables,  select the table you 
wish to view with this list.

Table Records window

Table Columns window

Name - Specify or Edit the 
name of the column here.

Width - Specify or Edit a width 
in characters for the column.

New/Edit Column

New Column - Click this 
button to begin adding 

a new column.

Delete Column - Click 
this button to delete the 
currently selected column(s).

New Column - Select this option to 
begin adding a new column.

Delete Columns - Select this option to 
delete the currently selected column(s).

Edit Column - Select this option to 
edit a selected column.

Type - Specify the type of column* 
(Character,  Integer,  Real,  Boolean) 
to create (* Can only specify when 
creating a new column).

This dialog will open when clicking 
‘New Column’ or ‘Edit Column’.

Click and drag to 
resize the columns.

Apply - If you have made 
any changes to the 
attribute table,  you must 
click here to apply them,  
otherwise any changes 
you made will be discarded 
when the window is closed.

Del - Deletes the selected 
record from the table.

Add - Adds a new blank record to the end of 
the table.  Once a blank record has been added,  
you can enter values into each of its fields.

Sel / All - Use this button to toggle between viewing 
the whole table and viewing only those records that 

have been selected using Select Table Records.
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FUNCTIONALITY

Table Records and Table Columns allow you to view and edit data tables which exist on the MPTables layer.  These 
functions will open in the same palette allowing you to use the tabs to toggle between the two windows,  and are 
accessed by going to Window > MAPublisher Tables > Table Records OR Table Columns.

USING THE TABLE RECORDS WINDOW

This window lets you display the Table Records for a table or for selected parts of it.  Only the records of a single 
table will be displayed in the window at a given time.  If multiple tables exist on the MPTables layer,  you can toggle 
between these tables by choosing from the Table dropdown.   Also the values displayed in the Table Records 
window may be sorted by column value by double-clicking on the column heading,  and the widths of the columns 
may be changed by clicking on the column separator and dragging it as desired.

EDITING RECORDS

MAPublisher’s Table Records window is a fully editable spreadsheet environment.  All table entries can be edited.  
To change the value of a cell double-click on the cell and enter the new value such as you would in a spreadsheet 
program.  Keep in mind that you must enter values that correspond with a column’s type (i.e.  only enter numbers 
into a column of type “Real”).  After making the changes click the Apply button to set the edits permanently into the 
map file’s database record.  Closing the window without clicking Apply will discard any changes you have made.  
Note:  Mac users only - After making edits to cell values within the Table Records window you should click in an alternate 
cell in the Table Records window before clicking the Apply button,  otherwise the edits may not be recorded.

ADDING AND DELETING RECORDS

The Table Records window also allows you to Add or Delete table entries,  by clicking the Add or Del buttons 
respectively.  To delete single table entries click the row number at the left of the window and click the Del button.  
To delete multiple table entries shift select the rows before clicking this button.  Adding a table entry will place a 
new row at the top of the window.

SELECTING SPECIFIC RECORDS

In order to view table entries selected in Select Table Records (page 114) click the Sel button.  When these elements 
have been selected,  the button will change to All,  allowing you to click again to view all the contents of the table.

USING THE TABLE COLUMNS WINDOW

The Table Columns window allows you to view,  edit,  create and delete table columns.  Only the records of a single 
table will be displayed in the window at a given time.  If multiple tables exist on the MPTables layer,  you can toggle 
between these tables by choosing from the Table dropdown.   

Working With Tables:  Table Records and Table Columns
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ADDING,  DELETING AND EDITING COLUMNS

Any changes you make within the Table Columns window will instantly update the Table Records window.  

To add a new column click the New button at the base of the window,  or go to Options > New Column.  This will 
open a dialog allowing the specification of a Name,  Width (in characters) and a column Type.  Imported tables will 
have up to four types of attribute columns,  and these principals must be considered if you add columns to a table 
using the New Column function.  The column types are Character,  Integer,  Real and Boolean.  
Character columns will contain attributes that are alphanumeric,  for example columns containing letters or 
numbers,  or a combination of both.  
Integer columns contain only whole numbers.  
Real columns contain numbers carrying decimal values.  
Boolean columns contain purely True or False values.  

To edit the properties of a column select the column and go to Options > Edit Column.  Note that if you decide to 
edit the properties of a column via the Edit Column palette option,  you will be unable to change the column type.  
To delete a column or number of columns,  select the column(s) in this window and click the Delete button,  or go to 
Options > Delete Columns.

TABLE RECORDS & TABLE COLUMNS TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
14-ii ...  Viewing,  Editing,  and Deleting Table Records
14-iii ...  Adding a New Column to a Table

Working With Tables:  Table Records and Table Columns
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Source Table - This is the imported or created 
table you want to join to a MAP Attribute table.

Match Column - Select the column from your 
Source Table that matches a column from the 

MAP Attribute table of the Target MAP Layer.

Linear match/Ordered match - Select 
whether you wish to perform a linear 

or an ordered match.

Case-sensitive - When this is checked,  the 
column entries from the two selected match
columns will be matched up case-sensitively.

Join Table
Filter > MAP Tables > Join Table

FUNCTIONALITY

The MAPublisher Join Table filter joins an imported or created data table to a selected target MAP Layer based 
upon common or matching fields and columns.  The matching columns are not required to have matching names.

PREREQUISITES

To use Join Table you must have both a MAP Layer and a Data Table which contain one common attribute 
column that contains similar fields.  View the attributes of each attribute table using the MAP Attributes & Columns 
windows,  and the Table Records & Columns windows.  If you have a matching column,  proceed to this dialog by 
going to Filter > MAP Tables > Join Table.

USING JOIN A TABLE

THE DIALOG AT A GLANCE

The Join Table dialog is split into two sections.  The upper section deals with the parameters of the Source Table,  
i.e.  the data table that is contained on the MPTables layer.  The lower section is for the input of parameters for the 
destination layer,  i.e.  the Target Table that is connected to the vector features on a MAP Layer.

SOURCE TABLE SETTINGS

Select the data table that you wish to join to the attributes of the vector data.  This can be achieved by choosing a 
table on the MPTables layer from the Source Table dropdown.  In the Match Column dropdown,  choose a Column 
of the data table that contains the fields you wish to match to the destination attribute table.  

TARGET TABLE SETTINGS

Choose the attribute table that you wish to join the data table to.  This can be achieved by choosing a MAP Layer 
from the Target Layer dropdown.  In the Match Column dropdown,  choose a Column in the attribute table of the 
MAP Layer that contains the fields you wish to match the Source Table to.

Target Layer - Select the MAP Layer containing 
the MAP Attribute table you are going to join the 
source table with.

Match Column - Select the column from the 
MAP Attribute table of your Target Layer that 
matches a column from the Source Table.

Working With Tables:  Join Table
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JOIN METHOD SETTINGS

Choose if you require a Linear match or an Ordered match.  

Linear match will result in a slower matching process than setting it to Ordered Match but the Source Table and 
Target Table do not have to be sorted first.  

Ordered match is faster but requires that the records in both the Source Table and Target Table are pre-sorted on 
the Match Columns so that like (matching) values are in the same position.

If the Case-sensitive option is checked,  the column entries from the two matching columns will only be matched 
by case.  For example if you have a mixture of upper or lower case entries in the data table that is mirrored in the 
destination attribute table you should check this box.  If one of the matching columns contains values in lowercase,  
and the other contains values in uppercase,  for example,  you should not check this box.

RESULTS

When you click OK the data table on the MPTables layer will be added to the attribute table on the destination MAP 
Layer.  To view the addition of these attributes,  open the MAP Attributes window.  Notice that the matching column 
in your data table has also been added,  but has been appended with a ‘J’ (for ‘Joined’).  This column can be removed 
in the MAP Columns window if you require.

Note there is additional information regarding Joining SDTS Tables,  on page A1/37.

JOIN TABLE TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
14-iv ...  Joining a Table to a MAP Attribute Table

Working With Tables:  Join Table
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Select Table Records
Filter > MAP Tables > Select Table Records

FUNCTIONALITY

The MAPublisher Select Table Records filter allows you to select a particular set of records from an imported or 
created table.  The selected fields can be viewed when opening the Table Records window and clicking the Sel 
(Select) button.  This function is very similar to Select by Attribute (page 40) where selections are made based on 
attribute information.  A particular column is selected and then a logical expression is built defining the desired 
features for selection.  

PREREQUISITES

To use Select Table Records you must have a data table that exists on the MPTables layer.  Open the dialog via Filter 
> MAP Tables > Select Table Records.  

Working With Tables:  Select Table Records

Column - Select the 
column on which you 

wish to base your query. 

Build Expression 
- Displays the current 

expression.  This will 
update if you change the 
expression’s parameters.

Final Expression - After 
clicking Insert,  the Build 

Expression is moved into 
this box.  This is the final 

expression that will be 
assigned to the elements 

when you click OK.

Ignore case in strings
 - If this is checked,  any 

expression that 
compares string (non-

numeric) values will be 
case insensitive.

a value from the list or 
enter one manually in 
the textbox.

Value B - These are only 
made available if the 
selected comparison is a 
“Between” type in which 
case the second value 
will be entered here.

Insert - Moves the build 
expression into the 
Expression box.

Boolean Operators - 
You can use brackets,  
AND,  OR and NOT 
operators to create 
a more complex 
expression involving 
multiple inserts of build 
expressions.

Clear Expression - 
Clears the expression 
box allowing you to 
insert a new expression.

Table - Allows you 
to select the table 
you wish to query.

Comparison - A list of operators to 
help you build your expression - i.e.  
Equal to,  Greater than,   etc.

Value A - There are two parts to this parameter - a 
textbox and a dropdown list containing all unique 
values from the selected column.  You can select

Selection Type - There are 5 types of selections you can make - Initial (used when 
nothing is currently selected),  Add to (used when you need to add to the current 
selection),  Remove from (used when you need to remove features from the current 
selection),  Select from (where you limit the features being searched to those 
already selected) and Reverse (where the current selection is simply reversed).
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USING SELECT TABLE RECORDS

ENTERING EXPRESSIONS

In the dialog you must first select the data table on which you want to make a selection by choosing from the Table 
listbox.  Then select an attribute Column in the data table,  a Comparison,  and a choice of Values,  in order to build 
an expression.  Values can either be entered manually or by choosing from the dropdowns.   The Expression will be 
displayed as you make selections and enter values in the Build Expression section.

When the expression has been built you must click the Insert button.  The Boolean Operator Buttons can be used 
if you wish to use multiple columns or values in order to generate an expression.  If you make a mistake at any time,  
click the Clear Expression button.

SELECTION OPTIONS

This filter has five selection options: Initial selection,  Add to selection,  Remove from Selection,  Select from 
selection and Reverse select.  

Initial selection is used when there is no current selection.  
Add to selection will add the results of the query to any currently selected features.  
Remove from selection will remove the results of the query from the current selection.  
Select from selection will only query those features that have already been selected.  
Reverse select will select the features that do not match the specified expression.

Select Table Records also contains an option to Ignore case in strings.  If this option is checked,  any expression that 
compares non-numeric values will not differentiate between characters in upper and lower case.  

RESULTS

When you have entered a valid expression,  click OK to make your selection.  Then open the Table Records window 
and click the Sel button to view the selected fields.  Click the same button again (it will now be named All) to return 
to the full attribute list.  You can subsequently toggle back and forth between Sel and All.

SELECT TABLE RECORDS TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
14-v ...  Selecting Specific Table Records

Working With Tables:  Select Table Records
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Name - Enter the name of your new table in this field.  
Note that this name should not contain spaces.

Create Table / Delete Table
Filter > MAP Tables > Create Table
Filter > MAP Tables > Delete Table

Table -  Select the existing table you wish to delete.

CREATING NEW TABLES

MAPublisher allows you to also create your own custom tables to merge with existing map data attributes.  New 
tables can be created by going to Filter > MAP Tables > Create Table.  Specify a Name for your new table and click OK.  
If you do not previously have an MPTables layer,  this operation will create one.  You should then use Table Records 
and Table Columns to build the attributes for your new table.

DELETING TABLES

Similarly you can easily delete any previously imported or created tables.  Open the dialog by going to Filter > MAP 
Tables > Delete Table.  Select the Table you wish to delete and click OK.  Note that MAPublisher will not delete the 
MPTables layer even if all the tables have been deleted.  You must remove the MPTables layer manually by using 
Illustrator’s Delete Layer function.

CREATE & DELETE TABLE TUTORIALS

Please refer to the following exercises in the Tutorials PDF:
14-vi ...  Creating a New Table
14-vii ...  Deleting a Table

Working With Tables:  Create Table and Delete Table
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Chapter 15

Drawing Tools

In MAPublisher 6,  any artwork you create on a specified 
MAP Layer using Illustrator’s drawing tools will be 
incorporated into the map data on that layer,  and can 
therefore be rescaled or reprojected with the existing 
data.  If the new artwork is of the same feature type as 
the MAP Layer,  they will be automatically added to the 
attribute table of that layer.  Therefore it is very easy to 
quickly add features to MAP Layers.

MAPublisher also provides two if its own tools,  which 
are designed to draw rectangular or elliptical areas of 
specified dimensions in Map Units.  The MAP Area Tools 
will be discussed in this section.
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Width/Height - Enter the width and 
height for the area to be drawn.

MAP Area Tools
Main Toolbar > MAP Area Tool (Box)  

Main Toolbar > MAP Area Tool (Ellipse)  

FUNCTIONALITY

By using the MAP Area tools,  areas of exact map dimensions can be quickly added to any MAP Layer and its 
related attribute table.  This tool can also be useful for measuring distances from a specific location,  by using the 
MP attribute column(s) in the MAP Attributes window.  Whenever an area is created using the MAP Area tools,  any 
objects that fall inside the area (in whole or part) will be automatically selected.  

PREREQUISITES

In order for the area tools to draw properly and return real world values for MPArea and MPPerimeter,  the MAP 
Layer must be projected (i.e.  not in Lat/Long).  See the MAP View Editor (pages 51-53).

MAPublisher offers Ellipse and Rectangle drawing tools.  Select whichever shape you require from the main 
Illustrator Tools palette,  and select the MAP Layer in the Illustrator Layers palette which contains the coordinate 
system on which you want to draw the shape.

USING THE MAP AREA TOOLS

OVERVIEW

There are two methods of using the MAP Area tools.  As with Illustrator shape tools you can either click and drag to 
create a shape at an unspecified size.  Alternatively you can single click in the MAP document to open the Add Area 
dialog,  where you specify exact width and height values for the shape.

DRAWING VIA CLICK AND DRAG

To draw shapes at unspecified sizes,  click and drag over the Map document while holding down the left mouse 
button until the desired area has been outlined,  as is done with the standard Illustrator area drawing tools.  Use 
the Alt key (Windows) or the Option key (Mac) to draw from the centre and/or the Shift key to constrain the 
proportions.  When you release the mouse button the area will be created.

Drawing Tools: MAP Area Tools

Center area on click - Check this option 
if you want the area to be drawn centered 
on the click point.
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ENTERING SPECIFIC DIMENSIONS

To draw shapes at specified sizes,  single click at a point in your Map document at the location from which you wish 
to plot the shape.  The MAPublisher Add Area dialog will appear into which you can enter specific dimensions for 
the area to be drawn.  The parameters you enter should be in the same units as your current MAP Layer.

If you wish to have the area centered over the click point simply check the Center area on click box.  If you do not 
check this box an area will be drawn from its upper left corner.  

Click OK to plot a shape using the dimensions you entered.

RESULTS

Plotting a shape using either of these methods will initially select the features that fall,  inside the area (in whole or 
part).  Therefore,  these tools can be also useful for selecting features that are within designated distances away from 
a central location.

MAP AREA TOOLS TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
15-i ...  Creating Shapes with Specific MAP Dimensions

Drawing Tools: MAP Area Tools
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Chapter 16

Layer Management

Managing the often large amount of layers that compose 
a mapping project is crucial for minimizing file size 
and for assisting in projects passed between several 
individuals or departments.

The Merge Layers function described in the MAP Views 
chapter assists for the combining of whole Illustrator 
layers.  However there may be scenarios where you 
wish to move certain graphics only into alternate layers.   
MAPublisher offers functionality to move data safely 
between layers using its own Copy and Paste tools.

The Copy MAP Object and Paste MAP Object functions 
will be discussed in this section.
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FUNCTIONALITY

The MAPublisher MAP Copy/Paste function is designed to safely copy and paste MAPublisher objects between 
MAP Layers while retaining the geographic and attribute characteristics of the objects.  In order to copy and paste 
map data safely you should use the MAP Copy and Paste Object tools which can be found under Object > MAP Copy 
Object.  Copying and pasting MAPublisher objects using the native Illustrator Copy and Paste functions may result 
in the loss of attribute and geographic data for the objects involved.  MAP Copy and Paste will also allow for non-
MAPublisher objects to be copied and pasted independently or in conjunction with MAPublisher objects.

The difference between this function and the Merge Layers tool (see page 48) is that selected artwork can be 
merged with another layer,  rather than all the data on a particular layer.

PREREQUISITES

An important point to remember prior to using MAP Copy/Paste is that in order for this function to perform 
correctly,  both the destination and output layer (i.e.  the layer you are copying from,  and the layer you are pasting 
to),  must have identical georeferencing information.  The safest methodology to use is to only copy and paste 
between layers that exist inside a single MAP View.

Regarding attribute information,  note that if the destination and output layer both have attribute structures,  these 
attribute structures must match.  Check the attribute structures of both layers by using the MAP Attributes and 
MAP Columns windows.  However,  you can also safely copy attribute information if the destination layer does not 
contain any attribute information,  as is the case with a new MAP Layer.

USING MAP COPY AND PASTE

To select an object or group of objects for copying simply select the desired objects using any of the Adobe 
Illustrator or MAPublisher selection tools and then go to Object > MAP Copy Object > Copy MAP Object(s).  The objects 
will then be placed on the clipboard.

To paste the chosen object(s) to another layer select the destination layer from the Illustrator layers palette and 
then select Object > MAP Copy Object > Paste MAP Object(s).  The objects will then be placed on the destination layer.  
Pasted objects are placed in the same location on the document from where they were copied.   Note that the Paste 
MAP Object(s) menu item will be greyed-out and inaccessible if a MAPublisher Paste operation is not permitted.

Note that objects may NOT be copied and pasted between documents using the MAP Copy/Paste tools.  Also 
objects that have been deleted prior to having been pasted on a new layer will not be copied to the new layer.  If 
you wish to remove objects from the initial layer you must delete them AFTER pasting them to the new layer.

MAP COPY AND PASTE TUTORIAL

Please refer to the following exercise in the Tutorials PDF:
16-i ...  Copying and Pasting between MAP Layers

MAP Copy & Paste
Object > MAP Copy Object > Copy MAP Object(s)
Object > MAP Copy Object > Paste MAP Object(s)
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Graphic File Formats

Technical Reference Guide: File Formats

AI
The Adobe Illustrator (AI) native postscript file format.  Please refer to the Adobe Illustrator User Guide for more 
information.

DOQ
Digital Orthophoto Quadrangle (DOQ) are geographic images from the United States Geological Survey (USGS) and 
are stored in the JPG format.  They can be placed by Adobe Illustrator and registered by the MAPublisher Register 
Image filter.  DOQ’s are usually very large files (30-40 MB or more) and will require extremely large amounts of RAM.

DRG
Digital Raster Graphics (DRG) are scanned images of published topographic maps from the USGS stored in TIF 
format.  They can be placed by Adobe Illustrator and registered by the MAPublisher Register Image filter.  DRG’s 
are also usually very large files (30-40 MB or more) and will require extremely large amounts of RAM for any 
manipulation within Illustrator.

EPS
The Encapsulated Post Script (EPS) file is used to transfer PostScript language artwork between applications (also see 
PostScript in the glossary section of the User Guide).  EPS files are easily opened by Adobe Illustrator because the 
format is widely supported by most graphics programs.  It is the preferred format for export to most illustration and 
page-layout programs.  EPS files are by their nature vector based,  but can contain embedded raster graphics and 
fonts.

GIF
Graphic Interchange Format (GIF) is a colour-indexed graphics format,  commonly used for web pages and image file 
transfer.  Adobe Illustrator can export 8-bit indexed-colour or grayscale gifs.

JPEG
Joint Photographic Experts Group (JPEG or JPG) is a compression technique for raster file formats.  The Digital 
Orthophoto Quadrangle geographic images from the USGS are stored in this format,  which can be imported by 
Adobe Illustrator and registered by the MAPublisher Register Image filter.  DOQ’s are usually very large files (30-40 
MB or more) and will require extremely large amounts of RAM.

PDF
Portable Document Format (PDF) is a standardized format developed by Adobe for use across Macintosh,  Windows,  
DOS,  and UNIX platforms.  Based on the PostScript Level 2 language,  PDF supports both raster and vector graphics.

TIFF/GEOTIFF
Tagged Image File Format (TIFF or TIF) is a common raster graphic file format that can be imported by Adobe 
Illustrator.  Many raster geographic images from GIS systems are stored in this format,  which can be imported by 
Adobe Illustrator and registered by the MAPublisher Register Image filter.  A GeoTIFF is a TIFF file with embedded 
geographic information identifying its position and scale in world co-ordinates.

OTHERS
Please refer to the Adobe Illustrator User Guide for other graphics file formats supported by Adobe Illustrator.
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This section contains descriptions of the GIS formats supported for import by MAPublisher using the FME engine.  
Here you will find an overview of the structure of each format,  as well as information on supported format versions 
and elements unique to each data type.  Each file format will carry a checklist covering which core elements are 
supported by MAPublisher during its import.  You can also refer to the Frequently Asked Questions section in this 
guide for information on any issues associated with the various file formats.  Also see the File Formats section on 
pages 20 to 22.

FME documentation on these formats can be found by visiting the following link:
http://www.safe.com/products/fme/formats/index.php

AUTOCAD DRAWING (*dwg) and DRAWING EXCHANGE (*.dxf)

There are two formats used by AutoCAD: DXF (drawing exchange format) files,  which are large; and ASCII 
representations of the binary DWG (drawing) files.  Logically,  both files are identical and,  therefore,  the FME treats 
both file types in the same manner.

 Supported Elements   Supported Geometry
 Typical File Extensions  *.dwg,  *.dxf Aggregate  No
 Automated Translation Yes  Circles   Yes 
 User-Defined Attributes  Yes  Circular Arc Yes 
 Coordinate System Support  No  Elliptical Arc  Yes 
 Generic Colour Support  Yes  Ellipses   Yes 
 Spatial Index   Never  Polygon   Yes
 Schema Required   Yes  Donut Polygon  Yes
 Transaction Support  No  Point   Yes
 Geometry Type Attribute  autocad_entity Line   Yes
      Text   Yes
 Supported Versions
  Windows:  Releases 09 to 14,  2000,  and 2004.
 Macintosh:  Releases 09 to 14,  and 2000.  

Prior to the import process,  additional Settings can be made,  which will affect how the selected file will import.  The 
following parameters can be applied to the import:

• Group Entities - Group entities by Layer Name,  Geometry or build Attribute Schema by scanning extended  
 entity data.  The default is to Group Entities by Layer Name.
• Blocks - Check this box if you want to explode blocks and return the entities that form the components of the  
 block as separate features.  The default is Yes (to Expand Info Entities).
• Visual Attributes - Check this box if you want each visible attribute to be returned as a single text feature.  The  
 default is Yes (to Expand Info Text Entities).
• Paper Space - Setting to ‘Read’ will instruct MAPublisher to also read the entities from paper space.  By default,   
 MAPublisher will only read the entities from model space.
• Bulge Handling - Determines how AutoCAD curves are handled on import.  By default, the arcs are approximated  
 by splitting them into a series of connected segments (vectorized).  In rare cases when the number of points on  
 the map becomes a critical consideration, an approximation with smooth Bezier curves can be specified.  Note  
 that this method is not precise and may introduce visible inaccuracy for the points along the curve,  so it should  
 only be used when a high amount of precision is not a consideration.

Technical Reference Guide: File Formats
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ESRI ARCINFO EXPORT (*.e00)

ArcInfo Export (e00) is a format,  either ASCII or compressed into binary,  which is used to transfer files between 
different versions of ArcInfo.  It is a commonly found format for freely distributed data such as that found at the GIS 
Data Depot (http://www.gisdatadepot.com).

A single E00 file describes a complete ArcInfo coverage.  The file itself is actually an archive of several smaller files,  
referred to as subfiles.  Some of these subfiles have fixed names which do not vary from coverage to coverage,
and follow a predefined data format.  The remainder of the subfiles contained within an E00 are the info files.  These 
files may contain user-defined attributes,  and have names which vary from coverage to coverage.  

 Supported Elements    Supported Geometry
 Typical File Extensions  *.e00   Aggregate  No
 Automated Translation Yes   Circles   No 
 User-Defined Attributes  Yes   Circular Arc Yes 
 Coordinate System Support  Yes   Elliptical Arc  Yes 
 Generic Colour Support  No   Ellipses   No 
 Spatial Index   Never   Polygon   Yes
 Schema Required   Yes   Donut Polygon  Yes
 Transaction Support  No   Point   Yes
 Geometry Type Attribute  e00_type   Line   Yes
       Text   Yes  

There are essentially four types of geometry defined in E00 files,  which will be reproduced as layers during import:
Arcs (lines),  Points,  Polygons,  and Text.   Prior to the import process,  an additional Setting can be made:

• Tic points layer - This option enables you to include an additional layer which will hold the registration points for  
 the imported data.  The default is to set to Yes.

ESRI ARCINFO GENERATE (*.gen)

ArcInfo Generate files are ASCII coordinate files created from ArcInfo coverages through the use of the ArcInfo 
Generate command.  Generate is a useful mechanism that allows you to transfer ArcInfo GIS data to MAPublisher.  
There are several types of Generate files,  and currently point,  line,  and text Generate files are
supported.  All Generate file names are required to end with a .gen extension.

 Supported Elements    Supported Geometry
 Typical File Extensions  *.gen   Aggregate  No
 Automated Translation Yes   Circles   No 
 User-Defined Attributes  No   Circular Arc No 
 Coordinate System Support  No   Elliptical Arc  No 
 Generic Colour Support  No   Ellipses   No 
 Spatial Index   Never   Polygon   No
 Schema Required   Yes   Donut Polygon  No
 Transaction Support  No   Point   Yes
 Geometry Type Attribute  arcgen_geometry  Line   Yes
       Text   Yes  

Technical Reference Guide: File Formats
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ESRI SHAPEFILE (*.shp)

ESRI shapefiles are binary files used to export data with attributes from both ArcInfo and ArcView.  Shapefiles store 
both geometry and attributes for features; however no topological information is carried in a shapefile.  

A single logical shapefile consists of three physical files,  each with one of the following file name extensions:
*.shp : Geometric data
*.shx : Index to the geometric data
*.dbf : Attributes for the geometric data

These extensions are added to the base name of the shapefile,  creating separate physical files that must all reside 
in the same directory.  You must select the *.shp file for import.  Point,  multipoint,  polyline,  and polygon geometric 
data can be stored in *.shp files.  However,  a single *.shp file can contain only one type of geometry.  Each entity in 
a *.shp file has a corresponding entry in the *.shx index file and a corresponding row of attributes in the associated 
*.dbf file.  The order of the entries in each of these files is synchronized.  For example,  the 3rd geometric entity in the 
*.shp file is pointed to by the 3rd entry in the *.shx index file and has the attributes held in the 3rd row of the *.dbf.  

A single shapefile may also consist of a number of additional files,  with the following file name extensions:
*.sbn / *.sbx :  Spatial index files for the geometric data.  These two files are only generating by an ESRI product.
*.prj : Spatial coordinate system information.

If a *.prj file exists in your shapefile directory,  holding the projection information of the shapefile,  this will 
automatically be read by MAPublisher on import.  If your shapefile folder does not contain a .prj file you will be 
required to specify the projection in order to fully utilize MAPublisher.  

 Supported Elements    Supported Geometry
 Typical File Extensions  *.shp (*.shx,  *.dbf,  *.prj) Aggregate  Yes
 Automated Translation Yes   Circles   No 
 User-Defined Attributes  Yes   Circular Arc No
 Coordinate System Support  Yes (if have *.prj)  Elliptical Arc  No
 Generic Colour Support  No   Ellipses   No 
 Spatial Index   Optional   Polygon   Yes
 Schema Required   Yes   Donut Polygon  Yes
 Transaction Support  No   Point   Yes
 Geometry Type Attribute  SHAPE_GEOMETRY  Line   Yes
       Text   No

Technical Reference Guide: File Formats
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MAPINFO INTERCHANGE (*.mif/*.mid)

The MIF is a published ASCII format used by the MapInfo product for input and export purposes.  The MapInfo 
Reference Manual describes the MIF format and all constants it uses for colour,  style,  symbol,  and fill patterns.  
MapInfo Interchange Format Files are often called MIF or MIF/MID files.  

A single logical MIF file consists of two physical files,  having the following file name extensions:
*.mif : Geometric data
*.mid : Attributes for the geometric data

These extensions are added to the base name of the MIF file,  creating separate physical files that must all reside in 
the same directory.   You must select the *.mif file for import.
Each entity in a *.mif file has a row of attributes stored in an associated *.mid file.  A single .mif file contains many 
different types of geometry however,  the associated attribute in the *.mid file must have the same number and 
type of fields for each entity in the *.mif file.  The order of the entries in the two files is synchronized.  For example,  
the second geometric entity in the *.mif file has the attributes held in the second row of the *.mid file.  The number 
and type of attributes associated with each entity is specified by the user.  There must be at least one attribute field 
in the *.mid file.

 Supported Elements    Supported Geometry
 Typical File Extensions  *.mif (*.mid)  Aggregate  Yes
 Automated Translation Yes   Circles   Yes 
 User-Defined Attributes  Yes   Circular Arc Yes
 Coordinate System Support  Yes    Elliptical Arc  Yes
 Generic Colour Support  Yes   Ellipses   Yes 
 Spatial Index   Never   Polygon   Yes
 Schema Required   Yes   Donut Polygon  Yes
 Transaction Support  No   Point   Yes
 Geometry Type Attribute  mif_type   Line   Yes
       Text   Yes

The MAPublisher MID/MIF importer supports the storage of point,  line,  polyline,  arc,  ellipse,  rectangle,  rounded 
rectangle,  region (polygon),  and text geometric data in .mif files.  Each geometric entity present in a *.mif file has 
display properties such as pen and brush width,  pattern,  and color.   Supported MID MIF properties are as follows:

MAPublisher 6 supports the import of line weights (0-7),  colours (24 bit RGB),  strokes (1-71).  It also supports fonts 
(family,  style,  justification) for text.  In order to use line patterns and fill patterns you must have opened or 
accessed the style library equivalents.  Two library files have been created,  ‘MIF_LineStyles.ai’  & ‘MIF_AreaStyles.ai’,  
which provide support for many of the standard MapInfo pen styles (stroke patterns) and brush styles (fill patterns).  
These files can be found in the utilities folder on your MAPublisher CD.  Please refer to your Adobe Illustrator User 
Guide for details about how to add these libraries to your Adobe Illustrator Style palette. 

Technical Reference Guide: File Formats
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MAPINFO TABLE (*.tab)

The MapInfo TAB format is a proprietary format used by the MapInfo Professional Desktop mapping product.  
MapInfo native format files are often called Tab files.  The MapInfo TAB importer is closely patterned after the
MapInfo MIF/MID reader and writer.  This commonality makes it easy to support both MIF and MapInfo native 
formats in the same mapping file.  MapInfo is a two-dimensional (2D) system with no provision for transferring 
elevation data for each vertex in a MapInfo feature.  

A single logical TAB file consists of a number of physical files,  having the following file name extensions:
*.tab : The main file for a MapInfo table,  it is associated with the appropriate dat,  map,  id and ind files.
*.dat : Tabular data for a table in MapInfo’s native format
*.id : An index to a MapInfo graphical objects (MAP) file.
*.map : Contains geographic information describing map objects
*.ind : An index to a MapInfo tabular (DAT) file

These extensions are added to the base name of the TAB file,  creating separate physical files that must all reside in 
the same directory.   You must select the *.tab file for import.

 Supported Elements    Supported Geometry
 Typical File Extensions  *.tab (*.dat, *.id, *.map, *.ind) Aggregate  Yes
 Automated Translation Yes   Circles   Yes 
 User-Defined Attributes  Yes   Circular Arc Yes
 Coordinate System Support  Yes    Elliptical Arc  Yes
 Generic Colour Support  Yes   Ellipses   Yes 
 Spatial Index   Always   Polygon   Yes
 Schema Required   Yes   Donut Polygon  Yes
 Transaction Support  No   Point   Yes
 Geometry Type Attribute  mapinfo_type  Line   Yes
       Text   Yes

The MAPublisher TAB importer supports the storage of point,  line,  polyline,  arc,  ellipse,  rectangle,  rounded 
rectangle,  region (polygon),  and text geometric data in .tab files.  Each geometric entity present in a *.tab file 
has display properties such as pen and brush width,  pattern,  and color.   Supported TAB properties match those 
described for MID MIF files on the previous page.

Technical Reference Guide: File Formats
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MICROSTATION DESIGN (*.dgn)

MicroStation Design Files or DGN (.dgn) are the native files created by Bentley Systems Inc.’s MicroStation product.  
Design files consist of a header,  followed by a series of elements.  The header contains global information including 
the transformation equation from design units to user coordinates,  as well as the dimension of the elements in 
the file.  Each element contains standard display information,  such as its colour,  level,  class,  and style,  as well as a 
number of attributes specific to its element type.  For example,  a text element has fields for font,  size,  and the text 
string in addition to the standard display attributes.

Individual design file elements must be less than a system-imposed maximum number of bytes.  Complex elements 
solve this problem by physically grouping individual elements together into an object that will be manipulated as a 
whole.  MAPublisher supports the import of complex shapes.

 Supported Elements   Supported Geometry
 Typical File Extensions  *.dgn  Aggregate  No
 Automated Translation Yes  Circles   Yes 
 User-Defined Attributes  No  Circular Arc Yes
 Coordinate System Support  No   Elliptical Arc  Yes
 Generic Colour Support  Yes  Ellipses   Yes 
 Spatial Index   Never  Polygon   Yes
 Schema Required   No  Donut Polygon  Yes
 Transaction Support  No  Point   Yes
 Geometry Type Attribute  igds_type Line   Yes
      Text   Yes
 Supported Versions
  Windows:  95,  SE,  J,  V8.    Macintosh:  95,  SE,  J.

Prior to the import process,  additional Settings can be made,  which will affect how the selected file will import.  The 
following parameters can be applied to the import:

• Group Elements By - Choose how you want to group the elements of the file on import.  If you group the  
 elements by level,  it may result in a large number of output files.  ‘By Level’ is the default.
• Linkage Extraction - Linkage Extraction boxes allows you to extract MSLinks and/or FRAMME attribute linkage  
 values from the Source Design File.  Only the first three linkage values will be extracted.
• Cells - Check ‘Expand Cells’ if you want the cells expanded into separate features.
• Tags - Check this box to display tags.  Elements in a design file may have user-defined attributes (tags) attached  
 to them which can be read by MAPublisher.
• Coordinate Units -Choose Master,  Sub,  or UOR as the coordinate units of the features.  ‘Master’ is the default.
• Complex Strings - Check ‘Drop’ if you want each component of a complex chain to be returned as its own feature.   
 Otherwise all elements of the complex chain will be merged into a single linear feature.  Check ‘Propagate 
 Member Linkages’ if you want the linkages attached to the first component of the complex chain to be returned  
 on the MAPublisher feature,  supplementing any existing linkages.
• Background Colour - Check ‘Create black background’ if you wish MAPublisher to create a layer comprising a  
 simple black fill,  to mimic the common Microstation background.

Technical Reference Guide: File Formats
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TIGER/LINE (*.rt1) (*.bw1)

TIGER/Line files are a digital database of geographic features,  such as roads,  railroads,  rivers,  lakes,  political 
boundaries,  census statistical boundaries,  etc.,  that cover the entire United States.  The database contains 
information about these features such as their location in latitude and longitude,  the name,  the type of feature,  
address ranges for most streets,  the geographic relationship to other features,  and other related information.  
TIGER/Line files are the public product created from the Census Bureau’s TIGER database of geographic information.  
More information on the TIGER/Line file format and data product can be found on the U.S.  Census web page at:
http://www.census.gov/geo/www/tiger/

This website contains a detailed description of the current TIGER/Line format,  with an explanation of field meaning 
for each feature type.  A detailed description of the TIGER/Line 1998 format,  with an explanation of field meaning 
for each feature type,  is available at: http://www.census.gov/geo/www/tiger/tiger98.pdf

FME considers a directory of TIGER/Line data files to be a dataset.  Optionally the *.rt1 file may be used as a dataset.  
The directory may contain TIGER/Line files for one or more regions.  The regions are counties,  or county equivalents.
Each county consists of a series of files with a common basename,  and different extensions.  Always select the *.rt1 
or *.bw1 file for import.

 Supported Elements   Supported Geometry
 Typical File Extensions  *.rt1,  *.bw1 Aggregate  No
 Automated Translation Yes  Circles   No 
 User-Defined Attributes  Yes  Circular Arc No
 Coordinate System Support  Yes   Elliptical Arc  No
 Generic Colour Support  No  Ellipses   No 
 Spatial Index   Never  Polygon   Yes
 Schema Required   Yes  Donut Polygon  Yes
 Transaction Support  No  Point   Yes
 Geometry Type Attribute  tiger_type Line   Yes
      Text   No
 Supported Versions
  1990,  1992,  1995,  1997,  1998,  1999,  2000,  2002

USGS DIGITAL LINE GRAPH (*.dlg) (*.opt)

DLG is a published ASCII format developed by the United States Geological Survey (USGS) Federal Agency and is 
intended to assist in data exchange with the National Digital Cartographic Data Base (NDCDB).
The DLG reader supports all three distinct types of DLG data:
•  Large-scale DLG data (1:24,000-scale)
•  Intermediate-scale DLG (1:100,000-scale)
•  Small-scale DLG data (1:2,000,000-scale)
The three scales of DLG data are physically formatted into files in one of these ways: standard,  optional,  and 
graphics formats.  MAPublisher supports both the standard and the optional DLG distribution formats;  however the 
graphics format is not supported.  Most DLG data is distributed in the optional format.

Technical Reference Guide: File Formats
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The DLG file structure was designed to accommodate all categories of spatial data represented on a conventional 
line map.  Node,  line,  and area data types are present within the DLG format,  along with linkages and attribute 
codes. Linkages are references to other features within the same DLG data set,  used in a variety of contexts.  DLG 
files do not explicitly store attribute values but use a feature coding approach in which unique feature codes are 
assigned to the different types of features stored within the data set.  MAPublisher will look for the extension .dlg or 
.opt for the input DLG files.

 Supported Elements   Supported Geometry
 Typical File Extensions  *.dlg,  *.opt Aggregate  No
 Automated Translation Yes  Circles   No 
 User-Defined Attributes  No  Circular Arc No
 Coordinate System Support  Yes   Elliptical Arc  No
 Generic Colour Support  No  Ellipses   No 
 Spatial Index   Never  Polygon   Yes
 Schema Required   No  Donut Polygon  Yes
 Transaction Support  No  Point   Yes
 Geometry Type Attribute  dlg_type  Line   Yes
      Text   No

USGS SDTS (*catd.ddf)

Spatial Data Transfer Standard (SDTS) is a standardized binary format used by the USGS for transferring earth-
referenced spatial data between dissimilar computer systems that includes support for the inclusion of spatial data,  
attribute,  georeferencing,  data quality report,  data dictionary,  and other supporting meta-data within a single 
file transfer format.  Files in the SDTS format will have the extension *.ddf.  More information on this format can be 
found at:  http://mcmcweb.er.usgs.gov/sdts/

A group of *.ddf files is normally identified by the catalog file,  or *CATD.DDF file,  which relates the files of a single 
SDTS transfer,  and binds together all the files with a common prefix.  Always select the SDTS file which ends in 
‘CATD’,  which is a new requirement in MAPublisher 6,  i.e.  “HP01CATD.DDF”. 

 Supported Elements   Supported Geometry
 Typical File Extensions  *.ddf  Aggregate  No
 Automated Translation Yes  Circles   No 
 User-Defined Attributes  No  Circular Arc No
 Coordinate System Support  Yes   Elliptical Arc  No
 Generic Colour Support  No  Ellipses   No 
 Spatial Index   Never  Polygon   Yes
 Schema Required   N/A  Donut Polygon  Yes
 Transaction Support  No  Point   Yes
 Geometry Type Attribute  sdts_type Line   Yes
      Text   No
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Frequently Asked Questions

This section presents a number of frequently asked questions (FAQs) regarding the use of MAPublisher.  If the 
answer to your particular question is not included here please consult the online FAQs at http://www.avenza.com/
freezone/freezone.faq.html or the online MAPublisher Knowledge Base at http://www.avenza.com/support.kb.html.  
In addition,  there is a valuable GIS FAQ database put out by the US Census Bureau at: http://www.census.gov/geo/
www/faq-index.html

INSTALLATION ISSUES

All the MAPublisher filters are in the Plug-ins folder but they do not all show up in Adobe Illustrator.
Try exiting out of Adobe Illustrator,  deleting the Adobe Illustrator preferences and plugin cache files, and then 
restarting Illustrator:
•  In Windows the preferences and plug-in cache files are most often found in C:\Documents and Settings\username\ 
 Application Data\Adobe\Adobe Illustrator XX,  but depending upon your version of Windows they may appear in  
 the top level of the Adobe Illustrator folder.  In either case they are named ‘AIPrefs’ and ‘Plug-in Cache’.
•  On the Macintosh OSX platform the preferences file is most often found in Users\username\Library\Preferences\ 
 Adobe Illustrator XX.  
Also check under Edit > Preferences > Plug-ins & Scratch Disks and ensure that the correct location of your plug-ins 
folder is indicated.

Why can I not install to my Non-English version of Adobe Illustrator?
The Plug-ins folder in Non-English versions of Adobe Illustrator will be named differently.   MAPublisher will 
automatically locate the Plug-ins folder in English,  Dutch,  French,  German,  Italian,  Spanish and Swedish versions 
of Adobe Illustrator.  For all other language versions of Adobe Illustrator,  you will need to Browse for and select the 
equivalent to the Illustrator Plug-ins folder during the MAPublisher installation process.

I try to access the MAPublisher filters, but always receive a message saying MAPublisher cannot obtain a 
license.  What should I do?
1. Check you have registered your copy of MAPublisher and received a license file.  MAPublisher will fail to  
 operate until you have received a license file for activation.  For further details, please see page 15.
2. If you have purchased a Machine specific license (uncounted license) you must ensure the License file is located  
 in the following directory:
 Windows:  Program Files\Adobe\Illustrator XX\Plug-ins\MAPublisher Plug-in
 Macintosh:  Applications\Adobe Illustrator XX\Plug-ins\MAPublisher Plug-in
3. If you have a try-out version of MAPublisher,  check that your copy has not expired.  To do this, locate the *.lic file  
 in the directory listed above.  Open this file in a simple text editor.  On the second line will be details of the 
 expiration date of your try-out version.  Note that this file has been automatically generated by Avenza and  
 therefore manually editing will not re-activate MAPublisher.

Technical Reference Guide: Frequently Asked Questions



A1/10 A1/11Technical Reference Guide: Frequently Asked Questions

MEMORY & SPEED ISSUES

Why do I need so much more memory (RAM) than I do with my GIS?
The graphics software environment of Adobe Illustrator loads the entire file into memory rather than just reading it 
from disk,  thus more memory is required.  MAPublisher builds a mini-GIS application inside Illustrator so that it can 
geo-code information and attach data to objects.  This also has some overhead.  When you are importing a lot of 
files with MAPublisher into Illustrator,  you’ll notice that the amount of available memory will decrease rapidly and 
your computer loses speed.  This is due to the memory management.  MAPublisher reserves a fairly large amount of 
memory for each import-action,  which is not always returned when the import is done.  The solution is simple: save 
your file,  close it and open it again.  It’s not even necessary to close Illustrator itself.  By closing the file the reserved 
memory is properly returned.

How can I improve the speed of my data import?
Many GIS data files are large and when a series of such files is imported,  you may find that the import filter starts to 
run more slowly.  This is because scratch and memory allocations are being used up.  Try the following suggestions:
•  Periodically save your work then close and reopen the file.  This will free up the available scratch memory.
•  Reduce the maximum number of undos,  since they all reside in memory.
•  Set a grain value on import to drop redundant data points.
•  See the Memory Considerations section for other suggestions,  pages A1/20 to A1/21.

DATA IMPORT ISSUES

Why do my files appear squashed after import?
They are probably stored in geographic or lat/long co-ordinates.  Data in lat/long usually looks “squashed”.  You can 
project them into an alternate map projection using the MAP View Editor (see pages 51-53).

What alternatives are there for importing a file format not supported by MAPublisher?
We provide a web page that has links to freeware,  shareware and commercial GIS data translators at 
http://www.avenza.com/support.links.html.  If you cannot find the translator that you need give us a call as we may 
have other suggestions.

Why do my shapefiles not import?
There are a couple of possible causes of this.  The two items to check for are:
1.  Make sure that you have all 3 required files.  There should be a “triplet” for each layer/coverage with the  
 extensions *.dbf,  *.shp & *.shx.  If you are missing any of these files you will not be able to import your files  
 successfully.
2.  If you have transferred these files from one operating system to another then you must always use binary ftp  
 transfer,  or the files may be corrupted.  We have found that you cannot rely on the automatic transfer with all ftp  
 utilities.  Some do not recognize the files as being binary and will transfer them as ASCII.



A1/12 A1/13

I am having trouble getting my layers to overlay correctly.  Both files import correctly when they are 
imported alone,  but when I import the second file,  they do not line up as expected.
They should overlay correctly.  Probably they are in different projections or coordinate systems.  It is very important 
that you ensure that data used within a single mapped area have the same map projection.  If different data sets for 
a geographic location have differing projections,  the chances are high that they will not overlay on import.  If the 
files are of differing projections/coordinate systems,  any software will give you the same results.   If the projections 
are known,  you can use the MAP View Editor filter to change all data to a common projection.  For more information 
about map projections see the British Columbia Government Ministry of Environment tutorial on map projections 
at http://srmwww.gov.bc.ca/gis/projectiontutorial.html.

Why do my MapInfo files crash on import or do not import properly?
There are a couple of possible common causes of this.  A couple of possibilities may be:
1.  How did you transfer the file to the machine where it is being imported? If you have transferred these files from  
 one operating system to another then you must always use ASCII ftp transfer,  or the files may be corrupted. We  
 have found that you can not rely on the automatic transfer with all ftp utilities.  Some do not recognize the .MID  
 files as being text.  The .mid files may be inadvertently interpreted as binary music files,  which often carry the  
 same file extension.  If they are transferred as binary you will have trouble importing them.
2.  Were the files compressed? If the files are compressed using a windows ZIP format,  you must be careful when  
 decompressing them.  If this is the case and the utility you used was Stuffit,  you need to make sure that it was  
 set for a DOS zip file or the file can be corrupted.  The shareware utility ZIPIT found at http://maczipit.com has  
 been found to be quite good for decompressing windows zip files.

I am having trouble with importing SDTS files.  Where am I going wrong?
Be very careful how you receive a xxx.tar.gz file off the USGS website and decompress it.  These files are in a binary 
format and if you use Smart TAR CR/LF translation it will not import and may cause errors in MAPublisher.  Make sure 
that you do all FTP transfers as binary.  After you receive it,  use gzip to decompress it and TAR to further decompress 
it.  You should have about 20 separate files,  look for the ones that end in xxxxCATD.DDF.  

Why does my data sometimes vanish?
If you imported some data and it appeared when selected,  but when you deselected the data it seemed to vanish,  
here are a few things to check:
•  You may have inadvertently pressed cut or the delete key.  Check under Edit in the menu bar,  if the “Undo Clear”  
 task is available this means that you just deleted something.  Select “Undo Clear,” and the data should return.
•  Check the order of your layers.  Try moving the layer in question to the top of the list of layers in the Layers palette  
 so that it is drawn on top of the other layers.
•  Make sure that current layer is available for viewing in the Layers palette,  by having a dot in the left-hand column  
 under the eye (visualization) and beside the layer name.
•  Check that you have colours for the fill and stroke set in the paint palette.
•  Check the setting for the stroke width and increase if necessary.

Technical Reference Guide: Frequently Asked Questions
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EXPORTING ISSUES

How do I strip all the attributes from a MAPublisher file?
Simply drag your MAP Layers to into the default MAP View entitled [Non-map layers],  and all georeferencing and 
attribute information will be removed.  Note that this function must only be used as a final step.  You will be unable 
to recover attribute information after converting a  ‘MAP Layer’  to a  ‘Non-map Layer’.

What causes missing features when exporting MAPublisher layers?
If you are using an pre-existing Adobe Illustrator file not created with MAPublisher you must correctly assign 
MAPublisher status to your layers and data.  Only one feature type per layer is supported.  The feature type icon next 
to your MAP Layer in the MAP Views palette is indicative of the features on that layer,  and is the feature type which 
will be applied if the layer is exported.  For example if you have Point symbols on a Line Layer,  they will not be 
recognized as being MAPublisher objects and will be dropped in the export process.

Why is MAPublisher exporting the ‘MPArea’ column values as negatives?
Certain polygons may be displayed as negative areas in the ‘MPArea’ column.  Data that was originally digitized 
counterclockwise will contain negative values.  When exporting Area layers to GIS formats,  polygon outlines 
must have a positive ‘MPArea’ value.  If you have values for polygons in the ‘MPArea’ column of your MAP Attribute 
table which contradict these guidelines,  you can use Flip Selected Lines (page 91) to convert the MAPublisher area 
calculation from a negative to a positive value or vice versa.  For the correction of simple closed areas,  use Select by 
Attribute to select all elements that have an ‘MPArea’ of less than zero.  Then go to Filter > Flip Selected Lines.

LABELING ISSUES

I am having trouble with the MAP Tagger tool? Where am I going wrong?
This can happen either when the layer or object to be labeled is not available for editing.  Check to make sure that 
the desired layer is available for editing,  the features in question are not locked,  and you have a Text layer in your 
document to use to output the text to.  In addition,  if there is no fill to an area or polygon object the label tool 
(much like the Illustrator selection tool) can only find the paths defining the unfilled area.  Therefore in such cases it 
cannot  ‘find’  the unfilled area and thus cannot label the unfilled area.

PROJECTION ISSUES

How do I know what projection my files are in?
In MAPublisher 6,  the importers will automatically determine the projection of the chosen files,  if this information 
is included in the file header or is located in an associated file (e.g. *.prj).  If MAPublisher returns a message of 
<undetected> for the Projection,  you should first ask your data provider to provide you with this information.  Also 
there are a couple of strong hints that may indicate that a file is in latitude/longitude (lat/long).  Both ArcView and 
MapInfo tend to store files in lat/long for rapid reprojection.  This is why most files derived from such sources are 
stored in lat/long.  A good test to see if a file is in lat/long is to look at the Map Anchor values in the MAP View Editor 
or in the MAP Location Tool.  Typical Lat/Long values will be X between -180 and 180 & Y between -90 and 90.



A1/14 A1/15

TABLE ISSUES

What causes Join a Table not to work?
When using the Join a Table filter you should first ensure that the linking columns have similar attribute structures 
(i.e.  the join columns should be of matching type).  If your join does not work when you are joining on character 
columns,  you should check for trailing blanks in your character values/fields.

OTHER ISSUES

Where can I find version updates for MAPublisher?
Updaters will always be found in the Avenza FreeZone at http://www.avenza.com/freezone.

How accurate is MAPublisher georeferencing?
At this point in time we are restricted to 32 bit storage for numbers,  which allows for 7 digits of precision.  The 32
bit storage restriction is controlled by the graphics environment software and not the MAPublisher software.  We
have asked for this storage restriction to be increased to 64 bit without success.  We can and do all our internal
calculations in 64 bit for accuracy,  but the results still must be stored as 32 bit.  MAPublisher’s values are roughly 4.3 
billion times more precise than Illustrator’s.
Illustrator is fundamentally an art program.  The numbers it uses for its vertex data are more than sufficient to 
provide precision enough such that the human eye cannot tell the difference,  even at its highest zoom level.
Unfortunately,  MAPublisher must translate its coordinates into Illustrator’s when placing them on the artboard.  We 
do this using mathematical calculations based upon the parameters you provide (e.g. map & page anchors,  scale,  
etc.). When MAPublisher does this,  it is,  in a sense,  compressing its more-precise numbers into Illustrator’s less-
precise numbers,  and this is where the truncation may occur.
An easier way to visualize this is to think of a pad of grid paper.  If this paper were the artboard,  Illustrator would 
only be able to place points where two grid lines meet,  but MAPublisher could put points anywhere on the page. 
However,  since Illustrator is ultimately where the information is plotted,  when a MAPublisher point is plotted on 
the page it would get ‘rounded’ to the nearest grid line intersection point. 

I am receiving an “Error loading plug-ins” when I start Illustrator.  What should I do?
Search for and delete any copies of a file named “Adobefnt05.lst.” If that does not work, search for and delete any 
copies of a file whose name starts with  ‘Adobefnt’ and has a *.lst extension.  The Adobefnt *.lst files are cached 
descriptions of the font environment.  They can be rebuilt when needed so it is safe to delete them.

Are there any sources for free GIS data?
There are a multitude of web sites which offer free GIS data in several different forms.  Please see pages A1/22 to  
A1/24 of this user guide for a list of several free download sites.

Why do some art objects fail to display completely?
Sometimes drawing with Illustrator’s shape creation tools results in the object not being displayed completely by 
Illustrator.  The object’s geometry is complete because if you set the View to outline (View > Outline) as opposed 
to Preview you can see that the object is there in its entirety (you can also zoom in and out).  However,  once you 
restore the zoom level to the original extents at which the object was created it will no longer appear as a complete 
shape.  The solution to this is to disable the anti-aliasing option in the Illustrator preferences dialog.

Technical Reference Guide: Frequently Asked Questions
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What can cause attribute corruption?
The most likely cause of attribute corruption (other than the files being corrupted before you got them) is that you 
have put layers with differing attribute structures into a single layer.  As a rule of thumb you should use one layer for 
each external file that you are importing.

What can I do when a filter does not appear to work?
• Make sure that you have highlighted the desired Layer in the Layers palette and that it is unlocked and visible.
• Make sure that what you have asked the filter to do makes sense.
• Check your available and assigned RAM (Mac users).
• Try closing Illustrator and deleting your Illustrator preferences file.

Why have I lost the attributes for my point layer?
Regarding the editing of Point Data,  you must use either MAP Stylesheets,  Assign Legend Info,  or Auto Assign 
Legend Info to change symbology.  As point data is linked dynamically to the symbols which exist in the Symbols 
palette,  you cannot edit graphical properties manually.  A possible reason,  therefore,  is that you have chosen ‘Break 
Link to Symbol’ from the Symbols palette options,  resulting in the loss of attributes for your point data.
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GIS Backgrounder

WHAT IS GIS?

A Geographic Information System (GIS) captures,  stores,  checks,  analyzes,  and displays georeferenced data 
about the earth.  A GIS uses a database management system (DBMS) to store and link data that relates to the same 
geographic area.  This facilitates the following types of queries:
•  what if…?
•  what is it?
•  where is it?
•  what spatial patterns exist?
• what has changed since…?

FEATURES OF A GIS

ANALYTICAL TOOL
GIS systems are used by all levels of governments,  academia and business for such diverse purposes as monitoring 
environmental changes,  sales planning,  census reporting,  municipal zoning,  land records,  mineral resource 
management,  and mapping telecommunications and cable television utilities.  In short,  a GIS serves many 
needs and can be thought of as an analytical tool since it can be used to determine spatial relationships between 
geographic areas.  A GIS contains a database linking spatial data with geographic information and lets you associate 
information with map features and to create new relationships based on those associations.

AREAS
An area is a closed,  bounded object,  which encompasses a homogeneous area (e.g.,  a park).

ATTRIBUTES
Attributes store descriptive information and are stored as sets of characters (including numbers).  Attributes are 
usually considered tabular data.

GEOGRAPHIC DATA
Since a GIS is a digital map database storing both spatial (graphic) and descriptive (tabular) information,  the 
integration of this information provides an opportunity for analysis and communication.  Data is stored using the 
Cartesian system (X,Y co-ordinates) as follows:
• points are stored as a single X,Y location
• lines are stored as a series of ordered X,Y co-ordinates
• areas are stored as a string of X,Y co-ordinates defining the lines that bound the area.

LABELS,  SYMBOLS AND COLOUR
Map attributes can be represented by labels,  symbols,  and colour to make them easy to interpret (e.g.  rivers may 
be represented with blue lines of varying widths depending upon their size).

LAYERS
Map features can be logically grouped into layers of related information.  For example,  a map could be layered 
by rivers,  soils,  mineral deposits,  and municipality.  This layering makes it easy to perform analysis that overlay 
geographic features and combine adjacent areas with similar characteristics.

Technical Reference Guide: GIS Backgrounder
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LINES
A line represents the linear shape of a map element,  which is too narrow to be an area (e.g.,  a contour line or road).

MAP FEATURES
A GIS stores two types of map information: spatial information (which describes the location and shape of 
geographic features) and descriptive information about those features.  A GIS links these two types of data and 
maintains the spatial relationships between the map features.  Features are portrayed on two-dimensional maps 
as points,  lines,  and areas.  For example,  a map may contain points representing location information (such as 
telephone poles),  lines representing linear features (such as roads),  and areas representing geographic features 
(such as lakes).

POINTS
Usually represented by a symbol or label,  a point is a discrete location which is usually too small to be identified as 
an area or line (e.g.,  an oil wellhead or manhole).

SPATIAL RELATIONSHIPS
A map allows you to identify spatial relationships (e.g.,  a fire tower located inside a park) but it relies on you to 
derive this information from it.

TOPOLOGY
Topology is a mathematical process for determining spatial relationships.  It does this by expressing different spatial 
relationships as lists of features (i.e.  an area is defined by the boundary lines).  The primary advantage of this type of 
data storage is that it is more efficient and permits faster processing of larger data sets.
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WHY IS THE GRAPHICS ENVIRONMENT GOOD FOR MAPPING?

Avenza supports the fact that performing map-related graphics tasks is best done in the right environment-
a powerful graphics program like Adobe Illustrator.  This environment offers practicality,  freedom and easy 
maneuverability for fast,  cost-efficient and professional graphic output results.  The MAPublisher environment 
focuses on the map graphics first with the right GIS data management tools to facilitate the map production 
process in the easiest and most efficient way.  This is in direct contrast to traditional GIS software that are designed 
and written,  for the analysis of geographic data,  with the graphic map production coming second,  almost as an 
afterthought.  This means that as powerful as most GIS’s are for analysis,  they were never designed for cartographic 
or publication quality mapping.  Cartographers have long been doing their mapping within graphics environments 
because they provide tools such as Bezier curves and true CMYK colour separation for publication quality mapping.

FEATURES OF THE GRAPHICS ENVIRONMENT

ACCURATE COLOUR
Colours displayed on screen accurately reflect the colours as they will be printed.

PROPORTIONAL SYMBOLOGY
Symbology is accurately proportional to the map area you have “zoomed” into.

VIEWS
You can display your document on–screen in a variety of ways using the View menu commands.  For example,  you 
can see a preview of the illustration as you edit,  you can view only the outlines of your artwork,  or you can preview 
selected parts of your artwork while displaying the rest as outlines.  You can also create and save custom views of 
your document,  retaining a particular magnification level,  layering,  and other viewing features for later retrieval.  
You can even display multiple views of a document at several different magnification levels simultaneously.   

UPDATE PORTIONS OF A LAYER OR LEGEND
MAPublisher gives you the ability to update portions of a layer or legend by selecting one or more individual map 
objects based on attribute or colour/pattern/symbol and then applying a new colour/pattern/symbol.  There is 
no deleting and then re-adding of the relevant map elements or layers.  In practical terms this means that if you 
added a roads layer/element to your map and then realized that one of your roads line symbols didn’t look right,  all 
you need to do is select for that class of road and change the symbol with the palettes.  There is no need to delete,  
re-code and re-drape your roads.  It is even easier if you use the MAPublisher legend filters,  in which case you only 
need to modify the legend for your roads and then draw to update the roads as desired.

REDRAWING IS AUTOMATIC
Redrawing of the affected map objects is clean and automatic and impacts only the redrawn portion and possibly 
some immediately adjacent portions of the map.  This eliminates the need to wait while the entire map is re-drawn 
or refreshed.  This applies to text as well as to vector data.

BROAD SELECTION OF FONTS
A broad and flexible selection of text fonts,  styles,  sizes and enhancement features (e.g.,  haloing) is available.

Graphics Backgrounder
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PASTE IN FRONT OR BEHIND
When pasting map objects/elements,  you have the option of deciding to paste the new object “in front” or “behind” 
the copied elements at the time of pasting.

POSTSCRIPT PATTERN FILLS
You can use PostScript pattern fills and complex vector strokes.  You can sample colours from images and apply 
them precisely to vector data.

COMPLEX COLOUR TREATMENTS
Even with complex colours you can quickly and accurately create colour ramps with differing depths/intensity of 
10%,  20%,  etc.  These can be set as individual colours on a palette or as a gradient across mapped features.

IMPROVED SYMBOLOGY
Improved symbology (e.g.,  road treatments and cartographic symbols) than is available in traditional GIS software.

SPEED DRAWING
You can easily turn on and off selected layers of a map to speed drawing.  This can be done by turning off specified 
layers,  and/or limiting the display of selected layers to simple vectors with all symbology removed.  Not only will 
this speed the handling of the map,  it lets you easily use underlying vectors for reference with no distraction or 
distortion caused by mapping symbology.

ACTUAL SIZE VIEWING
In addition to standard zooming and panning capabilities,  you can view the details on a map at the actual size at 
which they will be plotted/printed.

RULERS,  GUIDES AND ALIGNMENT TOOLS
Rulers with adjustable guides and multi-combination alignment tools are available for use in aligning map objects.

GROUPING AND UNGROUPING
There is grouping and ungrouping functionality.  When items are grouped you still retain the option of separately 
accessing,  querying and otherwise working with the individual components of a map group.

STORE RELATED OBJECTS
Individual but related map objects can be “stored” together by groups or by layers or both within the graphic file.  
This provides additional control and support in handling and organizing the map components.

TEXT PLACEMENT
The graphics environment offers a truly hands-on text placement environment and goes well beyond that of a GIS.  
For example text can be easily placed along any path or outside the map
extents and is fully editable.

Technical Reference Guide: Graphics Backgrounder
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RAM RECOMMENDATIONS

Occasional User: 256-512mb of RAM is recommended.
A graphics or GIS user who uses MAPublisher with medium sized data sets with up to 20 layers,  minimal text labels,  
and some low-resolution or small coverage raster images.

Power User: 512mb-1GB of RAM is recommended.
A professional cartographer who uses MAPublisher daily and works with large urban data sets (including large 
transportation layers) with 20 or more layers,  raster based air photographs,  large numbers of text labels,  complex 
fill patterns,  etc.

RAM USAGE HINTS

Users often ask us why is so much RAM needed to operate MAPublisher.  First of all,  Adobe Illustrator requires a 
significant amount of RAM itself in order to run smoothly.  Secondly,  map data sets are often large which increases 
the need for RAM even further.  Map data sets contain both vector and attribute data which must be stored 
in memory.  Since we are adding a database to Illustrator this increases the file size,  which increases the RAM 
requirements.  MAPublisher builds a mini-GIS application inside Illustrator so that it can geo-code information and 
attach data to objects.  This also has some overhead.

GIS users also often ask why so much more memory is needed with MAPublisher than is with GIS software.  The 
graphics environment software of Adobe Illustrator loads the entire file into memory rather than just reading it 
from disk,  thus more RAM memory is required.

When you are importing a large number of files into Illustrator using MAPublisher,  you’ll notice that the amount of 
available memory will decrease rapidly and your computer loses speed.  This is due to the memory management.  
MAPublisher reserves a fairly large amount of memory for each import-action,  which is not properly returned when 
the import is done.  The solution is simple: save your file,  close it and open it again.  It’s not even necessary to close 
Illustrator itself.  By closing the file,  the reserved memory is properly returned.

Memory Considerations
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RAM SAVING TIPS

Since a percentage of the memory is taken for attribute storage,  drop any redundant or otherwise unnecessary 
attribute fields from the map attributes table.

Many sources of street data include paths/vectors that are segmented based on street addressing information.  You 
can use the MAPublisher Join Lines filter to join these into single linear features based on a selected attribute field.  
Reducing the number of objects (and data records) in the map file will free up memory.

Many GIS data files are large and when a series of such files is imported,  you may find that the import filter starts 
to run more slowly.  This is because scratch and memory allocations are being used up.  The best solution is to 
periodically save your work,  quit out of Adobe Illustrator and then restart.  This will free up the available scratch 
memory.

The minimum number of undos can be reduced (since they ALL reside in memory).

Use polylined or pre-joined linear feature data sets where available.

In your GIS application strip out the attributes you won’t be using for queries or labeling before importing the data 
into Illustrator.

Increase your RAM allocation to Adobe Illustrator (Mac only) and be sure that it is the only application open.

You can click on the status dropdown in Illustrator (bottom left hand corner) and select “Free memory” to see how 
much memory resource is free at any given time.

You can set a primary and secondary scratch disk under the Illustrator preferences option in order to draw 
additional storage from a partitioned or multi-drive environment.

Technical Reference Guide: Memory Considerations
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Since the Internet is always changing,  refer to our web page (www.avenza.com) for the most recent list of relevant 
Internet sites or do a Google or Yahoo search.  As of the writing of this manual all the following links were active and 
functional.

For Geographic Information System (GIS) users,  the appeal of graphics is strong and the increasing ability to 
discover and share GIS across the Internet is fascinating.  The Internet offers a large number of free-access GIS-
related websites from which you can access map and information data sets.

For the general public,  there’s general information about countries,  states,  and places; simple maps of areas (e.g.,  
GIF,  PS format); lists and maps of Internet resources in an area.

For cartographers and geography researchers,  there are cartographic/ GIS base map files (e.g.,  USGS Demos,  DLGs,  
TIGER); thematic data of a geographic nature (e.g.,  census data); and complete GIS data sets (e.g.,  ArcInfo export 
files).

These lists are readily available,  and there is a comprehensive list of free data sites accessible from the MAPublisher 
Internet home page at: http://www.avenza.com/support.links.html.

FREE MAP DATA

The following are just some of the many sites on the Internet that offer free download of GIS data.  Data is available 
from these and other Internet sites in a wide variety of formats.  Please consult the sections in this manual on file 
formats (pages 20 to 22 & A1/2 to A1/9) to ensure that you obtain usable data.

AUSLIG
Australian national mapping agency offering digital map data,  satellite imagery and elevation data.  Data obtained 
here can be used for commercial purposes with permission.
• http://www.auslig.gov.au/mapping/index/

CAST
The Center for Advanced Spatial Technologies (CAST),  University of Arkansas.  Planned free access on the ARKNet 
statewide network.  Among its high–tech offerings,  CAST maintains a catalog of Arkansas,  U.S.  national and global 
data - e.g.,  GIS data in areas of archaeology,  agriculture and population are downloadable as GIF files across the 
Internet.  Obtain a map of historical land coverage data.  Obtain data sets including Environment,  Prehistoric and 
Historic Climate Reconstruction,  Historic Census,  and Tabular databases.
• http://www.cast.uark.edu/local/hunt/index.html

DIRECTIONS MAGAZINE DATA CENTER
Directions magazine is an internet-centred publication that provides news,  analysis,  commentary product 
information and free map data.
• http://www.directionsmag.com/datacenter

EROS DATA CENTER
The Eros Data Center will be providing FTP access to a variety of USGS digital data sets.
• http://edcwww.cr.usgs.gov

Online Links
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FREEDATA.CA
This site is dedicated to the issue of access to government geospatial data across Canada.  .
• http://www.freedata.ca

GEOCOMMUNITY & GIS DATA DEPOT
The GeoCommunity and GIS Data Depot are an excellent sources of free GIS data,  geographic software (including 
data viewers,  translators and compression utilities) and industry news.  This site also has several GIS-related 
discussion forums.  The data found on this site covers most areas of the world.
• http://www.geocomm.com

GEOCONNECTIONS/GEOCONNEXIONS
This site from Canada’s Ministry of Natural Resources offers many links to GIS data and other informational 
resources.
• http://www.cgdi.gc.ca

GEOGRAPHY NETWORK
The Geography Network is an online resource for finding and sharing world-wide geographic content,  including 
maps and data from many of the world’s leading providers.
• http://www.geographynetwork.com

GEOGRATIS
Geogratis is a Natural Resources Canada site offering maps,  satellite imagery and tabular data.
• http://geogratis.cgdi.gc.ca

GISUSER
GISuser.com was launched in February,  2004.  Their goal is to provide the geospatial technology user with the latest 
news,  resources,  and tools affecting the GIS industry.  
• http://www.gisuser.com

MAPCRUZIN
MAPCRUZIN has data resources for environmental and socio-demographic research.
• http://www.mapcruzin.com

NATIONAL ATLAS OF THE UNITED STATES
This site is a great source of a wide variety of data files for the United States.
• http://www.nationalatlas.gov/atlasftp.html

DOUG PRICE’S LIST OF FREE DIGITAL GIS DATA
This site based at the Tennessee Geographic Information Council and the University of Tennessee offers an 
extensive list of data download links from around the world.
• http://www.lib.utk.edu/~tngic/price.html

ROBERT E.  KENNEDY LIBRARY @ CALIFORNIA POLYTECHNIC STATE UNIVERSITY
California Polytechnic State University has various links to US-based map inventories.
• http://www.lib.calpoly.edu/research/all_databases/gis/gis5.html
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UNITED STATES GEOLOGICAL SURVEY
Department of the Interior – USGS home page.  This is the primary source for Digital Line Graph (DLG) files.  A must–
have resource is the US Geological Survey Digital Format Standards manual published by the USGS.
• http://www.usgs.gov - USGS Home page.
• http://nsdi.usgs.gov - Digital products.
• http://www.usgs.gov/pubprod/index.html - Products and Publications Listings.
• http://greenwood.cr.usgs.gov - The USGS Greenwood map server.

UNITED STATES FISH AND WILDLIFE SERVICE
The FWS carries a variety of map data in the USGS DLG format.
• http://www.fws.gov

OTHER VALUABLE MAPPING LINKS

The following are some additional places on the Internet where you can find news,  reviews,  tips and general GIS,  
cartographic and geographic information.

GIS CAFE
• http://www.giscafe.com

GIS DICTIONARY
• http://www.geo.ed.ac.uk/agidict/welcome.html

GIS LOUNGE
• http://www.gislounge.com

GIS@DEVELOPMENT
• http://www.gisdevelopment.net

UNIVERSITY OF CALIFORNIA,  BERKELEY
• http://sunsite.berkeley.edu/GIS

UNIVERSITY OF EDINBURGH
• http://www.geo.ed.ac.uk/home/gishome.html

UNIVERSITY OF FLORIDA - GEOPLAN CENTER
• http://www.geoplan.ufl.edu

US CENSUS BUREAU
• http://www.census.gov/geo/www/faq-index.html
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Technical Support Options

In this section you will find some tips and hints for performing additional MAPublisher-related tasks as well as a 
detailed listing of your technical support options.

TECHNICAL SUPPORT

Please consult the FAQs on pages A1/10 to A1/15,  the additional how-to’s on the following pages as well as the 
following online options before contacting Avenza technical support as your situation may be easily addressed by 
one of the answers contained therein.

MAPUBLISHER ONLINE KNOWLEDGE BASE
The MAPublisher Online Knowledge Base is a searchable online archive that offers a variety of MAPublisher 
information including newsgroup items,  specific solutions and other contributions from Avenza,  MAPublisher 
resellers and other MAPublisher users.  The MAPublisher Online Knowledge Base is located at 
http://www.avenza.com/support.kb.html.

INTERNET MAILING LISTS
There are two very popular Internet mailing lists that are populated by experienced MAPublisher users worldwide 
and offer an open forum for discussing problems,  solutions,  tips and other general issues relating to MAPublisher 
and cartography.  These lists are also monitored by Avenza technical support staff who often participate with a 
solution or useful discussion item.
•  mapublisher-l - This is the main MAPublisher list.  Subscribe by sending an email to majordomo@avenza.com 
 with the statement subscribe mapublisher-l <emailaddress> in the body of the message.  substitute your actual  
 email address for <emailaddress>.
•  map-mac - This is a very popular mapping list to which many MAPublisher users belong.  It is not limited to mac- 
 related discussions.  Subscribe by sending an email to majordomo@avenza.com with the statement subscribe 
 map-mac <emailaddress> in the body of the message.  Substitute your actual email address for <emailaddress>

ONLINE FAQS
There is an ever-growing list of Frequently Asked Questions and answers on the Avenza website at 
http://www.avenza.com/freezone/freezone.faq.html which provides an additional source of tips,  tricks and general 
MAPublisher information.

CONTACTING AVENZA TECHNICAL SUPPORT
Avenza offers a number of methods for direct communication with our qualified and experienced technical 
experts.  Please have your MAPublisher registration details handy to get prompt attention and include it in any 
email correspondence.  Support issues are handled on a first come,  first-served basis.  Avenza does not guarantee 
a response within any specified time.  For priority support consider joining the MAPublisher Maintenance Program 
(see page A1/26).
•  email: support@avenza.com 
•  online form: http://www.avenza.com/support.form.html
•  phone: +1.416.487.6442 (Free for MAPublisher Maintenance Program subscribers. Others US$49 per incident.)

Technical Reference Guide: Technical Support Options
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MAPUBLISHER MAINTENANCE PROGRAM (MMP)

The MAPublisher Maintenance Program is a subscription-based service plan that guarantees its members:
•  unlimited priority technical support - guaranteed same business day (9-4 EST) or next business day response
•  MMP only telephone support (+1-416-487-6442)
•  free MAPublisher updates
•  free MAPublisher version upgrades
•  additional discounts and offers available to MMP members only

Your MAPublisher 6 purchase includes a one-year membership in the MAPublisher Maintenance Program so you are 
well on the way to worry-free use of MAPublisher and will be able to enjoy all the benefits of the MMP immediately.  
All MAPublisher Maintenance Program subscriptions begin on the date of registration of the license file and run for 
1 calendar year.

Your email address has been automatically entered in the maintenance-l online email list for MMP subscribers so 
that you are assured of receiving all the latest MMP news and access to all the update and upgrade files.  If you 
purchased your MAPublisher 6 license from a reseller or are the end user but not the person who purchased the 
software,  please contact us at sales@avenza.com to ensure that we receive your email address and add you to the 
MMP notification group.

RENEWAL

Approximately 8 weeks prior to the expiration of your annual MMP subscription you will be notified regarding 
renewal options.  You will be contacted a minimum of 5 times prior to expiration in order to ensure that you have 
ample opportunity to renew or not at your discretion.  You will have the option of renewing your MMP for an 
additional year at the then prevailing price or canceling without penalty.  Of course, if you cancel or let your MMP 
lapse you will no longer be entitled to the benefits of the program as outlined above and will thus have to purchase 
future upgrades at the upgrade price.

Note:  There is a grace period of 30 days from the time of the MMP expiry during which you may still renew without 
penalty.  All post-expiration renewals will be backdated to the actual expiry date.

LAPSED SUBSCRIPTIONS

Failure to renew your MMP within 30 days from the expiry date will result in a lapsed MMP subscription.  Lapsed 
subscriptions may not be renewed and the licensee will be required to purchase support and upgrades accordingly.

Please direct all MMP questions and purchase inquiries to info@avenza.com.

WISHLIST

As either a new or experienced MAPublisher user we value your opinions on how we can improve our product.  
Please let us know what  functions you would like to see incorporated into future upgrades of MAPublisher.
•  email us at wishlist@avenza.com,  or
•  fill out the form at http://www.avenza.com/products.wishlist.html
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PROJECTIONS OVERVIEW

Map Projections are attempts to show the surface of the earth,  or parts of it,  on a flat surface.  Some distortions 
of conformality,  distance,  direction,  scale,  and area always result from this process.  Certain projections minimize 
distortions in some of these aspects at the expense of maximizing errors in others,  whereas others only moderately 
distort all of these properties.

•  Conformality:  The scale at any point on the map is the same in all directions.  Meridians (lines of longitude) and  
 parallels (lines of latitude) intersect at right angles.  Projections with these properties are Conformal.
•  Distance:  A map has an Equidistant projection when it portrays equal distances from the centre of the  
 projection to any other place on the map.
•  Direction:  A map preserves direction when azimuths (angles from a point on a line to another point) are  
 portrayed correctly in all directions.  Projections with these properties are Azimuthal.
•  Scale:  The relationship between a distance portrayed on a map and the same distance on the Earth.
•  Area:  When a map portrays areas over the entire map so that all mapped areas have the same proportional  
 relationship to the areas of the world they represent,  the projection used is an Equal Area projection.

PROJECTION CATEGORIES

    Cylindrical Projection:  The result of projecting a spherical surface onto a cylinder.   In a typical
    cylindrical projection,  one imagines the paper to be wrapped as a cylinder around the globe,  
   tangent to it along the equator.  Light comes from a point source at the centre of the globe or,   
   in some cases,  from a filament running from pole to pole along the globe’s axis.  In the former 
   case the poles clearly cannot be shown on the map,  as they would be projected along the axis
   of the cylinder out to infinity.  In the latter case the poles become lines forming the top and 
   bottom edges of the map.  The Mercator projection,  long popular but now less so,  is a  
   cylindrical projection of the latter type that can be constructed only mathematically.  In all 
cylindrical projections the meridians of longitude,  which on the globe converge at the poles,  are parallel to one 
another; in the Mercator projection the parallels of latitude,  which on the globe are equal distances apart,  are 
drawn with increasing separation as their distance from the equator increases in order to preserve shapes.  However,  
the price paid for preserving shapes is that areas are exaggerated with increasing distance from the equator.  The 
effect is most pronounced near the poles; e.g.,  Greenland is shown with enormously exaggerated size,  although its 
shape in small sections is preserved.  The poles themselves cannot be shown on the Mercator projection.  

    Conic Projection:  The result of projecting a spherical surface onto a cone.   In a conic projection 
    a paper cone is placed on a globe like a hat,  tangent to it at some parallel,  and a point source of 
    light at the centre of the globe projects the surface features onto the cone.  The cone is then cut 
    along a convenient meridian and unfolded into a flat surface in the shape of a circle with a   
    sector missing.  All parallels are arcs of circles with a pole (the apex of the original cone) as their
    common centre,  and meridians appear as straight lines converging toward this same point.   
    Some conic projections are conformal (shape preserving); some are equal-area (size preserving).  
A polyconic projection uses various cones tangent to the globe at different parallels.  Parallels on the map are arcs of 
circles but are not concentric.

All About Projections
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    Azimuthal Projection:  The result of projecting a spherical surface onto a plane.  In an azimuthal
     projection a flat sheet of paper is tangent to the globe at one point.  The point light source may
     be located at the globe’s centre (gnomonic projection),  on the globe’s surface directly opposite
    the tangent point (stereographic projection),  or at some other point along the line defined by   
    the tangent point and the center of the globe,  e.g.,  at a point infinitely distant (orthographic   
    projection).  In all azimuthal projections,  the tangent point is the central point of a circular map;
     all great circles passing through the central point are straight lines,  and all directions from the 
central point are accurate.  If the central point is a pole,  then the meridians (great circles) radiate from that point 
and parallels are shown as concentric circles.  The gnomonic projection has the useful property that all great circles 
(not just those that pass through the central point) appear as straight lines; conversely,  all straight lines drawn on it 
are great circles.  A navigator taking the shortest route between two points (always part of a great circle) can plot his 
course on a gnomonic projection by simply drawing a straight line between the two points.

Miscellaneous Projections:  Projections that do not fall into the above categories,  such as unprojected maps,  
and rectangular latitude and longitude grids.  Also this classification can be applied to modified projections; 
being altered versions of other projections.  Pseudo projections have some of the characteristics of another class 
of projection.  For example the Sinusoidal is called a pseudocylindrical projection because all lines of latitude are 
straight and parallel,  and all meridians are equally spaced.  However it is not a truly cylindrical projection because 
all meridians except the central meridian are curved.

PROJECTION EXAMPLES

CYLINDRICAL PROJECTIONS

• Peters:  This projection is a cylindrical equal-area projection that de-emphasizes area exaggerations in high 
 latitudes by shifting the standard parallels to 45 or 47 degrees.  
• Mercator:  Has straight meridians and parallels that intersect at right angles.  Scale is true at the equator or at 
 two standard parallels equidistant from the equator.  The projection is often used for marine navigation because  
 all straight lines on the map are lines of constant azimuth.  
• Miller Cylindrical:  Has straight meridians and parallels that meet at right angles,  but straight lines are not of 
 constant azimuth.  Shapes and areas are distorted.  Directions are true only along the equator.  The projection  
 avoids the scale exaggerations of the Mercator map.  
• Oblique Mercator:  These projections are used to portray regions along great circles.  Distances are true along a 
 great circle defined by the tangent line formed by the sphere and the oblique cylinder,  elsewhere distance,   
 shape,  and areas are distorted.  Once used to map Landsat images,  this projection is used for areas that are long,   
 thin zones at a diagonal with respect to north,  such as Alaska State Plane Zone 5001.  
• Transverse Mercator:  These projections result from projecting the sphere onto a cylinder tangent to a central
 meridian.  Transverse Mercator maps are often used to portray areas with larger north-south than east-west  
 extent.  Distortion of scale,  distance,  direction and area increase away from the central meridian.  
• British National Grid:  This is one of many national grid systems are based on the Transverse Mercator projection,   
 and is administered by the British Ordnance Survey.  The true origin of the system is at 49 degrees north latitude  
 and 2 degrees west longitude.  The false origin is 400 km west and 100 km north.  Scale at the central meridian  
 is 0.9996.  The first BNG designator defines a 500 km square.  The second designator defines a 100 km square.  The  
 remaining numeric characters define 10 km,  1 km,  100 m,  10 m,  or 1 m eastings and northings.
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• Universal Transverse Mercator (UTM):  Used to define horizontal,  positions world-wide by dividing the surface  
 of the Earth into 6 degree zones,  each mapped by the Transverse Mercator projection with a central meridian in 
 the center of the zone.  UTM zone numbers designate 6 degree longitudinal strips extending from 80 degrees  
 South latitude to 84 degrees North latitude.  UTM zone characters designate 8 degree zones extending north and  
 south from the equator..  See the UTM Zone Map on page A1/35.
•  Behrmann Cylindrical Equal-Area:  Cylindrical Equal-Area projections have straight meridians and parallels,  
 the meridians are equally spaced,  the parallels unequally spaced.  There are normal,  transverse,  and oblique 
 cylindrical equal-area projections.  Scale is true along the central line (the equator for normal,  the central  
 meridian for transverse,  and a selected line for oblique) and along two lines equidistant from the central line.  
 Shape and scale distortions increase near points 90 degrees from the central line.   The Behrmann projection uses  
 30:00 North as the parallel of no distortion.  

CONIC PROJECTIONS

• Albers Equal Area Conic:  A conic projection that distorts scale and distance except along standard parallels.  
 Areas are proportional and directions are true in limited areas.  Used in the United States and other large  
 countries with a larger east-west than north-south extent.  
• Equidistant Conic:  Direction,  area,  and shape are distorted away from standard parallels.  Used for portrayals of  
 areas near to,  but on one side of,  the equator.  
• Lambert Conformal Conic:  Area,  and shape are distorted away from standard parallels.  Directions are true in  
 limited areas.  Used for maps of North America.  
• Polyconic:  The polyconic projection was used for most of the earlier USGS topographic quadrangles.  The  
  projection is based on an infinite number of cones tangent to an infinite number of parallels.  The central  
 meridian is straight.  Other meridians are complex curves.  The parallels are non-concentric circles.  Scale is true  
 along each parallel and along the central meridian.  

AZIMUTHAL PROJECTIONS

• Azimuthal Equidistant:  These projections are sometimes used to show air-route distances.  Distances measured  
 from the centre are true.  Distortion of other properties increases away from the centre point.  
• Lambert Azimuthal Equal Area:  Is sometimes used to map large ocean areas.  The central meridian is a straight  
 line,  others are curved.  A straight line drawn through the centre point is on a great circle.  
• Orthographic:  Are used for perspective views of hemispheres.  Area and shape are distorted.  Distances are true  
 along the equator and other parallels.  
• Stereographic:  Are used for navigation in polar regions.  Directions are true from the centre point and scale  
 increases away from the centre point as does distortion in area and shape.  

MISCELLANEOUS PROJECTIONS

• Unprojected Maps:  Include those that are formed by considering longitude and latitude as a simple rectangular  
 coordinate system.  Scale,  distance,  area,  and shape are all distorted with the distortion increasing toward the  
 poles.  
• Mollweide:  Used for world maps,  is pseudocylindrical and equal-area.  The central meridian is straight.  The 90th  
 meridians are circular arcs.  Parallels are straight,  but unequally spaced.  Scale is true only along the standard  
 parallels of 40:44 N and 40:44 S.
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• Eckert IV Equal Area:  Used for world maps,  is a pseudocylindrical and equal-area.  The central meridian is  
  straight,  the 180th meridians are semi-circles,  whereas other meridians are elliptical.  Scale is true along the  
 parallel at 40:30 North and South.  
• Eckert VI Equal Area:  Is also used for maps of the world,  and is pseudocylindrical and equal area.  The central  
  meridian and all parallels are at right angles,  all other meridians are sinusoidal curves.  Shape distortion increases  
 at the poles.  Scale is correct at standard parallels of 49:16 North and South.  
• Robinson:  Is based on tables of coordinates,  not mathematical formulas.  The projection distorts shape,  area,   
 scale,  and distance in an attempt to balance the errors of projection properties.  
• Sinusoidal Equal Area:  Maps in this projection have straight parallels at right angles to a central meridian.   
  Other meridians are sinusoidal curves.  Scale is true only on the central meridian and the parallels.  Often used in  
 countries with a larger north-south than east-west extent.  

DATUMS AND ELLIPSOIDS OVERVIEW

An ellipsoid is a mathematical figure generated by the revolution of an ellipse about one of its axes.  The earth 
is not a sphere but an ellipsoid distorted by rotation about its axis,  with the globe bulging at the equator and 
flattened at the poles.  The actual amount of the flattening is approximately 21.5 km difference between the polar 
and equatorial radii.  Ellipsoidal earth models are required for accurate range and bearing calculations over long 
distances.  For example GPS navigation receivers use ellipsoidal earth models to compute position and waypoint 
information.  Ellipsoidal models define an ellipsoid with an equatorial radius and a polar radius.  The best of these 
models can represent the shape of the earth over the smoothed,  averaged sea-surface to within about 100 metres.

Reference Ellipsoids are usually defined by semi-major (equatorial radius) and flattening (the relationship  
between equatorial and polar radii).  Other reference ellipsoid parameters such as semi-minor (polar radius) and  
eccentricity can be computed form these terms.

A datum is a mathematical model that describes the shape of the ellipsoid,  and orientation of coordinate systems 
used to map the earth.  A datum is a smoothed mathematical surface of the earth’s mean,  sea level surface.  
Different nations and agencies use different datums as the basis for coordinate systems in GIS.   

Modern datums range from flat-earth models used for plane surveying to complex models used for international 
applications which completely describe the size,  shape,  orientation,  gravity field,  and angular velocity of the earth.  

DATUM EXAMPLES

• NAD27: For many years the North American Datum of 1927 was the standard in the United States.  NAD27 was  
 based on the Clarke Ellipsoid of 1866,  which was developed from ground survey in Europe and North America in  
 the 19th Century.   The centre point for NAD27 is Meades Ranch in Kansas,  USA.
• NAD83: During the 1970’s and 1980’s satellites were able to measure the ellipsoid flattening more accurately  
 (the World Geodetic System ellipsoid of 1984 or WGS84) and a new datum was developed from these   
 measurements called the North American Datum of 1983.  The Global Positioning System is based on WGS84.    
 The centre point for NAD83 is the centre of the earth’s mass and uses the GRS80 spheroid which factors in the  
 earth’s equatorial bulge.  
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MAPUBLISHER 6 PROJECTIONS

MAPublisher 6 contains choices from over 4500 supported coordinate systems,  based upon a wide variety of 
projections,  ellipsoids and datums.   Coordinate systems are listed in the following categories inside the MAP View 
Editor and Source Projection dialogs.  Note that some coordinate systems may exist in a number of categories.

Technical Reference Guide: All About Projections

-ALL PROJECTIONS-
(Lists all the projections in the database)

-CUSTOM-
(Lists projections added to the database via import)

-RECENTLY USED-
(The last 20 projections used)

-SEARCH ________-
(Lists the most recent results of a  ‘Search Projection’ )

BY CLASS ...
 ... Azimuthal 
 ... Conic
 ... Cylindrical
 ... Polyconic
 ... Pseudoconic
 ... Pseudocylindrical

BY GEOGRAPHICAL AREA ...
 ... Africa
 ... Asia
 ... Australia & NZ 
 ... Canada  
 ... Common Global Projections  
 ... Common Regional Projections  
 ... EPSG 
 ... Europe 
 ... Pacific 
 ... US (others) 

BY PROPERTY ...
 ... Compromise 
 ... Conformal 
 ... Equal Area 
 ... Equidistant 
 ... Latitude/Longitude 
 ... Perspective 

BY SCOPE
 ... Continent 
 ... Hemisphere 
 ... Region 
 ... World 

BY USE ...
 ... Geological 
 ... Navigation 
 ... Presentation 
 ... Thematic 
 ... Topographic 
 ... USGS-suitable 

STATE PLANES ...
 ... State Planes (HPGN) 
 ... State Planes (HPGN,  FT) 
 ... State Planes (HPGN,  IFT) 
 ... State Planes (NAD27) 
 ... State Planes (NAD83) 
 ... State Planes (NAD83,  FT) 
 ... State Planes (NAD83,  IFT) 

UTM ... 
 ... UTM (ERP50-W) 
 ... UTM (HPGN) 
 ... UTM (HPGN,FT) 
 ... UTM (HPGN,IFT) 
 ... UTM (INTNL) 
 ... UTM (NAD27) 
 ... UTM (NAD27,FT) 
 ... UTM (NAD27,IFT) 
 ... UTM (NAD83) 
 ... UTM (NAD83,FT) 
 ... UTM (NAD83,IFT)

Abbreviations:
ERP50-W: European Datum,  1950,  West
EPSG: European Petroleum Survey Group
FT:   in Feet
HPGN: High Precision Geodetic Network
IFT:  in International Feet
INTNL:  International
NAD27: North American Datum,  1927
NAD83: North American Datum,  1983
UTM:  Universal Transverse Mercator
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WORKING WITH CUSTOM COORDINATE SYSTEMS

A coordinate system within MAPublisher defines a mathematical model of the conversion between a specific 
location on the earth and a set of coordinates.  Coordinate system definitions are specified by a set of parameters 
that define this mathematical model,  including the earth model (ellipsoid or datum),  the units used to measure 
the coordinates,  the projection type,  and any parameters specific to the projection type.  Coordinate systems may 
be extracted from input feature data sources,  may come predefined or may be defined by MAPublisher users.  
MAPublisher allows output coordinate systems that are different than the input ones to be specified and performs 
the required coordinate conversions when necessary.

MAPublisher 6 currently contains 4515 coordinate systems which are defined by a wide range of differing  
projections,  datums and ellipsoids.  Even though the current list of selections is comprehensive there may be 
instances where the end user may wish to add a brand new coordinate system to meet their particular needs,  or 
perhaps to modify an existing definition to change the units for example.  In either case the coordinate system 
database files that accompany MAPublisher may be edited directly by the end user so that new/modifed entries can 
be permanently stored within the defined list of coordinate system options.

Before commencing the process of creating a custom coordinate system,  ensure that Adobe Illustrator is closed.

CREATING A CUSTOM COORDINATE SYSTEM

The following pages will deal with the process of defining a custom coordinate system.  For advanced users,  please 
refer to the Safe document entitled ‘FME_CS_Support.pdf’ which is located in the Documentation folder of the 
MAPublisher 6 CD,  or at the following link:  http://www.avenza.com/support.docs.html
Certain procedures in this section may require additional instructions which can be found in this PDF.  

Creating new or modifying existing coordinate systems is a two step process based on the editing the following 
files,  “LocalCoordSysDefs.fme”and “Coordsys.db”.   The contents of these files may be viewed and edited in a 
simple text editor such as Notepad or SimpleText.   It is strongly recommended that you backup the original 
versions of these files prior to attempting to edit or modify them.

DEFINING THE NEW COORDINATE SYSTEM

In order for a new coordinate system to be recognized within MAPublisher,  the coordinate system must first be 
defined within the “LocalCoordSysDef.fme” file.  This file is typically located in the following directory:

Windows:  C:\Program Files\Avenza\MAPublisher\FME\reproject 

Macintosh:  Library : Frameworks : FMEObjects.Framework : Resources : FMECore.bundle* :    
  Contents : Resources : FME_HOME : Reproject
* Note that if this folder is ‘packed’,  you must ‘Ctrl-click’ the icon,  and select ‘Show Package Contents’ from the dropdown.

Open this file in a text editor.  This file contains the names and descriptions of all predefined coordinate systems.   
Within it are a series of lines entitled: “COORDINATE_SYSTEM_DEF”,   “DATUM_DEF”,   “ELLIPSOID_DEF”,   and “UNIT_DEF” 
which define additional,  site-specific coordinate systems.  

Custom Projections
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As an example,  the NAD83 based UTM Zone 12  coordinate system,  defined in the “LocalCoordSysDef.fme” file,  
would be similar to the text below.  The meanings of these values are described in (brackets).

COORDINATE_SYSTEM_DEF UTM12N83 \  (Coordinate System Name)
DT_NAME NAD83 \    (Datum Name)
PROJ TM \     (Projection Type)
UNIT METER \      (Unit Type)
DESC_NM “NAD83 based on UTM Zone,  meter”  \ (Descriptive Name)
SOURCE “Source description” \   (Source of the definition)
PARM1 -111.0 \     (Additional parameter unique for this coordinate system)
SCL_RED 0.9996 \    (Additional parameter unique for this coordinate system)
ORG_LAT 0.0 \     (Additional parameter unique for this coordinate system)
X_OFF 500000.0 \     (Additional parameter unique for this coordinate system)
Y_OFF 0.0 \     (Additional parameter unique for this coordinate system)
MAP_SCL 1.0     (Additional parameter unique for this coordinate system)

DEFINING COORDINATE SYSTEM VARIABLES

The following table provides an overview of the basic parameters required for defining a Local Coordinate System.  
Note that not all of the parameters shown above are required for all coordinate systems definitions.  Please refer to 
pages 99-107 of the ‘FME_CS_Support.pdf’ document for unique requirements of each projection type.

NAME  RANGE  DESCRIPTION     OPTIONAL?

<coordSysName> Any string The name of the coordinate system being  defined No
      may be used to identify the coordinate system of a
      reader or writer.

<unit name> See supported The name of the units used to measure   No
    Coordinate Units coordinates in the coordinate system.
    (*page 84) 

<projType> See supported The type of map projection used for this definition.   No
    Projection Types Determines which additional parameters may     
    (*page 85) need to be specified.   

<parameter> Dependent on Each projection system makes use of a set of   No
    the Projection parameters.  
    Type selected  

<datumName> See supported The datum to be used for the projection.    Yes
    Datums  Either a datum or an ellipsoid must be
    (*page 115) specified for each coordinate system.

<ellipName> See supported The ellipsoid to be used for the projection                         Yes
    Ellipsoids Either a datum or an ellipsoid must be
    (*page 136) specified for each coordinate system.     

*Refers to page number in the  ‘FME_CS_Support.pdf’
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NAME  RANGE  DESCRIPTION     OPTIONAL?

<quadrant> -4..4  The quadrant of the Cartesian coordinate  Yes
      produced by the coordinate system.                                                                             
      See Quadrant (*page 140)

<descript.  name> any string A descriptive name of the definition.   Yes

<source> any string Person or agency supplying the definition.    Yes

*Refers to page number in the  ‘FME_CS_Support.pdf’

REFERENCING THE NEW COORDINATE SYSTEM 

Once the definitions are defined in the “LocalCoordSysDef.fme” they are then referenced by the “Coordsys.db” file.
This file is typically located in the following directory:

Windows:  C:\Program Files\Avenza\MAPublisher\FME\ 

Macintosh:  Library : Frameworks : FMEObjects.Framework : Resources : FMECore.bundle* :    
  Contents : Resources : FME_HOME
* Note that if this folder is ‘packed’,  you must Ctrl-click the icon,  and select ‘Show Package Contents’ from the dropdown.

The “Coordsys.db” file contains the names and descriptions of all predefined coordinate systems.  This is where you 
need to reference the coordinate system defined in the “LocalCoordSysDef.fme” file.  Special attention must be given 
to naming conventions and to ensuring that the definition name,  coordinate system description,  units,  and datum 
variables all coincide with parameters specified in the associated coordinate system definition.  If you do not adhere 
to these principles,  conflicts will occur during the startup process.

As an example,  the NAD83 based UTM Zone 12  coordinate system,  defined in the “Coordsys.db” file,  would be 
similar to the text below.  

UTM12N83 | NAD83 based on UTM Zone,  meter | WORLD | NAD83 |  | TM | METER  
[ * CR ]

[ * CR ]  You must enter a carriage-return here

The meanings of these values,  in the same order as the text above,  are as follows.
<Coordinate System Name> | <Description of Coord System> | <Group> | <Datum> | <Ellipsoid> | <Projection> | <Units>

ACCESSING THE NEW COORDINATE SYSTEM 

Once the definition has been successfully created and saved in the “LocalCoordSysDef.fme” and “Coordsys.db” 
files,  restart Illustrator to access the new definition as a selectable choice in the coordinate systems dropdown list.
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UTM Zone Map

UTM
Zone

1
2
3
4
5
6
7
8
9

10
11
12
13
14
15
16
17
18
19
20
21
22
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24
25
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28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
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Central
Meridian

177W
171W
165W
159W
153W
147W
141W
135W
129W
123W
117W
111W
105W
99W
93W
87W
81W
75W
69W
63W
57W
51W
45W
39W
33W
27W
21W
15W
9W
3W
3E
9E

15E
21E
27E
33E
39E
45E
51E
57E
63E
69E
75E
81E
87E
93E
99E

105E
111E
117E
123E
129E
135E
141E
147E
153E
159E
165E
171E
177E

Longitude
Range

180W-174W
174W-168W
168W-162W
162W-156W
156W-150W
150W-144W
144W-138W
138W-132W
132W-126W
126W-120W
120W-114W
114W-108W
108W-102W
102W-96W
96W-90W
90W-84W
84W-78W
78W-72W
72W-66W
66W-60W
60W-54W
54W-48W
48W-42W
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108E-114E
114E-120E
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126E-132E
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138E-144E
144E-150E
150E-156E
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162E-168E
168E-174E
174E-180E
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Tips and Hints

CREATING ASCII DELIMITED POINT FILES

There may be times when you wish to add a point or a series of points to your map but you do not have a GIS 
or ASCII file containing these points ready for import.  Provided you have the real-world coordinates for the 
locations you wish to plot*,  you can manually create a delimited ASCII file using a text editor (ex.  Notepad,  BBEdit,  
SimpleText,  Ultra Edit etc.) or a spreadsheet program (ex.  Excel,  Lotus 123 etc.).   This file can then be imported 
using either Simple or Advanced Import using the ASCII Point Data import format.

One column in the file must contain the X coordinates of the points and another must contain the Y coordinates.  
You can add as many additional columns as you wish containing additional information to be imported as attribute 
data.

If you are using a text editor,  you can simply type in your data in the following format:

“Column 1 Header”,”Column 2 Header”,”Column 3 Header”...etc
“Column 1 Value 1”,”Column 2 Value 1”,”Column 3 Value 1”...etc
“Column 1 Value 2”,”Column 2 Value 2”,”Column 3 Value 2”...etc

Note that negative values for the X and Y coordinates denote west longitudes and south latitudes,  respectively.  
Also make sure to enter a carriage return using the “enter” key on your keyboard after the last line of data otherwise 
the last line may be ignored by the MAPublisher Point Importer.

If you are using a spreadsheet application you can enter your point information as a table and save the file in a text 
format,  preferably .csv or .txt,  choosing either comma or tab delimiting.  The spreadsheet application will format 
the text automatically.  The screenshot below illustrates an example of such a table in Microsoft Excel prior to 
exporting as a .csv or .txt for import into Adobe Illustrator using MAPublisher 6.

*Note the MAP Location Tool can be used to generate the X and Y coordinate values suitable for building ASCII Point Files. 
See page 37 for more information.
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JOINING SDTS TABLES

The following information should be used in conjunction with the MAPublisher Join a Table function.

When working with United States Geological Survey SDTS files it is necessary to join tables frequently in order to 
obtain the map attribute table you require to make the map you want.  This is due to the fact that SDTS data is 
constructed such that the primary vector data is held separately from the various attribute tables that one might 
want to use for a particular mapping purpose.  The attribute table that comes as part of the vector file usually 
contains a unique identifier (RCID) for each map element that is used to join it with the other data tables.  For 
example,  a particular vector file containing the geography of rivers would contain a data column called RCID.  
Various data tables containing information such as vegetation,  fish counts or flow rates might be available each 
also with an RCID column.  The desired tables are then joined to the initial map attribute table by RCID value using 
the techniques described in the previous pages.  

To find the SDTS tables to join with the vector map file look for the files which have names that start with the same 
character string as the name of the vector file.  MAPublisher 6 imports SDTS files that have the characters “CATD” at 
the end of the file name.  A typical table to import and join with this file might be called HY01CATD.ddf.

Use the MAPublisher table importer with SDTS file type chosen to import these files.  When you join layer and table,  
you do the join based on the column from the layer matched to the RCID column of the table.  Several SDTS sample 
files can be found on your MAPublisher CD in the SDTS_samples folder.  Note that the CATD catalog file found 
amongst the SDTS files explains what each table is.

ROTATING OBJECTS INDIVIDUALLY IN ADOBE ILLUSTRATOR

On some occasions you may wish to rotate selected objects about their own centres rather than as a group about a 
common origin.  This can be accomplished using the native Adobe Illustrator Transform Each function.  To use this 
function,  first select the objects you wish to rotate.  Then go to Object > Transform > Transform Each.  In the “Rotate” 
box enter a desired rotation value and click OK.  Each of the selected objects will be rotated individually about their
own centres.

You may also use the Edit Column filter to individually rotate point symbols or text items based on a specified 
variable or by the contents of an attribute column.  See pages 43-44 for guidelines on how to use this function.

BUILDING COLOUR-RAMP LEGENDS

You can enhance the look of your maps by using colour ramps,  rather than random colours,  for your legends.
1.   Build a vertical set of filled legend elements on a Legend Layer.
2.  Assign legend information to the elements using either Assign Legend Info or Auto Assign Legend Info (see  
  pages 64-68)
2.   Colour the first (top) and last (bottom) elements with the two extreme end colours for the ramp.
3.   Marquee select the complete set of legend elements.
4.   Select Filter > Colors > Blend Vertically and the legend elements will be blended between the two end colours.
5.   You can then select Filter > MAP Legend > Draw Legend Layer to update your map.
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GEOREFERENCING AN ADOBE ILLUSTRATOR FILE

If you are using an existing Illustrator file that was created without the use of MAPublisher and as such does not 
contain any geographic parameters or attribute data,  the following steps will enable you to georeference your 
Illustrator file and ultimately create an attribute-rich and accurate scale and world grid structure for your map.  
Please note that the steps that follow refer to functions that are outlined in more detail in the body of this user 
guide.  Please familiarize yourself with the main MAPublisher functions and in particular those under the MAP Views 
section (pages 45-53) before proceeding.

Before beginning to georeference an Adobe Illustrator file you must be in possession of the following information:
1.  The real-world scale of your data
2.  Details of the coordinate system the data is in (i.e.  Projection,  Datum etc)
3.   The X-Y coordinates of one tie-in point in the coordinate system of your data

When you have this information please use the following guidelines in order to georeferencing data with 
MAPublisher in Adobe Illustrator.  

1.   Go to View > Show Rulers.  Set the 0,0 point to the lower left hand corner of the page by double-clicking on the  
  cross hairs in the upper right corner.
2.   If you have a completed Illustrator vector file go to step 3.  Otherwise,  place and digitize your raster image.
3.   Identify a registration or ‘tie-in’ point in your document.  This should be a specific location in your document for   
  which a real-world coordinate location is known or can be easily determined.  Record the location of this point  
  in real world coordinates on a piece of paper.
4.   Locate the same tie-in point on the Illustrator document page and determine its X,Y coordinates in page units.   
  Record this number as well using Window > Info.
5.   You should now have the location of your tie-in point in both map and page units (e.g.  –79.5,  43.5 in Lat/Long is  
  located at 4cm,  2cm in the document).
6.   Open the MAP Views palette,  navigate to the Options section and select New MAP View.
7.   Enter a name for the MAP View.  Set the Scale to the proper scale of the map (i.e.  a set distance in document  
  units divided by a set distance in ground units).
8.  Click the Source Projection button.  Choose a projection which matches that of your vector data and click OK.
9.  Click OK in the MAP View Editor to apply the information to the new MAP View.
10.  In the MAP Views palette,  navigate to the Options pullout,  and then click on Specify Anchors.  
11.  Set the Map Anchors to the value of the tie-in location in map units using the values determined in step 3 (e.g.   
  –79.5,  43.5).
12.  Set the Page Anchors to the value of the tie-in location in Page Units using the values determined in step 4 (e.g.   
  4,  2).  Then click OK.
13. If you have not previously done so,  ensure that each layer in your Adobe Illustrator file contains only one feature  
  type (Point,  Area,  Line, Text, Legend).  
13. In the MAP Views palette drag each of the layers which contain your data in to your new MAP View,  ensuring  
  that you set the appropriate Feature Type in the Undefined Layer dialog.
14.  Repeat steps 1-13 for any other coordinate systems which exist in your document (such as inset maps for  
  example).
15.   Your document is now a georeferenced MAPublisher file wherein each feature is also georeferenced and  
  capable of accepting attributes using the MAP Attributes function (see pages 38-39).  You can also use the  
  MAPublisher Export function to create a GIS file from this newly georeferenced Illustrator map.
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TIPS ON EXPORTING TO OTHER GIS SOFTWARE WITH MAPUBLISHER

These strategies do not focus on how to do the procedures,  as these are discussed in the Export section (page 52),  
but more on what you need to know and understand for successful export results.

First and most importantly you need to understand that the MAPublisher export was designed to export MP 
imported or created data one layer and one feature at a time.  Why is it important to know this? MAPublisher 
only recognizes objects that have been imported by or created with its filters.  If a layer was not imported with 
MAPublisher or is not hosted by a designated MAP View,  then MAPublisher will not allow you to export the layer.  

If you have an entire layer that was not created by MAPublisher then:
1.  Ensure that your layer contains only a single feature type (Point,  Area,  Line or Text).  
2.  In the MAP Views palette,  check that you have a designated MAP View with a matching coordinate system.  If  
  you do not,  create a new MAP View (see page 47).
3.   Select the layer in the MAP Views palette.
4.   Drag the layer to the MAP View containing the matching coordinate system to georeference the layer.  

There are also a couple of additional considerations to be aware of when exporting:

Since the current exported vector formats are GIS formats that do not support the concept of Bezier curves you 
need to compensate for this.  If you have Bezier curves in your Adobe Illustrator file they will not be recognized in 
the GIS software.  In order for these features may be represented correctly you will need to add points to these lines 
in Illustrator first.  Simply identify and select any objects that use Bezier curves and then select Object > Path > Add 
Anchor Points.  Repeat this command until the line has a sufficient number of anchor points that the shape of your 
curves will not be lost on export.

Adobe Illustrator stores the origin of text that has been applied along paths differently from other text objects.  We 
have found the following steps to be the most successful way to get such Text exported to GIS files:
1.  Create a new Illustrator layer
2.   Select any text that has been created along paths.
3.  Drag this text to the new Illustrator layer
4.  Select Type > Create Outlines.  The text will be converted to vector objects.
5.  In the MAP Views palette,  drag this layer back into your MAP View,  specifying Area as the feature type
You can now export your Text as Area objects.  Since the text is no longer text,  you can no longer modify the fonts.  
We recommend that you make a copy of the original text objects before you do this process.  These hints on how 
to transfer Illustrator files are necessary because the graphics environment handles text and curves differently and 
they need some modification in order for the GIS software to represent these accurately.

IRREGULAR TEXT ALONG LINES AND HOW TO FIX IT

Sometimes when text is applied along lines the results are less than optimal,  with text elements falling off the line.  
This happens because there are two or more nodes in one place.  The following steps should help fix this in your 
document.  The solution is to run the MAPublisher Spline Lines filter on the lines to quickly eliminate the redundant 
nodes before applying text.  If there is a concern about modifying the source,  you can run the Join Lines filter on the 
layer (with the label field as the join field) to make a second joined layer that can then can then be splined.  The first 
layer is for unmodified linear feature symbolization and the second layer is used only for the text labeling.  Remove 
the splined vectors after you apply the text,  and before adjusting positioning of your text.
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DOUGLAS-PEUCKER LINE SIMPLIFICATION

The Douglas-Peucker algorithm was primarily designed to reduce the number of points required to represent a 
vector line.  A common problem in digital cartography and geographic information systems can occur when lines 
are generated automatically from a mathematical function,  which records points at a fixed interval regardless if 
they are all lying along a straight line.  A reduction of the number of points makes for a cleaner and more readable 
cartographic line.  As well in cartographic work within Adobe Illustrator the removal of points along a path can 
significantly improve the speed of file redraws and reduce the overall file size.

The Douglas-Peucker Algorithm was created in Fortran 66 by David H.  Douglas and Thomas K.  Peucker at the 
University of Ottawa in 1970-71.  It was extensively tested in 1972 and was publicly communicated in the following 
article: “Algorithms for the Reduction of the Number of Points Required to Represent a Digitized Line or Its 
Caricature”,  ‘Canadian Cartographer’,  Vol.  10,  No.  2,  December 1973.

There are a number of online resources where more information may be found on the Douglas-Peucker algorithm 
including http://citeseer.nj.nec.com/hershberger92speeding.html and 
http://www.cs.unc.edu/~mantler/safesimp/safeset/sld004.html.

TIPS ON EXPORTING DATA TABLES

You can export any data tables that are linked to physical features in MAPublisher.
a)   To export as a comma-delimited data table,  export the desired features as MapInfo mid/mif format.  The export  
  file with the extension .mid will contain your attribute data in comma delimited form.
b)  To export as a DBF data table,  export the desired features as Arcview shape files format.  The export file with the  
  extension .dbf will contain your attribute data in standard DBF format.

BEZIER CURVES AND OTHER MAPUBLISHER OPERATIONS

Bezier curves are defined using four control points.  Two of these are the end points of the curve,  while the other 
two effectively define the gradient at the end points.  These two points control the shape of the curve.  The curve is 
actually a blend of the control points.  This is a recurring theme of approximation curves; defining a curve as a blend 
of the values of several control points.

Most GIS formats do not usually support bezier curves used in graphics packages such as Adobe Illustrator.  As such 
you will typically find that curved sections of GIS data will be composed of a series of small line segments rather 
than an actual curve.  This is also how such features will first appear in Illustrator when imported with MAPublisher.  
The MAPublisher Simplify Lines filter can be used to convert this type of feature into a Bezier curve (see page 92).

If Bezier curves are exported from Illustrator using any of the MAPublisher Export filters they will be converted 
to link and node topology (i.e.  the end points of the curve will simply be joined as straight lines).  It is therefore 
necessary to create additional points to curves to retain their true shape.  This can be done globally by using the 
Illustrator’s Add Anchor Points function via Object > Path > Add Anchor Points.

This version of MAPublisher supports Bezier curve features during the following operations:
•   Scale and Projection transformations via the MAP View Editor
•   Area and length calculations
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CREATING SYMBOLS FOR USE IN POINT STYLESHEETS

A MAPublisher Symbol Library and a National Parks Symbol Library are supplied in the Utilities folder on the 
MAPublisher 6 CD.  You may also find that a search on the internet may be useful for finding additional libraries.  
Please refer to Tutorial 7-iii:  ‘Creating a Point Stylesheet’ for information on using such libraries for use in MAP 
Stylesheets.  If you are required to create new symbols,  the steps below will help you to quickly create symbols 
manually in Adobe Illustrator.

1. Use Adobe Illustrator’s tools for the manual creation of artwork that will comprise the new symbol.  If you  
 wish to use a character that are contained in a font library,  select the text character instance and go to Type > 
 Create Outlines to convert the text to vector art.
2. Open the Illustrator Symbols palette (Window > Symbols).
3. Select the artwork that will comprise the new symbol and drag it into the Illustrator Symbols palette.  Double  
 click the symbol in this palette to assign a name.
4. When Edit MAP Stylesheet is accessed for Point Stylesheets,  this symbol will be available in the Style column.

CREATING A LEGEND TEMPLATE

You can create template files with legends to automate the production of a series of similar maps.  

The procedure when using MAP Stylesheets is as follows:
1.   Create a prototype map using the MAPublisher Stylesheet function to create the desired “look”.
2.   Make a copy of your prototype map file.  Delete all the layers from the file so that only the designated   
  Stylesheets exist
3.  Save it to a new template file.  
4.   Use this template file as a base for future maps as follows:
a)   Make a copy of the template file.
b)  Import all map layers into the template file and do any needed processing.
c)   In the MAP Stylesheets palette,  drag your MAP Layers into the desired MAP Stylesheets.  
d)  Your new layers will be symbolized by the previously defined Stylesheet.

The procedure when using Assign Legend Info or Auto Assign Legend Info is as follows:
1.   Create a prototype map using the MAPublisher Legend filters to create the desired “look”.
2.   Make a copy of your prototype map file.  Delete all the map objects except the Legend Layer elements.
3.  Save it to a new template file.  
4.   Use this template file as a base for future maps as follows:
a)   Make a copy of the template file.
b)  Import all map layers into the template file and do any needed processing.
c)   Drag the Legend Layer into the MAP View that contains the features you wish to apply the legend to.
d)  With the appropriate legend elements selected,  select Filter > MAP Legends > Draw Legend Layer.  
e)  Your new layers will be symbolized by the previously defined legend elements.
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The U.S.  Geological Survey offers many different types of map products including the following:

 • Antarctic    • National Atlas    • Special Maps
 • Geologic    • Photo-image    • Topographic
 • Hydrologic    • Planets and Moons   • Topographic-Bathymetric
 • Land Use    • Satellite Image

ANTARCTIC

Antarctic maps are available in four different scales:

1:250,000  
A topographic reconnaissance and a geologic reconnaissance series at this scale has contour intervals of 200 meters 
and show Bathymetric information for coastal areas.  The topographic series is the primary map source for the 
planning,  logistic support,  and multi-disciplinary investigations of the U.S.  Antarctic Research Program.

1:500,000  
Three series of maps - topographic reconnaissance shaded-relief,  satellite image,  and sketch - are published at this 
scale.  The satellite imagery was recorded by NASA’s Landsat.

1:1,000,000  
Topographic maps and Landsat maps are published at this scale.  Topographic maps in the International Map of the 
World (IMW) format have contours at 100,  300,  or 500 meters.

1:2,188,800  
A reconnaissance sketch and topographic map of the Ross Ice Shelf at this scale was made in support of the Ross Ice 
Shelf Geo-physical and Glaciological Program.

GEOLOGIC

The USGS makes many kinds of geologic maps as a part of a continuing program to fulfill one of its missions: to 
examine the geological structure,  mineral resources,  and products of the national domain.  USGS maps that portray 
the geology of regions or local areas are available for over 50% of the United States.

HYDROLOGIC

Hydrologic Investigations Atlases (HA Series) are either black-and-white or multicoloured maps showing a wide 
range of water-resources information,  such as depth to ground water,  floods,  irrigated acreage,  producing 
aquifers,  availability of water on Indian lands,  surface-water discharge to the oceans,  chemical or mineral content 
of water,  surface impoundments,  and water temperature.  Flood-prone area maps (scale of 1:24,000) are available 
by quadrangle name,  from the Water Resources Division District Office in the State of interest.

LAND USE

Land use refers to human uses of the land (for example,  for housing and industry).  Land cover describes the 
vegetation,  water,  natural surfaces,  and construction on the land surface.  Standard base map features include 
boundaries,  cities and towns,  railroads,  roads and highways,  rivers and lakes - but no contours.  Land use and land 
cover maps are available for most of the United States.  Land use and land cover data are shown on USGS base maps 
at a scale of 1:100,000 for a few maps in Western States or at 1:250,000 (most maps).

USGS Data Backgrounder
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NATIONAL ATLAS

The National Atlas of the United States of America (1970) contains 765 maps and charts on 335 pages.  This Atlas 
is now out of print,  but can be found in many libraries.  Separate sheets of selected reference maps and thematic 
maps from the Atlas are available from the USGS.  Some of the sheets have been updated.

PHOTO-IMAGES

Orthophoto Maps are multicoloured,  distortion-free,  photographic image maps.  They show subtle topographic 
detail in areas of very low relief,  such as marshlands and coastal zones.  They are produced in standard 7.5 minute 
quadrangle format from aerial photographs.  Scale of 1:24,000 or 1:25,000.

Orthophotos Quads are multicoloured,  distortion-free,  photographic image maps.  They have no contours,  
minimal cartographic treatment,  and only a few names and symbols.  Orthophoto quads are available for selected 
areas along the east coast of the United States.

Border Maps are natural colour photoimage maps.  They are available for the USA-Mexico border and the USA-
Canada border.

PLANETS AND MOONS

In 1960,  the USGS established an astro-geology program on behalf of NASA to support lunar and planetary 
exploration.  A prime activity of the program is the systematic mapping of the stratigraphy and structure of the 
Moon,  Mars,  Venus,  Mercury,  and the moons of the outer planets.  Many USGS maps of the Moon,  Mars,  Venus,  
Mercury,  and the moons of Jupiter and Saturn are now available for purchase by the public.  The maps include 
geologic,  topographic,  photomosaic,  and shaded-relief maps.  The scales,  projections and sheet sizes vary widely.

SATELLITE IMAGES

Satellite image maps are multicolour or black-and-white photograph-like maps made from data collected by Earth 
resources satellites.  They are a diverse group of experimental maps printed in a standard edition and in a variety 
of scales and sizes.  Many standard editions have topographic maps printed on the reverse side.  Most image maps 
are printed to simulate colour-infrared photography by combining imagery that was scanned in red,  green,  and 
infrared wave lengths of light.

On colour-infrared imagery,  healthy vegetation appears in shades of red.  Unhealthy vegetation appears in shades 
of pink,  blue,  or white.  Clear water appears dark blue or black.  Sediment laden water takes on a light-blue tone.  
Most cultural features appear as a steely blue-gray.  Satellite images are available for selected areas in about half of 
the States and such areas as Antarctica,  the Bahamas,  and Iceland.

SPECIAL MAPS

A wide variety of special maps are available for purchase from the USGS:
•   Geologic Map of the United States
•   Basement Rock Map of the United States - Exclusive of Alaska and Hawaii
•   Coal Fields of the United States
•   World Seismicity Map
•   Generalized Tectonic Map of North America
•   Surface Water and Related Land Resources Development in the United States and Puerto Rico
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Many other special USGS maps are published from time to time.  The USGS has also published several planimetric 
maps of the United States,  North America,  and the World.  Most of these maps show political boundaries,  major 
cities and capitals,  and many rivers and lakes.

TOPOGRAPHIC

Most USGS topographic maps use brown contours to show the shape and elevation of the terrain.  Elevations are 
usually shown in feet,  but on some maps they are in meters.  Contour intervals vary,  depending mainly on the scale 
of the map and type of terrain.  The maps show and name prominent natural and cultural (man-made) features.

7.5-Minute Maps
The best known USGS maps are those of the 7.5-minute,  1:24,000-scale quadrangle series.  On such maps,  1 inch = 
2,000 feet.  The scale of these maps is used for areas where much detail must be shown.

15-Minute Maps
From 1910 to about 1950,  maps showing an area within 15 minutes of latitude and longitude were the USGS 
standard for topographic coverage of the United States.  These maps were at a scale of 1:62,500 (1 inch = about 
1mile) and are still available.  Features shown on these maps are similar to those on 7.5-minute maps,  but some 
detail is omitted or generalized at the smaller scale.

U.S.  1:100,000-Scale Series
Much of the United States is covered by 30- by 60-minute quadrangle maps at a scale of 1:100,000.  Most of these 
maps are derived from 1:24,000-scale maps,  but they show distances and contour intervals in meters.  Contours are 
at intervals of 5,  10,  20,  or 50 meters depending on terrain relief.

County Map Series
A county map may consist of one or more sheets,  depending on the size of the county.  County maps are available 
in scales of 1:50,000 and 1:100,000.

U.S.  1:250,000 - Scale Series
Maps in the 1:250,000-scale (1 inch = about 4 miles) series are available for the entire United States.  They were 
originated by the U.S.  Army Map Service during the 1950s,  but are now maintained by the USGS.  This series serves 
as base maps for aeronautical charts and geologic maps,  for geographic reference,  and in planning regional land 
use,  transportation,  and utility systems.

State Map Series
The state maps in this series are usually published in three separate editions: base map,  highway and contour map,  
and shaded-relief map.  Most are at a scale of 1:500,000.  The features shown are limited to areas within the State.  
No areas adjoining States are shown except for shorelines and other water areas that form State boundaries.

U.S.  1:1,000,000 - Scale Series
This series of topographic maps has been discontinued by the USGS and will not be reprinted when the existing 
stock is depleted.  The ground area shown ranges from 73,734 to 122,066 square miles (123,000 to 204,000 square 
kilometers).  The maps show principal cities and towns,  railroads,  and political boundaries in black,  roads in red,  
water features in blue,  topography in brown,  contour lines and gradient tints.

National Park Map Series
Each of these topographic maps,  some of them with shaded relief,  feature a national park,  national monument,  or 
national historic site at a range of scales.  The maps are much like the standard quadrangle maps at the same scale,  
but they highlight recreational features.
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Shaded-relief Maps
USGS publishes shaded-relief editions of certain topographic maps to accentuate physiographic features of special 
interest,  and for some state,  Antarctic,  and national park maps.  These maps use shaded relief,  as well as contour 
lines,  to represent the shape of the terrain.

TOPOGRAPHIC-BATHYMETRIC

These USGS maps show in one format and one edition the data for a land-water area previously shown separately 
as a topographic map and a bathymetric map.  On topographic-bathymetric maps,  contour lines show elevations 
of the land areas above sea level,  and isobaths (depth contours) show the form of the land below the water surface.  
Some bathymetric maps show magnetic and gravitational data in addition to water depths.  Because coastal zones 
include both land and water,  maps of such areas must include both topographic and bathymetric data.  To
produce these coastal maps,  the National Ocean Service provides bathymetric data to be added to USGS 
topographic maps.  The combined map serves the needs of oceanographers,  marine geologists,  land use planners,  
physical scientists,  conservationists,  and others having an interest in management of the coastal zone,  the 
wetlands,  and the offshore environment.
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Appendix 2: Data List

The following is a list of the data included in the Tutorial Data folder on this CD.  These files are used in the example 
exercises in the Tutorials.pdf.

avginc.csv  ASCII comma-delimited table of income statistics for downtown Toronto

azdeci.txt  ASCII comma-delimited file containing point data for part of Arizona  

borneo.tfw  World file containing registration information for the borneo.tif image 

borneo.tif  A relief image of the island of Borneo in Tiff format

burlroads.mif  A MapInfo file of a few of the major roads, highways and railways of Burlington, Canada

canada.shp  A Shapefile of the provinces of Canada in Latitude/Longitude

capeverde.e00  An ArcInfo Export file of the Cape Verde Islands

fcstreets.mif  A MapInfo file of major roads in Falls Church County,  Virginia

fsatoronto.mif  A MapInfo file of the forward sortation areas (postal zones) of downtown Toronto

greenland.mif  A MapInfo file of Greenland

hypoint.e00  An ArcInfo Export file of Alberta,  Canada containing elevation points and values

income.mif  A MapInfo file of downtown Toronto containing various income statistics

italy.mif  A Mapinfo file of the outline of Italy

sicily.tif   A relief image of the island of Sicily in Tiff format

southchinasea.shp A Shapefile containing a map of the South China Sea and surrounding area.

toronto.ai   An Adobe Illustrator file of streets and postal areas in downtown Toronto

torontostreets.mif A MapInfo file containing road data for downtown Toronto.

torontostreetsjoined.mif A version of the torontostreets file containing lines joined by street name

ukpoly.shp  A Shapefile of the outline of the United Kingdom

ukrail.gen  An ArcInfo Generate file of railways in the United Kingdom

usa48.ai  An Adobe Illustrator file of the conterminous United States 

usa.tab   A MapInfo Table file of the United States

world.mif   A MapInfo file containing a political map of the world with statistical information 

worldeast.shp  A Shapefile containing the continents of Africa,  Antarctica,  Asia,  Europe and Oceania

worldwest.shp  A Shapefile containing the continents of North America and South America

Data List
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Appendix 3: Utilities List

The following utility programs and files are included on the MAPublisher 6 CD for your reference and convenience.  
They can all be found in the Utilities folder.  Please ensure you consult the Readme files before using these tools.

MACINTOSH UTILITIES

Utilities > MAP Actions

MAP_Actions.aia  Custom action set for the quick loading of MAPublisher windows and palettes

Utilities > MAP Styles and Symbols

MAP_AreaStyles.ai A custom library of 99 styles,  used for Area Stylesheets. 

MAP_LineStyles.ai A custom library of 99 style,  used for Line Stylesheets.

MAP_PointSymbols.ai A custom library of 99 symbols,  used for Point Stylesheets.

MIF_AreaStyles.ai A library of MapInfo MIF/MID area styles 1-71,  used for Area Stylesheets.

MIF_LineStyles.ai A library of MapInfo MIF/MID line styles 1-77,  used for Line Stylesheets.

DGN_LineStyles.ai A library of Microstation DGN line styles 1-7,  used for Line Stylesheets.

NP_PointSymbols.ai The National Park font library converted to symbols,  used for Point Stylesheets.

IAN Symbol Sampler.ai Sample Symbol library for Point Stylesheets,  created by the Integration and   
   Application Network,  University of Maryland Center for Environmental Science,  USA.

WINDOWS UTILITIES

Utilities > MAP Actions

MAP_Actions.aia  Custom action set for the quick loading of MAPublisher windows and palettes

Utilities > MAP Styles and Symbols

MAP_AreaStyles.ai A custom library of 99 styles,  used for Area Stylesheets. 

MAP_LineStyles.ai A custom library of 99 style,  used for Line Stylesheets.

MAP_PointSymbols.ai A custom library of 99 symbols,  used for Point Stylesheets.

MIF_AreaStyles.ai A library of MapInfo MIF/MID area styles 1-71,  used for Area Stylesheets.

MIF_LineStyles.ai A library of MapInfo MIF/MID line styles 1-77,  used for Line Stylesheets.

DGN_LineStyles.ai A library of Microstation DGN line styles 1-7,  used for Line Stylesheets.

NP_PointSymbols.ai The National Park font library converted to symbols,  used for Point Stylesheets.

IAN Symbol Sampler.ai Sample Symbol library for Point Stylesheets,  created by the Integration and   
   Application Network,  University of Maryland Center for Environmental Science,  USA.

Utilities > Shapechecker

shapechk.exe  A utility for checking the validity of shapefiles.

Utilities > MapInfo scripts

BulkLayerExport  A script for MapInfo Professional for batch exporting of mid/mif files.

Utilities List
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Appendix 5: Glossary

If you have difficulty with some of the GIS terminology used,  you can also access the following for more 
information:

http://srmwww.gov.bc.ca/gis/glosstxt.html
http://www.avenza.com/glossary.html

A
Accuracy
The closeness of results of observations,  computations or estimates to the true values or the values accepted as 
being true.  Accuracy relates to the exactness of the result,  and is distinguished from precision,  which relates to the 
exactness of the operation by which the result is obtained.

AGI
Association for Geographic Information.

Algorithm
A set of rules for solving a problem.

ASCII
American Standard Code for Information Interchange,  a widely used industry standard code for exchanging 
alphanumeric codes in terms of bit-signatures.

ANSI
American National Standards Institute,  an association formed by the American Government and industry to 
produce and disseminate widely used industrial standards.

Analog / Analogue
A continuously varying electronic signal.  Also refers to traditional paper mapping products and aerial photographs.

Annotation
The explanatory or descriptive alphanumeric text or labels on a map (or artwork),  such as street or place names.

Application
A set of computer programs designed for a specific task.

ArcInfo Export
File format with the extension .e00 for files exported from ArcInfo.

Area
A bounded continuous two-dimensional object,  which may or may not include its boundary.  Usually defined in 
terms of an external polygon or in terms of a set of grid cells.  A fundamental unit of geographical information.  See 
polygon.

Aspect
Individual azimuthal map projections are divided into three aspects: the polar aspect which is tangent at the pole,  
the equatorial aspect which is tangent at the Equator,  and the oblique aspect which is tangent anywhere else.  (The 
word ‘aspect’ has replaced the word ‘case’ in modern cartographic literature).

Attribute
Non-graphic alphanumeric textual information associated with a point,  line,  or area element in a GIS data set; 
tabular data associated with geographic features.

Glossary: A
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Azimuth
The angle measured in degrees between a base line radiating from a center point and another line radiating from 
the same point.  Normally,  the base line points North,  and degrees are measured clockwise from the base line.

B
Bezier Curve
A Bezier curve consists of two anchor points connected by a curved segment,  with at least one direction point and 
direction line attached to each anchor point.

Binary
A number system of base 2.  Numbers are represented simply as a series of 0’s or 1’s in contrast to base 10 number 
systems that represent numbers using the characters 0-9.  For example,  the base 10 number 65535 translates to the 
base 2 number 1111111111111111.  Binary numbers are the fundamental basis of computing.

Bitmap
A grid of small squares,  cells or pixels stored in memory and used to generate an image.

Boolean
There are two types of values: true and false.  True/false or yes/no usually represent these.

C
CAD(D)
Computer-Aided Drafting (Design).

Cadastre
A public register or survey that defines or re-establishes boundaries of public and/or private land for purposes of 
ownership and taxation.

Cartography
The organization and communication of geographically related information in either graphic or digital form.  It can 
include all stages from data acquisition to presentation and use.

CAST
Centre for Advanced Spatial Technologies,  University of Arkansas.

Cell
The basic element of spatial information in a raster image.

Clipping
A graphic process of cutting lines and symbols off the edge of a display area.

Colour Ramp
A graduated range of colours between two extreme colour selections.

Conformal
A map projection is conformal when at any point the scale is the same in every direction.  Therefore,  meridians and 
parallels intersect at right angles and the shapes of very small areas and angles with very short sides are preserved.  
The size of most areas,  however,  is distorted.

Contour
A line connecting points of equal elevation.
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Curvature
The amount of curve in line as defined by a series of points.

D
Data model
An abstraction of the real world which incorporates only those properties,  being relevant to the application at 
hand.  The data model would normally define specific groups of entities,  and their attributes and the relationships 
between these entities.  A data model is independent of a computer system and its associated data structures.

Database
A collection of data organized according to a conceptual structure describing the characteristics of the data and the 
relationships among their corresponding entities.

Database management system (DBMS)
A set of computer programs for organizing the information in a database usually containing routines for data input,  
verification,  storage,  and retrieval.

DEM
Digital Elevation Model.  DEM is a raster format used by the USGS to record elevation information.  Unlike other 
raster file formats,  DEM cells do not represent colour brightness values but rather the elevation of points on the 
earth’s surface.

Demographics
Statistics of birth,  death,  population,  etc.

Developable surface
A developable surface is a simple geometric form capable of being flattened without stretching.  Many map 
projections can then be grouped by a particular developable surface: cylinder,  cone,  or plane.

DGN
Native file format of MicroStation from Bentley Systems Inc.

Digital
The ability to represent data in discrete units or digits.

Digital Line Graph
USGS standard output file format.  These files can be in either Optional (.opt,  .do) or SDTS (.ddf ) form.

Douglas-Peucker Line Simplification Algorithm
A method of simplifying line data by removing unnecessary vertices.

Drag
To hold down the mouse button while you move the mouse cursor on the screen.

Drag and drop
The act of dragging a file with the mouse over another executable file to cause some action on the first file.

DTP
Desktop Publishing.

DWG
AutoCAD Drawing file.

DXF
AutoCAD Drawing Exchange Format.
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E
Element
A fundamental geographical unit of information,  such as a point,  line,  area,  or pixel.

EPS
Encapsulated Post Script file format The EPS format is used to transfer PostScript language artwork between 
applications - also see PostScript.

Equal areas
A map projection is equal area if every part,  as well as the whole,  has the same area as the corresponding part on 
the Earth,  at the same reduced scale.  No flat map can be both equal area and conformal.

Equidistant
Equidistant maps show true distances only from the center of the projection or along a special set of lines.  For 
example,  an Azimuthal Equidistant map centered at Washington shows the correct distance between Washington 
and any other point on the projection.  It shows the correct distance between Washington and San Diego and 
between Washington and Seattle.  But,  it does not show the correct distance between San Diego and Seattle.  No 
flat map can be both equidistant and equal area.

F
FAQ
Frequently Asked Question.

Feature
A set of points,  lines or polygons in a spatial database that represent a real-world entity.  The terms feature and 
object are often used synonymously.

Feature code
A set of characters (alpha,  alphanumeric or numeric) within the GIS,  which uniquely identifies a feature class or 
group of features.

File
A collection of related information that can be accessed by an assigned name.

Filter
See Plug-in filters.

Folder
A storage area for files within the Macintosh OS,  the equivalent of a DOS or UNIX directory.

Format
The way in which data is arranged for storage and for transmission between software and computers.

FTP
File Transfer Protocol.

G

Geographic features
Points,  lines,  and areas that comprise a map.
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Geographic Information System (GIS)
Any system designed for the capturing,  storing,  checking,  integrating,  analyzing and displaying of spatially 
referenced data about the earth.

Georeference
To establish the relationship between page coordinates on a planar map and known real-world coordinates.

GeoTIFF
An industry-wide standard for specifying information in TIFF tags which was developed by several organizations 
within the GIS community.  GeoTIFF files are raster images that contain georeferencing information as well as image 
information in a single file.

GIR
Geographic Information Retrieval.

GIS
Geographic Information Systems.

GPS
Global Positioning Systems.

Grain
The frequency of vertices or points forming a line.

Graticule
The spherical co-ordinate system based on lines of latitude and longitude.

Great Circle
A circle formed on the surface of a sphere by a plane that passes through the centre of the sphere.  The Equator,  
each meridian,  and each other full circumference of the Earth forms a great circle.  The arc of a great circle shows 
the shortest distance between points on the surface of the Earth.

Grid
A set of regularly spaced sample points or an exact set of reference lines over the earth’s surface.

H
Header File
A file associated with an image that contains georeferencing information for the image.  File extensions may be TFW 
or JPW (tiff,  jpeg World Files),  IRP (Image Report Files) or TAB (Table files).

Hydrography
In its most general definition,  hydrography is the description and study of seas,  lakes,  rivers,  and other bodies of 
water with regard to: the measurement of flow and investigation of the behaviour of streams; the measurement 
of tides and currents,  and the surveying,  sounding,  and charting of those bodies of water (Webster’s Third New 
International Dictionary,  1993).

Hypsography
Lines or points which depict the relief of the land or contours or spot elevations.

I
Icon
An image representing a software function or tool.



A5/6 A5/7Glossary: I-L

Image
A graphic representation or description of a scene,  typically produced by an optical or electronic device.  Examples 
include remotely sensed or satellite data,  scanned data,  and photographs.

Import sequence
The order of steps required to import data.

Integer
A number without a decimal.  Integer values can be less than,  equal to,  or greater than zero.

Isoline
A line on a surface connecting points of equal value for any of the characteristics used in the representation of the 
surface.

J
Join Lines
A function in MAPublisher for joining a set of linear features based on a common value such as street name.

JPEG
Joint Photographic Experts Group,  is a lossy compression technique for raster file formats.

L
Label
Text used to identify a map feature.

LANDSAT
The generic name for a series of earth resource scanning satellites launched by the United States of America.

Latitude
Angular distance,  expressed in degrees and minutes,  along a meridian north or south of the equator.

Lat/Long
Latitude/Longitude.  Unprojected.

Layer
A designated level in artwork used for storing,  organizing and editing graphic or mapping data.

Legend
The section of the map that explains the meaning of the symbols used to depict graphic or geographic elements.

Legend element
A legend key combined with its associated text.

Legend key
The graphic symbol used to illustrate attributes in a legend.

Longitude
The angular distance east or west from a standard meridian to another meridian on the earth’s surface; expressed in 
degrees and minutes.

Line
One of the basic geographical elements,  defined by at least two pairs of X,Y co-ordinates; usually too narrow to be 
an area.  See also arc,  path and vector.
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Linear scale
The relation between a distance on a map and the corresponding distance on the Earth.  Scale varies from place to 
place on every map.  The degree of variation depends on the projection used in making the map.

Lossless/Lossy
Lossless techniques compress image data without removing detail; lossy techniques compress images by removing 
detail.

M
MacOS
Apple Macintosh operating system.

Map
A graphic representation of features of the earth’s surface or other geographically distributed phenomena.

Map Anchor
The minimum X and Y coordinates of the data files.

Map Coordinates
The X,Y representations of ellipsoidal earth locations on a mapping plane.

Map Extent
The geographic extent of a geographic data set specified by the minimum bounding rectangle.

MAP Layer
A MAPublisher term for an Illustrator Layer containing Georeferencing Information.

Map Projection
A map projection is a systematic representation of a round body such as the Earth on a flat (plane) surface.  Each 
map projection has specific properties that make it useful for specific purposes.  Also see Projection.

MAP Stylesheet
A MAPublisher Stylesheet,  containing styles based on attribute information.  

MAP View
A MAPublisher term for a distinct coordinate system.  A MAP Layer must reside within a MAP View.

Marquee
A dashed rectangle drawn with a selection tool used to select multiple objects.

Meridian
A line of longitude running vertically from the north pole to the south pole.

Meta-Data
Data about data typically including information such as currency,  accuracy,  and extent.  Meta-data is typically 
stored in data models or data dictionaries.

MIF
The MapInfo Map Interchange Format

Mid/Mif
An ASCII file format pair exported from MapInfo GIS software.  The .mif file contains the vector data and the .mid file 
contains the attribute data
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MrSID
MrSID is a file format developed by LizardTech that reduces the size of large,  high-resolution images to a fraction of 
their original size while maintaining the original image quality and integrity.

N
NAD
North American Datum.
Network
Two or more interconnected computer systems for implementation of specific functions or a set of interconnected 
graphic lines defining some spatial features.

Node
The point or intersection at which areas or lines are joined; endpoints of an arc.

NSDI
National Spatial Data Infrastructure.

O
OS
Operating System.

Orthophoto
A modified copy of a perspective photograph of the earth’s surface with distortions due to tilt and relief removed.

Overlay
A set of graphical data that can be superimposed on another set of graphical data through registration to a 
common co-ordinate system.  The process of laying one set of digital spatial data over another for analysis purposes.

P
Page Anchor
The location on the page where the map anchor is placed.

Page Extent
Defines a rectangular portion of the graphics page to be displayed.

Page Size
The size of the drawing page.

Parameters
Variable options or choices; boundaries of operations or of an object.

Path
A line/vector defined by a series of points (a string of X,Y coordinates).

PDF
Portable Document Format.  Developed by Adobe,  a PDF is a file type,  which can be used to cross Macintosh,  
Windows,  DOS,  and UNIX platforms.

Pixel
The smallest unit of information in a grid cell map or raster image.
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Plug-in filter
A module or modules supplied separately from the Adobe Illustrator program,  usually for creating special effects in 
artwork.  The MAPublisher application plug-in filters are modules that enable the incorporation of GIS and mapping 
capabilities within the Adobe Illustrator graphics environment.

PMS
Pantone™ Matching System.

Point
A discrete location represented by a symbol or label; usually too small to be displayed as an area or line.
Polygon
Any area bounded by a straight or irregular closed line representing a map component or any other graphic feature.

Polyline
A line made up of a sequence of line segments.

Positional Accuracy 
The degree to which a position is measured or depicted,  relative to its correct position as established by either 
other features or by other accurate processes.

Postscript
A page description language built into many desktop printers and virtually all high-end printing systems.  See the 
Adobe Illustrator User Guide for more details.

PPC
Power PC (e.g.,  Macintosh PowerPC processor).

Precision
That which relates to the exactness of the operation by which the result is obtained.  The exactness with which a 
value is expressed,  whether the value be right or wrong.

Projection
The representation on a plane surface of any part of the surface of the earth.  Also see Map Projection.

R
Raster
A method for the storage,  processing and display of spatial data.  Each given area is divided into rows and columns,  
which form a regular grid structure.  Each cell must be rectangular in shape,  although not necessarily square.  Each 
cell within this matrix contains an attribute value as well as location coordinates.  The spatial location of each cell 
is implicitly contained within the ordering of the matrix,  unlike a vector structure which stores topology explicitly.  
Areas containing the same attribute value are recognized as such,  however,  raster structures cannot identify the
boundaries of such areas as polygons.  Also raster structures may lead to increased storage in certain situations,  
since they store each cell in the matrix regardless of whether it is a feature or simply ‘empty’ space.

Record
A set of attributes relating to any entity; a set of related,  contiguous data.

Redundancy
The duplication of data in a database.

Remote Sensing
The technique of obtaining data about the environment and the surface of the earth from a distance,  for example,  
from aircraft or satellite.
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Render
To cause to be or to become,  to draw.

Resolution
The number of dots per inch displayed on screen or printed to an output device.

Rhumb line
A line on the surface of the Earth cutting all meridians at the same angle.  A rhumb line shows true direction.  
Parallels and meridians,  which also maintain constant true directions,  may be considered special cases of the 
rhumb line.  A rhumb line is a straight line on a Mercator projection.  A straight rhumb line does not show the 
shortest distance between points unless the points are on the Equator or on the same meridian.

RS
Remote Sensing.

Rubber sheeting
A procedure to adjust the co-ordinates all of the data points in a dataset to allow a more accurate match between 
known locations and a few data points within the dataset.  Rubber sheeting,  also known as rubber banding,  
preserves the interconnectivity or topology,  between points and objects through stretching,  shrinking or re-
orienting their interconnecting lines.

S
SAIF
Spatial Archive and Interchange Format.  SAIF is a Canadian Draft National Standard for Geomatics data interchange.  
It is a specification for data,  which includes an object-oriented data model,  and a language for describing both 
spatial and non-spatial data.

Scale
The relation between the size of an object on a map and its size in the real world.

Scanner
A device for converting images from maps or photographs of part of the real world into digital form automatically.

SDTS
Spatial Data Transfer Standard - a standardized format used by the USGS for transferring earth-referenced spatial 
data between dissimilar computer systems that includes support for the inclusion of spatial data,  attribute,  
georeferencing,  data quality report,  data dictionary,  and other supporting meta-data within a single file transfer 
format.

SEA
Self-Extracting Archive,  a file compression format for reducing the size of large files for archival or transfers.

Shapefile
The shape file format is a public format that is the native file format for ESRI’s ArcView product.  This format can be 
used to export data with attributes from both ArcInfo and ArcView.  From ArcInfo the command at the ARC level to 
create a shape file is arcshape

Sliver
A gap formed when two lines,  which should be contiguous,  are slightly separated in a graphical representation or 
map.
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Spaghetti Data
Vector data composed of line segments which are not topologically structured or organized into objects and which 
may not even be geometrically clean.  Spaghetti data can be useful however,  if all that is required is a visual image 
or plot of a map and no spatial analysis is to be performed.

Spatial
Of space,  a two or three-dimensional position in space.

Spatial Data
Any information about the location and shape of,  and relationships among,  geographic features.  This includes 
remotely sensed data as well as map data.

Sphere Coordinates
X,Y locations on the ellipsoidal earth,  usually expressed in degrees and minutes.

Spline
A function in MAPublisher that improves the smoothness of curved lines,  drops redundant points from paths and 
changes the anchor points on paths to direction points for further manual modifications.

SPOT
An earth resource satellite with high-resolution sensors launched by France in January 1986.

Static Graphic Files
Unchanging and uneditable graphic files.

T
Thematic Map
A map displaying selected kinds of information relating to specific themes,  such as soil,  land-use etc.

Theme
A user-defined perspective on a geographic dataset specified,  if applicable,  by a name and feature class or dataset 
name,  attributes of interest,  or data classification scheme.

Thiessen Polygon
A polygon bounding the region closer to a point than to any adjacent point.  The polygons are drawn so that the 
lines are of equal distance between two adjacent points.  Thiessen polygons,  also known as Voronoi diagrams and 
Dirichlet tessellations,  are sometimes used as a crude form of interpolation,  particularly within the geosciences.

Thinning
Reducing the number of points defining a line while preserving the essential shape of the line.  Common weeding 
algorithms include: distance traversed algorithm,  Nth point selection algorithm,  angle selection algorithm,  
William’s point relaxation algorithm and Douglas-Peucker algorithm.

TIFF
Tagged Image File Format,  a common raster graphic file format.

Tile
A discrete part of the earth’s surface.  By splitting a study area into tiles,  considerable savings in access times and 
improvements in system performance can be achieved.

Topographic map
A map showing natural and man-made features as well as relief,  often in the form of contours.
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Topography
The study of the relief of a given area on the Earth’s surface,  usually on a large scale,  including both natural and 
man-made features.

Topology
The way in which geographic features relate to each other.

Toponym
The place names of a region or map feature.

Transform
The process of changing the scale,  projection,  or orientation of a mapped image.

TRIM
A GIS data file format from the Terrain Resource Information Management of British Columbia,  Canada.

U
Ungenerate
The file format created by the ArcInfo Ungenerate function.

UNIX
A general-purpose,  multi-user computer operating system.

URL
Universal Resource Locator or Internet address.

USGS
United States Geological Survey.

UTM
Universal Transverse Mercator,  a common map projection.

UTM Grid
A grid system based upon the Transverse Mercator projection.  The UTM grid extends North-South from 80oN to 
80oS latitude and,  starting at the 180o Meridian,  is divided eastwards into 60,  6 degree zones with a half degree 
overlap with zone one beginning at 180 degrees longitude.  The UTM grid is used for topographic maps and 
georeferencing satellite images.

V
Vector Linework / Artwork 
One method of data type,  used to store spatial data.  Vector data is comprised of lines,  defined by beginning and 
end points,  which meet at nodes.  The locations of these nodes and the topological structure are usually stored 
explicitly.  Features are defined by their boundaries only and curved lines are represented as a series of connecting 
arcs.  Vector storage involves the storage of explicit topology,  which raises overheads,  however it only stores those 
points which define a feature and all space outside these features is ‘non-existent’.

Vector Data
An abstraction of the real world where positional data is represented in the form of coordinates.  In vector data,  the 
basic units of spatial information are points,  lines and polygons.  Each of these units is composed simply as a series 
of one or more coordinate points,  for example,  a line is a collection of related points,  and a polygon is a collection 
of related lines.
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Vertex
One of a set of ordered X,Y coordinates that constitute a line.  A points representing spatial X,Y coordinates that 
occur along a line between the nodes and help define the shape of the arc.

VPF
Vector Product Format.  A binary format used by the US Defense Mapping Agency.  It is well documented and 
can be sued as an internal format and as a transfer format.  It carries geographic and attribute information but no 
display data.  VPF files are sometimes referred to as VMAP products.  MAPublisher 6 does not support VPF files.

W
World file
A file associated with an image that contains georeferencing information for the image.  File extensions may be TFW 
or JPW (tiff,  jpeg World Files),  IRP (Image Report Files) or TAB (Table files).

WWW
World Wide Web.

Z
Zone
Any well-defined region of more or less belt-like form.

Zoom
To magnify or reduce the current view of a document.

Glossary: V-Z
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Index
A
Acknowledgements           A4/1
Add to Selection 40-41,  114-115  
Advanced Import           viii,  16,  25,  31-34,  51-52,  A1/36
Alignment           51-52,  A1/19
Anchors           36,  46,  49,  51-53,  80,  A1/14,  A1/38
Angle           33,  37,  51,  53
Apply           38-39,  62,  65,  109-110
Apply to All 46
ArcInfo Export Format 19,  20,  25-27,  48,  55,  A1/3,  A5/1
ArcInfo Generate Format 19,  20,  25,  55,  A1/3
ArcView Shapefile Format 19,  20,  25,  55,  A1/4,  A1/11
Area Layer 46-47,  55,  62-63,  76,  90-91,  94-96
Area Legend 61,  62,  66-68 
Area Stylesheet 62-65,  A3/1
Area Tools 117-119
ASC File 108
ASCII Point Data ix,  19-22,  25-27,  29,  31,  33,  57,  108,   
  A1/36
Assign Legend Info ix,  49,  61,  66-67,  76,  A1/15,  A1/37,   
  A1/41
Attributes 13,  20,  27,  35-36,  38-43,  48,  54-55,   
  63-65,  83,  93,  107,  108,  111,  113,  
  A1/13,  A1/15,  A5/1
Auto Assign Legend Info  ix,  49,  61,  68-70,  76,  A1/15,  A1/37,   
  A1/41
Auto Grain viii,  30
Auto Scale 31,  34,  51,  52
AutoCAD 19-20,  25,  27,  29,  33,  48,  54-56,  A1/2
Azimuthal Projection A1/27-A1/29,  A1/31 

B
Bezier Curve 89,  91,  94,  A1/18,  A1/39-A1/40, 
  A5/2
Boolean ix,  38-39,  40,  66-67,  109,  111,   
  114-115,  A5/2
Boolean Expression ix
Buffer Selected Lines 89,  90
Build Expression 40-44,  66,  114-115
BW1 Format 19,  22,  25,  A1/8

C
Calculate 42,  78-80,  82,  90,  102-103
Calculator Buttons 42
Cell Dimensions  78
Cell Size 78 - 80 
Character 38-39,  109,  111
Character Style 63,  64 
Checkout License 15 
Clear Expression 40-44,  66,  114-115
Colour Mode  104-105
Colour Ramp A1/37,  A5/2 

Column 22,  27,  29,  33,  35-36,  38-44,
  54-56,  62-70,  72-75,  78,  80-81,
  83-84,  89-93,  107,  109-115,  122,
  A1/12-A1/14,  A1/36-A1/37
Comparison 42-44,  66-67,  114-115
Compatibility 13
Conformality A1/27
Coordinate  ix,  21,  22,  27,  29,  33,  36,  37,  52,
  54,  57-58,  79-80,  94,  102-105,
  A1/7,  A1/38  
Coordinate System viii,  23,  26,  28-34,  36,  45-53,  58,   
  79,  97,  100-105,  118,  A1/2-A1/9,   
  A1/12,  A1/29-A1/34,  A1/38-A1/39 
Copy Coordinates 37 
Copy Map Objects 121-122
Conic Projection A1/27,  A1/29
Create New 31,  34,  51
Create Table 107,  116
CSV Format 19,  22,  25,  108,  A1/36
Custom Coordinate System  A1/32-A1/34
Custom Projection A1/31,  A1/32-A1/34
Cylindrical Projection A1/27-A1/31

D
DAT Format 19,  21-22,  25,  108,  A1/6 
Datum viii,  23,  29,  32,  50,  52,  
  A1/30-A1/34,  A1/38
DBase files 22-23,  108,  A1/4,  A1/11,  A1/40
DDF Format 19,  22,  25,  108,  A1/9,  A1/12,  
  A1/37
Delete Column 38,  109,  111
Delete MAP Stylesheet 62,  65
Delete MAP View 46,  49
Delete Table 107,  116
Destination MAP View 31,  33-34
Details 26,  29,  31-32,  50,  51-52
DGN Format 19,  21,  25-26,  29,  31,  33,  45,  48
  55-56,  A1/7,  A5/3
Digital Line Graph 19,  22,  25,  A1/8-A1/9,  A1/24,  A5/3
Direction A1/27 
Display Number Selected 40-41
Distance A1/27
DLG Format 19,  22,  25,  A1/8-A1/9,  A1/24
Document Setup 18 
Document Units 52,  79-80,  A1/38
Douglas-Peucker 94,  A1/40,  A5/3
Draw Legend Layer 67,  69,  A1/37,  A1/41
Drawing Tools 117-118
Duplicate MAP Stylesheet 62,  65
Duplicate MAP View 46,  48
DWG Format 19,  20,  25,  27,  29,  33,  48,  54-56,   
  A1/2,  A5/3
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DXF Format 19,  20,  25,  27,  29,  33,  48,  54-56,   
  A1/2,  A5/3

E
E00 Format 19,  20,  25-27,  48,  55,  A1/3
Edit Column 38-39,  42-44,  109,  111 
Edit Expression 42-44
Edit MAP Stylesheet 62,  64-65,  A1/41
Edit MAP View 31,  34,  46,  51-53
Editor 31,  34
Ellipsoid A1/30-A1/34
ESRI ArcInfo Export 19,  20,  25-27,  48,  55,  A1/3
ESRI ArcInfo Generate 19,  20,  25,  55,  A1/3
ESRI Shapefile 19,  20,  25,  55,  A1/4,  A1/11
Existing Layer 29-30,  31-34
Export ix,  45,  52-54
Export Formats viii,  ix,  19-21,  55
Export Image  101,  104-105
Export Layer 46,  54-56
Export Settings 54,  56
Export Table A1/40
Expression 40-44,  66-67, 114-115

F
Feature Text Label 49,  71-73,  84,  91,  92
FiIe Formats 19-22,  25,  55,  108,  A1/1-A1/9
Filter(s) 17,  40-44,  66-70,  71-73,  78-84,
  90-96,  97-100,  102-105,  108-116
Final Expression 40,  42,  66-67, 114-115
Flip Selected Lines 36,  55,  89,  91,  A1/13
FME viii,  A1/2-A1/9,  A1/32-A1/34
Follow Lines 72-73,  74-75
Font  13,  71-76,  79,  98,  A1/1-A1/9
Format 19-22,  25,  55,  108,  A1/1-A1/9

G
Generate Format 19,  20,  25,  55,  A1/3
Georeferencing viii,  13,  33,  35-42,  45-56,  79,  98,
  101-105,  122,  A1/13,  A1/14,  A1/38
GeoTIFF  101-105,  A5/5
GIS  iv,  viii,  19,  23,  25,  28,  35,  36,  45,  47,   
  55,  57,  91,  94,  105,  A1/2,  A1/11,  
  A1/13,  A1/14,  A1/16-A1/17,  A5/5
Grain viii,  30,  94
Graphic File Formats A1/1
Graphic Style 63-64
Grid Generator 49,  78-82,  83
Group By 95-96

H
Height 78,  80,  98-99,  118

I
Ignore Case in Strings 40-41,  66,  114-115
Image(s) 48,  101-105,  A1/38,  A1/42-A1/45
Import Formats viii,  19-22,  25
Import Map (Advanced) viii,  16,  25,  31-34,  51-52,  A1/36
Import Map (Simple) viii,  16,  25,  26-30,  A1/36
Import Multiple Files viii,  25-34
Import Points ix,  19,  22,  25-27,  29,  31,  33,  A1/36
Import Settings 27
Import Single Files viii,  16,  25-34,  A1/36
Import Table 107,  108
Importing Map Data 25-34
Index 77,  78,  81,  83-84
Index by Features 83,  84
Index by Text Objects 83,  84
Index Label 78,  81
Initial Selection 40-41,  114-115
Installation 11,  14-15,  A1/10
Integer 38-39,  109,  111,  A5/6
IRP File 101,  103,  105,  A5/5,  A5/13

J
Join Lines 89,  92-93,  A1/21,  A1/39,  A5/7
Join Points 89,  95-96
Join Table 107,  112-113,  A1/37
JPEG World File 101,  103,  105,  A5/5,  A5/13,  A5/6

K
Keep Format Extension 54-55
Keep Text Above Lines 72-73,  74-75,  91
Knowledge Base A1/10,  A1/25

L
Labeling 67,  70,  71-76,  91,  92,  A1/13
Latitude 23,  36,  48,  49,  52,  57-59,  77,  79,
  A1/13,  A1/27-A1/34,  A1/36,  A5/6
Layer: Area  46-47,  55,  62-63,  66,  76,  90-91,   
  94-96,  A1/13
 Legend 46-47,  49,  66,  68,  79,  83,  98,  100,
  A1/37,  A1/41
 Line 46,  47,  62,  63,  66,  90-96
 MAP viii-ix,  36-44,  46-49,  55-56,  62-70,
  72-77,  83-86,  90-92,  94,  98,  100,
  102-105,  112-113,  117-119,  122
  A1/13,  A1/41,  A5/7
 Non-Map 46-49,  86,  A1/13 
 Point 47,  49,  58,  63,  66,  68,  A1/15
 Text 47,  49,  63,  66,  72-73,  74-75,  83-84
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Layer Management 121-122
Layer Name Search & Replace 46-48
Leader Line 74-75
Legacy Document Conversion 13
Legacy Text 13
Legend Layer 46-47,  49,  66,  68,  79,  83,  98,  100,
  A1/37,  A1/41
Legend Matching Features 67,  70
Legend Template  A1/41
Legends viii-ix,  36,  39,  49,  61,  66-70,  
  A1/37,  A1/41
License File 15,  A1/10,  A1/26
Licensing 15
Line Functions 89-96
Line Layer 46,  47,  62,  63,  90-96
Line Legend 61,  62,  66-68
Line Stylesheet 62-65,  A3/1
Linear Match 112-113
Links A1/22-A1/24
LGO File 101
Listgeo File 101
Location Tool  35,  37,  79,  A1/13
Longitude 23,  36,  48,  49,  52,  57-59,  77,  79,
  A1/13,  A1/27-A1/34,  A1/36,  A5/6
Lower Left 36,  51-52,  78-80,  102-103,  A1/38

M
Maintenance Program A1/25,  A1/26
Make Index 77,  83-84
Map Anchors 23,  31,  36-37,  49-53,  80,  A1/38,  A5/7
MAP Area Tools 117-119
MAP Attributes 35,  38-44,  64,  93,  107,  112-113,
  118,  122,  A1/21,  A1/38
MAP Columns 35,  38-44,  113,  122
MAP Copy & Paste 121-122
Map Data viii-ix,  19-23,  25-34,  A1/2-A1/9,
  A1/22-A1/24
MAP Layer viii-ix,  36-44,  46-49,  55-56,  62-70,
  72-77,  83-86,  90-92,  94,  98,  100,
  102-105,  112-113,  117-119,  122,
  A1/13,  A1/41,  A5/7
MAP Location Tool 35,  37,  79,  A1/13
MAP Point Plotter ix,  49,  57-59
MAP Security ix,  14-15
MAP Stylesheet ix,  61-65,  A1/15,  A1/41,  A5/7
MAP Tagger Tool 67,  70,  71,  74-76,  84,  91,  A1/13
MAP Tools 16
Map Units 36,  37,  78-80,  82,  90,  92,  94,
  97-99,  102,  A1/38
MAP View Editor ix,  31,  34,  45,  48,  49,  50,  51-53,
  102,  118,  A1/11,  A1/12,  A1/13,
  A1/38,  A1/40

MAP View(s) viii-ix,  26,  28,  29,  30,  31,  33,  34,
  45-56,  57,  58,  59,  63,  66,  68,  72,
  74,  79,  80,  81,  86,  90,  97,  100,
  102,  104,  122,  A1/13,  A1/38
  A1/39,  A1/41,  A5/7
MapInfo MID/MIF Format 19,  21,  25,  55,  A1/5,  A1/40
MapInfo TAB Format 19,  21,  25,  55,  A1/6
Memory 12,  86,  A1/11,  A1/20-A1/21
Merge Layers 43,  46,  48,  121,  122
MicroStation 19,  21,  25-26,  29,  31,  33,  45,  48,
  55-56,  A1/7
MID/MIF Format 19,  21,  25,  55,  A1/5,  A1/40,  A5/7
Missing Projection 46,  48
MMP A1/25,  A1/26
MP Attributes 36,  39,  54,  55,  91,  118,  A1/13
MPArea 36,  39,  54,  55,  91,  118,  A1/13
MPLength 36,  39,  54,  55,  91
MPPerimeter 36,  39,  54,  55,  91,  118
MPTables 107-116
Multiple File Import viii,  25-34
Multipliers 27

N
New Based On 31,  34
New Column 38-39,  42,  109,  111
New MAP Stylesheet 62,  64
New MAP View 46,  49,  50,  51,  53,  A1/38,  A1/39
New Projection 31
Non-Map Layer 46-49,  86,  A1/13
North Arrow viii,  47,  49,  97,  100

O
OPT Format 19,  22,  25,  A1/8-A1/9
Ordered Match 112-113

P
Page Anchors  31, 33,  36-37,  47,  49,  51-53,
  A1/14,  A1/38,  A5/8
Page Units 18,  37,  78-81,  94,  98-99,  A1/38
Paste Map Objects 121-122
Percent Along Line 72-73
Pixel Size 102-103,  104-105
Placing Images 102
Plug-in Folder 14-15
Point Layer 42-44,  47,  49,  58,  63,  66,  68,  95
Point Legend 61,  62,  66-68
Point Plotter ix,  49,  57-59
Point Stylesheet 62-65,  A3/1
Points viii-ix,  13,  27, 29,  49,  57-59,  61-70,   
  89,  95-96,  A1/17
Plotting Points 57-59
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Precision 48,  A1/14,  A5/9
Preview Pane 51-53
Projection(s) viii-ix,  25-34,  35-41,  45-53,  57,  59,
  102,  A1/13,  A1/27-A1/35,  A1/38,  A5/9
Projection Category 26,  28,  31,  32,  50,  51-52
Projection List viii,  26,  28,  31,  32,  34,  50,  51-52
Properties 42-44
Proximity 92-93,  94

R
RAM 12,  A1/11,  A1/20-A1/21
Real 38-39,  109,  111
Reference Info Files  101
Register 15
Register Image 101,  102-103
Registration 15
Remove Duplicate Entries 83-84
Remove from Selection 40-41,  114-115
Result Column 42-43
Result Property 43-44
Reverse Order 68-69
Reverse Select 114-115
Rotation 31,  37,  42-44,  49,  51,  53,  104,  105
Row 33,  78,  80-81,  109-110
RT1 Format 19,  22,  25,  A1/8

S
Same as 31-32,  46,  48,  50,  51-52
Scale  25,  28,  31,  33,  37,  42-44,  47,  51-52,
  58-59,  62,  64-65,  98-99,  
  A1/27-A1/30,  A5/10
Scale Bar viii,  47,  49,  97-99
SDTS Format 19,  22,  25,  108,  113,  A1/9,  A1/37
Search & Replace 46-48
Search Projection 26,  31,  50,  51,  53
Search Results 26,  31,  50,  51,  53,  A1/31
Select by Attribute 35,  40-41,  55,  67,  86,  114,  A1/13
Select from Selection 40-41,  114-115
Selection Statistics 40-41,  85-87
Selection Type 40,  114
Select Table Records 107,  109,  110,  114-115
SelStats 40-41,  85-87
Settings: Import 27
 Export 54
Shapefile Format 19,  20,  25,  55,  A1/4,  A1/11,  A5/10
Simple Import viii,  16,  25,  26-30,  A1/36
Simplify Lines 89,  94,  A1/40
Single File Import viii,  16,  25-34,  A1/36
Sinusoidal Projection A1/28,  A1/30
Sort  39,  68-69,  83-84,  95-96,  110
Source Projection ix,  26,  28,  31,  45-46,  48,  50,  51,   
  53,  A1/31,  A1/38

Spatial Data Transfer Standard  19,  22,  25,  108,  113,  A1/9,  A1/37
Specify Anchors 47-49,  53,  A1/38
Spline Selected Lines 89,  91
State Plane A1/28,  A1/31
Style 63-64
Stylesheet ix,  61-65,  A1/15,  A1/41
Support A1/25-A1/26
Symbol ix,  13,  42-44,  49,  58-59,  61-70,   
  A1/15,  A1/41,  A3/1
System Requirements 12

T
Table Columns 107,  108,  109-111,  116
Table Records  107,  108,  109-111,  116
Tagger Tool 67,  70,  71,  74-76,  84,  91,  A1/13
TAB Format 19,  21,  25,  55,  101-105,  A1/6
Technical Support A1/25-A1/26
Text Creation 71-76
Text Layer 42-44,  47,  49,  63,  66,  72-75,  83-84
Text Legend 61,  62,  66-68
Text Stylesheet 62-65,  A3/1
TFW Format 101,  103,  105
Tic Points 27,  A1/3
TIF File 101-105,  A5/11
TIGER/Line Format 19,  22,  25,  A1/8
Tips and Hints A1/36-A1/41
TXT Format 19,  22,  25,  108,  A1/36
Tutorial Data 14,  A2/1

U
Undefined Layer 46,  48-49,  A1/38
Unique Occurrences 68-70
Units 18,  36,  37,  52,  78-81,  82,  90,  92,   
  94,  98-99,  102,  A1/38
Universal Transverse Mercator 48,  A1/29,  A1/31-A1/35
Upper Right 78-80,  102-103,  A1/38
Use Existing 31,  34
USGS 19,  22,  25,  108,  113,  A1/8-A1/9,   
  A1/24,  A1/37,  A1/42-A1/45,  A5/13
USGS DLG Format 19,  22,  25,  A1/8-A1/9,  A1/24
USGS SDTS Format 19,  22,  25,  108,  113,  A1/9,  A1/37
Utilities  A3/1
UTM  48,  A1/29,  A1/31-A1/35,  A5/12

V
Value Range  ix,  36,  61,  63,  66,  68-70  
View Anchors 51

W
Width 38-39,  78,  80,  90,  109-111,  118
Workspace 18
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