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Welcome

Avenza welcomes you to mapmaking in the 21st century!

Combined with Adobe Illustrator, MAPublisher has revolutionized the art of mapmaking by allowing spatial data 
files to be used to create maps inside a vector graphics program. MAPublisher allows you to perform all your 
cartographic tasks where they should be done: in a powerful graphics environment.

MAPublisher 9.2 improves on the already powerful tools of previous versions by adding additional file support, 
additional tools, and improvements to existing tools.

This tutorial guide assumes that the user is familiar with Adobe Illustrator CS5/CS5.1/CS6, and has at least a basic 
understanding of geographic information systems (GIS) terminology and concepts. The tutorials in this guide 
should be used in conjunction with the MAPublisher 9.2 User Guide.

By following these tutorials, you will learn how to create maps using the MAPublisher features and tools in Adobe 
Illustrator. This guide covers the steps necessary to build a map and perform fundamental cartographic and GIS 
tasks. Together, MAPublisher and Adobe Illustrator will give you a totally integrated cartographic design software 
system with graphics tools and geographic functions present in the same work environment.

TUTORIAL DATA

The tutorials in this guide use GIS data installed with MAPublisher. The tutorial data is installed at:

Windows XP
C:\Documents and Settings\All Users\Shared Documents\Avenza\MAPublisher 9\Tutorial Guide & Data\Tutorial Data

Windows Vista / 7 / 8
C:\Users\Public\Public Documents\Avenza\MAPublisher 9\Tutorial Guide & Data\Tutorial Data

Mac OS X
/Applications/Avenza/MAPublisher 9.2/MAPublisher Tutorials/Tutorial Guide/Tutorial Data

Avenza produces and distributes helpful styles swatches, and symbols with the MAPublisher installation. These are 
installed into Adobe Illustrator's default library installation locations and can be accessed through Adobe Illustrator 
Symbols panel option menu: Open Symbol Library > MAP Symbols; the Adobe Illustrator Graphic Styles option menu: 
Open Graphic Style Library > MAP Graphic Styles; and through the Adobe Illustrator Swatches panel option menu: 
Open Swatches Library > MAP Swatches.

Helpful Styles and Symbols can be found in the following locations:

Windows XP
C:\Documents and Settings\All Users\Documents\Avenza\MAPublisher 9\Helpful Styles & Symbols

Windows Vista and Windows 7
C:\Users\Public\Documents\Avenza\MAPublisher 9\Helpful Styles & Symbols

Mac OS X
/Applications/Avenza/MAPublisher 9.2/Helpful Styles & Symbols



iv MAPublisher 9.2 Tutorial Guide
Contents

Welcome

Contents

1  Importing Map Data
1.1	 Import a single data file . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                7

1.2	 Import multiple datasets simultaneously . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                               8

1.3	 Import data to match an existing MAP Layer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                           9

1.4	 Import data with point per path limitations  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                           10

1.5	 Import data that requires optional settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                            11

1.6	 Import point data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

1.7	 Import multiple data types . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                           13

1.8	 Import multiple datasets with different coordinate systems . . . . . . . . . . . . . . . . . . . . . . . . . . . .                            15

1.9	 Import data to match an existing MAP View  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                           17

1.10	 Assign a source coordinate system prior to import . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                     18

1.11	 Transform a coordinate system on import  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                             20

2  MAP Views and Georeferencing
2.1	 Create MAP View on import . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                           22

2.2	 Copy a MAP View from an existing MAPublisher document  . . . . . . . . . . . . . . . . . . . . . . . . . . . .                            22

2.3	 Duplicate and delete MAP Views . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                      23

2.4	 Transform coordinate systems by drag and drop . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                       24

2.5	 Drag layers into existing coordinate systems . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                          24

2.6	 Drag new layers into different coordinate systems . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                     25

2.7	 Edit layer names using search and replace . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                             26

2.8	 Specify a source coordinate system after import . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                       27

2.9	 Transform a coordinate system using the MAP View editor . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                             27

2.10	 Edit scale and position . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                29

2.11	 Copy a coordinate system from one layer to another . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                   30

2.12	 View coordinates and create a MAP Location  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                          33

2.13	 Create a new MAP View with Georeferencer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                           34

2.14	 Export data to GIS formats . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                            40

Contents



vMAPublisher 9.2 Tutorial Guide
Contents

3  MAP Attributes
3.1	 View, edit, and zoom to MAP Attributes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                               43

3.2	 Add a new column to a MAP Attribute table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                           44

3.3	 Change an existing column's properties . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                               45

3.4	 Create a new column using expressions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                               46

3.5	 Join tables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                           47

4  Data Creation
4.1	 Plot points in decimal degree and degrees-minutes-seconds formats . . . . . . . . . . . . . . . . . . .                  49

4.2	 Plot centroids  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                        51

5  Drawing with MAPublisher
5.1	 Create shapes with specific map dimensions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                          52

6  Cropping with MAPublisher
6.1	 Crop data with MAP Vector Crop Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                 55

7  Geoprocessing
7.1	 Buffer art using an entered value . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                      57

7.2	 Flip lines  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                             59

7.3	 Join lines based on attribute value . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                    60

7.4	 Simplify art . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                           61

7.5	 Join points  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                           62

7.6	 Join areas  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                            65

8  MAP Themes and Legends
8.1	 Create an area stylesheet theme  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                      67

8.2	 Create a line stylesheet theme  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                        69

8.3	 Create a point stylesheet theme . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                      71

8.4	 Batch generate stylesheet theme rules . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                72

8.6	 Create a bar chart theme . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                             74

8.7	 Create a pie chart theme . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                              76

8.8	 Create a chart legend . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                 78

8.9	 Create a dot density theme  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                           79



vi MAPublisher 9.2 Tutorial Guide
Contents

9  Labeling
9.1	 Generate labels for a line layer using Label Features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                   80

9.2	 Generate labels for an area layer using the MAP Tagger Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . .                           82

9.3	 Create knockouts for labels  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                           83

10  Making Selections
10.1	 Create an attribute filter  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                              85

10.2	 Create a spatial filter . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                  86

10.3	 Create an art selection filter . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                           88

11  Working with Images
11.1	 Register an image with a reference file  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                89

11.2	 Register an image without a reference file  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                            90

11.3	 Export a placed image as a georeferenced raster file . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                   92

12  Grids, Graticules and Indexes
12.1	 Create an index grid . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                  93

12.2	 Create a graticule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                     96

12.3	 Create a measured (UTM) grid . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                        98

12.4	 Create a feature based index . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                         100

12.5	 Create a text based index . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                            102

13  Scale Bars and North Arrows
13.1	 Create a scale bar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                    103

13.2	 Create a north arrow . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                 104

14  MAP Web Author 
14.1	 Prepare the map for web tags . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                        106

14.2	 Create web tag callouts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                              107

14.3	 Export to Flash  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                      109

14.3	 Export to HTML5  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                                    113

15  Geospatial PDF Export
15.1 Export document to geospatial PDF . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                   117

16  Import Spatial Databases
16.1	 Import Esri Personal or File geodatabase  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                             122

16.2	 Import Esri ArcSDE geodatabase . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                     125

16.3	 Import basic Esri ArcSDE server  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                      128



7MAPublisher 9.2 Tutorial Guide
1  Importing Map Data

1  Importing Map Data
See User Guide, Chapter 3. 

1.1	 Import a single data file

1.	 Create a new Letter sized Adobe Illustrator document in landscape orientation.
2.	 From the MAPublisher toolbar, click the Simple Import button  or go to File > Import Map Data > Simple.
3.	 Choose MapInfo Interchange Format [*.mif] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder and select world.mif.

The Source Coordinate System is specified as WGS 84 since MAPublisher reads this information from the data 
source. In cases where no coordinate system is specified, click the Specify button to choose a system.

5.	 With the dialog box matching the one above, click OK.

The data is added and fitted to the artboard. The layer world_area is added to Adobe Illustrator's Layers panel. 
The MAP Views panel now contains a MAP View with the imported world layer. See chapter 4 in the MAPublisher 
User Guide for more information about MAP Views.

6.	 Close the document without saving.
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1.2	 Import multiple datasets simultaneously

Simple Import will import multiple map files simultaneously if the files are in the same data format, are in the 
same coordinate system, and are located in the same directory.

1.	 Create a new Letter sized Adobe Illustrator document in portrait orientation.
2.	 From the MAPublisher toolbar, click the Simple Import button.
3.	 Choose MapInfo Interchange Format [*.mif] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder and select both fsatoronto.mif and torontostreets.mif (hold the 

Command key (Mac) or the Ctrl key (Windows) to select multiple files). Click Open.

Although two files are selected for import, the Dataset box only lists the last file (alphabetical order).

5.	 With the dialog box matching the one above, click OK.

The layers fsatoronto_area and torontostreets_line are added to Adobe Illustrator's Layers panel. The MAP Views 
panel now contains a MAP View called fsatoronto holding the two imported files.

6.	 Close the document without saving.
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1.3	 Import data to match an existing MAP Layer

1.	 Create a new Letter sized Adobe lllustrator document in landscape orientation.
2.	 From the MAPublisher toolbar, click the Simple Import button.
3.	 Choose MapInfo Interchange Format [*.mif] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder and select worldwest.mif. Click Open.

The selected file appears in the Dataset file list in the MAPublisher Simple Import dialog box. Notice that the 
Source Coordinate System is Robinson.

5.	 Click OK to complete the import.

The layer worldwest_area is added to Adobe Illustrator's Layers Panel. The MAP Views panel contains the 
worldwest MAP View projected in a Robinson projected coordinate system.

6.	 Import worldeast.shp (ensure Esri Shapefile [*.shp] is chosen in Format drop-down list.)

In the Simple Import dialog box, the Source Coordinate System of worldeast.shp is indicated as Robinson.

7.	 Click OK to continue the import process.
8.	 In the Matching MAP View Found dialog box, accept the default Add to: worldwest option as the Destination MAP 

View. Click the Resize MAP View to fit check box.
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The worldeast layer is imported to match the worldwest layer. Notice that the scale of the worldwest_area layer has 
been adjusted so that both layers can now fit inside the page extents. The layer worldeast_area is added to the 
Adobe Illustrator Layers panel. In the MAP Views panel, the MAP View worldwest now contains both layers.

9.	 Close the document without saving.

1.4	 Import data with point per path limitations 

1.	 Create a new Letter sized Adobe Illustrator document in portrait orientation.
2.	 Click the Simple Import button.
3.	 Choose MapInfo Interchange Format [*.mif] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder and select greenland.mif, click Open. Click OK.

A warning appears because the vertex count exceeds Adobe Illustrator's allowable 32,000 points per path.

5.	 Click View Log to read the warning messages. Click Close to close the MAPublisher Log.

MAPublisher removes points in order to meet Adobe Illustrator's maximum points per path while maintaining 
the integrity of the path's shape. Greenland looks distorted because there is no coordinate system defined.

6.	 Close the document without saving.
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1.5	 Import data that requires optional settings

The Tutorial Data folder contains many GIS file formats. Various file formats require unique import settings that are 
accessed by clicking the Settings button in the Simple and Advanced Importer dialog boxes. Refer to Chapter 3 of the 
User Guide for the available settings for each format.

1.	 Create a new Letter sized Adobe Illustrator document in portrait orientation.
2.	 Click the Simple Import button.
3.	 Choose Esri Interchange File [*.e00] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder and select capeverde.e00. Click Open.
5.	 Click the Settings button in the Simple Import dialog box.
6.	 Make sure Ignore TIC layer is unchecked. Click OK.
7.	 Click OK to complete the import.

Note:	 As e00 files are generally an archive of several files, MAPublisher will reproduce an e00 import as distinct 
Adobe Illustrator layers. Notice that MAPublisher generates point, area, line and text layers. An extra layer 
appended with _tic_point is created to hold tic points, as was specified in the Settings dialog box.

8.	 Close the document without saving.

1.6	 Import point data

Along with importing Microsoft Excel files, MAPublisher can import delimited ASCII text files as point data provided 
they contain coordinate values. Supported delimiters include: comma, return, end of line and tab in multiple formats. 
Below is an example of ASCII that is supported for import:

“AZ,Antonio Tank,reservoir,Santa Cruz,4,23,312004N,1103943W,31.33444,-110.66194,,,,,,,Duquesne"
“AZ,Agua Prieta Substation,locale,Cochise,4,3,312006N,1093335W,31.335,-109.55972,,,,,,,Douglas"
“AZ,Adobe Spring,spring,Santa Cruz,4,23,312037N,1110234W,31.34361,-111.04278,,,,,,,Pajarito Peak"

1.	 Create a new Letter sized Adobe Illustrator document in portrait orientation.
2.	 Click the Simple Import button.
3.	 Choose Delimited XY Text Data [*.csv, *.tsv, *.txt]  from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder, and select azdeci.txt.
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The Settings dialog box opens automatically. Specify the appropriate coordinate format of the data in the 
Format drop-down list before selecting in which columns of the import file the coordinates will be found.

5.	 Use Decimals Degrees (D+[.d*]) as the Coordinate Format.
6.	 Use Column #10: -110.66194 for the Longitude coordinates and Column #9: 31.33444 for the Latitude coordinates.
7.	 Leave Use first line as a header unchecked because the first line of this file does not contain column headings. 

Accept the default data types as assigned.

8.	 Make sure that this dialog box matches the one above and click OK.

Since a delimited text file does not contain coordinate system information, it must be manually specified. In this 
case we know that the Latitude and Longitude are given in WGS 84. (In your own work, check the metadata if 
you are unsure of the system.)

9.	 Click the [No Coordinate System Specified] link. In the Specify Source Coordinate System dialog box, navigate to 
Geodetic > World, choose the WGS 84 coordinate system and click OK.

10.	 In the Simple Import dialog box, click OK to start the file import process.
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11.	 Save this document as MyPoints.ai in the Tutorial Data folder. It will be used again in exercise 8.3.

1.7	 Import multiple data types

1.	 Create a new Letter sized Adobe Illustrator document in landscape orientation.
2.	 From the MAPublisher toolbar, click the Advanced Import button  or to File > Import Map Data > Advanced.
3.	 In the Advanced Import dialog box, click Add.
4.	 Select MapInfo Table [*.tab] from the Format drop-down list.
5.	 Click Browse, navigate to the Tutorial Data folder, select usa.tab, and click Open. A coordinate system is detected.
6.	 Click OK to close the Add dialog box.

The selected file appears in row 1 of the file list. Now add another file in a different map file format.

7.	 Click Add to open the Add dialog box.
8.	 Select Esri Shapefile [*.shp] from the Format drop-down list.
9.	 Click Browse, navigate to the Tutorial Data folder and select canada.shp. Click Open.
10.	 Click OK to close the Add dialog box.
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The selected file appears in the second row of the list. Both are in the NAD27 coordinate system.

11.	 Under Destination MAP View, usa is chosen by default in the New based on drop-down list. This bases the MAP 
View, coordinate system, and page scaling on the usa.tab file.

12.	 Check the Auto-scale option.

Auto-scale ensures all selected files are scaled to fit inside the page extents.

Note:	 Not checking the Auto-scale option will base the page scaling on the file selected in the New based on 
drop-down list only. Therefore only this file is fitted to the current page extents, which may cause elements in 
other selected files to be placed outside of the page boundary.

13.	 Click OK to import the two files.

Notice that in the Adobe Illustrator Layers panel there are new layers called usa_area and canada_area. Also in 
the MAP Views panel there is a new MAP View called usa containing the imported files.

14.	 Close the document without saving.



15MAPublisher 9.2 Tutorial Guide
1  Importing Map Data

1.8	 Import multiple datasets with different coordinate systems

1.	 Create a new Letter sized Adobe Illustrator document in landscape orientation.
2.	 From the MAPublisher toolbar, click the Advanced Import button.
3.	 In the Advanced Import dialog box, click Add.
4.	 Select MapInfo Table [*.tab] from the Format drop-down list.
5.	 Click Browse, navigate to the Tutorial Data folder, select usa.tab, and click Open.
6.	 Click OK to close the Add dialog box.

The selected file appears in row 1 of the file list. The coordinate system of usa.tab displays NAD27. The 
coordinate system preview area lists various parameters of the file including the name of the coordinate system, 
page and map anchors, visual scale, and map angle.

7.	 Click the Add button to add another file.
8.	 Select Esri Shapefile [*.shp] from the Format drop-down list.
9.	 Click Browse, navigate to the Tutorial Data folder, select worldwest.shp, and click Open.
10.	 Click OK to close the Add dialog box.

The worldwest.shp file appears in the second row of the file list and displays the Robinson coordinate system.

11.	 In the Destination MAP View frame, select the New based on option and choose worldwest from the drop-down list.

The destination MAP View will be based on the coordinate system and page scaling on the worldwest.shp file.
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12.	 Click OK to import the two files into the Robinson coordinate system.

The map files are automatically sized to fit the page. Note that the Auto-scale option was not checked in 
the Advanced Import dialog box. The page scaling was based on the worldwest.shp which contained larger 
geographic extents than the usa.tab in all four compass directions.

In the Adobe Illustrator Layers panel, new layers called usa_area and worldwest_area are added. Also, in the 
MAP Views panel there is a new MAP View containing the imported files (the MAP View has the same name as 
the file selected for the MAP View destination).

13.	 Close the document without saving.
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1.9	 Import data to match an existing MAP View

This tutorial will produce the same results as Tutorial 1.8 - Importing MAP files in multiple coordinate systems.

1.	 Create a new Letter sized Adobe Illustrator document in portrait orientation.
2.	 Click the Simple Import button.
3.	 Select Esri Shapefile [*.shp] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder, select worldwest.shp, and click Open.
5.	 Click OK to close the Simple Import dialog box.

In the Adobe Illustrator Layers panel there is a new layer called worldwest_area. Also in the MAP Views panel 
there is a new MAP View called worldwest (which is set in the Robinson coordinate system).

6.	 Click the Advanced Import button on the MAPublisher toolbar, and then click Add.
7.	 Select MapInfo Table [*.tab] from the Format drop-down list.  
8.	 Click Browse, navigate to the Tutorial Data folder, select usa.tab, and click Open.

9.	 In the Destination MAP View frame, click the Use existing option and choose worldwest from the drop-down list. 

View the coordinate system of this map file in the coordinate system preview area.



18 MAPublisher 9.2 Tutorial Guide
1  Importing Map Data

10.	 Click OK to import the file based on the Robinson parameters of the worldwest_area layer.

The file is imported and reprojected to automatically align with the worldwest layer. This functionality allows 
you to easily register multiple files with different coordinate systems.

In the Adobe Illustrator Layers panel there are new layers called usa_area and worldwest_area. Also in the 
MAP Views panel there is a new MAP View called worldwest containing the imported files set in the Robinson 
coordinate system

11.	 Close the document without saving.

1.10	 Assign a source coordinate system prior to import

1.	 Create a new Letter sized Adobe Illustrator document in portrait orientation.
2.	 Click the Advanced Import button. In the Advanced Import dialog box, click Add.
3.	 Select Esri ArcInfo Generate [*.gen] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder, select ukrail.gen, and click Open.
5.	 Click OK to close the Add dialog box.

The selected file appears in the first row of the file list and it has an unknown coordinate system.
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6.	 In the Advanced Import dialog box, with the first row selected, click Edit.
7.	 In the Edit dialog box, click the [No Coordinate System Specified] link, go to Projected > Europe > United Kingdom, 

choose British National Grid, and click OK.
8.	 Click OK to return to the Advanced Import dialog box.

Under Destination MAP View frame, view the coordinate system information in the area to the right.

9.	 Click OK to import the file in the British National Grid coordinate system.

10.	 Close the document without saving.
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1.11	 Transform a coordinate system on import

Read about the MAP View Editor in chapter 4 of the User Guide before completing the following tutorial.

1.	 Create a new Letter sized Adobe Illustrator document in portrait orientation.
2.	 Click the Advanced Import button. In the Advanced Import dialog box, click Add.
3.	 Select Esri Shapefile [*.shp] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder, select ukpoly.shp,and click Open.
5.	 Click OK to return to the Advanced Import dialog box.

The selected file appears in Row 1 of the file list. The coordinate system of ukpoly.shp is currently WGS 84.

6.	 In the Destination MAP View frame, select the Create New option, and click the Editor button to open the Map 
View Editor dialog box.
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7.	 In the MAP View Editor, click the WGS84 coordinate system link. Click the *Recent* category list under Coordinate 
Systems > Projected and choose British National Grid. Alternatively, go to Projected > Europe > United Kingdom to choose 
the British National Grid coordinate system.

8.	 Click OK to close the Specify Source Coordinate System dialog box.
9.	 Click OK to close the MAP View Editor and return to the Advanced Import dialog box.

Under Destination MAP View, view the coordinate system information in the area to the right.

10.	 Click OK to import the file in the British National Grid coordinate system.
11.	 Close the document without saving.
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2.1	 Create MAP View on import

1.	 Open usa48.ai from the Tutorial Data folder.
2.	 From the MAPublisher toolbar, click the MAP Views button  or go to Window > MAPublisher > MAP Views.
3.	 Use Simple Import to import usa.tab from the Tutorial Data folder.

Notice that a MAP View called usa 1 is automatically created. The 1 denotes that a MAP View already exists with 
that name, so it adds a suffix to differentiate it. Each Adobe Illustrator layer comprising the MAP View is depicted 
with an icon that represents the Feature type contained on each of the map layers.

4.	 Continue with the next tutorial.

2.2	 Copy a MAP View from an existing MAPublisher document

Continue working with the previous tutorial.
1.	 Keep the usa48.ai document open, create a new Adobe Illustrator document and make it active.
2.	 From the MAPublisher toolbar, click the Copy MAP Objects From button  or from MAP Views panel options menu.

A list of MAP Views are available from any opened document containing MAP Views. In this case, the MAP Views 
usa and usa 1 are available to import.

2  MAP Views and Georeferencing
See User Guide, Chapter 4
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3.	 Check the usa check box in the Source column and click OK.

The MAP View is copied into the new document along with all the MAP Layers within that MAP View. It 
maintains the original scale and position of the usa MAP view.

4.	 Close the active document without saving, but keep the usa48.ai document open.
5.	 Continue with the next tutorial.

2.3	 Duplicate and delete MAP Views

Continue working with the previous tutorial.
1.	 In the MAP Views panel, select the usa MAP View. Then click the panel option menu and click Duplicate "usa".

A new MAP View called Copy of usa is created. It only duplicates the MAP View and not the MAP Layers that are 
contained in the source.

2.	 Select the usa MAP View and click the Delete button.

A message dialog box states that the MAP View is not empty. Click Delete MAP View and child layers.

3.	 Close the document without saving.
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2.4	 Transform coordinate systems by drag and drop

1.	 Create a new Letter sized Adobe Illustrator document in landscape orientation.
2.	 Use Simple Import to add world.mif from the Tutorial Data folder.
3.	 Use Simple Import to add worldwest.shp from the Tutorial Data folder.

There are two MAP Views: one called world, in the WGS 84 coordinate system, that contains the world_area layer; 
and the second called worldwest, in the Robinson coordinate system, that contains the worldwest_area layer.

4.	 In the MAP Views panel click the worldwest_area layer and drag it to the world MAP View.

       

The worldwest_area layer is transformed into the WGS 84 coordinate system and matches the page scaling of 
the world_area layer.

5.	 Drag worldwest_area back to the worldwest MAP View and it will transform the layer back to the Robinson 
coordinate system.

6.	 Keep the document open for the next tutorial.

2.5	 Drag layers into existing coordinate systems

Continue working with the previous tutorial.
1.	 Use the Toggle Visibility button in the Adobe Illustrator Layers panel to hide the world_area layer.
2.	 In the Adobe Illustrator Layers panel, create a new layer called Extras, and move it to the top of the layers hierarchy.
3.	 With the Extras layer selected, roughly trace over some features that exist on the worldwest_area layer using the 

Adobe Illustrator Pen tool and give it a red colored fill.
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The new features are polygons. Make sure that the elements are closed so that the start and end points of the 
lines are coincident.

4.	 In the MAP Views panel, click the Extras layer and drag it into the worldwest MAP View.
5.	 In the Undefined Layer dialog box, select Area from the Feature type drop-down list, and click OK.

The Extras layer is now stored in the same coordinate system as the worldwest MAP View.

6.	 Keep the document open for the next tutorial.

2.6	 Drag new layers into different coordinate systems

Continue working with the previous tutorial.
1.	 In the Adobe Illustrator layers panel, use the Toggle Visibility buttons to hide the worldwest_area layer, and to 

make the world_area layer visible. The Extras layer is already visible.
2.	 In the MAP Views panel click the Extras layer and drag it into the world MAP View.

The Extras layer is moved to the coordinate system of the world MAP View. It is immediately transformed from 
Robinson to WGS 84 coordinate system and aligns with the data in the world_area layer.

3.	 Keep the document open for the next tutorial.
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2.7	 Edit layer names using search and replace

Continue working with the previous tutorial.
1.	 In the MAP Views panel option menu, click Layer Name Search & Replace.

2.	 In the Find what box, type _area. In the Replace with box, type _layer. Click the Replace All button.

The text _area is replaced with _layer in the name of all applicable layers.

     

3.	 Close the document without saving.
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2.8	 Specify a source coordinate system after import

1.	 Create a new Adobe Illustrator document in portrait orientation
2.	 Use Simple Import to add ukrail.gen from the Tutorial Data folder (do not specify a coordinate system).
3.	 In the MAP Views panel, double-click the ukrail MAP View to open the MAP View editor. Close the warning dialog 

box that appears (it appears because no coordinate system was specified).
4.	 In the MAP View editor dialog box, click the [No Coordinate System Specified] link to open the Specify Source 

Coordinate system dialog box.
5.	 Go to Projected > Europe > United Kingdom and choose British National Grid (or choose it from the *Recent* folder).

6.	 Click OK to close the MAP View editor dialog box.

The source coordinate system for the file is now British National Grid. The MAP View is assigned a coordinate 
system and can now be transformed.

7.	 Close the document without saving.

2.9	 Transform a coordinate system using the MAP View editor

1.	 Create a new Letter sized Adobe Illustrator document in portrait orientation.
2.	 Use Simple Import to add fsatoronto.mif from the Tutorial Data folder. 

The map file is in the WGS 84 coordinate system.

3.	 In the MAP Views panel, double-click the fsatoronto MAP View to open the MAP View editor.
4.	 Change the name of the MAP View to Postal Code Zones.
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5.	 Check the Perform Coordinate System Transformation check box to enable its frame options and click the 
[No Coordinate System Specified] link.

6.	 In the Specify Destination Coordinate System dialog box, go to Projected > UTM > NAD83, choose NAD83 / UTM zone 17N, 
and click OK. 

The Preview Pane displays how the new coordinate system is fit to the page. UTM zone 17N is a proper 
projected coordinate system to use for this area.

7.	 Click OK to close the MAP View editor dialog box.

     
The MAP View is transformed from WGS 84 to NAD83 / UTM zone 17N. See Appendix A2 on Projections and 
Datums in the User Guide for more information.  

8.	 Keep the document open for the next tutorial.
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2.10	 Edit scale and position

1.	 In the MAP Views panel, double-click the Postal Code Zones MAP View to open the MAP View editor.
2.	 Change the map scale to 1: 35,000 by typing 35000 in the Scale box.
3.	 In the Positioning section, click the Quick alignment tab to make it  active. There are nine squares in the 

alignment grid indicating positions on the artboard. Click the center square to reposition the data to the center 
of the page.

The Preview Pane shows the new data extents and the page anchor values have been automatically updated.

4.	 Click OK.

The Postal Code Zones MAP View is rescaled and repositioned in the center of the page.

5.	 In the MAP Views panel, double-click the Postal Code Zones MAP View to open it again.
6.	 In the Angle box, type 343.00 to specify an angle of rotation, then click OK.
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The layer is now rotated. Georeferencing has not been affected.

7.	 Close the document without saving.

2.11	 Copy a coordinate system from one layer to another

1.	 Create a new Letter sized Adobe Illustrator document in landscape orientation.
2.	 Import worldwest.mif from the Tutorial Data folder. 

The map file is in the Robinson coordinate system.

3.	 Select the Canada polygon shape and assign a fill color to it.

4.	 In the MAP Views panel, double-click the worldwest MAP View to open the MAP View Editor.
5.	 Change the map scale to 1: 250 million by typing 250000000 in the Scale box.
6.	 Click the Show Anchors check box to display the map and page anchors (if the artboard is blocking the anchor 

numbers, click the zoom out button a few times). In the Quick alignment tab, click the top-left square to 
reposition the data to the top-left of the page.
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The Preview Pane shows the new data extents and the Page Anchor values have been automatically updated. 
Move the artboard in the preview if the anchor values block the extent box.

7.	 Click OK.

The worldwest MAP View is rescaled and repositioned in the top-left corner of the page. This can be used as a 
small inset map used referencing Canada to the Western Hemisphere countries.

8.	 Import canada.shp from the Tutorial Data folder.

The map file is in the NAD27 coordinate system.

9.	 In the MAP Views panel, double-click the canada MAP View to open the MAP View Editor.
10.	 Check the Perform Coordinate System Transformation check box to enable its frame options. Check the Same 

As check box and select the worldwest MAP View in the drop-down list. Notice how the destination is set to 
Robinson and the datum shift is NAD27 to WGS84 (88).
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11.	 In the Quick alignment tab, click the center square to reposition the data to the center of the page.

The Preview Pane shows the new data extents and the Page Alignment values are automatically edited.

12.	 Click OK.

The MAP View is transformed to match the coordinate system of the worldwest MAP View.

13.	 Close the document without saving.
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2.12	 View coordinates and create a MAP Location

1.	 Open usa48.ai from the Tutorial Data folder.
2.	 In the MAPublisher Toolbar, click the MAP Info button .

The MAP Info panel appears.

3.	 Move the mouse cursor to a location on the map to view its geographic coordinates.

The MAP Info panel shows the Position (Easting and Northing) and Geodetic base (Longitude and Latitude) 
values and are constantly updated as the mouse cursor is moved around the map document. (To view WGS84 
or MGRS values, click the panel options menu.)

4.	 In the Adobe Illustrator Tools, click the MAP Locations tool (the cursor changes to a crosshair).
5.	 Click anywhere on the map to create a MAP Location.

A MAP Location is ready to be created at the point of the click. It is created in projected units of meters. 
Optionally, click the Copy to Clipboard button to make the coordinate values available beyond this dialog box.

6.	 Click OK.

A blue MAP Location pin is placed on the artboard. When the MAP Location tool is enabled, hovering near the 
pin will make its label visible. To see a list of all MAP Locations, open the MAP Locations dialog box from the 
MAPublisher toolbar.

7.	 Close the document without saving.
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2.13	 Create a new MAP View with Georeferencer

This tutorial provides a basic overview of assigning georeferencing information to existing Adobe Illustrator 
documents. Please see Georeferencer in Chapter 6 of the MAPublisher 9.2 User Guide.

1.	 In Adobe Illustrator, open toronto.ai from the Tutorial Data folder.

This is a regular Adobe Illustrator document. It contains two Adobe Illustrator layers that do not have any 
georeferencing or attribute information. However, the data was known to be digitized in NAD 83/UTM Zone 
17N coordinate system. They are located in the [Non-MAP layers] section of the MAP Views panel.

2.	 Click View menu and click Show MAP Locations.

MAP Locations are used to reference page locations (green pin) and world locations (blue pin). Three MAP Page 
Locations appear on the map. These were created for you for the purpose of this exercise. To georeference, a 
minimum of four MAP Page Locations are required. You'll need to add one more MAP Page Location. Later, you 
will assign it a world coordinate.

3.	 From the Tools toolbar, click the MAP Location Tool. The cursor changes to a crosshair.
4.	 Pan and zoom to the location pointed out in the graphic and click once. In the Add Map Page Location dialog 

box, type Queens Park into the Name box.

A MAP Page Location is placed in the document at the X,Y page coordinates above. (Your coordinates may be 
slightly different depending on where you clicked. You can adjust the X and Y values accordingly.)



35MAPublisher 9.2 Tutorial Guide
2  MAP Views and Georeferencing

5.	 From the MAPublisher toolbar, click the Georeferencer button (read and close the brief tutorial graphic).

The Georeferencer dialog box opens. Two MAP Page Locations have already been assigned world locations for 
the purpose of this exercise. You'll need to assign two more world locations to the other MAP Page Locations: 
one manually and one using the online map service.

6.	 Click the Add reference location button.

The Lennox/Lipponcott MAP Page Location is added to the list (MAPublisher automatically finds it.) 

7.	 Double-click the X|Longitude or Y|Latitude cell box.
8.	 Enter the values into the following dialog box, Long: -79.409466 and Lat: 43.664095. Then click OK.

A world location is manually assigned to the Lennox/Lippincott MAP Page Location.
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You'll assign the last MAP Page Location with world coordinates using an online map service.

9.	 In the Georeferencer dialog box, click the Google Maps button.

The Matching MAP Page Location of Front/Bathurst which was already assigned a world location is shown on 
the map with a placemark. The artboard also centers to the location. You can use the Zoom artboard buttons to 
zoom in to the artboard.

10.	 Click the Matching MAP Page Location drop-down list and choose Queens Park (UNASSIGNED). On the left side of the 
map, click the Zoom out [-] button until you can see two other placed world locations. Pan north and zoom into 
the map area labeled University of Toronto. As you continue to zoom in, the Queen's Park map label will appear. 
Zoom into the north side of Queens Park and compare it to the features on the artboard.
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11.	 Click the map to assign a world location to the Queens Park MAP Page Location. Click Yes when asked to confirm 
the location.

A world location is assigned and a placemark is plotted.

12.	 Click OK to close the Add World Locations dialog box.

Four reference locations are available and the Georeference & Save button is enabled.

13.	 Click the Georeference & Save button.
14.	 In the Select Coordinate System list, choose NAD83 / UTM zone 17N.
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The data was known to be digitized in NAD83 / UTM Zone 17N. It is the most appropriate coordinate system to 
use. Sometimes a coordinate system may not have the highest Rank, but may be the most appropriate to use. 
You'll also view some of the error introduced with georeferencing.

15.	 Click the Error Details button.

The table shows Error X, Error Y, and Combined Error. These errors come from how accurately the MAP Page 
Locations are assigned world locations. Lower error values means a higher georeferencing accuracy. Your errors 
may vary depending on how accurate you placed your MAP Locations.

16.	 Click OK to close the Error dialog box.
17.	 In the Select Coordinate System dialog box, click OK.
18.	 In the Create MAP View dialog box, change the MAP View name to Toronto. Click the two check boxes beside the 

Streets and Postal Code Area layers. Then click OK.

19.	 Click OK.
20.	 Assign the appropriate MAP Layer type to Streets and Postal Code Areas.
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The MAP Views panel updates and lists the Toronto MAP View and two layers.

21.	 From the MAPublisher toolbar, click the MAP Locations button .

The MAP Locations table lists the four MAP Page Locations and the four newly added MAP World Locations.
This verifies that the document is georeferenced.

22.	 Close the document without saving.
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2.14	 Export data to GIS formats

1.	 Create a new Letter sized Adobe Illustrator document in portrait orientation.
2.	 Use Simple Import to import fsatoronto.mif and torontostreets.mif. Click OK to add the fsatoronto MAP View.

3.	 From the MAPublisher toolbar, click the Export button  > Export MAP Layers .
4.	 In the Export dialog box, choose Esri Shapefile [*.shp] from the Format drop-down list, enable the check box beside 

the torontostreets_line layer, and browse to a location to save the shapefile.

5.	 Click OK to export the file.

View the contents of the destination folder. The fsatoronto layer is exported as an Esri Shapefile with all 
attributes and georeferencing intact. This Esri Shapefile consists of four files: fsatoronto.shp, fsatoronto.shx, 
fsatoronto.dbf, and fsatoronto.prj. It is ready to be used in software supporting the shapefile  format. 
Descriptions of file extensions can be found in chapter 2 of the MAPublisher User Guide. 

6.	 In the Adobe Illustrator Layers panel, select all objects on the torontostreets_line layer.
7.	 Click the MAP Attributes panel button  on the MAPublisher toolbar. Resize the MAP Attributes panel to see 

all the attribute column headings and then click the Edit Schema button.
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8.	 In the column list, click #Length and check the Visible check box. Click FromLeft to view its schema and uncheck the 
Visible check box and click OK.

The #Length attribute is visible now and the FromLeft attribute is hidden.

Before continuing, the other Integer type columns need to be hidden.

9.	 Right-click the ToLeft column and click Hide ToLeft.

Note:	 Alternatively, click the Show/Hide Columns button and choose an attribute to make it visible or hidden.
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10.	 Hide the remaining columns: FromRight, ToRight and Type.

11.	 In the MAP Views panel, select the torontostreets_line layer. From the MAP Views panel options menu, click 
Export “torontostreets_line".

12.	 In the Export dialog box, select MapInfo Table [*.tab] from the Format drop-down list. At the bottom of the dialog 
box, click Export visible attributes only option.

This ensures that only visible attributes are exported (#Length and Street columns in the attribute table). The file 
location should be the same location as the previous exported file.

13.	 Click OK to export the layer.

The torontostreets_line layer is exported to MapInfo Table format with the specified attributes and 
georeferencing intact. It is ready to be used in software supporting the format. View the contents of the 
destination folder. You'll see that four new files were created: torontostreets.tab, torontostreets.dat, torontostreets.
id, and torontostreets.map. Descriptions of these file extensions can be found in chapter 2 of the MAPublisher 
User Guide. Each file format has its own settings.

14.	 Close the document without saving.
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3.1	 View, edit, and zoom to MAP Attributes

1.	 Create a new Adobe Illustrator document.
2.	 Import world.mif from the Tutorial Data folder.
3.	 With all of the art selected on the world_area layer, click the MAP Attributes button  on the MAPublisher 

toolbar or from the menu Window > MAPublisher > MAP Attributes.
4.	 To edit attribute values, double-click inside a cell and type a new value.

All attribute values and some property attributes can be edited. MAPublisher creates some attributes which 
have the hash symbol (#) as a prefix. These attributes can be edited (but must be made visible first). However, 
#Area, #Perimeter, #VertexCount, and #Length are properties of the geometry and cannot be edited.

Keep in mind to enter values that correspond with a column's type (e.g. only enter numbers into a column of 
type Real or Integer). The edits are automatically maintained in the attribute table once entered.

5.	 The widths of the columns in the MAP Attributes panel may be changed by dragging the column separator left 
or right. Right-click and click Resize All To Fit Content.

6.	 Click a column heading to sort it in an ascending manner. Click the column heading again to sort it in a 
descending manner.

7.	 Zoom to a specific piece of art via the MAP Attributes panel. Select an attribute record and click the Zoom to 
Feature button. MAPublisher zooms to the area of the file where the artwork is located and displays it within 
visible handles.

8.	 Keep the document open for the next tutorial.

3  MAP Attributes
See User Guide, Chapter 5
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3.2	 Add a new column to a MAP Attribute table

Continue working with the previous tutorial.
1.	 If necessary, open the MAP Attributes panel and select all objects on the world_area layer. The panel displays all 

of its attribute columns and values.
2.	 Click the Edit Schema button at the bottom of the MAP Attributes panel.

The Edit Schema dialog box displays the columns associated with the MAP Attributes table on the currently 
selected layer.

3.	 Click Add to add a new attribute column.
4.	 In the Name box, rename Attribute1 to Head of State. 

Note:	 Notice that spaces are not accepted for column names. MAPublisher inserts an underscore ( _ ) if a space is 
typed into a column name. Also, notice that the Display Name box is populated with the same name. This can 
be changed to reflect a name with no spaces in it.

5.	 In the Display Name box, remove the spaces, so the name becomes Head of State.
6.	 In the Type drop-down list, choose String (this allows the column to contain alphanumeric values).
7.	 Set a width of 10 (this is the number of characters which can be displayed in each cell).

In certain instances, a default value for an attribute may be required. Setting a Default Value gives each record 
the same value. Do not enter a default value for this tutorial.

8.	 Click OK to close the dialog box.

The new column is created and can be given values in the MAP Attributes panel.

9.	 Leave the document open for the next tutorial.
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3.3	 Change an existing column's properties

Continue working with the previous tutorial.
1.	 If necessary, open the MAP Attributes panel and select all objects on the world_area layer.
2.	 Click the Edit Schema button and select Capital in the attribute column list.
3.	 In the Display Name box, rename it to Capital City. Also, change the size to 30.

The column type may be changed after it is created (e.g. convert a type real column to a type integer column). 
For this tutorial, leave the type as String. Also, any new polygons added to the world_area layer will have a 
default value of None.

4.	 Leave the Visible check box enabled and the Read-only and Derive value from expression unchecked.

5.	 Click OK. 

The column is now renamed and its width is increased to accommodate longer names.

6.	 Leave the document open for the next tutorial.
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3.4	 Create a new column using expressions

Continue working with the previous tutorial.
1.	 If necessary, open the MAP Attributes panel and select all objects on the world_area layer.
2.	 Click the Edit Schema button. 
3.	 Click Add to create a new attribute column called Annual_Increase and set the Type to Integer.
4.	 Check the Derive value from expression check box and click the Expression Builder button next to the Edit 

Expression box.

Build expressions by making selections from the Objects list in combination with using the operators available 
at the top of the dialog box.

5.	 In the Expression Components section at the bottom of the dialog box, double-click the Population column 
in the Objects list, click the * symbol button, click the ( symbol button, double-click Pop_Grw_Rt column, click 
the / symbol button, then type 100. Finally, click the ) symbol button to close the expression builder. The final 
expression in the Edit Expression box is: Population*(Pop_Grw_Rt/100).

The expression is valid statement means that the expression syntax is correct and can be performed.

6.	 Click OK to close the Attribute Expression Builder dialog box
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The expression box is populated with the expression that was just created.

7.	  Click OK again to close the Edit Schema dialog box.
The Annual_Increase attribute column is updated with values calculated from the expression. Notice that these 
calculated values are grayed out. They can only be edited by modifying the attribute expression.

8.	 Close the document without saving.

3.5	 Join tables

1.	 Create a new Adobe Illustrator document.
2.	 Import canada.shp from the Tutorial Data folder. Make sure all art is selected.
3.	 Open the MAP Attributes panel and click the Join Table button at the bottom right of the panel.
4.	 Make sure the Data Type is set to Files (ASCII, Excel, Dbf)*, click Browse next to the Dataset Name box and select 

CA_commute.csv from the Tutorial Data folder.
5.	 Check the First line contains column names check box and choose NAME from the Matching Column drop-down 

list.  Leave the schema specifications character encoding at their default values. Since there is only one MAP 
Layer in the MAP View, the Destination Target Layer will default to canada_area. 

* The Data Type drop-down list is not available on Mac.
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6.	 The Matching Column drop-down list shows attribute columns of the same type (String) from the target layer to 
base the join on. Set the matching column to NAME.

7.	 Make sure that the dialog box matches above and click OK.

8.	 Scroll to the right to view the joined attributes. The imported table is joined with the attribute table of canada.shp. 
9.	 Close the document without saving.
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4.1	 Plot points in decimal degree and degrees-minutes-seconds formats

1.	 Open usa48.ai from the Tutorial Data folder.

This document contains the conterminous United States. The polygons are on the usa_area layer, in a MAP View 
named usa. The specified coordinate system is United States: Albers Equal Area, meter.

2.	 In the MAP Views panel, click the Add MAP Layer button. In the Add MAP Layer dialog box, rename Layer 1 to 
Cities, set the Feature type to Point and click OK.

3.	 Open the Adobe Illustrator Symbols panel (Window > Symbols).
4.	 In the Symbols panel option menu, click Open Symbol Library > MAP Symbols > MAP - Symbols. If you're using a 

non-English version of Illustrator, browse to Open Symbol Library > Other Library and load MAP - Symbols.ai from  
\Helpful Styles & Symbols\MAP Symbols folder (see page iii).

5.	 Choose several city symbols in the Map Symbols panel to add them to the Adobe Illustrator Symbols panel.

     

6.	 In the MAP Views panel, select the Cities layer.
7.	 Open the MAP Point Plotter panel (choose Window > MAPublisher > MAP Point Plotter) or click the MAP Point Plotter 

button  on the MAPublisher toolbar.
8.	 To change the plot symbol, click the [MAPublisher Default Symbol] and select a different map symbol. Leave the 

Scale set to 100%
9.	 Set the Input Coordinate System to Use: WGS 84. 
10.	 Ensure that Decimal Degrees (D+[.d*]) is chosen in the Format drop-down list.
11.	 To plot a point for Los Angeles, type -118.4183 in the Long box and type 34.1151 in the Lat box. Click the Plot 

button to plot the point on the map.

4  Data Creation
See User Guide, Chapter 6
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A point is plotted at the location of Los Angeles (34.1151 degrees north, 118.4183 degrees west).

12.	 Choose Delimited Degrees Minutes Seconds (D+dMM'SS[.s*]") from the Format drop-down list. 
13.	 To plot a point for New York City, type 73d56'39.0"W in the Long box and 40d41'14.0"N in the Lat box.
14.	 Click the symbol text name to select a symbol style, change the Scale to 150% and click Plot.

A point is plotted at the location of New York City (40 degrees, 41 minutes, 14 seconds north and 73 degrees, 56 
minutes, 39 seconds west).

15.	 Finally, plot a point for Chicago. Type 87d41'18"W in the Long box and 41d50'21"N in the Lat box. Alternatively, 
change the Format back to Decimal Degrees (D+[.d*]) and type -87.6883 in the Long box and 41.8392 in the Lat box.

All the points are plotted on the map. Experiment with plotting your own points, using different symbols, 
coordinates, coordinate systems and data.

16.	 Keep the document open for the next tutorial.



51MAPublisher 9.2 Tutorial Guide
4  Data Creation

4.2	 Plot centroids

Continue working with the previous tutorial.
1.	 Choose Plot Centroids from the MAP Point Plotter panel option menu.

The MAP View and Source layer are already set in the Plot Centroids dialog box. The Destination is already set to 
be a new layer called centroid. This creates a new destination layer and places the points on this layer.

2.	 Change the Style to a different map symbol and change its scale to 50%.
3.	 Leave the other options as default and click OK to close the dialog box.

Points are plotted for the centroid location for each state polygon.

4.	 Close the document without saving.
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5  Drawing with MAPublisher
See User Guide, Chapter 7

5.1	 Create shapes with specific map dimensions

1.	 Create a new Adobe Illustrator document.
2.	 Import fsatoronto.mif and import torontostreets.mif from the Tutorial Data folder.
3.	 Transform the coordinate system of the fsatoronto MAP View to NAD83 / UTM zone 17 (see Tutorial 2.9).
4.	 Zoom to an intersection of these streets. A recommended zoom level is 600%.

To construct an imaginary building at precise map dimensions
5.	 In the MAP Views panel, add a new MAP Layer called Buildings and specify it as an Area feature type.
6.	 In the Adobe Illustrator Tools panel, click the MAP Area Plotter Rectangle Tool button.
7.	 In the Adobe Illustrator Layers panel, make sure the Buildings layer is active. Click once near the intersection of 

the two selected streets to open the Area Plotter dialog box.
8.	 Type 50 into the Width box, type 30 into the Height box, check the Center area on click check box, and click OK.
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Since the fsatoronto MAP View is in UTM, the units are displayed in meters. These settings create a rectangle 
50 x 30 meters. The center of the polygon locates at the single-click point from the previous step.

9.	 Move the building to the southeast corner of the intersection. Rotate it so that it is parallel to College St. using 
the Rotate Tool. Give the building a fill color.

Presume that this building is an established grocery store. In a recent survey it was found that on average, the 
majority of its customers lived within 500 meters of the store.

10.	 In the main Adobe Illustrator Tools panel, click the MAP Measurement Tool.  Click the center of the building 
rectangle and move the cursor outwards until the distance is about 500 meters.

The MAP Measurement Tool displays a distance of about 500 meters. This helps to approximate a distance of 
500 meters around the grocery store. To measure multiple straight sections, hold the Shift key and click.



54 MAPublisher 9.2 Tutorial Guide
5  Drawing with MAPublisher

11.	 In the main Adobe Illustrator Tools panel, click the MAP Area Plotter Rectangle Tool button (Alternatively, click 
and hold the button to choose the MAP Area Plotter Ellipse Tool). Single-click in the center of the building to 
open the Area Plotter dialog box. 

12.	 In the Options section, type 1000 for both the Width and Height (or click the Constrain Dimensions check box). 
Make sure the Shape is an Ellipse and the Point is Center. Click OK.

A 1000 meter diameter circle (500 meter radius) is placed around the grocery store and shows where the 
majority of customers live. The circle can be selected and styled like other area and line elements.

13.	 Close the document without saving. 
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6  Cropping with MAPublisher
See User Guide, Chapter 7

6.1	 Crop data with MAP Vector Crop Tool

1.	 Create a new Adobe Illustrator document.
2.	 Import torontostreetsjoined.mif and fsatoronto.mif from the Tutorial Data folder.
3.	 With all data on both layers selected, open the MAP Attributes panel.

Examine the table structure and map attribute records. Deselect the data and close the MAP Attributes panel.

4.	 Click the MAP Vector Crop Rectangle Tool from the main Adobe Illustrator Tools panel. 

Notice the mouse cursor has changed to a cross hair.

5.	 Click once near the center of the map. This opens the Vector Crop dialog box.
6.	 In the Size section, enter a width of 0.025 and a height of 0.045 (degrees). In the Target section, choose Only and  

choose the fsatoronto_area layer in the drop-down list.

Move the dialog box out of the way to see a preview of the crop area size. This will give you an idea of what 
section of the data will be cropped. The crop should only target fsatoronto_area layer and the streets will 
remain untouched.

7.	 Click OK to complete the crop.
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The fsatoronto_area layer is cropped to the crop extent and the streets were untouched because they were not 
included as a target.

8.	 In the Adobe Illustrator Tools, click and hold the MAP Vector Crop Rectangle Tool button to choose the Ellipse 
Rectangle Tool. On the artboard, click and drag an ellipse to draw a crop extent. Release the mouse button to 
complete the crop.

Note:	 To achieve a proportional crop area, hold the Shift key while dragging the crop area.

9.	 Once again, select all data in both layers and open the MAP Attributes panel.

Notice that the attributes have been maintained, but there are fewer features because of the crop.

10.	 Close the document without saving.
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7  Geoprocessing
See User Guide, Chapter 8

7.1	 Buffer art using an entered value

1.	 Create a new Adobe Illustrator document.
2.	 Import burlroads.mif from the Tutorial Data folder and assign NAD83 / UTM zone 17N as the source coordinate system. 

Navigate to the location, Projected > UTM > NAD83 to find the coordinate definition (Tutorial 1).
3.	 Select a few lines to be buffered.

4.	 On the MAPublisher toolbar, click the Buffer Art button  or choose Object > MAPublisher > Buffer Art.
5.	 In the Buffer Art dialog box, click the Only buffer selected art check box. Under the Buffer Width section, choose 

the Static Value option, in the Units drop-down list choose Meter, and type 25 into the adjacent box. Under the 
Destination section, choose the New Layer option and type Line Buffers into the box. Under the Options section, 
click the Apply style check box and choose a fill color.

A static value of 25 meters represents a buffer value of 12.5 meters on either side of the selected roads.

6.	 Click OK to apply the buffer art settings.
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The lines that were selected for buffering now have a buffer around them on a layer called Line Buffers. The 
buffered lines were styled according to the fill color options set. Like any other object in Adobe Illustrator, then 
can be styled separately. As with most buffers, it's best to make them stand out from the features above them.

Alternatively, a Graphic Style can be chosen in the Buffer Art dialog box so that a style is automatically applied 
to the newly created buffer. To do this, click the toggle to switch to Graphic Style mode.

7.	 Close the document without saving.
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7.2	 Flip lines

There are two methods in MAPublisher to ensure that text labels are oriented correctly when they are attached to 
paths. The first is to check the Reverse right to left paths (flip upside-down text) option in Label Features or the MAP 
Tagger Tool. Alternatively, permanently correct any digitizing irregularities by using the Flip Lines function.

1.	 Create a new Adobe Illustrator document.
2.	 Import torontostreetsjoined.mif from the Tutorial Data folder.
3.	 Select the two lines as indicated in the graphic below and add arrowheads to the lines. In Illustrator CS5/CS6 the 

Add Arrowheads controls have been integrating into the Stroke panel (Window > Stroke).

     

4.	 Accept the default arrowhead style and click OK.

Arrowheads are added to the selected road lines. 

5.	 On the MAPublisher toolbar, click the Flip Lines button. 

Notice how the selected lines now have their beginning and end points switched (as indicated by the 
arrowhead). The orientation of the lines are permanently corrected. Any labels placed along these lines are now 
oriented correctly (labels would be oriented below the lines if the lines were not flipped). 

6.	 Close the document without saving.
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7.3	 Join lines based on attribute value

1.	 Create a new Adobe Illustrator document.
2.	 Import torontostreets.mif from the Tutorial Data folder.

Select individual line segments to see that lines are not joined with other line segments, even though the line 
may be of the same street.

3.	 Select all objects on the torontostreets_line layer.

In the MAP Attributes panel, notice there are 1197 line segments in the torontostreets_line layer.

4.	 On the MAPublisher toolbar, click the Join Lines button. 

5.	 Make sure that torontostreets_line is selected as the Target Layer. Leave join lines on target layer selected.
6.	 Under Destination choose the Copy result to new layer option and enter the layer name Joined Streets.
7.	 	Under Join Options, leave the Only join lines with shared values from option checked and choose the Street 

attribute from the drop-down menu.
8.	 Type 0.01 in the Proximity box and make sure the proximity unit is set to Degree. Proximity is the tolerance setting 

used in the join process.
9.	 Ensure the Close Segment Gaps check box is unchecked.

10.	 Make sure that the dialog box matches the one above and click OK.
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A new layer called Joined Streets is created and contains 264 line segments (according to the MAP Attributes 
panel). The original dataset contained 1197 line segments. Select an individual line segment and notice that the 
line is joined with line segments that share the same street name (the attribute the join was based on).

11.	 Close the document without saving.

7.4	 Simplify art

1.	 Create a new Adobe Illustrator document.
2.	 Import the ukrail.gen file from the Tutorial Data folder and specify British National Grid as the coordinate system. It is 

located under Projected > Europe > United Kingdom.
3.	 Select all objects in the ukrail_line layer and click the Simplify Art button  on the MAPublisher toolbar.
4.	 In the Simplify Art dialog box, type 2000 in the Proximity box and choose Meter in the Units drop-down list.
5.	 Click Preview to see a preview of the simplified data with the current settings. 

     

6.	 Click OK to start the simplification process.

     

The selected art is now simplified based on a proximity value of two kilometers (2000 meters) and have been 
simplified from 17,186 vertices to 8,756 vertices or a vertex reduction of about 50%.

7.	 Close the document without saving.



62 MAPublisher 9.2 Tutorial Guide
7  Geoprocessing

7.5	 Join points

1.	 Create a new Adobe Illustrator document.
2.	 Import torontostreetsjoined.mif and torontopoints.mif from the Tutorial Data folder. After import, ensure the 

torontopoints_point layer is positioned at the top of the layers hierarchy in the Adobe Illustrator Layers panel.
3.	 If necessary, deselect all layers and only select the points of the torontopoints_point layer and open the MAP 

Attributes panel.

The ID attribute column contains four unique values identifying points that compose: two subway lines (S1 and 
S2), the mainline rail track (R1), and a park boundary (P43). The LineNumber and AreaNumber columns contain 
rising numeric values indicating the number of each point in its sequence. Note that some points contain 
matching values.

4.	 Deselect all points and on the MAPublisher toolbar, click the Join Points button. 

Since only one point layer is present in the document and there are no points selected, the Source Layer 
defaults to the torontopoints_point layer in the Join Points dialog box.

5.	 In the Destination Layer box, type Joined Points (a new layer will be created with this name) and leave the Close 
paths check box unchecked.

6.	 In the Group By Column drop-down list, choose ID. This contains the unique attributes that will be used to join 
similar points together.

7.	 In the Sort By section, click LineNumber in the Available Columns list, and click the right arrow button to add it to 
the Sort Order list. Click AreaNumber and click the right arrow button again to add it to Sort Order.

Ensure that LineNumber is at the top of the Sort Order list box. Having LineNumber at the top of the Sort 
Order column makes it the primary sorting column when determining the order of points in the chain. The 
AreaNumber column is used as the secondary sorting column, if any points in the primary column contain 
matching values.



63MAPublisher 9.2 Tutorial Guide
7  Geoprocessing

8.	 Make sure the dialog box matches the one above and click OK.

All the points are joined based on the specified parameters. A line layer called Joined Points is created that 
contains four new lines. The lines represent two subway lines, the mainline rail track, and the perimeter of a small 
park. To see the Joined Points line more clearly, hide the other layers.



64 MAPublisher 9.2 Tutorial Guide
7  Geoprocessing

9.	 Select the four lines of the Joined Points layer and open the MAP Attributes panel.

Notice that an attribute column named ID was created and contains the values specified in the Group By 
Column setting in the Join Points dialog box. Note that the small segment with the attribute P43 is the outline of 
a park area. However, this segment should be closed and should be deleted using the following steps.

10.	 In the Adobe Illustrator Layers panel, select the torontopoints_point layer and use the MAP Selections to select 
all the points with an ID equal to P43 (see Tutorial 10 on Making Selections).

11.	 With the points of P43 selected, click the Join Points button.

In the Join Points dialog box, the torontopoints_point layer and Selected Points option are chosen by default.

12.	 In the Destination Layer box, type Park Area. This time, check the Close Paths check box. Leave the Group By 
column as the default of ID.

13.	 Add AreaNumber and LineNumber to the Sort Order column list, and make sure LineNumber is at the top of the list.

14.	 Make sure your dialog matches the graphic above and click OK.
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The selected points are joined based on the specified parameters. A new Park Area layer is created that contains 
a polygon that represents the perimeter of a small park. The map can be styled to more clearly show the subway 
lines, rail line and park.

     

15.	 Close the document without saving.

7.6	 Join areas

1.	 Create a new Adobe Illustrator document.
2.	 Import worldd.mif from the Tutorial Data folder. 
3.	 With the world layer selected open the MAP Attributes panel.

Notice that the Continent column holds the contient entry for each country. This is the attribute that you will 
join areas with.

4.	 Deselect all art by going to Select > Deselect in the file menu. 

5.	 On the MAPublisher toolbar, click the Join Areas button .
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Since only one are layer is present in the document and there are no areas selected, the Source Layer defaults to 
the world_area layer in the Join Areas dialog box.

6.	 Under Destination, choose the Copy results to new layer option and type Joined Areas (a new layer will be created 
with this name).

7.	 Under Join Type, choose the Join areas by attribute option and choose Continent from the drop-down menu.
8.	 Leave all attributes set to Clear if different when joining. Notice beside Continent it states "Join on". Click Ok.

New areas have been created based on matching Continent attributes and the boundaries of counties of have 
been dissolved.

9.	 Close document without saving.	
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8.1	 Create an area stylesheet theme

1.	 Create a new Adobe Illustrator document.
2.	 Import world.mif from the Tutorial Data folder.
3.	 In the Adobe Illustrator menu, choose Window > Graphic Styles to open the Graphic Styles panel.
4.	 In the Graphic Styles panel option menu, choose Open Graphics Style Library >  MAP Graphic Styles > MAP - Area 

Solid Colors. For non-English installations of Illustrator choose Open Graphics Style Library > Other Library and load 
MAP - Area Solid Colors.ai from the \Helpful Styles & Symbols\Graphic Styles folder (see page iii).

5.	 Shift-select all the graphic styles in the MAP - Area Solid Colors panel and drag them into the Adobe Illustrator 
Graphic Styles panel.

      

6.	 Open the MAP Themes panel, click the MAP Themes button on the MAPublisher toolbar or from the menu 
Window > MAPublisher > MAP Themes.

7.	 In the MAP Themes panel option menu, click New MAP Theme.
8.	 In the New MAP Theme dialog box, type Continents1 into the Theme Name box, choose Stylesheet as the Theme 

Type, choose Area from the Feature type drop-down list, and click OK.

9.	 Double-click Continents1 stylesheet, or choose Edit "Continents1" from the MAP Themes panel option menu

10.	 Click the Layers button, click the check box for the world_area layer and click OK. In the Edit Stylesheet Theme 
dialog box, click the Add button to add a style rule. Rename Rule 1 to Africa.

11.	 In the Expression section, click the left-hand drop-down list to set the attribute to Continent, choose the equal 
sign as the operator, and choose Africa from the right-hand drop-down list as the attribute value. 

12.	 Under Apply Properties click the Style check box and choose the Land 40 graphic style.

8  MAP Themes and Legends
See User Guide, Chapter 9
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13.	 Leave the other display properties at their default values and click Apply to see the changes made to the map.

Note:	 The MAPublisher Log records which artwork was affected or not. Click View Log to see which pieces of art did 
not satisfy the expression. Otherwise click Close. If changes are made to a style, click white empty space in 
the dialog box before clicking the Apply button.

14.	 Repeat steps 9 to 11 for each of the subsequent continents. Note that the same style cannot be used more 
than once, as one style equals one legend entry. When all of the continents are assigned a style, click the Apply 
button to see the changes, or click OK to close the dialog box.

The styles specified have been applied to the map. The styles in the Graphic Styles panel are now linked to the 
attribute values specified by the style rules.

15.	 Save this document as MyWorld.ai in the Tutorial Data folder.
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8.2	 Create a line stylesheet theme

1.	 Create a new Adobe Illustrator document.
2.	 Import fcstreets.mif from the Tutorial Data folder.
3.	 Open the Adobe Illustrator Graphic Styles panel.
4.	 Use the Adobe Illustrator Line Segment Tool to create a graphic style by drawing a line on the page. Assign the 

line a stroke weight of 2 pt, a stroke color of red, and a fill of none. 
5.	 Open the Adobe Appearance panel via Windows > Appearance. From the Appearance panel option menu 

choose Add New Stroke. Set the color to yellow and the stroke weight to 1.6. Make sure the newly created stroke 
is above the 2 pt red stroke in the Appearance panel. 

6.	 Use the Selection Tool to drag this line into the Graphic Styles panel. In the Graphic Styles panel, double-click 
the style to open the Graphic Style Options dialog box. Rename the style to Primary Road. 

Delete the line on the artboard (the style will remain available inside the Graphic Styles panel).

7.	 In the Graphic Styles panel option menu, click Open Graphic Style Library > MAP Graphic Styles > MAP - Line Styles. 
If using a non-English version of Illustrator, choose Other Library > Open Graphic Style Library and browse to the 
MAPublisher supplied file MAP - Line Styles.ai from \Helpful Styles & Symbols\Graphic Styles folder (see page iii).

8.	 From the MAP - Line Styles panel , add the graphic styles MAP Line 12 and MAP Line 16 to the document's 
Graphic Style panel. 

These new styles will now be available for use in the current document.

9.	 Rename MAP Line 12 to Local Road and MAP Line 16 to Secondary Road. Close the MAP - Line Styles panel.
10.	 Open the MAP Themes panel and in the panel option menu, click New MAP Stylesheet.
11.	 In the New MAP Theme dialog box, type Road Types into the Theme name field, choose the Stylesheet Theme type, 

choose Line from the Feature type drop-down list, and click OK.
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12.	 Double-click the Road Types stylesheet. Click the Layers button and click the fcstreets_line layer check box in the 
Selected column, then click OK.

13.	 In the Edit Stylesheet Theme dialog box, click the Add button three times to add three rules. Rename Rule 1 to 
Primary Road, Rule 2 to Secondary Road, and Rule 3 to Local Road.

14.	 In the Expression field, for the Primary Road rule select "Number" from the pull down menu displaying 
attributes, and choose the unique attribute value  "A25". Under Apply Properties, check the Style check box and 
choose the Primary Road style. 

15.	 In the Expression field, for the Secondary Road rule select "Number" from the pull down menu displaying 
attributes, and choose the unique attribute value  "A31". Under Apply Properties, check the Style check box and 
choose the Secondary Road style. 

16.	 In the Expression field, for the Local Road rule select "Number" from the pull down menu displaying attributes, 
and choose the unique attribute value  "A41". Under Apply Properties, check the Style check box and choose the 
Local Road style. 

17.	 When all the rules are defined with a style and expression, click Apply. (If a MAP Theme warning appears, just 
click the close button.)

The primary, secondary and local roads are styled accordingly.

18.	 Save this document as MyRoads.ai in the Tutorial Data folder.
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8.3	 Create a point stylesheet theme

1.	 Complete Tutorial Guide exercise 1.6 or open your previously saved MyPoints.ai in the Tutorial Data folder.
2.	 Open the Adobe Illustrator Symbols panel (choose Window > Symbols), in the Symbols panel option menu, 

click Open Symbol Library > MAP Library > MAP Symbols > MAP - Symbols. If using a non-English version of Adobe 
Illustrator choose Open Symbol Library > Other Library and load MAP - Symbols.ai from \Helpful Styles & Symbols\
MAP Symbols (see page iii).

3.	 Shift-select all the symbols in the MAP Symbols panel, and drag them into the Adobe Illustrator Symbols panel.

          

4.	 Open the MAP Themes panel and in the panel option menu, click New MAP Theme.
5.	 In the New MAP Theme dialog box, type Point Data into the Theme Name field, choose Stylesheet as the Theme 

Type, choose Point from the Feature type drop-down list, and click OK.

6.	 Double-click the Point Data stylesheet, or choose Edit "Point Data" from the MAP Themes panel option menu. 
Click the Layers button and select the azdeci_point layer. 

7.	 In the Edit Stylesheet Theme dialog box, click the Add button four times to add four rules. Rename Rule 1 to 
Airport, Rule 2 to Church, Rule 3 to Hospital and Rule 4 to Park. In the Expression column, build the expression: C3 
= "airport" and under Apply Properties, check the Symbol check box and from the drop-down list choose MAP 
Symbol 34 (airplane symbol). Check the Scale check box and change the Scale to 70%. 

8.	 Select the Church rule and in the expression column, build the expression C3 = "church". Under Apply Properties  
heck the Symbol check box and from the drop-down list choose a church symbol. Check the Scale check box 
and change the Scale to 70%. 

9.	 Select the Hosptial rule and in the expression column, build the expression C3 = "hospital". Under Apply 
Properties check the Symbol check box and from the drop-down list choose a hospital symbol. Check the Scale 
check box and change the Scale to 70%. 

10.	 Select the Park rule and in the expression column, build the expression C3 = "park". Under Apply Properties  
check the Symbol check box and from the drop-down list choose a park symbol (e.g. Green - camping). Check 
the Scale check box and change the Scale to 70%. 
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11.	 Click Apply. The specified symbol styles are applied to the map. The styles used in the Symbols panel are now 
linked to the attribute values specified by the style rules.

12.	 Close the document without saving.

8.4	 Batch generate stylesheet theme rules

1.	 Create a new Letter sized Adobe Illustrator document in landscape orientation.
2.	 Import world.mif from the Tutorial Data folder.
3.	 In the MAP Themes panel option menu, click New MAP Theme.
4.	 In the New MAP Theme dialog box, type Population into the Theme Name box, choose Stylesheet as the Theme 

Type, choose Area from the Feature type drop-down list, and click OK.

5.	 Double-click Population stylesheet, or choose Edit "Population" from the MAP Themes panel option menu.
6.	 Click the Layers button and select the world_area layer.
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7.	 Click the Batch Generate Rules button to open the Rule Generator dialog box. Under Source: choose be sure that 
the world_area layer is selected. Choose Population from the Attribute drop-down list.

8.	 Click Load to generate rules. Rules are produced using the default values of 5 classes using Equal Intervals.
9.	 The Natural Breaks Jenks-Caspall method offers a more mathematically rigorous classification. Click the Method 

drop-down list and change Equal Intervals to Natural Breaks Jenks-Caspall.
10.	 Under Visual Property Assignment click the Set fill icon and choose a color ramp from the drop-down list. 

Available color ramps are those loaded into the Illustrator Swatches panel. Reverse the color ramp as necessary.

11.	 Click Add to close the Rule Generator dialog box, and back in the Edit Stylesheet Theme dialog box click Apply. 
Your map has now been stylized based on your batch generated rules.

12.	 Close the document without saving.
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8.6	 Create a bar chart theme
1.	 Create a new Adobe Illustrator document.
2.	 Import canada.shp from the Tutorial Data folder.
3.	 In the MAP Themes panel option menu, click New MAP Theme. In the New MAP Theme dialog box, type 

Population into the Theme Name box, choose Chart as the theme type.

4.	 Double-click Population Chart theme in the Themes Panel. Click Yes when the alert box asks to create the 
required Legend layer. 

5.	 In the Edit Chart Theme dialog box, choose Bar Chart from the Type drop-down list.
6.	 Check the "Ignore" check box and enter in the following expression: LIKE(NAME,"Yukon") OR LIKE(NAME,"Nunavut") OR  

LIKE(NAME,"Northwest Territories"). This will prevent bar charts from being applied to Canada's far north.
7.	 In the Source Data tab, with canada_area selected in the Layer drop-down list, click the Add button twice to add 

two attributes.
8.	 Highlight the first unspecified attribute. In the Attribute drop-down list, choose POP2001. In the Appearance 

section choose a fill color and set the stroke to None.
9.	 Repeat these steps with the second unspecified attribute highlighted, this time using the POP2010 attribute and 

a different color for the chart bar (and no stroke).

10.	 In the Chart Options tab, change the bar thickness to 10, the maximum bar length to 80,  the bar spacing to 4.

11.	 In the General Options tab, click the Draw chart border check box.



75MAPublisher 9.2 Tutorial Guide
8  MAP Themes and Legends

12.	 In the Title tab,  click the Show title check box. Enter Pop as the title in the Specify box.

13.	 In the Labels tab, click the Show attribute value labels check box. Change the rotation value to 90 and click the 
Appearance text style link.

14.	 In the Edit Text Rendition dialog box change the text size to 8.00 pt and click OK. 
15.	 Click the Align value labels check box.
16.	 Click the Show attribute name labels check box and repeat steps 13 and 14.

17.	 Click Apply to apply the theme to the map.
18.	 Select the newly created charts and go to Object > Transform > Transform Each. Adjust the horizontal and 

vertical scale to both 30% and click OK.

19.	 Close the document without saving.
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8.7	 Create a pie chart theme

1.	 Create a new Adobe Illustrator document.
2.	 Import canada.shp from the Tutorial Data folder.
3.	 Join the table CA_commute.csv to the canada_area layer on the NAME column (see Exercise 3.5).
4.	 In the MAP Themes panel option menu, click New MAP Theme. In the New MAP Theme dialog box, type 

Commuting into the Theme Name box, choose Chart as the theme type.

5.	 Double-click Commuting Chart theme in the Themes Panel. Click Yes when prompted to create a Legend layer. 
6.	 In the Edit Chart Theme dialog box, choose Pie Chart from the Type drop-down list.
7.	 Check the "Ignore" check box and enter in the following expression: LIKE(NAME,"New Brunswick") OR LIKE(NAME,"Nova 

Scotia") OR  LIKE(NAME,"Prince Edward Island") OR LIKE(NAME,"Newfoundland and Labrador"). This will prevent pie charts from 
being applied to Canada's Maritime region.

8.	 In the Source Data tab, with canada_area selected in the Layer drop-down list, click the Add button six times to 
add six attributes to the pie chart.

9.	 Highlight the first unspecified attribute. In the Attribute drop-down list, choose Cmt_Drive. In the Label field, 
enter Drive Own Vehicle. In the Appearance section, choose a fill color from the drop-down list or click the color 
swatch to open the Color Picker dialog box.

10.	 Repeat step nine for the five remaining attributes choosing a unique color for each attribute and assigning 
attributes and labels as follows:  Cmt_Ride as Small Vehicle Passenger, Cmt_Public as Public Transit, Cmt_Walk as Walk, 
Cmt_Bicycl as Bicycle, and Cmt_Other as Other. 

11.	 In the Chart Options tab, change the Pie radius to 25.00.
12.	 In the Labels tab, click the Show attribute value labels check box. Set the offset to 3.0, click the Label with pie 

percentage check box, and click the Appearance text style link.
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13.	 In the Edit Text Rendition dialog box, leave the font as Arial and choose Narrow as the text style and change the 
font size to 8.00 pt.

14.	 Click Apply to apply the theme to the map.

Note that some text labels, particularly the value labels for "Other" and "Bicycle" attributes, will need to be 
manually adjusted for optimal appearance. This is caused by small percentage values.

15.	 Leave the document open for the next exercise.
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8.8	 Create a chart legend

1.	 Create a MAP Theme, Bar chart or Pie chart like those found in exercise 8.4 to 8.7. Click a Chart Theme in the 
MAP Themes panel, open the MAP Themes panel option menu and click Create Legend.

2.	 In the Create Chart Legend dialog box, accept the default output layer.
3.	 Click the Label appearance text style link. In the Edit Text Rendition dialog box, leave the font as Arial, choose 

Narrow as the text style, and change the font size to 10 pt.
4.	 In the Style tab, change the number of columns to 2.
5.	 In the Title & Border tab, click the Draw title check box and enter Commuting Modes. Click the Draw title line check 

box and increase the margin to 8.00 px.

6.	 Click Create to create the Chart Legend. The Legend will be placed in the centre of the current MAP View, and 
can be manually placed elsewhere on the document.

7.	 Close the document without saving.
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8.9	 Create a dot density theme

1.	 Create a new Adobe Illustrator document.
2.	 Import southchinasea.shp from the Tutorial Data folder.
3.	 In the MAP Themes panel option menu, click New MAP Theme.
4.	 In the New MAP Theme dialog box, type Population into the Theme name box and choose Dot Density as the 

Theme type.

5.	 In the MAP Themes panel, double-click the Population Dot Density theme.
6.	 In the Edit Dot Density Theme dialog box, choose POP_ADMIN from the attribute drop-down list. Click the Load 

button to view the attribute's data range. Notice that the low end of the range contains negative values.
7.	 Enter a dot value of 25000.
8.	 Leave the Dot Options at default values and click Apply to create dot density theme. 
9.	 Click View Log in the MAPublisher alter box. Notice that three pieces of art were not stylized as they held 

negative values in the POP_ADMIN column. Close the MAP Theme Log dialog box.

10.	 Close the document without saving.
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9.1	 Generate labels for a line layer using Label Features

1.	 Create a new Adobe Illustrator document.
2.	 Import torontostreetsjoined.mif from the Tutorial Data folder. 
3.	 In the MAP Views panel, add a new MAP Layer called Street Names and set the Feature type to Text.

4.	 Open the Window > Type > Character panel. Set the font to Arial 8 pt size. This will be the style for the labels.
5.	 Select several streets from torontostreetsjoined_line. These are going to be labeled.
6.	 On the MAPublisher toolbar, click the Label Features button. 
7.	 Only one layer is listed (torontostreetsjoined_line). In the Attribute drop-down list, choose Street. In the Target 

drop-down, choose Street Names. Leave the Style as Use current settings.

The Layer column shows the line, area, point, and text layers currently containing selected data. For each layer, 
the Attribute drop-down list is populated with the attribute structure of that layer. Label the data based on a 
column that holds the appropriate attribute values. 

The Label Settings tabs, contain options to adjust label position, alignment to lines of latitude, minimum font 
sizes, and horizontal scaling to best place labels within polygons and paths. MAPublisher places line labels 
intelligently, depending on the curvature and length of the line string.

8.	 In Line Settings tab, set the Label Position option to Descender. Leave all of the other options as their default.

Labels can be modified if they exceed the length of the line with the current default font size.

9.	 Check the Adjust label if larger than line check box to activate the label rules.
10.	 Check the Reduce font size check box to reduce the size of the font to a specified minimum size in points. The 

default minimum font size value is set to 5 pt.
11.	 Check the Reduce horizontal scaling to a minimum of check box and set the value to 50%. This allows text to be 

scaled down horizontally by the fraction specified to adjust the kerning of the text.
12.	 Check the Set all labels to the same minimum font size check box.

9  Labeling
See User Guide, Chapter 10
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If any of the labels have been adjusted in size due to the activation of a line adjustment rule, all labels can be 
resized to the same size. In this case, it is set to reduce to a minimum of 5 pt.

13.	 Make sure your dialog box matches the graphics above and click OK to label your map.

The labels are added to the map for the streets that were selected. These labels are static and can be styled, 
edited, and moved.

14.	 Close the document without saving.
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9.2	 Generate labels for an area layer using the MAP Tagger Tool

1.	 Create a new Adobe Illustrator document.
2.	 Import fsatoronto.mif from the Tutorial Data folder.
3.	 In the MAP Views panel, add a new Text MAP Layer called Zone Names to the fsatoronto MAP View.
4.	 In the Type Character panel, set the font to Arial and its size to 8 pt. This will be the style for the labels.
5.	 Double-click the MAP Tagger Tool  button in the Adobe Illustrator Tools panel.

Similar to Label Features in the previous tutorial, the label settings must be chosen before MAPublisher is able 
to determine the attributes that will be labeled. The Layer column shows the line, area, point, and text layers 
currently containing selected data.

6.	 In the Label Settings dialog box, choose FSA in the Attribute drop-down list. This attribute contains the name of 
every postal code zone in the selected MAP Layer. In the Target column, choose Zone Names. Click OK to confirm 
these settings.

Notice that the mouse cursor is now the MAP Tagger Tool cursor. Using the MAP Tagger Tool, click on any area 
feature to label it. You can click multiple times on an area to label it more than once.

Note:	 To create leader lines, hold the Shift key and click and drag. Release when the leader line is the appropriate 
length. To reopen the Label Settings dialog box, double-click the MAP Tagger Tool button.

7.	 Close the document without saving.
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9.3	 Create knockouts for labels

1.	 Open Contours.ai from the Tutorial Data folder.

Three MAP layers are visible: contours_labels, contours_line and Background. The contour labels are positioned 
above the contour lines. Use the Create Knockouts feature to mask the contour line below the label.

2.	 From the MAPublisher toolbar, click the Create Knockouts button. 
3.	 Click the Select Layers icon and click the check box for contours_line, then click OK.

The Create Knockouts feature bases the masks on the input of contours_line and contour_labels. Accept the 
default settings shown above to see how the knockouts will look.

4.	 In the Create Knockouts dialog box, click OK.

The knockouts are created. However, the labels are too close to the contour ends. Adjust the masks by adding a 
buffer and changing the transparency. There is no need to undo the previous step.

5.	 In the MAPublisher toolbar, click the Create Knockouts button.
6.	 Set the Mask opacity to 80%. In the Knockout boxes section, set both the Left and Right buffer to 5.00 pixels.
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The Mask opacity adjusts the transparency of the contour lines so that they will be slightly visible (100% opacity 
means that it is completely invisible). The side buffer adds space to the left and right sides of the label so that it 
creates the effect that the contour lines are further away from the label. The reason there is no need to Undo the 
previous mask is because the Replace existing knockouts option is checked.

7.	 Click OK to close the Create Knockouts dialog box.

The knockouts are created with a 5 pixel buffer and 80% opacity. To further adjust the mask, change the settings 
in the Transparency panel.

8.	 In the Adobe Illustrator Layers panel, click the target to select all art on the contours_line layer. Go to the 
Window menu and click Transparency, then click the Mask (right-hand frame). In the Adobe Illustrator Layers 
panel, click the target to select all the art of <Opacity Mask>. In the Transparency panel, adjust the Opacity to 
see how it affects the contour lines.

9.	 Close the document without saving.
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10  Making Selections
See User Guide, Chapter 11

10.1	 Create an attribute filter

1.	 Create a new Adobe Illustrator document
2.	 Import fcstreets.mif from the Tutorial Data folder. It is a line file depicting the major roads of Falls Church, Virginia.
3.	 Select fcstreets_line and click the MAP Selections button on the MAPublisher toolbar. 
4.	 Click the Create New MAP Selection button at the bottom of the panel.

5.	 In the Name box, type Route number. Leave the type as Attribute Filter.

6.	 Click the Expression Builder button to open the Expression Builder dialog box. 
7.	 In the Objects list, under the heading fcstreets_line, double-click Number so that it is entered into the expression 

entry box above. Click the equals (=) button and type "A25" (including quotes).

Note:	 To view the unique values of a specific attribute column, click display unique values under the Description 
box. Click a value to enter it into the expression entry box. It recognizes the attribute as a string and places 
quotations around the value.

8.	 Click OK to close the Edit Expression dialog box.
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The expression is valid.

9.	 Click OK. In the MAP Selection panel, click the Apply as New Selection button.

Lines corresponding to the selection parameters are selected and the MAP Selection is saved in the panel.

     

10.	 Deselect all artwork and leave the document open for the next tutorial.

10.2	 Create a spatial filter

Continue working with the previous tutorial.
1.	 In the MAP Selections panel, click the Create New MAP Selection button.
2.	 In the New MAP Selection dialog box, type Intersect Route A25 into the Name box. In the Type drop-down list, 

choose Spatial Filter.

This spatial filter will select any roads that intersect with Route A25. Use the attribute filter that was created in 
the previous tutorial.

3.	 In the Filter Using drop-down list, choose Existing MAP Selection. In the frame below, the attribute filter Route 
Number is already chosen (because it is the only one).

4.	 Ensure that the Spatial Relationship drop-down list is set to Intersect and contain.
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5.	 Uncheck the Do not select art on the same layer as the 'Filter Using' art option.

Since this spatial filter is selecting art on the one and only MAP layer, this option must be unchecked.

6.	 Make sure the dialog box matches the one above and click OK.
7.	 In the MAP Selection panel, click the Apply as New Selection button.

     

Roads that intersect Route A25 are selected and the MAP Selection is saved in the panel.

8.	 Deselect all artwork and leave the document open for the next tutorial.
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10.3	 Create an art selection filter

Continue working with the previous tutorial.
1.	 Select all artwork on the fcstreets_line layer.
2.	 In the MAP Selections panel, click the Create New MAP Selection button.
3.	 In the New MAP Selection dialog box, type All Routes into the Name box. In the Type drop-down list, choose Art 

Selection and click OK.

     

All selected roads are saved as a MAP Selection in the panel. Now use the MAP Selections panel controls to 
select subsets and add or remove selections altogether.

4.	 In the MAP Selections panel, select the Intersect Route A25 spatial filter and click the Remove from Current 
Selection button.

All the roads that were based on the spatial filter are removed from the current selection.

5.	 Select the Route Number attribute filter and click the Add to Current Selection button.

Route A25 is added to the current selection. Experiment with different combinations to vary selections.

6.	 Close the document without saving.
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11  Working with Images
See User Guide, Chapter 13

11.1	 Register an image with a reference file

1.	 Create a new Adobe Illustrator document in landscape mode Letter sized.
2.	 Import southchinasea.shp from the Tutorial Data folder.
3.	 In the MAP View panel create a new layer of Image type and name it Borneo.
4.	 Make sure that the Layer Borneo is selected. In the Adobe Illustrator menu, click File > Place, navigate to the 

Tutorial Data folder, select the sample raster image file borneo.tif, and click Place.

The raster image is placed at a default position and scale in the center of the screen.

5.	 With the image selected, click the Register Image button on the MAPublisher toolbar. 
6.	 Click the Load File button and select borneo.tfw from the Tutorial Data folder.

All boxes in the dialog box are updated to reflect the data contained in the reference info file. Click OK to close 
the warning.

7.	 Click OK to register the image.
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The image is registered; its size and position have been changed to reflect the information in the reference file.

Note:	 A new map view can be created by registering an image on a non-map layer. The new map view will have the 
same coordinate system of the registered image, the image will be scaled to fit the document size and placed 
on an MAP Layer of the Image type. For more information on this see MAPublisher User Guide, Chapter 12.

8.	 Leave the document open for the next tutorial.

11.2	 Register an image without a reference file 

Continue working with the previous tutorial.

This method is useful if no reference file is available. However, it is necessary to know the coordinates for one 
of the corners of the image as well as the pixel scale in order to register the image correctly. That information is 
provided for you in this tutorial.

1.	 Select and delete the existing Borneo image, but leave the Borneo layer in the document.
2.	 With the Borneo layer highlighted, in the Adobe Illustrator menu, click File > Place, navigate to the Tutorial Data 

folder, select the sample raster image file, borneo.tif, and click Place.

The raster image is brought in at a default position and scale in the center of the screen.

3.	 With the image selected, click the Register Image button on the MAPublisher toolbar. 

One of the four corners of the raster image is what MAPublisher will use as the raster anchor point (Upper Left 
Placement, Lower Left Placement, Upper Right Placement or Lower Right Placement).

4.	 Click the Upper Left Placement (top left corner of the blue diagram) and type the following values into the 
Upper Left Placement X and Y boxes: X=108.3375605,  Y=7.7816585.

5.	 Make sure that Constrain Proportions option is checked and type pixel size X equal to 0.012773.
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6.	 Make sure the dialog box matches above and click OK.

The image is registered to the selected layer.

7.	 Leave the document open for the next tutorial.
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11.3	 Export a placed image as a georeferenced raster file

Continue working with the previous tutorial.
A referenced image must be placed on an Image layer in order to export it.

1.	 With the Borneo image selected, click Export > Export Selected Image from the MAPublisher Toolbar.
2.	 In the Export Selected Image dialog box, choose GeoTIFF from the Reference format drop-down list to set the 

georeferencing output format.

3.	 Click Save As and navigate to a location to save the export image.
4.	 Type a file name (e.g. MyBorneo.tif ) for the export image and click Save to complete the export process.

The image of Borneo is exported as a GeoTIFF file using the coordinate system of the South China Sea layer. 

5.	 Close the document without saving.
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12.1	 Create an index grid

1.	 Open grids-example.ai  from the Tutorial Data folder.

Make sure the world_area layer in the WGS 84 MAP View is chosen. Several graphic styles and character styles 
have been created for you for this tutorial to style grids and graticules. You can also create these prior to using 
the Grids & Graticules dialog box and the styles will be available from the menus. Alternatively, you can use the 
Custom mode to create a style or font and apply it directly.

2.	 On the MAPublisher toolbar, click the Grids & Graticules button.  In the message, click Create Legend layer.

3.	 In the Grids & Graticules dialog box, click the Index Grid button to show its options. Leave the By number of 
columns/rows as 10 for each box.

4.	 In the Grid Collection box, click Grid Lines. Ensure the Draw Grid Lines check box is checked and the 
Solid line option is chosen. Click the style link (1 pt Black). In the Edit Appearance dialog box, click the 
Graphic style/Custom style toggle icon and then select Grid Style from the Style drop-down list, then click OK.

5.	 In the Grid Collection box, click Grid Border. Ensure the Draw Border check box is checked and the Solid line 
option is chosen. Click the style link (1 pt Black). In the Edit Appearance dialog box, change the stroke weight to 
1.25 pt, then click OK.

 

12  Grids, Graticules and Indexes
See User Guide, Chapter 13
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6.	 In the Grid Collection box, click Cell References. In the Label placement control, click both the top label (1, 2) 
and the left label (A, B) to enable them. Notice that labels in the Label placement control highlighted with a 
green box when the mouse hovers over the different style options.

Clicking the border reference labels enables or disables the display of border labels on the grid.

7.	 Click Preview.

The Grids & Graticules dialog box minimizes and a grid is drawn with the settings you specified. You'll change 
more index settings such as offset and label style.

8.	 Click Restore.
9.	 In the Label placement control, click the center style label to enable them.
10.	 Under the Cell References section, increase the Place labels off cell by value to 5.00 px.
11.	 Click the Border style link. In the Edit Text Appearance dialog box, click the Character style/Custom style toggle 

icon, and choose My Grid Style from the Character style drop-down list, then click OK.
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12.	 Click the Center style link. In the Edit Text Appearance dialog box, change the font size to 9.00 pt and choose a 
gray fill color. Then click OK.

13.	 Click the Row order drop-down list and choose Ascending.

14.	 Make sure your settings match the ones above and click OK to create the index grid.

An index grid is placed on the map. Each cell is labeled with an alphanumeric reference label. The border labels 
are offset from the border compared to the first preview. To edit an existing grid, select the grid and click the 
Grids & Graticules button.

15.	 Save the document as MyGrid.ai. It will be used in Tutorial 12.4 Creating an Index: Feature Based.
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12.2	 Create a graticule

1.	 Open grids-example.ai  from the Tutorial Data folder.

Hide all other layers and make sure the world_area projected layer is visible in the Mollweide MAP View.

2.	 From the MAPublisher toolbar, click the Grids & Graticules button. In the message box, click Create Legend layer.
3.	 In the Grids & Graticules dialog box, click the Graticules button to show its options. Under Latitude, type 20 in 

the Interval box. Under Longitude, type 20 in the Interval box.

Graticules can be plotted to intersect at specific lines of latitude and longitude. Pass through values of zero 
will create a graticule that passes through the Prime Meridian and the Equator. This graticule will have lines at 
intervals of 20 degrees.

The Vertices slider controls the number of nodes to construct the graticule. Higher numbers should be used if 
graticules are curved or in anticipation of transforming them. For now, leave the default setting. 

4.	 In the Grid Collection box, click Grid Lines. Ensure the Draw Grid Lines check box is checked and the 
Solid line option is chosen. Click the style link (1 pt Black). In the Edit Appearance dialog box, click the 
Graphic style/Custom style toggle icon and then select Grid Style from the Style drop-down list, then click OK.

5.	 Click the Show Ticks Along Grid Lines check box. Change the Place tick every setting to 10.00 (degrees) and the 
Tick length setting to 4.00 px.

6.	 In the Grid Collection box, click Grid Border. Click Draw Grid Border to uncheck it.
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7.	 In the Grid Collection box, click Line Labels. In the Label placement control, click the West label (Lat) to enable it.
8.	 Under the Coordinate Values Along Grid/Graticule Border section, click the Longitude style link and change the 

character style to My Grid Style. Click the East link to change the offset to 5.00 px. Finally, make sure the If line does 
not hit bounds, label drop-down list is set to Latitude & Longitude.

9.	 Click OK to create the graticule.

A graticule is placed over the map with latitude labels. To edit an existing grid, select the grid and click the Grids 
& Graticules button.

10.	 Close the document without saving.
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12.3	 Create a measured (UTM) grid

1.	 Open grids-example.ai  from the Tutorial Data folder.

Hide all other layers and make sure the toronto_area layer is visible in the Toronto NAD 83 / UTM 17N MAP View.

2.	 From the MAPublisher toolbar, click the Grids & Graticules button. In the message box, click Create Legend layer.
3.	 In the Grids & Graticules dialog box, click the Measured Grid button to show its options. Set the Cell Size Width 

and Height to 1000 (meters). Leave the Positioning options as default.

Grid cell sizes will be created at 1000 x 1000 meters in size.

4.	 In the Grid Collection box, click Grid Lines. Ensure the Draw Grid Lines check box is checked and the Solid line 
option is chosen. Click the style link and change it to the Grid Style graphic style.

5.	 In the Grid Collection box, click Grid Border. Click the Draw Ticks Along Border check box and change the Tick 
length to 5.00 px.

6.	 In the Grid Collection box, click Line Labels. In the Label placement control, click the X and Y labels for East, 
West, North, and South to enable them. 

7.	 Under the Coordinate Values Along Grid/Graticule Border section, change the Easting style to the My Grid Style 
character style. Change the East offset to 3.00 px. 

8.	 Click the Format link and choose Full value with units and Direction in the Label format drop-down list and click OK.
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9.	 Make sure your dialog box matches the following and click OK.

A grid is placed on the map based on the specifications made. Each cell line has UTM map coordinate labels. To 
edit an existing grid, select the grid and click the Grids & Graticules button. If the grid is moved, the grid labels 
will automatically adjust to new coordinates.

10.	 Close the document without saving.
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12.4	 Create a feature based index

1.	 Open MyGrid.ai (saved from Tutorial 12.1).
2.	 In the Adobe Illustrator Layers panel, turn on the Country labels Text layer.

3.	 Select the grid in the map document and click the Make Index button on the MAPublisher toolbar. 
4.	 Choose the Make index based on label and matching feature position option. In the Label Layer drop-down list, 

choose Country labels. In the Feature layer drop-down list, choose world_area (the layer that was labeled). In the 
Label text matches attributes drop-down list, choose Country (the attribute column used to label the map).

Advanced options are available for fine-tuning index appearance.

5.	 Click the Advanced button.
6.	 In the Advanced Options dialog box, choose Feature label from the Sort by drop-down list. Under Output 

Formats, choose the Single-line expanded option. To add an attribute to the index, select the Capital and 
Population attributes in the Select Additional Attributes list.
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The grid cell locator and feature name in the index file are separated by a single tab. The index is sorted 
alphabetically by feature label.

7.	 Click OK to accept the advanced options and in the Make Index dialog box, click Save As to save the index. 
Browse to a location to save the index, name it MyIndex.txt, and click Save.

A text file is created based on the specifications entered in the Make Index dialog box.

8.	 The index may be inserted into the map document by creating an Adobe Illustrator box and using the Place 
command (File > Place).

9.	 Leave the document open for the next tutorial.
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12.5	 Create a text based index

Continue working with the previous tutorial.
1.	 Select the grid in the map document and click the Make Index button on the MAPublisher toolbar.
2.	 Choose the Make index based on label position option. Click the Layers button and click the Selected toggle for 

Country labels, then click OK.

Indexing by label position generates an index containing only grid cells that contain a text label within it. 

Note:	 Text labels are indexed according to the text object's anchor.

3.	 Click the Advanced button. Choose Grid Cell from the Sort index by drop-down list. Under Specify Index 
Separator, to the right of Attribute, click the tab button. In the Edit Attribute-Grid Separator dialog box, type "," 
into the Custom box and click OK.

The grid cell locator and feature label in the index file is separated by a single comma. The index is sorted 
alpha-numerically by grid cell label.

4.	 In the Make Index dialog box, click Save As to save the index. Browse to a location to save the index, name it 
MyGridIndex.txt, and click Save.

5.	 Close the document without saving.
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13  Scale Bars and North Arrows
See User Guide, Chapter 14

13.1	 Create a scale bar

1.	 Open usa48.ai from the Tutorial Data folder.
2.	 On the MAPublisher toolbar, click the Scale Bar button . When prompted, create a Legend layer.
3.	 In the Scale Bar dialog box, use the up and down arrow buttons to view scale bar styles (for this tutorial, use the 

default one). Choose Kilometer in the Units drop-down list. In the Interval box, type 250.
4.	 Click the Appearance hyperlink. In the Scale Bar Appearance dialog box, change the Alternate colour to 20% 

Black and the Stroke to 0.5 pt. Then click OK.

5.	 Under the Interval Options section, In the Number of labeled intervals box, type 4. Set the Number of intervals to 
subdivide to 1 and the Number of sub intervals to 5.

These settings create a scale bar that represents a total distance of 1000 km. It has four main intervals each 
representing 250 km with the first interval further divided into five smaller intervals.

6.	 Under the Labeling Options section, click the Tick label appearance hyperlink to open the Edit Text Rendition 
dialog box. Click the character style / custom style toggle icon so that [Normal Character Style] is displayed. 
Click OK. 

7.	 Click the Display scale value check box, choose Show above from the drop-down list, and choose Align center.
8.	 Click the Display units to right of last interval label check box. 
9.	 Click the Display page to map units ratio check box, choose Centimeters  from the Page units for captions 

drop-down list, change the Precision to 0 decimal(s), and choose Show below from the Placement drop-down list.

Look at the preview 
to see how these 
settings affect the 
look of the scale bar.
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10.	 Click OK to accept settings for the Scale Bar dialog box.

The Scale Bar is placed at the center of the page according to the defined Settings. If necessary, resize the scale 
bar using the bounding box. The scale automatically adjusts after it is resized.

11.	 Click the scale bar to select it. Click and drag the top anchor of the bounding box slightly downward to resize 
the scale bar. (Note: dragging it too much will prevent it from resizing).

     

12.	 Leave the document open for the next tutorial.

Note:	 The scale bar can edited through the Adobe Illustrator menu Object > Edit Scale Bar. When the MAP view is 
rescaled, the scale bar dynamically updates. The scale bar can be expanded to be edited as regular Adobe 
Illustrator artwork (however, doing so breaks the link to the MAP View scale value). 

13.2	 Create a north arrow

Continue working with the previous tutorial.
1.	 In the MAP Views panel, add a new MAP Layer called North Arrow and specify the Feature type as Legend.
2.	 Open the Adobe Illustrator Symbols panel. Click its panel options menu and go to Open Symbol Library > MAP 

Symbols > Other symbols > North arrows. 
3.	 Click and drag a north arrow symbol to the artboard.

4.	 Select the north arrow symbol and click the North Arrow button on the MAPublisher toolbar. 

     

* Sample north arrow designs are located in the \Helpful Styles & Symbols\Symbols folder (see page iii). 
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The north arrow is changed from a regular symbol to a dynamic north arrow and is aligned in the north 
direction. The projection of the map allows for the rotation of the north arrow. If it is moved, it will change its 
rotation and continue to point towards north. North arrows can be created from any Adobe Illustrator symbol. 
Note that the north arrow created is now added to the Symbols panel*.

5.	 In the MAP Views panel, double click the usa MAP View.
6.	 In the MAP View editor, set an Angle of 45 degrees, click the Auto Scale button and the center page alignment.

7.	 Click OK to accept the angle edits.

The north arrow is oriented according to the MAP View it is placed in. Any changes made to the coordinate 
system or angle of the MAP View will cause the north arrow to automatically orient itself towards north.

8.	 Close the document without saving.
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14  MAP Web Author 
See User Guide, Chapter 15

This tutorial is a MAP Web Author work flow to create a Flash map and HTML5 map from a static map document.

14.1	 Prepare the map for web tags

1.	 In Adobe Illustrator, click File > Open, navigate to the \Tutorial Data\MAPWebAuthor_Tutorial folder and open the  
Canada_Web_Map.ai tutorial document.

Before creating any web map, it is recommended to appropriately set the document size in Adobe Illustrator. 
This will also determine the size of the web map. Use Document Setup or the Artboard Tool to set the document 
dimensions. For this tutorial, the document is already set at 500 pixel width x 500 pixel height.

2.	 In the Adobe Illustrator menu, click the MAP Web Author button on the MAPublisher toolbar.  
3.	 In the MAP Web Author panel option menu, click Specify Source Media Folder.
4.	 Choose the Relative Path option and leave the Source Media Folder field blank.

This dialog box sets the path to the ImageFiles folder (the folder containing the image data) for web tagging. To 
indicate that the ImageFiles folder is in the same directory as Canada_Web_Map.ai, leave the path blank.

5.	 Click OK to close the Specify Source Media Folder dialog box.
6.	 Click any province on the map and open the MAP Attributes panel to become familiarized with the attribute 

structure and data.
7.	 Close the MAP Attributes panel and continue to the next tutorial.
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14.2	 Create web tag callouts

This tutorial creates Web tag callouts for every object in the Provinces layer. These Web tags are used to expose 
attribute information when map features are clicked.

1.	 In the Adobe Illustrator Layers panel, click the target button beside the Provinces layer name to select all art.
2.	 In the MAP Web Author panel, click the Edit button to open the Edit Web Tag dialog box.

3.	 In the Edit Web Tag dialog box, click the Title box and then click the Insert Attribute button and in the expanded 
list, click %NAME% to insert it. Similarly, click the Web Tag Image box and insert %IMAGE%.

The %NAME% and %IMAGE% attribute variables retrieve values from the Provinces attribute table. In the case 
of %IMAGE%, the attribute is actually the image path (you saw this when you reviewed the layer attributes). The 
Show Preview option is enabled by default. This displays a preview of the web tag as content is entered.

Note:	 The attribute names are case sensitive and should match exactly as they are in the MAP Attribute table.
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Now, add more information to the web tag by entering some basic HTML code. Look at the preview to see how 
it changes as the code is typed.

4.	 In the Content box, type the following:
<b>Province:</b> %NAME%<br> 
<b>Population:</b> %Population%<br>
<b>Province:</b> %CapitalCity%<br><br>
Go to the <a href="%OfficialWebSite%">government website</a>

Beside the preview, click the arrow buttons to scroll through the web tags for each province. The current and 
total number of web tags being editedn is shown in between the arrow buttons. The web tags can be manually 
resized, however, the Auto Size feature ensures that content will fit properly.

5.	 Click OK to save the web tags and to close the  Edit Web Tag dialog box.
6.	 Keep the document open and continue to the next tutorials to export the map. There are two types of map 

export to choose from: Flash and HTML5.

Follow tutorial 14.3 to learn how to export to a Flash map.

Follow tutorial 14.4 to learn how to export to an HTML5 map.
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14.3	 Export to Flash

After creating web tags, the next step is to export the map. This tutorial teaches how to export to Flash so that it 
can be viewed in a web browser. It is necessary to have the latest version of Adobe Flash Player installed that is 
compatible with your web browser.

1.	 In the MAP Web Author panel under Export, click the Flash button (art does not have to be selected to export).

2.	 In the Export to Flash dialog box, click the Browse button next to the Export location box. In the Export File 
dialog box, navigate to \Tutorial Data and create a new folder called canada-flash and use the index.html file name. 
Click Save.

The Export location box populates with the new file path.
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3.	 In the Export Settings tab, locate the User Toggle column and click the check boxes for Major city names, Major cities 
and Provinces.

The User Toggle allows the layers to be turned on and off in the map viewer.

4.	 Under the Options column for the Major city names layer, double-click to setup layer options. In the Layer 
Export Options dialog box, choose Hide the layer when the map is initially loaded option and click OK.

The Options column now shows that the Major city names layer is hidden when the map is initially loaded. 
Experiment with the other Layer Export options to see what kind of affect it has on the final map. Refer to the 
MAPublisher 9.2 User Guide for more information.

5.	 Leave the other options in the Export Settings tab as the default and click the Viewer Style tab.
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6.	 In the Viewer Style list, scroll down to Click Highlight Line and double-click the color value to change it. Select 
a purple color (RGB 170, 0, 255 - #aa00ff) and click OK. Double-click the Line Thickness value and change it 
to 2. Scroll down to Hover Highlight Line and change the color to blue (RGB 0,170,255 - #00aaff) and the Line 
Thickness to 1.

The Viewer Styles are used to style Flash elements on the map. Do not confuse these with the MAP Stylesheets 
or Adobe Illustrator graphic styles. These are strictly to style elements such as the web tag callout, the 
navigation buttons, overview map and search box. Changing the default Viewer Style settings creates a 
Cascading Style Sheet (CSS) that contains CSS code that manipulates the look of the Flash elements. For more 
information about this and MAP Web Author, see chapter 15 of the MAPublisher User Guide.

7.	 Leave the options in the Viewer Settings tab as the default and click Export. More information about Viewer 
Settings are available in the MAPublisher User Guide.

After the export process finishes, the Web Export Log dialog box appears. It provides a summary of which layers 
were exported, the corresponding export file name, the number of vertices in each layer and the Flash file sizes. 
It also provides a link to the Export Folder that was specified earlier.

Note:	 Make sure you have properly configured permissions in the Flash Player Global Security Settings panel. See 
chapter 15 of the MAPublisher User Guide for more information.
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8.	 Click the Export Folder link to open the folder. The index.html is located in the export folder. Double-click the 
index_data folder to view all of the map export files.

9.	 Return to the canada-flash folder and double-click index.html to open the Flash map in a Web browser.

     

Navigate the map using the map zoom slider and zoom in and out buttons, the pan tools and using the mouse 
to pan around the map. When the mouse hovers over a province, it highlights to the color specified earlier. Click 
the province and the Web tag callout appears with information defined in the Multiple Web Tag Dialog. Notice 
that the Major city names are hidden. This option was set earlier. Use the layers list to toggle the visibility of the 
provinces, major cities and city names. The overview map in the bottom right corner can be used to navigate 
the entire map without having to zoom out.

The latest Adobe Flash Player is required. It can be downloaded from the Adobe Website at www.adobe.com. If 
you encounter a Flash permissions warning, please see the Avenza Systems forums at www.avenza.com/forum.

10.	 Keep the document open to continue working with it and learn how to export to HTML5.
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14.3	 Export to HTML5

This tutorial teaches how to export to HTML5 so that it can be viewed in a web browser. Unlike Flash, it does not 
require any special plug-ins to be installed. The export process varies slightly and the final result my look similar, but 
the technology used behind the scenes is different.

1.	 In the MAP Web Author panel under Export, click the HTML5 button (art does not have to be selected to export).

2.	 In the Export to HTML5 dialog box, click the Browse button next to the Export location box. In the Export File 
dialog box, navigate to \Tutorial Data and create a new folder called canada-html5 and use the index.html file name. 
Click Save.

The Export location box populates with the new file path.
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3.	 Click the Hide/Show Layers tab. Click the Allow user to hide and show layers in this viewer check box. Click the Add 
button and then click the check boxes for Major city names and Major cities in the Selected column, then click OK.

This setting allows the layers to be turned on and off in the map viewer. The layers are added as a group to the 
list. To the right are several options to change initial visibility, the layer group name and layer format. Expand 
the new layer group to see the layers.

4.	 In the Options frame, rename the layer group to Major Cities.

The Major cities and Major city names will be able to be toggled on and of in the Layers control.

Note:	 The Hide and show layers only at specific zoom levels option puts layers below layers specified in the Allow user 
to hide and show layers in this viewer option.

5.	 Click the Theme tab. Click the Use Custom Theme option to enable its settings. Click the Feature Highlight 
drop-down and choose a purple color (C=75, M=100, Y=0, K=0). 
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The Theme tab has options to style viewer elements. Do not confuse these with the MAP Stylesheets or 
Adobe Illustrator graphic styles. These are strictly to style elements such as the background and foreground 
controls, border and feature highlight. Alternatively, use one of the predefined themes (light or dark). For more 
information about this and other detailed HTML5 options, see chapter 15 of the MAPublisher User Guide.

6.	 Click Export.

After the export process finishes, the Web Export Log dialog box appears. It provides a summary of how many 
tiles were exported, the size of the map data, and the path to the export folder.

7.	 Click the Export Folder link to open the canada-html5 folder. The index.html is located in the export folder. 
Double-click the index_data folder to view all of the exported files.
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8.	 Return to the canada-html5 folder and double-click index.html to open the Flash map in a Web browser.

     

Navigate the map using the mouse to pan, the zoom in and zoom out buttons, and the home button (see all). 
When the mouse hovers over a province, it highlights to the color specified in the Theme tab and shows its 
web tag. Click a province and the web tag appears until it is manually closed. The Layers List button allows you 
to toggle layers on and off. Since the Major city and Major cities name layers were grouped, there is only one 
toggle. Add them individually to get individual layer toggle functionality.

9.	 If necessary, save the document. Otherwise close the document without saving.
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15  Geospatial PDF Export

15.1 Export document to geospatial PDF

1.	 Open usa48.ai from the Tutorial Data folder.

2.	 From the MAPublisher Toolbar, click the Export button > Export Document to Geospatial PDF. In the Geospatial 
PDF Export Settings dialog box, make the Content tab active. Ensure that the usa_area check box is checked. 

3.	 Click the Layer List & Model Tree tab. Click usa_area to enable its options. Click the Use attribute for feature name 
check box. The Attribute drop-down list is STATE_NAME.

This setting will use the attributes of STATE_NAME, in an ascending sort order, in the Model Tree. In the Options 
tab, leave the Embed AI file within PDF as checked. This ensures that the geospatial PDF can be read properly if it 
is ever imported into Adobe Illustrator using MAPublisher.

4.	 Click the Export button. In the Export dialog box, choose Geospatial PDF from the Save as type drop-down list. 
Navigate to the Tutorial Data directory, specify the file name as tutorial15.pdf and click Save.

5.	 Open the operating system file browser window and navigate to the Tutorial Data folder.
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6.	 Double-click to open tutorial15.pdf in Adobe Acrobat Reader (the latest version is required).

The latest Acrobat Reader supports geospatial PDF files and comes with tools to explore the map. The Analyze 
toolbar is located in the Tools menu. It holds three tools specific to geospatial PDFs: Object Data Tool, Measuring 
Tool and Geospatial Location Tool. On the left hand side, there are two useful Navigation panels related to 
geospatial PDFs: Layers and Model Tree. There are also Acrobat Reader preferences to change display elements 
such as geographic units. 

7.	 Click the Layers button in the Navigation panel to expand it. (If it is not present, right-click the Navigation panel 
and choose Layers.)

Only the usa_area layer is present in this geospatial PDF. Click the eye button to toggle the layer's visibility.
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8.	 Click the Model Tree in the Navigation panel to expand it. Click the + symbol beside usa, then usa_area to 
expand them. Click on a state to view its relative location on the map. Alternatively, use the Object Data Tool 
and click features on the map.

The Model Tree shows the map features of all the layers in the document. At the bottom of the Model Tree is a 
window that displays attribute data. In this case, the state name for the feature selected is California.

9.	 Click Tools, click Analyze, then click the Geospatial Location Tool. A status window appears in the bottom-right 
corner that displays the longitude and latitude of the cursor position.
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10.	 In the Analyze menu, click the Measuring Tool. Click the southeast corner of Oregon and draw a measurement 
line to the southeast corner of Kansas. Use the Object Data Tool to find these states if you are unfamiliar with 
the geography. (If necessary, zoom in to see the features in more detail).

When the Measurement Tool is enabled, a secondary measurement toolbar appears that contains Snap Types 
and Measurement Types. A status window in the bottom-right corner appears that displays information on the 
distance measured, azimuth, latitude and longitude of the cursor position. In this case, the straight line distance 
from Portland to Kansas is approximately 1218 miles (or about 1,960 km).

11.	 In the Acrobat Reader menu, click Edit > Preferences. In the Categories list, click Measuring (Geo).

This panel is used to change geospatial measuring options. See the MAPublisher User Guide for detailed 
information on all of its options and settings.
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12.	 In the Display value as drop-down list, choose Degrees, Minutes, Seconds.
13.	 In the Use default distance unit drop-down list, choose Miles.

14.	 Click OK to accept these settings.
15.	 Using the Measure Tool, choose several points to measure.

Notice that the distance is displayed in miles (km) and that the coordinates are displayed as Degrees, Minutes, 
Seconds. Return to the Measuring (Geo) preferences to experiment with the settings to see how they can help 
you explore geospatial PDF maps.
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16.1	 Import Esri Personal or File geodatabase

Note:	 To work with this tutorial, an ArcGIS license is required. This tutorial is only compatible with MAPublisher 
32-bit versions. See the User Guide for more information. 

In this tutorial, you will be importing data to be used for a Northern Ontario rail map.

1.	 In Adobe Illustrator, click File > New ,and create a new landscape oriented document.
2.	 Using Simple Import or Advanced Import click, from the Format drop-down list choose Esri File Geodatabase [*.gdb] 

or Esri Personal Geodatabase [*.mdb].
3.	 Click Browse and in the Tutorial Data folder select NorthernOntario.gdb to open a File Geodatabase or 

NorthernOntario.mdb to open a Personal Geodatabase.
4.	 The Select Feature Classes dialog box appears. Click the populated_points, canada_rail, and canada feature 

classes to select them.

5.	 Click OK to close the Select Feature Classes dialog box and OK again to import the feature classes.

Notice on import that the imported point data covers all of North America. You will import the data again, 
instead this time specifying a spatial filter and using SQL (Special Query Language) to perform an attribute filter 
to limit the amount of imported data.

6.	 Click Edit > Undo to remove the imported data.
7.	 Use Simple or Advanced Import again to import the NorthernOntario geodatabase again.

16  Import Spatial Databases



123MAPublisher 9.2 Tutorial Guide
16  Import Spatial Databases

Note:	 To only use a spatial filter, click the Spatial Filter button on the Select Feature Classes dialog box.  
To perform both a spatial filter and an SQL query simultaneously, choose SQL Query.

8.	 In the Select Feature Classes dialog box, choose SQL Query and click the Create SQL Select Query button.

9.	 In the Create SQL Select Query dialog box, enter the following query:

		  SELECT * FROM populated_points WHERE populated_points.STATEABB='CA-ON';
		  SELECT * FROM canada WHERE canada.NAME IN ('Ontario', 'Quebec', 'Manitoba');
		  SELECT * FROM canada_rail 

10.	 At the bottom of the dialog box, click the Specify Spatial Filter button.

Note:	 Note that the spatial filter has been defined by the extents of the data selected by the SQL query. Through 
the spatial filter, you will further refine the selection to an envelope just beyond Northern Ontario.
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11.	 Ensure the Intersects relationship option is chosen and enter the following Lower left and Upper right 
coordinate values:

The Intersects relationship option specifies that only data that intersects the spatial filter boundary will be 
imported. Click OK to confirm these values, OK again to confirm the SQL Query, OK to close the Select Feature 
Classes dialog box, and finally OK to import the features. 

The feature classes are successfully imported using the SQL query and spatial filter.

12.	 Close the document without saving.
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16.2	 Import Esri ArcSDE geodatabase

Esri ArcSDE technology is a means to interface with and access spatial data from an RDBMS (Relational Database 
Management System). Data stored in an ArcSDE is accessed from a server, whether on an internal network, or 
externally through the Internet. The Utah GIS Portal (http://gis.utah.gov) is one such resource that serves GIS data 
free of charge. This tutorial requires the use of an Internet connection.

1.	 In Adobe Illustrator, click File > New and create a new landscape oriented document.
2.	 Using Simple or Advanced Import, choose Esri ArcSDE Geodatabase from the format drop-down list.
3.	 Click Browse. In the Browse ArcSDE Geodatabase dialog box, select Connections and click the Create New 

button to enter the following parameters: 

					     Connection Name: UtahGISPortal
					     Server: gdb93.agrc.utah.gov
					     Service: 5151
					     Database Name: SGID93
					     User Name: agrc
					     Password: agrc
					     Transactional Version: sde.DEFAULT

Optionally, click Test Connection to check whether these settings work. A message dialog box appears 
informing you whether the connection was successful or not.

4.	 Click OK to confirm the connection settings.
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The UtahGISPortal connection is saved to the list. A saved connection can be accessed again in the future.

5.	 In the Browse ArcSDE Geodatabase dialog box, make sure UtahGISPortal is selected and click OK.

Note:	 Depending on the Internet connection speed, it may take a few seconds to connect to the server.

6.	 In the Select Feature Classes dialog box, type Bioscience into the MAP Dataset box. Choose the feature at the top 
of the list SGID93.BIOSCIENCE.DominantVegetation and click OK.

Note:	 After clicking OK, it may take a few minutes to retrieve the data from the ArcSDE server.
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7.	 In the Simple (or Advanced) Import dialog box, click OK again to finalize the import.

The DominantVegetation layer for Utah downloads and is imported into Adobe Illustrator successfully.

Note:	 The connection parameters to this ArcSDE database service may have changed since the time of printing. 
Updated parameters should be available on the Utah GIS Portal website located at http://gis.utah.gov.

8.	 Close the document without saving.
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16.3	 Import basic Esri ArcSDE server 

Users who do not have an ArcGIS license can install the free Esri desktop application called ArcReader (see the Esri
Website for information - www.Esri.com). File and Personal Geodatabases cannot be read. Access to files with
Basic Esri ArcSDE Server connections is limited compared to the Esri ArcSDE Geodatabase connections.

1.	 In Adobe Illustrator, click File > New and create a new landscape oriented document.
2.	 Using Simple or Advanced Import, choose Basic Esri ArcSDE Basic from the Format drop-down list.
3.	 Click Browse. In the Browse Basic ArcSDE Server dialog box, select Connections and click the Create New button 

to enter the following parameters:

					     Connection Name: UtahGISPortal_Basic
					     Server: gdb93.agrc.utah.gov
					     Service: 5151
					     Database Name: SGID93
					     Version: sde.DEFAULT
					     User Name: agrc
					     Password: agrc

4.	 Click OK to confirm the connection settings.
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The UtahGISPortal_Basic connection is saved to the list. A saved connection can be accessed again in the future.

5.	 In the Browse ArcSDE Geodatabase dialog box, make sure UtahGISPortal_Basic is selected and click OK.

Note:	 Depending on the Internet connection speed, it may take a few seconds to connect to the server.

6.	 In the Select Feature Classes dialog box, type Bioscience into the MAP Dataset box. Choose the feature at the top 
of the list SGID93.BIOSCIENCE.DominantVegetation and click OK.

Note:	 After clicking OK, it may awhile to retrieve the data from the ArcSDE server.
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7.	 In the Simple (or Advanced) Import dialog box, click OK again to finalize the import.

The DominantVegetation layer for Utah downloads and is imported into Adobe Illustrator successfully.

Note:	 The connection parameters to this ArcSDE database service may have changed since the time of printing. 
Updated parameters should be available on the Utah GIS Portal website located at http://gis.utah.gov.

8.	 Close the document without saving.

Congratulations! You have completed the MAPublisher Tutorial Guide. Please see the MAPublisher 9.2 User 
Guide for more detail and information on specific features and commands. Check the Avenza Systems web site 
and forums for updates and more information.
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