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Welcome

Avenza welcomes you to map-making in the 21st century!

Combined with Adobe Illustrator, MAPublisher has revolutionized the art of map-making by allowing spatial data 
files to be used to create maps inside a vector graphics program. MAPublisher allows all cartographic tasks to be 
performed where they should be done; in a powerful graphics environment.

This manual assumes that the user is familiar with Adobe Illustrator and has at least a basic understanding of 
geographic information systems (GIS) terminology and concepts. Please refer to the Adobe Illustrator user guide for 
more information on using Adobe Illustrator. 

The User Guide explains the installation process and the many features of MAPublisher. All MAPublisher panels, 
filters and tools are thoroughly detailed together with the related concepts necessary to build map and perform 
fundamental cartographic and GIS tasks. Please refer to the document Avenza Projections Guide.pdf for more 
information on the projections supported in MAPublisher.

As a complement to these guides, the MAPublisher software installer includes tutorial documents (MAPublisher 8 
Tutorial Guide.pdf , MAPublisher 8 Quick Start Guide.pdf and MAPublisher 8 MAP LabelPro Tutorial Guide) and associated 
GIS datasets. We encourage all users to go through these guides to gain additional experience with MAPublisher 
tools and functions. 

MAPublisher and Adobe Illustrator together constitute an integrated cartographic design software system with 
state-of-the-art graphics tools and geographic functions.
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viii Introduction

Introduction

MAPublisher 8 is the newest version of a powerful suite of plug-ins for Adobe Illustrator CS3 and CS4 that bridges 
the gap between geographic information systems (GIS) and high-end graphic design software in order to facilitate 
the map creation process. MAPublisher 8 offers additional panels, functions, tools and filters to the powerful Adobe 
Illustrator design environment that enable GIS data files to be used as a base for cartographic production destined 
for print or Web contents.

Working from a traditional Adobe Illustrator document, users create and edit their data organized through layers 
(either new or imported with MAPublisher). Users benefit from the Adobe Illustrator graphic tools as well as 
additional custom MAPublisher functions and panels to create, edit and query the map data.

MAPublisher Simple and Advanced Import functions allow the import of major GIS and CAD formats (ArcGIS, MapInfo, 
AutoCAD, MicroStation, KLM and more) into Adobe Illustrator, while retaining their native geometry (Point, Line, 
Text, Area), layer structure, geographic location and attribute data.

The cartographic workspace is managed through MAP Views that control the geospatial parameters: coordinate 
system, map anchor, map scale and rotation. Layers organized under the same MAP View share the same 
geographic frame of reference. A layer must reside within a MAP View to be managed by MAPublisher functions 
and keep its spatial and attribute information; however layers not related to a MAP View may still be used for 
presentation purposes (such as title, scale and legend). An Adobe Illustrator document may contain more than one 
MAP View. For example, a map with an inset map at a larger scale to represent a zoomed-in area of interest.

The MAP Attributes panel allows for creating, editing and querying attribute information. For example, for a line layer 
containing street data, each line segment may be linked to a table with information relative to the street name 
and street category. Using the MAP Attributes panel, this information can be viewed, queried, edited or additional 
columns of data may be appended.

The MAP Stylesheets make use of the attribute data to apply Adobe Illustrator graphic styles, symbols or character 
styles to map features, depending on a given object’s attribute value.

MAPublisher offers many functions and tools to manage GIS data from within Adobe Illustrator. They are described 
in detail in this manual:

•	Import major GIS and CAD format (MAPublisher Simple and Advanced Import, Spatial Database).
•	Plot a symbol by typing in its world coordinates (MAP Point Plotter).
•	Draw objects with geographic dimensions (MAP Area Tools).
•	Trim the geographic extents of the map (MAP Vector Crop).
•	Join lines or points that share a same attribute value, simplify lines, create a buffer area around a line 

(MAPublisher line functions)
•	Automatically label features based on attribute data (MAP LabelPro, Feature Text Label and MAP Tagger Tool).
•	Select features based on attributes (MAP Selection Filters).
•	Import and export geographically referenced images.
•	Create grids and indexes.
•	Create scale bars and north arrows.
•	Export to Geospatial PDF. 
•	Export a map to Flash with populated Web tags (MAP Web Author).
•	Export layers to major GIS and CAD formats.
•	Connect to a GPS device for real-time symbol or line tracing (MAP GPS).
•	And more... 
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What’s New in MAPublisher 8

MAP Web Author
Use the new MAP Web Author tool to create interactive Flash maps for Web-based content, complete with rollovers, 
pop-ups and layer control
A number of options are available to design your Web tags:

•	 Use MAP Attributes to automatically populate the text field.
•	 Include Images, and set their size.
•	 Type and style custom text.
•	 Insert hyper links.
•	 Customizable with Javascript.

Users can tag multiple data layers at the time. During the export process, the user can customize the outline of Web 
tags using the interface options or CSS File. MAP Web Author API add more possibilities for advanced users.

MAPublisher Spatial Database import
MAPublisher 8.2 supports direct import from ESRI Personal Geodatabase (.mdb), File Geodatabase (.gdf ), and 
ArcSDE servers. This function requires ESRI software and a valid license installed on the computer and consequently 
it is only available on Windows operating systems. Supported feature types are Point, Polyline, Polygon, Circular Arc, 
Eliptical Arc, Bezier Curve, Annotations (text). The MAPublisher Spatial Database import allows for SQL queries and 
spatial filters. This function is available as an optional add-on to MAPublisher 8.2.

MAP Vector Crop Tool
With the new MAPublisher 8 Vector Crop Tool, users only need to draw a box around an area of interest and all 
geometry outside the frame is cropped out, while preserving attributes and styles.

MAPublisher LabelPro™
MAPublisher LabelPro™ revolutionizes the way users can label map data, including using symbols as labels and label 
conflict resolution with a high degree of customizable rule-based labeling options. The MAP LabelPro engine uses 
your map data attributes for labeling with styles, rules and controls configured through an intuitive, easy-to-use 
Graphical User Interface. This function is available as an optional add-on to MAPublisher 8.1 and higher.

MAPublisher Toolbar
MAPublisher now has its own customizable toolbar. Buttons for importing, all MAPublisher filters, and toggle 
buttons for MAPublisher panels can be found on this dockable toolbar.

MAPublisher Preferences
The new MAPublisher Preferences allow users to fully customize their MAPublisher experience. Control everything 
from the way layers are sorted to the font used to display attribute data or style of the MAP Selection Filters panel. 
This includes several previously hidden options that used to be the domain of advanced users.

MAP Measurement Tool
The MAP Measurement Tool measures straight distances (between two points), path distances (multiple points) and 
the perimeter and area of closed paths — in page or map unit (real world distances). Furthermore, the measuring 
path can be converted to a line or area in the currently selected layer.
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Export to Geospatial PDF:
New with MAPublisher 8.2 is the ability to export map data to a geospatially enabled PDF. In this process, all objects 
and associated MAP Attributes information (when available) are ported to PDF, while also maintaining the map 
coordinate system. When a geospatial PDF is opened with Adobe Acrobat Reader 9, one can find locations, measure 
distances, add location markers as well as copy coordinates to the clipboard. Additionally, objects can be selected 
and queried and their MAP Attributes can be viewed in the Adobe Acrobat Model Tree.

MAP Point Plotter Panel
The MAP Point Plotter panel has been redesigned for the release of MAPublisher 8. The point style is now selected 
from a pop-up dialog box which contains a larger preview of all the styles present in the document, including their 
full name. By default, the point's position is plotted using the same coordinate system as the current MAP layer, but 
users can now elect to plot using another coordinate system (geodetic or projected). Another new feature is the 
ability to plot centroids. A point may now be plotted at the centroid of every area or line on a selected MAP area or 
line layer.

MAPublisher License Management
The new MAPublisher License Management system helps users manage their licensing in a more streamlined and 
user-friendly manner. Users can now evaluate the product, register, retrieve their licenses and checkout a floating 
license, all in a single dialog box. Additionally, MAPublisher panels are now marked with a lock icon when the 
software is not licensed.

Split Layer
The MAPublisher Selection Filters panel has a new option that allows users to split a layer into new layers based on 
an expression or by unique attribute value. The qualifying features can either be copied or moved to a new layer, 
while maintaining all their attribute data.

KML/KMZ Import and  Export 
KMZ files (KML compressed format) can now be imported and exported directly into and from MAPublisher. Google 
Maps does not support the KML Schema tag or any derived tag (i.e. KML files with attributes values). As such, 
MAPublisher 8 KML/KMZ export settings now includes an option to export to KML/KMZ without the attributes 
information, so that the resultant KML file is compatible with Google Maps. 

S-57 Import
IHO S-57 vector format can now be imported with MAPublisher 8. Use the supplied S-57 template to automatically 
style the map on import.

Geographic Markup Language - Simple Features Import and Export
OGC GML Simple Features (points, lines and polygons), version 2.0 and higher, can now be imported and exported 
(to version 3.1.1) with MAPublisher 8.
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Expressions 
Expressions created in the MAP Selection Filters and recent expressions used in the MAP Attributes panel and MAP 
Stylesheets panel can now be selected and re-used in the Expression Builders of all panels. 

MAPublisher 8.2 introduces new functions available from the Expression Builder (MAP Attributes, MAP Selection 
Filters and MAP Stylesheets panels).

MAP Views Editor
The MAP View Editor now has the ability to display both thumbnails and coloured extents of MAP Views in the 
document. Combined with the new ability to zoom and pan the preview, users should find it much easier to 
precisely position their MAP view on the canvas. Additionally a new function allows to automatically rotate a MAP 
View so that it is oriented to North.

Specify Anchor
 The Specify Anchor function has been redesigned so that the anchor point world coordinates maybe entered in any 
coordinate system specified by the user (geodetic or projected), hence removing the need for external coordinate 
conversions.

Register Image
When no matching vector data is available, a new MAP View can be created directly from a GeoTIFF reference file or 
by specifying a coordinate system.

Grids and Graticules
The Grids and Graticules function offers new options for labelling, a preview option and now fully supports rotated 
MAP Views.

MAP Attributes Interface
The attribute viewer has had several enhancements added for MAPublisher 8. Several buttons have been added 
to provide faster access to some existing functionality: the column button makes setting attribute visibility much 
more accessible and the Zoom to Feature button zeroes in on the current row's artwork in one click. The look and 
feel of the panels has also been improved, with new icons for existing buttons as well as new attribute type icons 
in the column headers. Additionally, the list of layers now only displays MAP layers that have selected MAP features 
selected. 

The MAP Attributes panel has a new function Export Attributes to export all selected attribute information to a 
delimited text file (comma, space, tab or semi-colon separated).

A new function Add Calculated Data has been implemented to allow users to populate attribute columns based on 
geometrical or statistical calculation (e.g. centroid position, mean, distribution...).

Simplify Line Functionality
With MAPublisher 8, Simplify Lines now preserves topology when simplifying—no more gaps between simplified 
polygons. In addition, a new preview option lets you see the results without leaving the dialog box—it even 
displays simplification statistics like number of points removed.
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Import/Export Optimization
The import process has been optimized, improving the loading speed by up to 80%.

MapInfo MID/MIF and MicroStation DGN exports have been enhanced. MicroStation exports now supports the use 
of seed files.

MAP Views Panel
The MAP Views panel has been revamped for speed and stability. The panel should also provide better feedback 
about the states of layers and MAP Views. One immediate effect is that large files or files with large number of layers 
and MAP Views open much faster. Additionally, the MAP Views panel has a new Export button for easy access, as 
well as a new Switch to MAP View button, which should facilitate the movement of layers between MAP Views.

MAP Stylesheets Panel
The MAP Stylesheets panel has been revamped for speed and stability. The panel should also provide better 
feedback about the states of layers and MAP Stylesheets. The popular Switch To button from the MAP Views panel 
has also made it into the MAP Stylesheets panel, allowing you to facilitate the movement of layers from one 
stylesheet to another with just a couple of quick clicks. 
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Before using MAPublisher please read this section to 
ensure that you have a suitable hardware environment, are 
familiar with the installation and activation procedures, and 
adequately prepare your system and workspace to make 
maps with Adobe Illustrator and MAPublisher 8.

Topics covered in this section:
System Requirements
Installation Instructions
MAPublisher Compatibility Notes
MAPublisher License Management
The MAPublisher Tools
The MAPublisher Toolbar
MAPublisher Preferences 
Preparing the Workspace

Getting 
Started
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System Requirements 

WINDOWS

•	 Adobe Illustrator  CS3/ CS4
•	 Intel Pentium 4 processor or higher (Dual core recommended)
•	 Windows XP / Vista / 7 
•	 2 GB of RAM minimum (4 GB of RAM or higher recommended)
•	 300 MB of available hard-disk space

MAC OS X

•	 Adobe Illustrator CS3 / CS4
•	 Intel recommended (Power PC G5 deprecated)
•	 Mac OS X 10.5 or higher*
•	 2 GB of RAM minimum (4 GB of RAM or higher recommended)
•	 300 MB of available hard-disk space

* Official support for Mac OS 10.4 has been deprecated. As such, we highly recommend using MAPublisher on OS 10.5 or 
higher.

NOTE: 	 Not all foreign language versions of Adobe Illustrator may be supported. 
Please contact support@avenza.com for more information.

Before installing MAPublisher 8, please ensure that sufficient system resources are available, as outlined below:
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Please note that MAPublisher is licensed for use on a single computer and once activated will be node-locked 
to that computer and will only function on that computer. Therefore, before proceeding with installation and 
activation please ensure that MAPublisher is being installed on the appropriate computer.

Different full version releases (i.e. 8.x and 7.x) can be installed on the same computer if two versions of Adobe 
Illustrator are present. For example MAPublisher 8 with Adobe Illustrator CS3 and MAPublisher 7.6.3 with Adobe 
Illustrator CS2. However, two point-releases of MAPublisher 8.x cannot be on the same machine. For example, 
MAPublisher 8.2 with Adobe Illustrator CS4 cannot operate together with MAPublisher 8.1 with Adobe Illustrator 
CS3 on the same computer.

In the all cases, it is recommended to un-install older versions of MAPublisher before installing the newest release. 
In this process, an option will be given to backup custom coordinates systems and MAP LabelPro rules.

NOTE:	 If MAPublisher 8 is installed without un-installing an earlier MAPublisher version, removing the earlier 
version will also un-install MAPublisher 8. 

WINDOWS

1.	 �Make sure that a compatible version of Adobe Illustrator is installed on the computer. If Adobe Illustrator is 
running, exit the program.

2.	 DVD version: Insert the MAPublisher 8 DVD. If Autorun is disabled on the system, navigate to the MAPublisher 8.2 
directory on the DVD, and double-click the Setup.exe file.
Electronic version: Double-click the mp82wi-e.zip file to open the WinZip self extractor. When the files are unzipped, 
proceed to the MAPublisher directory and double-click the Setup.exe file.

3.	 Proceed through the installation screens as instructed. Options are given to install documentation and tutorial 
data. If these components are selected, the files can be subsequently be found here: 			 
Start > All Programs > Avenza > MAPublisher 8 > MAPublisher Tutorials. 

4.	 Launch Adobe Illustrator. Please proceed to the section on Registration and Licensing on the following page.

MAC OS X

1.	 �Make sure that a compatible version of Adobe Illustrator is installed on the computer. If Adobe Illustrator is 
running, exit the program.

2.	 DVD version: Insert the MAPublisher 8 DVD. Navigate to the MAPublisher 8.2 directory on the DVD, and double-
click the Install MAPublisher 8.2 icon.
Electronic version: Unstuff the mp82mi-e.dmg file if this operation has not been completed automatically. Then 
proceed to the MAPublisher 8.2 folder and double-click the Install MAPublisher 8.2 icon.

3.	 Proceed through the installation screens as instructed. Note that documentation and tutorial data will also 
be installed. After installation, these files can be found in the Applications\Avenza\MAPublisher 8\MAPublisher 
Tutorials . An Alias to this folder will be created at the end of the installation process which will be placed on the 
desktop.

		
4.	 Launch Adobe Illustrator. Please proceed to the section on Registration and Licensing on the following page.

Installation Instructions 



16 Chapter 1: Getting Started
MAPublisher Compatibility Notes 

MAPublisher Compatibility Notes 

MAPublisher 8 is compatible with Adobe Illustrator CS3 and CS4. Please read the following important compatibility 
information for use when opening legacy MAPublisher and Adobe Illustrator documents.

BACKWARD COMPATIBILITY

All MAPublisher documents are not backwards compatible with previous versions of MAPublisher. 

MAPUBLISHER 5 (OR EARLIER) DOCUMENTS

Point Data
MAPublisher introduced new standards on dealing with point data in MAPublisher 6. Pre-MAPublisher 6 documents 
will have font based points converted to symbols on opening of the document. 

MAPUBLISHER 6 (OR EARLIER) DOCUMENTS

Grids and Graticules
Grids and Graticules were redesigned in MAPublisher 7. Please note that grids created in previous versions of 
MAPublisher (6.x and earlier) will need to be recreated with the new tool if the generation of an index is required.

Legend to Stylesheet Conversion
Legend functionality (Assign Legend Info, Draw Legend etc) was ported into MAP Stylesheets in MAPublisher 7. 
Legend information held in legacy MAPublisher documents (6.x and earlier) will be converted into stylesheets on 
document open. Subsequently Graphic Styles (for line and area legends), Character Styles (for text legends) and 
Symbols (for point legends) will automatically be generated and added to the respective Adobe Illustrator panels.

To qualify for legend conversion, legend art in legacy documents must contain the following properties:
1.	 Be of a valid art type: i.e. polygon, path, symbol or text
2.	 Have a legend expression assigned (via Assign Legend Info or Auto Assign Legend Info)
3.	 Have a target MAP Layer

During the conversion process you will be asked to set additional conversion preferences:
1.	 Determine if target MAP Layers should be immediately assigned to the applicable stylesheet. Checking this 

option will immediately apply the new stylesheets to map art on target layers, whereas unchecking this option 
means the new stylesheets will not be applied on document open, allowing you to manually drag target layers 
into the applicable stylesheet later. Note auto assignment conversions are slower.

2.	 �Determine if you wish to merge similar converted stylesheets (i.e. stylesheets with a matching feature type and 
original map layer) into a single stylesheet. Note this option will be disabled if it is not applicable.

Tables
Table information held on table layers (i.e. MPTables layers) will be removed on document open. Therefore ensure 
that all tables have been joined to the vector art prior to opening the document in MAPublisher 8.
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Open in Adobe Illustrator  CS3 or CS4

Adobe Illustrator 10 or earlier

Legacy Document Format

ALL MAPUBLISHER DOCUMENTS IN ADOBE ILLUSTRATOR 10 (OR EARLIER) FORMAT 
Legacy Text Conversion
Adobe introduced new methods on dealing with text art in Adobe Illustrator CS. Therefore files containing 
MAPublisher text objects must be converted using Adobe Illustrator and MAPublisher text conversion utilities.

If the Illustrator Legacy Text Conversion message appears when opening a legacy document, you should click OK (if the 
text contains attributes that need to be retained). This will allow MAPublisher to use its own conversion utility to 
update text items maintaining the text attributes. If you click Update, the document will be opened, however all 
attributes associated with this text will be lost. 

When receiving the MAPublisher Legacy Text message, choose one of the following: 

 All text art — to convert both MAPublisher text and regular Adobe Illustrator text to the new Adobe Illustrator text 
format.

 MAPublisher text art only — to convert only MAPublisher text to the new Adobe Illustrator text format.

 Nothing — to open the file but lose attribute information associated with MAPublisher text elements.

Adobe Illustrator CS3/CS4

New Document Format

8



18 Chapter 1: Getting Started
MAPublisher License Management 

MAPublisher License Management 

MAPublisher will fail to function until activated. The following instructions are for the activation of single-user 
licenses of MAPublisher 8 only. If you have purchased a floating license please refer to the floating license 
installation guide provided with your purchase. MAPublisher 8 is available in both single-user and floating license 
configurations. Floating licenses are designed to allow an organization to deploy a specific number of licenses that 
can be used and shared on any number of computers over a network. 

IMPORTANT: Some peripheral components might interfere with the activation process. Before activating 
MAPublisher, users must temporarily unplug or disable: mobile phone, blue tooth, wireless or GPS systems.
Laptop users with a docking station must activate MAPublisher in the undocked state. 

After the installation of MAPublisher 8, launch the version(s) of Adobe Illustrator you installed it to. The MAPublisher 
Welcome Screen will appear automatically. This screen gives four licensing options: Evaluate, Register, Retrieve and 
Floating. 

NOTE:	 To continue to use Adobe Illustrator without MAPublisher, cancel this dialog box and activate MAPublisher 
license later by navigating to the Help menu in Adobe Illustrator and then to MAPublisher Licensing > License 
Management.

MAPublisher panels are marked with a lock icon  when the software is not licensed.

ACTIVATING AN EVALUATION VERSION OF MAPUBLISHER

1.	 After installation of MAPublisher 8, click the Evaluate button of the MAPublisher Welcome Screen or MAPublisher License 
Management dialog box. Fill the form. 	

	 If you cannot activate the evaluation license directly from the application (due to Firewall limitations), then go 
to www.avenza.com/register or email (activation@avenza.com) or phone and provide the Machine ID displayed 
in the MAPublisher License Management dialog box. An email with a zipped license file attachment will be sent to 
you. You must unzip this attachment and save the .lic file to the appropriate folder*.

	

MAPublisher Welcome Screen

MAPublisher License Management

Machine ID -  When moving or 
activating a license through the 
internet or by e-mail, please note 
the computer's machine ID here.
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2.	� When you are ready to purchase the software you can open the MAPublisher License Management dialog box 
from Adobe Illustrator Help menu at MAPublisher Licensing > License Management, click Register button and 
follow the instructions in the next paragraph.

REGISTER A PURCHASED COPY OF MAPUBLISHER

1.	 To activate MAPublisher 8 you must enter the Serial Number which was provided when you purchased the 
product. 

2.	 After installation of MAPublisher 8, click the Register button of the MAPublisher Welcome Screen or MAPublisher 
License Management dialog box. You will be prompted to enter the serial number, then fill out the form. 

If you cannot register your purchased license directly from the application (due to Firewall limitations), then go to 
www.avenza.com/register or email (activation@avenza.com) or phone and provide the Machine ID displayed in the 
Finish screen. We will then send you an email with a zipped license file attachment. You must unzip this attachment 
and save the .lic file to the appropriate folder*.

RETRIEVE YOUR MAPUBLISHER LICENSE

If you have inadvertently deleted your license file from your hard drive, you can click the Retrieve button of the 
MAPublisher Welcome Screen or MAPublisher License Management dialog box. This will download the license file from 
our server.

If you cannot retrieve your MAPublisher license directly from the application (due to Firewall limitations), then go to 
www.avenza.com/register or email (activation@avenza.com) or phone and provide the Machine ID displayed in the 
MAPublisher License Management dialog box. We will then send you an email with a zipped license file attachment. 
You must unzip this attachment and save the .lic file to the appropriate folder*.

* The license file is located in the following directories:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8
Windows Vista / 7: C:\ProgramData\Avenza\MAPublisher 8 
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In

Alternatively, users may right-click on a row in the License Management dialog box (started from the menu Help 
> MAPublisher Licensing > License Management) and click on the menu item Browse to license folder... This opens a 
file browser at the dedicated MAPublisher license file directory for your operating system. Keeping this browser 
opened, users can past in the license file received directly at the appropriate location.
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CHECKOUT A FLOATING LICENSE

If you have purchased a floating license please refer to the floating license installation guide provided with your 
purchase. Once the server license is fully operational, follow these instructions to check-out a license from the client 
machine (computer running the actual MAPublisher application). 

1.	 After installation of MAPublisher 8, click the Floating button of the MAPublisher Welcome Screen or MAPublisher 
License Management dialog box.

2.	 Enter the name or IP address of the server where the license manager resides.

3.	 Click the Checkout button to retrieve the one of the licenses from the server. 

NOTES: 
•	 If you wish to use Adobe Illustrator without MAPublisher, then click the Check in button from the 

MAPublisher License Management dialog box (at Help > MAPublisher Licensing > License Management). 
This releases the license, so other users can now use it.

•	 The link to the server is set for once. The next time you start the application, you just need to the click 
the Checkout button on the MAPublisher Welcome Screen (or License Management dialog box).

MAPUBLISHER LABELPRO LICENSING

MAPublisher LabelPro is an optional add-on to MAPublisher. Purchased MAPublisher LabelPro licenses are added 
to the main MAPublisher license. During the registration process described earlier in this chapter, all valid licenses 
will be imported. When purchasing a new MAPublisher LabelPro license on the top of an existing MAPublisher 
license, the existing serial number will be tagged to support LabelPro and the new license must be retrieved (see 
instructions earlier).

To evaluate MAPublisher LabelPro license, open the MAPublisher License Management dialog box from the Adobe 
Illustrator menu Help > MAPublisher Licensing > MAPublisher License Management. Click the MAPublisher LabelPro 
branch and then click the Evaluate button as previously explained.

The evaluation version of MAPublisher LabelPro scrambles the text of placed labels but preserves the case, spacing 
and punctuation, so that the results give a sense of how actual labels would be placed based on the rule settings. 
See chapter 18 for more details on MAP LabelPro functionality and usage. 

NOTE:	 MAPublisher and MAPublisher LabelPro can only be both floating licenses or both local licenses (fixed 
or evaluation). A user on a floating license wishing to evaluate MAPublisher LabelPro will have his main 
MAPublisher and MAPublisher LabelPro licenses switched to a local evaluation license. At the end of the 
evaluation period, the settings for floating license can be reset as described above.
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MAPUBLISHER SPATIAL DATABASE LICENSING

MAPublisher Spatial Database is an optional add-on to MAPublisher 8.2. Purchased MAPublisher Spatial Database 
licenses are added to the main MAPublisher license. During the registration process described earlier in this chapter, 
all valid licenses will be imported. When purchasing a new MAPublisher Spatial Database license on the top of an 
existing MAPublisher license, the existing serial number will be tagged to support Spatial Database and the new 
license must be retrieved (see instructions earlier).

To evaluate MAPublisher Spatial Database license, open the MAPublisher License Management dialog box from the 
Adobe Illustrator menu Help > MAPublisher Licensing > MAPublisher License Management. Click the MAPublisher Spatial 
Database branch and then click the Evaluate button as previously explained.

NOTE:	 MAPublisher and MAPublisher Spatial Database can only be both floating licenses or both local licenses 
(fixed or evaluation). A user on a floating license wishing to evaluate MAPublisher Spatial Database will have 
his main MAPublisher and MAPublisher Spatial Database licenses switched to a local evaluation license. At 
the end of the evaluation period, the settings for floating license can be reset as described earlier.

MOVING A LICENSE

To move a previously activated license to a new computer, use the following steps:

1.	 Uninstall MAPublisher from the current computer.
2.	 Install MAPublisher on the new computer.
3.	 Obtain the machine ID for the new computer — as found in the MAPublisher License Management dialog 

box started from the Adobe Illustrator Help menu at MAPublisher Licensing > License Management.
4.	 Send an e-mail to activation@avenza.com with the following information:

•	 Product name, version and serial number (or machine ID of the old computer).
•	 New machine ID.
•	 A note that indicates the request to move (rehost) the license to a new computer.
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The MAPublisher Tools 
MAPublisher tools can be found in a number of locations in Adobe Illustrator. 

The MAPublisher Importers can be found under 
the File menu

Edit MAP Object - for editing Scale Bars, Grids and Graticules  
(menu item name is adjusted accordingly)

The MAPublisher filters can be found under the Object > Filters menu*.
The MAPublisher Edit MAP Object function can be found under the Object menu.

MAP Images

MAP Labeling

MAP Legend

MAP Lines

* In Adobe Illustrator CS3, MAPublisher Filters are found in the  Filters menu.

The MAPublisher Preferences can be found 
under the Edit menu.
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Five MAPublisher tools can be found in the main Adobe Illustrator Tools panel

The MAPublisher panels can be found under the Window menu

MAP Area Tool (Box)

MAP Area Tool (Ellipse)

MAP Vector Crop Tool

MAP Measurement Tool

MAP Tagger Tool

MAP Location Tool
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The new MAPublisher Toolbar allows the user to launch the MAPublisher tools, described in the previous paragraph, 
in a single click. The MAP toolbar is divided in five sections: MAPublisher Import, MAPublisher Lines, MAPublisher 
LabelPro, MAPublisher Legends, MAPublisher Imaging and MAPublisher Panels.

	

NOTE: MAPublisher Toolbar cannot be saved in a workspace (Adobe Illustrator main menu Window > Workspace 
>Save Workspace...)

MAPUBLISHER IMPORT/EXPORT

		

Simple Import Advanced Import

Export Geospatial PDF

MAPUBLISHER LINES

Buffer Line

Flip Line

Join Lines

Simplify Lines

Join Points

MAPUBLISHER LABELING

Feature Text MAP LabelPro

MAPUBLISHER LEGENDS

North Arrow

Grids Graticules

Scale Bar

Make Index

MAPublisher Toolbar 
Window > MAPublisher > MAP Toolbar

MAPublisher Lines MAPublisher Legends MAPublisher PanelsMAPublisher 
Imaging

MAPublisher 
Import/Export

MAPublisher
Labeling
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MAPUBLISHER IMAGING

Export Image Register Image

MAPUBLISHER PANELS

MAP Attributes

MAP GPS Panel

MAP Stylesheets

MAP Views

MAP Point Plotter

MAP Web Author

MAP Location Tool

MAP Selection Stats

MAP Selection Filter
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MAPublisher Preferences
Edit > MAPublisher Preferences (Windows)

Illustrator > MAPublisher Preferences (Mac OS)
MAPublisher Preferences are options that allow users to customize MAPublisher panels and editors, including those for 
layer ordering, font for attribute data display, panel style, etc. Settings are available for the following categories:

•	 Expression Builder.
•	 General.
•	 Import Map Data
•	 MAP Attributes (panel).
•	 MAP LabelPro.
•	 MAP Location (panel).
•	 MAP Measurement.
•	 MAP Selection Filters (panel).
•	 MAP Stylesheets (panel and editor).
•	 MAP Views (panel and editor).
•	 Spatial Database (Basic ESRI ArcSDE Server Editor, ESRI Geodatabase Editor and General Spatial 

Database Editor). Windows only.

Property sheet with options specific to the selected 
category on the list on the left side.

MAPublisher Preferences are saved within the Adobe Illustrator preference file called AIPrefs (Windows) or 
Adobe Illustrator Prefs (Mac OS), which is launched each time Adobe Illustrator is started. Therefore, MAPublisher 
Preferences are not file dependent.

NOTE:	 The Adobe Illustrator preference file is located in following directory 

Windows XP: C:\Documents and Settings\[ user profile ]\Application Data\Adobe\Adobe Illustrator CSX Settings\AIPrefs
Windows Vista / 7: C:\Users/(user)\AppData\Roaming\Adobe\Adobe Illustrator CSX Settings\AIPrefs
Mac OS X: Users/~username/Library/Preferences/Adobe Illustrator CSX Settings/Adobe Illustrator Prefs

OPEN MAPUBLISHER PREFERENCES

MAPublisher Preferences can be opened from the Adobe Illustrator main menu, Edit > MAPublisher Preferences 
(Windows) or Illustrator > MAPublisher Preferences (Mac OS X), from the panel options menu of the following 
MAPublisher panels: MAP Attributes, MAP Selection Filters, MAP Stylesheets and MAP Views, and from double-click of 
the tools buttons: MAP Location and MAP Measurement.
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When opened through the Adobe Illustrator menu, MAPublisher Preferences opens up with no category selected. 
When started from a specific MAPublisher panel options menu, MAPublisher Preferences open on the current panel 
property sheet. 

MAPUBLISHER PREFERENCES SETTINGS

Clicking one of the MAPublisher category or sub-categories on the left hand list displays the corresponding 
property sheet displayed on the right. 

Expression Builder Preferences
The Expression Builder property sheet shows the settings relative to the Expression Builder dialog box used with 
the MAP Attributes, MAP Stylesheets and MAP Selection Filters panels (see chapter 5 for more information).

General Preferences
The General property sheet is used to change the layer ordering rule for all MAPublisher panels. By default, layers 
are sorted alphabetically only. The other option is to first group layers by data type first (Legend, Text, Point, Line 
and Area) and subsequently in alphabetical order for each group.

Sorting Style - Set to Name, then type 
for an alphabetical sorting. Set to 
Type, then name to first sort the layers 
per data type (Legend, Text, Point, 
Line or Area) 

Maximum unique values - Set the 
maximum number of unique 
values visible in the Expression 
Builder (Expression Components > 
Description).

The default value is 1000, users with 
high performance computers can 
increase this number.

Locale- This option affects how 
MAPublisher formats numbers (e.g. 
use comma or point as a decimal 
separator). Use the operating system 
local settings or specify a different 
language and country

Pinned map units - The selected map 
units are listed first in the unit 
drop-down lists of MAPublisher (e.g. 
in Scale Bar or Buffer Lines dialog 
boxes).

Max recent map units - Maximum 
number of map units memorized by 
MAPublisher.
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Import Map Data Preferences
The Import Map Data preference category allows users to sort the order of the attributes columns upon import. 
By default, attributes are imported in the same order as in the source GIS data file and the MAPublisher #Property 
attributes are created in front of the imported attributes (see chapter 5 for additional information)

MAP Attributes Preferences
The MAP Attributes preference category does not contain general settings but has a sub-category for the MAP 
Attributes panel (see chapter 5 for a full description of the MAP Attributes panel).

MAP Attributes Preferences

Attribute sort on import - Set to Do not 
Sort to maintain the attributes order 
of the source GIS file. Set to Order 
attributes alphabetically to apply this 
new ordering.

Property disposition on import - Set to 
Move properties to start or Move 
properties to end.

Append feature type as suffix on imported 
layer names - By default, the feature 
type is appended to the layer name 
(e.g. '_area' or '_point'). Clear this 
check box to prevent this behaviour.

Ensure imported layer names are unique- 
By default, MAPublisher appends 
a number 1, 2 etc... to an imported 
layer name if the layer name already 
exists. Clear this check box to prevent 
this behaviour.

Show extensions in Format drop-down list 
- By default, the Format drop-down 
list in the Simple and Advanced 
Import dialog boxes shows the format 
extensions (e.g. '.shp'). Clear this check 
box not to display format extensions.

Show full file name in Advanced Import table 
- The Advanced Import table shows 
the list of selected files for import. 
By default, only the file name is 
displayed. Check this option to display 
the full path.

Show extents in Advanced Import table - 
Check this option to display the data 

extents (lower left and upper right 
corners coordinates).

Replicate attribute data to compound path 
sub-components - Enable this option 
before import or creating new 
attributes so that the attributes do 
not get broken when releasing a 
compound path (see chapter 5). 

Default string size - Specify the default 
string size applied when creating a 
new attribute of type  String.

Default decimal count - Specify the 
default number of decimals applied 
when creating a new attribute of 
type  Real.
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MAP Attributes > Panel Preferences:

MAP LabelPro Preferences
The MAP LabelPro preference category contains general settings to save the path access to saved rules, styles and 
symbol folders (see chapter 18 for more information on MAP LabelPro). 

NOTE: The default directories for the rule, style and symbol folder are as follow:
•	 Default rules and styles folders—respectively Rules and Styles subfolders in the directory:
Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\..
Windows Vista / 7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\..
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/..

•	 Default symbol folder:
Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\Symbols
Windows Vista / 7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\Symbols
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/Symbols

Base rule folder – Directory path to the 
rule folder. Click the browse button 

 to open a folder browser and 
change the path.

Base style folder – Directory path to the 
style folder. Click the browse button 

 to open a folder browser and 
change the path.

Symbol folder – Directory path to the 
symbol folder. Click the browse 
button  to open a folder browser 
and change the path.

Ignore invisible artwork – Enable this 
option to ignore individual invisible 
artwork. If this option is disabled, 
individual invisible artwork will 
be taken into account as labelling 
source and obstacle.

Table font– Set the text font for 
headers and attribute values.

Table font size– Set the text font size.

Show icons in column headers – Enable 
this option to display the data type in 
front of the attribute column name (

 Boolean,  Integer,  Real,  
String).

Use selected locale to format displayed 
numbers – Enable this option to apply 
number formats compliant with the 
locale set in the General preferences.
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MAP Location Preferences
The MAP Location preference category does not contain general settings but has a sub-category for the MAP 
Location Tool panel (see chapter 4 for a full description of the MAP Location Tool).

MAP Location > Panel Preferences:

MAP Measurement Preferences
The MAP Measurement category contains display settings for the MAP Measurement Tool (see chapter 7 for details).

MAP Selection Filters Preferences
The MAP Selection Filters preference category does not contain general settings but has a sub-category for the 
MAP Selection Filters panel (see chapter 11 for a full description of the MAP Selection Filters panel).

MAP Selection Filters > Panel Preferences

Lat/Long display format- Set the latitude 
and longitude display format:
•	 Decimal degrees 
•	 Delimited Degrees Minutes Seconds 
•	 Degrees.Minutes 
•	 Degrees.MinutesSeconds 
•	 Packed DMS with decimal point
•	 Packed DMS 

Display precision - Set the number of 
decimals shown on the MAP Location 
Tool panel.

Include latitude and longitude when copying 
coordinates - Enable this option to 
copy the positions in both projected 
(WX, WY) and geodetic coordinates 
(longitude, latitude) when using 
Shift+click in the MAP Location Tool 
panel (see chapter 4).

Display precision - Set the number 
of decimals shown on the MAP 
Measurement annotations

Line colour - Set the colour of the 
digitized measurement path.

New line colour- Set the colour of the 
current segment (between last 
digitized point and current mouse 
position).

Angular/Linear units - Choose to use the 
current layer units or select a specific 
unit in the drop-down lists.

Show filters on two lines - Enable this 
option to display the selection filter 
name and its expression on two 
separate lines. 
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MAP Stylesheets Preferences
The MAP Stylesheets preference category does not contain general settings but has sub-categories for the MAP 
Stylesheets editor and panel (see chapter 9 for a full description of the MAP Stylesheets editor and panel).

MAP Stylesheets > Editor Preferences:

MAP Stylesheets > Panel Preferences:

MAP Views Preferences
The MAP Views preference category does not contain general settings but has sub-categories for the MAP Views 
editor and panel (see chapter 4 for a full description of the MAP Views editor and panel).

MAP Views > Editor Preferences:
In the MAP Views Editor, the Preview Pane allows to display up to 10 MAP Views represented in different Coloured 
boxes . The MAP Views Editor preference property sheet allows to customize the colour of these coloured boxes.

MAP Stylesheet sort style – By default, 
the General sorting style is applied 
(option Use General preference). Set to 
Name, then type for an alphabetical 
sorting. Set to Type, then name to first 
sort the layers per data type (Legend, 
Text, Point, Line or Area).

Sort list using natural string comparison – 
Enable this option to use the natural 
sorting for layer and MAP Stylesheet 
names using numbers (e.g. 1,2,10 
instead of 1, 10, 2).

Maximum values to load - Maximum 
number of attribute values that are 
loaded in list of values of the Simple 
Expression dialog box..
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MAP Views > Panel Preferences:

Spatial Database Preferences
The MAPublisher Spatial Database preference category does not contain general settings but has three sub-
categories: Basic ESRI ArcSDE Server Editor, ESRI Geodatabase Editor and General Spatial Database Editor (see chapter 
19 for a full description of the MAPublisher Spatial Database).

Spatial Database > Basic ESRI ArcSDE Server Editor Preferences:

Spatial Database > ESRI Geodatabase Editor Preferences:

Sort list using natural string comparison – 
Enable this option to use the natural 
sorting for layer and MAP Stylesheet 
names using numbers (e.g. 1,2,10 
instead of 1, 10, 2).

ArcGIS Bin Directory – Specify the 
location where the ArcGIS software is 
installed. Click the browse button  
to open a folder browser and change 
the path.

Show tool tips while dragging – When 
dragging a layer from one MAP 
View to another, a tooltip displays 
information on the destination MAP 
View. Clear this check box to prevent 
tool tips to be displayed. 

Automatically connect to – Check this 
option to automatically connect to a 
specific server connection, selected 
in the drop-down list.

Use alias as layer name – Enable this 
option to use feature classe's alias 
name rather than its true name

Use abbreviated table name for layer name - 
ArcSDE geodatabases' tables 
are identified as databaseName.
userName.tableName. The 
abbreviated version uses only the 
table name as layer name.

If this option is used in combination 
with the "use alias" option, the alias is 
applied first.

Display coded domain/subtype description 
- Option to import attributes with 
coded values from subtypes and 
attribute domains as follow: 
•	 Instead: replace the codes by their 

description (text);
•	 Never: import actual values—codes.
•	 In Addition: create two attribute 

columns, one with the coded 
values and one with the 
descriptions. 

Load subtypes as separate layers– Enable 
this option to use create new layers 

per subtype.

Sort feature datasets alphabetically when 
selecting for import – Enable this option 

to sort feature datasets alphabetically 
in the import dialog boxes.

Sort feature classes alphabetically when 
selecting for import – Enable this option 
to sort feature classes alphabetically 

in the import dialog boxes.

Sort attributes alphabetically when 
selecting for import – Enable this option 
to sort attributes alphabetically in the 
import dialog boxes.

Automatically connect to – Check this 
option to automatically connect to a 
specific server connection, selected 
in the drop-down list.
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Spatial Database > General Spatial Database Editor Preferences:

RESET MAPUBLISHER PREFERENCES TO DEFAULT SETTINGS

MAPublisher Preferences can be reset directly from the MAPublisher Preferences dialog box. A right click on a 
category will display the choice to reset the preference setting of this category or the entire MAPublisher Preferences.

MAPublisher Preferences will also be reset if the Adobe Illustrator preferences are reset or deleted. Adobe often 
recommends this to solve some problems with the application. Adobe Illustrator preferences are reset by doing one 
of the following:

•	 Press and hold Alt+Control+Shift (Windows) or Option+Command+Shift (Mac OS) as Adobe Illustrator is 
starting. The current settings are deleted.

•	 Remove or rename the AIPrefs file (Windows) or Adobe Illustrator Prefs file (Mac OS). New preferences 
files are created the next time Adobe Illustrator is restarted.

Number of SQL queries to remember –
Select the number of queries 
memorized in the Recent category.

Number of default datasets to remember – 
Select the number of default datasets 
saved in memory for later use.
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Preparing the Workspace 

Before you can start using MAPublisher, you must first set up your Adobe Illustrator document. It is at this point 
that you define your page size and units, set your print orientation and generally prepare your Adobe Illustrator 
workspace.

Establish the desired page size and orientation before importing map data as MAPublisher will establish 
georeferencing based on the current page. However editing page dimensions after import will maintain correct 
georeferencing based on the new page dimensions.

SETTING UP YOUR DOCUMENT

1. �Create a new Adobe Illustrator document by selecting File > New, or Select File > Document Setup if you already 
have a blank document open - The Adobe Illustrator Document Setup dialog box appears.

2. �Select the size to use for your page. Letter (8.5” x 11”) is the default size*. You may wish to change the orientation 
to landscape for some files. For example, a map of Chile may be best displayed in portrait but a map of Indonesia 
may be best displayed in landscape.

3. Select your desired page units. The default unit type is Points.

4. �Ensure the page origin is at 0,0. To do this, select View > Show Rulers. Double-click the top left corner of the 		
rulers where the vertical and horizontal rulers intersect.

For more information and details regarding these operations please refer to your Adobe Illustrator User Guide.

* In step 2 the default page size of 8.5” x 11” is for North American versions of Adobe Illustrator. Other language versions 
of Adobe Illustrator may have different default page sizes. Consult your Adobe Illustrator User Guide for more information.

NOTE:	 When using Adobe Illustrator CS3, the document size should not exceed a limit of 200 inches by 200 
inches (200’’ equals 5080 mm, 508 cm, 14400 points, 1200 picas, 14400 pixels). Passed this limit, some 
MAPublisher tools may not operate properly (shift in positioning) due to some issue with this version of 
Adobe Illustrator. Note that the maximum length and width dimension for an Adobe Illustrator document 
is 227.5416 inches.
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MAPublisher 8 imports and exports most of the GIS industry 	
leading vector file formats:

Import Formats 
CAD (*.dxf ) (*.dwg)
Digital Line Graph (*.dlg) (*.opt)
ESRI ArcInfo Generate (*.gen)
ESRI Interchange File (*.e00)
ESRI Shapefile (*.shp)
GML (Simple Features 2.0 +) 
MapInfo Interchange (*.mif / *.mid)
MapInfo Table (*.tab)
MicroStation Design (*.dgn) Not supported under Mac PPC/Rosetta

Delimited Text Data (*.txt) (*.csv) (*.tsv)
KML (*.kml,*kmz)
S-57 (*.000)
Spatial Data Transfer Standard (SDTS) (*.ddf )
TIGER/Line (*.rt1) (*.bw1)
Basic ESRI ArcSDE Server
ESRI ArcSDE Geodatabase
ESRI File Geodatabase (*.gdb)
ESRI Personal Geodatabase (*.mdb)

Export Formats 
CAD (*.dxf ) (*.dwg)
ESRI Interchange File (*.e00)
ESRI ArcInfo Generate (*.gen)
ESRI Shapefile (*.shp)
GML (Simple Features 3.1.1) 
MapInfo Interchange (*.mif / *.mid)
MapInfo Table (*.tab)
MicroStation Design (*.dgn)
Delimited Text Data (*.txt) (*.csv) (*.tsv)
KML/KMZ (*.kml/*.kmz)

This section provides an overview of the supported formats. 
For an in-depth analysis of further considerations when using 
these formats during Import, please see appendix A1.

Map Data File 
Formats
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DATA FORMAT DESCRIPTIONS

AutoCAD Drawing (*dwg) and Drawing Exchange (*.dxf)
Import and Export
These file types are most commonly created by Autodesk AutoCAD product, though other software programs 
such as Bentley MicroStation and various other computer-aided design (CAD) programs are capable of creating 
files in this format. There are two formats used by AutoCAD: DXF (drawing exchange format) files, which 
are large, and ASCII representations of the binary DWG (drawing) files. Logically, both files are identical and, 
therefore, MAPublisher treats both file types in the same manner. AutoCAD files consist of drawing settings and 
configurations, as well as a series of entities, or graphic elements, organized into layers. MAPublisher provides broad 
support for many AutoCAD entity types and options. Prior to import set the colour mode of the Adobe Illustrator 
document to the same scheme used in the colour table of the CAD file (i.e. RGB or CMYK) to ensure colours are 
imported correctly.

Note the hierarchy of layers in multi-feature imports is by feature type: text layers, then point, then line, then area layers.

Digital Line Graph (*.dlg) (*.opt)
Import only
The USGS (United States Geological Survey) DLG file structure is designed to accommodate categories of spatial 
data represented on a conventional line map. Node (point), line, and area data types are accepted. The attribute 
coding scheme is designed to accommodate basic cartographic data categories such as hypsography, hydrography, 

or political and cultural features, as well as additional thematic data categories.

Delimited Text Data (*.txt) (*.csv) (*.tsv)
Import and Export 
MAPublisher also supports the import of Delimited Text Data held in a variety of tabular file formats, as long as the 
data contains coordinate values. File types supported are Text (.txt), Tab Separated (.tsv) and Comma Separated 
(.csv) files. Import Settings dialog box: In order to import point data with MAPublisher the parameters must be set 
by clicking the Settings’ button. This operation is required to choose the columns of the selected attribute file that 
will be used to derive the X and Y coordinates of the data, and ensure correct georeferencing. These and further 
settings are discussed in chapter 6 and in the Delimited Text Data Settings section in appendix A1.

ESRI ArcInfo Generate (*.gen)
Import and Export
ArcInfo Generate files are created by ESRI ArcInfo product, and have a simple ASCII from x-y to x-y format. Due to its 
simplicity you can also use a text editor such as Notepad to create text files and save them with a *.gen extension, 
which can then be imported with MAPublisher. 

Import and Export Supported Data Formats 
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ESRI Interchange File (*.e00)
Import and Export
ESRI Interchange File files are created by ESRI ArcInfo product. A single E00 file describes a complete ArcInfo 
coverage. The file itself is actually an archive of several smaller files, or sub files, which will have fixed names and 
follow a predefined data format. MAPublisher will reproduce these sub files as distinct Adobe Illustrator layers on 
import. Therefore importing a single e00 import can result in the generation of point, area, line and text layers.

Note the hierarchy of layers in multi-feature imports is by feature type: text layers, then point, then line, then area layers.

ESRI Shapefile (*.shp)
Import and Export
Shapefiles are most commonly created by ESRI ArcGIS or ArcView. Shapefiles store both geometry and attributes for 
features, and a single shapefile will consist of at least three physical files. The .shp portion contains the geometric 
data, the .dbf contains attributes for the geometric data, and the .shx contains the index information. All three 
files are required in order to successfully import a shapefile to Adobe Illustrator using MAPublisher. There is also 
usually a .prj file, which holds the coordinate system information of the shapefile and will automatically be read 
by MAPublisher on import. If your shapefile folder does not contain a .prj file you will be required to specify 
the coordinate system in order to fully utilize MAPublisher. The important things to remember when importing 
Shapefiles are that the .shp file must be the one that is selected through the MAPublisher import filter and that 
all its component files must be in the same folder. You may also find that your Shapefile directory comes with two 
extra files, a .sbn and a .sbx, which hold the spatial index for the geometric data. These two files will not exist unless 
the Shapefile was created with an ESRI product, and are not necessary for successful import with MAPublisher.

GML (Simple Features 2.0+)

Import and Export
The Geographic Markup Language (GML) was designed as a geographic interface language for the Geo-Web. It is 
currently in draft as an ISO standard (ISO 19136). The goal of the format is to provide users with a set of abstract 
base objects that can be built into working real world dataset. It uses as XML base to store geometry and feature 
information that can easily be transported across the Internet. 

The GML Simple Feature Profile was created by the Open Geospatial Consortium (OGC) as a restricted but useful 
subset of the GML specification. It provides a reduced geometry and metadata profile that can be shared across 
many GIS tasks. This simple feature model can be used as a base to generate local application profiles for a specific 
work area. Since the GML models base abstract classes, these application profiles (schemas) are required for 
accessing and processing any GML datasets. GML data has a *.gml extension, and requires a attributes schema file 
*.xsd. Some GML files may have their .xsd file referenced to a URL path, we recommend to copy the xsd files locally, 
to avoid error messages upon import when no internet connection is available. 

Users have two options to store their .gml and .xsd files: they can be both located in a same directory or the xsd files 
can be kept in the MAPublisher GML Schema directory found here:
Windows XP, Vista and 7: C:\Program Files\Avenza\MAPublisher 8\Data Source Files\GMLSchema
Mac OS X: /Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/Data Source Files/GMLSchema

The second option is the most practical if all the GML files are using a same schema (only one instance of the xsd file 
needs to be saved). 
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Installed with MAPublisher are three default xsd files: 
•	 xml.xsd, generic GML attribute schema. 
•	 nen3610.xsd and top10nl.xsd, models standardized in the Netherlands (maintained by the Dutch 

topographic office Kadaster). 

GML files with a missing xsd file or with an invalid attribute schema will cause a GML validation error upon import 
(see chapter 3). Users have the option to either find the appropriate xsd file and copy it to the GML Schema 
directory or to the GML file directory, or to disable the GML validation. This option will assign a type string to all 
attributes. See chapter 3 Importing Map Data for more details on these settings. 

MAPublisher supports the import of simple features (points, lines, polygons, donuts, and aggregates) in GML 2.0 
and later versions. MAPublisher supports export to GML 3.1.1. 

KML/KMZ (*.kml, *kmz)
Import and Export
Keyhole Markup Language (KML) is an XML-based language for managing the display of three-dimensional 
geospatial data in the programs Google Earth, Google Maps, Google Mobile and WorldWind. The KML file specifies 
a set of features for display. Each feature always has a longitude and a latitude and can have other data, such as tilt, 
heading, and altitude. KML shares some of the same structural grammar as GML. KML files are very often distributed 
as KMZ files, which are zipped KML files with a .kmz extension. MAPublisher imports and exports both file type 
based on the KML version 2.2. specifications.

MapInfo Interchange (*.mif/*.mid)
Import and Export
Files of this type are most commonly created by the MapInfo product, though other products, including 
MAPublisher, are also capable of generating files in this format. These files exist in pairs where each file has the same 
name but ends in either a .mif or .mid file extension. The .mif portion contains the vector geometric data, and the 
.mid contains the associated attributes. Both files are required in order to successfully import a file of this format to 
Adobe Illustrator using MAPublisher. The important things to remember when importing MapInfo files are that the 
.mif file must be the one that is selected through the MAPublisher import filter and that both files must be in the 
same folder. MAPublisher will automatically locate and deal with the .mid file. 

MapInfo Table (*.tab)
Import and Export
The TAB format is a simple, non-topological format for storing the geometric location and attribute information 
of geographic features, and is an integral part of the MapInfo product. The TAB format defines the geometry and 
attributes of geographically-referenced features in several files with specific file extensions that are stored in the 
same folder on disk. They are:

.tab: main file: table structure in ASCII format.

.map: the file that stores the feature geometry.

.id: the file that stores the index of the feature geometry.

.dat: the dBASE file that stores the attribute information of features.

.ind: table field indexes (if necessary)
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The geometry of each feature is stored as a shape that comprises a set of vector coordinates. The attributes for each 
feature are stored as a record in a dBASE table (.dat) associated with the Shapefile (.map). There is one record in the 
dBASE table for each feature in the map file. Raster TAB files cannot be imported in MAPublisher.

To ensure successful import, select the .tab component in the MAPublisher importers.

MicroStation Design* (*.dgn)
Import and Export
MicroStation Design files (.dgn) are the native files created by Bentley Systems Inc. (and formerly Intergraph) 
MicroStation product. Design Files consist of a header, followed by a series of elements. The header contains global 
information including the transformation equation from design units to user coordinates, as well as the dimension 
of the elements in the file. Each element contains standard display information, such as its colour, level, class, and 
style, as well as a number of attributes specific to its element type. During the import process MAPublisher will 
reproduce .dgn levels as distinct Adobe Illustrator layers. Therefore a typical single import will produce one layer for 
each Level that exists in the MicroStation Design File.

MAPublisher supports the import of MicroStation J (version 7) and V8 files, however attached raster file will not be 
imported (they are ignored). Prior to import set the colour mode of the Adobe Illustrator document to the same 
scheme used in the colour table of the original file (i.e. RGB or CMYK) to ensure that the colours are interpreted 
correctly upon import.

The hierarchy of layers in multi-feature imports is by feature type in the following order: text layers, then point 
layers, then line layers, then area layers. Raster files attached to DGN files are ignored during the import process.

Files are exported to DGN from MAPublisher as MicroStation J files. Upon export, users may select a dgn seed file. 
All information  in the seed file gets carried over to the output file, such as level (layer) definitions, units, colors, 
line styles definitions, etc. If an exported layer name matches a level name in the seed file, the data of that layer is 
appended to the existing level, if not, a new level is created. 

S-57 (*.000)
Import only
S-57 is referring to the IHO (International Hydrographic Office) Special Publication number 57 related to the IHO 
transfer standard for Digital Hydrographic Data . Maintained by the IHO, S-57 format is intended for the exchange of 
digital hydrographic data between national hydrographic offices and for its distribution to manufacturers, mariners 
and other data users. It is used for the supply of ENC cells (Electronic Navigational Charts) to ECDIS (Electronic Chart 
Display and Information System). The objects spatial geometry can be of Point, Line or Area geometry, while object 
descriptions are categorized in object classes, organized in specific attributes schemas. To make full use of this 
format, refer to the online object catalog available on www.s-57.com.

MAPublisher imports non-encrypted S-57 data into MAP layers named per S-57 object acronym, of type Area, Line 
or Points. All S-57 Attributes are converted into MAP Attributes.

An Adobe Illustrator template is supplied to automatically style the map after import. The template contains a series 
of MAPublisher stylesheets linking S-57 imported features to nautical symbols and graphic styles (libraries provided 
by Avenza). This representation is non-exhaustive and meant to assist users with limited knowledge of the S-57 
format to interpret the data contents more easily. The S-57 template and the symbols and graphic styles libraries 
can be found in the MAPublisher Helpful Styles & Symbols folder (see Appendix 4).
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Spatial Data Transfer Standard SDTS (*catd.ddf)
Import only
Digital cartographic products of the USGS are available in the Spatial Data Transfer Standard format, and are 
generally distributed over the Internet as a means of promoting the standard. For SDTS import, select the catd file 
(xxxxcatd.ddf ), which is the index file that contains a description of the other files in the SDTS transfer. Individual 

DDF files cannot be imported. Generally all SDTS downloads will contain the CATD file.

TIGER/Line (*.rt1) (*.bw1)
Import only
TIGER is an abbreviation of Topologically Integrated Geographic Encoding and Reference System, and was developed 
by the U.S. Census Bureau. TIGER/Line files are a digital database of geographic features, such as roads, railroads, 
rivers, lakes, political boundaries, census statistical boundaries, etc., that cover the entire United States. The 
database contains information about these features such as their location in latitude and longitude, the name, the 
type of feature, address ranges for most streets, the geographic relationship to other features, and other related 
information. TIGER/Line files are the public product created from the Census Bureau TIGER database of geographic 
formation. TIGER was developed in order to support the mapping and related geographic activities required by the 
census and sample survey programs. More information on the TIGER/Line file format and data product can be found 
on the US Census web page at: http://www.census.gov/geo/www/tiger/

MAPublisher considers the .rt1 or .bw1 file as the TIGER dataset. Even though each county will consist of a series 
of files with a common base name, there may be a number of different extensions. Remember to select the .rt1 or 
.bw1 file when importing TIGER data. 

Basic ESRI ArcSDE Server† (Optional Add-On For MAPublisher 8.2)
Import only
ArcSDE geodatabases are multi-user ESRI spatial databases, that allow users to store, use, and manage their GIS 
data in one of the following commercial database management systems (DBMS): IBM DB2, IBM Informix, Microsoft 
SQL Server, or Oracle. They are available in three levels of flexibility: desktop, workgroup and enterprise.  The Basic 
ESRI ArcSDE Server import option allows users who have a free ESRI desktop application called ArcReader to import 
feature classes from ArcSDE geodatabases, but with some limitations on the selection functions — see chapter 19 
relative to spatial databases for more information.

† Basic ESRI ArcSDE Servers are not supported on MAC OS due to limitations of the related ESRI libraries.files.

ESRI ArcSDE Geodatabase† (Optional Add-On For MAPublisher 8.2)
Import only
ArcSDE geodatabases are multi-user ESRI spatial databases, that allow users to store, use, and manage their GIS 
data in one of the following commercial database management systems (DBMS): IBM DB2, IBM Informix, Microsoft 
SQL Server, or Oracle. They are available in three levels of flexibility: desktop, workgroup and enterprise. The ESRI 
ArcSDE Geodatabase import option allows users who have ArcGIS software and a valid license to import all ArcSDE 
geodatabase types with advanced options for the selection — see chapter 19 relative to spatial databases for more 
information.

† ESRI ArcSDE Geodatabases are not supported on MAC OS due to limitations of the related ESRI libraries.
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ESRI File Geodatabase† (*.gdb) (Optional Add-On For MAPublisher 8.2)
Import only
A File Geodatabase is a native ESRI single-user spatial database. It is a collection of various types of GIS datasets 
held in a file system folder. This is the recommended native data format for ArcGIS — see chapter 19 relative to 
spatial databases for more information. This function requires ArcGIS software and a valid license.

† ESRI File Geodatabases are not supported on MAC OS due to limitations of the related ESRI libraries.

ESRI Personal Geodatabase† (*.mdb) (Optional Add-On For MAPublisher 8.2)
Import only
A Personal Geodatabase is a native ESRI single-user spatial database. This is the original data format for ArcGIS 
geodatabases stored and managed in Microsoft Access data files — see chapter 19 relative to spatial databases for 
more information. This function requires ArcGIS software and a valid license.

† ESRI Personal Geodatabases are not supported on MAC OS due to limitations of the related ESRI libraries.

DATA CONSIDERATIONS

When obtaining GIS data for use with MAPublisher, whether from an online source, commercial vendor, 
government office or from an internal source within your organization, there are a number of important 
considerations to keep in mind.

First and foremost you should always endeavour to obtain data in one of the formats supported by the MAPublisher 
Importers (see above). In cases where the file format native to a particular mapping application is not supported by 
MAPublisher, you can often request the data provider to export a file in one of the supported formats.

When obtaining data you should acquire as much metadata about the files as possible. MAPublisher deals with 
data in the following manner: Unprojected data will be imported by MAPublisher with latitude and longitude map 
anchors, which will therefore range from (x) -180 to 180, (y) -90 to 90. 

If you receive projected data you should be aware of the following. MAPublisher will import projected data 
with a true scale and appropriate map anchors. Unlike unprojected data, these map anchors will not be in lat/
long, but rather in a coordinate system appropriate for the particular projection. For most file formats the name 
of the projection, datum, and units will be recognized by MAPublisher. However if the program cannot find this 
information in the data, and you wish to subsequently reproject your data, you will be required to specify the 
coordinate system.

Additionally, please be aware that MAPublisher is a 2D mapping program. Therefore if you attempt to import 3D 
data with MAPublisher it will be converted to two dimensional artwork by the importers.

NOTE: 	 Data provided in a generic latitude and longitude (unprojected) coordinate system will usually be 
recognized as a WGS 84 (World Geodetic System 1984 - EPSG = 4326) coordinate system by the 
MAPublisher importers.
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The Import filters are the starting point for most users wanting 
to work with GIS map data in Adobe Illustrator. These filters 
are used to import GIS data files, set the initial map scale and 
define your cartographic workspace to start making maps.

MAPublisher 8 supports import of the following GIS data formats:

CAD (*.dxf ) (*.dwg)
Digital Line Graph (*.dlg) (*.opt)
ESRI ArcInfo Generate (*.gen)
ESRI Interchange File (*.e00)
ESRI Shapefile (*.shp)
GML (Simple Features 2.0 +) 
MapInfo Interchange (*.mif / *.mid)
MapInfo Table (*.tab)
MicroStation Design (*.dgn)
Delimited Text Data (*.txt) (*.csv) (*.tsv)
KML/KMZ (*.kml,*kmz)
S-57 (*.000)
Spatial Data Transfer Standard (SDTS) (*.ddf )
TIGER/Line (*.rt1) (*.bw1)
Basic ESRI ArcSDE Server†

ESRI ArcSDE Geodatabase†

ESRI File Geodatabase† (*.gdb)
ESRI Personal Geodatabase† (*.mdb)
See chapter 2 for a description of these formats. 

Two import filters will be discussed in detail in this section:

Simple Import: This filter is designed to provide a fast way 
to import one file, or several files of the same data format and 
coordinate system into Adobe Illustrator.

Advanced Import: This filter provides functionality to 
import a number of files of differing data type and/or 
coordinate systems into Adobe Illustrator.

† Import settings for ESRI geodatabases formats are covered in 
chapter 19.

Importing 
Map Data
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Coordinate System Information - This 
area shows information about the 
coordinate systems. (i.e. Name, 
Type, Envelope, EPSG Code). To 
choose a known source coordinate 
system select it from this list.

Search - Click this button and your 
search results will be populated.

Simple Import 
File > Import Map Data > Simple and MAP Toolbar 

Format - Select the data type you 
wish to import. This drop-down list 

shows the names of all MAPublisher 
supported data types.

Dataset - Displays the directory 
path and filename for the currently 

selected file(s). You can also 
manually type in the dataset 

location here.

Settings - Opens a Settings dialog box 
if the file format requires the input 
of extra parameters, such as for the 
import of DGN, DXF, DWG, E00, GML, 
KML, MIF/MID, Tab and Delimited 
Text Data (see facing page).

Browse - Opens a Data Source 
browser to enable the selection of 
files for import.

Character Encoding - Assign a codec if 
the attribute information held in the 
selected dataset uses a double byte 
character set.

Specify - If the coordinate system of the selected 
file(s) is known, but it was not automatically 
detected by the program, click here. This will open 
the Specify Source Coordinate System dialog box 
(below).

Source Coordinate System - Provides 
a description of the coordinate 

system and units detected in the 
data source.

Specify Source Coordinate System

Coordinate Systems - Choose a 
category appropriate to the 

data to be imported. To view all 
of the coordinate systems select 

*All*. For a list of the last 10 
coordinate systems used, select 

*Recent*.

Search - Specify a text string 
to search the database for 

coordinate systems. Results 
are displayed in the *Search* 

category.

RELATED TOOLS

Accessed via the Specify button.

Clear - Click this button to 
clear the existing source 
coordinate system.

Same as - Check this option in order 
to assign a coordinate system that 

matches that of an existing MAP 
View.

Dataset Coordinate Systems
Automatically opens if multiple datasets have been selected and they do not have a matching coordinate system.

Dataset - List of all the datasets 
selected for import.

Coordinate System - List the coordinate 
system of each individual dataset.
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Hatches - Check this box to read the 
hatch pattern on import .

Group Entities By - Group entities by 
layer name or geometry.

White Lines and Fills - Set the option:
•	  Import as is: import the data true 

to the original colour settings 
contained in the file. 

•	 Change white lines and fills to black: 
import black lines instead of the 

files native white lines.
•	 Create black background: 

incorporate a layer containing a 
black background, to mimic the 

AutoCAD environment.

AutoCAD DXF/DWG Settings

Add to - Add the incoming data file to a 
matching MAP View.

Fit to page based on new MAP View - Create a 
new MAP View for the imported data. 

Existing data and incoming data will be 
treated separately in terms of page scaling 

and position.

Matching MAP View

MAP View list - Select the matching coordinate 
system that you wish to align the incoming 
data to.

Resize MAP View to fit - Check this box to rescale the 
matching data so that both the selected layer and 
the incoming data fit inside the page extents.

Automatically opens if there is already a coordinate system in your document which matches the incoming data.

Delimited Text Data Settings

Latitude/Longitude or X/Y Columns - These two drop-down lists hold the 
names of all the numeric columns in the selected file. Select the 
columns containing the coordinate information.

Use first line as a header - Check this box if the first 
line of the text file contains column headings.

Coordinate Format - Select the coordinate format of the data to be 
imported (e.g. Decimal Degrees, Packed DMS... see chapter 6).

GML validation - GML validation must be 
disabled to import GML files with a missing 

.xsd file or with an invalid attribute structure.

If not disabled, a GML validation error will be 
displayed during the import of these files - as 

seen on the right.

GML (Simple Features 2.0+) Settings

IMPORT SETTINGS
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KML/KMZ Settings
Allow Random Colour Mode -  Enable 
this option to generate random 

colour settings for the data.

Expand Network Links - Enable this 
option to use of network linked 

KML files.

Import KML as Visible Attributes - Enable this option to 
import KML-specific attributes into the MAP Attributes 
panel as visible entities. When this option is disabled, 
these KML attributes are imported but are hidden in the 
MAP Attributes panel

The KML attributes are Description and Address which 
are displayed  in the MAP Attributes panel as 
kmlDescription (object description) and kmlAddress 
(object address). 

Complex Chains - Check the Drop 
box for each component of a 

complex chain to be returned 
as its own feature. Otherwise all 
elements of the complex chain 

will be merged into a single 
linear feature.

Group Elements - Choose how to 
group the elements. If elements 

are grouped by level, it may 
result in a large number of 

output files.

Coordinate Units - Specifies how 
feature coordinates will be 
interpreted and converted.

MicroStation Design Settings

White Lines and Fills - Set the option:
•	  Import as is: import the data true to the original 

colour settings contained in the file. 
•	 Change white lines and fills to black: import black 

lines instead of the files native white lines.
•	 Create black background:. incorporate a layer 

containing a black background, to mimic the 
Microstation environment.

Ignore TIC Layer - Enable not to create a 
_tic_point layer. Disable to create a 

layer holding the registration control 
points. 

ESRI Interchange File Settings

Pen and Brush Patterns - Enable 
this box to view the pen and 

brush pattern values in the 
imported attribute table.

MapInfo TAB and MIF/MID Settings

Basic ESRI ArcSDE Server, ESRI ArcSDE Geodatabase, 
ESRI File Geodatabase and ESRI Personal Geodatabase

Unicode database - Unless specific issues 
importing converted geodatabases, 

keep this option as default. 

Use local to decode - This option might be 
required if the geodatabase was created by 
converting a file in a format not supporting 
unicode (e.g. ESRI shapefile) and if it contains 
non-ASCII characters.

Locale - Specify the locale name (e.g. en-US), 
leave it as 0 to use the locale of the current 
machine.

THESE ARE ADVANCED SETTINGS, PLEASE CONTACT AVENZA SUPPORT AT support@avenza.com FOR ASSISTANCE.

Prepend feature dataset name to layer name 
- Select this option to append feature 

dataset names to layer names. 
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SIMPLE IMPORT FUNCTIONALITY

The Simple Import function provides a fast, uncomplicated method of importing map data into Adobe Illustrator. Its 
purpose is for the map maker to import quickly a single piece of map data, or several files sharing the same format 
and coordinate system.

PREREQUISITES

In order to import data via Simple Import, an Adobe Illustrator document must first be created and setup 
appropriately. For example, a map of the world would fit well into a page with a landscape orientation, whereas a 
map of South America would fit best into a page with a Portrait orientation. 
MAPublisher will interpret the artboard dimensions during the import process, and calculate a map scale for the 
document accordingly. If the document size is changed in the Adobe Illustrator document settings, the scale will 
have to be recalculated using the MAP View Editor (see chapter 4 for more information). 

Some import options are specified in the MAPublisher Preferences Import MAP Data category, such as attribute order, layer 
naming convention or display of extents in the import dialogs. For a full description, please refer to chapter 1 on 
MAPublisher Preferences.

USING SIMPLE IMPORT

The MAPublisher Simple Import function is accessed from the Adobe Illustrator menu File > Import Map Data > 
Simple Import or from the MAPublisher toolbar button .

Overview
The dialog box itself is split into two sections. The upper section allows to choose a file format, select the file to 
import, and enter any additional settings that may be required. The lower section displays the coordinate system of 
the selected file (if available) or allows to specify it manually if the file doesn't store this information.

Adding Files
First specify the format of the file to be imported. Set the Format drop-down list as <Auto detect format> or to a 
specific format. With the <Auto detect format> option, all supported GIS files will be displayed in the browser. 
Choosing the required format directly is recommended to ease the navigation.

Once a format has been selected, click the Browse button to select the file(s) to be imported and then click Open. 
Alternatively type in the full path of the file(s) in the Dataset text box. Only files in a same format and sharing the 
same coordinate system can be imported at once with the MAPublisher Simpler Import dialog box.

NOTE:	 The import of multiple of Delimited Text files is not supported. 
NOTE:	 Data provided in a generic latitude and longitude (unprojected) coordinate system will usually be 

recognized as a WGS 84 (World Geodetic System 1984 EPSG = 4326) coordinate system by the MAPublisher 
importers.
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Source Coordinate System
Once the Dataset text box has been populated with a valid path, the program will read the file(s) to determine if a 
valid coordinate system can be found, and display this in the Source Coordinate System section.

If the program returns the message [No Coordinate System Specified] for the coordinate system, click the Specify 
button to specify it. In the Specify Source Coordinate System dialog box, coordinate systems are separated into categories 
(geodetic or projected) to ease the process of choosing a coordinate system: under the Coordinate System category 
*All* will list all the coordinate systems in the database. For an overview of Geodetic and Projected systems and 
Datums see appendix A2. To view the parameters of a certain coordinate system, click the Info button. 

Character Encoding
Extended and international character sets are supported as attributes on import. To assign a character codec 
suitable for your selected dataset, choose the appropriate value from the list box.

Format Specific Settings
Certain file formats offer additional configuration parameters which can be accessed by clicking the Settings button. 
These file formats are ESRI Interchange File, ESRI Geodatabases (ArcSDE, File and Personal), CAD DWG/DXF, MicroStation DGN, MapInfo 
MIF/MID, MapInfo TAB, KML/KMZ, Delimited Text Data* and GML. After selectin a file, if the format accepts additional settings 
the Settings button will be enabled. See the import settings at the beginning of this chapter for an overview of the 
meanings of these options.
*Additional Settings are mandatory only for importing Delimited Text Data.

Delimited Text Data Settings
MAPublisher also allows for the import of delimited text files as point data provided they contain coordinate values.  
MAPublisher supports the following delimiters between data values: comma, return, end-of-line and tab.

To import delimited text data, first specify the Format: Projected Units, Decimal Degrees, Delimited Degrees Minutes 
Seconds, Degrees.Minutes, Degrees.MinutesSeconds, Packed DMS with decimals and Packed DMS (see chapter 6, for 
more details). In the Coordinate Columns, specify the fields in the source file that contains the coordinate information. 
The caption of the fields display Longitude and Latitude or X and Y, depending on the selected format.  If the first line 
of the text file contains columns headings, check the Use first line as a header option, although MAPublisher generally 
detects it automatically. f the file does not appear to contain column headers, MAPublisher will assign the default 
headers Column1, Column2 to the attribute columns on import.

Importing Data
Once the files are selected and settings specified,  click OK to start the import process.  If the Adobe Illustrator 
document contains a MAP View with a coordinate system matching the incoming data, the Matching MAP View dialog 
box will open with the following options:
•	 Add to: choose the MAP View from the drop-down list where to add the incoming data. Check the option Resize MAP 

View to fit to rescale all the data (existing and incoming) to fit on the artboard. If this option is not checked, the 
imported data may fall outside the page extents

•	 Fit to page based on new MAP View: the incoming data will be treated separately from the matching data, as if it was 
the first import. The incoming data will overlap with the existing data, use the MAP View Editor to rescale and 
move the data on the page (see chapter 4 on MAP Views). 

NOTE:	 Importing ESRI Geodatabases require further settings, refer to chapter 19 for a detailed description.
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RESULTS

The data is imported as individual Adobe Illustrator layers with appropriate feature type matching the original 
source data type. Layers are named based on the file name or on the layer name in the source file. By default, 
the appropriate feature type extension is appended (e.g. name_area), and  a layer name is already present in the 
document, it appends a number (e.g.  name_area 1) — but this may be disabled in the MAPublisher Preferences, 
Import MAP Data property sheet. The layers are automatically placed as sub-features of a MAP View (existing or new) 
that contains the geospatial, scaling and positioning information. 

NOTE:	 When importing data exceeding the allowable 32,000 points per path in Adobe Illustrator, MAPublisher 
automatically simplifies the imported object and shows the following warning message: 

	 The simplification algorithm compares points in a line or polygon in groups of three.  When the shortest 
segment is found, the center point is removed, and the total segment distances are recalculated.  This 
removal process continues until the maximum allowable number of points is reached.
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Advanced Import 
File > Import Map Data > Advanced and MAP Toolbar 

Add - Allows the selection of 
files for import by opening the 
Advanced Import Data 
Source function (see below).

Remove - Removes selected 
files from the list.

Edit - Allows the edit of the 
selected file by re-opening 
the Simple Import Data 
Source function (see below).

Format - Select the data type you 
wish to import. This drop-down list 

shows all MAPublisher supported 
data types.

Dataset - Displays the directory 
path and filename for the currently 

selected file(s). You can also 
manually type in the dataset 

location here.

Source Coordinate System - This section 
allows the manual selection of 

the coordinate system if this 
information is not held in the data 

source. 

Same as - Check this option in order 
to assign a coordinate system that 

matches that of an existing MAP 
View.

Info - Click this button to view the 
parameters of a selected coordinate 

system.

Advanced Import Data Source

IMPORT SETTINGS
See the Simple Import various Import Settings dialog boxes and options.

Settings - Opens Settings dialog box 
for file formats that requires the 
input of extra parameters, such as 
for the import of DGN, DXF, DWG, 
E00, GML, KML, MIF/MID, Tab and 
Delimited Text Data (see chapter 2).

Browse - Opens a Data Source 
browser to enable the selection of 
files for import.

Character Encoding - Assign a codec 
if the attribute information held in 
the selected dataset uses a double 
byte character set.

Clear - Click this button to clear the 
existing parameters of the source 
coordinate system.

Specify - Click this button to open 
the Specify Source Coordinate 
System tool (see Appendix 
2), enabling you to search for 
coordinate systems by specifying a 
text string. Results are displayed in 
the *Search* category.

Destination MAP View

New based on - Imports all of the 
files to one of the coordinate 

systems in the File List.

Use existing - Allows to import 
all of the files in a coordinate 

system that already exists in a 
MAP View in the document.

Auto scale - If multiple files are 
present in the File List, and 

New Based On or Use Existing 
is selected, check this box to 

ensure the imported artwork 
fits inside the page extents.

RELATED TOOLS

Accessed via the Add or Edit button.

Create new - Allows to import all of 
the files in a new coordinate system. 
Click the Editor button to open the 
MAP View Editor (see chapter 4) .

Coordinate System- coordinate 
system of the file.

Data Source - Map file(s) to be 
imported (full path or just 
file name depending on 
MAPublisher Preferences - see 
chapter 1).

Features - Number of objects to 
be imported

(if enabled in Import MAP Data 
MApublisher Preferences).
Extents - Displays the lower 
left (LL) and upper right 
(UR) coordinates (XY) of the 
dataset extents.

File List - This is a table where 
all files selected for import 

are listed.

Details - Displays details of currently 
selected file: Coordinate System, 
Unit, Page Anchors, Scale, 
MapAnchors and Rotation.
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ADVANCED IMPORT FUNCTIONALITY

Advanced Import provides an alternative method of importing map data into Adobe Illustrator. This function can 
import files in multiple formats and coordinate systems. All files flagged for import are displayed in the dialog 
box with information relative to their coordinate system. All imported files are reprojected to match a selected 
coordinate system. 

NOTE:	 Advanced Import is recommended when importing data that will require a coordinate system 
transformation that implies redrawing and path divisions (e.g. world data reprojected from European to 
North American aspect). Applying a coordinate system transformation during Advanced Import allows 
MAPublisher to split paths during transformation, which is not possible at a later stage. Divided pathas are 
grouped as compound paths.

PREREQUISITES

In order to import data via Simple Import, an Adobe Illustrator document must first be created and setup 
appropriately. Please refer to the Simple Import Prerequisites section in this chapter.

USING ADVANCED IMPORT

The  MAPublisher Advanced Import is accessed from the Adobe Illustrator menu File > Import MAP Data > Advanced 
Import or by clicking the MAPublisher Toolbar button  or by using the keyboard shortcut, Alt+Shift+Ctrl+A. 

Dialog Box Overview
The top part of the Advanced Import dialog box provides a list of the selected files, their coordinate system 
information and the number of features they contain. The bottom part of the dialog box refers to the Destination 
MAP View settings.

The Add and Edit buttons open a dialog box similar to the Simple Import dialog box. Please refer to the previous 
section for information on the Character Encoding, Format Specific Settings and Delimited Text Data Settings.

NOTE: 	 The dialog box displays the file name or the full path of the selected files depending on the settings 
specified in the MAPublisher Preferences for Import MAP Data (see chapter 1). Users can also choose to 
display the geographical extents of the file.

Adding Files
Click the Add button to select one or more files that share the same format and coordinate system. The Add dialog 
box is similar to the Simple Import dialog box, please refer to previous section for more information. Click OK to add 
the files to the Advanced Import list.

To import more files in a different format or coordinate system, use the Add dialog box again, as often as necessary.

Advanced Import File List
All selected files are listed in the Advanced Import dialog box. The list contains two columns, for each file, the 
coordinate system and full access path are displayed.
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Click on a row of the list to select a file. Then, click Remove to remove the file or click Edit to change the import 
parameters. The Edit dialog box provides the same options as the Add dialog box, users can modify the access path, 
settings or source coordinate system.

NOTE: 	 It is not possible to import multiple files with a mix of unknown and known coordinate systems therefore 
the unknown coordinate systems will need to be specified.

Destination MAP view
Although the Advanced Import allows to import files with multiple source coordinate systems, they have to be 
imported into a single coordinate system. This information is stored in the Destination MAP View section (for more 
information on MAP Views, please refer to chapter 4).

Users have three options to select the coordinate system of the Destination MAP View.

•	 New based on option: choose the coordinate system of one of the files selected for import. 
•	 Use existing option: if the Adobe Illustrator document already contains map data, choose the MAP View with the 

desired coordinate system from the list of existing MAP Views in the document

With these two options, check the option Resize MAP View to fit to rescale all the data (existing and incoming) to fit on 
the artboard. If this option is not checked, the imported data may fall outside the page extents

•	 Create new option: specify the parameter for a new MAP View. Click the Editor button to open the MAP View Editor. 
In the Destination Source Coordinate system section, click the Specify button to select a coordinate system from a 
large list of existing system or to create a custom one. The MAP View Editor is explained in depth in chapter 4, in 
brief it allows for the edition of the scale, the position of the data on the page and rotation. 

RESULTS

Once the files have been selected and properly set up, click OK to start the import process.

The data is imported as individual Adobe Illustrator layers with appropriate feature type matching the original 
source data type. Layers are named based on the file name or on the layer name in the source file. By default, 
the appropriate feature type extension is appended (e.g. name_area), and  a layer name is already present in the 
document, it appends a number (e.g.  name_area 1) — but this may be disabled in the MAPublisher Preferences, 
Import MAP Data property sheet. The layers are automatically placed as sub-features of a MAP View (existing or new) 
that contains the geospatial, scaling and positioning information. 
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The MAP Views panel is the hub from which many additional 
MAPublisher features may be accessed. The panel itself will 
display the Adobe Illustrator layers that exist in the current 
document as sub layers of distinct coordinate systems, or 
MAP Views. With this tool, you can specify coordinate systems 
for map layers, transform coordinate systems, edit scale and 
data placement, merge layers, and export to GIS formats.

During a standard Import process, an Adobe Illustrator 
layer is created for each feature type automatically, and is 
automatically appended with a _point, _line, _area, or _text 
suffix in the Adobe Illustrator Layers panel. Certain file types 
generate multiple layers, such as the levels found in DGN or 
DXF, but they are similarly split up by feature type. A single 
import of such files produces a single MAPublisher View as 
an import can only take place in a single coordinate system. 
Custom MAP Views may be created in order to georeference 
existing Adobe Illustrator artwork.

The following pages deal with the creation and management 
of MAP Views, specifying and reprojecting a coordinate system, 
editing scale and data placement on the page, merging Adobe 
Illustrator layers, and exporting to GIS formats.

The topics covered in this section are as follows:
Georeferencing
MAP Views Panel
MAP View Editor
Import MAP View
Export
MAP Location Tool

MAP Views and 
Georeferencing
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Georeferencing a non-georeferenced Adobe Illustrator file in MAPublisher can be separated into three steps:

1.	 A Source Coordinate System must be specified. The coordinate system gives a method to represent geographic points 
in relation to a world origin (these are also called point map, geographic, real world or spatial coordinates).

2.	 MAPublisher bases its georeferencing on a tie point within an Adobe Illustrator document (artboard). The 
relationship between Page Anchor and Map Anchor is defined below.

3.	 A Scale is necessary to translate measurements on the ground to measurements on the artboard.

During the import process, the software reads the coordinate system settings from the input file and calculates a 
scale to best fit the map data on the page. The software treats the point at (0,0) in the document (Page Anchor) as 
being coincident to the lower left corner of the data in real world coordinates (Map Anchor). From this point on these 
two points are dynamically linked. MAPublisher uses this anchor point in subsequent data transformations, such as 
rescaling and transforming, but also in the creation of grids and to maintain georeferencing on export. 

If a coordinate system has not been defined in the source data, the Source Coordinate System has to be manually set 
in MAPublisher, as well as the Scale. One should not estimate this information, it is usually provided as metadata 
by data vendors or indicated as text on the original map. Also, anchors have to be specified manually: Map Anchor 
information can be entered in any coordinate system  unit (for example latitude and longitude in degree), Page 
Anchor are entered in the document units.

The most common way to set up an Adobe Illustrator page is to set the page origin (0,0) to coincide with the lower 
left corner of the map extents. If this information is not known, any point on the map can be used as long as its 
geographic location is known (e.g. a building or graticule grids on a scanned map—this information is usually given 
by the data provider if not obvious on the map itself ).  The position in page coordinates for the same point is found 
using the Adobe Illustrator Info panel.

Again, once the relationship between the real world coordinates and the page coordinates is established, 
MAPublisher will be able to perform coordinate system transformations, rescaling, plotting points etc... 

For further information, please refer to the appendices. See appendix A1 General Tips on Georeferencing an Adobe 
Illustrator file. Appendix A2 provides general information on the MAPublisher coordinate systems as well as 
customizing options.

Georeferencing 

Ymap

Xmap

WORLD
(0,0)

Illustration of page and map anchors

Page
(0,0)

ypage

xpage
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MAP Views Panel 
Window> MAPublisher > MAP Views and MAP Toolbar 

MAP Views - List of the distinct 
configurations for geospatial 

parameters

New MAP View - Create a new MAP View and specify its name and coordinate information.

Duplicate MAP View - Create a duplicate of the currently selected MAP View.

Edit MAP View - Open the MAP View Editor to edit the name and coordinate system of the currently selected 
MAP View.

Delete Selection - Delete the currently selected MAP View or MAP Layer provided it does not contain any 
Adobe Illustrator layers.

Add MAP Layer - Create a new MAP Layer through Add MAP Layer dialog box.

Specify Anchors - For manually establishing the tie-in point between Map and Page Anchors (should only be 
used for new MAP Views or for the correction of georeferencing errors).

Import Coordinate System From File - Imports a coordinate system from different file types including, WKT 
definitions (*.wkt), MAP files (*.map), ESRI projection files (*.prj), MapInfo TAB files (*.tab). The imported 
coordinate system overwrites the source coordinate system of the selected MAP View (see appendix A2).
 
Export Coordinate System to File - Exports the selected MAP View coordinate system to a WKT definition (*.wkt) 
(see appendix A2).

Import MAP View - Import MAP Views and associated MAP Layers from other open documents.

Export - Enable the export of the selected MAP View or MAP Layer to various GIS formats.

Merge Layers - Combine two or more MAP Layers, as long as their attribute structures match. Ctrl key 
(Windows) or the Command key (Mac) to select the layers in the MAP Views panel.

Layer Name Search and Replace - Search for text within layer names and specify an alternative.  Useful for multi-
layer imports.

Load Custom Coordinate Systems - Load external coordinate systems in .xml format (see appendix A2).

Edit Custom Coordinate Systems - Open the custom coordinate system editor to create new coordinate systems 
and edit the parameters of existing ones in the data source (see appendix A2).

Preferences - Opens MAPublisher Preferences on the MAP Views Panel property sheet (see chapter 1).

MAP Layers - An alphabetical 
list of the layers that comprise 

each MAP View, symbolized by 
feature type.

Non-MAP layers - List the Adobe 
Illustrator layers that are not part 

of a specified MAP View, and 
do not contain georeferencing 

information.

New MAP View button - Create a 
new MAP View and specify its 
name and coordinate system 
information. Opens the MAP View 
Editor.

Delete selection button - Delete the 
currently selected MAP Layer or 
MAP View (provided it does not 
contain any map layers).

Lock button - Click this box to lock 
or unlock the Layer (mirrored 

in the Adobe Illustrator Layers 
panel).

Switch MAP View - Click this button 
to switch the selected layer from 
one MAP view to another. Remove 
GIS data moves the selected layer 
to [Non-MAP layers] section, 
discarding the geographic 
information and attributes in the 
process. 

Export MAP View  / MAP Layer  - 
Export the selected MAP View or 

MAP Layer to various GIS formats.

MAP VIEWS PANEL OPTIONS MENU

Zoom To MAP View  / MAP Layer  - 
Zoom to the selected MAP View or 
MAP Layer data extent.

Add MAP Layer - Create a new MAP 
layer ( in both the MAP Views 
panel and the Adobe Illustrator 
Layers panel). Opens the Add MAP 
Layer dialog box.
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Missing Coordinate System
Automatically opens when dragging a MAP Layer to an alternate MAP View, and 
either the source or destination MAP View has an unspecified coordinate system.

Select custom coordinate system - Choose 
this option and then click the Select 

button to specify the coordinate 
system of the named MAP View via the 
Select Coordinate System dialog box 

(see Appendix 2). Once selected, the 
coordinate system will be displayed 

below it.

Same as - Choose this option in 
order to assign a coordinate 
system to the named MAP View 
that matches that of an existing 
MAP View. The coordinate 
system of the selected MAP 
View will be displayed below.

Layer Name Search and Replace

Find what - Type in the 
variable contained in the 
current layer names on 
which you wish to search.

Replace with - Type in the 
variable you wish to change 

the layer names to.

Define Layer
Automatically opens when dragging a Non-MAP layer into a specified MAP View.

Apply to all - When multiple layers are 
switched at once to a specified MAP View, 
check this box to apply the same feature 
type to all.

RELATED TOOLS

Feature Type -Select the type of feature that 
exists on the layer being dragged. This 

drop-down list presents a choice of Area, 
Line, Point, Text or Legend layer types.

Base Attribute Schema on - Check this option to 
copy the attribute schema from the existing 
MAP Layer selected in the drop-down list

Plot Centroids, Feature Text Label, MAP 
Tagger Tool and MAP LabelPro tools make use 
of this option, see specific chapters. 

Add MAP Layer

Specify Anchors
Should only be accessed when creating a new MAP View, or 

correcting inaccurate georeferencing information. 
Caution: editing anchors can damage the accuracy of the data.

Map Anchors - The location 
of the Map Anchors in 

the units of the selected 
coordinate system. 

Page Anchors - The location 
of the Page Anchors in 
the units of the current 

document (see File > 
Document Setup).

Coordinate system - Specify 
the coordinate system in 
which the anchor position 
is entered. 
Use the current MAP View's 
coordinate system, or 
specify a different one (by 
default, the geodetic system 
base of the projection 
or WGS84, in latitude-
longitude format). Click 
the Select button to open 
the Select Coordinate System 
dialog box and choose any 
coordinate system

Feature Type -Select the type of feature that 
exists on the layer being dragged. This 

drop-down list presents a choice of Area, 
Line, Point, Text or Legend layer types.

Base Attribute Schema on - Check this option to 
copy the attribute schema from the existing 

MAP Layer selected in the drop-down list.

Plot Centroids, Feature Text Label, MAP 
Tagger Tool and MAP LabelPro tools make use 
of this option, see specific chapters. 

Layer name -Type the name of the new layer 
(it will appear in both MAP Views and 

Adobe Illustrator Layers panels).
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OVERVIEW

The MAP Views panel displays a list of all the Adobe Illustrator layers in the current document and all MAP Views—
defined configurations for geospatial parameters (coordinate system, anchors, map scale and rotation). Every 
MAP Layer is shown in this panel as belonging to a particular MAP View. Adobe Illustrator layers that do not have 
georeferencing information (e.g. layers existing in the document prior to import) are placed in the [Non-MAP layers] 
category.

Categories are symbolized in the following manner:

 MAP View 		  Contains  layers with georeferencing and attribute information.

 [Non-MAP layers] 	 Contains layers with no georeferencing or attribute information. 

Each layer that belongs to a MAP View is symbolized in MAPublisher panels and dialog boxes with an icon 
identifying its feature type:

 Area layer	 (e.g. county boundaries, urban areas, country outlines etc.)

 Line layer	 (e.g. rivers, roads, railways etc.)

 Point layer	 (e.g. town and city symbols, railway stations etc.)

 Text layer	 (e.g. text labels)

 Legend layer	 (for MAPublisher Legend items: North Arrows, Scale Bars, Grids)

NOTE:	 Layers are sorted alphabetically or per data type, as specified in the MAP Views category in the MAPublisher 
Preferences (see chapter 1).

FUNCTIONALITY

MAP Views are designed to provide an easy method of accessing settings for specifying and transforming 
coordinate systems, for editing scale and data placement on the page and for exporting to GIS formats. The 
MAP Views panel allows for merging Adobe Illustrator layers, georeferencing existing Adobe Illustrator artwork, 
changing multiple layer names, and reprojecting data on the fly.

USING THE MAP VIEWS PANEL

The MAP View Editor is discussed in detail later in this section. 

Creating New MAP Views
To create a new MAP View click New MAP View under the panel options menu or click the New button  at the 
base of the panel. This will automatically open the MAP View Editor, which will be discussed in the MAP View Editor 
section, allowing to set up a coordinate system, and enter values for scale, rotation, and page anchors. After 
creating a new MAP View, the Specify Anchors item from the MAP Views panel options menu must be used to define 
the tie-in point between Map Anchors and Page Anchors.
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Duplicating And Deleting MAP Views
MAP Views can be duplicated. For example, to create inset maps make a duplicate and drag MAP Layers into the 
new MAP View. Then use the MAP View Editor to edit the placement, scale or coordinate system of the duplicate.

MAP Views that do not contain any MAP layers can be deleted. Both of these tools are accessed in the panel options 
menu of the MAP Views panel. You can also delete a MAP View by clicking the Delete button at the base of the panel. 
Note that these functions act on MAP Views only, and not MAP Layers.

Creating New MAP Layers 
New MAP Layers are necessary in order to digitize geospatial data or generate artwork using MAPublisher tools 
(plot points, labels, legends, grids, scale bars and north arrows).  Click the Add MAP Layer button   to create 
a new Adobe Illustrator layer, placed directly into the selected MAP View. Specify the appropriate Layer name and 
Feature type for the new layer. 

To generate artwork using MAPublisher tools, specify the Feature Type as follow:

	 for Text items. Feature Text Label , MAP Tagger (chapter 10) and MAPublisher LabelPro (chapter 18) require a Text layer 
as destination. 

	 for Point symbols. Point Plot (see chapter 6) will not function without a Point layer selected.

	 for Legend items. Grids and Graticules (see chapter 13), Scale Bars and North Arrows (see chapter 14) must be placed 
on Legend layers.

NOTE:	 The Advanced option Base attribute schema on allows to copy the attribute schema from an existing MAP 
Layer (see chapter 5 for details). This option is required to enable the copy of attributes from source to 
destination layers in the MAPublisher labelling tools and Plot Centroids function. See respective chapters.

Reprojecting MAP Layers via MAP Views Panel
The MAP Views panel can be used to move Adobe Illustrator layers from one MAP View to another, enabling to 
reproject vector art* quickly. Layers can be moved via drag-and-drop or with the new Switch MAP View button .
* Raster imagery cannot be reprojected with MAPublisher.

For example, when importing two data layers, one in UTM projection and the other in latitude/longitude, 
MAPublisher will produce two distinct MAP Views, each holding the associated MAP Layer. To reproject the layer 
which is in UTM into Lat/Long, drag it from the UTM MAP View and drop it into the Lat/Long MAP View. MAPublisher 
will automatically reproject and scale artwork on the layer to match the destination MAP View.
When reprojecting in this manner, and either the origin or destination MAP View does not contain a defined 
coordinate system, the Missing Coordinate System dialog box is displayed offering the  two options:

1.	�Specify custom coordinate system to specify the projection of the named MAP View, via the Source Coordinate 
System function.

2.	�Same as to specify the coordinate system of the named MAP View by choosing a coordinate system which already 
exists in a MAP View in the document.

NOTE: 	 Many transformations will inherently cause the loss of precision by the very nature of the complex 
mathematical calculations that must be performed. Additionally there are differences in precision between 
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MAPublisher and Adobe Illustrator. MAPublisher calculations are in 64-bit for accuracy, but the results still 
must be stored as 32-bit for Adobe Illustrator. As a result, please be aware that some precision may be lost 
if layers are dragged repeatedly from one coordinate system to another. When determining a coordinate 
system to use via the drag method, we strongly recommend to use Edit > Undo to revert coordinate 
systems until the appropriate system is found. 

Zoom to MAP View  / Zoom to MAP Layer 
Use these functions to zoom to the selected MAP View  or MAP Layer  in the MAP Views panel. This is 
particularly useful for files containing a large number of layers.

Assigning Georeferencing Information To Adobe Illustrator Layers
Existing Adobe Illustrator layers that do not contain georeferencing or attribute information also appear in this 
panel under the default MAP View entitled Non-MAP layers. Such layers can be moved into a specified MAP View with 
a matching geospatial configuration (coordinate system, scale, position on the page, etc.).

NOTE:	 Moving a non-MAP layer to a MAP View does not imply any transformation (the artwork is not redrawn). 
Users must ensure that the art on the non-MAP layer is positioned and scaled properly on the page with 
regard to the MAP View definition.

Moving a non-MAP layer into a specified MAP View prompts the Define Layer dialog box to specify the feature type of 
the layer. Multiple layers may be selected and moved together to a specified MAP View. Use the Apply to all option to 
assign the same feature type to all layers being moved. The Advanced option Base attribute schema on allows to copy 
the attribute schema from an existing MAP Layer (see chapter 5 for details).

Specify Anchors
The Specify Anchors function should only be accessed when referencing a new MAP View (for example in the 
process of georeferencing an Adobe Illustrator file, see appendix A1) or to correct an inaccurate referencing. 

The MAP Anchors are entered in the unit of the selected coordinate system. MAP Anchors coordinates must be known 
from information written on the map (e.g. graticules crossing) or from external source (metadata, survey points 
or other). When the Use Current MAP View's coordinate system option is toggled, MAP Anchors coordinate values are 
entered in the current MAP units of the coordinate system of the MAP View. When the Use: XXXX option is toggled, the 
Select button becomes enabled. Clicking the Select button opens the Select Coordinate System dialog box. Choose any 
coordinate system, the coordinates values entered will be in the unit (Point Style) for this coordinate system. When 
the selected or default coordinate system is projected, X and Y coordinates are entered in the unit (Point Style) of 
the coordinate system (e.g. metre, kilometre, feet). When the selected or default coordinate system is Geodetic, Lat 
and Long coordinates are entered in degrees. 

NOTE:	 When the current MAP View coordinate system is a projected system, the default system specified in 
Use:XXXX is set to the geodetic system base for the projection. For example, if the MAP View's system is the 
US State Plane NAD83 / Colorado North (ftUS), the default alternative system is set to NAD83 (to enter the 
latitude/longitude coordinates in degrees).

The Page Anchors are entered in the current unit of the document. This unit can be changed through the Adobe 
Illustrator menu File > Document Setup. Positions of points on the document in page coordinates are determined 
using the Adobe Illustrator Info panel (menu Window > Info).
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Layer Name Search and Replace 
The MAP Views options list also provides a Search and Replace function, enabling the quick change of names of 
multiple Adobe Illustrator layers. For example MicroStation Design or CAD imports may contain a large number of 
similar named layers. This option allows to quickly change the names of all layers that contain a specified character 
string. 

Merge Layers
If several layers in a same MAP View share the same attribute schema and data type, they can be merged into a 
single layer using the Merge Layers function. For example, if a dataset has been split in separated files and imported 
as multiple layers in Adobe Illustrator, this function is used to re-combine the dataset into a single layer.

To select multiple layers, press the Ctrl or Shift keys (Windows) or the Command or Shift keys (Mac) and click the layers 
in the MAP Views panel, then click Merge Layers in the panel options menu. The layers are merged in a single layer 
holding the data and its associated attributes.

Export MAP Views  and MAP Layers 

The MAP Views panel offers the option to export a single MAP View or a single MAP Layer  to a 
multitude of GIS formats. This function is explained later in this chapter.

Removing MAPublisher Information
At the end of the project cycle, it may be useful to permanently remove all georeferencing and attribute 
information in the current document. This can be accomplished by switching all MAP Layer(s) to the [Non-MAP 
layers] category in the MAP Views panel via drag and drop or clicking the Switch Map View button  and the Remove 
GIS data... option. 

NOTE:	 This function should only be used as a final step as all attributes and georeferencing will be removed 
leaving a standard Adobe Illustrator file devoid of all map information. Be sure to save a copy of the file 
before performing this operation.
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FUNCTIONALITY

The MAP View Editor displays and controls the geospatial parameters of the MAP View (coordinate system and scale 
on the page), the position of the data extents on the page (alignment and rotation) and allows to edit the MAP View 
name. A preview pane shows and allows the move the current MAP View relative to the artboard and to the other 
MAP Views in the document.

The MAP View Editor is also the place where a coordinate system transformation are performed. Transformations 
affect the data geometry on the page because shapes and points are redrawn to match the new coordinate system 
properties. 

USING THE MAP VIEW EDITOR

The MAP View Editor can be accessed as part of the Advanced Import dialog box or from the MAP Views panel:
•	 Advanced Import: click the Create new option in the Destination MAP View section, and then click the Editor button 

to open the MAP View Editor. 
•	 MAP Views panel: select a MAP View, and then select Edit under the Options arrow in the upper right corner of 

the panel. Or double-click the MAP View name in the MAP Views panel.

MAP View Editor 
MAP Views panel > Edit MAP View / New MAP View, 

Advanced Import > Create New > Editor

Same as - Check this option to 
transform to a coordinate system 
used by another MAP View in the 

document.

Specify Datum Shift - Change the 
datum shift for the transformation.

Perform Coordinate System 
Transformation - Enable this option 

to transform the data to a new 
coordinate system.

Specify Destination Coordinate System - 
Open the Specify Destination 

Coordinate system dialog box to select 
a coordinate system .

Preview Pane - Displays the data 
extents of the MAP View:

White rectangle - Artboard extents.
Green rectangle - Data extents of the 

current MAP View.

Crosshair - Location of the current 
Map and Page Anchors.

Show Anchors - Display or hide the 
Map and Page Anchors.

Name - Name of the MAP View. 

Zoom buttons - zoom in/out or fit to 
the extents of the map view.

Previews - Select the preview 
options: None, Coloured Boxes, 
Thumbnails, Thumbnails and Boxes

 Page Alignement -  Affects the position 
of the Page Anchors:
•	  LL X, LL Y - Position of the lower left 

corner of the data in document 
units.

•	 Alignment Control - Click a position 
on the grid to control the 
alignment of the data extent 
relative to the page (e.g. center 
middle, upper right...).

Scale - Editable of the MAP View 
scale relative to the page. Click Auto 

Scale to fit the data extents to the 
page extents.

Angle - Editable rotation angle of 
the MAP View. Click  to reset to 
0, click  to orient the MAP View 

north up. 

Info - View the parameters of a 
selected coordinate system.

Specify - Open the Specify Source 
Coordinate System dialog box to select 
a new source coordinate system. 
To be used only if the source 
coordinate system is undefined or 
is not matching the data.
To apply a new coordinate system 
to a MAP View, use Perform Coordinate 
System Transformation.

Clear - Remove all references to a 
coordinate system

Source Coordinate System - Displays 
the current coordinate system 
assigned to the MAP View.
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Preview Pane 
By default, the Preview Pane displays the data extents with a green rectangle and the MAP View orientation with an 
arrow pointing north. The Previews option allows to change the preview to None (default green rectangle), Coloured 
boxes (previews up to 10 MAP views, symbolized with rectangles of different colours as specified in the MAP View 
Editor MAPublisher Preferences, see chapter 1), Thumbnails (preview a reduced image of the document contents, 
including all MAP views) and Thumbnails and boxes (shows both thumbnails and coloured boxes of up to 10 MAP 
views in the document). 
NOTE:	 Due to Adobe Illustrator rasterization limitations, thumbnails cannot be displayed when a very large MAP 

View is present in a file.

To move the data on the page, click inside the green rectangle and drag to a more suitable position within the 
page. Use the Zoom In, Zoom Out and Center buttons to set the magnification of the preview. To move the page within 
the Preview Pane, click outside the MAP View extent and drag to move the page.

MAP View Name
The current name of the MAP View is listed in the Name text box, which is editable. MAP Views are ordered 
alphabetically in the MAP Views panel, so changing a MAP View name may change its position in the panel.

Page Alignment
During the import process, MAPublisher sets the page and map anchors so that the page origin (0,0) to coincide 
with the lower left corner of the map extents.  The Page Alignment settings allow to move precisely the data on the 
page. In the LL X/ LL Y fields, users can edit the position of the lower left corner of the data extent in document unit. 
When the values are changed, all the data contained in the MAP View is shifted accordingly. Alternatively, the 
alignment grid provides pre-set arrangements for position of the map extents relative to the page (center-middle, 
lower-left, upper-right, etc.). A click on one of the grid location aligns the map data accordingly.

Editing the lower left corner position does not affect data integrity. It simply means that the data is shifted on the 
page but the corresponding real world coordinates remain unchanged.

NOTE: 	 The Page Anchor does not always coincide with the lower left corner of the map extent. When manually 
registering an Adobe document, users can also enter a specific position using the MAP Views panel options 
menu Specify Anchors (see first section of this chapter). 

Scale
The scale of the current MAP View is shown in the Scale text box. For MAP Views in projected coordinate system, 
the scale value is a real world scale (exact ratio linear distance on the page over distance on the ground). For MAP 
Views in geodetic coordinate system (i.e. Lat/Long format in angular unit), the scale value is approximated using 
the common formula 1°= 111.353m (metres per degree at the equator). This is not an accurate number because the 
formula is only valid at the equator, but it is more intuitive for cartographic considerations.

The scale can be edited manually (typing in a precise value) or by using the Up and Down arrows to increase or 
decrease the scale by 10% of the starting value. The Auto Scale button applies the scale to fit the data to the page 
extent and centers the map on the page.
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Rotation
A rotation figure can be applied or edited by specifying an angle in the entry field, or by using the arrow buttons. 
Notice that changes to rotation will be automatically previewed in the Preview Pane with the green rectangle and 
arrow depicting the new orientation of the data. Click  button to reset to the angle to 0. Click  button to 
orient the MAP View True North up (True North is calculated at the center of the data extents).

Set Source Coordinate System
In most cases, the MAP View source coordinate system is initially assigned during the import process if the imported 
data file contains such an information (see chapter 3). To view the properties of the source coordinate system, click 
the info button.

If no coordinate system is recognized during the import, the resulting MAP View source coordinate system is set to 
[No Coordinate System Specified]. In order to rescale, rotate or transform the MAP View, a coordinate system must be 
specified. To do so, click the Specify button to open the Specify Source Coordinate System dialog box (explained below).

In some rare cases, the source coordinate system might have been wrongly assigned during the import process 
(due to a wrong manual selection or file issue). In this case, users may specify another coordinate system by clicking 
the Specify button. This should be used with caution because data integrity may be lost if the current coordinate 
system is overwritten by mistake. Changing the source coordinate system does not affect the data geometry on the 
page. To reproject a MAP View to a new coordinate system, use Perform Coordinate System Transformation.

Coordinate System Transformation
To reproject a MAP View to another coordinate system using the MAP View Editor, click the Perform Coordinate System 
Transformation check box (the MAP View must contain data for this option to be available). Users have two options to 
select the destination coordinate system:  
•	 To select a coordinate system from the MAPublisher database, click the Specify button in the Perform Coordinate 

System Transformation frame to open the Specify Destination Coordinate System dialog box (described below). 
•	 To select a coordinate system used by another MAP View in the document, click the  Same as check box and 

select the appropriate MAP View in the drop-down list. This does not affect the page position.

The Preview Pane displays the new data extents for the transformed MAP View, however the thumbnails view is not 
available until the transformation is finalized by clicking the OK button in the MAP View Editor. 

Some coordinate system transformations require a datum shift. When this is the case, MAPublisher selects the most 
appropriate datum transformation. This can be edited by clicking the Specify button in the datum shifts frame and 
selecting another datum transformation (see Avenza Projections Guide.pdf for more information).

NOTE:	 Coordinate system transformations are also performed by layer drag and drop between MAP Views.

Specify Coordinate System
The Specify Source/Destination Coordinate System dialog box allows to select, copy and edit coordinate systems and 
associated parameters from the MAPublisher coordinate systems (Geodetic Data Source). The MAPublisher Geodetic 
Datasource is explained in depth in the Appendix A2, and discussed here briefly only.

Coordinate systems are divided in two categories: Geodetic and Projected. For a convenient use, they are sorted in sub-
folders by continent > country > sub-division (e.g. state or county). The *All* category lists all systems with no sorting; 
the *Recent* category lists the last 10 systems recently selected; the *Search* category lists the result of a coordinate 
system search. The MAPublisher coordinate systems may also contain custom systems.
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New MAP Views
After clicking the New MAP View button, the MAP View Editor opens for users to set the name, coordinate system and 
page scaling of the new MAP View. After a new MAP View is created, the Specify Anchors option from the MAP Views 
panel must be used to define the tie-in point between Map Anchors and Page Anchors. Map Anchor coordinates 
can be entered in any chosen coordinate system (for example, latitude and longitude in degree for projected map).

This functionality is explained in detail in Georeferencing an Adobe Illustrator file in appendix A1 General Tips. 

IMPORTANT NOTES FOR ADOBE ILLUSTRATOR CS4 USERS 

Adobe Illustrator CS4 introduced the concept of multiple artboards (up to 100). MAPublisher 8 takes this new 
feature into account in the MAP View Editor.

When a document contains multiple artboards, the MAP View Editor dialog box has an additional drop-down list 
to select the Active Artboard. When this section of the dialog has focus, the Preview Pane displays the number of each 
artboard. The current active artboard is shown in white, while the others are grayed out. The Data Extents LL Corners 
and Scale calculations are based on the Active Artboard dimensions.

To move the data extent (green box in the Preview Pane) from one artboard to another, change the Active Artboard 
number to the artboard where the data is to be moved, then click the Auto Scale button or one of the Data Extents 
LL Corner boxes.

NOTE:	 Adobe Illustrator CS4 allows users to move artboards. However, this action does not preserve the 
georeferencing (same effect as moving art on the active artboard). Instead of moving the artboard, users 
must do the following:

•	 Create a new artboard at the desired position on the canvas.
•	 Open the MAP View Editor and move the data from the initial artboard to the new one (see 

explanation above).
•	 Delete the initial artboard. 

Artboards- Preview of the artboards  
present on the canvas. 

Active Artboard -  White background.

Other Arborads - Grayed out.

Active Artboard- Select the number of 
the artboard to be set as Active
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Import MAP View 
MAP Views panel > Import MAP View From Document

Document list - List of 
open documents 

and the MAP Views 
contained in them.

FUNCTIONALITY

MAPublisher Import MAP View copies a MAP View from one document to another, including all the layers that are 
within that MAP View. This can be a useful tool when merging parts of several documents into a single document. 
An example might be to import a commonly used inset map.

PREREQUISITES

At least two documents must be opened to use Import MAP View. The active document does not need to contain 
any MAP View, but the second document must at least contain one MAP View.

NOTE:	 Import MAP View imports all the layers contain in the selected MAP View. To limit the number of layers 
being exchanged: in the source document , make a duplicate of the MAP View and move a subset of layers 
from the original MAP View to the duplicate; then import of the duplicate. This way, only the subset of 
layers gets imported.

USING IMPORT MAP VIEW

To access the function, click the Import MAP View from Document... item in the MAP Views panel options menu.

The Import MAP View dialog box shows all other documents currently open, along with all the MAP Views they 
contain. Simply select the MAP View to be imported into the current document, and click OK to import the MAP 
View and MAP Layers.
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Export 
MAP Views panel > Export and buttons  (MAP View)  (MAP Layer)

Format - Select the export format for 
the selected layer or MAP View.

 
Dataset - Displays the directory path for 

the export of the currently selected 
layer or MAP View. You can also 

manually type in the dataset location .

Release Version - Specify the AutoCAD 
version number you wish to export to.

AutoCAD Settings

Keep format extension - Check this option 
to export layers with their feature 
extension (_area, _line, _point, or 

_text) which may have been appended 
to layer names during import.

Settings - Opens a Settings dialog box 
for the input of extra parameters (see 
below).

Browse - Opens a Data Source browser 
to enable the selection of an export 
directory.

Character Encoding - Assign a codec if the 
attribute information held in the selected 
layer or MAP View uses a double byte 
character set.

General Settings

MicroStation Settings

EXPORT SETTINGS

Export visible attributes only - Check 
this option to export only the 
attributes that are currently visible 
in the MAP Attributes panel. 

Seed File - If required, select a seed file to be applied 
to the exported dgn file . Click Clear to remove the 
seed file selection.

Coordinate Units - Specifies how feature coordinates 
will be interpreted and converted (Master, Sub or 
Units of Resolution).

Area Fills - Controls whether or not fill linkages will 
be written out for ellipses, shapes, and solids.

KML/KMZ Settings
Delimited XY Text Data 

Settings

Do not export attributes - Check this option for export to 
KML to be used in Google Maps (Google Maps does 
not support KML files with attribute values).

Include header - Add the column headers 
at the first line of the exported text file

MIF/MID Settings

Delimiter - Set the fields delimiters to either 
comma, semicolon or tab.

E00 Settings

E00 Compression Level - Set the compression of 
the exported E00 file (default is None).

Suppress Pen and Brush lines - Check this option to 
remove all pen and brush styles in the output 
MapInfo MID/MIF files.
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FUNCTIONALITY

MAPublisher supports the export of single MAP Layers or whole MAP Views to various GIS formats, maintaining all 
georeferencing and attribute information. The following export formats are supported:

CAD (*.dxf ) (*.dwg)
Delimited Text Data (*.csv) (*.tsv) (*.txt)
ESRI Interchange File (*.e00)
ESRI ArcInfo Generate (*.gen)
ESRI Shapefile (*.shp)
GML (Simple Features 3.1.1) (*.gml / *.xsd)
KML/KMZ (*.kml/*.kmz)
MapInfo MIF/MID (*.mif / *.mid)
MapInfo TAB (*.tab)
Microstation Design (*.dgn)

NOTE:	 Exporting a MAP View to CAD or MicroStation format will assemble all hosted layers into a single file.

NOTE:	 Exporting a MAP View to Flash map or Geospatial PDF is explained in chapter 15 and 17 respectively.

PREREQUISITES

The Export function exports a single selected Adobe Illustrator layer contained in a MAP View or all layers contained 
in a selected MAP View. Both imported and user created MAP Views that contain MAP Layers that are suitable for 
export to GIS formats. 

NOTE:	 Export to KML/KMZ is only possible if the MAP View's coordinate system is WGS84 geodetic. So it might be 
required to first transform the MAP View to that system.

USING MAP EXPORT

Export a MAP View 
To export all the MAP layers within a single MAP View, select the MAP View to be exported in the MAP Views panel, 
then click the button . Alternatively, click Export “<MAP View name>” in the panel options menu.

Export a MAP Layer

To export a single layer, select the MAP Layer to be exported in the MAP Views panel, then click button 
. Alternatively, click Export “<Layer name>” in the panel options menu.  Within the dialog box select the export 
required Format, and then click the Settings button. 

NOTE: 	 Only a single MAP View or a single layer can be exported at one time.
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Keep Format Extension
The name of the MAP Layer or MAP View selected for export is the default name of the exported file. However 
the feature type text (i.e. _area, _line, _point, or _text) appended to Adobe Illustrator layers by MAPublisher in the 
Import process, are removed during the export process, unless the Keep format extension option is checked.

Export Visible Attributes
Check this option to export only the attributes that are currently visible in the MAP Attributes panel. If this option is 
not checked, all attribute columns (including MAPublisher #Property attributes) are exported.

Format Specific Settings
Depending on the selected export format, additional specific settings may be available. This is the case for the 
following formats: AutoCAD, Delimited XY Text Data, MicroStation, MID/MIF, E00 and KML/KMZ. See the Export 
Settings above. When exporting to KML/KMZ, specify the format extension (*.kml or *.kmz) in the Select Export File 
dialog box (Save As Type drop-down list).

Choosing a Destination Folder
Most of the export formats require the selection of a destination folder only. For export to ESRI or MapInfo formats, 
click the Browse button to specify a destination folder. Click the OK button to export your MAP Layer.
 
When exporting to AutoCAD format, it is required to specify a name for the exported file, and select the file extension 
(DXF or DWG) to be used. For MicroStation formats, it is required to specify a name for the exported file. To export to 
either of these formats, click the Browse button to name the export file, and then choose the file format from the 
Format drop-down list. 

ADDITIONAL NOTES

Valid Area Direction (Area Layer Exports)
When exporting Area layers to GIS formats, polygon outlines must have a positive Area value, whereas holes held 
inside compound paths (or complex shapes) must have a negative Area value. If some polygons in the #Area 
property column of the MAP Attribute table which contradict these guidelines, use the following tools to convert 
the MAPublisher area calculation from a negative to a positive value or vice versa:
•	 Flip Lines tool (chapter 8) for convert multiple areas:
•	 Create a Selection Filter (chapter 11) to select all elements that have an #Area of less than zero (to select negative 

values) or greater than zero (to select positive values). Then start the Flip Lines function. 
•	 #AreaDirection property value (chapter 5) to convert areas one by one: select the area to edit and then choose the 

alternate value for #AreaDirection in the MAP Attributes panel.

Text Exports 
It is not possible to export values in the #Text property column. An alternative is to create a new string attribute 
column and assign it an expression of #Text. See Edit Schema in chapter 5 on MAP Attributes. 

Texts on a path are exported as point text with an angle (main direction of the original path).
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MAP Location Tool 
MAP Toolbar, or Tools> MAP Location Tool  and

Window > MAPublisher > MAP Location

WX/WY - The X and Y coordinates of the 
cursor in current map units.

Scale 1: - Scale of the current layer.

Map X/Y - Map Anchors.

Units - Units of the coordinate system, 
if specified.

FUNCTIONALITY

The MAPublisher Location Tool displays the coordinates of the mouse cursor on the selected map layer, in current 
Map Units and in Degrees. Latitude and longitude values are in reference to the geodetic datum set in the coordinate 
system definition. When no georeferencing is present on the selected layer, the dialog box will display the 
coordinates in Page Units. The dialog box will also display the Map and Page Anchors, the Scale, Angle of rotation, and the 
Coordinate System and Units of the MAP Layer.

The MAP Location Tool also enables the X and Y position of the cursor in the current map units (WX and WY) to be 
copied to the clipboard. An example of a use of this function is to build point files in an external text editor; files 
which can then be re-imported with MAPublisher. Coordinates are copied with the X value first and Y value second, 
and are delimited by a comma. For example: -79.396527,43.631979

USING THE MAP LOCATION TOOL

To use the MAP Location Tool, click the  button in Adobe Illustrator Tools panel or on the MAP Toolbar, or open the 
panel through Window > MAPublisher > MAP Location. With the cursor scroll around the map document, and note 
how the map units update with the location of the mouse. 

NOTE:	 While the MAP Location Panel is opens, the values are constantly updated with any other tool selected.

When the MAP Location Tool button is enabled in the Adobe Illustrator Tools panel, users are able to copy the 
coordinates of a specific location. The appropriate layer must be selected in the MAP Views panel, the MAP View 
containing the layer will determine the MAP units and coordinate system used to display the positions. To copy the 
positions:

•	 Position the cursor at the desired location.
•	 Click the document while holding the Shift key. 

The X and Y position in map units are copied to the clipboard and can be paste into any text editor. Latitude and 
Longitude values are also copied if this is enabled in the MAP Location Tool preferences (see below). Only one set of 
coordinates can be copied at once. When shift+click is used again, the values copied previously will be overwritten.

NOTE: 	 When the cursor is placed outside of the MAP View extent of the selected layer, positions values are 
indicated as Unavailable .

Latitude/Longitude - The latitude and longitude 
coordinates of the cursor in degrees (based on 
the geodetic datum of the coordinate system).

Angle - Angle of Rotation. 

Page X/Y - Page Anchors.

Coordinate System - Coordinate system of the 
layer, if specified.

Copy Notification - When the MAP location tool 
is selected on the tool bar, you will see this 
text, enabling you to copy the current X and Y 
coordinates of the mouse cursor.

Displays the parameters of the currently selected layer.
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MAP LOCATION TOOL PREFERENCES

The MAPublisher Preferences for the MAP Location Tool can be accessed from the menu Edit > MAPublisher 
Preferences or by double-clicking the MAP Location Tool button  in the Adobe Illustrator Tools panel.

There, users can specify the latitude/longitude display format and number of decimals. Enable the option Include 
Latitude and Longitude values when copying coordinates to copy both the X/ Y and Lat/Long positions when using 
Shift+Click (see above).
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MAPublisher can import GIS files into Adobe Illustrator while 
retaining both geographic vector and attribute information 
and makes it very easy to produce high quality maps. 

The attribute information is later used as a key for many 
MAPublisher functions: MAPublisher labelling engines, MAP 
Stylesheets, MAP Selection Filters, MAP Web Author...

This section explains the principles of attribute information 
and how these are maintained within MAPublisher. 

Topics covered in this section are:
Attributes Foreword
MAP Attributes Panel
Edit Schema
Expression Builder
Find & Replace Attributes
Apply Expression
Join Table
Export Attributes

MAP 
Attributes
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Attributes Foreword 

ATTRIBUTE INFORMATION

The attribute table that forms part of a GIS map file is one of the most important parts of any data set. It is in the 
attribute table that we find important information such as street names for lines, zoning or zip code numbers for 
areas and elevations for points to go along with our vector line, area or point data. Along with vector line, area 
and point data imported as explained in the previous sections, MAPublisher also imports the attribute data table 
associated with any vector map file that it supports. 

MAP LAYERS

Throughout this guide, an Adobe Illustrator layer containing georeferencing and/or attribute information will be 
referred to as a MAP Layer. 

Each MAP Layer which can contain attribute information is symbolized in MAPublisher panels and dialog boxes 
with an icon depicting its feature type:

	  Area layer	 (e.g. county boundaries, urban areas, country outlines etc.)

	  Line layer	 (e.g. rivers, roads, railways etc.)

	  Point layer	(e.g. town and city symbols, railway stations etc.)

	  Text layer	 (e.g. text labels)

NOTE:	 Legend layers do not contain any attribute.

MAPUBLISHER #PROPERTY ATTRIBUTES

In addition to the attribute values that were created upon data import or within a work session, Area, Line, Point 
and Text layers are also assigned a number of additional MAPublisher attribute columns. These property columns 
(prefixed with a #) are designed to indicate the physical properties of map art on the Adobe Illustrator canvas. Art 
can be modified directly from the attribute table by making edits to values in these columns.

The following property columns are attached to valid map layers in this version of MAPublisher:

 Area layers
#LayerName	 describes the name of the containing layer. This property cannot be set.
#ID	 describes the internal unique ID to refer to Adobe Illustrator artwork within the document.Read-only.. 
#Name	 describes the name of the polygon. Editing this property will change the name in the Layers panel. 
#AreaDirection	 describes the direction as clockwise or counter-clockwise. Editing this value will reverse the direction 

accordingly.
#VertexCount	 describes the number of points in the art. This property cannot be set.
#Style	 describes the Graphic Style in use. Editing this property will apply the selected style to the art.
#StrokeWeight	 describes the stroke weight of the path. Editing this property will alter the stroke weight of the art.
#Perimeter	 describes the perimeter of the area in world units. This property cannot be set.
#PathClosed	 describes whether or not the path is closed (yes or no). Editing this value will open/close the path.
#ArtScale	 describes the scaling of the line stroke. Editing this value will scale the stroke weight.
#Area	 describes the area of the path in world units. This property cannot be set.
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 Line layers

#LayerName	 describes the name of the containing layer. This property cannot be set.
#ID	 describes the internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#Name	 describes the name of the polygon. Editing this property will change the name in the Layers panel. 
#VertexCount	 describes the number of points in the art. This property cannot be set.
#Style	 describes the Graphic Style in use. Editing this property will apply the selected style to the art.
#StrokeWeight	 describes the stroke weight of the path. Editing this property will alter the stroke weight of the art.
#PathClosed	 describes whether or not the path is closed (yes or no). Editing this value will open/close the path.
#Length	 describes the length of the path in world units. This property cannot be set.
#ArtScale	 describes the scaling of the line stroke. Editing this value will scale the stroke weight.

 Point layers

#LayerName	 describes the name of the containing layer. This property cannot be set.
#PageX	 describes the x-coordinate in the document units of the current point. 
#PageY	 describes the y-coordinate in the document units of the current point.
#ID	 describes the internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#Name	 describes the name of the point. Editing this property will change the name in the Layers panel.
#HorizontalScale	 describes the horizontal scaling of a point object. Editing this value will scale the symbol in the X axis.
#VerticalScale	 describes the vertical scaling of a point object. Editing this value will scale the symbol in the Y axis.
#Rotation	 describes the rotation in degrees of the art around its anchor point. Editing this value will rotate art.
#Style	 describes the Symbol in use. Editing this property will apply the selected symbol to the art.
#MapX	 describes the x-coordinate in the world units of the current point. 
#MapY	 describes the y-coordinate in the world units of the current point.

 
 Text layers

#LayerName	 describes the name of the containing layer. This property cannot be set.
#PageX	 describes the x-coordinate in the document units of the current point text. For text-on-a-path or text-

in-a-path, this will be the x-coordinate of the first vertex on the associated path.
#PageY	 describes the y-coordinate in the document units of the current point. For text-on-a-path or text-in-a-

path, this will be the y-coordinate of the first vertex on the associated path.
#ID	 describes the internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#FontSize	 describes the font size used by the text.
#FontFamily	 describes the font family used by the text.
#Name	 describes the name of the text field. Editing this property will change the name in the Layers panel.
#Text	 describes the contents of the text. Editing this property will edit text on the page.
#TextLength	 describes the number of characters in the contents of the text art. This property cannot be set.
#Rotation	 describes the rotation in degrees of the art around its anchor point. Editing this value will rotate art.
#Style	 describes the Character Style in use. Editing this property will apply the selected style to the art.
#MapX	 describes the x-coordinate in the world units of the current point. 
#MapY	 describes the y-coordinate in the world units of the current point.
#HorizontalScale	 describes the horizontal scaling of a point object. Editing this value will scale the text in the X axis.
#VerticalScale	 describes the vertical scaling of a point object. Editing this value will scale the text in the Y axis.

Warning - The #ID property is not persistent. This means that  if a document is saved and re-opened, the #ID value might 
change. The value will usually not change over the life of a document session, but there are Adobe Illustrator operations 
that can cause the value to change.
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IMPORTANT ADOBE ILLUSTRATOR COMPATIBILITY NOTES

Some Adobe Illustrator functions may cause the link between artwork objects and their attributes to be broken, 
resulting in possible data loss. These functions are:

•	 Compound path (Make)
•	 Pathfinder
•	 Live Paint
•	 Gradient mesh
•	 Blob brush (Adobe Illustrator CS4)

By default, releasing a compound path also breaks the link between released paths and the attributes. To avoid 
this behaviour, users may enable the option Replicate attribute data to compound path sub-components in the MAPublisher 
Preferences for MAP Attributes. This option must be enabled when attributes are created for the attribute data to be 
copied to the compound path components. For example, if a compound path is imported with the option disabled, 
the attribute data is not copied to the child paths — therefore releasing the compound path will always break the 
attributes, even if the option is enabled at a later stage.

NOTE:	 This option has an impact on the performance, so it should only be enabled if necessary. 

If required, users should first duplicate their working layer in the Adobe Illustrator Layers panel before using these 
functions. The original layer can be kept for labelling (see chapter 10 and 18) or for information purposes.
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MAP Attributes Panel
Window > MAPublisher > MAP Attributes and MAP Toolbar 

Attributes and Properties - 
Attribute and property 

values on the selected layer 
are displayed here.

Click and drag separator 
to resize the columns.

Edit Schema - To edit the properties 
of all columns comprising the 
current attribute table: i.e. edit 
column names, visibility, type and 
width, or assign expressions to 
columns.

Click header to sort column 
values alpha/numerically.

Edit Column - Edit the properties 
of the selected column.

Delete Column - To delete the 
currently selected column.

Right-click (Windows) or Ctrl-click (Mac) to display the menus:

Show/Hide Columns - Select or un-
select column names to show or 
hide columns. Or choose to show 
all columns, or hide all columns

FUNCTIONALITY

The MAP Attributes panel displays the map attribute and property attribute records for a map layer, which are linked 
to the map’s graphic elements, and makes them available for editing. This panel is also the hub from which you can 
edit column schemas and visibility, add or delete columns, join tables, find and replace attributes, and apply expres-
sions to selected art. Only the visible attributes of selected map features will be displayed in the dialog box. 

USING THE MAP ATTRIBUTES PANEL

Viewing Attributes
Selected features are sorted per layer. The Layer drop-down list shows all the layers that currently have features 
selected, as well as the number of selected map objects for each layer (also reported at the base of the panel). The 
attribute values displayed in columns in the MAP Attributes panel can be sorted in ascending or descending order 
by clicking the column header. The widths of the columns may be changed by clicking the column separator and 
manually dragging it to resize as desired. 

Zoom to Feature - Click the Feature 
number or right click the attribute 
and select Zoom to Feature.

Highlight Feature - Click the feature 
attribute to highlight that feature on 
your map.

Layer Selection - If data is 
selected on a number of 

layers, select the map layer 
containing the attributes to 

be viewed with this list. 

Hide Column - To hide the 
currently selected column.

New Column - Adds a new 
column to the attribute table.

Join Table - Click to join an external 
data table to the current attribute 
table.

Apply Expression - To assign attribute 
values or graphical properties to 
selected art via the input of an 
expression.

Find & Replace - Click to find and 
replace attributes in the current 
attribute table.

Export attributes - Export all 
selected attribute information 
to a delimited text file.

Preferences - Opens the 
MAP Attributes panel 
preferences(see chapter 1).

Selected objects - Number 
of objects selected on the 

current layer..

Pop-up menus

In column header: In a row: 

Resize all to fit contents - Resize 
the width of all columns to fit 
the longest value.

Resize COLUMN_NAME to fit content 
-  Resizes only the selected 
columns.

Add Calculated Data - Add or edit 
an attribute column(s) with 
calculated data.



76 Chapter 5: MAP Attributes
MAP Attributes Panel

The type of attribute is indicated by an icon preceding the column name :

	  Boolean - columns contain True or False values

	  Integer - columns contain only whole numbers (limited to 10 digits)

	  Real - columns contain numbers carrying decimal values

	  String - columns can contain attributes that are both alpha and numeric

Editing Attributes
MAPublisher MAP Attributes panel is a fully editable spreadsheet environment. All attribute values may be edited 
except for certain MAPublisher Property attributes (see earlier in this chapter). To change the value of a cell, double-
click within the cell and enter the new value such as you would in a spreadsheet program. Keep in mind that 
entered values must correspond with a column’s type (i.e. only enter numbers into a column of type Real or Integer). 
The edits will immediately be reflected in the map documents database records. Existing attribute records may also 
be edited or modified by performing a find and replace operation on them. 

Column Visibility
Click the Show/Hide Columns button (or Right-click (Windows) or Ctrl-click (Mac) on a column in the dialog box) to edit 
the column visibility, either toggling visibility for individual columns or for all columns. It is also possible to edit the 
visibility of attribute columns with the Edit Schema tool.

Zoom To and Highlight Feature
To zoom into a specific feature in the attribute table, select a single attribute and click the Zoom to Feature button. This 
will automatically fit this feature to the screen and highlight it—allowing to examine it closer or to simply locate it 
on the map. To highlight a specific feature on the page maintaining the current zoom level, click one attribute of 
that feature. 

Property Attributes
The attribute table can also be configured to display property attributes for datasets. These attributes describe 
the current assignment of graphical properties such as the stroke weight, style, rotation and scale. These fields are 
editable and provide the ability to modify a map objects graphical properties directly within the context of the MAP 
Attributes panel. To edit a property attribute for a particular map object, either double-click within the appropriate 
property cell and directly enter a value or choose from an available drop-down list depending on the property type 
being edited. Once these changes have been entered into the MAP Attributes panel, the modified art elements are 
graphically updated within the map to reflect these changes.
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Edit Schema 
MAP Attributes panel > Edit Schema / Edit Column / New Column

In MAPublisher, the term schema is used to define the structure and makeup of the map attributes table. 

FUNCTIONALITY
The Edit Schema function allows to edit and manage various components of the data’s map attribute structure, 
including creating, editing and deleting columns, setting visibility preferences, and assigning expressions. Any 
changes made to the schema will instantly be reflected in the MAP Attributes panel.

USING EDIT SCHEMA 
Select an object of the MAP Layer containing the attributes to be edited. It gets selected in the MAP Attributes 
panel. Access the tool by clicking the Edit Schema button or menu item in the MAP Attributes panel options menu.

Edit Schema lists all of the columns which currently exist in the MAP Layer attribute structure, including MAPublisher 
Property attributes (see previous section). By default, imported or created attributes will be visible, whereas property 
columns will not be shown by default. Please note some #Property column structures cannot be edited (read only).

Editing Column Format 
Each column has a name and display name. The name is used in the expression builder and for export. The display 
name is used when exporting to geospatial PDF (see chapter 17) and is shown by default in the column name in the 
MAP Attributes panel (see MAPublisher Preferences in chapter 1).

The punctuation characters are not supported in column names to avoid complications when exporting to external 
formats. The following illegal characters are replaced with an underscore '_' upon data import or join table: 

space ` ~ ! @ # $ % ^ & * ( ) - + = { } [ ] | ; : " ' \ , < . > / ?

These character are supported in Display name.

To rename a column enter the new text directly into the Name field. All expressions referring to this attribute name 
are updated instantaneously.

Up / Down - Click the appropriate 
button to move the selected 

column up or down the 
hierarchy.

Column list - Attribute and 
(#) property columns on the 
current layer are listed here.

Select a column here to edit its 
properties on the right.

Add - Click to add a new column 
to the column list. 

Remove - Click to delete the selected 
column.

Name - Edit the name of the selected 
column here.

Display Name- Edit the column label 
displayed.

Type - Edit the column type here: 
choose from Integer, Real, String or 
Boolean.

Size / Decimals - Edit the size of String 
type or amount of decimals of Real 
type.

Default Value - Assign the same value 
to all items in the selected column if 
required.

Visibility - Choose to show or hide 
the selected column by editing this 
option.

Read-only - Check this option to ensure 
that values in this column can not 
be edited.

Derive value from expression - Check this option to assign an 
expression to the selected column. Either enter the expression 
directly into the entry field, or click the Browse button to 
access the Expression Builder dialog box.
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NOTE:	 Some external file formats have limits on the number of characters allowed for field names. Therefore, 
during the export from MAPublisher, some field names might get truncated to comply to the chosen 
external file format. For example, ESRI shapefiles are limited to 10 characters (confirmed up to ArcGIS 9.3), 
ESRI Interchange File (.e00) to 16 characters, MapInfo to 30 characters.

Once the name is set, specify a data type by making the appropriate selection in the Type list. Please note the 
following:

•	 String columns can contain attributes that are both alpha and numeric.
•	 Integer columns contain only whole numbers.
•	 Real columns contain numbers carrying decimal values.
•	 Boolean columns contain True or False values.

To modify the amount of characters or decimals, enter a value into the Size/Decimal text box (the maximum string 
size is 28000). A Default Value can be assigned for all new objects placed on the selected layer by entering text 
accordingly. Check or uncheck the Visible option to edit a column’s visibility. Check or uncheck the Read-only option 
to edit a column’s read/write status. 

Check the Derive value from expression option to assign an expression to the selected column. Enter a valid expression 
in the Expression field or click the Browse button to enter and edit expressions via the Expression Builder dialog box. 
The Expression Validity icon  will report if the expression entered is valid. Otherwise it will report  and include 
additional warning notes. This function is useful, for example, to populate the column values based on the contents 
of other columns and/or mathematical formulas.

NOTE:	 Values derived from expression are dynamically linked to the attributes used in the expression. Therefore, 
they are read-only. Use the Apply Expression function to generate values that can be modified. 

The following are some examples of basic expressions which can be assigned to columns in Edit Schema:

“Ontario” (applied to column = NAME)
Result: All items are assigned the value “Ontario” in the NAME column.

“MAP Area 01” (applied to column = #Style)
Result: All area items are assigned the value “MAP Area 01” in the #Style column and are assigned the Graphic Style “MAP 
Area 01” on the page.

45 (applied to column = #Rotation)
Result: All point items are assigned the value 45 in the #Rotation column and are rotated to 45° on the page.

NOTE:	 String values are case-sensitive and must be entered in quotes (“...”).
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Adding, Deleting and Re-Ordering Columns
Stipulations regarding the display order of attribute columns in the MAP Attributes panel can be set by reordering 
the existing list according to your preferences. Any column may be promoted in the list/attribute table by selecting 
it in the list and clicking the Up and Down buttons to move it up or down within the list. Columns will display in the 
MAP Attributes panel according to the display order established in Edit Schema.

To create a new column, click the Add button and input the desired column properties. To delete an existing column, 
choose it from the available list and click the Delete button.

Click OK to confirm your edits to the attribute structure on the selected layer. These edits will immediately be visible 
in the MAP Attributes panel.

EDIT COLUMN

Edit Schema can also be accessed via the Edit Column context menu. Within the MAP Attributes panel, select the 
column to be edited, right-click the column heading or cell and click Edit. This opens the Edit Schema dialog box with 
the same column immediately selected in the column list.
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Expression Builder
Accessed from Edit Schema, Apply Expression, 

New/Edit Selection Filter, MAP Stylesheet Editor

Expression Validity - Indicates if the 
expression is valid  or invalid . If 

invalid, additional info is reported.

Advanced toggle - Click to show or hide 
the Expression Components section

Objects - List of attribute and property 
columns, constants and functions 

for use in the expression. To expand 
a folder click  ; to collapse click  . 

Double-click items to insert them into 
the expression.

Layer attributes - List of the attribute and 
property columns which comprise the 

current layer.

Constants - Insert either True or 
False into the expression if required. 

Functions - List of functions for use in the 
expression if required.

Description - Displays information on the 
currently selected item in the Objects 
panel, i.e. a description and example of 
the function or constant, or information 
regarding the format of the MAP layer 
along with it's attribute values.

When selecting an attribute, click the 
link display unique values* to display 
the attribute values of the selected 
attribute column.

Cursor Position - Position of the current 
text entry point.

Operator buttons - Click to insert an 
operator into the expression at the 

current cursor position.

Expression Entry - Where all composition 
of the expression occurs. Use the 
keyboard, operator buttons, and/or the 
Objects list to compose the expression.

Expression Builder

This dialog box appears when the Recent 
button is clicked

Recent Expressions

Recent - Select from a list of recently 
used expressions in the MAP Attribute 
or MAP Stylesheet panels or from the 
MAP Selection Filters (see chapter 11).

Expressions - List of expressions from the 
MAP Selection Filters saved expressions 

(see chapter 11) or from the ones used 
in MAP Attributes or MAP stylesheets 

during the current Adobe Illustrator 
session.

Click one or more entries to copy to 
the expression builder—multiple 

selections are concatenated with the 
AND statement.

*Display unique values only list up to 
a maximum set in the MAPublisher 
Preferences for the Expression builder (see 
chapter 1 for more information)
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FUNCTIONALITY

The MAPublisher Edit Expression tool provides for the entry and edit of expressions for use in the generation of 
new attribute values and properties, to make selections or to apply styles. Expressions can be entered using the 
keyboard, and/or by selecting from listed column names, operators and functions. 

Edit Expression provides functionality for a number of tools:

Edit Schema: To create or edit an expression for the generation of values in an attribute or column.
(MAP Attributes panel > Edit Schema > Derive value from expression > Browse)

Apply Expression: To apply an expression to an attribute or property column for selected art only.
(MAP Attributes panel > Apply Expression> Browse)

New/Edit Selection Filter (chapter 11): To create or edit expression criteria for use in selecting map data.
(MAP Selection Filters panel > New/Edit Selection Filter > Browse)

MAP Stylesheet Editor (chapter 9): To create or edit an expression for use in styling map data.
(MAP Stylesheets panel > Edit MAP Stylesheet > Advanced Expression > Browse)

ENTERING EXPRESSIONS

Expression can be built using the keyboard and/or by clicking the operator buttons or items in the Objects list 
(attributes name and values, constants and functions). These items are colour coded to ease the identification: 
attribute names in purple, string values in orange, operators and numerical values in grey, constants in green and 
functions in black. Clicking any of the operator buttons or double-clicking an item from the Objects list inserts that 
item into the expression. 

It is recommended to use the interface rather than the keyboard to build expressions, because functions are 
formatted correctly (e.g. with brackets), and, for attribute values of type strings, quotations marks are added 
automatically. Besides, expressions are case-sensitive. For string comparison, all strings values can be converted to 
a same case using the appropriate function (LOWER(“string”) or UPPER(“string”)). However, the keyboard is best used 
for deletions. 

Validity
The validity of the expression will be displayed below the Expression Entry field, and will be updated as the 
expression is built. The Expression Validity icon  will report if the expression entered is valid. Otherwise it will report 

 and include additional warning notes. 

Operator Buttons
Click to insert an operator at the current cursor position. Available operators are as follows:
( Open clause operator < Logical less than comparator
) Close clause operator > Logical greater than comparator
AND Logical AND operator + Mathematical addition operator
OR Logical OR operator - Mathematical subtraction operator
= Logical equal to comparator / Mathematical division operator
!= Logical not equal to comparator * Mathematical multiplication operator

& Text concatenate operator
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Expression Components 
Items in the Objects list fall into three categories. Information on a selected item is displayed in the Description 
panel. Double-click to insert an object at the current cursor position. Available objects are as follows: 

<MAP Layer>* Functions

List of #property columns ABS Absolute value of a number
List of attribute columns† ACOS Inverse of the cosine of an angle.

ASIN Arcsine of an angle.

Constants ATAN Arctangent of an angle.

 #true	 Boolean true value CONTAINS True if source string contains search string.

 #false	 Boolean false value COS Cosine of an angle.

 #pi	 π numerical value (3.141592) DEGREES Converts values from radians to degrees.

ENDSWITH Returns true is the source string ends with the suffix string.
FIXED Numbers as string values.
IF Conditional statement.
IF_CASE Conditional statement based on multiple cases.
LEFT Extracts the first N characters of a string.
LENGTH Returns the number of characters in a string.
LIKE Searches the source string using wildcards.
MID Extracts N characters of a strings from a specified location.
NUMBER String values as numbers.
POW Base to the power of an exponent.
PROPER Strings converted to capital case.
RADIANS Converts values from degrees to radians.
REGEX Searches the source string using a regular expression.
RIGHT Extracts the last N characters of a string.
ROUND Rounds to specified decimals of precision.

ROUNDDOWN Rounds down to specified decimals of precision.
ROUNDUP Rounds up to specified decimals of precision.
SEARCH Returns the position of a character in a string.
SIN The sine of an angle.
SPLIT Splits a string and extracts the indexed part of it

SQRT Square root of a value.

STARTSWITH Returns true if the source string starts with the prefix string.

SUBSTITUTE Replaces a set of characters by another in a string

SUBSTITUTE_RX Replaces a regular expression by characters in a string

TAN Tangent of an angle.

TRIM Removes all spaces in a text (except the singe ones between 
words).

UPPER Strings converted to upper case.

For each function, a description and some examples are provided in the Description panel of the Expression Components.

NOTE:	 String values are case-sensitive and must be entered in double quotes (“...”). 
	 For functions using indexes for text position (MID, SEARCH and SPLIT), the first index number is 0.

* Layer may vary depending on tool. For Edit 
Schema, Apply Expression and New/Edit 
Selection Filter, the current layer is displayed. 
In the MAP Stylesheet Editor, all layers hosted 
by the stylesheet are displayed.

† Unique values contained in each attribute 
column can be viewed in the Description 
panel.
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Recent Expressions
Expressions already entered in the MAP Attributes panel, MAP Stylesheets panel (see chapter 9) and MAP Selection 
Filters (see chapter 11) can be re-used by selecting them from the Recent list. Click one or more entries to copy to 
the expression builder—multiple selections are concatenated with the AND statement.

Only MAP Selection Filters expressions are saved with the Adobe Illustrator documents, the other recent expressions 
are only saved in memory for the time of the Adobe Illustrator session (they are reset if the document is closed).

Confirmation
When the expression is finalized and validated, click OK. The expression is inserted into the expression field of the ap-
propriate tool. The Edit Expression tool can be re-opened if further edits are required.

Example Basic Expressions
APPLY EXPRESSION

“Ontario” (applied to column = NAME)
Result: All selected items are assigned the value “Ontario” in the NAME column.

“MAP Area 01” (applied to column = #Style)
Result: All selected area items are assigned the value “MAP Area 01” in the #Style column and are assigned the Graphic Style “MAP Area 
01” on the page.

45 (applied to = #Rotation)
Result: All selected point items are assigned the value 45 in the #Rotation column and are rotated to 45° on the page.

SELECTION FILTER

NAME = “Ontario”
Result: All items with the value “Ontario” in the NAME column are selected.

POPULATION < 1000000
Result: All items with values less than one million in the POPULATION column are selected.

NAME = “Ontario” OR NAME = “Alberta”
Result: All items with the value “Ontario” OR “Alberta” in the NAME column are selected.

NAME = “Ontario” AND POPULATION < 1000000
Result: Only the items containing the value “Ontario” in the NAME column AND values less than one million in the POPULATION column 
are selected.

MAP STYLESHEET

NAME = “Ontario”
Result: All items with the value “Ontario” in the NAME column are assigned the selected style.

POPULATION < 1000000
Result: All items with values less than one million in the POPULATION column are assigned the selected style.

NAME = “Ontario” OR NAME = “Alberta”
Result: All items with the value “Ontario” OR “Alberta” in the NAME column are assigned the selected style.

NAME = “Ontario” AND POPULATION < 1000000
Result: Only items containing the value “Ontario” in the NAME column AND values less than one million in the POPULATION column are 
assigned the selected style. 
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EDIT SCHEMA

LOWER(NAME) (applied to column = name)
Result: All items in column name are assigned the value of the column NAME in lower case (e.g. “ontario” for “Ontario”, “new brunswick” 
for “New Brunswick”)

PROPER(name) (applied to column = Proper_name)
Result: All items in Proper_name are assigned the value of the column name in proper case (or capital case) (e.g. “Ontario” for “ontario”, 
“New Brunswick” for “new brunswick”).

TRIM(JOINING_COLUMN)
Result: All items are trimmed with all spaces except single ones between words ("   Route        66 " becomes "Route 66"). This is particularly 
useful prior to using the Join Table function because extra spaces at the beginning, end or in between words will cause the join to fail. 

Example Complex Expressions
SELECTION FILTER or MAP STYLESHEET

LIKE (NAME, “*New*”)
Result: all items with the string of letters "New" in the NAME column are selected (e.g. “New Brunswick” and “Province of Newfoundland”)

STARTSWITH (NAME, “o”)
Results: all items that starts with the letter “o” (“Ontario”) are selected.

EDIT SCHEMA

ROUND((POPULATION/ AREA ),3) (applied to column=density)
Result: All items are calculated as “population divided by area”, rounded to three decimals.

IF_CASE("null", VALUE>0,"positive",VALUE<0,"negative") 
Result: A default status of "null" is assigned unless the value is strictly superior or inferior to 0.

SUBSTITUTE_RX(ROAD_NAME,"\D","")
Result: All non digit characters (\D is the regular expression for non-digit character) are replaced by nothing (two double-quotes indicate 
that the new string is blank), therefore only numerical values are kept. For example, if the ROAD_NAME equals "Route 66", the result is 
"66". This can be useful to prepare an attribute table prior to labelling roads with road number rather than road names.

SPLIT(GEOLOGIC_UNIT,"(",0)
Result: All items containing one or more open parenthesis are split in several text blocks (as many as there is open parenthesis, plus one), 
and returns the first block found (index 0). For example, if GEOLOGIC_UNIT equals "Qmw(Qc)", the result is "Qmw".

SUBSTITUTE(SPLIT(GEOLOGIC_UNIT,"(",1),")","")
Result:  Removes all closing parenthesis (i.e subtitute all closing parenthesis  with nothing) in the result of the same SPLIT as above, that 
returns the second text block found (index 1). For example, if GEOLOGIC_UNIT equals "Qmw(Qc)", the result is "Qc": first the SPLIT function 
returns "QC)" and then ")" is removed with a SUBSTITUTE.

More examples of each individual function can be found in the Expression Builder dialog box itself. Make sure to 
expand the Expression Components, then as you select a function or constant on the Objects list, the Description tab 
is updated with explanations and examples.
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FUNCTIONALITY

The Find & Replace tool allows for the searching and/or replacing of attribute values and properties contained in 
the MAP Attributes panel. Note that only values in visible columns can be found and/or replaced.

USING FIND & REPLACE 

Access the tool by clicking the Find & Replace button or menu item in the MAP Attributes panel.

Find Only
To use Find & Replace to easily find values, click the Find tab to enter the search criteria. Find criteria can be typed 
directly into the Find what entry field (previous criteria can be selected from the list). A search may be performed on 
all attributes by default, or only on specific columns contained within the MAP Attributes panel by enabling the Just 
option and choosing a column from the list. Criteria may be further refined by enabling the Case sensitive and Match 
whole word only options. 

Once the search string has been entered click the Find Next button in order to perform the search. Search results can 
be seen in the MAP Attributes panel; the column header and row number containing the first matching record will be 
displayed in bold text. At this point search for individual records can be done by clicking again the Find Next button. 

Find & Replace
To replace records selected through the Find operation click the Replace tab. Find & Replace criteria can be typed 
directly into the Find what and Replace with entry fields (previous criteria can be selected from the lists). A find and 
replace may be performed on all attributes by default, or only on specific columns contained within the MAP 
Attributes panel by enabling the Just option and choosing a column from the list. Criteria may be further refined by 
enabling the Case sensitive and Match whole word only options. 

There are two methods to replace values. The first method requires to approve each replacement manually by 
clicking the Replace button so that each instance of the attribute located via the search parameters is successively 
replaced in the map attribute table. The second method allows for the replacement of all found records 
simultaneously, accomplished by clicking the Replace All button. 

Find & Replace Attributes 
MAP Attributes panel > Find & Replace

Find / Replace - Choose to Find variables, or to Find & 
Replace variables simultaneously.

Find what - Enter a variable on which to perform a 
search in the current attribute table. Note this list 

will also contain previous criteria.

Replace with - Enter a variable on which to replace 
found items. Note this list will also contain 

previous criteria.

Find/Replace All Attributes / Just in Column - Perform the 
Find, or Find & Replace, on all values in the current 

layer, or just in a specified column.

Find Next - Move to the next value matching the 
Find what variable.

Replace - Replace the selected value with the 
Replace with variable.

Replace All - Replace all occurrences matching the 
Find what variable.

Case sensitive - If checked, only values matching the 
case of the Find what variable will be found.

Match whole word only - If checked, only words 
matching the Find what variable will be found 
(words containing the variable will be ignored).
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FUNCTIONALITY

The Apply Expression function allows to apply a value or an expression to an attribute of the currently selected 
artwork for the purpose of assigning new values or edit properties attributes. For example, this tool can be used 
to compute attribute values based on the values in other columns, to assign a style by editing the #Style property 
attribute, or to rotate symbols by assigning a fixed value to the #Rotation property attribute. Read-only attributes 
cannot be edited with Apply Expression.

Note that property attributes are dynamic. Changes made to them in the map attribute table are reflected 
immediately in the graphical properties and on-screen display of the data to which they are linked. Expressions can 
be generated and applied to data based on the values found in an existing attribute column, providing a one-step 
process to transform a vast number of different objects in a single operation. 

NOTE:	 Unlike the Derive Value From Expression option in Edit Schema, values computed through Apply Expression are 
not tied to the original attributes constructing the expression and can be edited later on. Besides, only 
currently selected artwork is affected by the changes.

APPLYING EXPRESSIONS 

Ensure the data required for the application of the expression is selected, and that layer is selected in the MAP 
Attributes panel. Then access the tool by clicking the Apply Expression button or menu item in the same panel.

First specify a column from the Apply to list to specify which attribute column the expression will be applied to. The 
columns listed here are representative of the attribute structure unique to the data layer currently displayed in the 
attribute table as well as the standard MAPublisher property attributes. 

To assign an expression to a column, enter a valid expression in the Expression text box. The Expression Validity icon 
will report  if the expression entered is valid. Otherwise it will report  and include additional warning notes. 
Alternatively, click the Browse button to enter and edit expressions via the Edit Expression tool (page 46). 

The following are some examples of basic expressions which can be assigned to selected data with Apply Expression.
“Ontario” (applied to column = NAME)
Result: All selected items are assigned the value “Ontario” in the NAME column.

“MAP Area 01” (applied to column = #Style)
Result: All selected area items are assigned the value “MAP Area 01” in the #Style column. Same items are assigned the Graphic Style 
“MAP Area 01” on the page.

45 (applied to = #Rotation)
Result: All selected point items are assigned the value 45 in the #Rotation column. Items are rotated to 45° on the page.

Click OK to apply the expression to the selected data, updating the values in the selected attribute column and 
transforming data as appropriate.

Apply Expression 
MAP Attributes panel > Apply Expression

Apply to - Select the attribute column 
on which to apply the expression. 

Attribute and MAPublisher 
Property columns can be assigned 

expressions

Expression - Enter the expression 
directly into the entry field, or click 

the Browse button to access the Edit 
Expression function..

Expression Validity - Indicates if the 
expression is valid  or invalid .. If 
invalid, additional info is reported.
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FUNCTIONALITY

Join Table provides the ability to merge external data tables directly into an existing MAP Layer attribute schema in 
order to create a single extended attribute table. Three of the most common table formats are supported:

• dBase (*.dbf ) 	 • USGS SDTS (*.ddf )	 • Delimited Text (*.csv) (*.tsv) (*.txt)	 • Excel (*.xls) 

When exporting tables from spreadsheet applications for use with MAPublisher the preferred format to use is 
Delimited Text (*.csv).

NOTE:	 dBase tables created or edited in Microsoft Excel must have a proper data type assigned to each column 
through cell formatting before being saved as dbf. For example, numerical values specified in a cell set with 
a format "General" will import as an Integer type by default, therefore loosing all decimal values. 

Users on Windows operating system and with valid ESRI software and license installed on their computer, can join 
table with feature classes and non-spatial tables of ESRI geodatabases (ArcSDE, File and Personal). For information on 
ESRI software requirements for this option, please refer to chapter 19 of this user guide.

PREREQUISITES

In order to successfully join a table into an existing attribute schema, both MAP Layer and data table must share at 
least one common attribute column with matching values. The column must be of a matching type (i.e. String, Real, 
Integer, Boolean) in both the Source and the Destination table. If not, the join table might fail.

Access the Join Table tool by clicking the Join Table button  or options menu item in the MAP Attributes panel.

Join Table 
MAP Attributes panel > Join Table

Data Type- Choose Files or Geodatabase 
formats (Windows only)

Data Set Name- Click the Browse button 
to select the data table to be joined 

Character Encoding - Assign a codec if 
the attribute information held in the 
selected dataset uses a double byte 
character set.

Target Layer - Select the layer containing 
the MAP Attribute table about to be 
joined with the source table

Destination Matching Column - Select a 
column from the destination layer to 
match to a column in the Source Table.

Case sensitive - If checked, values from 
the two matching columns will be 
matched up case-sensitively.

Source Matching Column - Select a column 
from the source table to match to a 

column in the destination layer.

First line contains column names - 
For Delimited Text and Excel type 

tables, check this box to use the first 
line to derive column names.

Worksheet - Specify the worksheet to use 
when a Microsoft Excel file is selected.
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USING JOIN TABLE

Source Data (Files)
Users on Windows with ESRI software must first set the Data type drop-down list to Files (ASCII, Excel, Sdts, Dbf). This is 
the only option for other users.

Click the Browse button to select the data table for import. If a Microsoft Excel file is selected, use the Worksheet drop-
down list to specify the sheet to be used for joining. Then, select a common column by selecting an appropriate 
entry in the Matching Column drop-down list. 

In MAPublisher, double byte characters are supported in attributes on import, allowing such attributes to be used 
for labelling and export. To assign a codec suitable for the selected dataset, choose an appropriate entry from the 
Character Encoding drop-down list.

If the table contains column names as headers, check the First line contains column names option. If it does not contain 
headers, do not check this option and each column will be assigned a default heading name: Column1, Column2, etc.

Source Data (ESRI geodatabases)
Users on Windows operating system and with valid ESRI software and license installed on their computer, can select a 
feature class or non-spatial table of ESRI geodatabases (ArcSDE, File and Personal).

If the Data type drop-down list is set to ESRI ArcSDE Geodatabase, click the Browse button to select the ArcSDE server 
connection and then select the appropriate feature class or non-spatial table. If the Data type drop-down list is set 
to ESRI File Geodatabase or ESRI Personal Geodatabase, click the Browse button to select a feature class or non-spatial 
table. Please refer to chapter 19 for information on ArcSDE server connection and feature class selection.

The attribute selection is the same as for Files source data.

Destination Table
Choose the attribute table to be joined to the data table. This can be achieved by choosing a MAP Layer from the 
Target Layer list. When the destination layer has been selected, select a common column by selecting an appropriate 
entry in the Matching Column drop-down list. This column must match the format and values as the column selected 
in the Source Table section.

Additional Option
If the Case sensitive option is checked, the column entries from the two matching columns will only be matched by 
case. For example, if there is a mix of upper or lower case entries in the data table that is mirrored in the destination 
attribute table, this option should be checked. If one of the matching columns contains values in lowercase, and the 
other contains values in uppercase, for example, then do not check this option.

RESULTS 

The data table is added to the attribute table on the destination MAP Layer and may be viewed in the MAP 
Attributes panel. Notice that the matching column in the data table has also been added, but has been appended 
with a 1 if the column names were identical in the source and destination tables. 
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Add Calculated Data 
MAP Attributes panel options > Add Calculated Data

FUNCTIONALITY

The Add Calculated Data function populates existing or new MAP Attribute columns with values calculated from the art 
geometry or from another column numerical values. The calculation options are:

•	 Geographic information: centroid position for lines and areas or position for points .
•	 Perform statistic calculations based on the overall attribute data of a specified column.

Calculated values are not updated automatically when the source column changes. Add Calculated Data must be 
run again for updates to be applied. 

For single polygons, the centroid can be assimilated to the center of mass of the surface. For single lines, the 
centroid is the mid-point of the line. For polygons or lines grouped into a compound path, the centroid of the 
largest polygon or line is used. 

NOTE:	 The centroid of a Bezier polygon (smoothed path) may not be completely accurate because only the 
anchor points are used to calculate the centroid's position. If necessary, use the Adobe Illustrator Add Anchor 
Points function (Object > Path > Add Anchor Points) before running Add Calculated Data.

Calculated data can be added or updated to all art on a layer or only to the selected art, however statistical 
calculations are based on the entire dataset.

Add Centroid / Position Data

Add Statistics Data

Not available for text layers

/ position
Calculation- Set the type of calculation 

to be performed: 
•	 Centroid (area and line layers)
•	 Position (point layers)
•	 Statistics - see below

Column X - Select or add the attribute 
column to receive the x position value.

Column Y - Select or add the attribute 
column to receive the y position value.

Type - Select the type of coordinates:
•	 Page coordinates: position in 

Adobe document page units
•	 Projected coordinates: available if 

the coordinate system of the MAP 
View is projected

•	 Geodetic coordinates: Longitude/
Latitude position.

Unit - Set the unit when Projected 
coordinates or Geodetic coordinates is 
selected as Type.

Options - Apply the calculation to all art 
or only selected art.

Status -  icon indicates that a new 
column is created,  icon indicates 
that an existing column is being 
updated.

Calculation- Set the type of calculation 
to be performed: 

•	 Centroid / Position - see above
•	 Statistics 

Target - Select or add the attribute 
column to receive statistic values.

Status -  icon indicates that a new 
column is created,  icon indicates 
that an existing column is being 
updated.

Options - Apply the calculation to all art 
or only selected art.

Operation - Specify the operation to be 
perform: Distribution, Deviation, Sum, 
Mean or Standard Deviation.

Source - Select the attribute column to 
be used as source for the calculations.
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PREREQUISITES

Add Calculated Data can populate new or existing attribute columns. Only attributes of type Real can be updated 
so users should make sure that the proper data type are applied to these columns. 

For statistics calculations, the source column must be numerical (Integer or Real type), users may need to use the 
Join Table function to import appropriate numerical data beforehand (e.g. election results per county). (see Edit 
Schema in this chapter)

USING ADD CALCULATED DATA

Make a selection on the MAP layer concerned and click Add Calculated Data from the MAP Attributes panel options menu.

Calculate Centroid or Position
If the selected data is on a MAP layer of type Line or Area, set the Calculation drop-down list to Centroid to calculate 
the x and y position of the line or area centroids. If the selected data is on a MAP layer of type Point, set the 
Calculation drop-down list to Position to calculate the x and y position of points in a specific coordinate format.

In the Column X and Column Y drop-down lists, users have the options to keep the default new column names 	
(new_position_x and new_position_y), type names of their choice, or select an existing column. Only existing 
columns of data type Real are listed.

The positions coordinate format is set in the Type drop-down list. The options are:
•	 Page coordinates: x and y positions relative to the Adobe Illustrator page reference, in page units (as 

specified in the Adobe Illustrator document setup).
•	 Projected coordinates: x and y positions in the source coordinate system of the MAP View containing the 

selected layer (if this system is projected).
•	 Geodetic coordinates: longitude and latitude positions — calculated from x and y positions if the source 

coordinate systems of the MAP View containing the selected layer is projected.

The Unit drop-down list shows a selection of linear or angular units if the coordinate type is set to projected or 
geodetic respectively.

Finally, set the option to calculate the centroid or position to the selected art only or to all art on the current layer.

Calculate Statistics
To calculate statistics based on a source attribute column, set the Calculation drop-down list to Statistics.

The following statistical operations are available:
•	 Deviation: for each row, difference between the current value and the mean.
•	 Distribution: for each row, current value divided by the sum.
•	 Mean: sum of all the row values divided by the number of rows in the source column (same for all rows).
•	 Standard Deviation: measure of the variability or dispersion of the row values in the source column. A 

low standard deviation indicates that row values are very close to the mean, whereas high standard 
deviation indicates that row values are spread out. Calculated as the square root of the sum of all 
deviations squared, divided by the number of rows in the source column (same for all rows).

•	 Sum: addition of all the row values in the source column (same for all rows).
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In the Target drop-down list, users have the options to keep the default new column name (new_stat_col), type a 
name of their choice, or select an existing column. Only existing columns of data type Real are listed.

Then, select the required function in the Operation drop-down list. Deviation and Distribution calculate a value 
specific to each row; Mean, Standard Deviation and Sum create a single value for all rows.

In the Source drop-down list, select the source column from within all numerical attributes of the current layer. 
Users have the option to add calculated data to all art on a layer or only to the selected art, however statistical 
calculations are based on the entire dataset of the source column

NOTE:	 To obtain a distribution in percents, first use Add Calculated Data with the Distribution operation, then use 
the Apply Expression function to multiply the column values by 100 (e.g. COLUMN = COLUMN * 100).

RESULTS

The attributes columns are updated or created according to the specified settings. Note that these new values are 
not updated automatically when the source column changes. Add Calculated Data must be run again for updates to 
be applied. 
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Export Attributes 
MAP Attributes panel options > Export Attributes

FUNCTIONALITY

The Export attributes function exports all selected attribute information from the current MAP Layer to a delimited 
text file—comma, space, tab or semi-colon separated.

PREREQUISITES

Attributes will be exported as they are in the MAP Attributes panel. For example, users can change the number of 
decimals for attributes of type Real prior to exporting (see Edit Schema in this chapter), to limit the size of the exported 
file—or to turn on/off the visibility of some attributes, with Edit Schema or the MAP Attributes panel Show/Hide function. 

USING EXPORT ATTRIBUTES

Export attributes is accessed from the MAP Attributes panel options menu. 

In the Export Attributes dialog box, click the Browse button to navigate to the directory where the exported file will 
be saved and type a file name. By default, the exported file will be appended a .txt extension—to export in another 
delimited text format, type another file extension (*.csv or *.tsv) in the file name (e.g. file.csv).
 Users have the following options to set:

•	 Export all attributes or visible attributes only. 
•	 Set field delimiter in the exported text file to Comma, Semi-colon, Space or Tab.
•	 Export or not the column names on the first line.

RESULTS

A delimited text file is created according to the specified settings. Text attributes (type String) are exported in 
double quotes ("...") in the text file.

File  name - Click the Browse button to 
select the directory and type the file 

name where to save the exported 
attributes.

Scope - Choose to export all the 
attributes or only the visible attributes.

Delimiter - Specify the field delimiter. 
Select Comma, Semi-colon, Space or  

Tab from the drop-down list. 

Include column names on first line - Click 
this option to export the column 
names on the first line of the exported 
text file.
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The ability to place points onto a map is a fundamental part 
of cartography. Points can represent the locations of towns 
and cities, shops and malls, airports and train stations and 
more. MAPublisher provides the functionality to create or 
plot points in vector format. 

There may be times when you wish to quickly add a point 
or a small group of points to your map but you do not have 
a GIS or ASCII file containing these points ready for import. 
Alternatively your map may be in a projection that holds 
coordinates in linear units, yet the coordinates of your point 
locations are in angular units (i.e. degrees). 

Provided you have a fully specified MAP View, and know the 
coordinates (coordinate system and unit can be specified) for 
the locations you wish to plot, you can use the MAPublisher 
Point Plotter to have your points automatically added at their 
correct locations.

Topics covered in this section are:
MAP Point Plotter
Plot Centroids

Plotting 
Points
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MAP Point Plotter 
Window > MAPublisher > MAP Point Plotter and MAPublisher Toolbar 

PREREQUISITES

In order to plot points using the Point Plotter, you must first have a fully georeferenced MAP View in your document, 
as this function will use the coordinate system of that MAP View in order to generate points. Furthermore you must 
create a new Adobe Illustrator layer in which your points will be placed, as the software will not support multiple 
feature types on the same layer. Remember once you have created a Point layer, you must drag it into the desired 
MAP View, specifying  Point in the Define Layer dialog box.

USING POINT PLOTTER

Setting up the Symbol Selection
The symbols used by Point Plotter are a direct reproduction of those that exist in the Adobe Illustrator Symbols panel. 
To open the Adobe Illustrator symbols panel, click the menu Window > Symbols. If you wish to add points to this 
panel, create your symbols as closed Adobe Illustrator objects and drag them into this panel. Alternatively, open the 
MAP Symbols file from the Helpful Styles & Symbols folder on the MAPublisher DVD or local drive (see Appendix 4), and 
drag the symbols into your Adobe Illustrator Symbols panel.

Scale - Change the size of the chosen 
symbol if required. The arrow keys will 
increase or decrease the scale value by 
10% increments.

Style - Choose a symbol to use. Click 
the symbol name to open the list of 
symbols to choose from

Coordinates - Enter the coordinates of the 
point to be plotted either in MAP units 

or in a different choice of coordinate 
system.

Current Layer - Displays the selected 
layer's name and coordinate system. 

Format - Select the input format 
for values in degrees (when input 

coordinate system is geodetic.

Input Coordinate System - Specify the 
reference coordinate system in which 

the point coordinates are entered. Use 
the current layer's coordinate system, 

or specify a different one (by default 
WGS84, latitude-longitude format). 

Click the Select button to open the Select 
Coordinate System dialog box and choose 

any coordinate system.

Plot- Click to plot the symbol after 
coordinates have been entered.

NOTE:	 Points can only be plotted on point layers. The plot button will 
be disabled if another map layer type is the active layer.
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Entering Coordinates
When the Use Current Layer's coordinate system option is toggled, coordinate values can be entered in the current MAP 
units of the coordinate system of the MAP View containing the selected layer. 

When the Use: WGS 84 option is toggled, the Select button will become enabled. Clicking the Select button will open 
the Select Coordinate System dialog box. Choose any coordinate system, the coordinates values entered to plot points 
will be in the unit (Point Style) for this coordinate system.

When the selected or default coordinate system is projected, X and Y coordinates are entered in the unit (Point 
Style) of the coordinate system (e.g. metre, kilometre, feet). When the selected or default coordinate system is 
Geodetic, Lat and Long coordinates are entered in degrees. The values entered into the Latitude and Longitude text 
boxes may be entered in different formats:

•	 Decimal degrees (D+[.d*])
•	 Delimited Degrees Minutes Seconds (D+ MM SS[.s*])
•	 Degrees.Minutes (D+.MM[m*])
•	 Degrees.MinutesSeconds (D+.MMSS[s*])
•	 Packed DMS with decimal point((D)DDMMSS[.s*])
•	 Packed DMS ((D)DDMMSS[s*])

Items in [ ] are optional, * means zero or more digits, + means one or more digits.

NOTES: 
•	 Lines of latitude run East-West (the Equator is an example), whereas lines of longitude run North-South 

(the Greenwich Meridian is an example). Positive degree values represent north latitudes and east 
longitudes. Negative degree values represent south latitudes and west longitudes. Directions can be 
entered either with positing/negative values or using the N, S, E or W letters preceding or following the 
numerical values, separated or not with a space.

•	 Valid delimiters for Delimited Degrees Minutes Seconds format are: 
JJ space, hyphen (-), colons (:) or underscore (_) : e.g. 43 41 48.98N, 43-41-48.98N, 

43:41:48.98N or 43_41_48.98N
JJ d (degree), single quote (minute), double quote (second): e.g. 43d41'48.98"N 

•	 Packed formats require the use of two digits for degrees of latitude (e.g. 1°N must be written 01) and 3 
digits for degrees of longitude (e.g. 1°E must be written 001).

Examples of Latitude/Longitude values
Formats Decimals 

Degrees
Delimited 
Degrees Minutes 
Seconds

Degrees.Minutes Degrees.
MinutesSeconds

Packed DMS with 
decimal point

Packed DMS

Avenza Office:
43°41’48.98”N
79°23’32.38”W
(= 48°41.8163’N | 79°23.5396”W)
(= 48.6969°N | 79.3922°W)

Lat 43.6969N 43d41’48.98”N 43.418163N 43.414898N 434148.98N 43414898N

Long 79.3922W 79d23’32.38”W 79.235396W 79.233238W 0792332.38W 079233238W

Lat 43.6969 43 41 48.98 N43.418163 N 43.414898 434148.98 N 43414898

Long -79.3922 W 079 23 32.38 W79.235396 W 79.233238 -0792332.38 W 079233238

Lat N 43.6969 N 43-41-48.98 43.418163 43.414898 N 434148.98 43414898N

Long -079.3922 W 79:23:32.38 -079.235396 -079.233238 W 0792332.38 -079233238

Warning - Double-quotes (") are supported in MAP Point Plotter, but not in the import of Delimited Text.
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Choosing a Symbol and Scale
After entering coordinate values select an appropriate symbol to use by clicking the symbol name link. Again the 
symbols displayed are the symbols that currently exist in the Adobe Illustrator Symbols panel. To scale the symbol 
used, edit the Scale entry field. Clicking the Up and Down arrows will increase or decrease the value by 10%.

Plotting Points
Click Plot to plot the point in the designated MAP layer. To plot subsequent points, edit the coordinates, and also 
choose different symbols if required and click Plot again.
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Plot Centroids 
MAP Point Plotter panel > Plot Centroids

FUNCTIONALITY

The Plot Centroids function adds point symbols at the center of polygons or line, while copying the attributes from 
the source MAP layer when the New Layer option is selected. This function is useful for cartographic generalization 
purpose (e.g. replacing small island area by a symbol), or to simply add a meaningful symbol at the center of 
areas. For single polygons, the centroid can be assimilated to the center of mass of the surface. For single lines, 
the centroid is the mid-point of the line. For polygons or lines grouped into a compound path, the centroid of the 
largest polygon or longest line is used. 

NOTE:	 The centroid of a Bezier polygon (smoothed path) may not be completely accurate because only the 
anchor points are used to calculate the centroid's position. If necessary, use the Adobe Illustrator Add Anchor 
Points function (Object > Path > Add Anchor Points) before running Plot Centroids on Bezier polygons.

PREREQUISITES

The document must contain a fully georeferenced MAP View that includes a MAP layer of type Area or Line that 
contains art. An existing Point layer may be used as destination layer (Existing Layer option), in which case this layer 
must be included in the file before running the function . Furthermore, the desired symbol must be present in the 
Adobe Illustrator Symbols panel. 

USING PLOT CENTROIDS

Plot Centroids is located in the Point Plotter panel options menu. 
•	 Select first the MAP View that contains the layers concerned by the function.
•	 Select the Source Layer containing the polygons or lines for which the centroids will be plotted (MAP 

Layer of type Area or Line). 
•	 Select the symbol Style and Scale to apply. 
•	 Choose the Destination Layer in which the centroids will be added: select an existing Point layer or create 

a new one. 

The high placement accuracy option makes more advanced calculations for the centroid positions so as to force 
them to fall within the area boundaries (useful for areas with strange shapes, for example some S shape islands).

Source Layer - Select the Area or Line 
MAP Layer containing the paths on 

which the centroids will be calculated.

Destination Layer - Select an existing 
Point MAP Layer or create a new 

one, where centroid symbols will be 
added .

Options: 

Style - Select the symbol to use. The list 
correspond to the symbols present in 
the Adobe Illustrator Symbols panel.

Scale - Select the symbol scale

MAP View - Select the MAP View 
containing the layers of interest (Source 

Layer and Destination Layer)

Use high accuracy - if the selected source 
layer is an Area MAP Layer, check this 
option for a high placement accuracy..
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NOTE:	 When the New Layer option is enabled, the attributes from the source MAP layer are copied to the new 
Point layer. However, when using an existing point layer, attributes do not get transferred unless the Point 
layer was created with its attribute schema based on the same source MAP Layer (see chapter 4 for more 
information on the Base attribute schema on option when creating new MAP layers).

RESULTS

Symbols are added to the specified Point MAP Layer specified. Depending on the type of polygon or line (single or 
compound path), symbols are located on the center of the polygons/lines or at the center of the biggest polygon/
longest line of a group.

Example: result of plotting centroids on a Canadian provincial Area layer.
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Drawing Tools

MAPublisher benefits from Adobe Illustrator drawing tools. Any 
artwork created on a specified MAP layer is incorporated into 
the map data and can therefore be rescaled and reprojected. If 
the new artwork is of the same feature type as the MAP Layer, 
it will be automatically added to the attribute table.

Similarly, objects can be deleted and moved between layers 
with basic Adobe Illustrator tools. Therefore it is very easy to 
quickly add and delete features to MAP Layers.

In addition to this, MAPublisher also provides its own tools for 
creating and managing artwork. MAP Area Tools are designed to 
draw rectangular and elliptical areas of specified dimensions 
in MAP Units. The MAP Vector Crop Tool will trim all the vector 
data (on all active layers) falling outside of a crop area. The 
MAP Measurement Tools allows users to measure distances in 
page or world unit and to save the measuring path as an art.

The topics covered in this section are as follows:
MAP Area Tool
MAP Vector Crop Tool
MAP Measurement Tool
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MAP Area Tools 
Tools > MAP Area Tool (Box)  / MAP Area Tool (Ellipse) 

FUNCTIONALITY

By using the MAP Area tools, areas of exact map dimensions can be quickly added to any MAP Layer and its related 
attribute table. Whenever an area is created using the MAP Area tools, any objects that fall inside the area (in whole 
or part) will be automatically selected. 

USING THE MAP AREA TOOLS

Overview
MAPublisher offers Ellipse and Rectangle drawing tools. Select the shape you require from the main Adobe Illustrator 
Toolbar, and select the MAP Layer which contains the coordinate system on which you want to draw the shape.

There are two methods of using the MAP Area tools. As with Adobe Illustrator shape tools you can either click and 
drag to create a shape at an unspecified size. Alternatively you can single click in the MAP document to open the 
Add Area dialog box, where you specify exact width and height values for the shape.

Drawing via Click and Drag
To draw shapes at unspecified sizes, click and drag over the Map document while holding down the left mouse 
button until the desired area has been outlined, as is done with the standard Adobe Illustrator area drawing tools. 
Use the Alt key (Windows) or the Option key (Mac) to draw from the centre and/or the Shift key to constrain the 
proportions. When you release the mouse button the area will be created.

Entering Specific Dimensions
To draw shapes at specified sizes, single click at a point in your Map document at the location from which you wish 
to plot the shape. The MAPublisher Add Area dialog box will appear into which you can enter specific dimensions for 
the area to be drawn. If you wish to have the area centered over the click point simply check the Center area on click 
box. If you do not check this box an area will be drawn from its upper left corner. Click OK to plot the shape.

RESULTS

Plotting a shape using either of these methods will initially select the features that fall, inside the area (in whole or 
part). Therefore, these tools can be also useful for selecting features that are within designated distances away from 
a central location.

Width/Height - Enter the width and 
height for the area to be drawn.

Center area on click - Check this option 
if you want the area to be drawn 

centered on the click point. Units - Select a map or page unit to be 
used for width and height values.
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MAP Vector Crop Tool 
Tools > MAP Vector Crop 

FUNCTIONALITY

By using the MAP Vector Crop Tool, the entire map drawing (vector data) can be trimmed to a certain area of 
interest. Typically, the tool is meant to crop imported vector data that might be covering a larger area than the 
intended map extents. Used on a copy of the full original MAP View, MAP Vector Crop can also be utilized to create 
map insets (smaller maps centered on specific areas)—see example below.

PREREQUISITES

Before using the MAP Vector Crop Tool, ensure that the layers to be trimmed are visible and unlocked in the Adobe 
Illustrator Layers panel. Similarly, layers that are not supposed to be cropped should be locked or invisible. The extent 
of the map that will remain after cropping must be visible on the screen, so make sure to zoom out sufficiently prior 
to starting the vector crop tool.

NOTE:	 Invisible and locked layers will not be cropped.

Users should save a copy of the Adobe document prior to performing a crop. Due to some Adobe Illustrator 
limitations, text typed on a path might not return to their prior state after an undo.

USING THE MAP VECTOR CROP

Click the MAP Vector Crop Tool button  in the Adobe Illustrator Tools panel, then click and drag a rectangle over the 
artboard. Upon release of the mouse button, the crop function is completed.

If the remaining map is too large, the MAP Vector Crop can be run again on the remaining data.
If the remaining map is too small, the MAP Vector Crop can be undone (menu Edit > Undo) and run again.

RESULTS

On all visible and unlocked layers: 
•	 Text objects that have their anchor outside of the cropping rectangle are deleted. Text objects with their anchor 

inside the cropping rectangle are retained completely.
•	 Points falling outside of the cropping rectangle are deleted (the position of the center of the symbol is relevant). 

Symbols that have their center inside the cropping rectangle are maintained as a whole.
•	 Lines are clipped at the boundary of the cropping rectangle.
•	 Areas (polygons) that are completely out of the cropping rectangle are deleted. Areas intersecting with the 

cropping rectangle are clipped and closed following the edge of the rectangle. 

The overall result is a map coverage reduced to the cropping rectangle outline. Subsequently, the MAP View(s) can 
still be transformed, rescaled etc. See examples on the next page.

NOTE: 	 The purpose of the MAP Vector Crop is to cut vector data types (points, lines and polygons). Some Adobe 
Illustrator specific objects might not be cropped properly using this tool, for example:

•	 Blend and Live Paint objects.
•	 Any art using effects that have been rasterized.
•	 Custom art such as scale bars, grids/graticules, north arrows (expand custom art to crop).
•	 Images cannot be cropped with this tool.
•	 Legacy Text
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Due to an Adobe Illustrator limitation, text on a path may flip after a crop operation. This is corrected by checking the 
Flip option from Type on the Path Options dialog box (choose Type > Type on a Path > Type on a Path Options).

Examples
Crop vector data

Original map
Crop result: lines and area are clipped, text with 1st letter within the 
cropping rectangle and symbol with center point in rectangle are 
maintained. The MAP view can be re-scaled to fit better to the document 
size

Create Inset
•	 Open a map, and make a copy (choose File > Save a Copy). 

Leave the original map open, make the copy the active document.
•	 Use MAP Vector Crop to crop the area of special interest.
•	 Make the original map active. In the MAP Views panel, select the option menu 

Import MAP View from document. Select the MAP View from the copy .

The map now contains two MAP Views (at least). Their relative position can be managed 
from the MAP View Editor, as well as the scale of the inset map. 

	

Edit MAP views: e.g. move inset and change scale		  RESULT

Original

Copy and Crop
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MAP Measurement Tool 
Tools > MAP Measurement Tool 

FUNCTIONALITY

The MAP Measurement Tool measures straight distances (between two points), path distances (multiple points) and 
the perimeter and area of closed paths — in page or map unit (real world distances). Furthermore, the measuring 
path can be converted to a line or area in the currently selected layer. 

PREREQUISITES

To measure real distances on the ground (in map units), the Adobe Illustrator file must contain at least one MAP 
View with an assigned coordinate system.

The map units of the measurement is set in the MAPublisher Preferences for the MAP Measurement Tool. Users can 
select to use the current layer's map unit or select a specific unit. Angular units are used by geodetic coordinate 
systems, linear units are used by projected coordinate systems. The layer's map unit is defined in the coordinate 
system definition of the selected MAP View. The current map unit can be viewed in the MAP View Editor, by clicking 
the information button of the Source Coordinate System (called Point Style in the Definition tab) - see chapter 4 and 
appendix A2 for details. 

The page unit is defined in the Adobe Illustrator document setup. The page unit can be accessed and changed in the 
Document Setup dialog box (Adobe Illustrator menu File > Document Setup).

To enable snapping to art while measuring, turn on the Adobe Illustrator Smart Guides (Adobe Illustrator menu View > 
Smart Guides). The snapping tolerance is set in the Adobe Illustrator Preferences for Smart Guides (Adobe Illustrator 
menu Edit > Preferences > Smart Guides)

USING THE MAP MEASUREMENT TOOL

Click the MAP Measurement Tool button  in the Adobe Illustrator Tools panel to start a new measurement. The mouse 
cursor becomes a cross .

To measure distances in map unit — real world distances — select a MAP layer (i.e. layer belonging to a MAP View) 
in the Adobe Illustrator Layers panel. The unit of the layer's parent MAP View will be used in the measurements. 

To measure distances in page unit — distances on the page — select a non-MAP Layer (i.e. not included in a MAP 
View) in the Adobe Illustrator Layers panel. The unit of the document will be used in the measurements.

NOTE:	 While the MAP Measurement Tool is enabled, users can change the selected layer in the Adobe Illustrator 
Layers panel. If the new selected layer is contained in a different MAP View, the distance values are updated 
accordingly on the screen automatically without having to start a new measurement — e.g. if the MAP 
View scale is different, the measurement will significantly change. 

 
If the Adobe Illustrator Smart Guides are enabled, the MAP Measuring Tool can snap to existing anchor points. 
When the mouse cursors is near enough a point, Adobe Illustrator highlights it as shown in the image below.
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Measure Straight Distance
By default, the MAP Measurement Tool measures straight distances (distance between two points). 

Click a starting point to begin measuring. As the mouse moves on the artboard, a distance label indicates the 
distance from the starting point to the current mouse position. A second click digitizes the end point. As soon as 
the second point is clicked, the measurement is ended and the total distance is displayed.

When the measurement is finished, the user has the option to:
•	 Click once to clear the measuring line and label, or
•	 Click while holding the Shift key to convert the measuring line to an Adobe Illustrator art object (added 

to the currently selected layer), applying the currently selected stroke setting.

A new click on the page starts a new measurement. To exit the MAP Measurement Tool, select another tool in the 
Adobe Illustrator Tools panel.

Measure Path Distance
Click a starting point to begin measuring. Before clicking a second time, hold down the Shift key. The cursor 
changes from  to . A new point is added on the path, but the measurement does not end.

Keep holding the Shift key while adding more points along the path. As the mouse moves on the artboard, a total 
distance label indicates the length of the path already digitized and the distance from the last added point to the 
current mouse position. 

While digitizing the measuring path, hold the Alt key (Windows) or Control key (Mac OS) to display the length of each 
digitized path segment.

Before adding the last point, release the Shift key. As soon as the last point is clicked, the measurement is ended 
and the total distance is displayed. Hold the Alt key (Windows) or Control key (Mac OS) while clicking the last point 
to display all annotations (segment lengths and total distance).

When the measurement is finished, the user has the same options: click once to clear the measuring path and label, 
or click while holding the Shift key to convert the measuring path to an Adobe Illustrator art object (added to the 
currently selected layer), applying the currently selected stroke setting. 

A new click on the page starts a new measurement. To exit the MAP Measurement Tool, select another tool in the 
Adobe Illustrator Tools panel.
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Measure Perimeter and Area
To measure the perimeter and area of a closed path, follow the same steps as the measure of a path distance. When 
digitizing the last point, release the Shift button and place the mouse cursor over the start point — a box is drawn 
around the starting point — click to close the path and end the measurement.

Hold the Alt key (Windows) or Control key (Mac OS) while digitizing to display the length of each segment.

NOTE: 	 Holding down the Shift key while clicking the start point again prevents the path from being closed and 
the measurement can continue.

When the measurement is finished, the user has the same options: click once to clear the measuring path and label, 
or click while holding the Shift key to convert the measuring closed path to an Adobe Illustrator art object (added 
to the currently selected layer), applying the currently selected fill and stroke setting.

MAP Measurement Tool Preferences
The MAP Measurement Tool Preferences are accessed by double-clicking the MAP Measurement Tool button  
on the Adobe Illustrator Tools panel or from the menu Edit > MAPublisher Preferences > MAP Measurement.

Users can set the number of decimals for the measurement values, the digitized path colour and new segment 
colour. See chapter 1 for more information on MAPublisher Preferences.
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The Adobe Illustrator environment offers lots of flexibility 
when working with vector art. MAPublisher offers graphics 
specific line tools, which is discussed in detail in this chapter.

Buffer Lines allows for the creation of a buffer around current 
lines at designated distances in map units. 

Flip Lines can be used to swap the start and end points of 
lines if these line strings were not originally digitized in a 
preferable manner. 

Join Lines can be used to connect line segments into 
continuous line strings or compound paths based on a 
specified attribute column.

Join Points allows for point symbols to be joined based on 
attribute values. This tool will generate a line string joining 
common points, and is ideal for GPS data.

Simplify Lines allows for the removal of vertices from selected 
lines based on mathematical formulae.

Topics covered in this section are:
Buffer Lines
Flip Lines
Join Lines
Join Points
Simplify Lines

Line 
Functions
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Buffer Lines 
Object > Filters > MAP Lines > Buffer Lines* or MAP Toolbar 

FUNCTIONALITY

The MAPublisher Buffer Lines filter creates buffer Area objects around the line work. This can be useful if you are 
attempting to calculate distances on each side of a line. An example use this tool could be in the planning of new 
roads, where the actual width of the highway is a major consideration.

PREREQUISITES

To use Buffer Lines, the select artwork must be on a MAP Layer of type line  Line layer.

USING BUFFER LINES

Select the line(s) to buffer click the menu Filter > MAP Lines > Buffer Lines or the MAPublisher toolbar button  .

The buffer value for lines can be entered as a fixed a value or by selecting an attribute column that contains buffer 
values. The buffering value specified designates the total width of the new area object. For example, a value of 10 
map units would create a buffer of 5 map units on either side of the selected line. This works on individual lines or a 
selected set of lines. The buffer width is calculated and created using the units of measurement set in the dialog box.

1.	 Set the unit to use for the buffer value from the Units drop-down list. 

2.	 Then choose which option to use for the buffer values. When the Buffer Lines filter is run with the Attribute 
Value option checked, an area width is calculated based on the value(s) related to the selected object(s) in the 
attribute table. The area will then be constructed based on the line’s attribute value. When the filter is run 
based on a Static Value, an area object is created by the specified value.

 
3.	 Choose the  Area layer to place the buffer(s) (choose an existing layer or create a new one), then click OK to 

generate the areas. 

* In Adobe Illustrator CS3, Buffer Lines is found in the Filter > MAP Lines menu.

Static Value - If you want to enter a 
specific value to buffer the selected 

lines by, click this option and enter the 
value in the adjacent entry field.

Attribute Value - If your line data has 
a column in its attribute table that 

contains buffering values, click 
this option and select the column 

containing the value.

Units - Select a unit to use for the buffer 
values. The default is the current map unit.

Destination- Select the Area layer which 
will hold the buffered objects or choose 
to create a new layer..
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Flip Lines 
Object > Filters > MAP Lines > Flip Lines* or MAP Toolbar  

FUNCTIONALITY

The MAPublisher Flip Lines filter reverses the endpoints of a line or an area (open or closed path). 

Adobe Illustrator Brushes and Type on a Path tools are designed to position patterns and text depending on the 
direction of the endpoints. Two consequences of this are:

•	 Cases occur when labels are placed upside down and backward when using the MAPublisher labelling 
tools (MAP Tagger tool and Feature Text Label, see chapter 10 Labelling Functions).

•	 When applying graphic styles with a brush pattern to paths (manually or using MAPublisher MAP 
Stylesheets), sometimes patterns are not applied at the right side of the line or in the expected orientation.

In order for the labels or patterns to be consistent for a group of lines, flipping some of the lines may be necessary.

Lines can be flipped on  Line layers and  Area layers. In order to use this filter, select the lines to be flipped, and 
then go to Filter > MAP Lines > Flip Lines, or use the MAPublisher toolbar button .

NOTES: 	
•	 When exporting Area layers to GIS formats, polygon outlines must have a positive #Area value in the 

MAP Attributes panel. If some values in the #Area column are negative (and #AreaDirection is equal to 
Counter Clockwise), Flip Lines can then be used to reverse the #AreaDirection and convert the #Area to a 
positive value. 

•	 For compound paths, the #AreaDirection property is equal to Indeterminate, therefore compound paths 
cannot be flipped.

•	 The MAPublisher MAP Tagger tool or Feature Text Label, have an option to enable Flip upside-down labels to 
create text in a consistent orientation, without requiring the use of the Flip Lines function (see chapter 
10 for details).

* In Adobe Illustrator CS3, Flip Lines is found in the Filter > MAP Lines menu.
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Join on Attribute - Select the column 
you wish to base the join on. All 

lines within the selected proximity 
with matching column values will 

be joined.

Destination Layer - Enter the name of 
the output layer. This new layer will 

contain the newly joined lines.

Join Lines 
Object > Filters > MAP Lines > Join Lines* or MAP Toolbar 

FUNCTIONALITY

The Join Lines filter allows a group of linear features to be joined based on a common value within an attribute 
column. For example, it may be desirable to join all segments of a particular street by the common attribute of 
street name in order to create a single line element representing that street. When the Join Lines filter is run a new 
layer is created containing the joined lines in order to avoid deleting other attributes within the original street layer. 
The new MAP Layer contains the joined lines with an attribute column representing the joined column. 

Join Lines can be very useful for reducing the size of a data file by joining related lines and thus reducing the 
number of segments and associated data present in the file. It is also very useful to run Join Lines prior to labelling 
with Feature Text Label in order to reduce the occurrence of duplicate labels (see chapter 10 Labelling Functions).

PREREQUISITES

This tool can be executed on selections on  Line layers. To access Join Lines, choose Filter > MAP Lines > Join Lines or 
click the MAPublisher toolbar button .

USING JOIN LINES

In the Join on attribute drop-down list, select the attribute column containing the attributes you wish to join. For 
example to join lines based on street name, the column containing the street names should be selected. This will 
result in line segments containing the same street name being joined. 

In the Destination Layer text box, specify a name for the new  Line layer that MAPublisher will create to hold the 
joined lines.

A Proximity value should be entered and proximity Units assigned. Units can be specified in map units or page units. 
Entering a proximity value of zero will only join line segments that are touching. If the distance between the end of 
a segment and the start of another is greater than the set proximity value, these lines will not be joined. If two line 
segments in the selection are separated by a distance less than the set proximity value, check the Close Segment Gaps 
option to create a line segment that connects the two lines. When not selected a compound path will be created.

When the settings are entered, click OK. On the newly created Line layer view the layer’s attributes in the MAP 
Attributes panel. Note that the only attribute columns present are the default #Property columns and the attribute 
column specified for the join.

Proximity - Assign a proximity value 
in the current unit. This value 
determines how close together (in 
map units) the lines must be in order 
to be joined.

Proximity Units - Select a map or page 
unit to be used for proximity values.

Close Segment Gaps - If two line segments are separated by 
a distance less than the Proximity, selecting this option 
will create a line segment that connects the two lines 
otherwise a compound path is created.

* In Adobe Illustrator CS3, Join Lines is found in the Filter > MAP Lines menu.
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Join Points 
Object > Filters > MAP Lines > Join Points* or MAP Toolbar 

 Input Layer - Use this drop-down list to 
select the Point layer containing the 

symbols you wish to join.

All Points / Selected Points
 You can choose to join only those 

points that have been selected or all 
points on the selected MAP Layer.

Close paths - Check this option to 
generate an Area layer. If unchecked, a 

Line layer will be generated.

Sort By Available Columns - Select an 
attribute column containing  

ascending values to sort by. Then click 
the Add button to add the column to 

the Sort Order.

Destination Layer - Enter the name of the 
output layer. This new layer will contain 
the generated lines.

Group By - Specify the attribute column 
containing similar values to determine 
each group of points.

Sort Order - Contains a hierarchical list of 
the columns specified to sort by. 
To remove a column from the Sort 
Order, click the Remove button.

Move Up / Move Down - You can move 
columns up and down the 
Sort Order hierarchy by clicking the 
appropriate button . 

FUNCTIONALITY

The Join Points filter allows a group of point symbols to be joined to form a line, based upon sorting criteria which 
exist in the attribute structure of the point layer. For example, it may be desirable to join points that were originally 
generated by a GPS device, in order to create line elements connecting these points. When the Join Points filter is 
run a new layer is created containing a line linking each set of common points, with the generated layer containing 
the same common attribute column that was used to group the points together. 

PREREQUISITES

Join Points can only function on  Point layers, and can be used on both currently selected point symbols or all the 
point symbols on a specified layer. There must be at least two attribute columns on the specified point layer in order 
to use Join Points. To open the dialog box, choose Filter > MAP Lines > Join Points or click the MAPublisher toolbar 
button .

USING JOIN POINTS

From the Input Layer drop-down list, select the Point layer containing the points to be joined. Then specify if All Points 
should be joined, or just the Selected Points on this layer, by selecting the appropriate option. 

Specify a name for the Output Layer that this function will generate. By default, the program will generate a 
 Line layer. To generate an  Area layer (by linking the line end to the start) check the Close paths option. 

In the Group By Column drop-down list, select the attribute column containing the common attributes used to join 
the point together. For example to join points based on a unique ID, select the column containing the common ID 
names. This will result in point symbols containing the same name being joined together. 

* In Adobe Illustrator CS3, Join Points is found in the Filter > MAP Lines menu.
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Because each point that is joined will be represented by a node in a line string, a logical order by which the points 
are be joined must be specified. For example, it is logical that the point which was captured by a GPS unit first 
should be the first node in the line string, with the second and third points being located at the second and third 
nodes. In order to specify these parameters, choose columns by which to sort your points. These should be attribute 
columns which contain rising alphabetical or numerical values. 

In the Sort By Available Columns list, select the primary sorting column. This should be the attribute column that 
contains the best fit for rising alphabetical or numerical values. For example if points have rising values from 1–10, 
the point with a value equal to 1 will be at the start of the generated line, and the point with a value equal to 10 will 
be at the end of the line. Select first a column and then click the Add button to place the column into the Sort Order 
list. If all the values contained in the first Sort By column are unique,it is not required to set a secondary column. 

If the first Sort By column contained any similar values, a secondary column must be specified. Again click a column 
in the Sort By Available Columns list, and then click the Add button to place the column in the Sort Order list. Similarly 
third, fourth and fifth Sort By columns can be specified in the same manner if previous columns contain similar 
values. Note that the Sort By columns are a hierarchy with the topmost specified column being used for the primary 
sort, then the second, then third, etc. 

To move columns up or down the hierarchy after they have been specified, simply select the appropriate column in 
the Sort Order list and click either the Up or Down button. 

To remove any Sort By columns from the hierarchy, select the column in the Sort Order list and click the Remove button. 

Note that a maximum of five columns can be used to sort points into a logical order. If the columns specified to sort 
by do not distinguish an ordering between certain points, the order of these points in the attribute table will be 
used to determine the order of the nodes in the generated line string.

RESULTS

When all the options have been set click OK to join the points on the specified layer. An  Area or  Line layer will 
be generated, depending on the specified output layer type, which will be placed in the same MAP View as the 
Input Point layer which has been joined.
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Unit- Select page unit or map units 
(angular or linear unit list depending 
if the map coordinate system is 
projected or geodetic) used for 
proximity tolerance. 

FUNCTIONALITY

The MAPublisher Simplify Lines filter allows for the simplification or generalization of imported vector data. The 
Simplify Lines function uses the popular Douglas-Peucker algorithm for removing nodes and vertices during 
simplification. For more information on the Douglas-Peucker algorithm see Appendix A1.

Simplify Lines is used to reduce the number of points required to represent a vector-encoded line where the lines 
are approximated by a stream of X-Y coordinates. The function can be used on  Line or  Area layers and removes 
nodes based upon a proximity value in either Page Units or Map Units. The list of Map Units depends on the MAP View 
coordinate system—e.g. angular units (page units, degrees, etc) for geodetic coordinate systems; linear units (such 
as metre, feet) for projected coordinate systems.

The Proximity value or simplification tolerance is based on the vertical difference between the begin-end line 
and points off a line, not the distance between anchor points on the line. The Douglas-Peucker algorithm takes 
the proximity value and iterates through the line vertices to determine the points that fall within the specified 
proximity distance off the line and removes those vertices. Once all vertices are determined to be greater than the 
proximity value the line processing ends. A smaller proximity value will usually result in a fewer number of nodes 
being removed.

USING SIMPLIFY LINES

To access the function choose Filter > MAP Lines > Simplify Lines or the MAPublisher toolbar button . Enter a 
proximity value in Page Units or Map Units by making a selection from the Units drop-down list. Page Units will be 
simply the units of the current document. Enter a proximity value in the unit specified by typing a value or by using 
the arrows. 

Click the Preview button to see the simplification result. Once the result is correct, click OK to perform the actual 
simplification. It is always a good idea to experiment with different proximity values in order to achieve the desired 
results particular to the scale and coverage area.

Simplify Lines 
Object > Filters > MAP Lines > Simplify Lines* or MAP Toolbar 

Preview- Display a preview on the 
artboard before running the tool.

Proximity - Set the simplification 
tolerance (type in or use arrows).

Vertex Count - Displays the number 
of vertices in the original and 

simplified line after clicking the 
Preview button.

* In Adobe Illustrator CS3, Simplify Lines is found in the Filter > MAP Lines menu.



114 Chapter 8: Line Functions
Simplify Lines 

RESULTS

All selected lines or areas are simplified according to the settings. Simplified lines or areas will not be simplified 
again unless the tolerance value is increased. For example, if a line has been simplified with a proximity of 1.5 km., 
then it will not be simplified again until the tolerance is set to a value larger than 1.5 km.

In practice, it means that simplified lines can be selected again with non-simplified lines to run the function again, 
when the Simplify Lines function is run only the new lines will be simplified (unless the proximity value is increased).

NOTES: 	
•	 It is a good idea to perform simplify lines on artwork before exporting a Flash map. This will reduce the 

size of the file and therefore it will have a faster rendering time.
•	 To smooth the appearance of paths using Bezier curves, use the Adobe Illustrator function Simplify Lines 

found in the menu Object > Path > Simplify.
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MAPublisher provides extensive tools for quick, easy and 
accurate styling of points, lines, areas and text. This function 
is able to read and work with the data found in the MAP 
Attributes panel and to apply symbols, graphic styles and 
character styles to artwork according to specified legend 
criteria.

The topics covered in this section are as follows:
MAP Stylesheets Panel
MAP Stylesheet Editor
Create MAP Stylesheet Legend

MAP 
Stylesheets
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MAP Stylesheets Panel 
Window > MAPublisher > MAP Stylesheets or MAP Toolbar 

MAP Stylesheet List - An alphabetical list of 
the MAP Stylesheets and associated MAP 
Layers in the current document. Both are 

depicted with their feature type.

Lock button - Click this button to lock or 
unlock the layer.

No MAP Stylesheet - Lists the MAP Layers 
which are not associated  

to any MAP Stylesheet.

Panel Options Menu
New MAP Stylesheet - Opens the New 
Stylesheet dialog box to specify a name 
and feature type for the new stylesheet.

Duplicate MAP Stylesheet - Creates a duplicate 
of the selected MAP Stylesheet.

Edit MAP Stylesheet - Opens the MAP 
Stylesheet Editor dialog box to edit the 
selected MAP Stylesheet.

Delete MAP Stylesheet - Deletes the selected 
MAP Stylesheet.

Create MAP Stylesheet legend - Creates a legend 
using the selected MAP Stylesheet rules.

Preferences - Opens MAPublisher Preferences 
on the MAP Stylesheet Panel property 
sheet (see chapter 1)

Name - Specify a name for the new
MAP Stylesheet.

Feature Type - Specify a feature type for the 
stylesheet: Area, Line, Point or Text.

New MAP Stylesheet

FUNCTIONALITY

MAP Stylesheets allow to quickly create and apply legends (or expression rules) based on MAP Attributes using 
symbols, graphic styles, and character styles that exist in the respective Adobe Illustrator panels. Stylesheets are 
created using specific values contained in the MAP Attributes panel for the related MAP Layer assigned to the MAP 
Stylesheet and then stylized using Adobe Illustrator symbology, graphic styles or character style. MAP Stylesheets 
can be applied to data on both a one to one basis, where specific attribute values are assigned with a specific style 
or symbol (i.e. Style 1 = Value A) or with attribute value ranges (i.e. Style 2 = Greater than Value B and Less than 
Value C). Stylesheet information are saved in the Adobe Illustrator file..

USING THE MAP STYLESHEETS PANEL

To open the MAP Stylesheets panel, choose Window > MAPublisher Panels > MAP Stylesheets or click the Stylesheets 
button on the MAPublisher toolbar .

The MAP Stylesheets panel contains a list of all MAP Layers. Similar to MAP Views, the icons used for these layers are:

By default all MAP Layers will be listed as not belonging to a stylesheet—  [No MAP Stylesheet]. When a new MAP 
Stylesheet is created, drag a MAP Layer into it. This loads its attributes for creating legend rules or expressions.

Area Layer

Text Layer

Line Layer

Point Layer

Delete MAP Stylesheet - Deletes the selected 
MAP Stylesheet.

New MAP Stylesheet - Opens the New 
Stylesheet dialog box to specify a 
name and feature type for the new MAP 
Stylesheet.

Switch MAP View - Click this button to 
switch the selected layer from one MAP 

Stylesheet to another. Remove from 
Stylesheet moves the selected layer to 

[No MAP Stylesheet] section
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Loading Symbols and Styles
The symbology used by MAP Stylesheets is directly related to the symbols and styles which exist in native Adobe 
Illustrator panels. In order to correctly function, the MAP Stylesheet requires that symbology or styles appropriate 
to the feature type is established in the following Adobe Illustrator panels:

 Area Stylesheets:	 Graphic Styles panel (Window > Graphic Styles)

 Line Stylesheets: 	 Graphic Styles panel (Window > Graphic Styles)

 Point Stylesheets:	 Symbols panel (Window > Symbols)

 Text Stylesheets: 	 Character Styles panel (Window > Type > Character Styles)

Symbology can be quickly added to these panels by dragging and dropping artwork from the artboard, or by 
dragging and dropping symbology from custom libraries.

As an example under Window > Graphic Style Libraries > Other Library… navigate to the Helpful Styles & Symbols Files 
folder (see Appendix 4) on the MAPublisher DVD and load either MAP_AreaStyles.ai or MAP_LineStyles.ai. Then 	
shift-select these styles and drag them into the Graphic Styles panel for use in Area and Line Stylesheets.

Another option is to navigate to Window > Symbol Libraries > Other Library… and load MAP_PointSymbols.ai. Then 	
shift-select these symbols and drag them into the Symbols panel for use in Point Stylesheets.

NOTE: 	 An Adobe Illustrator file saves all the symbols, graphic styles and character styles created. Create a master 
file with all often used symbols, graphic styles and character styles for easy reference when adding these 
elements for MAP Stylesheet creation.

Creating a New Stylesheet
To create new MAP Stylesheets, first select New MAP Stylesheet… under the Options menu, or click the New button at 
the base of the panel. This opens the New Stylesheet function, where the name and feature type for the new MAP 
Stylesheet is specified . Clicking OK creates the new stylesheet in the panel and assign it with the appropriate type 
icon. It is possible to now drag single or multiple MAP Layers with a matching feature type into this stylesheet.

NOTE:	 Layers do not need to contain the same attribute structures to be under a same MAP Stylesheet, as long as 
they are all of a matching feature type.

Deleting and Duplicating Stylesheets
A document can contain as many MAP Stylesheets as desired. The MAP Stylesheets panel options menu offers 
functions to delete and duplicate stylesheets. 

Selected MAP Stylesheets may be deleted by clicking the Delete button at the base of the panel or by selecting Delete 
Stylesheet in the panel options menu. Only empty stylesheets can be deleted. Associated MAP Layers must be moved 
to [No MAP Stylesheet] or into another stylesheet via drag-and-drop or with the new Switch MAP Stylesheet button 

. Only at this stage will the Delete option be activated. Note that moving a stylesheet to [No MAP Stylesheet] 
will not restore the data to its default symbology; it will simply remove the relationship between attribute value and 
style/symbol.
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Duplicate Stylesheet can be used to create copies of existing stylesheets. Even though the copy will not contain a MAP 
Layer at first, the style rules which exist between attributes of the original layer and the symbology will be retained. 
This is useful to create different versions of a map: for each stylesheet duplicate, edit the styles that relate to each 
value in each stylesheet. To apply the different styles, MAP Layers only need to be moved from one stylesheet to 
another via drag-and-drop or with the new Switch MAP Stylesheet button .  
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MAP Stylesheet Editor 
MAP Stylesheets panel > Edit

FUNCTIONALITY

The  MAP Stylesheet Editor contains the rules applied to link certain attribute values with symbols or styles taken 
from the Adobe Illustrator panels (Symbols, Graphic Styles or Character Styles). In this interface, users create or 
remove rules that are defined by:

•	 Name: editable, 
•	 Style: selection from the Adobe Illustrator panels, 
•	 Expression: conditions on the attribute values, using Simple or Advanced methods,
•	 Scale: modify the scale of the selected symbol or the stroke of the selected graphic style.

NOTE:	 A style (symbol, graphic style or character style) can only be used once per MAP Stylesheet. To use a same 
style for multiple rules, the style must first be duplicated in the appropriate Adobe Illustrator panel.

PREREQUISITES

The desired symbols, graphic styles or character styles must be present in the Adobe Illustrator document. See 
previous section on Loading Symbol and Styles, or refer to the Adobe Illustrator documentation on how to create 
new symbol and styles. All Adobe Illustrator symbols and styles are supported by the MAP Stylesheet.

As stated above, users may want to duplicate some symbols prior to accessing the MAP Stylesheet Editor. Besides, it 
maybe useful to rename symbol and styles with a convenient convention to make the selection more easy.

Name - Editable name of the 
MAP Stylesheet.

 Rules - List of styling criteria 
in a hierarchical format.

Move Up/Down - To adjust the 
order in which the rules 

will be applied to .

 Rule Name - Editable name 
of the style rule.

Style† - List of established 
Graphic Styles (for area 

and line stylesheets), 
Character Styles (text 

stylesheets) or Symbols 
(point stylesheets).

Add/Remove - To add a new 
style rule or delete the 
currently selected rule.

Scale - To scale the symbols 
in point stylesheets or 
stroke in area and line 
stylesheets.

Expression - Click to edit 
the expression assigned 
to each style rule (*see 
below).

Expression Mode  
Select the style of the 
display for creating 
expressions (*see below).

*Simple Expression
To compose and edit expressions in Simple Mode

*Advanced Expression
To compose and edit expressions in Advanced Mode

Column - Lists the attribute 
column(s) of the associated 

MAP Layers.

Range operator - Click to 
activate the second row to 
enable the composition of 

range expressions. Value - List of 
values in the 
selected column.

Comparison - List of operators 
(Equal to, Greater than, Less 

than or equal to etc)

Expression - Enter the 
expression directly into 
the entry field, or click the 
[...]button to access the 
Expression Builder dialog box 
(see chapter 5).

Expression Validity - Indicates if the expression is  valid or  
invalid. If invalid, additional information is reported.

† For Text stylesheets, if the  Style list does not contain a recently created character style, simply return to the Character Style panel, double-click 
this style and click OK in the Character Style Options dialog box. This forces Adobe Illustrator to re-load the list of character styles.
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USING MAP STYLESHEET EDITOR

Select a MAP Stylesheet that hosts at least one MAP Layer, click the stylesheet name, and choose Options > Edit… 
Alternatively double-click the new MAP Stylesheet.

The Name of the current MAP Stylesheet is displayed at the top of this dialog box, which is editable. Also an icon 
representing the feature type is displayed. 

Click the Add button to create new rules in the MAP Stylesheet. 

Assigning a Style Rule Name
The Style Rule Name column contains the name of the rule. This can be edited to describe the style rule and/or its 
intention. This name is used when creating MAP Stylesheet legend so it is a good practice to do so. For example, 
style rules could be named "Roads" or "Cities with populations over 200,000".

Selecting Styles and Symbols
The Style field will contain a list of styles that currently exist in the Adobe Illustrator Graphic Styles panel (for Area and 
Line stylesheets), in the Symbols panel (for Point stylesheets), or in the Character Styles panel (for Text stylesheets). For 
each rule, choose a style or symbol to use. The Move Up and Move Down buttons moves the priority of the selected 
style up or down the list.

Assigning an Expression
The Expression field describes the criteria for applying the style rule. By default, the field displays the currently 
entered expression, if any. Clicking the Expression field opens either the Simple Expression panel or the Advanced 
Expression panel, depending on the Expression Mode and the current expression. Using the Advanced Expression, 
expressions created in the MAP Selection Filters may be re-used to create MAP Stylesheets rules. See chapter 5 for 
more information on the Expression Builder and chapter 11 on MAP Selection Filters.

To choose the mode in which to compose your expression, select the Simple or Advanced option. Then assign an 
expression for each rule using the guidelines below.

NOTE:	 Property and read-only attributes cannot be selected in the Simple Expression mode. To use property and 
read-only attribute values, use the Advanced option.

Simple Expressions...
�The Simple Expression panel is intended to facilitate quick expression generation. First, select a column from 
the drop-down list, or manually type in a name.

Choose a Comparison. There are six options available:

	 =	 Equal to				    >=	 Greater than or equal to
	 > 	 Greater than			  <=	  Less than or equal to
	 <	 Less than			    	 !=	 Not equal to	

�Select the Value against which the comparison will be applied. Select the value from the drop-down list or enter 
the value manually. Similarly, the value does not have to appear in the list to be valid.
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�If a Comparison is select (except Equal to, (=)), then the expression can be further. Clicking the Range operator 
check box enables an additional Comparison and Value input pair. 

If the operator Equal to (e.g. Attribute1 = A) is selected, when this rule is selected while clicking the Add button, 
the new expression will be automatically written using the same attribute Equal to the next value on the list 
(e.g. attribute1 = B). This does not occur with the other operators.

Advanced Expressions...
The Advanced Expression panel allows to construct more complex expressions and to use read-only and 
property attributes.

�Enter a valid expression in the Expression field. The Expression Validity icon will report  if the 		
expression entered is valid. Otherwise it will report  and include additional warning notes. Alternatively click 	
on the Browse button to enter and edit expressions via the Expression Builder dialog box (see chapter 5).

Advanced expression are saved in memory for the time of the Adobe Illustrator session and can be selected in 
the Recent list of the expression builder.

The following are some examples of basic expressions which can be entered for styling rules:

NAME = “Ontario”
Result: All items with the value “Ontario” in the NAME column are assigned the selected style.

POPULATION < 1000000
Result: All items with values less than one million in the POPULATION column are assigned the selected style.

NAME = “Ontario” OR NAME = “Alberta”
Result: All items with the value “Ontario” OR “Alberta” in the NAME column are assigned the selected style.

NAME = “Ontario” AND POPULATION < 1000000
�Result: Only items containing the value “Ontario” in the NAME column AND values less than one million in the 	
	 POPULATION column are assigned the selected style. 

NOTE:	 String values are case-sensitive and must be entered between double quotes (“...”).

Assigning a Scale
The Scale default is 100%. Editing the scale will alter the symbol size (points) or stroke weight (areas and lines). The 
maximum scaling factor is 1000%.

Building the Stylesheet
For subsequent style rules proceed in the same manner. Click Add, and then specify a Name, Style, Expression and Scale. 
Click the Apply button at any time to preview the results at any stage of building a stylesheet, while continuing to 
edit the settings for individual style rules. In order to delete a style rule from the list, click anywhere in its row to 
select it and click the Remove button.

Click OK to exit the dialog box and to assign the MAP Stylesheet to the associated MAP Layers.
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IMPORTANT NOTES

Dynamic Style Linkage
Once a MAP Stylesheet has been assigned with styles and symbols, those styles and symbols are dynamically linked 
to the attribute values. Consequently, when the attribute value is changed, the style/symbol is updated accordingly 
in the Adobe Illustrator document.

Additionally, if a MAP Stylesheet uses a simple equality expression on a non read-only or property attribute, manually 
applying a style/symbol to an object of a layer contained in that MAP Stylesheet will assign the corresponding 
attribute value to that object. Note that this only work if no rule already applies to that object.

A simple equality expression uses only one attribute and only one equality operator. For example AttributeA = 1 is a 
simple equality expression, while AttributeA > 15 is not.

For example, if MAP Stylesheet has a rule as follow, and contains a layer named point of interest:

Adding the restaurant symbol  on the same point of interest layer, will automatically assign the value "restaurant" 
to the CATEGORY attribute of the newly created art.

Caution should be used with manually editing the styles of artwork after MAP Stylesheets have been applied if 
any style rules have simple equalities. For this reason, it is generally recommended to remove layers from MAP 
Stylesheets when the styling is finalized.

Point Data
Regarding the editing of Point Data, the MAP Stylesheets or the MAP Attributes panel may be used to change 
symbology. As point data is linked dynamically to a symbol choosing Break Link to Symbol from the Symbols panel 
options will result in the loss of attributes for the point data. However symbols may be edited manually in isolation 
mode (double-click on the symbols in the Symbols panel).

Expression Modes
The Expression Mode determines which type of expression panel is used to edit a style rule’s expression. The 
expression mode will be remembered from the last session. 

If the Expression Mode is set to Advanced, the expression panel will always be the Advanced Expression panel, 
irrespective of the expression being edited. 

If the Expression Mode is set to Simple, the expression panel will be the Simple Expression panel, unless the 
expression to be edited is not a simple expression. A Simple Expression is one that is either empty or includes only 
one attribute and no more then two clauses using simple operators (=, !=, inferior, superior, AND). For example:

Simple Expression: 	 AttributeA = 1
Simple Expression:	 AttributeB < 5 AND AttributeB > 1
Advanced Expression:	 AttributeC > 1 OR AttributeD > 10 
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Create MAP Stylesheet Legend 
MAP Stylesheets panel > Create MAP Stylesheet Legend...

FUNCTIONALITY

A legend can be quickly created using any MAP Stylesheet. Any area, line, point or text MAP Stylesheets can be used 
for a legend. The legend is composed series of boxes (for areas or lines), point symbols or words Style — using the 
style/symbol set by the rule — followed by the expression associated with that MAP Stylesheet rule.

 Area MAP Stylesheet Legend

 Point MAP Stylesheet Legend

 Line MAP Stylesheet Legend

 Text MAP Stylesheet Legend

Style preview Associated style/symbol 
for the MAP Stylesheet rule.

Rule name - name of the MAP 
Stylesheet rule.

Rule expression - Expression used for 
the MAP Stylesheet rule

Output Layer - Select a layer of 
feature type legend.

Style preview - Include or not a 
preview of the style (box with 

graphic style applied).
Preview size- Specify the size 
of the box  representing 
line and area styles.

Rule name - Include or not the 
name of the rule.

Rule expression- Include or not 
the rule expression

Area/Line Stylesheets Legend

Point Stylesheets Legend

Text Stylesheets Legend

Actual size- Use the actual 
symbol size from the 
Symbols panel.

Preview size- Specify a fix 
size for all symbols.

Style preview - Include or not a 
preview of the word style with 

a character style applied.

Style preview - Include or not a 
preview of the style (symbol).
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USING CREATE MAP STYLESHEET LEGEND

MAP Stylesheet legends are added to a legend layer, a  Legend layer must be created first using the MAP Views 
panel Add button, choosing a feature type Legend (see chapter 4).

Select the MAP Stylesheet to use as base for the legend, then select Create MAP Stylesheet legend in the panel options 
menu. In the Create MAP Stylesheet legend dialog box, specify the output layer and the legend elements to be added.
 
The legend font is set by the current setting in the Adobe Illustrator Character panel. Prior to creating the MAP 
Stylesheet legend, use the Character panel to set the font and options.

Legends are not dynamically linked to the MAP Stylesheets. Each element can be further edited freely easily — 
using the Direct Selection tool, in isolation mode or if un-grouped (menu Object > Ungroup).
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One of the most useful features of MAPublisher is the ability 
to create labels for map objects using values from the MAP 
Attributes panel. Manually entering and placing labels is not 
necessary, provided that the labelling information is included 
in the map attributes of the MAP Layer being labelled.

MAPublisher provides two methods of adding labels 
to a map, both of which contain options to place labels 
intelligently using defined label settings.

One way to create feature labels is to first select all the 
features to be labelled and use Feature Text Label to label all of 
them by specified attribute values. 

An alternate method involves using the MAP Tagger Tool to 
apply labels individually, also by specified attribute values.

Topics covered in this section are:
Feature Text Label
MAP Tagger Tool

For more advanced labelling capabilities refer to chapter 18 on 
MAPublisher LabelPro (additional license required).

Labelling 
Functions
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Labelling Tools 
For Feature Text Label and MAP Tagger Tool

See Settings panels below

Source Layer - Lists the Point, Line and Area 
layers which can be labelled. For Feature 

Text Label, only layers containing selected 
items are listed.

Source Column - Select the column that 
contains the values you wish to use to 

label the selected features.

Label Settings - Click the appropriate button 
to assign label settings and rules for each 

layer type (see below).

Text layer - For each Source Layer, select the 
destination text layer you wish to place the 
generated text labels on.

Point Label Settings

Label Position - Choose the position of 
the label relative to the point symbol.

Labels curve with lines of latitude 
For projected layers, choose this option 
to generate curved text on latitude lines.

Distance from start - Controls where the text is 
located along the line. 

Auto - places text at the midpoint for straight 
lines and find the smoothest portion closest 

to the midpoint for curved lines.  
Fixed - allows for precise placement of text 

along a line.

Adjust label if larger than line - Specify rules for 
the scaling of text if the text will not fit onto 

the text path in its entirety. 
Click the Up or Down buttons to adjust 

the order in which the rules will be 
implemented in the labelling process.

Line Label Settings
Follow/Don’t Follow Line - Select whether text 
should follow paths or be placed at a point 
near the selected line.

Flip upside-down labels - By default this is 
always enabled and will automatically 
orient labels correctly. Disabling this 
feature will not flip label.

Line Smoothing / Offset Line - Check to smooth 
the generated text path. Then specify an 
offset distance for the text path from the 
original.

Label Position - Choose how the text will be 
placed on the generated text path.

Set all labels to same minimum size - If at least 
one label has been reduced in font size 
due to the implementation of rules, then 
ALL text items will be reduced to that font 
size ( in Feature Text Label only).

Area Label Settings

Placement Accuracy - To quickly generate 
labels, choose Low. To force labels within 
the boundaries of area of complex shape, 
choose High.

Set all labels to same minimum size - If at least 
one label has been reduced in font size 
due to the implementation of rules, then 
ALL text items will be reduced to that font 
size (Feature Text Label only).

Labels curve with lines of latitude 
For projected layers, choose this option to 

generate curved text on latitude lines.

Adjust label if larger than line - Specify rules 
for the scaling of text if the text will not fit 

inside the area object in its entirety. 
Click the Up or Down buttons to adjust 

the order in which the rules will be 
implemented in the labelling process.
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Feature Text Label 
Object > Filters > MAP Labeling> Feature Text Label* or MAP Toolbar 

FUNCTIONALITY

The Feature Text Label filter add labels to a map based on the attribute data of the features. Line, Point or Area MAP 
Layers containing attribute information can be labelled using this filter. All selected features on MAP Layers (which 
contain appropriate attribute information) can be labelled using this tool. Data selected on multiple MAP Layers 
can be labelled simultaneously. In addition, more options can be specified, such as alignment to lines of latitude, 
minimum font size, horizontal scaling and label position to place labels intelligently.

PREREQUISITES

Labels will be added to a   Text layer that must be created in the MAP Views panel. To create a new text layer, use the 
Add MAP Layer function in the MAP View panel(see chapter 4):

•	 Set the feature type to Text.
•	 To enable the copy the attributes from the source MAP layer to the label destination layer, check the 

option Base attribute schema on and select the appropriate layer to copy its attribute schema. 

For best results, set up a character style for type font, size, justification and color. (Adobe Illustrator menu Window 
> Type > Character Style). Select the appropriate style in the Character Style panel before starting the Feature Text 
Label tool and MAPublisher will generate labels based on these settings. Otherwise labels applied will appear in 
the current default colour, font and font size. Then select the features to be labelled and go to Filter > MAP Legend > 
Feature Text Label or the MAPublisher toolbar button  to access the function.

FEATURE TEXT LABEL SETTINGS

Source Layer and Column
First set the options for MAPublisher to determine the attributes that will be converted to text labels. The Source Layer 
list shows the Area, Point and/or Text layers currently containing selected data.

For each layer, the Column drop-down list(s) is populated with the attribute structure of that layer. Choose the 
appropriate column that holds the attributes used to label the map with.

Target Text Layer
In the Text layer drop-down list(s), specify a Text layer that the labels will be output to. Note that labels can only be 
created on to text layers in the same MAP View as the Source Layer.

LABEL SETTINGS

MAPublisher provides options to specify label preferences such as label position, alignment to lines of latitude, 
minimum font sizes and horizontal scaling to best place labels within polygons and paths. These label settings are 
common to Feature Text Label and the MAP Tagger Tool. 

 Line Labels
MAPublisher will place Line labels intelligently, depending on the curvature and length of the line string. Click the 
Line Labels button to assign MAPublisher Line Label Settings.

* In Adobe Illustrator CS3, Feature Text Label is found in the Filter > MAP Labeling menu.
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MAPublisher controls where text is placed along lines by using the Distance from start option. Selecting Auto will place 
text at the midpoint for straight lines and for curved lines this will find the smoothest portion of the curved line 
closest to the midpoint. Selecting Fixed, the distance from start is set as a percentage of the length of the line.

Flip upside-down labels is enabled by default and will automatically orient labels correctly if some lines are flipped. 
Disabling this feature will not flip labels.

If the Line Smoothing option is used, MAPublisher creates a smoothed path for each text object in the selected Text 
layer and places the text along this path at the specified Offset value. The labels can then be dragged and positioned 
at any position along a line. If the Line Smoothing option is not selected, the labels follow the original path.

The Label Position option allows for the selection of the vertical position of the labels relative to the line. Three op-
tions are available: Baseline, Descender, and Center:

•	 Select Baseline to place labels above the generated text path. 
•	 Select Descender to place the portion of a letter in a Latin-derived alphabet that normally extends below 

the baseline of a particular font above the generated text path. 
•	 Select Center to place the centre the label on the generated text path.

Labels can be modified if they exceed the length of the line in the current default font size. First check the Adjust label 
if larger than line option to activate the label rules. Rules are executed by MAPublisher in a hierarchical order, and can 
be reordered by clicking the rule and clicking the Up or Down button. 

Checking the Reduce font size option allows to reduce the size of the font to a specified minimum size in points. 
Checking Reduce horizontal scaling allows text to be scaled down horizontally by the percentage specified. 

Feature Text Label also provides an additional option (not applicable in MAP Tagger). If any of the labels have been 
adjusted in size due to the activation of a line adjustment rule, all labels can be resized to the same size by checking 
the Set all labels to the same minimum font size option.

If no rules are enabled, MAPublisher will not perform any label scaling. If none of the rules specified in the panel can 
be satisfied, MAPublisher will default to placing the label centered over the line. Also note that text generated for 
Line labels will be automatically orientated above the lines, irrespective of the direction of line digitization.

 Area Label

MAPublisher will place Area labels intelligently, depending on the shape and size of the area polygon. Click the Area 
Labels button to assign MAPublisher Area Label Settings.

Decide how to place area labels—with a high degree of precision or lower degree of precision—by choosing the 
appropriate Placement Accuracy option. 

If the Labels curve with lines of latitude option is selected, MAPublisher creates a path that conforms to local line of 
latitude and place the text along it. If this option is not selected, the labels are placed horizontally. This option is 
enabled only for MAP Views set with a projected coordinate system.

Labels can be modified if they exceed the size of the area in the current default font size. First select the Adjust label if 
larger than area option to activate the label rules. Rules are executed by MAPublisher in a hierarchical order, and can 
be reordered by clicking the rule and then the Up or Down button. 
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Checking the Reduce font size option allows to reduce the size of the font to a specified minimum size in points. 
Checking Reduce horizontal scaling allows texts to be scaled down horizontally by the fraction specified. Checking the 
Wrap Labels that are longer than area option adds  a carriage return at the nearest space in the text.

NOTE: 	 The Wrap Labels that are longer than area option is not available if the Labels curve with lines of latitude 
option is checked. 

Feature Text Label also provides an additional option which is not available with the MAP Tagger tool. If any of the 
labels have been adjusted in size due to the deployment of an area adjustment rule, all labels can be resized to the 
same size by checking the Set all labels to the same minimum font size option.

If no rules are enabled, MAPublisher will not perform any label scaling. If none of the rules specified in the panel can 
be satisfied, MAPublisher will default to placing the label centered over the area. In situations with area compounds, 
MAPublisher labels the largest area in the compound.

 Point Labels

Click the Point Labels button to assign MAPublisher Point Label Settings.

If the Labels curve with lines of latitude option is selected, MAPublisher creates a path that conforms to local line of 
latitude and places the text along it. If this option is not selected, the labels are placed horizontally. This option is 
enabled only for MAP Views set with a projected coordinate system.

Adjust the Label Position by specifying relative position of the labels to the point. Nine options for the text anchor 
placement are listed.

FEATURE TEXT LABEL RESULTS

When all the Layer Label Options have been set and the Label Settings have been specified click OK to label the 
selected features.

Labels applied using Feature Text Label appear in the current default colour, font and font size (as set by the 
selected character style). 

If the destination text layer and source layer have the same attribute schema, the attributes of the labelled features 
are copied as attributes to text features (to apply MAP Stylesheets for example).
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MAP Tagger Tool 
Tools > MAP Tagger Tool 

FUNCTIONALITY

The MAP Tagger Tool allows labels to be added to your map based on the attribute data of the features. Line, Point 
or Area MAP Layers containing attribute information can be labelled using this filter. This tool functions similarly to 
the Feature Text Label filter. However, labels are created by clicking the feature with the MAP Tagger Tool. You also 
have greater control over the initial placement of the label, because the label is placed where you click, and the 
tool provides the ability to create leader lines for labelling congested areas of the map. In addition, you may specify 
options such as alignment to lines of latitude, minimum font size, horizontal scaling and label position to place 
labels intelligently.

PREREQUISITES

Labels will be added to a   Text layer that must be created in the MAP Views panel. To create a new text layer, use the 
Add MAP Layer function in the MAP View panel(see chapter 4):

•	 Set the feature type to Text.
•	 To enable the copy the attributes from the source MAP layer to the label destination layer, check the 

option Base attribute schema on and select the appropriate layer to copy its attribute schema. 

For best results, set up a character style for type font, size, justification and color. (Adobe Illustrator menu Window 
> Type > Character Style). Select the appropriate style in the Character Style panel while using MAP Tagger tool, and 
MAPublisher will generate labels based on these settings. Otherwise labels applied will appear in the current default 
colour, font and font size. 

The MAP Tagger Tool can be found towards the bottom of the Adobe Illustrator Toolbar. Double-click the  tool to 
create new label settings or to edit settings. 

MAP TAGGER TOOL SETTINGS

Source Layer and Column
First set the options for MAPublisher to determine the attributes that will be converted to text labels. The Source Layer 
list shows all Area, Point and/or Text layers in the current document.

For each layer, the Column drop-down list is populated with the attribute structure of that layer. Select the column 
that holds the attributes used to label the data with.

Target Text Layer
In the Text layer drop-down lists(s), specify the Text layer that the labels will be output to. Note that labels can only be 
created on to text layers in the same MAP View as the Source Layer.

LABEL SETTINGS

MAPublisher provides options to specify label preferences such as label position, alignment to lines of latitude, 
minimum font sizes and horizontal scaling to best place labels within polygons and paths. These Label Settings are 
common to Feature Text Label and MAP Tagger Tool. 
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TAGGING MAP DATA

When the label settings are set, click OK to close the dialog box and confirm these settings.

Then click the map object to add labels for the clicked features. It can be convenient to lock the layers that do not 
require labelling in the Adobe Illustrator Layers panel to avoid selecting undesired objects.

The following list of keyboard modifiers may be used for additional labelling options:
(note  = click map object with MAP Tagger Tool selected).

  
	 Labels placed using current Adobe Illustrator Type and MAPublisher settings. 
	  Line labels are placed at click point and assigned angle of line at click point.
	  Area labels are placed horizontally at click point.
	  Point labels are placed horizontally at click point.
 

 + Shift

	 Only applicable for Line labels. Labels placed using current Adobe Illustrator Type and MAPublisher settings. 
	  Line labels are placed horizontally at click point.

 + Shift  + drag
	 Labels placed using current Adobe Illustrator Type and MAPublisher settings and leader line created on drag. 
	  Line labels are placed horizontally. Leader line connects text to line feature.
	  Area labels are placed horizontally. Leader line connects text to area feature.
	  Point labels are placed horizontally. Leader line connects text to point feature.

 + drag
	 Labels placed using current Adobe Illustrator Type and MAPublisher settings. 
	  Line labels are assigned angle of line at click point. 
	  Area labels are placed horizontally.
	  Point labels are placed horizontally.

NOTE: 	 To create custom leader lines use a graphic style. Create or load a graphic style and select it in the Graphic 
Styles panel while using the MAP Tagger Tool function. 

MAP TAGGER TOOL RESULTS

Labels are added for the object being clicked at the desired position (see above).

Labels appear in the current default colour, font and font size (as set by the selected character style). 

If the destination text layer and source layer have the same attribute schema, the attributes of the labelled features 
are copied as attributes to text features (to apply MAP Stylesheets for example).
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MAPublisher contains tools for selecting data graphically and 
by attribute values. 

The MAP Selection Filters tool provides functionality to create, 
edit and save multiple selection criteria. These selections can 
be applied to any MAP Layer and can only be used to split 
MAP Layers. Selection Filters are saved in the document.

The MAP Selection Stats tool are used for quickly selecting all 
features contained in a MAP Layer, for viewing how many 
objects are selected at a given time, to save a selection and to 
reverse selections.

The topics covered in this section are as follows:
MAP Selection Filters
MAP Selection Stats

Making 
Selections
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MAP Selection Filters 
Window > MAPublisher > MAP Selection Filters or MAP Toolbar  

Apply as New Selection - Makes a new selection 
using the highlighted criteria.

Add to Current Selection - Adds the highlighted 
criteria to the current selection.

Remove from Current Selection - Removes the 
highlighted criteria from the current selection.

Get Subset of Current Selection - Makes a selection 
within the current selection.

Create New Selection Filter - Opens the New Selection 
Filter function (below).

Delete Selection Filter - Deletes the selected filter(s).

MAP Selection Filters panel

New/Edit Selection Filter

Filters List - Lists the Selection criteria in the 
current document.

Edit Selection Filter - Opens the Edit 
Selection Filter function (below) for 
editing the assigned expression.

Name - Assign or edit the name of the 
selection filter.

Expression - Enter the expression 
directly into the entry field, or access 

the Expression Builder function (see 
chapter 5).

Valid Filter Icon - When a selection filter contains 
an expression that is valid for the active Adobe 
Illustrator data layer a green check mark icon is 

displayed.

Not Valid Filter Icon- If the expression is not valid for 
that particular data layer a red exclamation mark 

is displayed.

Expression Validity - Indicates if the 
expression is  valid or  invalid. 
If invalid, additional information is 
reported.

Edit Expression - Opens the Expression 
Builder for editing the assigned 
expression.

Split layer - Opens the Split Layer function 
(below) for copying or moving 
selected objects to a new layer.

Preferences - Opens the MAPublisher 
Preferences on the MAP Selection Filters 
property sheet.

Split Layer

Expression - Assign or edit the expression.

Expression Validity - Indicates if the 
expression is  valid or  invalid. 
If invalid, additional information is 

reported.
Destination Layer- Enter the name of 
the new layer to be created. Or enter 
a prefix when using split by attribute 
value.

Copy attribute schema - Check this option 
to copy the attribute schema onto the 
new layer

Action - Select the option to copy or 
move objects from the source layer to 
the destination layer

MAP Selection Filters Panel Preferences

Show filters on two lines - cleared
Show filters on two lines - selected.

Expression Builder - Opens the Expression 
Builder for editing the assigned 
expression (see chapter 5).

Split art based on unique values - Choose 
this option to split the selected layer 
into multiple layers - one per unique 
value of the selected attribute in the 

Attribute drop-down list.

Split by expression - Choose this option 
to split the selected layer based on 

the currently selected expression. The 
expression is editable (manually or 

using the Expression builder).
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FUNCTIONALITY

MAPublisher Selection Filters allow to build, edit and apply multiple selection criterias based on the attributes and 
properties contained in MAP Layers. Selection criterias are created in an expression. Selection filters can be applied 
to any MAP layer, and are saved in the document so that they can be edited or applied later. 

Expressions created in the MAP Selection Filters may be re-used for MAP Attributes and MAP Stylesheets expression 
builders (see chapter 5).

CREATING A SELECTION FILTER

To open the MAP Selection Filters panel, choose Window > MAPublisher > MAP Selection Filters or click the 
MAPublisher toolbar button . This panel will contain a list of all the selection filters in the current document.

Create a new MAP Selection Filter by clicking the Create New Selection Filter button or panel options menu. This will 
open the New Selection Filter dialog box.

The Name text box can be edited to describe the selection filter or its intention. For example, a selection filter could 
be named Cities or Countries with 80% or higher literacy.

The Expression field describes the criteria for the selection of feature art. Build a valid expression in the Expression 
field. The Expression Validity icon will report  if the expression entered is valid. Otherwise it will report  and 
include additional warning notes.

Alternatively click the  button to enter and edit expressions via the Edit Expression tool (see chapter 5).

The following are some examples of basic expressions which can be entered for use as selection filters.

NAME = “Ontario”
Result: All items with the value “Ontario” in the NAME column are selected.

POPULATION < 1000000
Result: All items with values less than one million in the POPULATION column are selected.

NAME = “Ontario” OR NAME = “Alberta”
Result: Items with the value “Ontario” OR “Alberta” in the NAME column are selected.

NAME = “Ontario” AND POPULATION < 1000000
Result: Only items containing the value “Ontario” in the NAME column AND values less than one million in the 
POPULATION column are selected.

Click OK to create the filter, adding it to the list of filters in the panel.

EDITING AND DELETING SELECTION FILTERS

The name and entered expression can be edited. To edit a MAP Selection Filter, double-click the appropriate 
selection filter in the panel, or click the selection filter in the panel and click the Edit Selection Filter in the panel 
options menu. This opens the Edit Selection Filter dialog box. Delete a MAP Selection Filter by clicking the Delete 
Selection Filter button or menu item.
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MAKING SELECTIONS

Once MAP Selection Filters have been created they can be applied to a MAP layer. Selection filters can only be 
applied to one layer at a time. However, more than one filter may be applied simultaneously (use Shift or Ctrl 
(Windows) or Command (Mac) to select multiple filters). When applying multiple selection filters, art only has to satisfy 
one of the chosen selection filters to qualify (i.e. multiple selection filters are combined using the “OR” operator).

NOTE:	 When the expression is marked as valid, it is not necessarily valid when applied to a given layer. For 
example, the expression Country=”Ohio” is only applicable to a layer with the Country attribute. If an 
expression is not valid for a layer, an error is shown when the selection filter is applied.

There are four methods of applying a selection filter (available as buttons and menu items):

•	 Apply as New Selection: Clears the current selection and selects any art on the current layer that meets the criteria 
of the chosen selection filter(s).

•	 Add to Current Selection: Adds any art on the current layer that satisfies the chosen selection filter(s) to the current 	
selection.

•	 Remove from Current Selection: Deselects any art on the current layer that is selected and satisfies the chosen 
selection filter(s).

•	 Get Subset of Current Selection: Deselects any art on the current layer that is selected and does not satisfy the 
chosen selection filter(s).

SPLIT LAYERS

A MAP Selection Filter may also be applied to create a new layer containing the selected features. Features can 
either be copied or moved from the source layer to the destination layer with the option to maintain the attribute 
information from the source layer. With this function, a layer can also be split by unique values of a selected 
attribute, hence creating multiple layers. The same options to copy or move the features apply.

This function is particularly useful to split a layer that contains a lot of objects. For example, a road layer with classes 
such as street, highway and toll road could be split in three distinct layers. Split Layers can be used as a preliminary 
to running MAPublisher LabelPro (to allow labelling of multiple classes with different styles, see chapter 18), or to 
exporting layers to external GIS formats.

To use Split Layers, the MAP Layer to be split must be selected in the Adobe Illustrator Layers panel and/or a filter can 
be selected from the list of valid filters in the MAP Selection Filters panel. The Split Layers function is started from the 
MAP Selection Filters panel options menu Split "layer name". 

In the Action options, users specify if split art can be either copied or move to the new layer(s).

Two splitting methods are possible: 
•	 Split art by expression: by default the expression of the currently selected filter is displayed (if applicable), 

and it can be edited manually or using the Expression Builder (see chapter 5). Then a layer name for the 
new layer must be entered in the Destination frame.

•	 Split art by unique attribute value: an attribute must be selected from the Attribute drop-down list. Each new 
layer created will contain only art that share the same attribute value. By default, the name of these 
layers correspond to each single attribute value. In the Destination frame, users can enter a prefix to be 
prepended to every layer name.

For both methods, users have the option to copy or not the attribute schema to the destination layer(s). 
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MAP Selection Stats 
Window > MAPublisher > MAP Selection Stats or MAP Toolbar 

USING THE MAP SELECTION STATS PANEL

To open the MAP Selection Stats panel, choose Window > MAPublisher > MAP Selection Stats or click the MAPublisher 
toolbar button . 

Layer Statistics
On initial opening, this panel displays the total number of map features that exist on the current MAP Layer, as 
well as how many are currently selected. As only one feature type is supported per MAP Layer, this dialog box only 
displays the current feature type. Only MAPublisher objects are displayed in the MAP Selection Stats panel. Objects 
that are in [Non-MAP layers] in the MAP Views panel, are not recognized in this panel.

Selecting objects manually or via a MAP Selection Filter updates the left hand field in the panel. The right hand field 
always displays the total number of objects that exist on the current MAP Layer. 

All or Reverse
The dialog box offers a quick way to select all map features on the current layer. Simply click the A (All) button to 
select all the Map features on the current layer.

Clicking the R (Reverse) button reverses the current selection (i.e. all the features that were selected are deselected, 
and the features that were deselected are selected).

Saving Selections
The Save button saves the current selection to memory, allowing to retrieve the selection again later. Only one 
selection can be saved, and it is limited to the current Adobe Illustrator session. A subsequent click of the Save 
button overwrites the original saved selection. 

Clicking Recall performs the selection that is saved to memory. Clicking Clear, removes the saved selection from 
memory.

Layer - The current MAP Layer and feature type.

Number Selected/Number Existing - The field on the 
left represents the number of selected objects 
on the active MAP Layer. The field on the right 
displays the total number of objects of a given 

feature on the active MAP Layer.

A and R - All and Reverse. Choose to either 
select all of the features on the selected 
MAP Layer, or reverse the current selection.

Clear - Removes the saved selection from 
memory.

M XOR - Selects both the saved and currently 
selected features, but also removes from 
the selection any features that are both 
saved and selected.

M AND - Selects the saved features that are 
also currently selected.

Save - Save the current selection to memory so 
that it can be recalled later.

M OR - Selects both the saved and currently 
selected features. 

Recall - Restores a selection that has been saved 
to memory.
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Additional Selection Options
This panel also offers additional selection tools: M OR, M AND, and M XOR.				  

Clicking the M OR button selects both the currently selected objects and the 
saved selection.

The M AND button selects the map features in the current selection which are 
included in the saved selection.

The M XOR button selects both the currently selected features and the 
saved selection if these selections do not overlap. However, if the current 
selection includes any features that are part of the saved selection, those are 
deselected.

Current
Selection

Current
Selection

Current
Selection

Saved
Selection

Saved
Selection

Saved
Selection

Resulting
Selection

Resulting
Selection

Resulting
Selection

M OR

M AND

M XOR
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Working With 
Images
MAPublisher contains tools for working with georeferenced 
raster images such as aerial photography and satellite imagery.

The Register Image filter accurately registers raster images with 
georeferencing information to vector map data. 

The Export Image filter exports raster images with various 
georeferenced formats.

Georeferencing information for raster images are usually 
stored in a separate text file (except GeoTIFF) where the 
image and its associated reference file have the same file 
name but a different file extension. 

The reference file formats that can be read by Register Image, 
or written to by Export Image are:
World (*.tfw)
Image Report (*.irp) 
MapInfo TAB (*.tab)
ListGeo (*.lgo)
GeoTIFF (*.tif ) (a single file containing both the image and its 
reference data)

Topics covered in this section:
Register Image
Export Image
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Tie Points† - Change the tie point of the 
image by clicking another corner of 

the graphic

Image Size† - Specify the size of each 
pixel in the selected map unit (updates 
the Effective Map Size). Register Image 

supports non square pixels.

Constrain Proportions - Check this option 
to keep the pixel proportions.

Effective Map Size X/Y† - Specify the X and Y 
size of the image in map units (updates 

the Pixel Size).

Register Image 
Object > Filters > MAP Images > Register Image* or MAP Toolbar 

FUNCTIONALITY

The Register Image filter applies geospatial properties to images imported to the document with the Adobe Illustrator 
Place command, i.e. image placement and pixel or image size—entered manually or loaded from a reference file. 
If an image's coordinate system matches one of existing vector data, the image can be scaled and rotated to fit 
the vector data. If no matching vector data is found in the document, a new MAP view can be created to store the 
cartographic information of the image to allow for data digitization with accurate positioning. 

Register Image does not have the capability to transform images from one coordinate system to another.

Units - Select a unit to use for the 
specification of georeferencing 
information. The default selection is the 
current map unit.

† Editing these options is not required when using the Load File function.

Placement X/Y† - Specify the coordinates 
(in map units) of the selected corner of 
the raster image.

Load File - Choose a file containing 
the georeference information for the 
selected raster image. The information 
from the file will be inserted into the 
appropriate fields.

* In Adobe Illustrator CS3, Register Image is found in the Filter > MAP Images menu.

Register Image

Undefined Layer

Coordinate System - Indicates the 
coordinate system of the loaded file 
(for GeoTIFF images). Set to unknown 
by default.

Select MAP View - Register the image on 
a new MAP View (created from the 
image registration information) or 

select an existing MAP View from the 
drop-down list.

This dialog box appears if the image to 
register is not placed on a MAP Layer

Feature Type - Select the type of feature 
that exists on the image layer. The 
feature type is indifferent if the layer 
contains only the image.

Base Attribute Schema - Check this option 
to copy the attribute schema from an 
existing MAP Layer.
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PREREQUISITES

For Register Image to be functional, the geospatial properties of the raster image must be known. Some raster 
image formats store the relationship between source image coordinates (pixel location) and real-world reference 
coordinates in an associated reference file but do not save the coordinate system information (e.g. world file .tfw). 
The commonly used GeoTIFF images are embedded with geographic information such as position and coordinate 
system. Depending on the image format, check the position and coordinate system of your imagery with your data 
provider before attempting to use this tool. 

To fit the imagery to existing vector data, one option is to first transform the vector data to match the image's 
coordinate system in MAPublisher (see the MAP View Editor in chapter 4). Alternatively Avenza's Geographic Imager for 
Adobe Photoshop can be used to transform the imagery to match the coordinate system of the MAP View.

Finally, the image must be imported to the document using the Adobe Illustrator Place command (File > Place). 
The image can be placed on any layer (MAP Layer or not). Use a MAP Layer only if it is certain that the image's 
coordinate system matches the MAP View containing the layer.
NOTE:	 The image can be placed to a layer containing artwork, but it is recommended to use a specific layer, 

dedicated only to the image registration for better layer management and workflow.

At this point, the image is placed on the artboard in a default location and with a default size. It still needs to be 
registered. With the image selected go to Object > Filter > MAP Images > Register Image* or click the MAPublisher 
toolbar button  to access the function.

USING REGISTER IMAGE

If the image is placed on a MAP Layer, the Register Image automatically registers the image using the coordinate 
system of the MAP View containing that MAP Layer. 

If the image is placed on non MAP Layer, the Undefined Layer dialog box opens. Users can either select to create a new 
MAP View or to use an existing MAP View (if it is certain that the coordinate system of this MAP View matches the 
one of the image). In both cases the feature type must be specified (indifferent if the layer only contains the image).

When creating a new MAP View, the MAP View's anchor point and scale are derived from the registration 
information (placement and image size). In the case of GeoTIFF images, the MAP View's coordinate system is 
automatically read from the image header—for other image formats, the coordinate system has to be specified 
manually in the MAP View Editor after the registration process (see chapter 4 for more information on Specify 
coordinate system).

Registration via Reference File
To select a reference file click the Load File button and navigate to the folder containing the reference file. The reference 
file usually is called the same name as the image, but may have a different extension (.irp, .tfw, .tab or .lgo). In the case 
of the GeoTIFF format, the image file itself contains both the image and reference data, however the same GeoTIFF file  
(.tif ) needs to be loaded to retrieve the georeferencing information. 

The values contained in this reference file are automatically entered into the image parameters. If the file is in 
GeoTIFF format, the image coordinate system is read and displayed in the Register Image dialog box Coordinate system 
field—for other file formats, the coordinate system is left to unknown. 

* In Adobe Illustrator CS3, Register Image is found in the Filter > MAP Images menu.
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Manual Registration
To manually enter image parameters, one of the following combinations must be available in page units or map units:
•	 The X and Y coordinates of one corner of the image and the X and Y Pixel Size.
•	 The X and Y coordinates of one corner of the image and the X and Y size of the image.

First choose the units to use for entering parameters by making a selection from the Units drop-down list. Then, click 
the appropriate corner of the graphic to indicate the image placement point and enter the X and Y coordinates for 
this location in the adjacent fields. Next set either the Pixel Size or Effective Map Size. The Pixel Size is the value of a single 
pixel in the units set. The Effective Map Size is the X and Y size of the whole image in the units set. Setting either 
option will update the other accordingly. 

NOTE: 	 The MAPublisher Register Image supports the registration of images having non-square pixels.

RESULTS

When registering GeoTIFF images, a warning message will be displayed if the coordinate system of the image 
does not match the selected MAP View's coordinate system. When registering images not in GeoTIFF format while 
creating a new MAP View, the coordinate system of the MAP View has to be specified in the MAP View Editor to 
finalize the georeferencing. 

Provided that the coordinate system, placement and size of the raster image are correct, the image will be scaled 
and registered. When matching vector data is available, the image will fit to the artwork. The MAP Location Tool can 
be used to check the positions (see chapter 4).

NOTES: 	
•	 Raster images cannot be transformed into another coordinate system. If the vector data is transformed 

through the MAP View Editor Perform Coordinate System Transformation function after the image has been 
register, the image will have to be transformed externally (with Avenza's Geographic Imager for example) 
and registered again in MAPublisher.

•	 Registered images can be re-scaled and rotated together with the vector data, but not automatically. 
After the vector data has been re-scaled or rotated using the MAP View Editor, Register Image must be used 
to re-apply the image referencing information. In the case of a manual registration, it is recommended 
to use the Export Image function before applying the changes to the vector data (see next paragraph). 
This way, registering the image again is only a matter of loading a reference file.

SUPPORTED GEOREFERENCED IMAGE REFERENCE FORMATS

World File (*.tfw, *.tifw, *.wld, *.eww, *.jgw, *.jpw, *.pgw, *.sdw, *.eww, *.blw, *.dmw) 
World files contain the affine relationship between source image coordinates (pixel locations) and real-world 
reference coordinates (lat/long or other real-world coordinate units). World files simply contain a computed 
relationship between source image coordinates and reference coordinates and not the complete reference point 
information. World files do not support storing coordinate system information.

IRP Image Report File (*.irp)
IRP Image Report files are ASCII report files indicating the coordinates of the four corners of the raster file and the 
pixel size in ground units to allow for georeferencing of the image in other image processing, CAD, or GIS programs.
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MapInfo TAB File (*.tab)
MapInfo Table file formats save the complete reference point list information such that it can be loaded again in the 
future. MapInfo TAB files support storing coordinate system information.

Supported projections when saving the coordinate system are listed below:

Albers Equal-Area 
Azimuthal Equidistant 
Cylindrical Equal Area*
Eckert IV*
Eckert VI*
Equidistant Conic*
Gall Stereographic*

Hotine Oblique Mercator
Lambert Azimuthal Equal Area*
Lambert Conic Conformal
Mercator*
Miller Cylindrical*
Mollweide*
New Zealand Map Grid

Hotine Oblique Mercator 1pt
Polyconic 
Robinson*
Sinusoidal*
Swiss Oblique Mercator
Stereographic Transverse Mercator

* Coordinate Systems using this projection will not be stored when saving the reference file. 

ListGeo file (*.lgo)
A ListGeo files are text files containing the GeoTIFF metadata information (or tags), which can then be read, and 
may also be used as input to other programs.

GeoTIFF File (*.tif, *.tiff)
Tagged Image File Format (TIFF or TIF) is a common raster graphic file format and one of the most common 
geospatial image formats you are likely to come across. Many raster geographic images from GIS systems are stored 
in this format. A GeoTIFF is a TIFF file with embedded geographic information such as position and scale in world 
coordinates, coordinate system or an explicit list of ground control points.

NOTE:	 The only way to differentiate a regular TIFF image from a referenced GeoTIFF image is to open it in a spatial 
imaging software application (such as Avenza's Geographic Imager product).

Unlike the other geographically referenced image formats discussed in this section, GeoTIFFs do not require a 
separate reference file. When registering a GeoTIFF image in MAPublisher, the same file name must be selected in the 
Load File dialog box—the required georeference information is contained in the file header.

Supported projections when saving the coordinate system are listed below:

Albers Equal-Area 
Cassini-Soldner - Cassini
Cylindrical Equal Area
Equidistant Conic
Equidistant Cylindrical
Equirectangular
Gnomonic
Hotine Oblique Mercator
Laborde Oblique Mercator

Lambert Azimuthal Equal Area
Lambert Conic Conformal (1SP)
Lambert Conic Conformal (2SP)
Lambert Cylindrical Equal Area
Mercator
Miller Cylindrical
New Zealand Map Grid
Oblique Mercator 
Oblique Stereographic 
Orthographic

Polar Stereographic
Polyconic
Robinson
Sinusoidal 
Stereographic
Transverse Mercator
Transverse Mercator (South Oriented)
VanDerGrinten
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Store Geography As - Select the output 
format for the georeferencing 

information for the selected image.

Export Image 
Object > Filters > MAP Images > Export Image or MAP Toolbar 

FUNCTIONALITY

MAPublisher offers the ability to export placed raster files as georeferenced images for use in other programs 	
and/or for archival purposes. This can be useful in a number of ways. For example, when working with an image 
for which there is no georeferencing file, use the MAPublisher Export Image function to create a GeoTIFF or other 
georeferenced image file based upon the coordinate system of the host MAP View.

The Register Image filter can be used to accurately position and scale imagery with vector data. Alternatively the 
imagery can be manually moved, scaled or rotated to align with artwork in a designated MAP View. If the host 
MAP View contains accurate georeferencing information, Export Image can be used to save raster data to a fully 
georeferenced image format. It is also possible to convert the vector artwork to a georeferenced raster image.

MAPublisher will export the selected image as a TIF, with a choice of the five reference file formats (see the previous page).

USING EXPORT IMAGE

With the image selected, go to Filter > MAP Images > Export Image or click MAPublisher Toolbar button .

The Store Geography as drop-down list will show the five available reference file formats. A regular TIF file will be 
generated with a reference file carrying the extension TFW, IRP, TAB or LGO if one of these formats is selected. If 
GeoTIFF is selected from this drop-down list, only a TIF file will be produced, as this will carry both the image and the 
georeferencing information.

RESULTS

When all of the export options have been set, click the Save As button. Specify a name for the TIF file, and the 
location where it will be saved. If the format is a TIF and reference file combination, the reference file will carry the 
same file name and will be saved to the same location as the TIF.

This image file can be subsequently used in imagery applications, such as Avenza's Geographic Imager for Adobe 
Photoshop, or in other Adobe Illustrator documents using MAPublisher.

NOTE:	 Exporting linked images in CMYK color mode will create an incorrect result. These images must either be set 
to a different mode or embedded prior to exporting.

NOTE:	 If a MAP View is rotated, the exported image will not store any rotation parameter (it will be automatically 
rectified - oriented north up).

Save As - Choose a destination name 
and directory for the exported image.

* In Adobe Illustrator CS3, Export Image is found in the Filter > MAP Images menu.
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MAPublisher contains tools to easily create map grids and 
map indexes. Grids can be created for reference purposes, or 
to follow designated lines such as latitude and longitude, and 
can also be labelled for indexing. When a labelled grid has 
been established, MAPublisher is able to generate index files, 
containing the location of text objects in MAP Layers.

Topics covered in this section:
Grid and Graticules
Make Index

Grids and 
Indexes
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Grids and Graticules 
Object > Filters > MAP Legend > Grids and Graticules* or MAP Toolbar 

Object > Edit Grid / Edit Graticules

Advanced - Access the Advanced 
dialog box to specify additional 
options for the grids or graticules.

Axis Labels - Solid graphic denote an 
enabled labelling option. 

Click an axis label to toggle all 
labels on that axis ON or OFF.

Coordinates Labels - Solid graphic 
shows labels will be generated 

(labelled as X,Y for measured grids 
or Lat/Long for graticules . Click the 

label to toggle between X, Y, Both, 
OFF or Lng, Lat, Both, OFF.

Label Direction - Click to reverse the 
direction that labels increment.

Cell Labels - Solid graphic shows 
labels will be generated. 

Click a cell label to toggle all 
center labels ON or OFF.

Flip Label Axes - Click to flip alpha 
and numerical labels..

Number of Columns and Rows -Select 
this option to create a grid with 

the specified number of rows and 
columns.

Index Grid Settings

Cell Size in Page Unit - Select this 
option to specify the cell size 
in page unit (as specified in the  
Adobe Illustrator Document 
Setup).

Grid/Graticule Selection - Click the 
appropriate button to select the 
grid type required and to assign 

settings (see below).
Note: Measured Grids can only be 

created on MAP Views in projected 
coordinate systems. See Settings panels below

Coordinate Values along Grid/Graticule 
Border:

X and Y Axis style - Select the 
Character Style to use for the X 
and Y labels.

X and Y Axis label rotation - Choose 
Horizontal or Vertical rotation.

Place labels off line by - Select a 
distance off the grid to place the 
labels.

Number of decimals - Specify the 
number of decimals.

Labels values - Select the type 
of labels to display (distances 
measured from the lower left 
corner of the grid, or actual 
coordinates (X/Y or lat/long).

Units - Set the units for Measured 
Grid dimensions if appropriate.

Append units to labels - Choose to include 
labels (i.e. degree symbols) for Line Labels.

Apply locale formatting to numbers - Choose 
to apply locale formatting (e.g. decimal 
separator as dot or comma), as specified in 
the MAPublisher Preferences. 

* In Adobe Illustrator CS3, Grids and Graticules is found in the Filter > MAP Legend menu.

† If the Center, Axes and X or Y Axis style lists do not contain a recently created character style, simply return to the Character Style panel, double-click 
this style and click OK in the Character Style Options dialog box. This forces Adobe Illustrator to re-load the list of character styles.

Line Style - Select a graphic style for 
the grid axis

Cell References:

Place labels of cell by - Select a distance 
off the grid to place the labels. 

Center Style†- Select the Character 
Style to use for the Center Labels.

Axes Style†  - Select the Character 
Style to use for the Axis Labels. .

Draw Border - Check this option to 
draw the grid border (frame) and 

select a graphic style for it.

Preview - Click this button to 
preview the grid. 

Hide on preview - Minimizes this 
dialog box during preview.
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FUNCTIONALITY

The Grids and Graticules tool generates grid lines based on a number of user-defined settings. 

There are three grid types available:
•	 Index Grid: divides the grid extents based on a specified number of cells or by entering a cell size in document unit.
•	 Graticules: plots grid lines at specific intervals of latitude and longitude which will be automatically curved as 

applicable. 
•	 Measured Grid: place grid lines based on a grid size in real-world dimensions.

Numerous options for labels, placement, size and alignment are provided.

All grids plotted with this tool can be subsequently resized using the bounding box of the grid, and can be edited 
by clicking the Adobe Illustrator menu Object > Edit Grid / Edit Graticules.

PREREQUISITES

Grids and Graticules are added on  Legend layers. If no legend layer is present in the document, a new legend layer 
will be created automatically. To manually create a new Legend layer, use the Add MAP Layer button on the MAP 
View panel and specify a feature type of Legend (see chapter 4 for more details).

Measured Grid Settings

Preset Origin - Choose this option to 
select a preset X and Y origin .

Grid passes through point - Choose this 
option to select specific coordinates 
for the X and Y origin .

Cell Width/Height - Specify the 
dimensions of each cell comprising 

the grid in the current map units.

Graticule Settings
Latitude Interval - Specify the interval for 

each line of latitude.

Pass through latitude - Specify a line of 
latitude that must be included (any 

great circle)/

Longitude Interval - Specify the interval 
for each line of longitude.

Pass through longitude - Specify a line of 
longitude that must be included (any 
meridian).

Vertices - Use the slider to increase or 
decrease the number of nodes which 

will be used in the construction of 
the graticules (use a higher number if 

graticules are curved).

Don’t label - Enabling any of these 
boxes will prevent the corresponding 

row or column from being labelled.

If line does not hit- Some curved lines 
may not hit the graticule extent 
border. Specify if MAPublisher should 
label these lines. Options are: None, 
Latitude, Longitude, Latitude&Longitude

Grid Style Options- see Index Grid settings.

Grid Style Options- see Index Grid settings.
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By default, MAPublisher will use the Normal Character Style when generating grid labels. If custom character styles 
are to be used for the labels, these styles should be established before opening this dialog box (Window > Type > 
Character Styles).

A default grid line style will also be used. To use an alternate style for the grid lines, create or add the desired style to 
the Graphic Styles panel prior to accessing the Grids and Graticules function.

The MAP View must have a coordinate system assigned in order to plot a grid. Graticules and Index Grids can be 
generated for any coordinate system. Measured Grids cannot be generated for geodetic coordinate systems.

To access the function select the legend layer and navigate to Object > Filters > MAP Legend > Grids and Graticules* or 
MAPublisher toolbar button .

INDEX GRIDS

The Index Grid option divides the grid extents based on a specified number of cells or by entering a cell size in 
document unit. The grid dimension can be either calculated from the specified number of columns and rows or by Cell 
Size in Page Units. Finally, graphic styles for the grid lines and border, and character styles for labels may be specified.

NOTE:	 The page units are specified in the Adobe Illustrator document setup (main menu File > Document Setup).

GRATICULES

The Graticules option permits grid lines to be placed at specific intervals of latitude and longitude (in degrees). 
Specify the interval for lines of latitude and longitude and as required a latitude and longitude value to pass through. 
Use the slider to increase or decrease the number of vertices used in the graticules if required (use a higher number 
if the graticules are highly curved due to the current projection). 

To control which axis are to be labelled, set the following features:
•	 Don’t label: allows not labelling a specific column or row (first or last, row or column).
•	 If line does not hit bounds, label (None, Latitude, Longitude or Latitude & Longitude): choose to label or not curved lines 

that do not intersect with the grid extents (applies even if the line hits the grid border but not the bounding box).
•	 None, Lat, Lng or Both axis labels: a click on the axis in the label placement control switches the label caption from 

off (text grayed out), Lat, Lng or Both. This is useful for rotated grids or for labels of curved lines.

Finally, graphic styles for the grid lines and border, and character styles for labels may be specified .

MEASURED GRIDS

The Measured Grid option creates a grid based on a grid cell size specified in real world unit, when the current MAP 
View is in a projected coordinate system. The size is specified in the Width and Height text boxes (the map units can 
be specified in the Units list).
 
The grid position can be specified as relative to the page extent (Preset Origin) or by entering a X, Y position (Grid Pass 
Through Point). Finally, graphic styles for the grid lines and border, and character styles for labels may be selected.

* In Adobe Illustrator CS3, Grids and Graticules is found in the Filter > MAP Legend menu.
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LABELLING OPTIONS

A number of labelling options are available for use in grids and graticules. 

The Cell Reference options are relative to the indexing labels of grids and graticules. In the label placement control, 
click on the axes labels (A, B or 1,2) and cell labels (A1,A2...) to enable or disable the display of these labels. Use the 
arrows to change the direction of axes and flip the numeric labels. Click a corner graphic to swap which axes are 
labelled numerically and which are labelled alphabetically. Then specify the axes label distance from the grid border 
(Place Labels of cell by option — a negative value places labels inside the grid) and choose a character style for the 
Center and Axis styles.

NOTE:	 Indexing labels for graticules are always generated as if the graticules covered the full map extents, 
regardless of the actual graticules' bounding box. 

The Coordinate Values along Grid/Graticule Border options are relative to the coordinate labels of the grids and graticules 
(X,Y for indexed and measured grids, Lat,Lng for graticules). In the label placement control, click on the X/Y or Lat/
Lng axis labels to select which values are labelled (disable, X, Y or X&Y for grids, disable, Lat, Lng, Both for graticules). 
These options are useful for rotated grids where grid lines may intersect on the wrong border of the grid or curved 
lines of latitude or longitude. The label rotation (Horizontal or Vertical) can be modified.

Other options for the coordinate labels are: 
•	Distance from the grid (Place labels off line by) — a negative value places labels inside the grid; 
•	Number of decimals; 
•	Label values: coordinates or distance from the lower left corner of the grid — index and measured grids only; 
•	Append units to labels: e.g. °, m;
•	Apply locale formatting: apply number formatting according to the locale settings in the MAPublisher 

Preferences (e.g. 10000 may be written 10,000 or 10.000 or 10 000).

ADVANCED OPTIONS 

Click the Advanced button to access additional grid extents and labelling options. 

Modify the bounding box extents of the grid or graticules by entering new coordinates for the Lower Left and Top Right 
position of the grid.

It is also possible to edit the first value used for cell labels by editing the Start alpha/numeric index at values. Omit 
certain alpha characters from cell references with the Do not use characters option. For example, it may be useful to 
omit the characters “I” and “O” for indexing purposes (when entering alpha characters to omit, separate characters with 
a comma). The Reference label order option can be edited to change the center labels from alpha-numeric (A-1) to 
numeric-alpha (1-A), or vice versa.

When creating graticules, users may need to edit the maximum graticule extents allowed. By default, MAPublisher 
automatically detects the maximum graticule extents as +/- 180° from the central meridian specified in the coordinate 
system definition of the current MAP View for longitudes and +/- 90° from the Equator for latitudes. The graticule is 
then created as the intersection of the bounding box and the maximum graticules extents.
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GENERATING AND EDITING THE GRID

When all the options have been set, click the Preview button to display a preview of the result. The Grids and 
Graticules dialog box may be minimized in the preview mode.

OK - Creates the grid on the artboard 
and closes the dialog box.

Cancel - Closes the dialog box without 
creating a grid.

Restore - Restores the full size Grids 
and Graticules dialog box to further 

edit the parameters.

Start alpha/numeric index at - Edit the first 
value used for cell labels.

Do not use characters - Enter alpha 
characters to omit from cell references. 

Reference Separator - Enter one or more 
characters to separate the alpha 

and numeric indexes (e.g. - or / for 
A-1 or A/1)

Reference label order - Choose to make 
Center Labels alpha-numeric or 

numeric-alpha.

Lower Left - Adjust X and Y values for 
the lower left of the grid extents.

Top Right - Adjust X and Y values for 
the upper right of the grid extents.

Advanced Grid Settings

Advanced Graticules Settings

Auto-Detect Graticule Bounds - Auto-Detect the 
maximum graticule extents from the MAP 

View's coordinate system definition.

Graticule Start | Graticule End - Enter specific 
coordinates for the graticule limits. 

Use only if the resulting graticule is truncated  
or wrapped.

In some rare cases, the bounding box specified may extend beyond the default limit (with some polar projections or 
some cases when the data crosses the 180 degrees west/east meridian), and the created graticule will be truncated 
or wrapped. In these cases, users may enter specific values for the Graticule Start and Graticule End coordinates in the 
Advanced dialog box — e.g. Start: -180, -90 | End: 360, 90. In most cases this is not necessary, so we recommend to use 
Auto-Detect and only edit the graticule start and end coordinates if the resulting graticule is truncated (increase extents) 
or wrapped (reduce extents). 
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Click OK to create the grid or Restore to return to setting up the parameters. The grid is plotted on the legend layer 
using the entered parameters. 

Once the grid is added on the artboard, use the bounding box of the generated grid (View > Show Bounding Box) to 
resize if required. Re-sizing grids horizontally or vertically adds, removes or re-sizes (index grids) component cells in 
the grid.

After transforming a MAP View containing a grid, the grid will be transformed and rescaled within its current 
bounds (the physical extents of the grid on the page is not edited), in which case the grid has to be resized manualy.

To change any parameter without generating a new grid, simply select the grid and access the Object > Edit Grid/
Edit Graticules menu item. This re-opens the Grids and Graticules dialog box populated with the current parameters 
of the grid. All parameters can be edited, even the grid type selection. 

IMPORTANT NOTES

Manually editing text position, font, colour etc is not possible on grids and graticules in their default grouped 
state. Manual editing is possible however if the grid is first expanded (Object > Expand), though this will negate any 
opportunity to subsequently edit the art via the Grids and Graticules dialog box. When expanded, grids cells are 
converted to both polygons (from index) and lines.

Measured grids cannot be labelled properly using actual coordinates when the data is projected using a 
stereographic or orthographic coordinate system (because some areas may have some high curvature).

If the generation of a grid/graticule causes blank or incomplete results, the following workflow should be used:

1.	 Transform the MAP View to a geodetic coordinate system (e.g. WGS 84). 
2.	 Generate a grid or graticules on this MAP View.
3.	 Expand the object (Object > Expand).
4.	 Create a new area layer in the MAP View. Drag the expanded grid to this new layer.
5.	 Transform the MAP View back to the original projection. 

Please see Appendix A3 for more information on working with grids and graticules in MAPublisher 8.
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Make Index 
Object > Filters > MAP Legend > Make Index* or MAP Toolbar 

Sort index by - Choose to sort the entries 
in the index file by either feature label 

or grid cell address.

Attribute Column Delimiter - Select a 
delimiter for the columns in the index 
file - Tab, Comma or Custom. If Custom 
is selected, enter the desired delimiter 

into the adjacent text field.

Make index based on label position - An index 
will be created by assigning one index 

location for each label found on the 
selected label text layer.

Make index based on label and matching 
feature position - MAPublisher will 

determine what features to index by 
matching label text on the selected 

Label layer to the indicated attribute on 
the Feature layer. An index is created 

for every grid cell in which the labelled 
feature can be found.

Advanced - Click this button to open 
the Advanced dialog box (below), to 
specify additional options for the index 
format.

Advanced Options

* In Adobe Illustrator CS3, Make Index is found in the Filter > MAP Legend menu.

Output Format

Single-line condensed - Creates one index 
entry for each unique label. The index is 

compressed in the format: A1-3;B2,4

Single-line expanded - Creates one index 
entry for each unique label. The index is 

in the format:  A1,A2,A3,B2,B3

Multiline - Creates one index per label 
recurrence.

Select additional attributes - Select one 
or more attributes to be added to 
the index file. The selected attributes 
appear in separated columns delimited 
by the chosen Attribute Column 
Delimiter.
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FUNCTIONALITY

When a grid (index or measured) or set of graticules have been created, the Make Index filter can be used to generate a 
map index based on the position of text elements in grid cells. Index files generated using this function are produced 
as a simple text file, and sorted alphabetically (by label or cell reference). A typical file would be formatted as follows:
		  Melrose Place	 B4
		  Richview Avenue	 A5
		  Sesame Street	 A4
		  Wisteria Lane	 B5

The index file has a header indicating the name of each column (name, attribute name if applicable, and grid 
locations).

PREREQUISITES

To create a map index, an Index Grid, Measured Grid or set of Graticules must have been created using the Grids and 
Graticules function. This grid must exist on a  Legend layer, and not be expanded, and must be selected in order to 
access the function. An index will be created even if grid labels are hidden.

The  Text layer containing the labels to be indexed must be located in the same MAP View as the grid.

To access the Make Index tool, click the menu Object > Filters > MAP Legend > Make Index or MAPublisher Toolbar 
button .

USING MAKE INDEX

Index Based on Label Position
This method creates an index by assigning one index location for each label found on the selected text layer. For 
example, if the label "High Street" is only found in grid cell A4, the only entry for "High Street" in the index file would 
be as follows: 	 High Street A4

Select the Make index based on label position button to generate an index using this method. Then choose the layer 
containing the text to be indexed from the Label layer drop-down list.

Index Based on Label and Matching Feature Position
This method creates an index by matching label text on a selected Label Layer to the indicated attribute on the 
Feature layer, creating an index entry for every grid cell in which the feature can be found. Note that only features 
that have labels can be indexed. For example if "High Street" passes through grid cells A3, B3 and C4, each grid cell 
will be in the index — on a single or multiline (see advanced options). For example as:  High Street A3, B3, C4

Use this function as follows:
•	 Select the Make index based on label and matching feature position option to generate an index using this method.
•	 Choose the layer containing the text to be indexed from the Label layer drop-down list.
•	 Choose the layer that was used to generate the labels from the Feature layer drop-down list. 
•	 In the Label text matches attribute list, select the attribute column in the selected Feature layer which matches 

the labels to be indexed.
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Advanced Formatting Options
To set additional options to control the formatting of the index file, click the Advanced button.

The Sort index by option controls the order of the index entries. The default setting is Feature label — entries  are 
ordered based on the label text (alphabetical). Alternatively, Grid cell can be selected to sort by the cell indexes.

The Attribute Column Delimiter indicates which delimiter is used to separate the different columns in the index file 
(label, additional attributes and indexes). The options are Tab, Comma, or a Custom delimiter. When using a custom 
delimiter, type the desired character(s) in the adjacent text field.

MAPublisher offers three types of Output Format:
•	 Single-line condensed: One index for each unique label is created. The grid cell references are compressed 

in the format: 
			   Label	 A1-3;B2,4;F-H9 
			   where:

•	 A dash "-" indicates a range: A1-3 means the label is found in cells A1, A2 and A3; F-H9 means 
the label is found in cells F9, G9 and H9. The ranges by number are grouped first and then the 
ranges by letter.

•	 A comma "," indicates a list: B2,4 means the label is found in cells B2 and B4 but not B3.
•	 A semicolon ";" separates each entry.

•	 Single-line expanded: One index for each unique label is created. All grid cell references as listed in the 
format:

			   Label	 A1, A2, A3, B2, B4, F9, G9, H9
•	 Multiline: One index for each cell reference is created: in the format

			   Label	 A1
			   Label	 A2
			   Label	 A3

Users can add more attributes to the index file by selecting one or more attributes from the Select addition attributes 
drop-down list. Additional attributes are inserted in the file in columns between the label and the grid locations, 
separated by the chosen Attribute Column Delimiter. For example:
			   Label	 Attribute1	 Attribute 2	 A1-3;B2,4;F-H9 

Saving the Index File
When all indexed options have been set, click the Save As button. Then specify a name for the text file, and the 
location where it will be saved. The index file can be opened in a text editor, or placed back into the document 
using the Adobe Illustrator Place function*.

* Using Adobe Illustrator CS4 on Mac OS X, it is recommended to copy the index contents into a text box instead of using 
the Place function.
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Scale Bars and 
North Arrows

MAPublisher contains tools for plotting accurate scale bars 
and north arrows onto your map. 

The Scale Bar filter offers a number of different designs that 
you can choose from, including double-bar designs for the 
placement of scale bars in multiple units. 

North Arrows are created from selected artwork on the page 
using the Create North Arrow filter, and will be immediately 
aligned to true north.

Topics covered in this section:
Scale Bar
Create North Arrow
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Scale Bar 
Object > Filters > MAP Legend > Scale Bar* or MAP Toolbar 

Object > Edit Scale Bar

FUNCTIONALITY

MAPublisher contains ten different scale bar designs that may be incorporated into a map. After creation, 
MAPublisher scale bars can be subsequently resized via a bounding box (for example to add or remove component 
intervals). Scale bars can also be edited by selecting the Object > Edit Scale Bar menu item.

PREREQUISITES

To accurately create a scale bar, a MAP View must contain accurate georeferencing information and the coordinate 
system must be projected. (i.e. not in degrees) . Scale bars are added on  Legend layers. If no legend layer is present 
in the document, a new legend layer will be created automatically.  To manually create a new Legend layer, use the 
Add MAP Layer button on the MAP View panel and specify a feature type of Legend (see chapter 4 for more details).

If a custom character style is to be used for the labels of the Scale Bar, it is also advisable to establish this style 
(Window > Type > Character Styles) before opening this dialog box.

Interval Options:

Labeled intervals - Enter the 
number of interval which will 
comprise each bar.

Horizontal lines - Select the desired 
number of horizontal lines to be 
included in the scale bar. Used 
with certain scale bar styles only

Sub intervals - Select the number 
of sub-intervals for each 
subdivided scale bar interval. 

Intervals to subdivide - Enter the 
number of scale bar intervals to 
be subdivided.

Add interval left of zero  
Check this box to have an interval 
placed on the scale bar to the left 
of the zero mark.

Display page to map units ratio - Check 
this option to show the scale 

as page unit to map unit ratio, 
selectable from cm, mm or inch. 

Specify the Precision and 
Placement.

† If the  Text style list does not contain a recently created character style, 
simply return to the Character Style panel, double-click this style and click 
OK in the Character Style Options dialog box. This forces Adobe Illustrator 
to re-load the list of character styles.

Preview Panel - Displays a preview 
of the generated scale bar.

Select Style - Click the up or down 
button to browse through the 

scale bar styles.

Units - Select the desired map 
units to be used in the selected 

scale bar.
Interval - Specify the length of 
each interval in the selected 

map unit.
Maintain relative size - Check this 
option to convert the interval 

values when units are changed..

Apply local - Use the locale 
format settings specified in the 
General section of MAPublisher 

Preferences..

Text Style† - Select the Adobe 
Illustrator Character Style to be 

applied to the text.

Display scale value - Check this 
option to display the scale value 

above or below the bar. 

Display units - Check this option to 
display the interval unit
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ADDING A SCALE BAR

The Scale Bar dialog box is accessed by clicking the menu Filter > MAP Legend > Scale Bar or MAPublisher toolbar 
button . 

Standard Options

Use the Up and Down buttons to select a scale bar design .Note that certain scale bar designs contain two bars and 
when such a design is selected, the Second Bar column of options will be enabled.

In the Units drop-down list, specify the units for the scale bar interval(s) to be based on. The default units are that of 
the current MAP View. 

In the Interval text box(s), specify a real-world distance that each interval of the scale bar will represent. This figure 
will be in the unit specified in the Units list.

NOTE: 	 A scale bar cannot be created on a MAP View that contains a coordinate system using custom (user 
defined) point styles or units.

Specify the number of cells in the bar(s) by entering a figure in the Number of labeled intervals entry field. 

Depending on the chosen style of scale bar, it may be required to specify the Number of horizontal lines that will 
compose the scale bar.

To subdivide some of the intervals or cells in the bar(s), choose a figure from the Number of intervals to subdivide list. The 
subdivided cells will begin from the left of the bar(s). The Number of sub-intervals that compose each of these cells can 
be specified in the next list. As required, choose to Add an interval left of zero.

Labelling Options
Choose a Character style for the scale bar labels by choosing a style from the list. The label options allow adding 
extra scaling information to the generated scale bar. The text that will be generated by this tool is displayed in the 
Preview panel when the options are set. 

Generating the Scale Bar
Click OK to place the selected scale bar on the legend layer at a default position (lower left corner of the artboard. 
The Adobe Illustrator editing tools may be used to move the scale bar to a desirable location. 

* In Adobe Illustrator CS3, Scale Bar is found in the Filter > MAP Legend menu.
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EDITING A SCALE BAR

Use the bounding box of the generated scale bar (View > Show Bounding Box) to resize. Resizing scale bars 
horizontally will add or remove intervals from the bar(s). Resizing vertically will adjust the width of the bar(s).

Scale bars can also be resized using the Adobe Illustrator menu Object > Transform >Transform Each, by changing 
the horizontal or vertical scales. 

To change the design of the scale bar, or to modify any parameter without generating a new version, select the 
scale bar and access the Object > Edit Scale Bar menu item. This will re-open the Scale Bar dialog box and the current 
parameters of the bar will be available for editing.

NOTE:	 Manually editing the type position, font, colour etc. is not possible on scale bars in their default grouped 
state. However, manual editing is still possible if the object is expanded first (Object > Expand). Please note, 
however, that this will remove all opportunity to subsequently edit the art via the Scale Bar filter. Please see 
Appendix A3 for more information on working with scale bars in MAPublisher 8.
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Create North Arrow 
Object > Filters > MAP Legend > Create North Arrow* or MAP Toolbar 

FUNCTIONALITY

The MAPublisher Create North Arrow filter provides the functionality to convert selected symbology into a 
geographically correct north arrow. Once the north arrow is created it will be rotated to true north, and this 
property will be maintained through subsequent reprojection or rotation. 

PREREQUISITES

The MAP Layer on which the art to be converted to a north arrow resides must be a  Legend layer, and be selected. 
This Legend layer must be hosted by the MAP View base for the alignment of the north arrow. 

CREATING A NORTH ARROW

Select the piece of art to be converted to a north arrow. The art can be any form of artwork which can normally 
be converted to an Adobe Illustrator symbol. Then select Filter > MAP Legend > Create North Arrow or MAPublisher 
toolbar button .

Upon creation, the north arrow will be added to the Adobe Illustrator Symbols panel and the coordinate system of 
the host MAP View will be used to align the north arrow correctly.

When the north arrow symbol is repositioned on the map, it will be re-oriented to the true north at the new location.

NOTE: 	 Sample north arrow designs are included on your MAPublisher DVD. Go to Window > Symbol Libraries > 
Other Library… navigate to the Helpful Styles & Symbols folder on the DVD and load the MAP_NorthArrows.ai 
file. Drag the required symbol onto the Legend layer and then execute the Create North Arrow filter.

* In Adobe Illustrator CS3, Create North Arrow is found in the Filter > MAP Legend menu.
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Users should have a basic understanding of HTML syntax 
to use this feature.

MAPublisher 8 introduces the MAP Web Author tool that 
exports Adobe Illustrator documents with GIS attribute data 
to interactive Flash maps; complete with callout bubbles, 
rollovers, layer control, pan and zoom controls.

Like other MAPublisher functions, MAP Web Author is 
completely built-in to Adobe Illustrator. An interactive Flash 
map can be exported without any additional coding or 
software requirements. Therefore, users are not required to 
have Adobe Flash installed to benefit from this tool.

Flash map export offers controls for the layers visibility. 
Additionally, map features (point, line, and area) can be 
identified from the attribute information when users type a 
keyword in a search box.

Users with a good understanding of HTML, CSS and 
Javascript will be able to customize maps to embed into any 
web page using the MAP Web Author API and CSS tools.

Topics covered in this section are:
MAP Web Author Panel
Web Tag Dialog
Export to Web
Web Export Advanced Settings
MAP Web Author Workflow
Advanced Features

MAP Web 
Author
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MAP Web Author Panel 
Window > MAPublisher > MAP Web Author or MAP Toolbar  

FUNCTIONALITY

The MAP Web Author tool exports a MAPublisher document as an interactive Flash map for Web display. Together with 
the map artwork, Web tags (also known as callout bubbles) are included in the export. Prior to the export process, 
the MAP Web Author panel is used to create, edit or modify these interactive objects.

Web tags can either be populated one object at a time or for a selection of objects. To create or edit multiple Web 
tags, select artwork and click the Edit button. Using this method, the same Web tag format is applied to all selected 
artwork. Information can be entered manually or extracted from the MAP Attributes fields (when available for the 
object layer). At any time, Web tags can be edited or modified by selecting them and clicking Edit.

Text and image formatting is created using simple HTML (Hyper Text Markup Language). The results can be checked 
in the Callout Preview window available in the Web Tag Dialog.

Additional settings such customizing the navigation and callout bubbles are available during the export process.

Export to Web - Opens the Web Export 
Dialog to finalize settings for export

Zoom - Zooms to selected Web tags

Edit - Opens the Web Tag Dialog.
Create or modify Web tags

Remove - Delete Web tags of any 
selected objects

All Web Art - Select all artwork that have 
a Web tag in the document.

Previous/Next Web Artwork - Navigate 
between Web tags. Status displays how 

many Web tags are selected.

Specify Source Media Folder

Specify Source Media Folder - Specify the 
directory path to the media files

Browse - Browse to the directory 
containing the media files (images)Absolute Path - Select this option to set 

an absolute path (best used when 
working on a single computer)

Relative Path - Select this option to set a 
path relative to the current location of 
the Adobe Illustrator document (best 

used when files have to be moved). 
Newly created documents must be saved 

for this option to be enabled.

Reset - clear the current Source Media 
Folder settings

MAP Web Author Panel

Web Art on Layer - Select all the artworks 
that have a tag in the currently 
selected layer
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PREREQUISITES

In order to use MAP Web Author, first complete a map using MAPublisher and Adobe Illustrator tools. The Adobe 
Illustrator document size will determine the size of the Flash map. It is recommended to set the document size 
before any work is started. However, the document size may be changed in the Adobe Illustrator Document Setup 
(CS3) or Artboard Options (CS4) dialog box at any time. Using pixel units is the most practical to determine Flash map 
sizes in a Web browser.

To populate Web tags, MAP layers must have relevant attributes populated in its MAP Attributes table. For 
example, to insert links to images, the MAP layer must have a dedicated attribute field containing an image path 
(e.g. \images\picture1.jpg). 

NOTES: 	
•	 Not just any map can be made into a Flash map. A print ready map does not necessarily mean that it is 

a Flash ready map. Unneeded art and attributes should be removed, lines should be simplified. Layers 
that do not require tagging will still be exported. 

•	 Only the active artboard will be exported to Flash (Adobe Illustrator CS4 only).

The Source Media Folder containing the images must be organized properly. The supported image formats are jpeg, 
png and gif. To be sure that images can be viewed properly, the latest Flash Player version should be installed 
(download from Adobe website www.adobe.com).

USING MAP WEB AUTHOR

Specify the Source Media Folder
The Source Media Folder is the directory containing images that might be displayed in the Web tags (callout bubbles). 
The path to this directory is chosen through Specify Source Media Folder in the MAP Web Author panel options menu.

Either an Absolute Path or a Relative Path may be entered. An absolute path refers to the full folder directory path 
(e.g. C:\folder1\folder2...). A relative path refers to the folder path from the current location of the Adobe Illustrator 
document. In the example below, the relative path starts from \MAPWebAuthor_Tutorial.

Absolute Path example Relative Path example

If the Adobe Illustrator file is to be exchanged between computers, it is good practice to use a Relative Path to avoid 
having to reset the link to Source Media Folder when the files are moved.
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Add, Edit and Remove Web Tags
To add or edit a Web tag, select a piece of artwork and click the Edit button in the MAP Web Author panel. This opens 
the Web Tag Dialog where the Web tag settings can be defined. When multiple artwork is selected, any settings made 
in the Multiple Web Tag Dialog are applied for all of the selected artwork. They may be individually modified by scrolling 
through the Web tags or at a later time by selecting the artwork and clicking the Edit button.

To remove Web tags, select artwork with an associated Web tag and click the Remove button.

Selection
Select any artwork in the document and the MAP Web Author panel displays the number of Web tags (assuming 
the artwork contains a Web tag). To select all the artwork with Web tags in a document, click the All Web Art button. 
To select all the artwork with Web tags on a specific layer, select the layer in the Adobe Illustrator Layers panel, and 
click the Web Art On Layer button. Use the navigation buttons to consecutively move to the previous or next artwork 
that contains a Web tag.

The Zoom To Selected Art option centers the Adobe Illustrator document view to the selected artwork with Web tags. 
Check this option and use the Previous/Next Web Art buttons to navigate between them.

Export to Web
The Export to Web button opens the Web Export Dialog described later in this chapter.



165Chapter 15: MAP Web Author
Web Tag Dialog 

Web Tag Dialog 

Callout Title - The title of the 
callout bubble.

Callout Preview - Open or close the 
preview of the callout bubble.

Callout Editor - Edit the callout 
contents. Supported HTML tags 
may be used to format the text 
and images in the contents.

Callout Size - Set the size (width 
and height in pixels) of the 
callout bubble.

Auto Size - Check this option to 
automatically size the callout 
bubble around its contents.

Callout Image - Choose Manually 
to browse to the image. 

Choose By Attribute and type 
the attribute name containing 

the path to the image.

HTML Tags and Graphic Tools
Use these tools to edit the text. 

From left to right: Bold, Italic, 
Link, Line Break, Unordered 

List, and Image. Chart options 
include Bar Chart and Pie Chart. 
The insert attribute drop-down 

list contains attributes 
contained in the layer.

Image Width and Height - Specify 
the image width and height in 

pixel or use default size.

HTML Supported Tags - Open 
Adobe Flash documentation to 

view more information about 
supported HTML tags.

Trigger External URL (Advanced)
Control how URLs are opened 
when either clicking or hovering 
over Web art. Framesets or target 
must be created to direct the Web 
page to a specific frame.

Callout Bubble example:

Callout title

Callout Image - as set in the 
Callout Image section

Callout Contents - can contain text, 
images and graphics. Set in the 
contents frame.

FUNCTIONALITY

Click the Edit button in the the MAP Web Author panel to open the Web Tag Dialog (Multiple Web Tag Dialog if multiple 
artwork is selected). These dialog boxes are used to design the Web tags (callout bubbles) using HTML. These 
callout bubbles appear when objects in the Flash map are clicked or hovered over. Not all objects in the map need 
to be associated with a callout. Use the Callout Preview to see how the HTML affects the Web tag.

NOTE:	 Document artwork (lines, areas, points) associated with callout bubbles are also called Web Art. Only Web 
Art will be searchable in the resulting Flash map (see Export to Web).

Previous and Next - Click Previous or Next button to 
switch from one Web tag to another (enabled when 
multiple artwork is selected).
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PREREQUISITES

In the Web Tag Dialog, text and image parameters are edited using HTML tags. HTML tags are key codes written 
between less than (<) and greater than (>) signs, that indicate how the Web browser should display the text. There 
are opening and closing version for most (but not all) of the tags, and the text to be affected is contained between 
the both tags. Both the opening and closing tags use the same key code but the closing tag is preceded by an initial 
extra forward slash sign (/).

Examples of text formatting

			   <b>Maps of the World</b>  Maps of the World	
	
			   <i>Maps of the World</i>  Maps of the World	

Examples
Some HTML tags are used to insert links and images.
•	<a href="http://www.avenza.com">Avenza Web Page</a> 

 Creates a link to www.avenza.com accessed when clicking "Avenza Web Page" text.
•	<img src="sourcemedia/picture.jpg" hspace="0" vspace="0" align="left" >

 Inserts an image (picture.jpg located in the Source Media Folder).

HTML ignores extra spaces and returns, therefore tags such as <br> (to create line breaks) and <p> (to start a 
new paragraph) should be used. In addition to the HTML tags, MAPublisher can use text extracted from the MAP 
Attributes table. The reference to the attribute field name is indicated between two percent (%) signs. For example, 
%AttributeName%.

Examples of using attribute fields
•	<b>%Street_Name%</b>  Main Street
•	<img src="sourcemedia/%image%" hspace="0" vspace="0" align="left" > 

 Displays image indicated in the attribute called "image" (a string text). hspace and vspace set the 
horizontal and vertical space left blank around the image. align set the image alignment to the left of 
the page

•	<a href="http://%WebSite%">Avenza Web</a>

 Avenza Web (and opens the Website indicated in the attribute WebSite on click).

Opening Tag Closing Tag
Text

Result
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USING THE WEB TAG DIALOG

Callout Set-up and Preview
The Preview button opens or closes the preview of the callout. As text and images are inserted, the preview gets 
updated to show the aspect of the callout bubble prior to export. Set the Height and Width of the callout bubble in 
pixel units or use the Auto Size option. This option sets the size of the bubble automatically based on the contents of 
the callout (image and text). Note that pie and bar charts cannot be displayed in the preview.

NOTE:	 Due to some known Flash Player HTML rendering limitations, the callouts of a Flash map exported using 
the MAP Web Author tool may not appear in a browser exactly as shown in the MAP Web Author tool 
preview window which supports proper HTML rendering. For example, ordered and unordered lists (<ol> 
and <ul> tags) are not recognized by Flash Player so they do not modify how the list is rendered and all list 
items will be shown using bullets.

Insert a Title
Callout bubbles can be given a title. The title can be typed in as a simple text, but it can also be formatted using 
HTML tags and MAP Attribute values. The attribute field name must be entered between percent (%) signs, e.g. 
%TITLE%.

Insert an Image
Images can be inserted into callout bubbles using two methods: Manually or By Attribute. To insert an image manually,  
choose the Manually option and browse to the image file. To use an attribute value containing the path to the image 
file, choose the By Attribute option and type the attribute field name into the box. The field name must be entered 
between percent (%) signs, e.g. %Image_File%.

By default, the original image size is used. To change the image size, enter a new Width and Height into the boxes. The 
width/height ratio is maintained. Use the Callout Preview to view the size of the image. This option is not available 
for Multiple tagging with option By Attribute.

NOTE:	 The maximum size for a callout is 1000 pixels x 1000 pixels. When this limit is reached, images are 
automatically scaled to fit (image aspect ratio is maintained).

Add and Edit Contents
As explained in the Prerequisites, the callout bubble contents can be typed and formatted using HTML tags. 
However, the Web Tag Dialog provides a series of tools to create HTML tags more quickly. The table below shows the 
tag buttons and functions that are available.

To insert a tag into the callout editor box, click a tag button. Then type callout text in between the opening and 
closing tags. Alternatively, highlight text with the cursor and click a tag button to wrap tags around it. Use the 
Callout Preview to see how the text, links or charts are displayed.

Aside from the HTML tags, the Web Tag Dialog provides a drop-down list to pick MAP Attributes (visible attributes only). 
Choose an attribute from the drop-down list and it will be entered into the callout editor box.

NOTE:	 MAP Attributes column names are case sensitive.
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Tag button Tag Function HTML tag example Result

Bold <b>bold text</b> bold text

Italic <i>italic text</i> italic text

Hyperlink <a href=”http://www.avenza.com”>Avenza Page</a> Avenza Page

Line Break line<br>break
break 
line

Unordered List

<ul> 
<li>list 1</li> 
<li>list 2</li> 
</ul>

•	 list 1
•	 list 2

Insert Image <img src=”ImageFile/Canada.png”>

Pie chart

<chart type=”pie” showLegend=”true” 
values=”’key1’, ‘%attrib1%’ | ‘key2’, 
‘%attrib2%’” colors=”0xff0000, 0x00ff00” 
width=”180” height=”180” >

Horizontal bar chart

<chart type="horizontalbar" showLegend="true" 
showAxisValues="true"  values="'key1', 
'%attrib1%' | 'key2', '%attrib2%'" 
colors="0xff0000, 0x00ff00" width="180" 
height="180" >

Vertical bar chart

<chart type="verticalbar" showLegend="true" 
showAxisValues="true"  values="'key1', 
'%attrib1%' | 'key2', '%attrib2%'" 
colors="0xff0000, 0x00ff00" width="180" 
height="180" >

Additional information for pie and bar charts:
•	 key1: Legend for the first value. Enter a text in between ' sign. For example: 'Male Population'
•	 %attrib1%:  Attribute that contains the first numerical value for the graph, as found in the MAP Attributes 

panel. For example, if the attribute is named MALE_POP enter '%MALE_POP%'
•	 key2:  Legend for the second value. You can enter a text of your choice in between ' sign. For example: 

'Female Population'
•	 %attrib2%:  Attribute that contains the second numerical value for the graph, as found in the MAP 

Attributes panel. For example, if the attribute is named FEMALE_POP enter '%FEMALE_POP%'
•	 colors: enter a list of colors for the chart (first color, second color etc...). The color values must be entered 

in hexadecimals values. For example, use the Adobe Illustrator Color Picker and select color : the hex 
value (below the B of RGB). However, Illustrator write the color #BC1E1E , but in MAP Web Author, the # 
sign by 0x (zero-x) replaces the # — so 0xBC1E1E must be entered.

•	 width and height: Size of the graph in pixels.
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Advanced HTML tags combinations are possible to create more effects. For more information and a complete list of 
HTML tags supported by Adobe Flash, click the link on the Web Tag dialog box or go to http://livedocs.adobe.com/
flash/9.0/main/wwhelp/wwhimpl/common/html/wwhelp.htm?context=LiveDocs_Parts&file=00000922.html.

Auto Size Option
When this option is used, the callout bubble automatically resizes to fit to its contents.

Trigger External URL
The Trigger External URL options allow an advanced Web designer to load a specified HTML document (designated 
by its URL address) into a targeted HTML frame. Attributes may be used (i.e. %ATTRIBUTE_NAME%). This option 
occurs when the Web Art is clicked or hovered over. 

A Web browser can be divided into multiple panes called HTML frames, to present documents in multiple views, 
which may be independent windows or subwindows. For example, within the same window, one frame might 
display a static banner, a second a navigation menu, and a third the main document that can be scrolled through or 
replaced by navigating in the second frame. An example layout could be as follow:

Frame 1

Frame 2

Frame 3

Names of frames created by Web designers must begin with an alphabetic character (a-z/A-Z). Some special 
purpose HTML frames have reserved names with a leading underscore. The following reserved names are available 
for selection from the Target drop-down list.

_blank: 	 Loads a linked document into a new blank window (unnamed). 
_self: 	 Loads a linked document into the same frame in which the link was clicked (frame containing Flash map).
_parent:	 Loads a linked document into the immediate parent of the document the link is in (frame containing 

Flash map).
_top:	 Loads a linked document into the entire window, clearing the frames.

To use the Trigger External URL options, enter the URL address of the HTML document to open in the Hover 
URL or Click URL fields. The specified URL can be any page available locally or any external Web page (for 
example http://www.avenza.com). In the Target drop-down list, enter the name of the destination frame (type in the 
name given by Web designers or use one of the four available reserved names). 
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Web Export Dialog

Export Settings

Export Location- The destination 
folder of the exported 

Flash documents.

Layer Controls - Lists all the layers 
in the active artboard. All layers 
will be visible, but only checked 

layers under User Toggle can be 
shown/hidden by a user. 
Options - Set layer export 

options. Show a layer at certain 
zoom levels, set initial layer 

visibility and static content is 
affected by pan and zoom.

Export - Export the document to 
a Flash map.

Compress Metadata File - Check 
this option to compress 

the map data file, map.xml 
(recommended).

Viewer Settings 
See next section for more details

Viewer Style - Use these setting to 
control the style and position 

of navigation  objects and map 
elements. Any changes to the 
default settings will output a 

new CSS file. 
Use External CSS File - If an external 

CSS file is specified, it will 
override any of the settings 

specified above. When a CSS 
file is specified, an Edit link is 

enabled. It opens the file in the 
system's default text edtior.

Viewer Settings - Customize the 
navigation controls of the map. 
The default settings shown are 

shown here.

JPEG Image Quality & Resolution
Drag the slider to control 

the amount of JPEG file 
compression. 

Map Settings 
Width and Height - Size of the 
Flash map in the browser. 
Cannot be larger than the 
Adobe Illustrator document.
Set to Artboard - Reset the width 
and height to its original values.
Pan X and Pan Y - Initial pan shift 
applied to the Flash map (from 
top-left corner).
Initial Zoom - Zoom level when 
the Flash map is opened. 
Minimum Zoom - The minimum 
zoom level that the map can 
be set to. 
Maximum Zoom - The maximum 
zoom level that the map can 
set to.

Preserve Appearance - Flatten 
artwork to a single layer before 

export. Checking this limits 
the editability of the file. When 

unchecked, path simplifications 
are applied by Adobe Illustrator. 

Flash Player Security Sandbox 
Provides a restricted area for 
the map that prevents access 
to private data. Depending 
on location of final Flash map, 
choose Local or Network. It is 
set to Auto by default.
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FUNCTIONALITY

Use the Web Export Dialog to set the look and feel of the Flash map: style navigation objects and map elements such as 
buttons, the search box, overview map, layer list, callout bubble, zoom slider, and highlight lines and colours. These 
are the final settings before exporting the document as a Flash map.

PREREQUISITE

Web tags must be first created using the Web Tag Dialog.

USING WEB EXPORT DIALOG

In the MAP Web Author panel, click the Export to Web button  to access the Web Export Dialog. The Web Export Dialog 
contains two tabs. The Export Settings tab controls the export location, layer options (visibility, toggability, etc.) and 
the Flash map settings. The Viewer Settings tab control the appearance and disposition of the Flash widgets.

WEB EXPORT DIALOG - EXPORT SETTINGS

In the Export Location box, specify the directory that will store the HTML index file (by default index.html) and Flash 
export files. Click the Export button to complete the Web export.

Layer Controls
To insert a layer list in the Flash map, at least one layer check box under the User Toggle column must be checked 
(Export Settings tab) and the Show Layer List option must be enabled (Viewer Settings tab). Layers that are checked 
are included in the Flash map layer list and can be toggled on or off. The layers that are unchecked are exported, but 
can not be toggled on or off.

Navigation buttons - Pan up, pan down, 
pan left and pan right buttons. 

Home button in the center of the 
pan buttons centers the map to its 

original view.

Zoom Slider - Move the slider arrow 
up or down to zoom in or out, 

respectively. Use the Zoom In or 
Zoom Out buttons to zoom at specific 

increments.

Layer list - Check boxes toggle 
layer visibility. Only layers 

checked under User Toggle are 
shown in the layers list.

Search box - Type text into search box 
and it searches through the contents 
of all the exported callout bubble. 
Results are highlighted on the map.

Callout Bubble - Web tag or pop-up 
displays content created in the Web 
Tag Dialog. 

Overview Map - Displays the full 
extent of the map at all times. When 
zoomed into the main map it shows 
the zoom extent. The zoom extent is 
interactive and can be used to pan 
around the map.

Highlighted Lines - By default, objects 
clicked on are highlighted in blue, 
objects hovered on are in green and 
objects found by the search are in 
yellow.
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Layer Export Options
It is also possible to customize the visibility and zoom of each layer. Double-click [Click Here To Set Layer Options] to 
access the Layer Export Options dialog box.

Map Settings
Use these settings to change how the Flash map is displayed in a Web browser:

•	 Change the width and height of the Flash map. It cannot be larger than the Adobe Illustrator document. 
Click the Set To Artboard button to reset the width and height to its original values.

•	 Set the initial position of the Flash map upon load using Pan X and Pan Y (if zoomed-in).
•	 Set the initial zoom upon load. Set the minimum and maximum zoom that the map is allowed to have.

Additional Settings
Images in Adobe Illustrator are exported as JPEG. The JPEG Image Quality & Resolution slider sets the compression level 
of exported images. This setting does not apply to images included in Web tags.

The option Use Preserve Appearance Settings For Flash Export flattens the artwork to a single layer before exporting. It is 
recommended to maintain the artwork quality. However, some known issues with Adobe Illustrator Flash export 
cause some documents to fail to export with this option enabled.

The Flash Player Security Sandbox provides a secure area in which a Flash map will load. Three options are offered:
•	 Auto: If the file is opened from a Web based URL, the sandbox is automatically switch to Network. If the 

file is opened from a file folder, the sandbox switches to Local. 
•	 Network: When Network is selected, Flash Player classifies assets (including SWF files) from the Internet 

in separate sandboxes that correspond to their Web site origin domains. By default, these files are 
authorized to access any resources from their own server, but can not load any local files or resources 
unless these are enabled through the Flash Security Settings (see later in this chapter).

•	 Local: With this option, Flash Security Settings are not required, however only contents from the local 
host computer can be accessed by Flash Player (i.e. hyperlinks, API will not function). This option is 
recommended when distributing Flash maps on CD, for example.

Initial Visibility - Show or hide 
the layer when the map is first 

loaded in a Web browser.

Zoom Range Visibility - By default, 
the layer is always shown. 

Choose a zoom level range for 
the layer to be visible within. 
When the layer is outside the 

zoom range, it is hidden.

Static Content Layer - By default, 
the layer will be affected by pan 

and zoom. Choose the second 
option so that a static layer is 

not affected by pan and zoom.

Layer Export Options
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The Compress Map Data File (map.xml or map.xml.zip) is used by the Flash viewer to get information on the initial zoom 
level, Web tag content, tagged object geographic coordinates. It is recommended to keep this option enabled to 
use a compressed version of this file (map.xml.zip) to maintain a fast loading map. However, advanced users may 
use the uncompressed version (map.xml). For example, an advanced user could create programs that automatically 
update the Web Tag contents. Once compressed, this file cannot be uncompressed to map.xml. If this file is required, 
the export must be run again with this option turned disabled.

NOTE:	 In MAPublisher 8.0, the metadata file was named map.afm or map.afm.compressed. The decision was made 
to change the file extensions because these file formats were not recognized by all Web servers.

WEB EXPORT DIALOG - VIEWER SETTINGS

Viewer Style
To set the style and position of the MAP Web Author map viewer controls, users can edit the Viewer Style list or use a 
CSS (Cascading Style Sheet). CSS is a style sheet language that enables the separation of document content (HTML, 
JavaScript) from document presentation — it is a simple mechanism for adding style (e.g. fonts, colors, spacing) to 
multiple Web pages at once.

The Viewer Style list contains MAP Web Author map viewer controls which include navigation buttons, zoom slider, 
search bar and callout bubbles. Each control can be styled and positioned by adjusting basic property values. Users 
can export with the default values without further adjustment. If any control properties are changed from the 
default values, a custom CSS file is exported to the export data folder.

NOTE:	 The controls in the Viewer Style list contain only basic properties, for more advanced designs an external 
CSS file should be used (see below).

Map viewer controls and properties in the Viewer Styles list are as follows — all positions are relative to the top left 
corner of the Flash map:

•	 Pan Up Button (Top, Left) - Position of the pan up button.
•	 Pan Down Button (Top, Left) - Position of the pan down button.
•	 Pan Left Button (Top, Left) - Position of the pan left button.
•	 Pan Right Button (Top, Left) - Position of the pan right button.
•	 Pan Home Button (Top, Left) - Position of the pan home button.
•	 Zoom In Button (Top, Left) - Position of the zoom in button.
•	 Zoom Out Button (Top, Left) - Position of the zoom out button.
•	 Zoom Slider (Top, Left) - Position of the zoom slider widget.
•	 Click Callout Bubble (Corner Radius, Show Arrow, Drop Shadow, Fill Colors Start, Fill Colors End) - style of a 

callout bubble when it is clicked.
•	 Hover Callout Bubble (Corner Radius, Show Arrow, Drop Shadow, Fill Colors Start, Fill Colors End) - style of a 

callout bubble when it is hovered over.

DropShadowAngle (here 45°)

DropShadowDistance 
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•	 Fixed Position Callout Bubble (Top, Left, Width, Height, Corner Radius, Draw Bubble, Fill Colors Start, Fill Colors 
End) - position and style of a static position callout bubble.

•	 Click Highlight Line - (Visible, Color, Transparency, Line Thickness).
•	 Hover Highlight Line - (Visible, Color, Transparency, Line Thickness).
•	 Search Highlight Line - (Visible, Color, Transparency, Line Thickness).
•	 Search Box (Top, Left) - Position of the search box.
•	 Layer List (Top, Left, Width, Height) - Position and size of the map layer list.
•	 Overview Map (Top, Left, Proportion) - Position and proportion (relative to map size) of the overview map. 

Alternatively, enable Use External CSS File and browse to a CSS file. The file will overwrite any of the configurations 
made in the Viewers Style list. Using an external CSS files for styling the viewer is advantageous because more visual 
aspects of the viewer can be set — such as, callout bubble style, text font, images for buttons — and external CSS 
can be reused for multiple maps. If the need arises, the external CSS file can be updated after the map has been 
exported.

For advanced users, the appearance of the MAP Web Author map viewer can be fully customized using CSS. The CSS 
implementation is based on the Adobe Flex 3 CSS system. Only class selectors are supported. Full documentation 
is located on the Avenza Systems website at http://www.avenza.com/mapublisher/mapwebauthor/css. This site 
includes CSS samples and examples of CSS code. 

Viewer Settings
In the Viewer Settings section, check/uncheck any of the check boxes to enable/disable the object/feature. Most of 
these options are enabled by default unless otherwise specified.

•	 Enable Navigation - Displays all of the navigation buttons, search box, layers list and overview map.
•	 Show the Click Callout Bubble - Display a callout bubble when a feature with a Web tag is clicked.
•	 Show the Hover Callout Bubble - Displays a callout bubble when a feature with a Web tag is moused over.
•	 Use Full Callout Content for Hover Callout - Displays full callout bubble when option to show hover callout 

bubble is enabled. Disabled by default.
•	 Show the Fixed position Callout Bubble - Displays a fixed position callout bubble. Disabled by default.
•	 Use Centroid Instead of Mouse for Callout Position - places the callout bubble position of a feature with a Web 

tag on the centroid. Disable it so that the callout position occurs where the mouse position is.
•	 Disable Viewer Navigation Animations - Enabling this option disables panning and zooming animations. 

Disabled by default.
•	 Use Low Stage Quality During Animations - Lowers the quality of animations for improved performance. 

Disabled by default.
•	 Export All Attributes With Map Features - Forces all attributes to export, regardless of whether they are used in 

a Web tag or not. Disabled by default.

NOTE:	 The visibility of the controls may also be set through an external CSS file.
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Layer List - List of the exported 
layers, including file name, 
number of vertices and file size.

Export Folder - Link to the export 
folder. Right-click to copy link 

location to clipboard.

Metadata (.xml) File Size - Size of 
the created metadata.xml file.
Less than 50 KB compressed 

(xml.zip) is ideal.

Total SWF File Size - Total file size 
of the created SWF files. 

Less than 600 KB is ideal.

Set Folder Permissions - Set folder 
permissions. Read more 

about Flash Security and 
permissions.

Export Again - Return to the Web 
Export Dialog.

Web Export Log

Flash Security and Permissions
When exporting a Flash map intended for Web distribution, choose the Network option in the Flash Player Security 
Sandbox drop-down list. If a Flash map is intended for only local use, choose the Local option. By default, the Auto 
option is chosen and automatically detects whether the Flash map is run on a network or locally. If the Network 
option is selected, the Global Security Settings must be configured in the Adobe Flash Player Settings Manager 
before an Internet browser can properly view the Flash map without posting it on a server. If the Local option is 
chosen, it is not necessary to set folder permissions. However, files exported with this option will not work for a Web 
site and will have to be exported again with either the Network or Auto option.

EXECUTE WEB EXPORT

Click the Export button to execute Web export. The export summary is displayed in the Web Export Log.

The export creates an index.html file and an index_data folder in the export location (the "index" name is default, a 
custom name can be substituted here in the Export Location box). Some of the important files are:

•	 map.xml.zip (or map.xml when the Compress Map Data File option is not checked).
•	 map-viewer-local.swf and map-viewer.swf (map viewer implementation files).
•	 map_LN.swf (where N is the layer number; one file per layer when option to toggle is checked). 

View the README.txt file inside the export data folder for more information about each file.

The Web Export Log displays several export file size statistics: the total SWF file size and the metdata file size. These file 
sizes are meant to warn the users when files get very large. Large files should be avoided as they may be very slow 
to open on a Web site.
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Click the Set Permissions button in the Web Export Log dialog box to access the Adobe Flash Player Settings Manager 
(http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html):

1.	 Click Edit Locations.
2.	 Click Add Location.
3.	 Click Browse For Folder or copy the full path as written in 

the Web Export Log dialog box and click Confirm.

The folder is added to the list of trusted locations. Locations 
can be modified or deleted at a later time.

NOTE:	 You must be connected to the Internet in order to set these permissions.

View Flash Map
To view the exported Flash map, browse to the Flash export folder (as specified in the Web Export Dialog) and open the 
file index.html (or name specified in Export Location) in a Web browser. Check that the Web browser has the latest 
version of Flash Player installed (http://www.adobe.com/products/flashplayer/). An outdated version may cause the 
Flash map to display incorrectly.

NOTE:	 Depending on the security settings of the Web browser used, some warnings may appear when opening 
files exported with Local option enabled. These can be ignored.
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MAP Web Author Workflow 

MAPublisher 8 is installed with tutorial materials. It is recommended that users work with the exercises in order to 
gain familiarity with MAPublisher tools. The tutorial materials have an exercise dedicated to the new MAP Web Author 
panel. The following workflow can be used for guidance.

1) MAP COMPILATION WITH ADOBE ILLUSTRATOR / MAPUBLISHER 8

Users must create their map document using MAPublisher 8 and Adobe Illustrator tools. If the only purpose of the 
map is to create a Flash map, consider at this stage the document size parameter, as this determines the size of map 
viewer extents in the Web browser.

2) PREPARING FOR MAP WEB AUTHOR

a) Creating a working directory
Create a folder on your computer. This folder is used to store all the components for the Web Flash map and 
the exported Flash files. 

b) Preparing images for the callouts
Images that will be used in the Web tagging process must be collected and grouped in a folder (Source Media 
Folder). When inserting images using a MAP Attributes field for multiple artwork, note that it is not possible to 
change the photo dimensions in the Web Tag Dialog. Image dimensions should be edited in a photo editor first.

c) Setting document size for the Flash map
If the document size hasn't been set at step one (document creation), it should be modified through the 
Adobe Illustrator menu File > Document Setup prior to Web export.

NOTE:	 Changing the document size after artwork is created may result in the adjustment of symbol and 
text sizes as well as stroke widths.

d) Attribute table information to attach the callouts
To use attribute information for Web tags, it must be organized using the MAPublisher MAP Attributes panel. 
This may require creating new attribute columns for elements such as Web site links or image file paths.

e) Data preparation
Run the crop tool, simplify lines and remove unneeded attributes.

3) USING MAP WEB AUTHOR

a) Setup the Source Media Folder
The user have a choice between entering an absolute or relative path for the Source Media Folder. 
Example: 	 Absolute path: C:\Work\Flash_Project\Images
	 Relative path: \Images

NOTE:	 If an image is placed under C:\Work\Flash_Project\Images\MyImage\MyImage1.jpg, and the Source 
Media Folder is C:\Work\Flash_Project\Images, then the path \MyImage\MyImage1.jpg must be typed 
in the Web Tag Dialog (or in the MAP Attributes panel when using attributes).
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b) Creating callout bubbles
Using the Web Tag Dialog, insert content  (such as a title, images and text) into the callout bubbles Use the 
Callout Preview to see an example of how the callout bubble will look, prior to the export process.

4) EXPORT FLASH DOCUMENTS

The settings entered in the Web Export Dialog are determined by the desired aspect of the Web map. It is recommend 
that users try different configurations. Here are some basic examples:

5) VIEWING FLASH MAPS WITH A WEB BROWSER

Download the latest Flash Player version (http://get.adobe.com/flashplayer/) and install it. Open the Flash map in a 
Web browser to view it (i.e. select the exported html file and open it locally).

NOTE:	 If the Flash Player Security Sandbox is set to Network during the export, the folder permissions must be set in the 
Adobe Flash Player Settings Manager, as explained earlier in this chapter. If the option Auto or Local has been 
chosen during the export, the map can be opened while offline with no further settings.

Simple MAP - No layer control, no navigation 
(Basic Settings). No Search box (Advanced 
Settings).

Default Style Map - Built-in layer control and 
navigation button added through the 
Basic Settings only.
No Advanced Settings required.

Customized Style Map - External layer control 
and navigation button added through the 
Basic Settings. Removed zoom buttons 
and changed callout bubble style through 
Advanced Settings.
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Advanced Features 

Additionally to the common MAP Web Author functions, users with good knowledge of HTML and Javascript can 
benefit from some advanced features. The information for these features are provided on the Avenza Systems Inc. 
Web site (www.avenza.com) to allow for frequent updates and is available to all MAPublisher customers.

EXTERNAL CSS

As explained earlier in this chapter, the visual aspects of the widgets that appear in the MAPublisher Web Author 
viewer can be configured using CSS (Cascading Style Sheet). The CSS implementation is based on the Adobe Flex 3 
CSS system. Only class selectors are supported. 

Refer to the Web page http://www.avenza.com/mapublisher/mapwebauthor/css for information on how to edit the 
CSS file and for a reference to the list of classes available for styling and their supported properties. 

MAP WEB AUTHOR JAVASCRIPT API

The MAP Web Author JavaScript API allows developers to embed and interact with maps produced by MAPublisher 
in web pages.

Some Web pages have been developed on the Avenza Systems Inc. Web site to provide a guide to the API and is 
available to all MAPublisher customers. They include an API reference, FAQs and examples.

For more information please refer to http://www.avenza.com/mapublisher/mapwebauthor/api. 

The Web Author examples are also provided on the MAPublisher DVD.
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The MAP GPS feature allows for the collection, display and 
styling of raw GPS data directly in Adobe Illustrator. Using the 
MAP GPS feature, you can connect to many NMEA compliant 
GPS devices, collect data points and then use the information 
to apply it to maps. The data can be reprojected, styled, and 
scaled automatically when it is received.

The MAP GPS Panel is covered in this section.

MAP GPS
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FUNCTIONALITY

MAP GPS will collect, interpret, and apply styles to points and lines from information received from a supported GPS 
device within an Adobe Illustrator document, based on user settings. 

Several plotting options are available for use in MAP GPS. For plotting points, users can decide whether to plot 
single points using the Manual Plot option, to plot points based on a specific time interval, or to plot points based on 
a set distance interval. For plotting lines, the Start Route feature may be used to create a line feature containing all 
valid information received from the GPS device. 

Additionally, auxiliary settings may be used to plot points on separate layers when either a change in speed or a 
change in heading is observed, when concurrently using one of the previously mentioned plotting options. 

MAP GPS also provides the ability to automatically apply user defined attributes for specific layers while plotting, 
and to record a log file of information received from the GPS device, which may then be played back into an Adobe 
Illustrator document at a later time.

PREREQUISITES

Prior to being able to use MAP GPS, it is required to have a compatible GPS receiver. Supported devices include any 
NMEA compliant device which has a serial COM port or Bluetooth connection option (using a COM Port). To use 
devices with USB connection, the USB port must be converted to virtual serial COM port using software provided by 
the GPS vendor or a third party application. 

Prior to interacting with the GPS device, the proper COM port settings have to be specified in the Device Settings 
dialog box so that the GPS can communicate and interact with the MAP GPS function.

Either a new document or an existing document may be used to begin a GPS session. If the appropriate type of 
layer is selected in the layers panel e.g. a point layer, then points will be plotted on that layer. If no layer or an 
improper layer for the type of plotting action is selected then a new layer will automatically be created of the 
proper type. 

MAP GPS Panel 
Window > MAPublisher > MAP GPS Panel or MAP Toolbar 

Start/Stop Scanning - Begins or ends 
scanning of the GPS device depending 
on the current state.

Manual Plot - Plots a single point at the 
current location read from the GPS and 
applies the manual plot settings from the 
Point Plot Settings dialog box.

Plot by Time - Plots points at a specified 
time interval which are reflected in the 
Point Plot Settings dialog box. 

Plot by Distance - Plots points at a specified 
distance interval which are reflected in 
the Point Plot Settings dialog box.

Start/End Route - Creates a path using the 
selected Graphic Style using all valid GPS 
information received.

GPS Fix - Displays the status of the GPS 
fix. No Fix, 2D or 3D will be displayed. 

Satellites In Use - Displays the number 
of satellites which are currently being 

tracked by the GPS device .

Altitude - Displays the current altitude 
in metres above mean sea level.

Position - Displays the current position 
of the GPS device in either Lat/

Long or UTM coordinate systems 
depending on the option selected. Dilution of Precision - Displays the 

Positional (PDOP), Horizontal (HDOP), 
and Vertical (VDOP) values received 
from the GPS device.

Lat/Long or Map Units (Meter) - Indicates 
if Lat/Long or projected coordinates 
are used for the display of the 
Position data.
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USING THE MAP GPS PANEL

Start Scanning
This feature allows MAPublisher to interact with the specified GPS device. When the Start Scanning button is clicked, 
the settings specified in the Device Settings dialog box will be used to begin reading and interpreting the information 
the GPS is receiving. This information is then used to display the GPS status in the GPS panel as well as to plot points 
and/or lines. 

Manual Plot
This method plots a single point at the current position reported by the GPS device. The plotted point is reflective 
of the settings specified under the Manual Plot section of the MAP GPS Point Plot Settings panel, i.e. using the specified 
scale and point symbol. When Manual Plot is clicked, a single point will be plotted either on an existing point layer 
(if selected) or on a new layer which is automatically created if a point layer is not selected. If the Adobe Illustrator 
document does not contain any MAP View, a new one is created in the WGS84 geodetic coordinate system.

Plot By Time
This method plots a single point each time the specified time interval is observed. The time interval is displayed in 
the MAP GPS Point Plot settings panel along with other settings such as scale and point symbol. 

Plot By Distance
This method plots a single point each time the specified distance interval is observed. The distance interval is 
displayed in the MAP GPS Point Plot settings panel along with other settings such as scale and point symbol. 

Start Route
This method creates a line feature for all valid information received by the GPS. Line styling is determined by the 
Graphic Style selected in the Adobe Illustrator Graphic Styles panel. 
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MAP GPS DEVICE SETTINGS
Accessed from the MAP GPS menu.

Port Name - Select the proper serial port for your 
GPS device.

Baud Rate - Select the baud rate for your GPS device.

Data Bits - Select the data bits for your GPS device. 

Parity - Select the proper parity for your GPS device.

Stop Bits - Select the proper Stop Bits for your GPS 
device.

Flow Control - Select the proper flow control for your 
GPS device.

Test this Configuration - Select button to ensure all the 
specified features are inputted correctly before 

continuing. 

The MAP GPS Device Settings dialog box provides for the input of the specific settings for the connected GPS Device. 
Users are required to manually select the appropriate settings prior to using MAP GPS. Appropriate settings for 
specific devices can usually be obtained by consulting the device’s user manual or by contacting the manufacturer. 

Many of the MAP GPS features can be accessed via the MAP GPS panel options menu. These features include Device 
Settings, Point Plot Settings, Autosave Settings, Edit User Attribute, as well as many different log file features. The following 
sections will outline each of the features and their uses. 

Device Settings - Opens the Device Settings dialog box.

Point Plot Settings - Opens the Point Plot Settings dialog box.

Autosave Settings - Opens the Autosave Settings dialog box.

Edit User Attribute for Current Layer - Opens the Edit User Attribute for Current 
Layer dialog box.

Record Sentence Log - Opens the Record Sentence Log dialog box.

View Sentence Log - Opens the View Sentence Log panel.

Playback Sentence Log - Opens the Playback Sentence Log panel.

Start Scanning - Begins Scanning the GPS device.

Manual Plot - Plots a single point.

Plot by Time - Begins plotting points by a specified time.

Plot by Distance - Begins plotting points by a specified distance

 Start Route - Begins plotting a route.

MAP GPS Panel Menu 
Accessed from the MAP GPS Panel
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FUNCTIONALITY

The MAP GPS Point Plot Settings panel is used for controlling all of the settings related to points to be plotted by the 
GPS. In this dialog box, users define parameters such as scale, interval, and point symbol. The Point Plot Settings panel 
also controls the additional auxiliary settings such as change in speed and change in heading. Point symbols reflect 
the symbols found in the Adobe Illustrator Symbols panel. New symbols created or loaded in the Adobe Illustrator 
Symbols panel will be appended to the MAP GPS Point Plot Settings panel.

Use the Type drop-down list to enter the settings for Manual Plot, Plot By Time, Plot by Distance, Plot by Change in Speed or Plot 
by Change in Heading.

USING THE POINT PLOT SETTINGS PANEL

Manual Plot
The Manual Plot setting option controls how points will be plotted and styled when using the Manual Plot option 
from the main MAP GPS panel. There are two settings for the Manual Plot, the Scale and Plot symbol. The scale 
controls the size of the point symbol to be plotted. With a scale of 100 percent selected, the point is plotted at the 
original size of the symbol. The second option is the Plot Symbol which determines which symbol is plotted.

Plot By Time
The Plot By Time setting options control how points will be plotted when using the Plot By Time feature from the 
main MAP GPS panel. Three separate settings can be adjusted: Scale, Every and Plot symbol. The Every setting is used to 
specify the time interval between plots. For instance, if the Every setting is set to 5 seconds, a new point is plotted 
every five seconds. These settings may be changed while plotting is occurring. If the user wishes to increase or 
decrease the scale or change to a different point symbol while plotting by time, they may do so by setting new 
parameters. Changes will be reflected in the next point to be plotted.

MAP GPS Point Plot Settings 
Accessed from the MAP GPS menu.

Type - Select the type of Plot you would like to apply 
the setting to. Either Manual Plot, Plot By Time, Plot 

by Distance, Plot by Change in Speed, or Plot By Change in 
Heading may be used.

Scale - Sets the size of the chosen symbol prior to or 
during plotting if required.

Every - Sets the intervals at which points will be 
plotted.

Symbol - Choose a symbol to use. Click the symbol 
name to open the list of symbols to choose from.

Enable this Auxiliary GPS Plot Type - This setting 
becomes enabled only for the Plot by Change 
in Speed, or Plot By Change in Heading 
options. If the check box is selected then 
when Plot by Time, Plot by Distance, or Start 
Route are being used the settings will be 
applied
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Plot By Distance
The Plot by Distance setting options control how points will be plotted when using the Plot by Distance feature from 
the main MAP GPS panel. Three separate settings can be adjusted: Scale, Every and Plot symbol. The Every setting is 
used to specify the distance interval between plots. For example, if the Every setting is set to 5 metres, a point will be 
plotted every five metres. These settings may be changed while plotting is occurring. If the user wishes to increase/
decrease the scale or change to a different point symbol while plotting by distance, they may do so by simply 
selecting new parameters. Changes will be reflected in the next point to be plotted.

Plot By Change in Speed

The Plot by Change in Speed auxillary settings will plot a point each time a change in speed is detected as specified by 
the threshold set in the Point Plot Settings. Change in speed points are plotted in addition to the points plotted while 
completing one of the standard plot options (Plot by Time, Plot By Distance or Route). To use this setting, a user must 
first enable it by selecting the Enable this Auxillary GPS Plot Type from the bottom of the MAP GPS Point Plot Settings 
panel. The optional settings for Scale, Every, and Plot Symbol must then also be specified. The Every setting has an 
additional option which allows specification of the speed units. Either km/h, knots, or mi/h may be used. When 
plotting begins, a new layer is automatically be created specifically for the change in speed points. This layer will 
be automatically named based on the name of the current layer upon which the main plotting operation is being 
conducted with the phrase change_in_speed prefixed to it. For example if the main plotting is in progress on a layer 
called ABCD, the layer created for the change in speed plots will be named change_in_speed_ ABCD.
 
Plot By Change in Heading

The Plot by Change in Heading auxillary settings will plot a point each time a change in heading is detected as specified 
by the threshold set in the Point Plot Settings. Change in heading points are plotted in addition to the points plotted 
while completing one of the standard plot options (Plot by Time, Plot By Distance or Route). To use this setting a user 
must first enable it by selecting the Enable this Auxillary GPS Plot Type from the bottom of the MAP GPS Point Plot 
Settings panel. The optional settings for Scale, Every, and Plot Symbol must then also be specified. When plotting 
begins, a new layer will automatically be created specifically for the change in heading points. This layer will be 
automatically named based on the name of the current layer upon which the main plotting operation is being 
conducted with the phrase change_in_heading_ prefixed to it. For example if the main plotting is in progress on a 
layer called ABCD, the layer created for the change in heading plots will be named change_in_heading_ ABCD.
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FUNCTIONALITY

The MAP GPS Autosave Settings provide the option to have a document automatically saved each time a specified time 
interval has elapsed. This feature allows for users to limit data loss in the instance that hardware or power problems 
occur while collecting data.

PREREQUISITES

The current document must have already been saved at least once to a local location on the computer. If the 
Autosave setting is activated and the current document has not been saved then a warning will appear upon leaving 
the Autosave dialog box, stating that this feature will not function until the document is saved and will offer the 
option to manually save the document at that time. 

USING THE AUTOSAVE SETTINGS 

The Autosave settings may be activated by selecting the associated check box and specifying the number of minutes 
between autosave instances. Once this has been activated and the current document has been saved, automatic 
saves will occur each time the specified interval is reached. 

Automatic Save - Enable the check box 
and set the setting to the desired 

time for Automatic saving to occur. 

MAP GPS Autosave Settings 
Accessed from the MAP GPS menu.
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FUNCTIONALITY

The Edit Attribute for Current Layer dialog box provides the ability to create a new attribute column for the current 
layer or use an existing string (text) attribute column and have custom attribute values automatically entered in 
that column for plotted features. Attribute values will be added each time a new point is plotted. For example, if 
points are being plotted along a street, a Street column could be created and the street name could be added as an 
automatic attribute value each time a new point is plotted.

PREREQUISITES

Prior to using this feature the current document requires a MAP View and at least one MAP layer. If the MAP layer is 
selected then the Edit User Attribute for Current Layer is accessible and can be set up for use when plotting begins. If the 
above criteria are not met the Edit User Attribute for Current Layer menu item will be greyed out and unavailable.

USING THE EDIT USER ATTRIBUTE FOR CURRENT LAYER

The Edit User Attribute For Current Layer function can be accessed whenever a valid MAP layer is selected. Upon opening 
the dialog box, the current layer name will be displayed in the dialog box along with any string attribute column 
names associated with that layer. To add attribute values to an existing attribute column select the desired column 
name from the Current Attribute combo box and enter the desired attribute value into the Current Value text field. To 
create a new column select the Create New button and enter a column name into the open dialog box. When a new 
attribute column is created its type will be automatically set to string. When the dialog box closes and plotting 
begins, the attribute value will be added to the layer each time a point is plotted.

NOTE: 	 If the Edit User Attribute For Current Layer dialog box is opened while plotting is in progress, the plotting will be 
paused. This allows the necessary changes to be made. Upon closing the dialog box all the points which 
would have been plotted will be plotted and will reflect the changes just made. 

Edit User Attribute for Current Layer 
Accessed from the MAP GPS menu.

Current Layer - Displays the 
currently selected layer in the 
Adobe Illustrator Layers panel

Current Attribute - Displays a list of 
string attribute columns for the 

current layer

Current Value - Allows for input of a 
value to be added as an attribute 

to the current column. 

Create New - Opens a dialog box which allows 
the user to create a new string attribute 
column on the layer.

Clear Value - Will clear the current value 
entered in the Current Value text field 



189Chapter 16: MAP GPS
Record Sentence Log 

FUNCTIONALITY

The Record Sentence Log feature allows for all information gathered from the GPS to be saved to a text file. This 
information can be used for back-up or debugging purposes or imported at a later time into a new document. In 
addition to being able to record to the file, the user is given the options of adding to an existing file or overwriting 
any information which may be in the specified file.

USING THE RECORD LOG SETTINGS DIALOG BOX 

The Record Log Settings dialog box requires either navigation to a directory or manual specification of a location to 
which the log file is to be saved. Once a directory has been specified the file name for the Record Log must be 
specified. This file will be saved as a standard text file that is readable in Notepad or any other plain text capable 
application. It may also be used at a later date to import the log information into a new or existing document as 
MAP features. In addition to specifying a file name and location either the Append option or the Overwrite option 
must be specified. The Append option will add all new information to the end of the file if the selected file contains 
information. The Overwrite option will overwrite any information currently contained in the specified file with the 
new information received. 

NOTE: 	 Once a Record Log file has been specified using the Overwrite option and plotting started, any interruption 
to the plotting, for example, evoking a Stop Scanning operation, will result in the saved log file being 
overwritten by new log data once scanning and plotting restart. If it is desired that a complete session 
log be created and saved which is not overwritten each time plotting is stopped and restarted, the Append 
option should be used.

Browse - Allows the user to navigate to a location to save the log. 

Log File - Allows the user to specify to a location to record the log. 

Append - Will add new information at the end of the file if it already 
contains log information.

Overwrite - Will overwrite information in the specified file if it 
contains any. 

Record Sentence Log 
Accessed from the MAP GPS menu.
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FUNCTIONALITY

The Playback Sentence Log feature allows for information contained in a log file to be re-imported into an Adobe 
Illustrator document. The Playback Sentence Log feature is used in conjunction with the MAP GPS Point Plot Settings 
panel to create a series of points or a route in the document based upon data previously collected using MAP GPS. 
Depending on the applied settings, GPS sessions which have been previously recorded can be recreated in a new or 
existing document. This feature may also be used to import raw NMEA files collected from other devices.

USING THE PLAYBACK SENTENCE LOG DIALOG BOX 

The Playback Sentence Log feature is used by selecting a previously recorded log file and then selecting one of the plot 
options: Build Route, Auto Plot by Time, or Auto Plot by Distance. 

•	 Build Route - A route will be created from the information in the log file using the selected Graphic style 
in the Adobe Illustrator panel.

•	 Auto Plot by Time - Settings from the Point Plot settings panel will be used to interpret the log file and 
plot points at specified times.

•	 Auto Plot by Distance - Settings from the Point Plot settings panel will be used to interpret the log file and 
plot points at specified distances. 

Playback Sentence Log 
Accessed from the MAP GPS menu.

Browse - Allows the user to navigate to the 
location where the log is located. 

Log File - Allows the user to specify the location 
where the log file is located. 

Build Route - A route will be created from the 
information in the log file using the selected 
Graphic style in the Adobe Illustrator panel.

Auto Plot by Time - Settings from the Point Plot 
settings panel will be used to interpret the log 

file and plot points at specified times.

Auto Plot by Distance - Settings from the Point Plot 
settings panel will be used to interpret the log 

file and plot points at specified distances. 
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Adobe Illustrator documents with GIS data can now be 
exported to geospatially enabled PDF files thanks to the 
MAPublisher function Export Geospatial PDF. 

A Geospatial PDF is an Adobe Acrobat file that retains 
geospatial coordinates. With the coordinates, users can view 
and interact with the PDF to find and mark location data.

MAPublisher not only exports the minimum geographic 
information to geospatial PDF, but also all the attributes data 
present in the Adobe Illustrator document. Attributes values 
can subsequently be accessed and searched in Acrobat 
version 9 (and 8 with limitations).

Using geospatial PDF exported with MAPublisher allows for 
performing the following tasks in Adobe Acrobat: 

•	 Find and mark location coordinates
•	 Measure distance, perimeter, and area
•	 View coordinates in measurement units in 

various formats/units
•	 Copy  location coordinates to clipboard.
•	 View attributes of map objects
•	 Reopen Geospatial PDF in Adobe Illustrator with 

MAPublisher capabilities maintained.

This section provides an overview of the exporting process 
of a MAP Geospatial PDF along with an outline of the tools used 
when viewing a geospatial PDF in Adobe Acrobat.

Topics covered in this section are:
MAP Geospatial PDF Export
View MAP Geospatial PDF

Export 
Geospatial PDF
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FUNCTIONALITY

The MAP Geospatial PDF export function exports any MAPublisher document, containing a MAP View with a 
specified coordinate system, to the Adobe Acrobat Geospatial PDF format, retaining the georeference and attribute 
information. All layers are exported to PDF, including non MAP layers (regular Adobe Illustrator layers) but these 
layers are not geospatially enabled and have no attributes.

The MAP Geospatial PDF files exported from MAPublisher are compatible with Adobe Acrobat 9 and later. The Adobe 
Acrobat Analysis Tools allow viewing and marking coordinates, viewing attributes, measuring distances, perimeters 
and areas.

With Acrobat Pro and Pro extended, the measurement tool is always enabled. To enable this tool in Acrobat Reader 
9 (standard), the file must first be opened in Acrobat Pro to enable annotations on the PDF (menu Comments > 
Enable for commenting and analysis).

NOTE:	 MAP Geospatial PDF files can also be opened in Adobe Acrobat 8, however no geospatial information will 
be visible, only attributes.

PREREQUISITES

MAP Geospatial PDF Export can only be used with MAPublisher documents, that is to say the document must 
contain at least one MAP View with a specified coordinate system. All coordinate systems within MAPublisher are 
supported, including user-defined systems*. Multiple MAP Views are supported with no limitation. 

* With some unusual coordinate systems, the measuring tool in Adobe Acrobat may not give proper results (displaying always 0). This is 
an Adobe Acrobat limitation.

Users should complete their map using MAPublisher and Adobe Illustrator tools prior to exporting (styling, 
simplification etc). Depending on the expected behavior of the geospatial PDF, attributes, layers and MAP Views 
might need additional manipulations as explained hereafter.

MAPublisher legacy files (created with version 8.1 or earlier) must be saved first with MAPublisher 8.2 prior to 
exporting. If not the Adobe Acrobat data tools (see later in this chapter) will not function properly.

NOTE:	 Some Adobe Illustrator effects are not supported during export. The attributes will not be visible for 
objects with the following effects* : 

•	 All Photoshop effects
•	 Any effect that modifies the outline shape of the artwork will cause attributes to fail. (i.e. warp effects, 

Convert to Shape, 3D effects, Distort and Transform, and some of the Pathfinder effects).
•	 Any effect that rasterizes the art will cause attributes to fail (several SVG filters do this).
•	 Gradients Fills are supported, with the caveat that transparency gradients (going from opaque to 

transparent) and Gradient Mesh are not supported. 

Geospatial Information Extents
The document exported to geospatial PDF only contains geographic information in the extent covered by a MAP 
View. In other words, Adobe Acrobat Geospatial Location Tool and Measurement Tool will not work outside the MAP 
View's extents. To increase the extents of the MAP View so that it covers a larger part of the document, create a 
polygon on a MAP Layer of type area that bounds the required new extents.

MAP Geospatial PDF Export 
File > Export> MAP Geospatial PDF or MAP Toolbar 

* In Adobe Illustrator CS3, some of these effects may be found under the Filter menu.
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Layers and MAP Views Structure
All layers in the Adobe Illustrator document are exported, including locked and hidden layers. The visibility status 
is maintained in the exported geospatial PDF, however not the locking status. Locking layers must be done within 
Adobe Acrobat. 

Layer order and name are maintained as in the Adobe Illustrator document, with the exception of nested layers. 
Adobe Acrobat does not support nested layers therefore only top most layers are maintained in the exported 
geospatial PDF. Objects in nested layers are exported but they are included in the top most layer. We recommend not 
to use nested MAP Layers because their attributes will not be exported unless the master layer is also a MAP Layer. 

Layers must have a unique name. If multiple layers have the same name, a warning message is prompted upon export.

All MAP Views are exported. MAP Views are exported in the order they appear in the MAP Views panel (alphabetical), 
the top most is exported first and lowest is exported last. If some MAP Views are overlapping, the positions shown in 
Adobe Acrobat are calculated based on the coordinate system of the latest exported MAP View (the lowest one in the 
MAP Views panel). When working with inset maps, the inset MAP View should be placed at the bottom of the tree in 
the MAP Views panel (using an appropriate MAP View name since the order is alphabetical).

MAP Attributes
Only visible attributes (see chapter 5) for map objects are exported to PDF, so users might want to delete or hide/
display relevant attributes in the MAP Attributes panel prior to exporting.

In Adobe Acrobat, the Model Tree displays a list of all the map objects in the document along with their attribute 
information (if applicable), organized in a tree structure in MAP View/Layer Name/ Object Name — see next section 
on how to view MAP Geospatial PDF. 

The name of the objects are displayed in the Structure Pane of the Model tree. They are derived from the map 
object's name as shown in the Adobe Illustrator Layers Panel. The default names given by Adobe Illustrator to 
objects are often meaningless for a data user. For example, lines and areas have a default name of <Path> or 
<Compound Path>, points have the name of the symbol or ordering number.

		                             
		  MAP Views Panel                                       Adobe Illustrator Layers                               Model Tree Objects List

For this reason, it is good practice to assign a specific name to objects prior to export in order to make the 
geospatial PDF more readable for users. This is achieved using the MAP Attributes panel and assigning a new value 
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to the property attribute #Name. For example, use Apply Expression or Derive value from expression functions to assign 
the value of another attribute to #Name. In the example below, #Name values are copied from an attribute called 
COUNTRY_NAME:

The Object Data Pane of the Model Tree displays either the coordinate system of a MAP View, if a MAP View is 
selected in the Model Tree, or the attribute information of a selected object. The attribute name displayed in the 
Property list corresponds to the attribute Display Name specified in the MAP Attributes panel.

		  		

		  MAP Views properties				    Attributes properties

For more information on MAP Attributes and expression builder, please refer to chapter 5.

USING EXPORT GEOSPATIAL PDF

To export to Geospatial PDF, choose File > Export and select MAP Geospatial PDF in the Save as type (Windows) or Format 
(Mac)( drop-down list) — or click the Export MAP Geospatial PDF button  on the MAPublisher Toolbar.

Upon export, a message is displayed to choose whether or not to preserve the Adobe Illustrator editing capabilities 
in the resulting PDF.

Display Name - Attribute name 
displayed in the Object Data Pane of 
the Model Tree.

#Name - Property attribute used 
for naming objects in the Adobe 

Illustrator Layers panel.

Derive value from expression - Possible 
option to automatically assign new 
values to the #Name attribute.
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If the Adobe Illustrator editing capabilities are preserved, users will be able to retrieve MAP Views, MAP Layers and 
MAP Attributes when re-opening the exported Geospatial PDF back into Adobe Illustrator. If not, the Geospatial 
PDF will open into Adobe Illustrator with no georeferencing or attribute information and all layers will be merged 
into one — this might be recommended for secured documents.

NOTE:	 If a preserved Geospatial PDF is opened in Adobe Illustrator and some changes are made, the file will 
have to be exported again using the Geospatial PDF export function. Simply saving the document will 
not maintain the geospatial capabilities of the PDF as it does not run through the MAPublisher 8 special 
Geospatial PDF engine..

Export Geospatial PDF does not have any settings dialog. The default PDF settings are applied, regardless of any 
specific preferences set elsewhere: 

•	 Compatibility: Acrobat 8, PDF 1.7.
•	 General: Embed Page Thumbnails and Create Acrobat Layers from Top-Level Layers. 
•	 Compression: no image compression, Compress Text and Line Arts is on.
•	 Security: no master or user password required.

To change PDF file settings (compression, password access, etc.) open the exported MAP Geospatial PDF file in 
Adobe Acrobat Pro or Pro Extended (version 9 or higher) and resave the document.
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The MAP Geospatial PDF files are compatible with the geospatial tools introduced in Adobe Acrobat 9. The 
availability of these tools depends on the user's Acrobat version (Reader, Standard, Pro or Pro Extended), but no 
additional Acrobat plug-in is necessary to use MAP Geospatial PDF. 

All traditional Adobe Acrobat tools applies, here are some of the most relevant:
•	 Search: selects objects with matching name first, then objects that have a matching attribute value. 
•	 Acrobat Layers panel: displays all layers and controls the display and lock of the layers.
•	 Object Data Tool: to select map objects and display their attributes in the Adobe Acrobat Model Tree 

(Structure Pane and Object Data Pane).

MAP Geospatial PDF files can also be read in Adobe Acrobat 8, however only the attribute information is accessible 
(through the menu Tools > Object Data > Object Data Tool) but Adobe Acrobat 8 does not have the geospatial tools 
available in the version 9.

Adobe Acrobat 9 has the following special tools to access geospatial information:
•	 Measuring Tool: to measure distance, area and perimeter.
•	 Geospatial Location Tool: to display, mark and query geospatial locations.
•	 Geospatial Registration Tool: to spatially register any PDF document by digitizing control points (Adobe 

Acrobat Pro Extended only).

These tools and the Object Data Tool are found on the Analysis Toolbar (menu View > Toolbars > Analysis).
Object Data Tool - Enable selection 

of MAP objects and display 
name and information in the 

Adobe Acrobat Model Tree 
(menu View > Navigation Panels 

> Model Tree).

Measuring Tool - Measure 
distance, perimeter and area.

Geospatial Location Tool - display, 
mark and query geospatial 
locations. 

Geospatial Registration Tool -
 register PDF documents 
(Acrobat Pro Extended only).

The settings for the Measurement and Geospatial tools are found in the Adobe Acrobat Preferences (menu Edit > 
Preferences), under the category Measuring (Geo). 

View MAP Geospatial PDF
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These analysis tools are described in many details in the Adobe Acrobat documentation that can be found under 
the Adobe Acrobat menu Help > Adobe Acrobat Help or on the AdobeWebsite www.adobe.com.

Not all tools are available depending on the Adobe Acrobat version, below is a matrix showing the features 
availability per Adobe Acrobat version:

Acrobat 9 Reader Acrobat 9 Standard 
Acrobat 9 Pro

Acrobat 9 Pro 
Extended

(Windows only)

Geospatial Measuring Tool

Measure distance/perimeter/area PÛ P P
Store measurements as comments PÛ P P
Export/import PDF comments PÛ P P
Geospatial Location Tool

Show on-screen coordinates P P P
Search for/zoom to a location P P P
Mark location with right click O P P
Copy coordinates to clipboard O P P
Geospatial PDF Registration Tool

Create from geoTIFF/JPG2000 O O P
Georegister a PDF map / image O O P
Add shapefile layers to a map O O P

* To enable the measurement tool in Acrobat Reader 9, the file must first be opened in Acrobat Standard, Pro or Pro 
Extended to enable annotations on the PDF (menu Comments > Enable for commenting and analysis).

NOTE: 	 The extended tools of Adobe Acrobat Pro Extended are not necessary for MAPublisher users because these 
functions are performed by MAPublisher. Besides, Adobe Acrobat Pro Extended is currently not supported 
for MAC operating systems.
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MAPublisher LabelPro is a comprehensive collision-free 
labelling solution integrated into the MAPublisher framework. 
Using rules and styles for text placement, it extracts label 
information from map layer attributes and performs fast, 
intelligent, cartographic text placement. Placement rules 
can be saved to a file and imported into other labelling work 
sessions.

Topics covered in this section:
MAP LabelPro
MAP LabelPro Settings
MAP LabelPro Styles
MAP LabelPro Rules
Label Verification

MAP LabelPro is available as an optional add-on to 
MAPublisher. For more information on how to obtain a MAP 
LabelPro license please contact sales@avenza.com or visit 
www.avenza.com.

For information on how to activate a purchased or evaluation 
license please refer to chapter 1 of this guide.

NOTE:	 The evaluation version of MAPublisher LabelPro 
scrambles the text of placed labels but preserves the 
case, spacing and punctuation, so that the results 
give a sense of how actual labels would be placed 
based on the rule settings.

MAPublisher 
LabelPro™
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MAP LabelPro 
Object > Filters > MAP LabelPro or MAP Toolbar 

Source – Displays MAP Views 
and its associated MAP 

Layers specified in Setup 
Layers.

Attribute - Select the 
attribute column 
containing the data to be 
used as labels for selected 
features.

Destination - Specify 
a destination from a 
list of available text 
layers. The destination 
layer holds the labels.

Priority - If multiple layers 
are being simultaneously 
labelled, assign a priority 
level to each labelling 
operation.
The same priority can be 
set to multiple layers.

Style - Create a 
new label style or 
choose from a list 
of established label 
styles.

Rules - Select a 
default set of rules 
or create custom 
rules that dictate 
how labels are 
placed. 

Suppression Layer - 
Repository for 
labels that could 
not be placed 
based on the 
rules set. 

Save & Label - Save the current 
settings in the LabelPro 
configuration dialog box 
and perform the labelling 
operation based on these 
settings.

Save- Save the current 
settings in the LabelPro 
configuration dialog box 
without performing any 
labelling.

Setup Layers - Open the Setup 
Layers dialog box to choose 
which layers are to be 
used  for labelling and/or 
obstacles.

Advanced -Specify user 
defined extents for labelling 
operations.

Obstacle layers – Displays 
MAP Views and its 

associated MAP Layers 
specified as obstacles 

during the labelling session.
Label all art on source layers - By 

default, only generate text labels 
for all data contained on the 

source layers.

Label only selected art on source layers - 
When enabled, generate text 

labels for currently selected data 
on the source layers

Statistics type - Choose an option 
from the  drop-down list to 
display labelling statistics 
for the completed labelling 
process.

Right-click (Windows) or Ctrl-click (Mac) to display the menus:
Pop-up menus

In Source : 

In a Obstacle Layers: 

Source MAP View Source MAP Layer

Obstacle MAP View Obstacle MAP Layer

Set destination layer - Set the same 
destination layer for all source 

layers in the MAP View.

Set suppression layer - Set the same 
suppression layer for all source 

layers in the MAP View.

Add to obstacle list - Add all or the 
selected layer to obstacle list

Move to obstacle list - Move all or 
the selected layer to obstacle 
list.
Remove from labeled list - Remove 
all or selected layer from the 
source list.

Setup layers - Opens the Setup  
Layers dialog box

Edit style - Opens the Style dialog 
box.

Edit rules- Opens the Rules 
dialog box.

Add to labeled list - Add all or the 
selected layer to the list of 
source layers.

Move to labeled list - Remove from 
the obstacle list and add all or 
the selected layer to source list.
Remove from obstacle list - Remove 
all or selected layer from the 
obstacle list.

In Source column header: 

Resize all to fit contents - Resize the 
width of all columns to fit content.

Resize COLUMN_NAME to fit content -  
Resizes only the selected columns.
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FUNCTIONALITY

The MAPublisher LabelPro labelling engine offers advanced labelling capabilities beyond those available in 
MAPublisher Feature Text. The MAP LabelPro engine contains sophisticated algorithms based on MapText’s EZ Label 
technology that solves many of the most common map labelling problems such as complex conflict resolution 
across multiple layers, the ability to specify data as obstacles and the ability to create complex labelling conventions 
via user defined rules. The MAPublisher LabelPro engine uses map data attributes for labelling and provides a much 
greater level of sophistication and control that can be configured through an intuitive user interface. Data layers 
may be assigned an order of prioritization for labelling sequences and existing text can be recognized as obstacles 
for multiple labelling sessions if necessary. Placement rules and properties, once set, can be saved to a file and 
imported into other files or shared over a network.

Only Point, Line and Area layers can be labelled using MAPublisher LabelPro, however, Text layers may only be used 
as obstacles.

PREREQUISITES

MAPublisher LabelPro can only be used in conjunction with MAPublisher documents. MAPublisher LabelPro 
generates static text, meaning the map extent and scale should be established prior to labelling. Once placed, 
labels do not maintain a link with the source data.

Before labelling with MAPublisher LabelPro, it is necessary to create the destination  Text layer(s) (layers on which 
the new labels will be contained). To use suppression layer(s) (for labels that could not be placed by MAPublisher 
LabelPro) create other text layer(s) for this purpose. To create a new text layer, use the Add MAP Layer function in the 
MAP View panel (see chapter 4): 

•	 Set the feature type to Text.
•	 To enable the copy the attributes from the source MAP layer to the label destination layer, check the 

option Base attribute schema on and select the appropriate layer to copy its attribute schema. 

For each source layer, MAPublisher LabelPro derives the labels from a selected attribute column. Use the MAP 
Attributes panel to analyze and/or edit the information prior to labelling. For instance, to force some labels to be 
stacked, users can insert the characters && in the MAP Attribute value to indicate a Carriage Return — this can be 
done by combining two columns into a new one or using the Find and Replace function.

It is not possible to label based on an expression (e.g. a road layer with classes such as street, highway and toll road 
can only be labelled with a single style and rule). To label multiple classes of a layer, use the Split Layer option of the 
MAP Selection Filter to create new layers for each class (see chapter 11). 

In the MAPublisher Preferences section for MAP LabelPro, base rule and style folder paths can be set. By default, 
invisible objects are ignored by MAPublisher LabelPro (they will not be labelled or used as obstacle). To take them 
into consideration, uncheck the option Ignore invisible artwork. See chapter 1 on MAPublisher Preferences for more 
information on this topic.

USING MAPUBLISHER LABELPRO

To start MAPublisher LabelPro click the MAP LabelPro button  on the MAPublisher Toolbar or the menu Object 
> Filters > MAP Labeling > MAP LabelPro*
* In Adobe Illustrator CS3, MAP LabelPro is found in the Filter > MAP Labeling menu.
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SETUP LAYERS

Before labelling, the Setup Layers dialog box must be configured to specify which MAP Layers are to be labelled 
and which layers, if any, will be denoted as obstacles. Obstacles are map objects that are included in the conflict 
resolution decision making process, and are considered objects that must be avoided when trying to place a label. 
The Setup Layers dialog box displays all valid MAP Views and their MAP Layers in the document. To mark a layer for 
labelling purposes or as an obstacle, check the appropriate check boxes to the right of the layer name. All layers are 
listed, but only layers that are checked will be included in the labelling process or considered as obstacles.

NOTE: 	 Layers may be used as both a label and an obstacle concurrently. It is possible to perform labelling 
operations for multiple MAP Views simultaneously, however, source data layers and destination text layers 
must belong to the same MAP View.

ADVANCED

In the Advanced options dialog box, set the Label Placement Area option to the extents based on the current 
artboard or the extents of labelled source layers. To set Label Margins, enable the option and enter the extents 
of the label container in increments of the current document units. Data that is outside of the label margins is 
disregarded in the labelling process.

Extents of the current artboard 
(Default) Label all designated data 
that falls within the extents of the 

current artboard.

Extents of labeled layers – Label data 
only to the extents of the selected 

MAP Layers.

Label Margins – Enable the check box 
to add margins to the  

selected extents.

Obstacles – Enable the check box to 
specify that paths without stroke 

are not considered obstacles.

NOTE: 	 These settings are applied in conjunction to the settings from the Source Art section in the main MAP LabelPro 
configuration dialog box. Units for margins are determined by Document Setup in Adobe Illustrator.

Name – Displays all MAP Views 
and the layers within them 

that may be specified for 
labelling purposes. 

Label – Enable the check box for 
each data layer to be labelled.  
Enabling the option beside the 
MAP View name will enable 
the label option for all the data 
layers that belong to it.

Obstacle – Check this option 
should you want the contents 
of the layer to be used as 
obstacles for label conflict 
resolution. 

MAPublisher LabelPro Settings
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SOURCE AND ATTRIBUTE COLUMNS

These settings determine which attribute information is converted 
into text labels for a respective layer. The Source column shows the 
Area, Point and Line layers in the document that have been enabled 
for labelling through the Setup Layers option. For each layer listed 
in Source column, the Attribute column holds a drop-down list 
populated with the attribute structure of that MAP layer. Specify the 
appropriate attribute to be used for generating that layer's labels.

NOTE:	 By default, label case is left exactly as it is found in the attribute table. To modify a label's case, see the options 
in the Label Case drop-down list located in the Style dialog box of each layer.

DESTINATION AND SUPPRESSION TEXT LAYERS

The layers on which generated labels should be placed are specified in the Destination and Suppression Layer 
column drop-down lists. Destination layers will contain only the labels that could be placed successfully on the 
map based on the defined rules. Suppression layers are repositories for labels that could not be placed successfully 
according to the rules and have not met all placement conditions. For best viewing results after labelling, hide the 
suppression type text layers. Alternately, the suppression layer can be set to Ignored and unsuccessfully placed labels 
will not output to any layer.

NOTE:	 Rows that have incomplete configuration settings (locked destination or suppression layers/unspecified 
destination layers) are displayed in red under the Source list in the configuration dialog box. It is normal 
for a certain percentage of labels to not succeed in being placed due to rule or data conflicts. Information 
regarding the success rate of placement can be reviewed by enabling one of the Statistic type options 
located in the Options frame.

PRIORITY

The Priority setting allows for complex hierarchical labelling 
sequences. The priority is the order of preference in which labels are 
placed. Layers with a priority of 1 will be placed first (or have a high 
priority). Layers with a priority of 12 will be placed last (or have a low 
priority). Consequently, layers with a low priority might have more 
suppression labels generated for them. Priorities are set by selecting a 
number in the Priority drop-down list for a respective layer.

NOTE:	 A maximum of twelve priorities may be assigned at any given time however the same priority number can 
be assigned to multiple layers.
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POINT AND AREA STYLES

The Style dialog box allows users to set label style properties for each map layer. To access the dialog box, click the 
Style edit button  . Set the text properties for font family, style, size and colour. A sample preview of the stylized 
text is shown in the large text box. Once the desired settings have been made, they can be collectively saved into a 
style file by clicking Save As. MAP LabelPro offers a pre-configured default style of 12 point Arial as a base labelling 
option.

MAPublisher LabelPro Styles

Once saved, Styles are added to the Styles drop-down list in the MAP LabelPro Configuration dialog box. This is very 
helpful in maintaining labelling consistency among similar mapping projects or when multiple users are working 
on the same project. Existing styles may be deleted by selecting it from the Style drop-down list and then clicking 
on the  delete button. Style files are saved to either a point, line or area folder depending on the type of map 
layer it is associated with.

By default, styles are saved in the following location:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\Styles
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\Styles
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/Styles

The default save path for the Styles can be modified in the MAP LabelPro section of the MAPublisher Preferences 
dialog box. Choose Edit > MAPublisher Preferences (Windows) or choose Illustrator > MAPublisher Preferences (Mac).

NOTE:	 On Windows, labelling with PostScript Type 1 fonts that are not placed in the Windows system font folder 
will produce an error message Failed to perform label placement: FontNotFound Exception. In these very rare 
cases, the font files should be copied from the Adobe font folder (usually under C:\Program Files\Common 
Files\Adobe\Fonts\Reqrt\Base) to the Windows font folder (found from Control Panel > Fonts). Notably, 
Myriad font is such a PostScript Type 1 font that is not installed on the Windows font folder by default.

NOTE:	 Attributes consisting of Unicode characters must be labelled with a Unicode font that contains the 
appropriate characters. For example, attempting to label Japanese characters with an Arial font will result 
in an error or incorrect results.

Family – Specify the font for the labels.

Style – Indicate the desired font style.

Size – Specify the font size.

Colour – Click the browse button  
to open the Adobe Illustrator Color 

Picker dialog box.
Selected colour values will be 

converted to the document colour 
mode (e.g. CMYK to RGB). 

Preview – Text sample (result may not 
be exact for some font families.

Save As– Save the current settings 
into a style file.

Label Case – Select the appropriate 
label case from the drop-down list:
•	 Leave as is: keep the case from the 

attribute value.
•	 Convert to lower case: e.g. abcd
•	 Convert to upper case: e.g. ABCD
•	 Convert to proper case: e.g. AbcdOpacity – Specify the level of opacity 

for the labels.

Name – Enter a style name.  
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LABELLING LINE DATA WITH SYMBOLS

MAPublisher LabelPro has the ability to place labels inside symbols. A typical application of this would be 
numbered highway route shields. To label lines with symbols, check the Label with symbol check box to enable 
the symbol options. Choose an appropriate symbol set from the Symbol File drop-down list and select a symbol 
from the Symbol drop-down list. Use the Height option to change the size of the symbol in the Adobe Illustrator 
document unit (e.g. inches or millimeters).

NOTE:	 The label font size and a fixed symbol height (not Auto size) affect how a label is sized inside a symbol. For 
example, if a fixed symbol height of 0.5 in is used, but the label font size of 5 pt, the symbol will be 0.5 in 
but the label inside will be no greater than 5 pt. If the label font is set to 50 pt, but the fixed symbol size is 
0.5 in, the label will have a maximum size of whatever fits inside the symbol or the selected font size.

Symbols are stored in the location set in the MAPublisher Preferences (see chapter 1). The default locations are:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\Symbols
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\Symbols
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/Symbols

NOTE:	 Labelling with symbols is only available for Line layers. To label areas with symbols, use the Plot Centroids 
function from the MAP Point Plotter (see chapter 6).

Label with symbol – Enable this check 
box to activate the symbology 

options

Symbol file – Choose which symbol 
file (.lsf ) that contains the desired 

symbols.

Symbol – Choose the symbol from 
this drop-down list.

Height– Specify a height manually 
or allow the symbol to be scaled 
automatically to fit the label's text 
via the Auto option.
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MAPublisher LabelPro provides users with an intuitive, easy to understand 
graphical user interface for setting up labelling rules. Each Point, Line and Area 
rule dialog box has numerous label placement options for a high level of label 
detail and a variety of configurations.

To access label rules, click the Rules edit button  in the Rules column of the 
main MAP LabelPro dialog box. Depending on the layer type, this will open 
either the Area, Line or Point Rules dialog box. Configure label rules and, if 
needed, save the rules to add it to the Rules drop-down list.

Rules operate in a very similar approach to Styles in that once added to the 
Rules list, they can be immediately applied, reused later in the same file or in other documents provided they are 
being applied to the same type of data. Rules are saved to the Area, Line or Point folder depending on the feature 
type of the map layer.

MAPublisher LabelPro offers a pre-configured Default rule for each data type. It is loaded by default and used until 
new rules have been created or selected. The default rule is a good starting choice as it is configured to be useful for 
the most common labelling situations, however, creating custom rules can be very useful when specific labelling 
conventions are required.

In an Area, Point or Line Rule dialog box, the sequence in which the rule options appear and are checked have no 
bearing on the order of label placement, only whether the option is enabled or not. Adjust the Priority value of 
layers to adjust the sequence of label placement. Existing rules may be deleted by selecting them from the Rule 
drop-down list and then clicking the delete button . 

Rules are saved to the location set in MAPublisher Preferences (see chapter 1). The default locations are:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\Rules
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\Rules
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/Rules

NOTE:	 Labelling results will vary depending on which rules are enabled. If no rules are enabled, MAP LabelPro will 
not perform any labelling.

MAPublisher LabelPro Rules
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AREA RULES

The Area Rules dialog box contains the label configuration options for labelling Area layers. Rules can be set by 
selecting an area feature type layer and clicking the Rules edit button  in the Rules column. The placement 
settings in the screenshot below represent the default configuration, however, these settings may be changed to 
match any labelling requirements. Click the Save As button to save the label configuration. The rule will be saved 
with a user assigned name. Click OK to apply the current settings.

NOTE:	 For Area type data, labels are placed relative to an object's centroid.
	 For areas grouped in a compound path, the largest area of the compound will be labelled.

Allow horizontal inside – Labels 
are allowed to be placed 

horizontally inside the 
polygon.

Allow dominant angle – Labels 
are allowed to be placed 
parallel to the dominant 

angle of the polygon.

Allow extending beyond boundary  
Labels are allowed to exceed 

the boundaries of the 
polygon being labelled.

Allow outside – Labels are 
allowed to be placed outside 

the polygon being labelled.

Allow inside, along boundary 
Labels are allowed to be 

placed inside the polygon, 
following the polygon 

boundary.

Allow stacking – Labels are 
allowed to stack up to a 
maximum of two, three, or 
four lines.

Allow labels to cross lines 
Labels are allowed to cross 
line features and area 
boundaries.

Allow font reduction 
Automatically reduces the 
label size incrementally, 
when necessary. Each step 
shrinks the selected font 
by 0.5 pt.

Allow overlapping labels
Area Labels are allowed to 
overlap other labels in the 
same labelling session.

Allow use of leader lines – Incorporates the use of 
leader lines. Options include the number of 
lines the leader line are allowed to cross, the 
width of the leader line being used and the 
style of arrow to be used as the leader line.
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LINE RULES

The Line Rules dialog box contains the label configuration options for labelling Line layers. Rules can be set by 
selecting a line feature type layer clicking the Line Rules edit button  in the Rules column. The placement 
settings in the graphic below represent the default configuration, however, these settings may be changed to 
match any labelling requirements. Click the Save As button to save the label configuration. The rule will be saved 
with a user assigned name. Click OK to apply the current settings.

Starting Point – Specify where the start of the label will be placed with 
options including Start, Center and End. Start will have the start of 
the label placed at the starting point of the line, Center will place 
the label in the center of the line and End will place the label at the 
end of the line. The starting point of a line depends on the direction 
of the vertices.

Placement – Place labels 
using an offset or on a 

centerline. Offset labels 
Above or Below a line. 

Vertical Split places multiple 
word labels above and 

below the line and relative 
to the center of the line. If 

the generated label only 
has one word, it will be 

placed on the suppression 
layer. The Centerline option 
places labels directly on top 

of the line.

Allow overhang – Labels  
are allowed to overhang 
the line up to a set 
percentage. The 
percentage of overhang 
is relative to the start of 
the label and the end of 
the line.

Allow stacking – Labels 
are allowed to stack to a 
maximum of two lines.

Allow Labels to Cross Lines
Labels are allowed to cross 
line features and area 
boundaries.

Allow font reduction 
Automatically reduces the 
label size incrementally, 
when necessary. Each step 
shrinks the selected font 
by 0.5 pt.

Allow use of leader lines 
Incorporate the use of 
leader lines. Allowed 
Line Crosses permits the 
number of lines the leader 
line will be allowed to 
cross. Leader Width and 
Arrow Style adjusts the 
thickness and style of the 
leader line, respectively.

Label joined feature – Places 
one label on a line that is 

joined together.

Label each feature – Labels 
each and every  

line segment.

Divided highways – Label 
multiple road segments 
with a common symbol 

such as a shield. Lines must 
be within 0.25 inch and 

75% of the lines must be 
parallel to be considered 

a divided highway. The 
divided highway symbol 
will be placed on the line 

with the longest geometry.
Repeat labels– Repeat labels along 
a line at specified amounts.

Allow overlapping labels – Check 
this option to allow line labels to 
overlap with other labels in the 
same labelling session.

Spread words – Multiple word 
labels placed a specified 
amount apart.

NOTE:	 Text as obstacles will not work unless the Allow labels to cross lines option is disabled. This is because text 
obstacles are treated as areas and not text. Also, text will only be avoided being placed where it intersects 
the outline of the shape and not within it.

	 Using the Placement option Vertical Split may require additional line smoothing (straightening or simplifying). 
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POINT RULES

The Point Rules dialog box contains the label configuration options for labelling Point layers and follows the same 
conventions mentioned for the previous two data types.

Placement – Click the 
placement buttons in 
the desired order of 
priority. Use the Clear 
Last or Clear All options 
to remove selections. 
Unselected positions 
will not be considered. 

Centered on point
Labels are placed on 
the center of the point. 

Allow use of leader lines
Incorporate the use of 
leader lines. Allowed 
Line Crosses permits 
the number of lines 
the leader line will be 
allowed to cross. Leader 
Width and Arrow Style 
adjusts the thickness 
and style of the leader 
line, respectively.

Allow stacking – Labels are 
allowed to stack up to a 
maximum of two, three, 
or four lines.

Allow labels to cross lines 
Labels are allowed to 
cross line features and 
area boundaries.

Allow font reduction 
Automatically reduces the 
label size incrementally, 
when necessary. Each 
step shrinks the selected 
font by 0.5 pt.

Allow overlapping labels – Check this option 
to allow point labels to overlap with other 
labels in the same labelling session.

SAVING AND LABELLING

Once the layers, main configuration, style and rule based options have been completed, proceed to label the map data 
by clicking the Save & Label button. Clicking the Save & Label button will save the current settings, close the main 
MAP LabelPro configuration dialog box and begin the labelling process.

Due to the complexity of the calculations involved in rule based text placement, it is likely that a progress meter 
will be displayed for most labelling processes except those that are sufficiently simple or small. Cancel the labelling 
process at any time by clicking on the  button in the progress dialog box.

Alternatively, save the current settings without labelling by clicking the Save button. This will close the main MAP 
LabelPro configuration dialog box and will not label any features. The dialog box can be reopened later to edit the 
saved label settings or be used to label the map.
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The graphic below shows results of a typical labelling result that options such as stack labels, repeat labels, allow 
labels to cross lines, and many others.

Verify that labels were successfully placed in accordance to the rule base set out in the MAP LabelPro configuration. 
Also verify that labels were placed on the appropriate Destination text layers. Text failing to meet the labelling 
criteria will be placed in a Suppression layer (if one is available and has been set). If no Suppression layer is available, 
the non-compliant text is ignored and is not generated. Once placed, the labels are considered standard text and 
may be modified using Adobe Illustrator or MAPublisher operations.

NOTE: 	 Undo and Redo operations are supported when labelling. Be aware that undoing a labelling operation will 
also undo any changes to rules, styles or settings made at the same time. It may be useful to save without 
labelling, close the MAP LabelPro Editor, re-open it, then proceed to click Save & Label.

OPTIONS
None – (Default) No statistics panel will 
display after labelling.

Just overall totals – Totals for all placed and 
unplaced labels (not separated by layer).

Just layer totals – Totals for each layer. 
Shows both placed and unplaced labels.

Show all – Show all statistics.

The Statistics type drop-down lists several options for displaying statistical information after the labelling process 
is completed. This information is useful in determining how successful the labelling operation was based on the 
number of labels written to Destination and Suppression layers. It may help indicate whether adjustments to the 
rule base are required to necessitate a higher rate of success. Statistics report may be saved as text file to future 
reference.

Label Verification
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Spatial databases are optimized data repositories for spatial 
data storage and management. Many GIS environments use 
spatial databases to easily access and manage GIS data in a 
central location.

MAPublisher 8.2 introduces support for import of the popular 
ESRI single-user and multi-user Geodatabases: Personal, File 
and ArcSDE Geodatabases; and direct access to ArcSDE server. 

The MAPublisher Spatial Database importer is built on ESRI 
software libraries and as such requires a valid ESRI software 
and license installed on the computer (ArcGIS 9.2 and higher). 

MAPublisher Spatial Database functions are available on 
Windows operating systems only.

Topics covered in this section:
Overview
Import ESRI Personal and File Geodatabases
Import ESRI ArcSDE Geodatabases
Import from Basic ESRI ArcSDE Server

MAPublisher Spatial Database is available as an optional 
add-on to MAPublisher 8.2. For more information on how to 
obtain a MAPublisher Spatial Database license please contact 
sales@avenza.com or visit www.avenza.com.

For information on how to activate a purchased or evaluation 
license please refer to chapter 1 of this guide.

MAPublisher 
Spatial 
Database
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Overview

A Geodatabase is a native ESRI ArcGIS data format for storing geographic data. It is a collection of geographic 
datasets of various types used in ArcGIS and managed in either a file folder or a relational database, such as: 

•	 Feature classes of points, lines, polygons, and annotation for discrete features
•	 Feature datasets (group of feature classes)
•	 Descriptive attributes held in tables 
•	 Raster datasets and raster catalogs for imagery

ESRI supports several types of Geodatabases that can all be imported in MAPublisher:

File 
extension

User access Size limit RDBMS 
Technology

ESRI Licensing
(create)*

MAPublisher 
Import   access

Personal 
Geodatabase

.mdb Single 2 GB Microsoft 
Access (Jet 
Engine)

ArcInfo
ArcEditor
ArcView

Folder browser

File Geodatabase .gdb Single 1 TB No RDBMS - 
uses local file 
structure.

ArcInfo
ArcEditor
ArcView

Folder browser

ArcSDE Desktop 
Geodatabase 
(called Personal in 9.2)

- Multiple 
(limited)

4 GB SQL Server 
Express

ArcGIS Engine
ArcInfo
ArcEditor

ArcSDE server 
connection

ArcSDE Workgroup 
Geodatabase

- Multiple 
(limited)

4 GB SQL Server 
Express

ArcGIS Server 
Workgroup

ArcSDE server 
connection

ArcSDE Enterprise 
Geodatabase

- Multiple 
(unlimited)

Depends 
on the 
server

DB2
Informix
Oracle
PostgreSQL
SQL server

ArcGIS Server 
Enterprise

ArcSDE server 
connection

*For all Geodatabases, an ArcEngine license is the minimum requirement for direct read of vector and raster data.

MAPublisher has the capacity to import all types of Geodatabases (categorized as Personal, File and ArcSDE 
Geodatabases), provided that the appropriate ESRI ArcGIS software and license are available on the computer.

As a minimum, a free ESRI ArcReader license allows users to access feature classes on ArcSDE servers, with some 
limitations on the selection functions.

The connection to a ArcSDE server requires server access, user account and versioning information to be provided 
by the database administrator. These parameters are exactly the same required to establish a connection using ESRI 
ArcCatalog — with a small exception for SQL Server Express connections, explained later on in this chapter.

Once imported in Adobe Illustrator, the data does not maintain a link with the original database and database 
functions are not valid (topology, table/feature class relationships, subtypes and attributes domains rules). However, 
MAPublisher can make use of the Geodatabases spatial and non-spatial relationships, subtypes and attribute 
domains information during the import process (to populate layer names and attributes according to the user's 
preferences).
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SOFTWARE REQUIREMENTS

MAPublisher Simple and Advanced Import functions require valid ESRI software and licensing installed on the 
computer to be able to import ESRI Geodatabases or to access an ArcSDE server. 

To use ESRI Geodatabases, the minimum license required is ESRI ArcGIS Engine — higher licenses that apply are 
ArcView, ArcEditor and ArcInfo. 

The direct access to feature classes on an ArcSDE Server requires only the free ESRI desktop application ArcReader. 
File and Personal Geodatabases cannot be read. With this licensing configuration, the access to files with Basic ESRI 
ArcSDE Server connections is limited compared to the ESRI ArcSDE Geodatabase connections (as explained later in 
this chapter).

NOTE:	 If ArcReader is not installed on the default installation directory, it might be necessary to edit the binary 
location in the MAPublisher Preferences, Basic ESRI ArcSDE Server Editor (see chapter 1).

MAPublisher supports all ArcSDE server connections and SQL queries supported by ESRI on the user's system.

NOTE:	 MAPublisher supports 9.2 and higher Geodatabases. However, there are some limitations to the direct 
connections from 9.2 clients to the ArcSDE 9.3 Geodatabases. Please refer to ESRI documentation on 
software requirements (service pack etc.) and limitations.

SUPPORTED FEATURES

Data Types
The following is a list of supported and unsupported Geodatabase geometry types for import in MAPublisher:

•	 Supported:
ÌÌ Point
ÌÌ Polyline
ÌÌ Polygon
ÌÌ Circular Arc*
ÌÌ Elliptical Arc*
ÌÌ Bezier Curve
ÌÌ Annotations

* Upon import, MAPublisher will convert the arc to a line wherein a series of vertices will maintain the geometry. 

•	 Unsupported:
ÌÌ Raster
ÌÌ Grids
ÌÌ MultiPatch
ÌÌ Dimensions

NOTE:	 To import a geometry type that requires the use of a Representation in ArcGIS (such as Bezier curves), the 
Behavior when Representation Geometry is Edited must be set to Change the geometry of the supporting 
feature — option specified when creating a new Representation in ArcGIS.



214 Chapter 19: Import ESRI Geodatabases
Overview

Aliases
ArcGIS users can give the feature classes an alias that acts as an alternate name. Unlike feature class names, aliases 
can contain spaces, punctuations, and start with a number. In ArcMap, feature classes are referred to with their alias 
name. In ArcCatalog, feature classes are represented by their true names.

In the MAPublisher Preferences for Spatial Database > ESRI Geodatabase Editor, users can specify to use aliases for layer names.

NOTE:	 Aliases for attribute field names are imported as Display Name and true field names as Name of MAP 
Attributes columns.

Subtypes and Attribute domains
Subtypes are particular attribute fields made to create groups of records in a feature class that share the same types 
of properties. The attribute fields designated as subtype fields contain numerical coded values and have a data type 
of short or long integer. Each coded value is associated with a description (textual).In the MAPublisher Preferences for 
Spatial Database > ESRI Geodatabase Editor, users may choose to load subtypes as separate layers.

Attribute domains are used to constrain the values allowed in any particular attribute of a feature class (or subtypes). 
There are two types of attribute domain:

•	 A range domain limits the value of a numerical attribute in between minimum and maximum values — 
range domains are not relevant to MAPublisher. 

•	 A coded value domain specifies a valid set of coded values for an attribute (of any type — text, numeric 
or date). Both coded values and their meaningful description are stored in the database.

In the MAPublisher Preferences for Spatial Database > ESRI Geodatabase Editor, users can set the option to import attributes 
with coded values from subtypes and attribute domains as follow: 

•	 Instead: replace the codes by their description (text);
•	 Never: import the actual values (code);
•	 In Addition: create two attribute columns, one containing the coded values and one containing the 

corresponding descriptions. 

Spatial Filters
During the import process, users can enter four coordinate points in any coordinates system unit to limit the 
geographic area for the data being imported (see next section).
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SQL Queries
During the import process, users can use SQL queries on feature classes and tables to limit the objects and 
attributes to be imported. 

Multiple feature classes can be imported using multiple SQL statements as long as all classes share the same source 
coordinate system. SQL queries can also be used to import a feature class and the attribute information from a 
related non-spatial table. To apply SQL queries on multiple feature classes with different source coordinate systems, 
use the Advanced Import and add the feature classes in several Add sessions (see chapter 3 for more information on 
the Advanced Import).

MAPublisher uses the ESRI libraries to run the SQL queries. Please refer to the ESRI documentation for more 
information on the supported SQL expressions and syntax — they can change depending on the Geodatabase and 
database server type.

Non-Spatial Relationships
MAPublisher supports non-spatial relationships between feature classes and tables during the import process using 
SQL queries. Here are some examples:

•	 Import and inner join a feature class to a related table (only features with entries in the related table are 
imported):
ÌÌ SELECT * FROM Feature_Class,Table WHERE FeatureClass.Id=Table.Id

•	 Import and inner join a feature class to a related table and apply a query:
ÌÌ SELECT * FROM Feature_Class,Table WHERE FeatureClass.Id=Table.Id AND Table.Attribute='ABC'

•	 Import a feature class without joining to a related table, but use a table value to make a query:
ÌÌ SELECT * FROM Feature_Class WHERE FeatureClass.Id IN (SELECT Table.Id FROM Table WHERE Table.

Attribute='ABC')

NOTE:	 SQL syntax may vary depending on the database server type.

Once the vector data is imported into Adobe Illustrator, the database relationships rules do not apply anymore. It is 
however possible to use the MAP Attributes panel Join Table function to join Geodatabase tables with MAPublisher 
vector data. For more information, please refer to chapter 5.

NOTE:	 When the non-spatial table information is imported together with the feature class using a SQL query, only 
the vector features that have a record in the related table are imported. Import first the feature class and 
use Join Table in a second step: all vector features are imported and the related table information is added 
where a record match is found. This second option might be recommended if the database is not well known.
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Import ESRI Personal and File Geodatabases

Format - Select ESRI File Geodatabase 
or ESRI Personal Geodatabase.

<Auto detect format> can only be 
used for Personal Geodatabases.

Simple Import 
Advanced Import > Add 

Browse - Opens a file/folder 
browser. File Geodatabases have 
the extension (*.gdb), Personal 
Geodatabases end with (*.mdb).

Select Feature Classes 

Feature classes - Click one or more 
feature classes to import - only classes 

sharing the same original coordinate 
system (spatial reference) can be 

imported together.

Spatial Filter

Point Coordinates - Enter the four corners 
of the spatial filter boundaries, eg: 

Point 1 Point 2

Point 3Point 4
Relationship - Specify which features 

should be included:
•	 Intersects: includes features that 

intersects with the boundaries
•	 Contains: includes only features that 

are entirely contained within the 
boundaries

Source Coordinate System - Coordinate 
system of the selected feature class.

Input Coordinate System - Coordinate 
system specified for entering the filter 
coordinates (if different from source).

Data Coordinate System - Original coordinate 
system of the selected file. 

Alternate Coordinate System - Check this option 
and click Specify to select an alternate 

coordinate system. 

Same As - Check this option to use a coordinate 
system that matches an existing MAP View.

Datum Shift - Click this button to specify a new 
datum shift.

SQL Query - Click this option to open the 
Create SQL Select Query dialog box

Specify Spatial Filter- Click this button to 
open the Specify Spatial Filter dialog box. 

Clear Input Coordinate System - Revert 
to the source coordinate system for 
entering the filter positions.
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FUNCTIONALITY

ESRI Personal and File Geodatabases can be imported through the Simple Import and Advanced Import functions of 
MAPublisher. The file selection is done in two steps: first the database is selected (*.mdb for a Personal Geodatabase, 
*.gdb for a File Geodatabase), then feature classes are selected directly or through SQL queries. Additionally, a spatial 
filter can be set to limit the geographic extents of the data being imported.

When feature datasets are present in the database, MAPublisher uses them to group feature classes per parent 
feature dataset to ease the selection process, but feature datasets are not imported as such. As an import setting, 
the feature dataset name may be prepended to the name of the data layer created during import.

For each format, multiple feature classes sharing the same source coordinate system may be selected at once 
in the Simple Import or Advanced Import > Add dialog box. To import feature classes that do not have matching 
spatial reference, use Advanced Import and add the feature classes in several Add sessions (see chapter 3 for more 
information on the Advanced Import).

The feature classes (objects and attributes) are imported on separated MAP layers. The layer naming convention is set 
in the MAPublisher Preferences for Spatial Databases > ESRI Geodatabase Editor.

USING IMPORT ESRI PERSONAL AND FILE GEODATABASES

In the Simple Import or the Advanced Import > Add dialog box, set the Format drop-down list to ESRI Personal 
Geodatabase or ESRI File Geodatabase — Personal Geodatabases can be selected with the <Auto detect format> option 
but not File Geodatabases because they are directories. Click the Browse button and select a file with the extension 
*.mdb (Personal Geodatabase) or a directory with the extension *.gdb (File Geodatabase) - only one Geodatabase can 
be accessed at one time. Click the Open button to finalize the selection. This opens a new dialog box for the selection 
of the specific feature classes to be imported.

Create SQL Select Query 

SQL Query Editor - Type in a 
SQL query - the SQL syntax 

must be compliant with 
the DBMS server in use.

One and one only "Shape" 
field must be specified in 

the SELECT clause.

Selection - Double-click 
a feature class name or 

attribute to add it to the 
SQL statement. 

Attributes' alias names are 
indicated in parenthesis

Add to Query - Select a 
feature class name or 

attribute and click this 
button to add the item the 

SQL statement.

Recent - Opens the list of recent SQL 
statements (see also MAPublisher 
Preferences on Spatial Database > General 
Spatial Database Editor - chapter 1). 

Delete - Click to delete 
recent SQL queries

Specify Spatial Filter - Opens 
the Spatial Filter dialog box 

(see previous page)..

Operators - Click an operator button to 
add the corresponding formatted text 
(including spaces) to the query.  

Validate - Click this button to verify the 
query syntax. 
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Select Feature Classes
In the Select Feature Classes dialog box, users have the option to directly import one or more feature classes or to 
build SQL queries to select subsets of feature classes. For a direct selection of feature classes, click the names of the 
feature classes to import — selected classes are highlighted. To deselect a class, click the selected name. Finally, 
click OK to start the import process.

Specify Spatial Filter
A spatial filter consists of a four corners polygon defining the extents for the imported data. When first opened, the 
Specify Spatial Filter dialog box displays the four corner coordinates that correspond to the actual data extent of the 
selected file. Users may enter new coordinates values using the selected file source coordinate system or using an 
alternate coordinate system - this is achieved by clicking the Specify Input Coordinate System button.

No specific order is required for entering the corners' coordinates, but Point 1, 2, 3 and 4 should be entered in a loop 
so as not to create a crossing polygon — only data included in the crossed area would be imported.

Users can choose whether or not to import objects that intersects with the spatial filter boundaries by setting the 
Relationship: 

•	 Intersects allows the import of the whole objects which geometry intersects with the spatial filter
•	 Contains imports only objects fully contained inside the spatial filter limits.

Create SQL Select Query
A SQL statement can be built to limit the number of objects and attributes imported from a single feature class. The 
SELECT clause should always contain one and one only "Shape" object (actual spatial feature). When possible use 
the operator button to add formatted query statements (including spaces), to limit the typing errors. 
For example: 

•	 In feature class "FC_Point", import all points and the "Valve" attribute (other attributes are not imported).
ÌÌ SELECT FC_Point.Shape, FC_Point.Valve_ID FROM FC_Point

•	 In feature class "FC_Line", import lines (vector only) that have the attribute "Id" equals to 1, 2, 3 or 4.
ÌÌ SELECT FC_Line.Shape  FROM FC_Line WHERE FC_Line.Id IN (1,2,3,4)

The Create SQL Select Query dialog box offers a Validate button to verify the query syntax prior to running the import.

Multiple feature classes can be imported using multiple SQL statements separated by a semi-colon (;) as long as all 
classes share the same source coordinate system. SQL queries can also be used to import a feature class and the 
attribute information from a related non-spatial table (see previous section). To perform SQL queries on multiple 
feature classes with different source coordinate systems, use the Advanced Import and add the feature classes in 
several Add sessions (see chapter 3 for more information on the Advanced Import).

Recently used SQL queries are saved and accessed by clicking the Recent button. The number of recent queries 
saved is set in the MAPublisher Preferences on Spatial Database > General Spatial Database Editor (see chapter 1).

Settings
Parameters relative to the Geodatabases encoding are accessed by clicking the Settings button. These settings are 
described in chapter 3 of this user guide. 

Additionally, users can choose to prepend the feature dataset names to the layer name created on import. 
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Import ESRI ArcSDE Geodatabases

Format - Select ESRI ArcSDE Geodatabase.
<Auto detect format> cannot be used.

Simple Import 
Advanced Import > Add 

Browse - Opens the ArcSDE Geodatabase 
browser

Connections - List of connections already 
created within MAPublisher.

MAP Datasets - List of recently selected 
MAP datasets.

Create new -Opens the Create new ArcSDE 
Geodatabase connection dialog box.

Edit -
•	 If a connection is selected: opens 

the Edit ArcSDE Geodatabase connection 
dialog box.

•	 If a MAP Dataset is selected: opens 
the Edit ArcSDE Geodatabase MAP Dataset 
dialog box .

Copy - Copies the selected connection.

Delete - Deletes the selected connection 
or MAP Dataset.

Browse ArcSDE Geodatabase 

Connection Settings - Specify the 
connection settings : Connection Name, 

Server, Service and Database Name as 
specified in the database Connection 

Properties in ESRI ArcCatalog.

See next page for specific details for SQL 
Server Express connection (Desktop and 

Workgroup Geodatabases).

Authentication - Specify the 
authentication method:

Database Authentication - enter user name 
and password provided by the database 

administrator.
Operating System Authentication - the 
server connection uses Windows 
authentication. The user must be 

logged into Windows with a login name 
that is also valid on the database server.

Test Connection - Tests the 
connection parameters prior to 
accessing datasets.

Connection Details - Specify the transactional or historical 
version to be accessed. The interface lists the existing 
versions for the database.
Information to be provided by the database administrator.

Create/Edit/Copy ArcSDE Geodatabase connection 
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Select Feature Classes 

Edit ArcSDE Geodatabase MAP Dataset 

Feature classes - Click one or more 
feature classes to import - only classes 

sharing the same original coordinate 
system (spatial reference) can be 

imported together.

SQL Query - Click this option to open 
the Create SQL Select Query dialog 
box. - see  Import Personal and File 

Geodatabases section

MAP Dataset- Type a name for the selected 
dataset (by direct selection or SQL query). 
This name will be displayed in the Recent/
Saved MAP Dataset list of the Browse ArcSDE 
Geodatabase dialog box.

The number of default recent MAP 
Datasets saved is set in the MAPublisher 
Preferences for Spatial Database > General 
Spatial Database Editor.

MAP Dataset - Edit the name of the 
MAP Dataset. The new name will be 

displayed in the Recent/Saved MAP Dataset 
list of the Browse ArcSDE Geodatabase 

dialog box.

Connection - Set the name of the 
connection to use to access a dataset

Feature Classes - List of directly selected 
feature classes

SQL Query - SQL query used to select the 
data features (when used).

MAPublisher Preferences
Spatial Database > ESRI Geodatabase Editor 

Use abbreviated table name for layer name - 
ArcSDE Geodatabases' tables are 
identified as databaseName.userName.
tableName. The abbreviated version uses 
only the table name as layer name.

If this option is used in combination 
with the "use alias" option, the alias is 
applied first.

Specify Spatial Filter- Click this button to 
open the Specify Spatial Filter dialog 

box. - see  Import Personal and File 
Geodatabases section

Spatial Filter - Spatial fiter used to limit 
the import extents (when used).



221Chapter 19: Import ESRI Geodatabases
Import ESRI ArcSDE Geodatabases

FUNCTIONALITY

ESRI ArcSDE Geodatabases can be imported through the Simple Import and Advanced Import functions of MAPublisher. 

Importing ESRI ArcSDE Geodatabases requires users to create a connection to the database server containing the 
database. Once a connection is established, the feature classes selection is done the same way as for Personal and 
File Geodatabases — by direct selection or SQL query (see previous section) and using spatial filters..

The connection parameters to an ArcSDE server are saved with the application. The dataset selections (called MAP 
Datasets) are also saved, the maximum number of default MAP Datasets kept is set in the MAPublisher Preferences 
for Spatial Database > General Spatial Database Editor. MAP Datasets saved with a specific name (other than the 
default one given) are always saved.

Like the other Geodatabase formats, multiple feature classes sharing the same source coordinate system may be 
selected at once in the Simple Import or Advanced Import > Add dialog box. To import feature classes that do not 
have matching spatial reference, use Advanced Import and add the feature classes in several Add sessions (see 
chapter 3 for more information on the Advanced Import). 

The feature classes (objects and attributes) are imported on separated MAP layers. ArcSDE Geodatabase tables 
are identified as databaseName.userName.tableName. An abbreviated version using only the table name as layer 
name can be applied as a preference. This option and other layer naming conventions are set in the MAPublisher 
Preferences for Spatial Databases > ESRI Geodatabase Editor (see chapter 1 and previous section).

When feature datasets are present in the database, MAPublisher uses them to group feature classes per parent 
feature dataset to ease the selection process, but feature datasets are not imported as such. As an import setting, 
the feature dataset name may be prepended to the name of the data layer created during import.

USING IMPORT ESRI ARCSDE GEODATABASES

In the Simple Import or the Advanced Import > Add dialog box, set the Format drop-down list to ESRI ArcSDE Geodatabase. 
The format has to be set, because the item <Auto detect format> will not work for ESRI ArcSDE Geodatabases. Click 
the Browse button to open the ArcSDE Geodatabase browser.

The Browse ArcSDE Geodatabase dialog box allows users to create, edit and delete connection parameters to ArcSDE 
servers and also to load previously selected MAP datasets.

ESRI ArcSDE Geodatabase Connection
In MAPublisher, users apply the same connection parameters as they do in the ESRI application interface (such as 
ArcCatalog) — with an exception for SQL Server Express connections:

•	 Connection name: recognizable name in the list of connection. 
•	 Server: server name provided by the database administrator.
•	 Service: service name provided by the database administrator.
•	 Database name: provided by the database administrator.
•	 Account information: Database authentication (user name and password provided by the database 

administrator) or Operating system authentication (uses the Windows login name, must be enabled by the 
database administrator)

•	 Connection details: transactional version (provided by the database administrator) or historical version (enter 
date and time).
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The same connections parameters are available when creating a new connection, editing or copying an existing one:
•	 To create a new connection, click anywhere on the Connections tree of the Browse ArcSDE Geodatabase dialog 

box. This enable the Create New... button that opens the Create New ArcSDE Geodatabase Connection dialog box 
where the connection parameters are to be entered.

•	 To edit an existing connection, click the connection name in the Connections tree of the Browse ArcSDE 
Geodatabase dialog box and then click the Edit button. This opens the Edit ArcSDE Geodatabase Connection 
where connection parameters can be edited.

•	 To copy an existing connection, click the connection name in the Connections tree of the Browse ArcSDE 
Geodatabase dialog box and then click the Copy button. This opens the Copy ArcSDE Geodatabase Connection 
where connection parameters can be edited.

•	 To delete an existing connection, click the connection name in the Connections tree of the Browse ArcSDE 
Geodatabase dialog box and then click the Delete button. Only a connections that has not dataset 
associated to itcan be deleted, so make sure to first delete all recent/saved datasets using that 
connection.

Important Note for SQL Server Express Users
There is an exception for connections to SQL Server Express servers — ArcSDE Desktop (called personal in ArcGIS 
9.2) and Workgroup Geodatabases. In ArcCatalog, users set a "Database Servers" connection where only the server 
name followed by \sqlexpress is required to establish a connection. In MAPublisher, there is no specific interface for 
SQL Server Express connections, the same interface as for the other types of ArcSDE Geodatabases must be used 
with specific settings: 

•	 Server: name of the server followed by _SQLEXPRESS
•	 Service: the server name must be preceeded by sde:sqlserver and followed by \sqlexpress (e.g. 

sde:sqlserver:ServerName\sqlexpress).
•	 Database name: the name of the database must be known.
•	 Operating System Authentication must be set because it is the authentication of SQL Server Express databases.

For example, the name of the database server with SQL Server Express is MyServer, the connections parameters are 
as follow:

•	 ArcCatalog > Database Servers > Add Database Server
ÌÌ Database Server: 	 MyServer\sqlexpress

•	 MAPublisher > Import ArcSDE Geodatabase > Server Connection:
ÌÌ Connection name: 	 as desired
ÌÌ Server: 	 MyServer_SQLEXPRESS
ÌÌ Service: 	 sde:sqlserver:MyServer\sqlexpress
ÌÌ Database name: 	 as required
ÌÌ Operating System Authentication
ÌÌ Version: 	 as required
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Select MAP Datasets
To make a new selection of feature classes from a ArcSDE Geodatabase, click a connection name on the Connections 
tree of the Browse ArcSDE Geodatabase dialog box and click OK. This opens the Select Feature Classes dialog box.

The Select Feature Classes dialog box for ArcSDE Geodatabases is very similar to the Select Feature Classes dialog box 
of Personal and File Geodatabases described in the previous section: users can directly select one or more feature 
classes, provided that they share the same spatial reference, or users can build an SQL query to select a subset 
of some feature classes and apply spatial filters.. The particularity of the ArcSDE Geodatabases is that the feature 
classes selection is saved as a MAP Dataset. When making a new selection, users can type in a specific name for the 
selection at the top of the dialog box.

The MAP Datasets previously saved are selectable directly from the Browse ArcSDE Geodatabase dialog box, by clicking a 
MAP Dataset name in the Recent/saved MAP Datasets tree. The name and connection settings of previously saved MAP 
Datasets can be changed in the Edit ArcSDE Geodatabase MAP Dataset dialog box opened by clicking the Edit button.

MAP Datasets may need to be deleted in order to remove the connection that they are based on. Use the Delete 
button to delete a dataset.

The maximum number of recent MAP Datasets saved with the default name is set in the MAPublisher Preferences 
for Spatial Database > General Spatial Database Editor (user named datasets are saved until deleted).

Settings
Parameters relative to the Geodatabases encoding are accessed by clicking the Settings button. These settings are 
described in chapter 3 of this user guide.

Additionally, users can choose to prepend the feature dataset names to the layer name created on import.
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Import from Basic ESRI ArcSDE server

Format - Select Basic ESRI ArcSDE Server
<Auto detect format> cannot be used.

Simple Import 
Advanced Import > Add 

Browse - Opens the Basic ESRI ArcSDE 
Server browser

Connections - List of connections already 
created within MAPublisher.

MAP Datasets - List of recently selected 
MAP datasets.

Create new -Opens the Create new Basic 
ESRI ArcSDE Server connection dialog box.

Edit -
•	 If a connection is selected: opens the 

Edit Basic ESRI ArcSDE Server connection 
dialog box.

•	 If a MAP Dataset is selected: opens 
the Edit Basic ESRI ArcSDE Server MAP 
Dataset dialog box .

Copy - Copies the selected connection.

Delete - Deletes the selected connection 
or MAP Dataset.

Browse Basic ESRI ArcSDE Server 

Create/Edit/Copy Basic ESRI ArcSDE Server connection 
Connection Settings - Specify the 

connection settings : Connection Name, 
Server, Service and Database Name as 

specified in the database Connection 
Properties in ESRI ArcCatalog.

See next page for specific details for SQL 
Server Express connection (Desktop and 

Workgroup Geodatabases).

User Name / Password - Specify if the 
authentication information provided by 

the database administrator

Test Connection - Tests the connection 
parameters prior to accessing datasets.

Version - Enter the transaction version 
information provided by the database 
administrator.

Unlike ArcSDE Geodatabases, the ArcSDE 
server interface does not list the versions 
existing in the database.

NOTE:	 If ArcReader is not installed on the default installation directory, it might be necessary to edit the binary 
location in the MAPublisher Preferences, Basic ESRI ArcSDE Server Editor (see chapter 1).
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FUNCTIONALITY

Users who do not have an ArcGIS license can install the free ESRI desktop application called ArcReader (see ESRI 
Website for information www.esri.com). File and Personal Geodatabases cannot be read and the access to files with 
Basic ESRI ArcSDE Server connections is limited compared to the ESRI ArcSDE Geodatabase connections:

•	 Aliases, sub-types and attribute domains are not supported — only true names and actual values 
(codes) are imported.

•	 Feature datasets are not recognized. Feature classes are all listed on the same level, they are not 
grouped by feature dataset.

•	 Operating System Authentication is not possible.

USING IMPORT BASIC ESRI ARCSDE SERVER

In the Simple Import or the Advanced Import > Add dialog box, set the Format drop-down list to Basic ESRI ArcSDE Server. 
The format has to be set, because the item <Auto detect format> will not work for Basic ESRI ArcSDE Server. Click 
the Browse button to open the Basic ESRI ArcSDE Server browser.

The Browse Basic ESRI ArcSDE Server dialog box allows to create, edit and delete connection parameters to ArcSDE 
servers and also to load previously selected MAP datasets.

Most functions are very similar to ESRI ArcSDE Geodatabases, below are some notes on particularities of the ArcSDE 
server access.

Basic ESRI ArcSDE Server Connection
In MAPublisher, users apply the same connection parameters as they do in the ESRI application interface (such as 
ArcCatalog) — with an exception for SQL Server Express connections:

•	 Connection name: recognizable name in the list of connection. 
•	 Server: server name provided by the database administrator.
•	 Service: service name provided by the database administrator.
•	 Database name: provided by the database administrator.
•	 User name and password: provided by the database administrator.
•	 Version: provided by the database administrator — no list of the existing settings on the database are 

provided.

Important Note For SQL Server Express Users:
Some specific settings are required for SQL Server Express connections. See section on ESRI ArcSDE Geodatabase 
connection.

Select MAP Datasets
The selection of MAP Datasets is done similarly as for ESRI ArcSDE Geodatabases, except that feature classes are not 
grouped into feature datasets. Please refer to the previous section for more information.
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Graphic File Formats 
AI
The Adobe Illustrator native postscript file format. Refer to the Adobe Illustrator User Guide for more information.

DOQ
Digital Orthophoto Quadrangle (DOQ) are geographic images from the United States Geological Survey (USGS) and 
are stored in the JPG format. They can be placed by Adobe Illustrator and registered by the MAPublisher Register 
Image filter. DOQ are usually very large files (30-40 MB or more) and will require extremely large amounts of RAM.

DRG
Digital Raster Graphics (DRG) are scanned images of published topographic maps from the USGS stored in TIF 
format. They can be placed by Adobe Illustrator and registered by the MAPublisher Register Image filter. DRG 
are also usually very large files (30-40 MB or more) and will require extremely large amounts of RAM for any 
manipulation within Adobe Illustrator.

EPS
The Encapsulated Post Script (EPS) file is used to transfer PostScript language artwork between applications (also see 
PostScript in the glossary section of the User Guide). EPS files are easily opened by Adobe Illustrator because the 
format is widely supported by most graphics programs. It is the preferred format for export to most illustration and 
page-layout programs. EPS files are by their nature vector based, but can contain embedded raster graphics and 
fonts.

GIF
Graphic Interchange Format (GIF) is a colour-indexed graphics format, commonly used for web pages and image file 
transfer. Adobe Illustrator can export 8-bit indexed-colour or grayscale gifs.

JPEG
Joint Photographic Experts Group (JPEG or JPG) is a compression technique for raster file formats. The Digital 
Orthophoto Quadrangle geographic images from the USGS are stored in this format, which can be imported by 
Adobe Illustrator and registered by the MAPublisher Register Image filter. DOQ are usually very large files (30-40 MB 
or more) and will require extremely large amounts of RAM.

PDF / GEOSPATIAL PDF
Portable Document Format (PDF) is a standardized format developed by Adobe for use across Macintosh, Windows, 
DOS, and UNIX platforms. Based on the PostScript Level 2 language, PDF supports both raster and vector graphics. 
A Geospatial PDF is an Adobe Acrobat file that retains geospatial coordinates.

TIF/TIFF/GEOTIFF
Tagged Image File Format (TIFF or TIF) is a common raster graphic file format that can be imported by Adobe 
Illustrator. Many raster geographic images from GIS systems are stored in this format, which can be imported by 
Adobe Illustrator and registered by the MAPublisher Register Image filter. A GeoTIFF is a TIFF file with embedded 
geographic information identifying its position and scale in world coordinates.

OTHERS
Please refer to the Adobe Illustrator User Guide for other graphics file formats supported by Adobe Illustrator.

Appendix 1: Technical Reference Guide
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This section contains descriptions of the GIS formats supported for import by MAPublisher. Here you will find 
an overview of the structure of each format, as well as information on supported format versions and elements 
unique to each data type. Each file format will carry a checklist covering which core elements are supported by 
MAPublisher during its import. You can also refer to the Frequently Asked Questions section in this guide for 
information on any issues associated with the various file formats. 
Also see chapter 2 on Map Data File Formats.

AUTOCAD DRAWING (*DWG) AND DRAWING EXCHANGE (*.DXF)

There are two formats used by AutoCAD: DXF is a CAD data file format, developed by Autodesk as their solution for 
enabling data interoperability between AutoCAD and other programs. The Dwg format is used for storing two and 
three dimensional design data and is the internal format for the AutoCAD Computer Aided Design package. DWG 
is also the common name for AutoCAD proprietary DWG technology developed by Autodesk for their AutoCAD 
package.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.dwg, *.dxf	 Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  Yes 
	 User-Defined Attributes 	 Yes		  Circular Arc	 Yes 
	 Coordinate System Support 	 No		  Elliptical Arc 	 Yes 
	 Generic Colour Support 	 Yes		  Ellipses 		  Yes 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  Yes		  Donut Polygon 	 Yes
	 3D Support		  Yes		  Point 		  Yes
						      Line 		  Yes
						      Text 		  Yes
	 Supported Versions
 	 Windows: Releases vrs. R12 to 2007
	 Mac OS X: Releases vrs. R12 to 2007. 

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import:

•	 Group Entities - Group entities by Layer Name or Geometry. 
•	 Hatches - Check this box if you want MAPublisher to read your hatch patterns upon import.
•	 White Lines and Fills - Enabling the Import as is option will instruct MAPublisher to import the data true to the 

original colour settings contained in the file. Check the Change white lines and fills to black box to import black 
lines instead of the files native white lines. Check the Create black background option to incorporate a layer 
containing a black background to mimic the AutoCAD environment.

MAPublisher Import Formats 
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DELIMITED ASCII TEXT (*CSV, *TSV,*TXT )

An ASCII file containing a tabular data where delimiters separate the columns and rows. Common delimiters are 
commas, spaces, or tabs. Microsoft Excel and many other spreadsheet programs will export data in these formats. 

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.csv, *.tsv, *.txt	 Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 Yes		  Circular Arc	 No
	 Coordinate System Support 	 No 		  Elliptical Arc 	 No
	 Generic Colour Support 	 No		  Ellipses 		  No 
	 Spatial Index 		  Never		  Polygon 		  No
	 Schema Required 		  Yes		  Donut Polygon 	 No
						      Point 		  Yes
						      Line 		  No
						      Text 		  No

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import: 

•	 Axis Column - Specify which columns contain the x and y coordinates for the point data to be read in.
•	 Coordinate Format - Choose the formatting type of the data you wish to import (e.g. Decimal Degrees, Delimited 

Degrees Minutes Seconds, Packed DMS) — formats are described in chapter 6.
•	 Use first line as header - Allows the user to enable the first line of the text file to be used as column headings.

ESRI INTERCHANGE FILE (*.E00)

An archive of files that describes a complete ArcInfo coverage. This is either ASCII or compressed into a binary and is 
used to transfer files between different versions of ArcInfo. It is a commonly found format for freely distributed data 
such as that found at the GIS Data Depot (http://www.geocomm.com).

A single E00 file describes a complete ArcInfo coverage. The file itself is actually an archive of several smaller files, 
referred to as subfiles. Some of these subfiles have fixed names which do not vary from coverage to coverage, and 
follow a predefined data format. The remainder of the subfiles contained within an E00 are the info files. These files 
may contain user-defined attributes, and have names which vary from coverage to coverage. 

	 Supported Elements				     Supported Geometry
	 Typical File Extensions 	 *.e00		   Aggregate 	 No
	 Automated Translation	 Yes		   Circles 		  No 
	 User-Defined Attributes 	 Yes		   Circular Arc	 Yes 
	 Coordinate System Support 	 Yes		   Elliptical Arc 	 Yes 
	 Spatial Index 		  Never		   Ellipses 		  No 
	 Schema Required 		  Yes		   Polygon 		  Yes
	 Geometry Type Attribute 	 e00_type		  Donut Polygon 	 Yes
						      Point 		  Yes
			    			   Line 		  Yes
						      Text 		  Yes		

There are essentially four types of geometry defined in E00 files, which will be reproduced as layers during import:
Arcs (lines), Points, Polygons, and Text. Prior to the import process, an additional Setting can be made:

•	 Tic points layer - This option enables you to include an additional layer which will hold the registration points for the 
imported data. The default is to set to Yes.
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ESRI ARCINFO GENERATE (*.GEN)

ESRI simple ASCII storage and interchange format. There are three different types of .gen files each with of its own 
syntax one for points, one for lines, and one for text geometries. This is the format exported by ArcInfo generate 
command. The gen files are use by ArcInfo to transfer coverages to other mapping systems.

	 Supported Elements			    	 Supported Geometry
	 Typical File Extensions 	 *.gen		   Aggregate 	 No
	 Automated Translation	 Yes		   Circles 		  No 
	 User-Defined Attributes 	 No		   Circular Arc	 No 
	 Coordinate System Support 	 No		   Elliptical Arc 	 No 
	 Generic Colour Support 	 No		   Ellipses 		  No 
	 Spatial Index 		  Never		   Polygon 		  No
	 Schema Required 		  Yes		   Donut Polygon 	 No
	 Geometry Type Attribute 	 arcgen_geometry	  Point 		  Yes
						       Line 		  Yes
						       Text		  Yes		

ESRI GEODATABASES

A Geodatabase is a native ESRI ArcGIS data format for storing geographic data. It is a collection of geographic 
datasets of various types used in ArcGIS and managed in either a file folder or a relational database. There are two 
main types of geodatabases: 

•	 Single-User: Personal Geodatabases (extension .mdb) and File Geodatabases (extension .gdb)
•	 Multi-User: server based geodatabases, also known as ArcSDE Geodatabases.

	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.mdb (personal), *.gdb (file) 	 Aggregate 	 Yes
	 Automated Translation	 Yes			   Circles 		  Yes 
	 User-Defined Attributes 	 Yes			   Circular Arc	 Yes
	 Coordinate System Support 	 Yes			   Elliptical Arc 	 Yes
	 Generic Colour Support 	 No			   Ellipses 		  Yes
	 3D Support 		  Yes			   Polygon 		  Yes
	 Schema Required 		  Yes			   Donut Polygon 	 Yes
	 Transaction Support 		  Yes			   Point 		  Yes
	 Enhanced Geometry		  Yes			   Line 		  Yes
	 Geometry Type Attribute 	 geodb_type		  Text 		  Yes
	 Encoding Support		  Yes			   Raster		  No
							       Solid		  No
							       Surface		  No
							       Z value		  Yes
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ESRI SHAPEFILE (*.SHP)

The ESRI Shapefile is a geospatial vector data format for geographic information systems software. It is developed 
and regulated by ESRI as a mostly open specification for data interoperability among ESRI and other software 
products. A Shapefile is a digital vector storage format for storing geometric location and associated attribute 
information. This format lacks the capacity to store topological information

A single logical Shapefile consists of three physical files, each with one of the following file name extensions:
*.shp :	 Geometric data
*.shx :	 Index to the geometric data
*.dbf :	 Attributes for the geometric data

These extensions are added to the base name of the Shapefile , creating separate physical files that must all reside 
in the same directory. You must select the *.shp file for import. Point, multipoint, polyline, and polygon geometric 
data can be stored in *.shp files. However, a single *.shp file can contain only one type of geometry. Each entity in 
a *.shp file has a corresponding entry in the *.shx index file and a corresponding row of attributes in the associated 
*.dbf file. The order of the entries in each of these files is synchronized. For example, the 3rd geometric entity in the 
*.shp file is pointed to by the 3rd entry in the *.shx index file and has the attributes held in the 3rd row of the *.dbf. 

A single Shapefile may also consist of a number of additional files, with the following file name extensions:
*.sbn / *.sbx : 	Spatial index files for the geometric data. These two files are only generating by an ESRI product 
however they are not required by MAPublisher for import and will they be generated when exporting data to the 
Shapefile format..
*.prj :	 Spatial coordinate system information.

If a *.prj file exists in your Shapefile directory, holding the coordinate system information of the Shapefile , this will 
automatically be read by MAPublisher on import. If your Shapefile folder does not contain a .prj file you will be 
required to specify the coordinate system in order to fully utilize MAPublisher. 

	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.shp (*.shx, *.dbf, *.prj)	 Aggregate 	 Yes
	 Automated Translation	 Yes			   Circles 		  No 
	 User-Defined Attributes 	 Yes			   Circular Arc	 No
	 Coordinate System Support 	 Yes (if have *.prj)		  Elliptical Arc 	 No
	 Generic Colour Support 	 No			   Ellipses 		  No 
	 3D Support 		  Yes			   Polygon 		  Yes
	 Schema Required 		  Yes			   Donut Polygon 	 Yes
	 Transaction Support 		  No			   Point 		  Yes
	 Geometry Type Attribute 	 SHAPE_GEOMETRY		  Line 		  Yes
							       Text 		  No
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GEOGRAPHIC MARKUP LANGUAGE - SIMPLE FEATURES (*.GML)

GML was designed as a geographic interface language for the Geo-Web. It is currently in draft as an ISO standard 
(ISO 19136). The goal of the format is to provide users with a set of abstract base objects that can be built into 
working real world datasets. It uses as XML base to store geometry and feature information that can easily be 
transported across the Internet. 

The GML simple feature profile was created by the Open Geospatial Consortium as a restricted subset of the GML 
specification. It provides a reduced geometry and metadata profile that can be shared across many GIS tasks. This 
simple feature model can be used as a base to generate local application profiles for a specific work area. Since the 
GML models base abstract classes, these application profiles (schemas) are required for accessing and processing 
any GML datasets. Generally, GML data has a *.GML extension, and requires any application specific schema files 
(*.xsd).  For more information on GML, and the GML simple features profile, please visit the Open Geospatial 
Consortium web site: www.opengeospatial.com
	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.gml (*.xml) *.xsd		  Aggregate 	 Yes
	 Automated Translation	 Varies			   Circles 		  No 
	 User-Defined Attributes 	 Yes			   Circular Arc	 Yes
	 Coordinate System Support 	 Yes 			   Elliptical Arc 	 No
	 Generic Colour Support 	 No			   Ellipses 		  No
	 3D Support 		  Yes			   Polygon 		  Yes
	 Schema Required 		  Yes (*.xsd)			   Donut Polygon 	 Yes
	 Transaction Support 		  No			   Point 		  Yes
	 Geometry Type Attribute 	 xml_type			   Line 		  Yes
							       Text 		  No

KEYHOLE MARKUP LANGUAGE (*KML/*KMZ)

KML is an XML-based language for managing the display of three-dimensional geospatial data in the programs 
Google Earth, Google Maps, Google Mobile and WorldWind. The KML file specifies a set of features for display. Each 
feature always has a longitude and a latitude and can have other data, such as tilt, heading, and altitude. KML shares 
some of the same structural grammar as GML. KML files are very often distributed as KMZ files, which are zipped 
KML files with a .kmz extension. MAPublisher uses KML version 2.2 specifications for import and export.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.kml, *.kmz	 Aggregate 	 Yes
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 Yes		  Circular Arc	 No
	 Coordinate System Support 	 Yes 		  Elliptical Arc 	 No
	 Generic Colour Support 	 Yes		  Ellipses 		  No 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  No		  Donut Polygon 	 Yes
	 3D Support		  Yes		  Point 		  Yes
						      Line 		  Yes
						      Text 		  No

Prior to the import process, additional Settings can be made, which will affect how the selected KML file will import. 
The following parameters can be applied to the import: 

•	 Allow Random Colour Mode - This option allows Adobe Illustrator to generate random colour settings for the data.
•	 Expand Network Links - Checking this box will enable the use of network linked KML files.
•	 Import KML Properties as Visible - Check this option to make KML properties visible attributes (hidden by default).
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MAPINFO INTERCHANGE (*.MIF/*.MID)

MIF is a published ASCII storage format used by the MapInfo. It is used as a file format for map and database 
exporting/importing in MapInfo software products. The MapInfo Reference Manual describes the MIF format and all 
constants it uses for colour, style, symbol, and fill patterns. MapInfo Interchange Format Files are often called MIF or 
MIF/MID files. 

A single logical MIF file consists of two physical files, having the following file name extensions:
*.mif :	 Geometric data
*.mid :	 Attributes for the geometric data

These extensions are added to the base name of the MIF file, creating separate physical files that must all reside in 
the same directory. You must select the *.mif file for import.

Each entity in a *.mif file has a row of attributes stored in an associated *.mid file. A single .mif file contains many 
different types of geometry however, the associated attribute in the *.mid file must have the same number and 
type of fields for each entity in the *.mif file. The order of the entries in the two files is synchronized. For example, 
the second geometric entity in the *.mif file has the attributes held in the second row of the *.mid file. The number 
and type of attributes associated with each entity is specified by the user. There must be at least one attribute field 
in the *.mid file.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.mif (*.mid)	  Aggregate 	 Yes
	 Automated Translation	 Yes		   Circles 		  Yes 
	 User-Defined Attributes 	 Yes		   Circular Arc	 Yes
	 Coordinate System Support 	 Yes 		   Elliptical Arc 	 Yes
	 Generic Colour Support 	 Yes		   Ellipses 		  Yes 
	 Spatial Index 		  Never		   Polygon 		  Yes
	 Schema Required 		  Yes		   Donut Polygon 	 Yes
	 Geometry Type Attribute 	 mif_type		   Point 		  Yes
						       Line 		  Yes
						       Text 		  Yes

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import:

•	 Import as Visible Attributes - Enable this option to view the pen and brush pattern values in the imported attribute 
table.

The MAPublisher MID/MIF importer supports the storage of point, line, polyline, arc, ellipse, rectangle, rounded 
rectangle, region (polygon), and text geometric data in .mif files. Each geometric entity present in a *.mif file has 
display properties such as pen and brush width, pattern, and colour. Supported MID MIF properties are as follows:

MAPublisher supports the import of line weights (0-7), colours (24 bit RGB), strokes (1-71). It also supports fonts 
(family, style, justification) for text. In order to use line patterns and fill patterns you must have opened or accessed 
the style library equivalents. Two library files have been created, MIF_LineStyles.ai and MIF_AreaStyles.ai, which 
provide support for many of the standard MapInfo pen styles (stroke patterns) and brush styles (fill patterns). 
These files can be found in the Helpful Styles & Symbols folder on the MAPublisher DVD. Please refer to your Adobe 
Illustrator User Guide for details about how to add these libraries to your Adobe Illustrator Graphic Style panel. 
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MAPINFO TABLE (*.TAB)

TAB is a proprietary geospatial vector data format for geographic information systems software used by MapInfo 
mapping products. A minimum of two files are required for the tab format. The .DAT file which stores the attribute 
data and the .TAB ASCII file which is the link between all other files and holds information about the type of data 
file. The MapInfo TAB importer is closely patterned after the MapInfo MIF/MID reader and writer. This commonality 
makes it easy to support both MIF and MapInfo native formats in the same mapping file. 

A single logical TAB file consists of a number of physical files, having the following file name extensions:
*.tab :	 The main file for a MapInfo table, it is associated with the appropriate dat, map, id and ind files.
*.dat :	 Tabular data for a table in MapInfo native format
*.id :	 An index to a MapInfo graphical objects (MAP) file.
*.map :	 Contains geographic information describing map objects
*.ind :	 An index to a MapInfo tabular (DAT) file

These extensions are added to the base name of the TAB file, creating separate physical files that must all reside in 
the same directory. You must select the *.tab file for import.

	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.tab (*.dat, *.id, *.map, *.ind)	 Aggregate 	 Yes
	 Automated Translation	 Yes			   Circles 		  Yes 
	 User-Defined Attributes 	 Yes			   Circular Arc	 Yes
	 Coordinate System Support 	 Yes 			   Elliptical Arc 	 Yes
	 Generic Colour Support 	 Yes			   Ellipses 		  Yes 
	 Spatial Index 		  Always			   Polygon 		  Yes
	 Schema Required 		  Yes			   Donut Polygon 	 Yes
	 Geometry Type Attribute 	 mapinfo_type		  Point 		  Yes
								        Line 		  Yes				  
								        Text 		  Yes		

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import:

•	 Import as Visible Attributes - Enable this option to view the pen and brush pattern values in the imported attribute 
table

The MAPublisher TAB importer supports the storage of point, line, polyline, arc, ellipse, rectangle, rounded 
rectangle, region (polygon), and text geometric data in .tab files. Each geometric entity present in a *.tab file 
has display properties such as pen and brush width, pattern, and colour. Supported TAB properties match those 
described for MID MIF files on the previous page.

Raster TAB files cannot be imported in MAPublisher.
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MICROSTATION DESIGN (*.DGN)

DGN are the native files created for Bentley Systems Inc. MicroStation product. These files consist of a header, 
followed by a series of elements. The header contains global information including the transformation equation 
from design units to user coordinates, as well as the dimension of the elements in the file. Each element contains 
standard display information, such as its colour, level, class, and style, as well as a number of attributes specific to 
its element type. For example, a text element has fields for font, size, and the text string in addition to the standard 
display attributes.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.dgn		  Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  Yes 
	 User-Defined Attributes 	 Yes		  Circular Arc	 Yes
	 Coordinate System Support 	 No 		  Elliptical Arc 	 Yes
	 Generic Colour Support 	 Yes		  Ellipses 		  Yes 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  Yes		  Donut Polygon 	 Yes
	 Geometry Type Attribute 	 igds_type		  Point 		  Yes
	 3D Support		  Yes		  Line 		  Yes
						      Text 		  Yes
	 Supported Versions
 	 Windows: V7, V8. Mac OS X: V7,V8

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import. Note: versions V7 and V8 are supported for import, attached raster 
files are ignored.

•	 Group Elements - Choose how you want to group the elements of the file on import. If you group the elements by 
level, it may result in a large number of output files. By Level is the default.

•	 Coordinate Units - Choose Master or UOR (Unit of Resolution) as the coordinate units. Master is the default.
•	 White Lines and Fills - Enabling the Import as is option will instruct MAPublisher to import the data true to the 

original colour settings contained in the file. Check the Change white lines and fills to black box to import black 
lines instead of the files native white lines. Check the Create black background option to incorporate a layer 
containing a black background to mimic the AutoCAD environment.

•	 Other - Check Drop complex chains if you want each component of a complex chain to be returned as its own 
feature, otherwise all elements of the complex chain will be merged into a single linear feature. 
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S57 FORMAT (*000)

S57format is intended for the exchange of digital hydrographic data between national hydrographic offices and 
for its distribution to manufacturers, mariners and other data users. It is used for the supply of ENC cells (Electronic 
Navigational Charts) to ECDIS (Electronic Chart Display and Information System). 
The format is public, developed and maintained by the IHO (International Hydrographic Office) CHRIS working 
committee (Committee on Hydrographic Requirements for Information Systems). The objects spatial geometry can 
be of Point, Line or Area geometry, while object descriptions are categorized in object classes, organized in specific 
attributes schemas. For a full format description, please visit http://www.iho.shom.fr/PUBLICATIONS/IHO_Download.
htm#S-57 (Appendix A in particular). An online object catalog is also available on www.s-57.com

An S57 base file has the extension *.000, while the update files have extensions like .001, .002 and so on. It can also 
be accompanied by other files:
*.000: main file
*.001: update file 1
*.002: update file 2
*.00n: update file n
files.TXT and files.JPG: ancillary text and picture files indicated in attribute definition

Update files contains only the changed (new/deleted/modified) objects and are only used as a complement 
of a .000 file. Only the *.000 file is required for the import into MAPublisher. The update files will be applied at 
conversion, when present. However, text and image files linked to attributes will be ignored.

	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.000 (*.001 *.002...)		  Aggregate 	 No
	 Automated Translation	 Yes			   Circles 		  No 
	 User-Defined Attributes 	 No			   Circular Arc	 No
	 Coordinate System Support 	 Yes 			   Elliptical Arc 	 No
	 Generic Colour Support 	 No			   Ellipses 		  No
	 3D Support 		  Yes			   Polygon 		  Yes
	 Schema Required 		  N/A			   Donut Polygon 	 Yes
	 Transaction Support 		  No			   Point 		  Yes
	 Geometry Type Attribute 	 s57_type			   Line 		  Yes
							       Text 		  No

NOTE: 	 Most ENC producers (private and public) publish their .000 files in encrypted formats. Only non-encrypted 
files can be imported in MAPublisher (from NOAA or USACE for example).
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TIGER/LINE (*.RT1) (*.BW1)

Topologically Integrated Geographic Encoding and Referencing (TIGER). TIGER is the United States Census Bureau 
format for its digital database of geographic features. TIGER includes both land attributes such as roads, buildings, 
rivers, and lakes, as well as areas such as counties, ZIP codes, census tracts, and census blocks. Some of the 
geographic areas represented in TIGER are political areas, including counties, congressional districts, school districts, 
and ZIP codes. Others are statistical areas, including Metropolitan Statistical Areas (MSA), census tracts, census block 
groups, and census block. The database contains information about these features such as their location in latitude 
and longitude, the name, the type of feature, address ranges for most streets, the geographic relationship to other 
features, and other related information. More information on the TIGER/Line file format and data product can be 
found on the U.S. Census web page at: http://www.census.gov/geo/www/tiger/
This web site contains a detailed description of the current TIGER/Line format, with an explanation of field meaning 
for each feature type. A detailed description of the TIGER/Line 1998 format, with an explanation of field meaning for 
each feature type, is available at: http://www.census.gov/geo/www/tiger/tiger98.pdf

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.rt1, *.bw1	 Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 Yes		  Circular Arc	 No
	 Coordinate System Support 	 Yes 		  Elliptical Arc 	 No
	 Generic Colour Support 	 Yes		  Ellipses 		  No 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  Yes		  Donut Polygon 	 Yes
	 Transaction Support 		  No		  Point 		  Yes
	 Geometry Type Attribute 	 tiger_type		 Line 		  Yes
						      Text 		  No
	 Supported Versions:  	 1992, 1995, 1997, 1998, 1999, 2000, 2002

USGS SDTS (*CATD.DDF)

SDTS is the USGS robust way of transferring Earth-referenced spatial data between dissimilar computer systems with 
the potential for no information loss. It is a transfer standard that embraces the philosophy of self-contained transfers, 
i.e. spatial data, attribute, georeferencing, data quality report, data dictionary, and other supporting metadata all 
included in the transfer. More info can be found at http://mcmcweb.er.usgs.gov/sdts/. Files in the SDTS format will 
have the extension *.ddf. More information on this format can be found at: http://mcmcweb.er.usgs.gov/sdts/

A group of *.ddf files is normally identified by the catalog file, or *CATD.DDF file, which relates the files of a single 
SDTS transfer, and binds together all the files with a common prefix. Always select the SDTS file which ends in CATD, 
i.e. HP01CATD.DDF. 

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.ddf		  Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 No		  Circular Arc	 No
	 Coordinate System Support 	 Yes 		  Elliptical Arc 	 No
	 Generic Colour Support 	 No		  Ellipses 		  No 
	 Spatial Index 		  Yes		  Polygon 		  Yes
	 Schema Required 		  N/A		  Donut Polygon 	 Yes
	 Transaction Support 		  No		  Point 		  Yes
	 Geometry Type Attribute 	 sdts_type		  Line 		  Yes
						      Text 		  No
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USGS DIGITAL LINE GRAPH (*.DLG) (*.OPT)

DLG is a fixed field record that may or may not have end of line markers. The DLG file structure was designed to 
accommodate all categories of spatial data represented on a conventional line map. DLG is a published ASCII format 
developed by the United States Geological Survey (USGS) Federal Agency and is intended to assist in data exchange 
with the National Digital Cartographic Data Base (NDCDB).

The DLG reader supports all three distinct types of DLG data:
	 • Large-scale DLG data (1:24,000-scale)
	 • Intermediate-scale DLG (1:100,000-scale)
	 • Small-scale DLG data (1:2,000,000-scale)

The three scales of DLG data are physically formatted into files in one of these ways: standard, optional, and graphics 
formats. MAPublisher supports both the standard and the optional DLG distribution formats; however the graphics 
format is not supported. Most DLG data is distributed in the optional format. The DLG file structure was designed to 
accommodate all categories of spatial data represented on a conventional line map. Node, line, and area data types 
are present within the DLG format, along with linkages and attribute codes. Linkages are references to other features 
within the same DLG data set, used in a variety of contexts. DLG files do not explicitly store attribute values but use a 
feature coding approach in which unique feature codes are assigned to the different types of features stored within 
the data set. MAPublisher will look for the extension .dlg or .opt for the input DLG files.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.dlg, *.opt		 Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 No		  Circular Arc	 No
	 Coordinate System Support 	 Yes 		  Elliptical Arc 	 No
	 Generic Colour Support 	 No		  Ellipses 		  No 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  No		  Donut Polygon 	 Yes
	 Geometry Type Attribute 	 dlg_type		  Point 		  Yes
						      Line 		  Yes
						      Text 		  No
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MAPublisher Unicode Support 

This section contains information regarding Unicode character encoding in MAPublisher. MAPublisher supports 
Unicode character encoding in MAP Views, MAP Attributes, MAP Stylesheets, and MAP Selection Filters. 
MAPublisher can also reference Adobe Illustrator layers, graphic styles and character styles using Unicode encoding.  

To use Unicode character encoding you require a Unicode compliant font. Mac OS X users will have Unicode 
compliant fonts installed with OS X. Windows users will require Unicode compliant fonts to render Unicode. For 
more information on Unicode visit http://www.unicode.org. 

The following tables display Unicode—UTF8 support in MAPublisher, for GIS data formats that are Unicode—UTF8 
compliant. Unicode support for importing and exporting data is different, so for each platform two tables have 
been created. For each data format there are four areas where Unicode character encoding can be used:

1. File Directory - when Unicode encoding is used in the path to where the file is located.
2. Filename - when Unicode encoding is used in the filename.
3. Attribute column name - when Unicode encoding is used in a column name for attributes.
4. Attribute value - when an attribute value contains Unicode encoding.

Windows Unicode Support (Importing)

Data Format File  
Directory Filename

Attribute 
Column 

Name

Attribute 
Value

Delimited 
Text P P P P

CAD-DWG P P FORMAT HAS NO  
ATTRIBUTES

CAD-DXF P P FORMAT HAS NO  
ATTRIBUTES

ESRI ArcInfo 
Generate P P FORMAT HAS NO  

ATTRIBUTES

ESRI ArcSDE 
Geodatabase P P P P

ESRI File 
Geodatabase P P P P

ESRI Inter-
change File P P P P

ESRI Personal 
Geodatabase P P P P

ESRI  
Shapefile P P P P

GML (Simple 
Features) P P P P
MapInfo  
MIF/MID P P O P

MapInfo TAB P P O P
MicroStation 

Design O O FORMAT HAS NO  
ATTRIBUTES

KML/KMZ P P P P
S57 P P

FORMAT USES SIMPLE 
ASCII TEXT FOR ATTRIBUTE 
NAMES AND MOST VALUES

Windows Unicode Support (Exporting)

Data Format File  
Directory Filename

Attribute 
Column 

Name

Attribute 
Value

Delimited 
Text P P P P

CAD-DWG P P FORMAT HAS NO  
ATTRIBUTES

CAD-DXF P P FORMAT HAS NO  
ATTRIBUTES

ESRI Inter-
change File P P P P
ESRI ArcInfo 

Generate P P FORMAT HAS NO  
ATTRIBUTES

ESRI  
Shapefile P P P P

GML (Simple 
Features) P P P P
MapInfo  
MIF/MID P P O P

MapInfo TAB P P O P
MicroStation 

Design O O FORMAT HAS NO  
ATTRIBUTES

KML P P P P
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Mac OS X Unicode Support (Importing)

Data Format File  
Directory

File-
name

Attribute 
Column 

Name

Attribute 
Value 

Delimited Text P P P P
CAD-DWG P P FORMAT HAS NO  

ATTRIBUTES

CAD-DXF P P FORMAT HAS NO  
ATTRIBUTES

ESRI ArcInfo 
Generate P P FORMAT HAS NO  

ATTRIBUTES

ESRI ArcSDE 
Geodatabase NOT SUPPORTED ON MAC OS X

ESRI File 
Geodatabase NOT SUPPORTED ON MAC OS X

ESRI Inter-
change File P P P P

ESRI Personal 
Geodatabase NOT SUPPORTED ON MAC OS X

ESRI Shapefile P P P P
GML (Simple 

Features) P P P P
MapInfo  
MID/MIF P P O P

MapInfo TAB P P O P
MicroStation 

Design O O FORMAT HAS NO  
ATTRIBUTES

KML/KMZ P P P P
S57 P P

FORMAT USES SIMPLE 
ASCII TEXT FOR ATTRIBUTE 

NAMES AND MOST 
VALUES

Mac OS X Unicode Support (Exporting)

Data Format File  
Directory

File-
name

Attribute 
Column 

Name

Attribute 
Value 

Delimited Text P P P P
CAD-DWG P P FORMAT HAS NO  

ATTRIBUTES

CAD-DXF P P FORMAT HAS NO  
ATTRIBUTES

ESRI Inter-
change File P P P P
ESRI ArcInfo 

Generate P P FORMAT HAS NO  
ATTRIBUTES

ESRI Shapefile P P P P
GML (Simple 

Features) P P P P
MapInfo  
MID/MIF P P O P

MapInfo TAB P P O P
MicroStation 

Design O O FORMAT HAS NO  
ATTRIBUTES

KML P P P P

Windows Unicode Support  
(Working with Images)

Data Format File Directory 
(Register Image)

Filename 
(Register Image)

File Directory 
(Export Image)

Filename 
(Export Image)

World File (.tfw) P 
Û

/ P
t

P 
Û 

/ P 
t

P 
Û

/ O
t

P 
Û

/ O
t

Image Report (.irp) P 
Û 

/ P 
t

P 
Û 

/ P
t

P 
Û

/ O 
t

P 
Û

/ O 
t

MapInfo TAB (.tab) P 
Û

/ P
t

P 
Û

/ P 
t

P 
Û

/ O 
t

P 
Û

/ O 
t

ListGeo (.lgo) P 
Û 

/ P 
t

P 
Û 

/ P 
t

P 
Û

/ O 
t

P 
Û

/ O
t

GeoTIFF (.tif) P 
Û

/ P 
t

P 
Û

/ P 
t

P 
Û

/ O 
t

P 
Û

/ O
t

ÛWhen using system encoding 
 on Windows XP 
 (for example, using the default 
Japanese encoding on Japanese 
Windows XP)

t�When using non-system 
encoding on Windows XP 
(for example, using Japanese 
encoding on English Windows XP)
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Mac OS X Unicode Support  
(Working with Images)

Data Format File Directory 
(Register Image)

Filename 
(Register Image)

File Directory 
(Export Image)

Filename 
(Export Image)

World File (.tfw)  P 
�

P 
�

P 
�

P 
�

Image Report (.irp)  P 
�

P 
�

P 
�

P 
�

MapInfo TAB (.tab)  P 
�

P 
�

P 
�

P 
�

ListGeo (.lgo)  P 
�

P 
�

P 
�

P 
�

GeoTIFF (.tif)  P 
�

P 
�

P 
�

P 
�

�Limited support
 (not all combinations of Unicode 	 
characters are supported) 
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Technical Support Options / FAQ 

MAPublisher support is provided free of charge to customers with a current MAPublisher Maintenance Program 
(MMP) subscription. All new license and upgrade purchases include a one year MMP subscription. Customers 
without a current MMP subscription may obtain support from a qualified MAPublisher technical specialist at the 
rate of US$49 per incident.

TECHNICAL SUPPORT 
Please consult the FAQs, the additional how-to’s on the following pages as well as the following online options 
before contacting Avenza technical support as your situation may be easily addressed by one of the answers 
contained therein.

MAPublisher User Forum and FAQ
The MAPublisher User Forum is located at http://www.avenza.com/forum. Answers to common technical questions 
may be found in the Common Support Issues and FAQs category. All users with a MAPublisher license (evaluation or 
permanent) can post and read topics under the General Questions for Evaluation and Licensed Users category. Additionally, 
users with maintenance have access to the Maintenance Users category. There, users can find additional information 
relative to software updates, etc.

Contacting Avenza Technical Support

Avenza offers a number of methods for direct communication with our qualified and experienced technical 
experts. Please have your MAPublisher registration details handy to get prompt attention and include it in any 
email correspondence. Support issues are handled on a first come, first-served basis. Avenza does not guarantee 
a response within any specified time. MAPublisher Maintenance Program subscribers receive free and unlimited 
support. All others are eligible for support at the rate of US$49 per incident.

• 	 email: support@avenza.com 
• 	 online form: http://www.avenza.com/support/form
• 	 phone: +1.416.487.6442

MAPUBLISHER MAINTENANCE PROGRAM (MMP)

The MAPublisher Maintenance Program is a subscription-based service plan that guarantees its members:
• 	 unlimited priority technical support - guaranteed same business day (9-4 EST) or next business day response
• 	 unlimited telephone support (+1-416-487-6442)
• 	 free MAPublisher updates
• 	 free MAPublisher version upgrades
• 	 additional discounts and offers available to MMP members only

Your MAPublisher purchase includes a one-year membership in the MAPublisher Maintenance Program so you are 
well on the way to worry-free use of MAPublisher for the first year and will be able to enjoy all the benefits of the 
MMP immediately. All MAPublisher Maintenance Program subscriptions begin on the date of purchase and run for 
one calendar year.
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Your email address has been automatically entered in the mp-maintenance-l online email list for MMP subscribers 
so that you are assured of receiving all the latest MMP news and access to all the update and upgrade files. If you 
purchased your MAPublisher license from a reseller or are the end user but not the person who purchased the 
software, please contact us at sales@avenza.com to ensure that we receive your email address and add you to the 
MMP notification group.

Renewal
Approximately 6-8 weeks prior to the expiration of your annual MMP subscription you will be notified regarding 
renewal options. You will be contacted a minimum of five times prior to expiration in order to ensure that you 
have ample opportunity to renew or not at your discretion. You will have the option of renewing your MMP for an 
additional year at the then prevailing price or canceling without penalty. Of course, if you cancel or let your MMP 
lapse you will no longer be entitled to the benefits of the program as outlined above and will thus have to purchase 
future upgrades at the upgrade price.

There is a grace period of approximately 30 days from the time of the MMP expiry during which you may still renew 
without penalty. All post-expiration renewals will be backdated to the actual expiry date.

Lapsed Subscriptions
Failure to renew your MMP within 30 days from the expiry date will result in a lapsed MMP subscription. Lapsed 
subscriptions may not be renewed and the licensee will be required to purchase support and upgrades accordingly.

Please direct all MMP questions and purchase inquiries to info@avenza.com.

WISHLIST

As either a new or experienced MAPublisher user we value your opinions on how we can improve our product. 
Please let us know what functions you would like to see incorporated into future upgrades of MAPublisher.
• 	 email us at support@avenza.com
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RAM RECOMMENDATIONS

Occasional User: 2 GB of RAM is recommended.
A graphics or GIS user who uses MAPublisher with medium sized data sets with up to 20 layers, minimal text labels, 
and some low-resolution or small coverage raster images.

Power User: 4 GB or more of RAM is recommended. 
A professional cartographer who uses MAPublisher daily and works with large urban data sets (including large 
transportation layers) with 20 or more layers, raster based air photographs, large numbers of text labels, complex fill 
patterns, etc.

RAM USAGE HINTS

Users often ask us why is so much RAM needed to operate MAPublisher. First of all, Adobe Illustrator requires a 
significant amount of RAM itself in order to run smoothly. Secondly, map data sets are often large which increases 
the need for RAM even further. Map data sets contain both vector and attribute data which must be stored in 
memory. Since we are adding a database to Adobe Illustrator this increases the file size, which increases the 
RAM requirements. MAPublisher builds a mini-GIS application inside Adobe Illustrator so that it can geo-code 
information and attach data to objects. This also has some overhead.

GIS users also often ask why so much more memory is needed with MAPublisher than is with GIS software. The 
graphics environment software of Adobe Illustrator loads the entire file into memory rather than just reading it 
from disk, thus more RAM memory is required.

When you are importing a large number of files into Adobe Illustrator using MAPublisher, you’ll notice that the 
amount of available memory will decrease rapidly and your computer loses speed. This is due to the memory 
management. MAPublisher reserves a fairly large amount of memory for each import-action, which is not properly 
returned when the import is done or even when it is cancelled. The solution is simple: save your file, close it and 
open it again. It’s not even necessary to close Adobe Illustrator itself. By closing the file, the reserved memory is 
properly returned. 

RAM SAVING TIPS

Since a percentage of the memory is taken for attribute storage, drop any redundant or otherwise unnecessary 
attribute fields from the map attributes table.

Many sources of street data include paths/vectors that are segmented based on street addressing information. You 
can use the MAPublisher Join Lines filter to join these into single linear features based on a selected attribute field. 
Reducing the number of objects (and data records) in the map file will free up memory.

Many GIS data files are large and when a series of such files is imported, you may find that the import filter starts 
to run more slowly. This is because scratch and memory allocations are being used up. The best solution is to 
periodically save your work, quit out of Adobe Illustrator and then restart. This will free up the available scratch 
memory.

Memory Considerations 
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The minimum number of undoes can be reduced (since they ALL reside in memory).

Use polylined or pre-joined linear feature data sets where available.

In your GIS application strip out the attributes you won’t be using for queries or labelling before importing the data 
into Adobe Illustrator.

You can set a primary and secondary scratch disk under the Adobe Illustrator preferences option in order to draw 
additional storage from a partitioned or multi-drive environment.

Turn off the layer preview icon that appears to the left of each layer name in the Adobe Illustrator layers panel. 
This can be done by clicking the options menu in the layers panel and then selecting small panel rows in the panel 
option dialog box.
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For Geographic Information System (GIS) users, the appeal of graphics is strong and the increasing ability to 
discover and share GIS across the Internet is fascinating. The Internet offers a large number of free-access GIS-
related web sites from which you can access map and information data sets.

For the general public, there’s general information about countries, states, and places; simple maps of areas (e.g., 
GIF, PS format); lists and maps of Internet resources in an area. For cartographers and geography researchers, there 
are cartographic/ GIS base map files (e.g., USGS Demos, DLGs, TIGER); thematic data of a geographic nature (e.g., 
census data); and complete GIS data sets (e.g., ESRI Interchange Files).

To find some information on the source listed it, use any internet search browser such as Google to get access to the 
websites.

FREE MAP DATA

Many sites on the Internet that offer free download of GIS data. Data is available from these and other Internet sites 
in a wide variety of formats. Please consult the sections in this manual on file formats (chapter 2 and MAPublisher 
Import Format section) to ensure that you obtain usable data. For example:

•	 AUSLING data: Australian mapping agency.
•	 CAST data: Center of Advanced Spatial Technologies, University of Arkansas.
•	 Directions Magazine Data Center : internet publication.
•	 EROS Data Center: access to USGS digital datasets.
•	 Geocommunity and GIS Data Depot: very good source of free GIS data.
•	 Geoconnections/Geoconnexions: Canada Ministry of Natural Resources site.
•	 Geography Network: world-wide geographic contents.
•	 Geogratis: maps offered by Natural Resources Canada.
•	 GISuser: provides latest news, resources and tools for the GIS industry.
•	 National Atlas of the United States: excellent data source for the United States.
•	 NOAA ENC Download: free download of electronic nautical charts in S-57 format (USA).
•	 Doug Price’s list of Free Digital GIS Data: Tennesse Geographic Information Council.
•	 Robert E. Kennedy Library @ California Polytechnic State University: US based map inventory.
•	 United State Geological Survey: various data formats available (DLG, GeoTIFF, etc.) from the USGS website.
•	 United States Fish and Wildlife Service: variety of map data in USGS DLG format.
•	 USACE IENC download: US Army Corps of Engineers, S-57 and ESRI Shapefile of US waterways.

OTHER VALUABLE MAPPING LINKS

In some additional places on the Internet where you can find news, reviews, tips and general GIS, cartographic and 
geographic information. For example

•	 GIS Cafe
•	 GIS Dictionary
•	 GIS Lounge
•	 GIS@Development
•	 University of Edinburgh
•	 University of Florida - Geoplan Center
•	 US Census Bureau

Online Links 
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General Tips and Hints 

CREATING ASCII DELIMITED POINT FILES

There may be times when you wish to add a point or a series of points to your map but you do not have a GIS 
or ASCII file containing these points ready for import. Provided you have the real-world coordinates for the 
locations you wish to plot *, you can manually create a delimited ASCII file using a text editor (ex. Notepad, BBEdit, 
SimpleText, Ultra Edit etc.) or a spreadsheet program (ex. Excel, Lotus 123 etc.). This file can then be imported using 
either Simple or Advanced Import using the ASCII Point Data import format.

One column in the file must contain the X coordinates of the points and another must contain the Y coordinates. 
You can add as many additional columns as you wish containing additional information to be imported as attribute 
data.

If you are using a text editor, you can simply type in your data in the following format:

“Column 1 Header”,”Column 2 Header”,”Column 3 Header”...etc
“Column 1 Value 1”,”Column 2 Value 1”,”Column 3 Value 1”...etc
“Column 1 Value 2”,”Column 2 Value 2”,”Column 3 Value 2”...etc

Note that negative values for the X and Y coordinates denote west longitudes and south latitudes, respectively. Also 
make sure to enter a carriage return using the enter key on your keyboard after the last line of data otherwise the 
last line may be ignored by the MAPublisher Point Importer.

If you are using a spreadsheet application you can enter your point information as a table and save the file in a text 
format, preferably .csv or .txt, choosing either comma or tab delimiting. The spreadsheet application will format the 
text automatically. The screenshot below illustrates an example of such a table in Microsoft Excel prior to exporting 
as a .csv or .txt for import into Adobe Illustrator using MAPublisher.

* The MAP Location Tool can be used to generate the X and Y coordinate values suitable for building ASCII Point Files. 
See chapter 4 for more information.
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JOINING SDTS TABLES
The following information should be used in conjunction with the MAPublisher Join a Table function.

When working with United States Geological Survey SDTS files it is necessary to join tables frequently in order 
to obtain the map attribute table you require to make the map you want. This is due to the fact that SDTS data is 
constructed such that the primary vector data is held separately from the various attribute tables that one might 
want to use for a particular mapping purpose. The attribute table that comes as part of the vector file usually 
contains a unique identifier (RCID) for each map element that is used to join it with the other data tables. For 
example, a particular vector file containing the geography of rivers would contain a data column called RCID. 
Various data tables containing information such as vegetation, fish counts or flow rates might be available each also 
with an RCID column. The desired tables are then joined to the initial map attribute table by RCID value using the 
techniques described in the previous pages. 

To find the SDTS tables to join with the vector map file look for the files which have names that start with the same 
character string as the name of the vector file. MAPublisher imports SDTS files that have the characters “CATD” at the 
end of the file name. A typical table to import and join with this file might be called HY01CATD.ddf.

Use the MAPublisher table importer with SDTS file type chosen to import these files. When you join layer and table, 
you do the join based on the column from the layer matched to the RCID column of the table. Note that the CATD 
catalog file found amongst the SDTS files explains what each table is.

ROTATING OBJECTS INDIVIDUALLY IN ADOBE ILLUSTRATOR
On some occasions you may wish to rotate selected objects about their own centres rather than as a group about 
a common origin. This can be accomplished using the native Adobe Illustrator Transform Each function. To use this 
function, first select the objects you wish to rotate. Then go to Object > Transform > Transform Each. In the Rotate 
box enter a desired rotation value and click OK. Each of the selected objects will be rotated individually about their 
own centres.

You may also use the #Rotation property column to individually rotate point symbols or text items based on a 
specified value. See chapter 5 for guidelines on how to use this function.

GEOREFERENCING AN ADOBE ILLUSTRATOR FILE
If you are using an existing Adobe Illustrator file that was created without the use of MAPublisher and as such does 
not contain any geographic parameters or attribute data, the following steps will enable you to georeference your 
Adobe Illustrator file and ultimately create an attribute-rich and accurate scale and world grid structure for your 
map. Please note that the steps that follow refer to functions that are outlined in more detail in the body of this user 
guide. Please familiarize yourself with the main MAPublisher functions and in particular those under the MAP Views 
section (see chapter 4) before proceeding.

Before beginning to georeference an Adobe Illustrator file you must be in possession of the following information:
1.	 The real-world scale of your data
2.	 Details of the coordinate system the data is in (i.e. Projection, Datum etc)
3.	 The X-Y coordinates of one tie-in point in the coordinate system of your data
When you have this information please use the following guidelines in order to georeferencing data with 
MAPublisher in Adobe Illustrator. 
1.	 Go to View > Show Rulers. Set the 0,0 point to the lower left hand corner of the page by double-clicking the cross 
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hairs in the upper right corner.
2.	 If you have a completed Adobe Illustrator vector file go to step 3. Otherwise, place and digitize your raster 

image. Identify a registration or tie-in point in your document. This should be a specific location in your 
document for which a real-world coordinate location is known or can be easily determined. Record the location 
of this point in real world coordinates on a piece of paper.

3.	 Locate the same tie-in point on the Adobe Illustrator document page and determine its X,Y coordinates in page 
units. Record this number as well using Window > Info.

4.	 You should now have the location of your tie-in point in both map and page units (e.g. –79.5, 43.5 in Lat/Long is 
located at 4cm, 2cm in the document).

5.	 Open the MAP Views panel, navigate to the Options section and select New MAP View.
6.	 Enter a name for the MAP View. Set the Scale to the proper scale of the map (i.e. a set distance in document 

units divided by a set distance in ground units).
7.	 Click the Specify button. Choose a projection which matches that of your vector data and click OK.
8.	 Click OK in the MAP View Editor to apply the information to the new MAP View.
9.	 In the MAP Views panel, navigate to the Options pullout, and then click Specify Anchors. 
10.	 Set the Map Anchors to the value of the tie-in location in map units using the values determined in step 3 (e.g. 

–79.5, 43.5).
11.	 Set the Page Anchors to the value of the tie-in location in Page Units using the values determined in step 4 (e.g. 

4, 2). Then click OK.
12.	 If you have not previously done so, ensure that each layer in your Adobe Illustrator file contains only one feature 

type (Point, Area, Line, Text, Legend). 
13.	 In the MAP Views panel drag each of the layers which contain your data in to your new MAP View, ensuring that 

you set the appropriate Feature Type in the Define Layer dialog box.
14.	 Repeat steps 1-13 for any other coordinate systems which exist in your document (such as inset maps for 

example).
15.	 Your document is now a georeferenced MAPublisher file wherein each feature is also georeferenced and 

capable of accepting attributes using the MAP Attributes function (see chapter 5). You can also use the 
MAPublisher Export function to create a GIS file from this newly georeferenced Adobe Illustrator map.

TIPS ON EXPORTING TO OTHER GIS SOFTWARE WITH MAPUBLISHER

These strategies do not focus on how to do the procedures, as these are discussed in the Export section of the MAP 
Views chapter, but more on what you need to know and understand for successful export results.

First and most importantly you need to understand that the MAPublisher export was designed to export MP 
imported or created data one layer and one feature at a time. Why is it important to know this? MAPublisher 
only recognizes objects that have been imported by or created with its filters. If a layer was not imported with 
MAPublisher or is not hosted by a designated MAP View, then MAPublisher will not allow you to export the layer. 

If you have an entire layer that was not created by MAPublisher then:
1.	 Ensure that your layer contains only a single feature type (Point, Area, Line or Text). 
2.	 In the MAP Views panel, check that you have a designated MAP View with a matching coordinate system. If you 

do not, create a new MAP Views.
3.	 Select the layer in the MAP Views panel.
4.	 Drag the layer to the MAP View containing the matching coordinate system to georeference the layer. 
There are also a couple of additional considerations to be aware of when exporting:



A1/24 Appendix 1: Technical Reference Guide
General Tips and Hints 

Since the current exported vector formats are GIS formats that do not support the concept of Bezier curves you 
need to compensate for this. If you have Bezier curves in your Adobe Illustrator file they will not be recognized in 
the GIS software. In order for these features may be represented correctly you will need to add points to these lines 
in Adobe Illustrator first. Simply identify and select any objects that use Bezier curves and then select Object > Path 
> Add Anchor Points. Repeat this command until the line has a sufficient number of anchor points that the shape of 
your curves will not be lost on export.

Adobe Illustrator stores the origin of text that has been applied along paths differently from other text objects. We 
have found the following steps to be the most successful way to get such Text exported to GIS files:
1.	 Create a new Adobe Illustrator layer
2.	 Select any text that has been created along paths.
3.	 Drag this text to the new Adobe Illustrator layer
4.	 Select Type > Create Outlines. The text will be converted to vector objects.
5.	 In the MAP Views panel, drag this layer back into your MAP View, specifying Area as the feature type
You can now export your Text as Area objects. Since the text is no longer text, you can no longer modify the fonts. 
We recommend that you make a copy of the original text objects before you do this process. These hints on how to 
transfer Adobe Illustrator files are necessary because the graphics environment handles text and curves differently 
and they need some modification in order for the GIS software to represent these accurately.

DOUGLAS-PEUCKER LINE SIMPLIFICATION

The Douglas-Peucker algorithm was primarily designed to reduce the number of points required to represent a 
vector line. A common problem in digital cartography and geographic information systems can occur when lines 
are generated automatically from a mathematical function, which records points at a fixed interval regardless if 
they are all lying along a straight line. A reduction of the number of points makes for a cleaner and more readable 
cartographic line. As well in cartographic work within Adobe Illustrator the removal of points along a path can 
significantly improve the speed of file redraws and reduce the overall file size.

The Douglas-Peucker Algorithm was created in Fortran 66 by David H. Douglas and Thomas K. Peucker at the 
University of Ottawa in 1970-71. It was extensively tested in 1972 and was publicly communicated in the following 
article: Algorithms for the Reduction of the Number of Points Required to Represent a Digitized Line or Its Caricature, 
Canadian Cartographer, Vol. 10, No. 2, December 1973.

BEZIER CURVES AND OTHER MAPUBLISHER OPERATIONS

Bezier curves are defined using four control points. Two of these are the end points of the curve, while the other 
two effectively define the gradient at the end points. These two points control the shape of the curve. The curve is 
actually a blend of the control points. This is a recurring theme of approximation curves; defining a curve as a blend 
of the values of several control points.

Most GIS formats do not usually support Bezier curves used in graphics packages such as Adobe Illustrator. As 
such you will typically find that curved sections of GIS data will be composed of a series of small line segments 
rather than an actual curve. This is also how such features will first appear in Adobe Illustrator when imported with 
MAPublisher. The Adobe Illustrator Object > Path > Simplify filter can be used to convert this type of feature into a 
Bezier curve (see chapter 8).
If Bezier curves are exported from Adobe Illustrator using any of the MAPublisher Export filters they will be 
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converted to link and node topology (i.e. the end points of the curve will simply be joined as straight lines). It is 
therefore necessary to create additional points to curves to retain their true shape. This can be done globally by 
using the Adobe Illustrator Add Anchor Points function via Object > Path > Add Anchor Points.

This version of MAPublisher supports Bezier curve features during the following operations:
•	 Scale and Projection transformations via the MAP View Editor
•	 Area and length calculations

CREATING SYMBOLS FOR USE IN POINT STYLESHEETS

A MAPublisher Symbol Library and a National Parks Symbol Library are supplied in the Helpful Styles & Symbols 
folder on the MAPublisher DVD. You may also find that a search on the internet may be useful for finding additional 
libraries. If you are required to create new symbols, the steps below will help you to quickly create symbols 
manually in Adobe Illustrator.

6.	 Use Adobe Illustrator Tools for the manual creation of artwork that will comprise the new symbol. If you wish to 
use a character that are contained in a font library, select the text character instance and click the menu 	
Type > Create Outlines to convert the text to vector art.

7.	 Open the Adobe Illustrator Symbols panel (Window > Symbols).
8.	 Select the artwork that will comprise the new symbol and drag it into the Adobe Illustrator Symbols panel 

double-click the symbol in this panel to assign a name.
9.	 When MAP Stylesheet Editor is accessed for Point Stylesheets, this symbol will be available in the Style column.

CREATING A STYLESHEET TEMPLATE

You can create template files with legends to automate the production of a series of similar maps. 

1.	 The procedure when using MAP Stylesheets is as follows:
2.	 Create a prototype map using the MAPublisher Stylesheet function to create the desired “look”.
3.	 Make a copy of your prototype map file. Delete all the layers from the file so that only the designated 

stylesheets exist
4.	 Save it to a new template file. 
5.	 Use this template file as a base for future maps as follows:

a) 	 Make a copy of the template file.
b) 	 Import all map layers into the template file and do any needed processing.
c) 	 In the MAP Stylesheets panel, drag your MAP Layers into the desired MAP Stylesheets. 
d) 	 Your new layers will be symbolized by the previously defined Stylesheet.

CREATING A MULTI-CONDITIONAL IF EXPRESSION

In Edit Expression it is possible to assign symbology to map objects by assigning an expression to the #Style 
column. In the following example this is achieved by creating a multi-conditional IF statement.

In the following example, a point layer represents cities. Each point has the value “Y”, “N” or “C” in the CAPITAL 
attribute column, describing whether the city is a state capital (Y), is not a state capital (N) or is a country capital (C).
There are three point symbols to assign to the type of point. In this example the following expressions can be 
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assigned to the #Style column of the point layer (both expressions have the same result):
Expression 1:
IF(CAPITAL = “Y”, “MAP Symbol 01”, IF(CAPITAL = “C”, “MAP Symbol 02”, “MAP Symbol 03”)) 

Expression 2:
IF_CASE("MAP Symbol 01", CAPITAL="C", "MAP Symbol 02", CAPITAL="N", "MAP Symbol 03")

Therefore: If the capital is “Y”, assign the symbol “MAP Symbol 01”. If the capital is “C” assign the symbol “MAP Symbol 
02”. All other symbols assign “MAP Symbol 03”.

NOTES FOR EXPORTING IMAGES

If the document colour mode is CMYK, exporting an embedded image may result in increased file size compared to 
RGB mode. 

If the image is LINKED consider the following:

1.	 The image will be exported in the original colour mode of the image irrespective of the current colour mode of 
the document (i.e. a linked grayscale image in a CMYK document will be exported as a grayscale image, whereas 
a linked RGB image in an CMYK document will be exported as a RGB image).

2.	 A linked image with Alpha channels may be exported in a different colour model. For example a grayscale with 
two alphas will export as an RGB or an RGB with an alpha channel will export as CMYK.

3.	 Linked images in CMYK mode (regardless of the color mode of the document) will export with an incorrect 
result and should therefore be avoided (see chapter 12).

If the image is EMBEDDED consider the following:

1.	 The image will be exported in the colour mode of document (i.e. an embedded grayscale image in a CMYK 
document will be exported as a CMYK image, whereas an embedded CMYK image in an RGB document will be 
exported as an RGB image).

2.	 Embedded grayscales do NOT pick up the document colour model (i.e. an embedded grayscale image will be 
exported as grayscale).

3.	 The export of embedded Bitmap images is not supported.

KEYBOARD SHORTCUTS

This version of MAPublisher supports the use of keyboard shortcuts in order to increase the efficiency of the user 
and to make it easier to access commonly used dialog boxes and menus. By default the Simple and Advanced 
Import dialog boxes can be accessed by pressing Shift+Ctrl+I and Alt+Shift+Ctrl+A, respectively. All other 
MAPublisher tools can have keyboard shortcuts manually set by accessing the Adobe Illustrator Keyboard Shortcut 
dialog box which is located under Edit > Keyboard Shortcuts.
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In the MAPublisher application, the coordinate system option must be entered at two levels: coordinate system of 
the source data (when importing GIS data) and coordinate system of the final map.

SOURCE DATA COORDINATE SYSTEM

The Source coordinate system is usually detected when the coordinate system information is available with the 
GIS data being imported and when supported in the native GIS format (such as Shapefile , e00). However, in some 
cases, this information is not imported because it is not supported in the original GIS format (e.g. DWG, DXF...) or 
when using a non-referenced Adobe Illustrator files. In that case, the coordinate system must be specified by the 
user. It generally can be found from an attached metadata document, by contacting the data provider or in textual 
information on the original data itself (e.g. title of a scanned map). 

In all cases, the source coordinate system must be known with certainty. Then only can the proper parameter 
be specified in the MAPublisher interface. A wrongly specified source coordinate system would make the map data 
unusable for transformations and merging with other datasets.

FINAL MAP COORDINATE SYSTEM

Most of cartographic projects are restricted in the choice of coordinate system for the final map. This parameter 
is usually part of the project requirement. It is the task of the professional cartographer to analyze carefully the 
situation to make the wise decision. For general purpose mapping projects (interpretive or marketing maps for 
example), a more approximative selection of the coordinate systems might be acceptable. Following the request 
from some of our users, who may not have a cartographic expertise, here are a list of simple considerations to take 
into account before making a choice:

•	 Use of a Geodetic Coordinate system (angular coordinates, Lat/Long):
•	 Appropriate for overlay with GPS data recorded in Lat/Long format.
•	 WGS84 system is required to export vector data to KML format (for display 

in Google Earth, Google Maps).

•	 Use of a Projected coordinate system:
•	 Appropriate for printed map (so that users can use a ruler to measure 

distances on the map).
•	 Required to add a scale bar. 

•	 Use of a particular system (within the list of projected and geodetic systems):
•	 Maps that are part of a portfolio or Atlas have to comply to the same 

system to be consistent. 
•	 When a geo-referenced image (geotiff or world tiff) is to be used together 

with the data, it is easier to use the same coordinate system for the vector 
data as of the raster.

•	 Most countries or geographic areas have published standards or usual 
way for representing the land (e.g. for road maps or meteorological maps). 
In this case, the user should make some test with the systems listed in 
MAPublisher. For a convenient use, coordinate systems are sorted by 
continent>country>sub-division (state or county for example).

Appendix 2: Coordinate Systems
Overview
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In doubt, it is recommended to test different coordinate systems and visualize the results.

For more information on the supported coordinate systems and projections in MAPublisher, please refer to the 
Avenza Projections Guide pdf document installed with MAPublisher.

Examples of appearance of the USA depending of the chosen coordinate system
Geodetic > World > WGS84 (unprojected)

Projected > World > Robinson

Projected > North America > United States > US National Atlas
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The Geodetic Datasource 

MAPublisher includes an extensive geodetic parameter database called the Geodetic Datasource. It contains all the 
latest updates from the widely used  EPSG Geodetic Parameter Dataset maintained by the Geodesy Subcommittee 
of OGP (International Association of Oil and Gas producers)—EPSG v6.18— as well as custom systems maintained 
by Avenza. In addition, the MAPublisher Geodetic Datasource supports user's custom definitions and allows for 
importing external WKT (Well-Know Text) and PRJ (ESRI projection file) parameter files.

Over 3500 pre-defined coordinates systems are readily available for use in most cartographic projects. Even though 
the current list of systems is comprehensive, there may be instances where the end users may wish to add a brand 
new coordinate system to meet their particular needs, or perhaps to duplicate and modify an existing definition to 
change the units for example.  A complementary Avenza Projections Guide is installed with MAPublisher. It describes 
all the projections and datum shifts methods supported by MAPublisher, to assist users in the process of creating or 
editing a coordinate system.

The default parameters installed with MAPublisher are stored within read-only XML database files referred to 
as the Geodetic Datasource (files named geodata.xml and avenza.xsp).  The base datasource files shipped with 
MAPublisher are installed in the Data Source Files folder at the following location:

Windows XP: 	 C:\Program Files\Avenza\MAPublisher 8\Data Source Files
Windows Vista/7: 	C:\Program Files\Avenza\MAPublisher 8\Data Source Files
Mac OS X:	 Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/Data Source Files

Custom definitions and parameters are saved or loaded from separate XML files that must always accompanied 
with a file named geocalc.xsd (when not present, this file can be copied from the Data Source Files folder).

The custom and read-only entries are organized into categories and sub-folders — users may create new folders, 
move entries or create short-cuts. That folder structure is saved in a view file (*.xvw). 

NOTE: 	 When MAPublisher is un-installed or a newer release is installed, an option will be given to backup the 
custom coordinates systems and view file (Windows only). The backup files can be found 

Windows XP:	 C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8
Windows Vista/7: 	 C:\ProgramData\Avenza\MAPublisher 8 
Mac OS X: 	 Applications/Avenza/MAPublisher 8/Data Source Backup

LOADING A CUSTOM COORDINATE SYSTEMS

A geodetic datasource or coordinate system database can be loaded into MAPublisher, thus greatly extending the 
coordinate systems available for use. You can load a geodetic database within MAPublisher by choosing Load Custom 
Coordinate Systems… from the MAP Views panel options menu. 

The directory containing the xml file must also contain the file geocalc.xsd. This file can be found in the directory 
of the default geodata.xml file (see above). So the custom xml file can either be copied to the Data Source File 
directory prior to loading, or geocalc.xsd should be copied from there to the custom xml directory.

Any additional change will be saved into the loaded xml file.
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Selecting a geodetic datasource to load

NOTE: 	 Coordinate systems may also be extracted from the input data formats (during import process).

COORDINATE SYSTEM EDITOR

MAPublisher includes an extensive geodetic parameter database. The contents of the Geodetic Datasource can be 
browsed or searched by using a search frame. Users can extend MAPublisher Geodetic Datasource to support an 
unlimited number of custom linear and angular units, ellipsoids, datums, datum shifts, and coordinate systems. 

MAPublisher Custom Coordinate Systems Editor is accessed from the MAP Views panel options menu Edit Custom 
Coordinate Systems. Coordinate systems may also be edited/created from the Specify Destination Coordinate System 
dialog box (started from Specify button in MAP Views panel and import dialog boxes), but the other geodetic objects 
are only accessible through Edit Custom Coordinate Systems.

Individual entries in the Geodetic Datasource are known as Objects. There are different types of objects for different 
types of definition. Objects contained in the Geodetic Datasource are:

•	 Angular Units - Type of units for measuring rotation (e.g. degrees or radians)

•	 Coordinate Points (Point Style)- A coordinate point is used to define the orientation of axes used and the 
type of units used in the system.

•	 Coordinate Systems (Coordinate Reference Systems) - A coordinate system is a complete definition 
needed to express the context of a set of map data.

•	 Datum Shifts - Parameters to transform coordinates from one Datum to another.

•	 Ellipsoids - An Ellipsoid gives a horizontal datum its size and shape. An ellipsoid does not have an 
origin and cannot be used as a base model for coordinates on its own.

•	 Envelopes - Defines a geographic area of use for a particular object.

•	 Horizontal Datums - A horizontal datum, more commonly referred to as just datum is the base model 
maps are built on. All coordinate systems must have a datum associated with them to be related to 
any other map. Without a known datum, coordinates are meaningless.

•	 Linear Units - Units for measuring straight line, cartesian distances.

•	 Prime Meridians - The prime meridian represents the line of longitude that is designated as 0 degrees. 
All other lines of longitude are expressed by the angle by which they deviate from the prime 
meridian. Together with the equator of an ellipsoid, the prime meridian defines the origin of a 
geodetic coordinate system. A prime meridian is defined by the angle that separates it from the 
Greenwich meridian. 
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Users have the possibility to define new coordinate systems, make copy and modify existing objects. The custom 
objects are stored in a separate xml file saved by the user. Users can also re-organize the Geodetic Datasource 
(default and custom parameters) into categories and sub-folders. These changes are saved to a view file (.xvw).
The view file may be deleted to reset the Custom Coordinate Systems Editor to its default state.

Datasource - File containing 
the default geodetic 

parameter (geodata.xml).

Custom Data - File containing 
the custom geodetic 

parameter. File loaded or 
saved by the user.

Geodetic Objects - See list 
above.

Search - Search parameters. 
Each category can be 

searched by it’s unique 
parameters (e.g. Name, 

EPSG Code)

Add/Remove - Add and 
remove folders and 

categories.

Save / Save As - Save changes 
to a custom file (data to 
xml and view to xvw).

Edits - Add, remove, edit, 
information or copy 
objects.

Lock Icon - Indicates read-
only parameters (default 
ones).

Warning Icon - Indicates 
incomplete parameters.

At the top of the Edit Custom Coordinate Systems dialog box two paths are be listed, the path to the main Geodetic 
Datasource file which is protected from user modification, and the Custom parameter file, where all of the user-
defined definitions are stored. 

On the left hand side of the dialog box, objects are organized into object type categories with sub-folders organized 
in a tree. To explore the sub-folders of a category, click the plus sign (Windows) or arrow (Mac OS) to the left to see 
categories listed underneath. Click a sub-folder name to list the contained objects on the pane to the right.

New folders or sub-folder can be created by clicking the New Folder button . The default name is New Folder, right 
click and click Rename to type in another name. Only empty user-defined folders can be deleted using the Delete 
Folder button .

Recently used objects are listed under the *Recent* sub-folder of each object category. To clear this list, right click on 
the *Recent* folder name and choose Clear Recent Object History. 

The *Search Results* sub-folder contains the recent search results. To run a query, use the Search frame, enter a text 
string and specify a category specific parameter to search from (e.g. Name, EPSG Code) in the In drop-down list. To 
find the containing sub-folder of an object found by a search query, right-click the object and click the menu Open 
Containing Folder. To clear this list, right click on the *Search Result* folder name and choose Clear Search History.
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The right hand pane lists the objects contained in the sub-folder selected in the Folder list on the left. For all objects, 
users can copy, query, or use drag and drop to move or create a short-cut. Only custom objects (written in blue) 
can be edited or deleted—default objects installed with MAPublisher in black and indicated with a lock icon are 
read-only. Incomplete objects are indicated in red with an exclamation mark (warning icon). Particularly, some of 
the default datum shifts are pointing to external grid files (.gsb) that are missing. These files cannot be distributed 
by Avenza due to copyright or government regulations and have be acquired separately. To find the required file, 
refer to the value column in the Definition tab of the Datum Shift Viewer. For example, the file nb7783v2.gsb from 
the datum shift "NAD83 (CSRS) (1) Canada - New Brunswick" is provided by Natural Resources Canada can provide 
the grid NTv2 (http://www.geod.nrcan.gc.ca/tools-outils/ntv2_e.php).

Like other databases the columns are re-sizable, and when column headings are clicked will sort information 
alphabetically/numerically.

When using the Save button, changes are saved in the custom parameter file (and when no custom file has 
previously been loaded, to customsystems.xml, located in the following directory):
Windows XP: 	 C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8
Windows Vista/7: 	C:\ProgramData\Avenza\MAPublisher 8	
Mac OS 		  Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/Data Source Files

And the default xvw file (folder structure) is saved as customview.xvw, located in the following directory:
Windows XP: 	 C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8
Windows Vista/7: 	C:\ProgramData\Avenza\MAPublisher 8	
Mac OS X:		  Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/ 

The Save As button saves a copy of all the systems (default and custom). This creates  xml and xvw files as well 
as a copy of geocalc.xsd, saved in a directory chosen by the user. These files can then be exchanged between 
computers. Custom xml and xvw files are loaded into MAPublisher through the MAP Views panel options menu Load 
Custom Coordinate Systems.

NOTE: 	 Please ensure that where the custom xml is saved there is a copy of the geocalc.xsd in the same folder, as 
this will be needed to load the file (geocalc.xsd is located in the Data Source Files folder).
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WORKING WITH GEODETIC DATASOURCE OBJECTS

Creating or editing objects will prompt the object's editor dialog box, each editor contains two tabs: Identification 
and Definition tabs.

The Identification tab of the editor is used to name the object and associate identifying codes with it (if applicable). 
The Name text box contains the definition name to be used to select the object in the main list. The Remarks text 
box is used to add notes and is optional. In the Identifiers list, identifying codes may be added for the object (e.g. 
reference to other databases). The GC code is a unique identifier assigned by MAPublisher and must not be altered. 
To enter additional codes use the spaces below. This tab is identical for all object types.

Geodetic Datasource object Identification tab

The Definition tab is used to define the object's parameters. Parameters are specific to each object type. Specific 
definition tabs per object are described here after.

Angular Units
For angular units, the new unit must be defined as a division of the scientific standard Degrees. The abbreviation is 
used to identify the unit within the application interface (Example: The abbreviation for Degrees is “deg”).

Angular Units Editor - Definition
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Coordinate Points
For Coordinate Points you must specify the coordinate point dimensions in either 2D or 3D. For Geodetic and 
Projected Coordinate Points, the Longitude and Latitude style of units must be entered for all 2D. Dimensional 
Points. The Longitude, Latitude and Ellipsoid Height style of units must be entered for 3D Dimensional Points.

                            
Geodetic Point Style Editor                                                           Projected Point Style Editor

Datum Shifts
For Datum Shifts, you must select an Envelope (appropriate geographic area of use). If you are unsure of a more 
specific envelope, leave it se to the default World Envelope. The Source and Target text boxes are used to specify 
the two geodetic models the Transformation is valid for. The Method specifies the necessary parameters to define 
a particular datum transformation. With the proper method selected, enter the appropriate parameters for your 
datum transformation. Be sure to define the appropriate units for each parameter by clicking the Units button.

Datum Shift Editor
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Ellipsoids
For Ellipsoids you must enter the parameters for the Semi-Major Axis and Semi-Minor Axis (often noted as “a” and “b” 
respectively) define the linear units the axes are specified in by selecting a predefined unit in the appropriate fields. 
The Inverse Flattening (often noted as “1/f”) will automatically calculate in the field below. Alternately, you can make 
the Inverse Flattening definitive by enabling the check box at the bottom. You can then manually enter the Inverse 
Flattening rather than the Semi-Minor Axis parameter.

Ellipsoid Editor
Envelopes
The use of an envelope is not required, but very much recommended to indicate the geographical extents where a 
given coordinate system is applicable. To define Envelopes you must select whether or not there are extents points, 
and if so, what point style they are in, and what the values of the minimum and maximum points are.

Envelope Editor
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Horizontal Datums
For Horizontal datums you must select the Ellipsoid the datum is based on, as well as the prime meridian used.

Horizontal Datum Editor

Linear Units
For Linear units you must enter a conversion for the new unit in terms of the scientific standard metres. The 
abbreviation is used to identify the unit within the application interface (Example: The Abbreviation for metres is 
“m”).

Linear Unit Editor
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Prime Meridians
For Prime Meridians you must enter the longitude value of the Prime Meridian and the angular unit that value is in.

Prime Meridian Editor

WORKING WITH COORDINATE SYSTEMS

A coordinate system within MAPublisher defines a mathematical model of the conversion between a specific 
location on the Earth and a set of coordinates. This model is specified by the coordinate system parameters, 
including the Earth model (ellipsoid or datum), the units used to measure the coordinates, the projection type, and 
any parameters specific to the projection type. 

Geodetic coordinate systems use Latitude and Longitude to define the position on the Earth and incorporate 
angular units of measurement such as degrees.

Projected coordinate systems consist of a two or three dimensional system in which each point on the plane 
is defined by an x,y coordinate and having an origin where the axes intersect. Projected coordinate systems 
incorporate linear units of measurement for the measurement of area, distance and direction.

Within MAPublisher, coordinate systems are organized in coordinate system categories. This structure allows 
grouping into a logical collection for convenience (per continent, country or local sub-divisions). 

The folders listed below represent the default schema for the coordinate systems in the Custom Coordinate Systems 
dialog box. Each folder option may be expanded by clicking the  node adjacent to the folder name.
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-ALL-
(Lists all the coordinate systems available in the database)

-RECENT-
(Lists the last 10 coordinate systems used)

-SEARCH ________-
(Lists the most recent results of a Search operation)

-GEODETIC-
(Lists the geodetic coordinate systems in the database)

-PROJECTED-
(Lists the projected coordinate systems in the database)

To define or edit Coordinate Systems, you must select an Envelope defining the appropriate area of use. If you are 
unsure of the appropriate envelope, you can leave it set to the default World envelope. The Point Style is how you 
will select the style of linear units for your system. For most systems, you will want to select Projected point in _____ 
(appropriate units). Then select the Geodetic model that using the appropriate datum for your system. When you 
select the appropriate Projection for your system, the parameters needed to define the system will appear in the 
table below. Enter the needed parameters and define the units each parameter is specified in.

NOTE:	 Information on supported projections and their parameters can be found in the document MAPublisher 
Projections Guide.pdf installed with MAPublisher.

                     
Geodetic Coordinate System Editor                                                  Projected Coordinate System Editor

Projected coordinate system options
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CREATE, EDIT AND DELETE GEODETIC DATASOURCE OBJECTS

Creating A New Object Category

1.	 Select Edit Custom Coordinate Systems from the options menu from the MAPublisher MAP Views panel.
2.	 �When necessary, select the Geodetic or Projected category and then click the New Category button  to create 

a new object category.

Deleting An Existing Object Category

1.	 Select Edit Custom Coordinate Systems from the options menu from the MAPublisher MAP Views panel.
2.	 When necessary, select the Geodetic or Projected category and then click the Delete Category button  to 

delete an object category.

Creating A New Object Within A Category

1.	 Select Edit Custom Coordinate Systems from the options menu from the MAPublisher MAP Views panel.
2.	 �When necessary, select the Geodetic or Projected category and then click the New Object button  to create a 

new object
3.	 In the New Object dialog box, Identification tab, enter a name for the new object. 
NOTE:	 The name must be unique.

4.	 Select and enter the appropriate parameters for the envelope, point style, geodetic value, projection, vertical 
reference, angular unit, linear unit, or scale factor unit that the new object is based upon.

NOTE: 	 For a new coordinate system, the parameters themselves may be customized. Every parameter must be set in 
the following sequence: ellipsoid, datum, envelop, unit (angular or linear), geodetic system and then projected 
system....

5.	 Press the OK button to create the object.
6.	 Press the Save button to commit your update to the Geodetic Datasource file.

Changing An Existing Object
1.	 Select Edit Custom Coordinate Systems from the options menu from the MAPublisher MAP Views panel.
2.	 Select the object, and choose the Edit Object button . 
3.	 Enter the modified parameters for the envelope, point style, geodetic value, projection, vertical reference, 

angular unit, linear unit, oe scale factor unit where appropriate.
4.	 Press the OK button to commit your changes.
5.	 Press the Save button to commit your update to the Geodetic Datasource file.

Deleting An Existing Coordinate System Object
1.	 Select Edit Custom Coordinate Systems from the options menu from the MAPublisher MAP Views panel.
2.	 Select the object, and choose the Delete Object button .
3.	 Press the OK button to commit your changes.
4.	 Press the Save button to commit your update to the Geodetic Datasource file.
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Copying An Existing Object
1.	 Select Edit Custom Coordinate Systems from the options menu from the MAPublisher MAP Views panel.
2.	 Select the object, and choose the Copy Object button .
3.	 Press the OK button to commit your changes.
4.	 Press the Save button to commit your update to the Geodetic Datasource file.

Renaming/Moving An Existing Object
1.	 Select Edit Custom Coordinate Systems from the options menu from the MAPublisher MAP Views panel.
2.	 Select the object, and choose the Edit Object button . 
3.	 Enter the modified parameters for the identification name.
4.	 Press the OK button to commit your changes.
5.	 �In order to move the coordinate system object, select the record and drag it to another category if necessary.
6.	 Press the Save button to commit your update to the Geodetic Datasource file.

Saving Coordinate Systems xml file

1.	 Select Edit Custom Coordinate Systems from the options menu from the MAPublisher MAP Views panel.
2.	 Customized the coordinate systems (actions above)
3.	 Click the Save As button, type the file name
This file can be exchanged with another computer using MAPublisher using Load Geodetic Datasource.

EXPORTING A REFERENCE FILE

The defined coordinate system for a Map View can be exported as a reference .wkt file via MAPublisher Export 
Coordinate System to File option. Select Export Coordinate System to File from the MAP Views panel options menu to access 
the export dialog box where you can save the wkt definition.

Exporting a coordinate system
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IMPORTING ADDITIONAL COORDINATE SYSTEM DEFINITIONS

By using the Import Coordinate System from File menu item in the MAPublisher MAP Views panel options menu, additional 
coordinate system definitions can be imported and merged with the existing datasource information. MAPublisher 
imports the following coordinate system file formats: WKT definitions (.wkt), MAP files (.map), ESRI PRJ files (.prj), 
and MapInfo TAB files (.tab).

NOTES:
•	 The Custom Coordinate Systems must be saved (Save or Save As button) after the import in order to be 

able to reuse it )
•	 New coordinate systems may also be added to the Custom Coordinate Systems during the map data 

import process; when the file coordinate system is not found in the existing lists of coordinate systems, 
it is automatically created with the proper required parameters.

Importing an Additional Datasource
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Appendix 3: MAPublisher 8 How To’s For Legacy Users

Legend Functionality in MAP Stylesheets 

A number of functions have been redesigned in MAPublisher 8. Users of MAPublisher 6 or earlier should consult the 
following pages for information on how to perform common legacy MAPublisher tasks in MAPublisher 8. 

BUILDING COLOUR RAMPS TO CREATE STYLES

You can enhance the look of your maps by using colour ramps, rather than random colours, for your area and line 
styles. A possible use for this would be in the creation of relief maps.
1.	 Determine the number of new graduated styles you wish to create. 
2.	 Create two rectangles with the Rectangle Tool aligned vertically, one at the top of the page, the other at the base. 
3.	 Colour the first (top) and last (bottom) elements with two end colours for the ramp.
4.	 Choose Object > Blend > Blend Options.
5.	 Choose Specified Steps from the list. Enter the value you determined in the first step minus two. Click OK.
6.	 Select the two rectangles. Choose Object > Blend > Make. The legend elements will be blended between the two 

end colours.
7.	 Choose Object > Expand, then choose Object > Ungroup. This ungroups the art so that the new styles can be 

added to the Graphic Styles panel and be used in the MAP Stylesheets.

ASSIGNING INCREMENTAL VALUES TO STYLES

It is very straightforward to assign styles to values for stylesheets based on Equal to expressions. The following 
examples can be used as a basis for new stylesheets, providing the functionality which was previously available in 
the Unique Occurrences option in Auto Assign Legend Info.

Example 1 (Rule 1 assigned first listed value and first style):
1.	 Create the first Equal to rule, using the first listed style, and an expression based on the first listed value in a 

specified attribute column, i.e. Style A assigned to Column X = "Value 1”. 
2.	 Click the Add button. The second rule will be automatically assigned an incremental expression, i.e. Style B 

assigned to Column X = "Value 2”. 
3.	 Keep clicking the Add button until all the values or styles have been used.

Example 2 (Rule 1 assigned first listed value and third style):
1.	 Create the first Equal to rule, using the first listed style, and an expression based on the third listed value in a 

specified attribute column, i.e. Style C assigned to Column X ="Value 1”. 
2.	 Click the Add button. The second rule will be automatically assigned the first unused style, i.e. Style A assigned 

to Column X = "Value 2”. 
3.	 Keep clicking the Add button. Assignments will be incremental, but will not include the third style again, i.e. 

Style B assigned to Column X ="Value 3”; Style D assigned to Column X = "Value 4”; etc
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CREATING STYLE RULES BASED ON MULTIBLE ATTRIBUTE COLUMNS

Assign Legend Info previously provided options to assign legend criteria to legend elements based on values 
in multiple attribute columns. This functionality can now be achieved using Advanced expressions in the MAP 
Stylesheet Editor. Choose the Advanced option to compose advanced expressions.

The following are some examples of multi-column expressions in a world countries stylesheet (using a string type 
column named CONTINENT and an integer type column named POPULATION).

CONTINENT=“Africa” AND POPULATION<1000000
Result: only African countries with populations less than one million are assigned the selected style.

CONTINENT=“Africa” OR POPULATION<1000000
Result: all African countries and all countries with populations less than one million are assigned the selected style.

CONTAINS(CONTINENT,“America” AND POPULATION>1000000
Result: only countries in North and South America with populations more than one million are assigned the selected style.

CONTINENT=“Europe” AND POPULATION>1000000 OR CONTINENT=“Asia” AND POPULATION>10000000
Result: countries in Europe with populations more than one million and countries in Asia with populations more than ten 
million are assigned the selected style.
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Grid and Scalebar Operations 
EDITING CUSTOM ART

Manually editing type (position, font, colour, etc) is not possible on Grids and Scale Bars in their default grouped 
state. Manual editing is possible but objects must be first expanded (choose Object > Expand). Note that this will 
negate any opportunity to subsequently edit the art using MAPublisher editing tools. 

If you require a different design to be used for your Grid or Scale Bar, or wish to change any parameter without 
generating a new version, simply select the Grid or Scale Bar and choose Object > Edit Grid or Scale Bar. This will 
re-open the Grids and Graticules or Scale Bar dialog box with the current parameters of the object for subsequent 
editing. Editing the style of text (text colour, font, alignment, etc) used in the Grid or Scale Bar can be achieved by 
modifying the properties of the style in the Character Styles panel.

Use the bounding box of the generated grid or scale bar (choose View > Show Bounding Box) to resize. Resizing scale 
bars horizontally will add or remove intervals from the bar(s). Resizing scale bars vertically will adjust the width of 
the bar(s). Resizing grids horizontally or vertically will add or remove component cells in the grid.

EXPORTING GRIDS

To export a grid you must first expand the object (choose Object > Expand), then move it to an Area layer. 
Alternatively expand your grid, move the legend layer to the [Non-MAP layers] category, then move it back into the 
MAP View specifying the feature type as Area.

MISSING DATA IN GRIDS ON PROJECTED MAP VIEWS

Certain projections may cause incomplete grids and graticules to be drawn. Such issues may occur if the MAP View 
is in a polar projection or the extents of the data cross the 180 degree west/east meridian.

If the generation of a grid/graticule causes blank or incomplete results, the following workflow should be used:
1.	 Reproject the MAP View to a standard Lat/Long projection (e.g. NAD27 Lat/Long, Degrees). 
2.	 Generate your grid or graticules on this MAP View.
3.	 Expand the object (choose Object > Expand).
4.	 Create a new Area layer in the MAP View. Drag the expanded grid to this new layer.
5.	 Reproject the MAP View back to the original projection. 
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Copy and Paste 
The MAP Copy/Paste function was removed in MAPublisher version 7. You can now achieve the same functionality 
via Adobe Illustrator native Copy/Paste tools.

1.	 Use Edit > Copy or Edit > Cut to copy art. 
2.	 Deselect the art.
3.	 Select the destination layer in the Layers panel 
4.	 Use Edit > Paste in Front or Edit > Paste in Back to paste the art into the new layer at its previous location. 

•	 When pasting to layers which already contain an attribute structure, the destination layer must have an attribute 
schema which matches the source layer (only attributes in common will be transferred). 

•	 When pasting to layers which contain no attribute structure, the destination layer will be assigned the same 
attribute schema as the source layer. 

•	 The destination layer can be contained in any MAP View as required. 
•	 The destination layer must be of a matching feature type as the source layer. 
•	 Pasted data will always maintain its attributes. If you paste into a non-map layer, drag this layer into a MAP View, 

then recreate the schema, attributes will be populated appropriately. 

Legacy Text Conversion 
Opening legacy files, you may be prompted to update text (legacy text conversion).
Only text objects that are associated to attributes are required to be updated. For other text with no attributes, you 
do not necessarily need to update.

All text art - Choose this option to convert all text 
to the Adobe Illustrator current version.

MAPublisher text art only - Choose this option to 
convert only the MAPublisher text (on MAP 

layers)

Nothing - Choose this option if no conversion is 
necessary
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Appendix 4: Helpful Styles and Symbols Files
The following files may be found in the Helpful Styles & Symbols files folder on your MAPublisher 8 DVD or with 
your MAPublisher 8 download.

Windows XP: C:\Documents and Settings\All Users\Documents\Avenza\MAPublisher 8\Helpful Styles & Symbols
Windows Vista/7: C:\Users\Public\Public Documents\Avenza\MAPublisher 8\Helpful Styles & Symbols
Mac OS X: Applications/Avenza/MAPublisher 8/Helpful Styles & Symbols

Helpful Styles & Symbols > QuickMap Styles
QuickMap styles are graphic styles and symbol libraries meant to allow users to quickly style their maps by the use 
of MAP Stylesheets. To ease the process, areas are classified in land and water styles, lines are classified in borders, 
contours, roads, rails and rivers styles.

QuickMap Styles - Area.ai	 Categorized graphic style library , for use in Area Stylesheets.

QuickMap Styles - Line.ai	 Categorized graphic style library, for use in Line Stylesheets.

QuickMap Styles - Point.ai	 Symbol library with common map symbols, for use in Point Stylesheets.

Helpful Styles & Symbols > S-57 Symbolization
The S-57 Symbolization folder contains nautical graphic styles and symbols libraries inspired from the International 
Hydrographic Office M-4 publication (Regulations of the IHO for international (INT) charts and charts specifications 
of the IHO). Graphic styles and symbol names are mostly based on the S-57 naming conventions. The folder also 
contains templates with a series of MAPublisher Stylesheets linking S-57 imported features to appropriate nautical 
symbols and graphic styles. The basic template allow users to quickly apply styles to the imported data. The 
advanced template is more detailed to help users learn the format and make use of the data.

Nautical_Graphic_Styles.ai	 Graphic style libraries for use with S-57 data.

Nautical_Symbols.ai	 Symbols library for use with S-57 data (main symbols).

S57_Advanced_Template.ait	 Adobe Illustrator template with detailed MAP Stylesheets for use with S-57 data.

S57_Basic_Template.ait	 Adobe Illustrator template with simplified MAP Stylesheets for use with S-57data.

US5FL12M	 Sample ENC file in S-57 format (chart of Tampa Bay, courtesy of NOAA®).

Use of the S-57 templates:
•	 To create a new document, choose File > New from Template. Select S-57_Advanced_Template.ait.
•	 Import a S-57 file (for example, use the sample file).
•	 In the MAP Stylesheets panel, move the layers from [No MAP Stylesheet] to its corresponding stylesheet, 

when available: 
JJ Advance template: the corresponding stylesheet has the same name as the layer, but not all 

layers have a stylesheet (therefore stay under [No MAP Stylesheet]).
JJ Basic template: all layers have a stylesheet, with the same name as the layer or, if not, the 

name "others". The letters A, L and P have be added to the names to sort the stylesheets per 
feature type (Area, Line or Point).
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NOTE:	 This representation is non-exhaustive and meant to assist users with limited knowledge of the S-57 format 
to interpret the data contents more easily. The created map must not be used for navigation, unless further 
processing is supervised by a trained hydrographer.

Helpful Styles & Symbols > Graphic Styles
This folder contains five graphic style libraries with various useful styles for areas and lines.

MAP_AreaStyles.ai	 A custom library of styles, for use in Area Stylesheets.	

MAP_LineStyles.ai	 A custom library of style, for use in Line Stylesheets.

DGN_LineStyles.ai	 A library of MicroStation DGN line styles 1-7, for use in Line Stylesheets.

MIF_AreaStyles.ai		 A library of MapInfo MIF/MID area styles 1-71, for use in Area Stylesheets.

MIF_LineStyles.ai		 A library of MapInfo MIF/MID line styles 1-77, for use in Line Stylesheets.

Helpful Styles & Symbols > Symbols
This folder contains eight symbols libraries, categorized per topics.

Aeronautical symbols.ai	 A library of aeronautical point symbols.

Bank Symbols.ai		  A library of symbols for major world banks, for use in Point Stylesheets.

MAP Symbols.ai		  A library of useful map symbols.

NorthArrows.ai		  A library of north arrow symbols, for use in the Create North Arrow filter.

Parks Symbols.ai		  A library of symbols composed from the US National Parks Service font library.

Subway Symbols.ai	 A library of symbols from the major subway lines in the world.

Transit Symbols.ai	 A library of symbols for the major transit systems of the world.

Weather Symbols.ai	 A library of weather-related point symbols.
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