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Welcome

Avenza welcomes you to mapmaking in the 21st century!

Combined with Adobe Illustrator, MAPublisher has revolutionized the art of mapmaking by allowing spatial data 
files to be used to create maps inside a vector graphics program. MAPublisher allows all your cartographic tasks to 
be performed where they should be done; in a powerful graphics environment.

MAPublisher 8 improves on the already powerful tools of previous versions by adding additional file support, 
additional tools, and improvements to existing tools.

This tutorial guide assumes that the user is familiar with Adobe Illustrator CS2, CS3, or CS4, and has at least a basic 
understanding of geographic information systems (GIS) terminology and concepts. The tutorials in this guide 
should be used in conjunction with the MAPublisher 8 User Guide.

By following these tutorials you will learn how to create maps using the MAPublisher filters in Adobe Illustrator. This 
guide covers the steps necessary to build a map and perform fundamental cartographic and GIS tasks. Together, 
MAPublisher and Adobe Illustrator will give you a totally integrated cartographic design software system with 
graphics tools and geographic functions present in the same work environment.

TUTORIAL DATA

All the tutorials in this guide will use GIS data supplied on your MAPublisher 8 CD or in the electronic download. 
Alternatively, if you have installed the software, you can find the Tutorial data in the following location on your 
hard drive:

Windows XP
C:\Documents and Settings\All Users\Shared Documents\Avenza\MAPublisher 8\Tutorial Guide & Data\Tutorial Data

Windows Vista
C:\Users\Public\Documents\Avenza\MAPublisher 8\Tutorial Guide & Data\Tutorial Data

NOTE:.This data may be accessed through shortcuts available through the Windows start menu 

Mac OS X
/Applications/Avenza/MAPublisher 8/MAPublisher Tutorials/Tutorial Guide/Tutorial Data

Helpful styles and symbols can be found in: 

Windows XP
C:\Documents and Settings\All Users\Documents\Avenza\MAPublisher 8\Helpful Styles & Symbols

Windows Vista 
C:\Users\Public\Documents\Avenza\MAPublisher 8\Helpful Styles & Symbols

Mac OS X
/Applications/Avenza/MAPublisher 8/Helpful Styles & Symbols
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1  Importing Map Data
See User Guide, Chapter 3. 

1.1	 Importing a Single Map File

Create a new Adobe Illustrator document in landscape orientation.1.	
In the Adobe Illustrator menu, click 2.	 File > Import Map Data > Simple... to open the MAPublisher Simple Import 
dialog box or click the Simple Import button on the MAPublisher toolbar.
Select 3.	 MapInfo MIF/MID from the Format drop-down list.
Click 4.	 Browse, navigate to the Tutorial Data folder, select world.mif, and click Open.

The Source Coordinate System is automatically read as WGS 84 because MAPublisher has the ability to interpret 
this information if it is contained in the data.

Make sure that the dialog box matches the one above and click 5.	 OK.

The data is imported and automatically fitted to the width of the artboard. Notice that in the Adobe Illustrator 
Layers panel there is a new layer called world_area. In the MAP Views panel there is a new MAP View holding the 
imported file called world. See chapter 4 for more on MAP Views in the User Guide.

Close the document without saving.6.	
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1.2	 Importing Multiple Map Files at Once

The Simple Import filter also allows for the import of multiple map files at a single time. When importing multiple 
files, all files must be of the same format, be in the same coordinate system, and be located in the same directory.

Create a new Adobe Illustrator document in portrait orientation.1.	
In the Adobe Illustrator menu, click 2.	 File > Import Map Data > Simple... to open the MAPublisher Simple Import 
dialog box or click the Simple Import button on the MAPublisher toolbar.
Select 3.	 MapInfo MIF/MID from the Format drop-down list (it should already be selected by default).
Click 4.	 Browse, navigate to the Tutorial Data folder, select fsatoronto.mif and torontostreets.mif (hold the Command key 
(Mac) or the Ctrl key (Windows) to select multiple files), and click Open.

Make sure that the dialog box matches the one above and click 5.	 OK.

In the Adobe Illustrator Layers panel, there are new layers called torontostreets_line and fsatoronto_area. Also in 
the MAP Views panel there is a new MAP View called fsatoronto holding the two imported files.

Close the document without saving.6.	
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1.3	 Importing Map Files to Match an Existing Map Layer

Create a new Adobe Illustrator document in landscape orientation.1.	
In the Adobe Illustrator menu, click 2.	 File > Import Map Data > Simple… to open the MAPublisher Simple Import 
dialog box or click the Simple Import button on the MAPublisher toolbar.
Select 3.	 MapInfo MIF/MID from the Format drop-down list.
Click 4.	 Browse, navigate to the Tutorial Data folder, select worldwest.mif, and click Open.

The selected file appears in the Dataset file list in the MAPublisher Simple Import dialog box. Notice that the 
Source Coordinate System is automatically read as Robinson.

Click 5.	 OK.

In the Adobe Illustrator Layers panel there are new layer called worldwest_area. Also in the MAP Views panel 
there is a new MAP View called worldwest set in the Robinson coordinate system.

Repeat steps 2 to 4, however set the import 6.	 Format drop-down list to ESRI Shape.
Navigate to the 7.	 Tutorial Data folder, select worldeast.shp, and click Open.

In the Simple Import dialog box, the Source Coordinate System of worldeast.shp is automatically read as Robinson.

Click 8.	 OK.
In the 9.	 Matching MAP View Found dialog box, accept the default Add to: worldwest option in the Destination MAP View 
frame. Then check Resize MAP View to fit.

The worldeast layer is imported to match the previous import, worldwest. Notice that the worldwest_area layer 
is rescaled so that it both layers fit inside the page extents. In the Adobe Illustrator Layers panel there is now 
an additional layer called worldeast_area. In the MAP Views panel, the MAP View worldwest now contains both 
layers.
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Close the document without saving.10.	

1.4	 Importing Map Files with Point Per Path Limitations 

Create a new Adobe Illustrator document in portrait orientation.1.	
In the Adobe Illustrator menu, click 2.	 File > Import Map Data > Simple... to open the MAPublisher Simple Import 
dialog box or click the Simple Import button on the MAPublisher toolbar.
Select 3.	 MapInfo MIF/MID from the Format drop-down list.
Click 4.	 Browse, navigate to the Tutorial Data folder, select greenland.mif, click Open, and click OK.

The vertex count exceeds the allowable 32,000 points per path in Adobe Illustrator, a warning dialog box 
appears stating that the data was simplified in order to facilitate a successful import process.

Click 5.	 OK to close the warning dialog box.

MAPublisher has calculated the amount of vertices in the file and removed just enough points in order to 
maintain the highest level of detail possible.

Close the document without saving.6.	
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1.5	 Importing GIS File Types that Require Optional Settings

There are a number of other file formats in the Tutorial Data folder to experiment with. MAPublisher can handle 
supported file formats in various ways. Some types of data import differently and require additional user input. 
There is an overview of the file formats supported by MAPublisher in the User Guide.

Create a new Adobe Illustrator document in portrait mode.1.	
Open the MAPublisher2.	  Simple Import dialog box.
Select 3.	 ESRI Interchange File (E00) from the Format drop-down list.
Click 4.	 Browse, navigate to the Tutorial Data folder, select capeverde.e00, and click Open.
In the 5.	 Simple Import dialog box, click the Settings button.
Make sure 6.	 Ignore TIC layer is unchecked, and click OK.
Click 7.	 OK to close the Simple Import dialog box.

NOTE:. As e00 files are generally an archive of several files, MAPublisher will reproduce an e00 import as distinct 
Adobe Illustrator layers. Notice that MAPublisher generated point, area, line, and text layers. An extra layer 
appended with _tic_point is created to hold tic points, as was specified in the Settings dialog box.

Close the document without saving.8.	

1.6	 Importing Points

MAPublisher import filters also allow the import of delimited ASCII text files as point data provided they contain 
coordinate values. A typical file of this nature might be set up as follows:

“AZ,Antonio Tank,reservoir,Santa Cruz,4,23,312004N,1103943W,31.33444,-110.66194,,,,,,,Duquesne"
“AZ,Agua Prieta Substation,locale,Cochise,4,3,312006N,1093335W,31.335,-109.55972,,,,,,,Douglas"
“AZ,Adobe Spring,spring,Santa Cruz,4,23,312037N,1110234W,31.34361,-111.04278,,,,,,,Pajarito Peak"

The MAPublisher Import Points filter supports the import of delimited ASCII files that contain any of the following 
delimiters between data values: comma, return, end of line and tab in multiple formats.
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Create a new Adobe Illustrator document in portrait orientation.1.	
Open the MAPublisher2.	  Simple Import dialog box.
Select 3.	 Delimited XY Text Data (CSV, TSV, TXT) from the Format drop-down list.
Click 4.	 Browse, navigate to the Tutorial Data folder, and select azdeci.txt.

The Settings dialog box opens automatically. Specify the appropriate coordinate format of their data in the 
Format drop-down list before selecting the columns of the import file to be used.

Use 5.	 Decimals Degrees (D+[.d*]).
Use 6.	 Column #10: -110.66194 for the Longitude coordinates and Column #9: 31.33444 for the Latitude coordinates.
Leave 7.	 Use first line as a header unchecked. The first line of this file does not contain column headings.

Make sure that the dialog box matches the one above and click 8.	 OK to close it.
Since the file contains coordinates in decimal degrees, click 9.	 Specify..., select the WGS 84 coordinate system from 
Geodetic > World, and click OK.
In the 10.	 Simple Import dialog box, click OK to start the file import.

The points are placed on the page as specified. All other columns that were in the file are imported as attribute 
data for the placed points.

Close the document without saving.11.	
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1.7	 Importing Multiple File Types

Create a new Adobe Illustrator document in landscape orientation.1.	
In the Adobe Illustrator menu, click 2.	 File > Import Map Data > Advanced… to open the MAPublisher Advanced 
Import dialog box or click the Advanced Import button on the MAPublisher toolbar.
Click 3.	 Add to open the Add dialog box.
Select 4.	 MapInfo TAB from the Format drop-down list.
Click 5.	 Browse, navigate to the Tutorial Data folder, select usa.tab, and click Open. A coordinate system is detected.
Click 6.	 OK to close the Add dialog box.

The selected file appears in Row 1 of the file list inside the dialog box. Now add another file in a different map 
file format.

Click 7.	 Add to open the Add dialog box.
Select 8.	 ESRI Shape from the Format drop-down list.
Click 9.	 Browse, navigate to the Tutorial Data folder, select canada.shp, and click Open.
Click 10.	 OK to close the Add dialog box.

The selected file appears in Row 2 of the file list inside the dialog box.

In the 11.	 Destination MAP View frame, usa is already selected in the New Based On drop-down list. This bases the page 
scaling on the usa.tab file.
Check the 12.	 Auto scale option. This ensures all selected files are fitted inside the page extents.

NOTE:. Not checking the Auto scale option will base the page scaling on the file selected in the New based on 
drop-down list only. Therefore only this file is fitted to the current page extents, which may cause elements 
in other selected files to be placed outside of the page boundary.

Make sure that the dialog box matches the one above and click13.	  OK to import the two files.
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Notice that in the Adobe Illustrator Layers panel there are new layers called usa_area and canada_area. Also in the 
MAP Views panel there is a new MAP View called usa containing the imported files.

Close the document without saving.14.	

1.8	 Importing MAP Files in Multiple Coordinate Systems

Create a new Adobe Illustrator document in landscape orientation.1.	
Open the MAPublisher 2.	 Advanced Import dialog box and click Add.
Select 3.	 MapInfo TAB from the Format drop-down list.
Click 4.	 Browse, navigate to the Tutorial Data folder, select usa.tab, and click Open.
Click 5.	 OK to close the Add dialog box.

The selected file appears in Row 1 of the file list. The coordinate system of usa.tab is automatically read as 
NAD27. The coordinate system preview area lists various parameters of the file including coordinate system, 
page and map anchors, visual scale, and map angle.

Click the 6.	 Add button to open the Add dialog box.
Select 7.	 ESRI Shape from the Format drop-down list.
Click 8.	 Browse, navigate to the Tutorial Data folder, select worldwest.shp, and click Open.
Click 9.	 OK to close the Add dialog box.

The selected file appears in Row 2 of the file list. The map file worldwest.shp is automatically read as Robinson.

In the 10.	 Destination MAP View frame, select the New Based On option and choose worldwest from the drop-down list. 
This bases the coordinate system and page scaling on the worldwest.shp file.
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Make sure that the dialog box matches the one above and click11.	  OK to import the two files into the Robinson 
coordinate system.

The map files are automatically sized to fit the page. Note that the Auto scale option was not required to 
be checked in the Advanced Import dialog box, as the page scaling was based on the worldwest.shp which 
contained larger geographic extents than the usa.tab in all four compass directions.

In the Adobe Illustrator Layers panel, new layers called usa_area and worldwest_area are added. Also, in the MAP 
Views panel there is a new MAP View containing the imported files (the MAP View has the same name as the file 
selected for the MAP View destination).
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1.9	 Importing Map Files to Match an Existing MAP View

This tutorial will produce the same results as Tutorial 1.8.

Create a new Adobe Illustrator document in portrait orientation.1.	
Open the MAPublisher 2.	 Simple Import dialog box.
Select 3.	 ESRI Shape from the Format drop-down list.
Click 4.	 Browse, navigate to the Tutorial Data folder, select worldwest.shp, and click Open.
Click 5.	 OK to close the Simple Import dialog box.

In the Adobe Illustrator Layers panel there is a new layer called worldwest_area. Also in the MAP Views panel 
there is a new MAP View called worldwest set in the Robinson coordinate system.

Open the MAPublisher 6.	 Advanced Import dialog box and click Add.
Select 7.	 MapInfo TAB from the Format drop-down list.  
Click 8.	 Browse, navigate to the Tutorial Data folder, select usa.tab, and click Open.

The selected file appears in Row 1 of the file list. The map file usa.tab is automatically read as NAD27.

In the 9.	 Destination MAP View frame, select the Use existing option and choose worldwest from the drop-down list. 

View the coordinate system of this map file in the coordinate system preview area.

Make sure that the dialog box matches the one above and click 10.	 OK to import the file based on the Robinson 
parameters of the worldwest_area layer.

The file is imported and reprojected to automatically align with the worldwest layer. This functionality allows a 
user to easily register multiple files in differing coordinate systems.

In the Adobe Illustrator Layers panel there are new layers called usa_area and worldwest_area. Also in the 
MAP Views panel there is a new MAP View called worldwest containing the imported files set in the Robinson 
coordinate system

Close the document without saving.11.	
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1.10	 Assigning a Source Coordinate System Prior to Import

Create a new Adobe Illustrator document in portrait orientation.1.	
Open the MAPublisher 2.	 Advanced Import dialog box and click Add.
Select 3.	 ESRI ArcInfo Generate from the Format drop-down list.
Click 4.	 Browse, navigate to the Tutorial Data folder, select ukrail.gen, and click Open.
Click 5.	 OK to close the Add dialog box.

The selected file appears in Row 1 of the file list.

In the 6.	 Advanced Import dialog box, select Row 1 (ukrail.gen) and click Edit...
In the 7.	 Edit dialog box, click Specify... and choose British National Grid located under Projected > Europe > United Kingdom.
Click 8.	 OK to return to the Advanced Import dialog box.

In the Destination MAP View frame, view the coordinate system information in the area to the right.

Click 9.	 OK to import the file in the British National Grid coordinate system.
Close the document without saving.10.	

1.11	 Transforming the Coordinate System on Import

Read about the MAP View Editor in chapter 4 of the User Guide before completing the following tutorial.

Create a new Adobe Illustrator document in portrait orientation.1.	
Open the MAPublisher 2.	 Advanced Import dialog box and click Add.
Select 3.	 ESRI Shape from the Format drop-down list.
Click 4.	 Browse, navigate to the Tutorial Data folder, select ukpoly.shp,and click Open.
Click 5.	 OK to return to the Advanced Import dialog box.

The selected file appears in Row 1 of the file list. The coordinate system of ukpoly.shp is currently WGS 84.

In the 6.	 Destination MAP View frame, select the Create New option, and click the Editor... button to open the Map View 
Editor dialog box.
Click 7.	 Specify..., navigate to the *Recent* category list under Coordinate Systems > Projected to display all recently used 
projections, and choose British National Grid. Alternatively, navigate to Projected > Europe > United Kingdom.
Click 8.	 OK to close the Specify Source Coordinate System dialog box.
Click 9.	 OK to close the MAP View Editor and return to the Advanced Import dialog box.

In the Destination MAP View frame, view the coordinate system information in the area to the right.

Click 10.	 OK to import the file in the British National Grid coordinate system.
Close the document without saving.11.	
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2.1	 The Creation of Map Views via Import

Create a new Adobe Illustrator document in portrait orientation.1.	
In the Adobe Illustrator menu, click 2.	 Window > MAPublisher > MAP Views to open the MAP Views panel or click the 
MAP Views button on the MAPublisher toolbar.
Import any map file from the 3.	 Tutorial Data folder.

Notice that a MAP View is automatically created. It is the same name of the imported file and contains the 
Adobe Illustrator layer(s) containing map data. Each Adobe Illustrator layer comprising the MAP View is depicted 
with an icon that represents the feature type contained on each of the map layers.

Close the document without saving.4.	

2.2	 Importing a MAP View from Existing MAPublisher Documents

Open 1.	 usa48.ai from the Tutorial Data folder.
Create a new Adobe Illustrator document.2.	
Select the new document and open the3.	  MAP Views panel.
In the 4.	 MAP Views panel option menu (top right corner of the panel), click Import MAP View from Document...

A list of MAP Views is available from any opened document containing MAP Views. In this case, only one MAP 
View called usa is available from the selected MAP Views to transfer.

Select the 5.	 usa MAP View and click OK.

The MAP View is imported into the new document along with all the MAP Layers within that MAP View.

2  MAP Views and Georeferencing
See User Guide, Chapter 4
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2.3	 Duplicating and Deleting MAP Views

Create a new Adobe Illustrator document in portrait orientation.1.	
Import any map file from the 2.	 Tutorial Data folder.
In the 3.	 MAP Views panel, select the new MAP View (of the same name as the imported map file).
In the 4.	 MAP Views panel option menu, click Duplicate.

A new MAP View entitled Copy of [MAP view name] is created. It doesn't contain any Adobe Illustrator layers.

Select the MAP View created in step 3.5.	
In the 6.	 MAP Views panel option menu, click Delete.

NOTE:.A MAP View that contains one or more map layers cannot be deleted. Move or delete all layers from a MAP 
View first before deleting the MAP View itself.

Close the document without saving.7.	

2.4	 Transforming Coordinate Systems by Dragging and Dropping

Create a new Adobe Illustrator document in landscape orientation.1.	
Use 2.	 Simple Import to import world.mif from the Tutorial Data folder.
Use 3.	 Simple Import to import worldwest.shp from the Tutorial Data folder.

There are now two MAP Views: one called world, in the WGS 84 coordinate system and contains the world_area 
layer; and the second called worldwest, in the Robinson coordinate system and contains the worldwest_area layer.

In the 4.	 MAP Views panel click on the worldwest_area layer and drag it into the world MAP View.

The worldwest_area layer is instantly transformed into the WGS 84 coordinate system and matches the page 
scaling of the world_area layer. Drag worldwest_area back to the worldwest MAP View and it will transform the 
layer back to the Robinson coordinate system.
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Close the document without saving.5.	

2.5	 Dragging Layers into Existing Coordinate Systems

Repeat Tutorial 2.4, steps 1 to 3.1.	
Use the 2.	 Toggle Visibility button in the Adobe Illustrator Layers panel to hide the world_area layer.
In the Adobe Illustrator Layers panel, create a new layer called 3.	 Extras, and move it to the top of the layers hierarchy.
With the 4.	 Extras layer selected, roughly trace over some features that exist on the worldwest_area layer using 
Adobe Illustrator drawing tools and give it a red coloured fill.

NOTE:.The new features are polygons. Make sure that the elements are closed so that the start and end points of 
the lines are coincident.

In the 5.	 MAP Views panel, click the Extras layer and drag it into the worldwest MAP View.
In the 6.	 Undefined Layer dialog box, select Area from the Feature Type drop-down list, and click OK.

The Extras layer is now stored in the same coordinate system as the worldwest MAP View.

Keep the document open for the next tutorial.7.	
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2.6	 Dragging New Layers into Different Coordinate Systems

Continue from Tutorial 2.5
In the Adobe Illustrator layers panel, use the 1.	 Toggle Visibility buttons to hide the worldwest_area layer, and to make 
the world_area layer visible. The Extras layer is already visible.
In the2.	  MAP Views panel click the Extras layer and drag it into the world MAP View.

The Extras layer is moved to the coordinate system of the world MAP View. It has immediately been transformed 
from Robinson to WGS 84 (latitude and longitude) and aligns with the data in the world_area layer.

Close the document without saving.3.	

2.7	 Editing Layer Names Using Search and Replace

Create a new Adobe Illustrator document in portrait orientation.1.	
Import 2.	 capeverde.e00 from the Tutorial Data folder. Uncheck the Ignore TIC layer option in the import settings.

In the both the Adobe Illustrator Layers panel and MAP Views panel, five new layers are shown. An ESRI 
Interchange file (e00) contains multiple feature types. All five of these layers contain the layer name prefix 
capeverde.

In the 3.	 MAP Views panel option menu, click Layer Name Search & Replace…
In the 4.	 Find what: box, type capeverde. In the Replace with: box, type Cape Verde.
Click the 5.	 Replace All button.

The text capeverde is replaced with Cape Verde in the name of all applicable layers.

Close the document without saving.6.	
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2.8	 Merging Map Layers

Create a new Adobe Illustrator document in landscape orientation.1.	
Use 2.	 Simple Import to import worldeast.shp and worldwest.shp from the Tutorial Data folder.
Ensure all of the data in the document is still selected and open the 3.	 MAP Attributes panel (click Window > 
MAPublisher > MAP Attributes).

Toggle between the layers using the Layer drop-down list. Both layers have an identical attribute structure so it is 
possible to merge the layers together.

For more information on the MAP Attributes panel, see Tutorial 3 or chapter 5 of the MAPublisher User Guide.

In the 4.	 MAP Views panel, shift-select the worldeast_area and worldwest_area layers so both are highlighted.
In the 5.	 MAP Views panel option menu, click Merge Layers

The two layers have been joined together to create a single layer holding all the map data and attribute 
information. Rename the merged layer in the Adobe Illustrator Layers panel if desired and view the combined 
attribute table in the MAP Attributes panel.

NOTE: Locked layers can not be merged.

Close the document without saving.6.	

2.9	 Specifying a Source Coordinate System After Import

Create a new Adobe Illustrator document in portrait orientation1.	
Use 2.	 Simple Import to import ukrail.gen from the Tutorial Data folder. Do not specify a coordinate system.
In the 3.	 MAP Views panel, double-click the ukrail MAP View to open the MAP View editor. Close the warning dialog box.
In the MAP View editor dialog box, click 4.	 Specify... to open the  Specify Source Coordinate system dialog box.
Select 5.	 British National Grid located under Projected > Europe > United Kingdom.
Click 6.	 OK to close the MAP View editor dialog box.

The source coordinate system for the file is now British National Grid. The MAP View is assigned a coordinate 
system and can now be transformed.

Close the document without saving.7.	

2.10	 Transforming the Coordinate System Using the MAP View Editor

Create a new Adobe Illustrator document in portrait orientation.1.	
Import 2.	 fsatoronto.mif from the Tutorial Data folder. The map file is in the WGS 84 coordinate system.
In the 3.	 MAP Views panel, double-click the fsatoronto MAP View to open the MAP View editor
Change the name of the MAP View to4.	  Postalcode Zones.
Check the 5.	 Perform Coordinate System Transformation check box to enable its frame options and click Specify... 
In the 6.	 Specify Destination Corodinate System dialog box, select NAD83 / UTM zone 17N located under Projected > UTM > NAD83. 
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The Preview Pane displays how the new coordinate system are fitted onto the page.

Click 7.	 OK to close the MAP Views editor dialog box.

The MAP View is transformed to NAD83 / UTM zone 17N. See Appendix A2 on Projections and Datums in the User 
Guide for more information.  

Leave the file open for the next tutorial.8.	

			   		
			   fsatoronto MAP View in WGS 84.			   fsatoronto MAP View in UTM Projection.

2.11	 Editing Scale and Positioning

Continue from Tutorial 2.10.
In the 1.	 MAP Views panel, double-click the Postalcode Zones MAP View to open the MAP View editor.
Change the map scale to 2.	 1: 30,000 by typing 30000 in the Scale text box.
There are nine buttons in the3.	  Alignment Control graphic (Data Extents LL Corner frame). Click the Align Center button 
(the button in the middle) to reposition the data to the centre of the page.

The Preview Pane shows the new data extents and the Page Anchor values have been automatically updated.

Click 4.	 OK.

The Postalcode Zones MAP View is rescaled and repositioned in the centre of the page.

In the 5.	 MAP Views panel, double-click the Postalcode Zones MAP View.
In the 6.	 Angle text box, type -17 for an angle of rotation. Alternatively use the clock hand in the graphic to achieve 
the rotation value of 343 degrees.
Click 7.	 OK.



24 MAPublisher 8 Tutorial 
2  MAP Views and Georeferencing

The data is now rotated and gives a better result for subsequent MAPublisher operations,  such as labeling. 
Georeferencing has not been affected.

fsatoronto MAP View in UTM Projection, rotated -17 degrees, and with a new scale of 1:30,000.

Close the document without saving.8.	

2.12	 Copying a Coordinate System from One Layer to Another

Create a new Adobe Illustrator document in landscape orientation.1.	
Import 2.	 worldwest.shp from the Tutorial Data folder. The map file is in the Robinson coordinate system.
Select the Canada polygon shape and assign a fill colour to it.3.	
In the 4.	 MAP Views panel, double-click the worldwest MAP View to open the MAP View Editor.
Change the map scale to 1: 250 million by typing 5.	 250000000 in the Scale text box.
Click the 6.	 Align Top Left button in the Alignment Control graphic (Data Extents LL Corner frame).

The Preview Pane shows the new data extents and the Page Anchor values have been automatically updated.

Click 7.	 OK.

The worldwest MAP View is rescaled and repositioned in the upper left corner of the page. This can be used as a 
small locator map.

Import 8.	 canada.shp from the Tutorial Data folder. The map file is in the NAD27 coordinate system.
In the 9.	 MAP Views panel, double-click the canada MAP View to open the MAP View Editor.
Check the 10.	 Perform Coordinate System Transformation check box to enable its frame options.
Check the 11.	 Same As check box and select the worldwest MAP View in the drop-down list.

Notice how the destination is automatically set to Robinson.
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Click the 12.	 Align Center button in the Alignment Control graphic (Data Extents LL Corner frame).

The Preview Pane shows the new data extents and the Data Extents LL Corner values are automatically edited.

Click 13.	 OK.

The MAP View is transformed to match the coordinate system of the worldwest MAP View.  

Close the document without saving.14.	

2.12	 Creating a New MAP View

This tutorial will provide a basic overview of assigning georeferencing information to existing Adobe Illustrator 
documents. Please see Georeferencing an Adobe Illustrator File in the MAPublisher 8 User Guide for more information.

In Adobe Illustrator, open 1.	 toronto.ai from the Tutorial Data folder.

This is a regular Adobe Illustrator document digitized in WGS 84 (degrees). It contains two Adobe Illustrator 
layers that do not have any georeferencing or attribute information. They are located in the [Non-MAP layers] 
section of the MAP Views panel.

In the 2.	 MAP Views panel option menu, click New MAP View... or click the Create New MAP View button at the bottom of 
the MAP Views panel. If needed, close the warning dialog box.
Rename the MAP View to 3.	 Toronto.
Click 4.	 Specify... in the Source Coordinate System frame.
Set the coordinate system to 5.	 WGS 84 located under Geodetic > World and click OK to close the Specify Source Coordinate 
System dialog box.
The scale for this file is 1: 26175.038531(as the data is in degrees, the scale value is 6.	 approximated using the 
common formula 1°= 111.353 metres) so type 26175.038531 in the Scale text box.
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Make sure that the dialog box matches the one above and click 7.	 OK to apply the information to the new MAP View.
In the 8.	 MAP Views panel option menu, click Specify Anchors.

The Specify Anchors dialog box will establish the tie-in point between Map Anchors (real world coordinates) and 
Page Anchors (coordinates in page units).

Set the 9.	 Map Anchors to the value of a tie-in location. For this example use X = -79.411893 deg and Y = 43.611883 deg.
Set the 10.	 Page Anchors to the value of the same location in document units. For this example use X = 0, Y = 0.

NOTE:. The map/page anchor relationship can be established at any known tie-in point (preferably within the 
extents of the dataset being georeferenced).

Make sure that the dialog box matches the one above and click 11.	 OK to apply the changes.
In the 12.	 MAP Views panel click and drag the Postalcode Zones layer into the Toronto MAP View.
In the 13.	 Undefined Layer dialog box, select Area in the Feature Type drop-down list and click OK.

The Postalcode Zones layer is moved to the specified coordinate system of the Toronto MAP View.
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Click and drag the14.	  Roads layer into the Toronto MAP View.
In the 15.	 Undefined Layer dialog box, select Line in the Feature Type drop-down list and click OK.

Both Adobe Illustrator layers are now map layers, in the specified coordinate system of the Toronto MAP View.

Optional steps
In the Adobe Illustrator Layers panel, select all objects on the 16.	 Postalcode Zones layer (click on the target button 
beside the layer name).
In the 17.	 MAP Attributes panel, and click the Edit Schema button at the bottom of the panel.
Below the column list, click 18.	 Add to add a new column, rename it Zone, set the Type to String, set the Size to 3, and 
click OK.
Select the southernmost polygon of 19.	 Postalcode Zones and in the MAP Attributes panel, type M5J in the cell under the 
Zone column.

Proceed in this manner to create attribute structures and enter values for both Adobe Illustrator layers.

The map files are now fully georeferenced and be exported to other GIS formats if required. The addition of an 
attribute structure means that it can fully utilize all MAPublisher functions.

To validate the georeferencing process, import 20.	 fsatoronto.mif from the Tutorial Data folder and add it to the 
Toronto MAP View to see how it registers with the newly created MAP layers.
Close the document without saving.21.	

2.14	 Exporting Data to GIS Formats

Create a new Adobe Illustrator document.1.	
Use 2.	 Simple Import to import fsatoronto.mif and torontostreets.mif.
In the 3.	 MAP Views panel, select the fsatoronto_area layer and in the MAP Views panel option menu, click Export 
“fsatoronto_area"...
In the 4.	 Export dialog box, select ESRI Shape from the Format drop-down list, click Browse, navigate to a location to 
save the shapefile, and click OK. The Dataset box is populated with the directory path.
Click 5.	 OK to export.  

The fsatoronto layer is exported as an ESRI shapefile with all attributes and georeferencing intact. It is ready to 
be used in software supporting this format.

View the contents of the destination folder. Four new files have been created: fsatoronto.shp, fsatoronto.shx, 
fsatoronto.dbf, and fsatoronto.prj. Descriptions of these file extensions can be found in chapter 2 of the 
MAPublisher 8 User Guide. 

In the Adobe Illustrator Layers panel, select all objects on the 6.	 torontostreets_line layer. 
Resize the7.	  MAP Attributes panel to see all the attribute column headings, and click the Edit Schema button.
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In the column list, select 8.	 #Length and check the Visible check box. Keep Street visible and select the other visible 
attribute columns (shown in the MAP Attributes panel) and uncheck the Visible check box for each one.

Only the #Length and Street attributes are visible.

In the9.	  MAP Views panel option menu, click Export “torontostreets_line"...
In the 10.	 Export dialog box, select MapInfo TAB from the Format drop-down list, click Settings, check the option for Export 
visible attributes only, and click OK.

This keeps only the visible attributes (#Length and Street columns in the attribute table).

Click 11.	 Browse and navigate to a location to save the export and click OK. The Dataset field is populated with the 
directory path.
Click 12.	 OK to export the layer.

View the contents of the destination folder. Four new files were created: torontostreets.tab, torontostreets.dat, 
torontostreets.id, and torontostreets.map. Descriptions of these file extensions can be found in chapter 2 of the 
User Guide.

The torontostreets_line layer is exported to MapInfo TAB format with the specified attributes and georeferencing 
intact. It is ready to be used in software supporting this format.

Close the document without saving.13.	
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2.15	 Determining the Coordinates of a Specific Location

Create a new Adobe Illustrator document.1.	
Import any map file from the 2.	 Tutorial Data folder.
In the Adobe Illustrator Tools panel, click the 3.	 MAPublisher Location Tool. 
In the 4.	 MAP Views panel, select the imported map layer.
Move the mouse cursor (it looks like a crosshair) to a location on the map to view its geographic coordinates.5.	

The MAP Location panel shows the WX and WY values and are constantly updated as the mouse cursor is moved 
around the map document. This tool also allows for the copying of coordinates.

With the 6.	 MAPublisher Location Tool, determine a location on the map to generate coordinates for. Hold down the 
Shift key and click this location.

NOTE: Holding the Shift key and clicking on a location copies the coordinates to the Clipboard.

Open a simple text editor and use the paste function to paste the coordinate values.7.	

NOTE:. The MAPublisher location tool panel continues to track the coordinates of the current cursor location 
regardless of which tool is currently selected in the Adobe Illustrator Tools panel.
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3.1	 Viewing, Editing and Zooming with MAP Attributes

Create a new Adobe Illustrator document.1.	
Import 2.	 world.mif from the Tutorial Data folder.
Select all of the objects on the 3.	 world_area layer if there are none already selected.
Open the 4.	 MAP Attributes panel (click Window > MAPublisher > MAP Attributes) or click the MAP Attributes button on 
the MAPublisher toolbar.
To edit attribute values, double-click inside a cell and type a new value.5.	

All attribute values and some property attributes can be edited. MAPublisher creates some attributes which 
have the hash symbol (#) as a prefix. These attributes are editable (but must be made visible first). However, 
#Area, #Perimeter, #VertexCount, and #Length are properties of the geometry and cannot be edited.

Keep in mind to enter values that correspond with a column's type (e.g. only enter numbers into a column of 
type Real or Integer). The edits are automatically maintained in the attribute table once entered.

The widths of the columns in the 6.	 MAP Attributes window may be changed by clicking on the column separator 
and dragging it left or right. Double-click a column separator to set the column width to the column attribute 
with the greatest amount of characters.
Attribute columns may also be sorted in an ascending manner by clicking on the column heading.7.	

New to MAPublisher 8 is the ability to zoom to a specific piece of art via the MAP Attributes panel. Select an 
attribute record and click on the Zoom to Feature icon  . MAPublisher zooms to the area of the file where the 
artwork is located and displays it within visible handles.

3  MAP Attributes
See User Guide, Chapter 5
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3.2	 Adding a New Column to a MAP Attribute Table

Continue working with the previous document.
If necessary, open the 1.	 MAP Attributes panel and select all objects on the world_area layer. The panel displays its 
attribute columns and values.
Click the 2.	 Edit Schema button at the bottom of the MAP Attributes panel. The Edit Schema dialog box displays the 
columns associated with the Map Attribute table on the currently selected layer.
Click 3.	 Add to add a new attribute column.
In the 4.	 Name text box, type Head_of_State.

NOTE:. Spaces are not accepted for column names. MAPublisher inserts an underscore ( _ ) when a space is typed 
into a column name.

In the 5.	 Type drop-down list, select String (this allows the column to contain alphanumeric values).
Set a width of 6.	 10 (this is the number of characters which can be displayed in each cell).

In certain instances, a default value for an attribute may be required. Setting a Default Value gives each record 
the same value. Do not enter a default value for this tutorial.

Click7.	  OK to close the dialog box.

The new column is created and can be given values in the MAP Attributes window.

Leave the document open for the next tutorial.8.	

3.3	 Changing an Existing Column's Properties

Continue with the previous document.
If necessary, open the 1.	 MAP Attributes panel and select all objects on the world_area layer.
Open the 2.	 Edit Schema dialog box and select Capital in the attribute column list.
Rename it to 3.	 Capital_City, change the size to 30, and change the Default Value to None. 

The column type may be changed after it is created (e.g. convert a type real column to a type integer column). 
For this tutorial, leave the type as String. Also, any new polygons added to the world_area layer will have a 
default value of None.
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Leave the 4.	 Visible check box enabled and the Read-only and Derive value from expression unchecked.
Click 5.	 OK. 

The column is now renamed and width increased to accommodate longer names.

Leave the document open for the next tutorial.6.	

3.4	 Creating a New Column Using Expressions

Continue working with the previous document.
If necessary, open the 7.	 MAP Attributes panel and select all objects on the world_area layer.
Open the 8.	 Edit Schema dialog box.
Click 9.	 Add to add a new attribute column called Annual_Increase and set the Type to Integer.
Check the 10.	 Derive value from expression check box.
Click the browse button (11.	 ...) to open the Edit Expression dialog box.
Expand the 12.	 Expression Components section at the bottom of the dialog box.

Build expressions by making selections from the Objects list in combination with using the operators available at 
the top of the dialog box.

Double-click the 13.	 Population column in the Objects list, click the * symbol button, the ( symbol button, double-
click Pop_Grw_Rt column, click the / symbol button, then type 100. Finally, click the ) symbol button to close the 
expression builder.
The final expression in the 14.	 Edit Expression box is: Population*(Pop_Grw_Rt/100).

The expression is valid statement means that the expression is correct and can be performed.

Click 15.	 OK to close the Edit Expression dialog box, and click OK again to close the Edit Schema dialog box.

The Annual_Increase attribute column is updated with values calculated from the expression.
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Close the document without saving.16.	

3.5	 Joining a Table

Create a new Adobe Illustrator document.1.	
Import 2.	 fsatoronto.mif from the Tutorial Data folder.
Open the 3.	 MAP Attributes panel and click Join Table from the panel option menu, or click the Join Table button at the 
bottom of the panel.
Click 4.	 Browse beside the Filename text box and select avginc.csv from the Tutorial Data folder.
Click the check box to enable 5.	 First line contains column names and select FSA from the Matching Column drop-down list.
Leave the default 6.	 Character encoding as System.
Since there is only one MAP Layer in the MAP View, the 7.	 Destination Target Layer will default to fsatoronto_area. The 
Matching Column drop-down lists attribute columns from the target layer to base the join on. In this case, the 
matching column is FSA.

Make sure that the dialog box matches the one above and click 8.	 OK.

The imported table is joined with the attribute table of fsatoronto.
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View the changes in the MAP Attributes panel. The additional match column is appended with a "1" after the 
name (in this case, FSA1). This helps to differentiate the joined column and the original FSA column. All columns 
following FSA1 contain the joined table records.

Close the document without saving.9.	
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4.1	 Plotting Points in Decimal Degree and Degrees-Minutes-Seconds Formats

Open 1.	 usa48.ai from the Tutorial Data folder.

This document contains the conterminous United States. The polygons are on the usa layer, in a MAP View 
named usa. The specified coordinate system is United States: Albers Equal Area, meter.

In the Adobe Illustrator Layers panel, create a new layer named 2.	 cities.
In the3.	  MAP Views panel, click and drag the cities layer into the usa MAP View.
In the 4.	 Undefined Layer dialog box, select Point from the Feature Type drop-down list.
Open the Adobe Illustrator Symbols panel5.	  (click Window > Symbols).
In the 6.	 Symbols panel option menu, click Open Symbol Library > Other Library... and load MAP Symbols.ai from the  
\Helpful Styles & Symbols\Symbols folder (see page ii).
Choose a selection of city symbols in the 7.	 Map Symbols panel, and drag them into the Adobe Illustrator Symbols panel.

      

In the Adobe Illustrator Layers panel, select the 8.	 cities layer.
Open the 9.	 MAP Point Plotter panel (click Window > MAPublisher > MAP Point Plotter) or click the MAP Point Plotter 
button on the MAPublisher toolbar. 
At the bottom of the panel, set the 10.	 Input Coordinate System to Use: WGS 84. 
Select 11.	 Decimal Degrees (D+[.d*]) from the Format drop-down list.
To plot a point for Los Angeles, type12.	  -118.4183 in the Long text box and type 34.1151 in the Lat text box.
Click the symbol text name to select a symbol style, leave the 13.	 Scale set to 100%, and click Plot.

4  Plotting Points
See User Guide, Chapter 6
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A point is plotted at the location of Los Angeles (34.1151 degrees north, 118.4183 degrees west).

Select 14.	 Delimited Degrees Minutes Seconds (D+dMM'SS[.s*]") from the Format drop-down list. 
To plot a point for New York City, type 15.	 73d56'39.0"W in the Long text box and 40d41'14.0"N in the Lat text box.
Click the symbol text name to select a symbol style, change the 16.	 Scale to 150%, and click Plot.

A point is plotted at the location of New York City (40 degrees, 41 minutes, 14 seconds north and 73 degrees, 56 
minutes, 39 seconds west).

Finally, plot a point for Chicago. Type 17.	 87d41'18"W in the Long text box and 41d50'21"N in the Lat text box. 
Alternatively, change the Format back to Decimal Degrees (D+[.d*]), and type -87.6883 in the Long text box and 41.8392 
in the Lat text box.

Close the document without saving.18.	

4.2	 Plotting Centroids

Open 1.	 usa48.ai from the Tutorial Data folder.
In the Adobe Illustrator Layers panel, create a new layer named 2.	 centroids.
In the3.	  MAP Views panel, click and drag the centroids layer into the usa MAP View.
In the 4.	 Undefined Layer dialog box, select Point from the Feature Type drop-down list.
Select all of the map data5.	  (Adobe Illustrator menu, click Select > All).
Open the 6.	 MAP Point Plotter panel (click Window > MAPublisher > MAP Point Plotter) or click the MAP Point Plotter 
button on the MAPublisher toolbar.
In the 7.	 MAP Point Plotter panel option menu, click Plot Centroids to open the dialog box.
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Set the 8.	 Scale to 100%. Leave the other options as the default settings.

NOTE:.These options may be changed as desired depending on user requirements.

Click 9.	 OK to close the Plot Centroids dialog box.

Points are plotted for the centroid location for each state polygon.

Optional
To add symbology to the centroids, follow steps 5 to 7 in Tutorial 4.1. The symbols appear in the 10.	 Style drop-down 
list in the Plot Centroids dialog box.
Close the document without saving.11.	
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5  Drawing with MAPublisher
See User Guide, Chapter 7

Creating Shapes with Specific Map Dimensions

Create a new Adobe Illustrator document1.	
Import 2.	 fsatoronto.mif and import torontostreets.mif from the Tutorial Data folder.
Transform the coordinate system of the3.	  fsatoronto MAP View to NAD83 / UTM zone 17 (see Tutorial 2.10).
In the Adobe Illustrator Layers panel, create a new layer called 4.	 Buildings.
In the 5.	 MAPS View panel, click and drag the Buildings layer to the fsatoronto MAP View, and specify the Feature Type as Area.
In the Adobe Illustrator Layers panel, select the6.	  torontostreets_line layer, and create and apply a new Selection Filter  
(Tutorial 10.1) to select College St. and Bay St. Build the expression: Street ="COLLEGE ST" OR Street = "BAY ST"

		       

Zoom in to the intersection of these streets. A recommended zoom level is 600%.7.	

To construct an imaginary building at precise map dimensions
In the Adobe Illustrator Layers panel, select the 8.	 Buildings layer and click the MAP Area Tool (box) button in the Adobe 
Illustrator Tools panel. 
Single-click on one of the corners of the intersection of the two selected streets to open the9.	  Add Area dialog box.

Since the fsatoronto MAP View is in UTM, the units are displayed in metres in the drop-down list. 

Type10.	  50 into the Width text box, type 30 into the Height text box, check the Center area on click check box, and click OK.

These parameters create a rectangle 50 x 30 metres. The centre of the polygon locates at the single-click point 
from the previous step.
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Move the building and rotate it as desired using the 11.	 Rotate Tool. Give the building a fill colour.
Zoom out to 150%.12.	

Presume that this building is an established grocery store. In a recent survey it was found that on average, the 
majority of its customers lived within 500 metres of the store.

Click the13.	  MAP Area Tool (ellipse) button in the main Adobe Illustrator Tools panel.  
Single-click in the centre of the building to open the 14.	 Add Area dialog box.
Type 15.	 1000 for both the Width and Height, check the Center area on click check box, and click OK.

A circle is placed which mimics the maximum distance away from the store that the majority of customers live. 
Notice that the streets which fall inside this circle, whether entirely or in part, are selected.

The company is planning to construct another grocery store in the same area and wishes to determine if a new 
store (Store B) will take any business away from its original store (Store A). Repeat the tutorial for a store located 
at the intersection of Beverley St. and Queen St. W.

Close the document without saving.16.	  
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6  Cropping with MAPublisher
See User Guide, Chapter 7

Cropping MAPublisher Data with MAP Vector Crop

Create a new Adobe Illustrator document.1.	
Import 2.	 torontostreetsjoined.mif and fsatoronto.mif from the Tutorial Data folder.
Select all data in both layers and open the 3.	 MAP Attributes panel.

View the table structure and map attribute records and then deselect the data. Close the MAP Attributes panel.

Click the 4.	 Map Vector Crop Tool from the main Adobe Illustrator Tools panel. 
With the 5.	 MAP Vector Crop Tool selected, manually click and drag a marquee window that encompass the desired 
map area coverage.

The map is cropped to the area defined in the previous step.6.	

Once again select all data in both layers and open the 7.	 MAP Attributes panel. Notice that the attributes have been 
maintained.
Close the document without saving.8.	
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7  Line Functions
See User Guide, Chapter 8

7.1	 Buffering Lines Using an Entered Value

Create a new Adobe Illustrator document.1.	
Import 2.	 burlroads.mif from the Tutorial Data folder and assign NAD83 / UTM zone 17N as the source coordinate system. 
Navigate to the location, Projected > UTM > NAD83 to find the coordinate definition (Tutorial 1).
In the Adobe Illustrator Layers panel, create a new layer called 3.	 Buffer Areas.
In the 4.	 MAP Views panel, click and drag the new layer into the burlroads MAP View, and specify the Feature Type as Area.
Select a few lines to be buffered.5.	
In the Adobe Illustrator menu, click 6.	 Filter* > MAP Lines > Buffer Lines to open the Buffer Lines dialog box.
Click the 7.	 Static Value option if it is not already enabled.
In the 8.	 Units drop-down list select Meter, and type 25 in the adjacent text box to represent a buffer value of 12.5 
metres on either side of the selected road(s).
In the 9.	 Output Layer drop-down list, select the Buffer Areas layer.

Click 10.	 OK.

The lines that were selected for buffering have been overlaid with new area objects, representing a buffer 
created around the original lines of the specified width. Buffered lines can be styled like any other object.

Close the document without saving.11.	

* In Adobe Illustrator CS4, the Filters menu is located in the Objects menu (Objects > Filters).
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7.2	 Flipping Lines

There are two methods in MAPublisher to ensure that text labels are oriented correctly when they are attached to 
paths. The first is to check the Reverse right to left paths (flip upside-down text) option in Feature Text Label or the MAP 
Tagger Tool. Alternatively, permanently correct any digitizing irregularities by using the Flip Lines function.

Create a new Adobe Illustrator document.1.	
Import 2.	 torontostreetsjoined.mif from the Tutorial Data folder.
In the Adobe Illustrator Layers panel, select the3.	 torontostreetsjoined_line layer, and create and apply a new Selection 
Filter (Tutorial 10.1) to select College St. and Dundas St. Build the expression: Street ="COLLEGE ST" OR Street = 
"DUNDAS ST W".

In the Adobe Illustrator menu, click 4.	 Filter > MAP Lines > Flip Lines to run the Flip Lines function.

The selected lines will have their beginning and end points switched. The orientation of the lines is permanently 
corrected. Any labels placed along these lines are now oriented correctly.

Use5.	  Feature Text Label or the MAP Tagger Tool to label these lines (see Tutorial 9).

The selected lines are labeled and the text is oriented above the lines (they would be oriented below the lines if 
the lines were not flipped). 

Close the document without saving.6.	
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7.3	 Joining Lines Based on Attribute Value

Create a new Adobe Illustrator document.1.	
Import 2.	 torontostreets.mif from the Tutorial Data folder.

Select individual line segments to see that lines are not joined with other line segments, even though the line 
may be of the same street.

Select all objects on the 3.	 torontostreets_line layer and open the MAP Attributes panel. Notice there are 1197 line 
segements in the layer.
In the Adobe Illustrator menu, click 4.	 Filter > MAP Lines > Join Lines... to open the MAPublisher Join Lines dialog box.
In the 5.	 Join on Attribute drop-down list, select Street in order to join the lines by their street name attribute.
Type 6.	 Joined Streets in the Destination Layer text box. It will be the name of the new layer containing the joined lines.
Type7.	  0.01 in the Proximity text box and make sure the proximity unit is set to Degree. Proximity is the tolerance 
setting used in the join process.
Ensure the 8.	 Close Segment Gaps check box is unchecked.

Make sure that the dialog box matches the one above and click 9.	 OK.

A new layer called Joined Streets is created and contains 284 line segments. The original map file contains 1197 
line segments. Select an individual line segment and notice that the line is joined with line segments that share 
the same street name (the attribute the join was based on).

Close the document without saving.10.	

7.4	 Simplifying Lines

Create a new Adobe Illustrator document.1.	
Import the 2.	 Ukrail.gen file from the Tutorial Data folder.
Specify the coordinate system as 3.	 British National Grid (see Tutorial 1.10).
In the Adobe Illustrator Layers panel, select all objects in the 4.	 ukrail_line layer and click Simplify Lines... (Adobe 
Illustrator menu, click Filter > MAP Lines > Simplify Lines...).
In the 5.	 Units drop-down list, select Kilometer, and type 2 in the Proximity text box.
Click 6.	 Preview to see a preview of the simplified data with the current settings. 
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Click 7.	 OK to start the simplification process.

The selected lines are now simplified based on a proximity value of two kilometres and have been simplified 
from 17,186 vertices to 8,756 vertices or a reduction of about 50%.

Close the document without saving.8.	

7.5	 Joining Points

Create a new Adobe Illustrator document.1.	
Import 2.	 torontostreetsjoined.mif and torontopoints.mif from the Tutorial Data folder. After import, ensure the 
torontopoints_point layer is at the top of the layers hierarchy in the Adobe Illustrator Layers panel.
If necessary deselect all layers and only select the points of the 3.	 torontopoints_point layer and open the MAP 
Attributes panel.

Notice that the ID attribute column contains four unique values identifying points that compose: two subway 
lines, the mainline rail track, and a park boundary. The LineNumber and AreaNumber columns contain rising numeric 
values indicating the number of each point in its sequence. Note that some points contain matching values.

Deselect all points and in the Adobe Illustrator menu, click 4.	 Filter > MAP Lines > Join Points... to open the Join Points 
dialog box.
Since only one point layer is in the document and there are no points selected, the 5.	 Input Layer frame defaults to 
all points in the torontopoints_point layer.
In the 6.	 Output Layer frame, type Joined Points (a new layer will be created with this name) and leave the Close Paths 
check box unchecked.
In the 7.	 Group By frame, select ID from the Column drop-down. This contains the unique attributes that will be used 
to join similar points together.
In the 8.	 Sort By frame, click AreaNumber in the column list and click the Add button.
In the 9.	 Sort By frame, click LineNumber in the column list and click the Add button.
Ensure that 10.	 LineNumber is at the top of the Sort Order list box by selecting it and clicking the Up button.

Having LineNumber at the top of the Sort Order column makes it the primary sorting column when determining 
the ordering of points in the chain. The AreaNumber column is used as the secondary sorting column, if any 
points in the primary column contain matching values.

Make sure the dialog box matches the one below and click 11.	 OK.
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All the points are joined based on the specified parameters. A line layer called Joined Points is created that contains 
four new lines. The lines represent two subway lines, the mainline rail track, and the perimeter of a small park.

Select the four lines on the 12.	 Joined Points layer and open the MAP Attributes panel.

Notice that an attribute column named ID is created and contains the values in the Group By frame from the Join 
Points dialog box.

Note that the small segment with the attribute P43 is the outline of a park area. However, this segment should be 
closed and should be deleted using the following steps.

In the Adobe Illustrator Layers panel, select the 13.	 torontopoints_point layer and use the MAP Selection Filters to select 
all the points with an ID equal to P43 (see Tutorial 10 on Making Selections).
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With these points selected, open the 14.	 Join Points dialog box.
In the 15.	 Input Layer frame, chose the Selected Points option.
In the 16.	 Output Layer frame, type Park Area as the layer name. This time, check the Close Paths check box.
Add 17.	 AreaNumber and LineNumber to the Sort Order column list, and make sure LineNumber is at the top of the list.
Click 18.	 OK.

The selected points are joined based on the specified parameters. A new Park Area layer is created that contains a 
polygon that represents the perimeter of a small park.
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8.1	 Creating an Area Stylesheet

Create a new Adobe Illustrator document.1.	
Import 2.	 world.mif from the Tutorial Data folder.
In the Adobe Illustrator menu, click 3.	 Window > Graphic Styles to open the Graphic Styles panel.
In the 4.	 Graphic Styles panel option menu, click Open Graphics Style Library > Other Library... and load MAP_AreaStyles.ai 
from the \Helpful Styles & Symbols\Graphic Styles folder (see page ii).
Shift-select all the graphic styles in the 5.	 MAP_AreaStyles panel, and drag them into the Adobe Illustrator Graphic 
Styles panel.

      

In the Adobe Illustrator menu, click 6.	 Window > MAPublisher  > MAP Stylesheets to open the MAP Stylesheets panel. 

The world_area layer does not belong to any stylesheet, so it is automatically placed into [No MAP Stylesheet].

In the 7.	 MAP Stylesheets panel option menu, click New MAP Stylesheet...
In the 8.	 New MAP Stylesheet dialog box, type Continents1 as the name, select Area from the Feature Type drop-down list, 
and click OK.

In the 9.	 MAP Stylesheets panel, drag the world_area layer into the Continents1 stylesheet.
Double-click the 10.	 Continents1 stylesheet, or click Edit "Continents1" from the panel option menu.
In the 11.	 Edit "Continents1" dialog box, click Add to add a style rule.
Rename the rule to 12.	 Africa, and choose a style from the Style drop-down list (these are the styles previously added).
At the bottom of the dialog box, set the13.	  Expression Mode to Simple. Click on the Expression field to open the Simple 
Expression builder. On the left-hand drop-down list, set the attribute to Continent, select the equal sign for the 
operator, and select Africa from the right-hand drop-down list as the attribute value.
Leave the 14.	 Scale set to 100%.
Click 15.	 Apply to see the changes made to the map.

NOTE: If changes are made to a style, click empty space in the dialog box before clicking the Apply button.

8  Legends and Stylesheets
See User Guide, Chapter 9
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Repeat steps 11 to 15 for each of the subsequent continents. Note that the same style cannot be used more 16.	
than once, as one style equals one legend entry.
When all of the continents are assigned a style, click the 17.	 Apply button to see the changes, or click OK to close the 
dialog box.

The styles specified have been applied to the map. The styles in the Graphic Styles panel are now linked to the 
attribute values specified by the style rules.

Save this document as 18.	 MyWorld.ai in the Tutorial Data folder. It will be used again in Tutorial 8.4.
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8.2	 Creating a Line Stylesheet

Create a new Adobe Illustrator document.1.	
Import 2.	 fcstreets.mif from the Tutorial Data folder.
Open the Adobe Illustrator 3.	 Graphic Styles panel.
Use the Adobe Illustrator 4.	 Line Segment Tool to create the first graphic style by drawing a line on the page. Assign 
it a stroke weight of 2 pt, a stroke colour of red, and a fill of none. Drag this line into the Graphic Styles panel. In the 
Graphic Styles panel, double-click the style to give it a new name.
Repeat the previous step to generate three more styles: green, yellow, and blue. Be sure to give each style a 5.	
unique name and delete the lines when the styles are completed.

Open the 6.	 MAP Stylesheets panel and in the panel option menu, click New MAP Stylesheet...
In the 7.	 New Map Stylesheet dialog box, type Road as the name, select Line from the Feature Type drop-down list, and 
click OK.
In the 8.	 MAP Stylesheets panel, click and drag the fcstreets_line layer into the Road stylesheet.
Double-click the9.	  Road stylesheet and in the Edit "Road" dialog box, click the Add button.
In the first row, use the 10.	 Style drop-down list to choose the red style created previously.
In the 11.	 Expression column, build the expression Number = A25.
Change the 12.	 Scale to 200%.
Repeat this process for each of the subsequent road numbers; where 13.	 A31 is styled green, A41 is styled blue, and A45 
is styled yellow. For these three road types, leave each scale at 100%.

When all the rules are defined with a style, click 14.	 OK.

The styles specified are applied to the map. The styles used in the Graphic Styles panel are now linked to the 
attribute values specified by the style rules.
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Notice that road A25 (red) has a 4 pt stroke weight. This is due to the scale being set to 200%.

Save this document as 15.	 MyRoads.ai in the Tutorial Data folder. It will be used again in Tutorial 8.5.

8.3	 Creating a Point Stylesheet

Repeat Tutorial 1.6 (Importing Points).1.	
Open the  Adobe Illustrator 2.	 Symbols panel (click Window > Symbols).
In the 3.	 Symbols panel option menu, click Open Symbol Library > Other Library... and load Map Symbols.ai from the  
\Helpful Styles & Symbols\Symbols folder (see page ii).
Shift-select all the symbols in the 4.	 MAP Symbols panel, and drag them into the Adobe Illustrator Symbols panel.

     

Open the 5.	 MAP Stylesheets panel and click New MAP Stylesheet... in the panel option menu.
In the 6.	 New Stylesheet dialog box, type Point Data as the name, select Point in the Feature Type drop-down list, and 
click OK.
In the 7.	 MAP Stylesheets panel, drag the azdeci_point layer from [No MAP Stylesheet] into the Point Data stylesheet.
Double-click the 8.	 Point Data stylesheet and in the Edit "Point Data" dialog box, click the Add button.
In the first row, use the 9.	 Style drop-down list to choose MAP Symbol 34 from the symbols loaded previously.
In the 10.	 Expression column, build the expression: C3 = airport.
Change the 11.	 Scale to 70%
Repeat this process for each of these points:12.	  church, hospital and park. Choose an appropriate symbols for each.
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When all the rules are defined with a style, click 13.	 OK.

The symbol styles specified are applied to the map. The styles used in the Symbols panel are now linked to the 
attribute values specified by the style rules.

Close the document without saving.14.	

8.4	  Duplicating Stylesheets

Open 1.	 MyWorld.ai (saved at the end of Tutorial 8.1) from the Tutorial Data folder.
In the 2.	 MAP Stylesheets panel, select the Continents1 stylesheet, open the panel option menu, and click Duplicate 
“Continents1"...
Double-click the3.	  Copy of Continents1 stylesheet.
In the 4.	 Edit "Copy of Continents1" dialog box, rename the stylesheet to Continents2.
Use the 5.	 Style drop-down list for each style rule to change the colours used to represent the continents.
When all continents have been assigned different styles, click 6.	 OK.

There are now two stylesheets available to use that have rules specifically for the world_area layer. 

In the 7.	 MAP Stylesheets panel, click and drag world_area from the Continents1 stylesheet into the Continents2 stylesheet.

The new styles assigned in this stylesheets are applied to the map accordingly. Now drag the world_area layer 
back to Continents1 to restore the map to its previous style scheme. Having multiple stylesheets defined allows 
a user to easily create multiple colour schemes for the same map.

Close the document without saving.8.	

8.5	 Editing Styles to Change Attributes

Open 1.	 MyRoads.ai (saved at the end of Tutorial 8.2) from the Tutorial Data folder.
In the Adobe Illustrator menu, click 2.	 Window > MAPublisher > MAP Selection Filters to open the MAP Selection Filters 
panel (see Tutorial 10).
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In the 3.	 MAP Selection Filters panel option menu, click New Selection Filter...
In the Expression box, type 4.	 Number = "A45" (case sensitive, include quotes), and click to OK close the dialog box.

This selects all lines on the fcstreets_line layer that have a number equal to A45. The yellow line at the lower right 
corner of the document is the only line that corresponds with this selection.

With the line selected, open the Adobe Illustrator 5.	 Graphic Styles panel, and assign the blue line style.
Open the 6.	 MAP Attributes window, to display the line attributes of the currently selected objects.

Notice that by changing to the blue line style, the line attribute has also been updated. By simply changing the 
style currently used to represent another attribute in the Road stylesheet, it has changed the attributes of the 
selected line from A45 to A41.

Close the document without saving.7.	

8.6	 Creating a MAP Stylesheet Legend

Open 1.	 MyWorld.ai (saved at the end of Tutorial 8.1) from the Tutorial Data folder.
In the Adobe Illustrator Layers2.	  panel, rename Layer 1 to Legend.
Open the 3.	 MAP Views panel, drag the layer Legend into the world MAP View and set the Feature Type to Legend.
Select the Adobe Illustrator 4.	 Type Tool, choose a font, and set the size to 10 pt.
In the 5.	 MAP Stylesheets panel, highlight the Continents1 stylesheet, open the panel option menu, and click Create MAP 
Stylesheet Legend. In the target layer window, choose Legend, and click OK.

The legend is created and positioned in the SW corner using the type face chosen at 10 pts.

Stylesheet legends can be created from any stylesheet (area, line, point or text). A stylesheet legend displays the 
symbol for the type of stylesheet used, the stylesheet rule's name, and the expression used to create the rule. 
The MAP Stylesheets legends can easily be edited, it is an Adobe Illustrator nested object.
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9.1	 Generating Labels for a Line Layer Using Feature Text Label

Create a new Adobe Illustrator document.1.	
Import 2.	 torontostreetsjoined.mif from the Tutorial Data folder. 
Create a new layer called 3.	 Street Names in the Adobe Illustrator Layers panel.
In the 4.	 MAP Views panel, click and drag the Street Names layer into the torontostreetsjoined MAP View and set the 
Feature Type to Text.

Select a font and text size for the labels.5.	
Select features from 6.	 torontostreetsjoined_line to be labeled. In this example, simply select one or more of the 
streets that were just imported.
In the Adobe Illustrator menu, click 7.	 Filter* > MAP Legend > Feature Text Label to open the Feature Text Label dialog 
box or click the Feature Text Label button on the MAPublisher toolbar. 
Only one 8.	 Source Layer is listed (torontostreetsjoined_line). In the Column drop-down list, select Street. In the Text Layer 
drop-down list select Street Names.

The Source Layer list shows the line, area, point and/or text layers currently containing selected data. For each 
layer, the Column drop-down list is populated with the attribute structure of that layer. Label the data based on 
a column that holds the appropriate attribute values. 

In the 9.	 Label Settings area, click the Line Labels button on the left to assign MAPublisher line label settings, if it is not 
already enabled.

In the Label Settings area, users can specify label preferences such as label position, alignment to lines 
of latitude, minimum font sizes, and horizontal scaling to best place labels within polygons and paths.  
MAPublisher places line labels intelligently, depending on the curvature and length of the line string.

Set the 10.	 Label Type option to Follow Line, create text on a path.
Set the 11.	 Distance from Start option to Auto.
Check the12.	  Reverse right-to-left paths (flip upside-down text) check box (should be enabled by default).
Leave the 13.	 Line Smoothing check box unchecked
Set the 14.	 Label Position option to Descender.

Labels can be modified if they exceed the length of the line with the current default font size.

Check the 15.	 Adjust label if larger than line check box to activate the label rules. The order for the rules can be changed 
by clicking on the rule and then pressing the Up or Down arrow button.

9  Labeling Functions
See User Guide, Chapter 10

* In Adobe Illustrator CS4, the Filters menu is located in the Objects menu (Objects > Filters).
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Check the 16.	 Reduce font size check box to reduce the size of the font to a specified minimum size in points. The 
default minimum font size value is set to 5 pt.
Check the 17.	 Reduce horizontal scaling to a minimum of check box and set the value to 50%. This allows text to be scaled 
down horizontally by the fraction specified to adjust the kerning of the text.
Check the 18.	 Set all labels to the same minimum font size check box.

If any of the labels have been adjusted in size due to the activation of a line adjustment rule, all labels can be 
resized to the same size (in this case 5 pt).

Click 19.	 OK and the labels appear for the selected map features.
Close the document without saving.20.	

9.2	 Generating Labels for an Area Layer Using the MAP Tagger Tool

Create a new Adobe Illustrator document.1.	
Import 2.	 fsatoronto.mif from the Tutorial Data folder.
Create a new layer called 3.	 Zone Names in the Adobe Illustrator Layers panel.
In the 4.	 MAP Views panel, click and drag Zone Names into the fsatoronto MAP View, and set the Feature Type to Text.
Select a font and text size for the labels.5.	
Double-click the 6.	 MAP Tagger Tool    button in the Adobe Illustrator Tools panel to open the Label Settings dialog box.

Similar to the Feature Text Label in the previous tutorial, the options must first be set in the Label Settings dialog 
box before MAPublisher is able to determine the attributes that will be converted to labels. The Source Layer list 
shows the line, area, point and/or text layers currently containing selected data.
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In the 7.	 Label Settings dialog box, set the Column drop-down list to FSA. This column contains the name of every 
postal code zone in the selected MAP Layer.
Now set the 8.	 Text Layer drop-down list to the Zone Names layer.
Click9.	  OK.
With the 10.	 MAP Tagger Tool button, click on any feature to label it.

NOTE: To create leader lines for tagged data click and drag while holding down the Shift key.

NOTE: To reopen the Label Settings dialog box, double-click the MAP Tagger Tool button.

Close the document without saving.11.	
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10  Making Selections
See User Guide, Chapter 11

10.1	 Making a Selection with MAP Selection Filters

Create a new Adobe Illustrator document1.	
Import 2.	 fcstreets.mif from the Tutorial Data folder. It is a line file depicting the major roads of Falls Church, Virginia.
Select 3.	 fcstreets_line and in the Adobe Illustrator menu, click Window > MAPublisher > MAP Selection Filters to open 
the MAP Selection Filters panel or click the MAP Selection Filters button on the MAPublisher toolbar. 
Click the 4.	 Create New Selection Filter button at the bottom of the panel or select the same option from the panel 
option menu.
Enter 5.	 Route number in the Name text box.
Click the 6.	 (. . .) browse button to open the Edit Expression dialog box. 
Click on the arrow button 7.	  to expand the Expression Components.
In the 8.	 Objects box, double-click Number under the heading fcstreets_line so that it is entered into the expression 
entry box. Click the equals (=) button and type "A25" (including quotes).

NOTE:  To view the unique values of a specific attribute column, click display unique values under the Description 
box. Click a value to enter it into the expression entry box. It recognizes the attribute as a string and places 
quotations around the value.

Click 9.	 OK to close the Edit Expression dialog box.
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Click 10.	 OK once more to close the New Selection Filter dialog box.

Lines corresponding to the selection rule are selected.

Leave the document open for the next tutorial.11.	

10.2	 Using Add to Current Selection to Add to an Existing Selection

Continue working with the previous tutorial.
Use the 1.	 Selection Tool to select some of the road data.
Ensure the 2.	 fcstreets_line layer is selected and open the MAP Selection Filters panel.
Select the previously created filter 3.	 Route number from the list in the panel (selected by default if it is the only one).
Now click the 4.	 Add to Current Selection button at the bottom of the panel.

The features that match the expression are added to the selection. 

Use the 5.	 Remove from Selection and Get Subset of Current Selection buttons to experiment with other selection types.
Close the document without saving.6.	

Apply as New Selection 

Add to Current Selection 

Remove from Current Selection

Delete Selection Filter

Create New Selection Filter 

Get Subset of Current Selection
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10.3	 Using Selection Filters for Advanced Selections

MAP Selection Filters can also be used to generate selections based on a number of attribute columns and criteria.

Create a new Adobe Illustrator document.1.	
Import 2.	 world.mif from the Tutorial Data folder. 
Make sure the 3.	 world_area layer is selected and open the MAP Selection Filters panel. 
Click the 4.	 Create New Selection Filter button at the bottom of the panel.
Enter 5.	 Population search in the Name text box.
Click the 6.	 (. . .) browse button to open the Edit Expression dialog box.
In the7.	  Expression Components section, double-click the Continent column in the Objects list to enter it into the 
expression entry box.
Continue building the expression. Click the 8.	 = symbol button and select "Africa" from the unique values list. Click 
the AND button, click the ( symbol button, in the Options list double-click the Population column, click the > symbol 
button, type 1000000, click the AND button, in the Options list double-click the Population column, click the < symbol 
button, type 10000000, and finally click the ) symbol button to close the expression. The final expression should 
match the following: Continent = "Africa" AND (Population > 1000000 AND Population < 10000000)

Click 9.	 OK to close the Edit Expression dialog box.

Click 10.	 OK to close the New Selection Filter dialog box to launch the selection.
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NOTE:. When a selection filter in MAPublisher 8 contains an expression that is valid for the active map layer, a green 
checkmark icon is displayed to the left of the expression in the MAP Selection Filters panel. If the expression is 
not valid for that particular map layer, a red exclamation mark is displayed.

Leave the document open for the next tutorial.11.	

10.4	 Making Selections with MAP Selection Stats

Continue working with the previous document.
Make sure a MAP Layer is selected in the Adobe Illustrator Layers panel, and select a few features on the map.1.	
In the Adobe Illustrator menu, click 2.	 Window > MAPublisher > MAP Selection Stats to open the MAP Selection Stats 
panel or click the MAP Selection Stats button on the MAPublisher toolbar.

The total number of features and the number of features that are selected are displayed in the panel.

NOTE:.This tool only functions on MAP Layers.

Click the 3.	 R button.

The selections made in step 1 are reversed.

Click the 4.	 SAVE button, deselect all features, then click RECALL.

All the features that were selected in step 3 are reselected.

Deselect all features, make another random selection of features, and click 5.	 M OR.

The selected set of features now consists of both the saved features and the features just selected.
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Deselect all features, make another random selection of features, and click6.	  M AND.

The selected set of features now consists of the features that are common to the saved selection set and the 
selection just made.

Deselect all features, make another random selection of features, and click 7.	 M XOR.

The selected set of features now consists of the features that are not common to the saved selection set and the 
selection just made.

Click 8.	 CLEAR to clear the saved selections.
Close the document without saving.9.	
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11  Working with Images
See User Guide, Chapter 12

11.1	 Registering an Image with a Reference File

Create a new Adobe Illustrator document.1.	
Import 2.	 southchinasea.shp from the Tutorial Data folder.  
Make sure the 3.	 southchinasea_area layer is selected in the Adobe Illustrator Layers panel.
In the Adobe Illustrator menu, click 4.	 File > Place, navigate to the Tutorial Data folder, select the sample raster 
image file borneo.tif, and click the Place button. 

The raster image is placed at a default position and scale in the centre of the screen.

With the image selected, click the Adobe Illustrator menu 5.	 Filter > MAP Images > Register Image to open the 
Register Image dialog box or click the Register Image button on the MAPublisher toolbar. 
Click the 6.	 Load File button and select borneo.tfw from the Tutorial Data folder.

A warning that the coordinates from the reference file will be used in the registration process appears. This is 
normal and is not indicative of an issue with the data. All text boxes in the dialog box are updated to reflect the 
data contained in the reference info file.

Click 7.	 OK.

The image is registered to the selected layer.

* In Adobe Illustrator CS4, the Filters menu is located in the Objects menu (Objects > Filters).



62 MAPublisher 8 Tutorial 
11  Working with Images

Select the raster image, right-click, select 8.	 Arrange > Send to Back.
This moves the raster image below the southeastchina data.

Leave the document open for the next tutorial.9.	

11.2	 Registering an Image without a Reference File 

Continue working with the previous document.
Select and delete the existing registered Borneo image from the document.1.	
Select the 2.	 southchinasea_area MAP layer in the Adobe Illustrator Layers panel.
In the Adobe Illustrator menu, click 3.	 File > Place, navigate to the Tutorial Data folder, select the sample raster 
image file, borneo.tif, and click the Place button.

The raster image is brought in at a default position and scale in the centre of the screen.

With the image selected, open the 4.	 Register Image dialog box.

One of the four corners of the raster image is what MAPublisher will use as the raster anchor point (Upper Left 
Placement, Lower Left Placement, Upper Right Placement or Lower Right Placement).

Click the 5.	 Upper Left Placement (blue diagram) and type the following values into the Upper Left Placement X and Y 
text boxes: X=108.337561,  Y=7.781662 
Make sure that 6.	 Constrain Proportions option is checked and type pixel size X equal to 0.012773.
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Make sure the dialog box matches above and click 7.	 OK.

The image is registered to the selected layer. This method is useful if no reference file is available. However, it 
is necessary to know the coordinates for one of the corners of the image as well as the pixel scale in order to 
register an image.

Leave the document open for the next tutorial.8.	

11.3	 Exporting a Placed Image as a Georeferenced Raster File

Continue working with the previous document.
To set the colour mode, in the Adobe Illustrator menu, click 1.	 File > Document Color Mode.

Select RGB or CMYK depending on the colour mode required for the exported raster image. For this example, 
use CMYK.

Select the registered image if it is not already selected. In the Adobe Illustrator menu, click 2.	 Filter > MAP Images > 
Export Image to open the Export Image dialog box or click the Export Image button on the MAPublisher toolbar.
In the 3.	 Store Geography As: drop-down list, select GeoTIFF to set the georeferencing output format.

Click 4.	 Save as to browse to a location to save the export image.
Type a name for the export image and click 5.	 Save to complete the export process.

The image of Borneo is exported as a GeoTIFF file using the coordinate system of the South China Sea layer. 

Close the document without saving.6.	



64 MAPublisher 8 Tutorial 
12  Grids, Graticules and Indexes

12.1	 Creating an Index Grid

Create a new Adobe Illustrator document.1.	
Import 2.	 world.mif from the Tutorial Data folder.
In the Adobe Illustrator Layers panel, create a new layer called 3.	 Grid.
In the 4.	 MAP Views panel, click and drag the Grid layer into the world MAP View, and specify the Feature Type as Legend.

To define the visual parameters for a grid, a style should first be created before it can be applied.

Use the 5.	 Rectangle Tool to draw a small rectangle. Specify no fill colour, choose a blue stroke colour, and set a 0.5 pt 
stroke width.
Select the rectangle and drag it to 6.	 Graphic Styles panel and rename it My Grid. Delete the drawn blue rectangle.

      

In the Adobe Illustrator menu, click 7.	 Window > Type > Character Styles to open the Character Styles panel.
Create a new character style setting the font family, font style, size and character colour and name it 8.	 My Grid Font 
(see the Adobe Illustrator Users Guide to learn more about Character Styles).

In the Adobe Illustrator Layers panel, select the 9.	 Grid layer.

The grid must be placed on a visible and unlocked MAP layer.

In the Adobe Illustrator menu, click 10.	 Filter* > MAP Legend > Grid & Graticules to open the MAPublisher Grids and 
Graticules dialog box or click the Grid and Graticules button on the MAPublisher toolbar.
In the 11.	 Grids and Graticules dialog box, click the Index Grid button to show its options. Leave the Number of Columns/
Rows as the default of 10.
Under 12.	 Display Options, select My Grid from the Style drop-down list to set the style of grid.
In the 13.	 Labeling frame, select the My Grid Font character style for each of the Center, Axes and End of Line style drop-
down lists.

Notice that when the mouse hovers over each style the Labeling box highlights the corresponding item.

12  Grids, Graticules and Indexes
See User Guide, Chapter 13

* In Adobe Illustrator CS4, the Filters menu is located in the Objects menu (Objects > Filters).
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Leave both 14.	 Place labels off cell by and Place label off line by as the default of 6 pt.
In the label diagram, click "A 15.	  B" or "1  2" to enable the labels for the corresponding side of the grid. 

Click on the letter or number to enable or disable the display of labels on the grid. Click the bidirectional arrow 
to reverse the order of the labels. 

Make sure the dialog box matches above and click 16.	 OK to process the index grid.

An index grid is placed on the map. Each cell carries an alphanumeric identifier. To edit an existing grid, go to 
Object > Edit Index Grid to change the configuration settings or type of grid.

Save the document as 17.	 MyGrid.ai. It will be used in Tutorial 12.4 Creating an Index: Featured Based.
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12.2	 Creating a Graticule

Create a new Adobe Illustrator document in landscape orientation.1.	
Import 2.	 world.mif from the Tutorial Data folder.
In the Adobe Illustrator Layers panel, create a new layer called 3.	 Graticule. 
In the 4.	 MAP Views panel, click and drag the Graticule layer into the world_area MAP View, and specify the Feature Type 
as Legend.
Draw a rectangle with 5.	 no fill and a blue stroke of 1 pt.
Click and drag the rectangle into the 6.	 Graphic Styles panel and rename it My Grid.
In the Adobe Illustrator Layers panel, select the 7.	 Graticule layer and open the Grid and Graticules dialog box.
Click the 8.	 Graticules button to show its options.

Graticules can be plotted to intersect at specific lines of latitude and longitude.

Under 9.	 Latitude, type 0 in the Pass through text box and type 20 in the Interval text box.
Under 10.	 Longitude, type 0 in the Pass through text box and type 20 in the Interval text box.

Pass through values of zero will create a graticule that passes through the Prime Meridian and the Equator. The 
graticule will have lines at intervals of 20 degrees.

Under 11.	 Display Options, set the style to My Grid.

The Vertices slider controls the number of nodes to construct the graticule. Higher numbers should be used if 
graticules are curved or in anticipation of transforming them. For now, leave the default setting. 

The Don't Label option is used in situations where the projection is creating a curved graticule that may have a 
section in one of the corners that do not need to be labelled. For example, when there is no data in the graticule 
or when there is only a small portion of the graticule showing and it does not need to be labelled. For this 
tutorial these options are not needed.
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In the 12.	 Labeling frame, enable the four end of line labels options. For this tutorial, label just the grid lines. In the 
Labeling diagram box, click all four numerical options located at the end of each grid line (10). When selected 
the number turns bold. Hover over each toggle to see its description. 

Make sure the dialog box matches above and click 13.	 OK to process the graticule.

A graticule is placed on the map based on the specifications made. To edit an existing graticule, go to Object > 
Edit Graticules to change the configuration settings. 

Close the file without saving14.	

12.3	 Creating a Measured (UTM) Grid

Create a new Adobe Illustrator document.1.	
Import 2.	 torontostreets.mif from the Tutorial Data folder.
Perform a coordinate system transformation to 3.	 NAD83 / UTM zone 17N, located in Projected > UTM > NAD83 (see 
MAPublisher User Guide, Chapter 4 or Tutorial 2.10).
In the Adobe Illustrator Layers panel, create a new layer called 4.	 Grid.
In the 5.	 MAP Views panel, click and drag the Grid layer into the world MAP View, and specify the Feature type as Legend.
Create a 6.	 My Grid graphic style and a My Grid Font character style, as was done in tutorial 12.1.
Select the 7.	 Grid layer and Open the Grid and Graticules dialog box.
Click the 8.	 Measured Grid button to show its options.
Set the 9.	 Cell Size as 1000 (metres) for both the width and height.
Leave the 10.	 Positioning options as default.
Under 11.	 Display Options, set the style to My Grid.
Check the 12.	 Append units to labels check box to show the units in the map document (metres).
In the 13.	 Labeling frame, select the My Grid Font character style for each of the Center, Axes and End of Line style drop-
down lists
In the 14.	 Labeling diagram box, click all four numerical options located at the end of each grid line (10). When 
selected the number turns bold.
Leave 15.	 Place labels off cell by and Place label off line by the default of 6 pt.
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Click 16.	 OK to process the Measured Grid.

A grid is placed on the map based on the specifications made. Each cell line has UTM map coordinate labels. To 
edit an existing measured grid, go to Object > Edit Measured Grid to change the configuration settings. If the grid 
is moved, the grid labels will automatically adjust to new coordinates.
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12.4	 Creating an Index: Feature Based

Open 1.	 MyGrid.ai (saved from Tutorial 12.1).
In the Adobe Illustrator Layers panel, create a new layer called 2.	 Text.
In the 3.	 Map Views panel, click and drag the Text layer into the world MAP View, and specify the Feature Type as Text.
Apply country labels to several or all of the countries using4.	  Feature Text Label or the MAP Tagger Tool.
Select the 5.	 Grid layer and then select the grid in the map document.
In the Adobe Illustrator menu, click 6.	 Filter *> MAP Legend > Make Index to open the Make Index dialog box.
Choose the 7.	 Make index based on label and matching feature position option.
In the 8.	 Label Layer drop-down list, select Text.  
In the 9.	 Feature layer drop-down list, world_area (the layer that was labeled).
In the 10.	 Label text matches attributes drop-down list, select country (the attribute column containing the text labels 
derived from the labeling operation).

Indexing by Feature generates an index entry for every legend cell that the labeled map object occurs in.

If desired, click the 11.	 Advanced... button to enable the Remove duplicate entries check box.  

The Remove duplicate entries feature checks for instances where two labels appear in the same grid cell and 
subsequently index only unique text items.

Sort Index12.	  by Feature Label, in the Index Delimiter frame select the Tab option, and click OK.

The grid cell locator and feature name in the index file is separated by a single tab. The index is sorted 
alphabetically by feature label.

* In Adobe Illustrator CS4, the Filters menu is located in the Objects menu (Objects > Filters).
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In the 13.	 Make Index dialog box, click Save As to save the index.
Browse to a location to save the index, name it 14.	 Index.txt, and click Save.

A text file is created based on the specifications entered in the Make Index dialog box.

The index may be inserted into the map document by creating an Adobe Illustrator text box and using the 15.	 Place 
command (File > Place).

Leave the document open for the next tutorial.16.	

12.5	 Creating an Index: Text Based

Continue working with the previous document.
In the Adobe Illustrator menu, click 1.	 Filter > MAP Legend > Make Index to open the Make Index dialog box.
Click the 2.	 Make index based on label position radio button.

Indexing by label position generates an index containing only grid cells that contain a text label within it. 

NOTE: Text labels are indexed accodring to the text object's anchor.

If desired, click the 3.	 Advanced... button to enable the Remove duplicate entries check box.  
Sort index4.	  by Grid Cell. In the Index Delimiter frame, select Comma, and click OK.

The grid cell locator and feature name in the index file is separated by a single comma. The index is sorted 
alpha-numerically by grid cell label.
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In the 5.	 Make Index dialog box, click Save As to save the index.
Browse to a location to save the index, name it 6.	 Index.txt, and click Save.

A text file is created based on the specifications entered in the Make Index dialog box.

The index may be inserted into the map document by creating an Adobe Illustrator text box and using the Place 
command (File > Place).

Close the document without saving.7.	
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13  Scale Bars and North Arrows
See User Guide, Chapter 14

13.1	 Creating a Scale Bar

Open 1.	 usa48.ai from the Tutorial Data folder.
Create a new Adobe Illustrator layer and rename it 2.	 Scale Bar.
In the 3.	 MAP Views panel, click and drag the Scale Bar layer to the usa MAP View, and specify the Feature Type as Legend.
In the Adobe Illustrator 4.	 Character panel, choose a desired font and 8 pt font size.
In the Adobe Illustrator menu, click 5.	 Filter* > MAP Legend > Scale Bar to open the MAPublisher Scale Bar dialog box 
or click the Scale Bar button on the MAPublisher toolbar. 
In the 6.	 Scale Bar dialog box, navigate with the Previous and Next buttons to choose a desired scale bar.
For the 7.	 Units drop-down list, select Kilometer.
In the 8.	 Interval text box, type 250.
Click the arrow button 9.	  to expand the Advanced options.
In the 10.	 Number of labeled intervals text box, type 4.

Depending on the scale bar chosen, select the Number of horizontal lines to use in the plotted scale bar. These 
settings create a scale bar that equates centimetres on the page to kilometres on the map.

Set the 11.	 Number of intervals to subdivide to 1, and the Number of sub intervals to 5.

These settings create a scale bar that represents a total distance of 1000 km, has four main intervals each 
representing 250 km and where the first interval is further divided into five smaller intervals.

In the 12.	 Labeling options frame, check the Display Scale check box and select above from the drop-down list.
Check the 13.	 Display page to map units ratio check box and select below (depending on the scale bar chosen, this option 
may not be enabled).
Set the 14.	 Page Units for captions drop-down list to Centimeter.
Check the 15.	 Display units to right of last interval label check box. 

Use the preview to see how these settings affect the look of the scale bar.

* In Adobe Illustrator CS4, the Filters menu is located in the Objects menu (Objects > Filters).
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Click16.	  OK to close the Scale Bar dialog box.

The Scale Bar is placed on the page according to the defined settings. If necessary, resize the scale bar using the 
bounding box. The scale automatically adjusts after it is resized.

Leave the document open for the next tutorial.17.	

NOTE: The scale bar maybe be changed through the Adobe Illustrator menu Object > Edit Scale Bar... When the MAP 
view is rescaled, the scale bar is updated automatically. At the end of the cartographic process, the scale bar 
can be expanded to be edited as a regular Adobe Illustrator artwork (doing so breaks the link to the MAP 
View scale value). 

13.2	 Creating a North Arrow

Continue working with the previous document.
Create a new Adobe Illustrator layer and rename it 1.	 North Arrow.
In the 2.	 MAP Views panel, drag the North Arrow layer into the usa MAP View, and specify the Feature Type as Legend.
Make sure the 3.	 North Arrow layer is active and use the Adobe Illustrator Type tool to create the letter N. 
Select the letter N and click the menu 4.	 Filter > MAP Legend > Create North Arrow or click the North Arrow button on 
the MAPublisher toolbar. 

        

The type is changed from regular text (above left) to a north arrow (above right) and is aligned in the north 
direction. North arrows can be created from any art object in Adobe Illustrator including symbols and 
characters. Note that the north arrow created is added to the Symbols panel*.

Open the MAP View of the imported file and adjust the 5.	 Angle to 45.

* Sample north arrow designs are included on the MAPublisher CD or download. They are located in the \Helpful Styles & Symbols\
Symbols folder (see page ii). 
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Click the 6.	 OK button.

The north arrow is orientated according to the MAP View it is placed in. Any changes made to the coordinate 
system or angle of the MAP View will cause the north arrow to automatically orient itself towards North.

Close the document without saving.7.	
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14  MAP Web Author

Exporting a Map to Flash Using MAP Web Author

In Adobe Illustrator menu, click 1.	 File > Open, navigate to the \Tutorial Data\MAPWebAuthor_Tutorial folder and 
open Flash_Canada.ai.

The MAPWebAuthor_Tutorial folder contains all the required files necessary for creating the web flash map in this 
tutorial and should have a file structure similar to the image below. 

NOTE: Before creating the map, it is recommended to appropriately set the document size in Adobe Illustrator. 
The document size is the same size as the Flash map viewed in a web browser. Use Document Setup (File > 
Document Setup...) to set the size. For the tutorial sample, Flash_Canada.ai, the document size is set at 500 
pixel width x 500 pixel height.

In the Adobe Illustrator menu, click 2.	 Window > MAPublisher  > Map Web Author to open the MAP Web Author panel 
or click the MAP Web Author button on the MAPublisher toolbar. 
In the 3.	 MAP Web Author panel option menu (click menu icon in the top right corner of the panel), click Specify Source 
Media Folder 
Select the 4.	 Relative Path option and leave the Source Media Folder field blank.

This dialog box sets the path to the ImageFiles folder (the folder containing the image data) for Web tagging. To 
indicate that the ImageFiles folder is in the same directory as Flash_Canada.ai, leave the path blank.

Click 5.	 OK to close the Specify Source Media Folder dialog box.

This tutorial creates a callout bubble for every object in the Provinces layer.

In the Adobe Illustrator Layers panel, click the target button beside the6.	  Provinces layer name to select all art on 
the layer.
In the7.	  MAP Web Author panel, click the Multiple button to open the Multiple Web Tag Dialog dialog box.
Type 8.	 Province into the Callout Title text box.
In the 9.	 Callout Image frame, select the By Attribute option and type %IMAGE% into the text box that appears.

This retrieves the value from the Provinces attribute table. The image path and dimensions are shown on the 
right-hand side of the frame. Click the Callout Preview-> button to see a preview of the callout. The image is 
located in the upper-left hand corner of the callout.

Now, add more information to the callout bubble by entering some basic HTML code. Check the Callout Preview 
to see how it changes as the code is typed.

NOTE: The attribute names are case sensitive.
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In the main content entry box type the following:10.	

<b>Province:</b> %NAME%<br>
<b>Population:</b> %Population%<br>
<b>Capital City:</b> %CapitalCity%<br><br>
Go to the <a href="%OfficialWeb%">government website</a>

Enable the 11.	 Auto Size check box on the upper right of the window
If necessary, click the 12.	 Callout Preview button to see the result of the HTML code entered.

Click 13.	 OK to close the Multiple Web Tag Dialog dialog box.
In the 14.	 MAP Web Author panel, click the Export to Web button to open the Web Export Dialog dialog box.
Click the15.	  (...) browse button to locate the working directory MAPWebAuthor_tutorial folder and highlight it.
Click 16.	 Make New Folder to create a new folder in the working directory. Name the new folder FlashMap.

Select the 17.	 FlashMap folder and click OK to close the Browse For Folder dialog box.
In the 18.	 Web Export Dialog dialog box, check the Enable Layer Visibility Toggle check box. In the Layer List, enable the 
check boxes for the following:  Major city names, Major cities and Provinces. 
Select 19.	 Built-in (Flash data-grid) in the Layer Control drop-down list.
Check the 20.	 Enable Navigation check box. 
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Check the 21.	 Compress Metadata file map .afm (recommended) check box.

Leave the other options as the default and click 22.	 OK.

The Web Export Log dialog box opens.

Right-click on the blue-highlighted path for the export folder and click 23.	 Copy Link Location.
Click the 24.	 Set Folder Permissions button.
A warming message appears. Click 25.	 OK to close it.
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The default Web browser opens and goes to the Web page http://www.macromedia.com/support/
documentation/en/flashplayer/help/settings_manager04.html.

In the 26.	 Adobe Flash PlayerTM Settings Manager, select Add Location in the Edit locations drop-down list.

In the 27.	 Trust this location dialog box, right-click to paste the link (...\Avenza\MAPublisher 8\Tutorial Guide & Data\
Tutorial Data\MAPWebAuthor_Tutorial\FlashMap\) copied from the Web Export Log dialog box. 

Click 28.	 Confirm to complete the Global Security Settings.
Back in the 29.	 Web Export Log, click Close.
Navigate to the working directory and find the 30.	 FlashMap folder.
Open 31.	 MAPublisherSWF.html in a Web browser (this file has the Flash file, MAPublisher.swf, embedded in it).

If required, install the latest Flash Player version to view the images properly (it can be downloaded from the 
Adobe Website at www.adobe.com).
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