Welcome

Avenza welcomes you to mapmaking in the 21st century!

Combined with Adobe Illustrator, MAPublisher has revolutionized the art of mapmaking by allowing spatial data files to be used to create maps inside a vector graphics program. MAPublisher allows all your cartographic tasks to be performed where they should be done; in a powerful graphics environment.

This manual assumes that the user is familiar with Adobe Illustrator and has at least a basic understanding of geographic information systems (GIS) terminology and concepts. Please refer to your Adobe Illustrator user guide for more information on using Adobe Illustrator. A glossary of GIS terms is included at the back of this manual.

By following this manual you will learn how to create maps using the MAPublisher filters in Adobe Illustrator. This manual covers the concepts necessary to build a map and perform fundamental cartographic and GIS tasks. A variety of GIS data as well as a MAPublisher 7 tutorial document, MP7tutorial.pdf, have been provided on your MAPublisher 7 CD or with your MAPublisher 7 download for use with this guide, however we do encourage you to experiment with your own data to gain additional experience with MAPublisher’s tools and functions.

Together MAPublisher and Adobe Illustrator will give you a totally integrated cartographic design software system with graphics tools and geographic functions present in the same work environment.

So join first class mapping organizations from around the world and experience modern day map-making by reading this user guide, going through the tutorials and experimenting with MAPublisher 7.
# Contents

Welcome ........................................................................................................................................... iv

CONTENTS ....................................................................................................................................... v

What’s New in MAPublisher 7 ..................................................................................................... viii

**Chapter 1: GETTING STARTED** ................................................................................................. 13

  SYSTEM REQUIREMENTS ............................................................................................................. 14
  MAPUBLISHER COMPATIBILITY NOTES .................................................................................. 14
  INSTALLATION INSTRUCTIONS ............................................................................................... 16
  REGISTRATION AND LICENSING ............................................................................................. 17
  THE MAPUBLISHER TOOLS ...................................................................................................... 18
  PREPARING THE WORKSPACE ................................................................................................. 20

**Chapter 2: MAP DATA FILE FORMATS** ................................................................................... 21

  Import & Export Supported Data Formats .............................................................................. 22
  Data Considerations .................................................................................................................. 25

**Chapter 3: IMPORTING MAP DATA** ......................................................................................... 27

  SIMPLE IMPORT ........................................................................................................................ 28
  ADVANCED IMPORT .................................................................................................................. 33

**Chapter 4: ATTRIBUTES AND GEOREFERENCING** ................................................................. 37

  ATTRIBUTES AND GEOREFERENCING - FORWARD ................................................................. 38
  MAPUBLISHER PROPERTY ATTRIBUTES .............................................................................. 39
  MAP LOCATION TOOL ............................................................................................................... 40
  MAP ATTRIBUTES ................................................................................................................... 41
  FIND & REPLACE ATTRIBUTES ............................................................................................... 43
  EDIT SCHEMA ........................................................................................................................... 44
  EDIT EXPRESSION ..................................................................................................................... 46
  IMPORT TABLE .......................................................................................................................... 49
  APPLY EXPRESSION ................................................................................................................ 51

**Chapter 5: MAP VIEWS** .............................................................................................................. 53

  MAP VIEWS PALETTE ................................................................................................................ 54
  REPROJECTING MAP LAYERS BY DRAG AND DROP ............................................................... 56
  LAYER NAME SEARCH & REPLACE ....................................................................................... 56
  MERGE LAYERS ........................................................................................................................ 56
  ASSIGNING GEOREFERENCING INFORMATION TO ILLUSTRATOR LAYERS ......................... 56
  CREATING NEW MAP LAYERS ................................................................................................. 57
  CREATING, DUPLICATING AND DELETING MAP VIEWS ....................................................... 57
  REMOVING MAPUBLISHER INFORMATION ........................................................................... 57
  SOURCE COORDINATE SYSTEM ............................................................................................... 58
  MAP VIEW EDITOR ..................................................................................................................... 59
  IMPORT MAP VIEW ................................................................................................................... 62
  EXPORT ...................................................................................................................................... 63
# Chapter 11: Line Functions
- Buffer Lines ................................................................. 102
- Flip Lines ................................................................. 103
- Join Lines ................................................................. 104
- Simplify Lines ......................................................... 105
- Join Points .............................................................. 106

# Chapter 12: Scale Bars and North Arrows
- Scale Bar ................................................................. 110
- Adding a Scale Bar .................................................. 111
- Advanced Options .................................................. 111
- Editing a Scale Bar .................................................. 111
- Create North Arrow ................................................. 112

# Chapter 13: Working with Images
- Register Image ........................................................ 114
- Using Register Image .............................................. 115
- Export Image .......................................................... 116

# Chapter 14: Drawing Tools
- Map Area Tools ....................................................... 118

## Appendices
- Appendix 1: Technical Reference Guide .................. A1/1
- Appendix 2: Mapublisher 7 How To's for Legacy Users A2/1
- Appendix 3: Utilities and Bonus Files ....................... A3/1
- Appendix 4: Glossary ............................................... A4/1
INTELLIGENT LABELING

Map data can now be labeled based on defined label settings. These settings include:

For point labels:
- Define the position of labels relative to the corresponding point symbol
- Orient labels to lines of latitude on projected MAP Views, if required

For area labels:
- Automatically find the best position for area labels
- Orient labels to lines of latitude on projected MAP Views, if required
- Set minimum font sizes and horizontal scaling preferences to fit labels within polygons
- Wrap text containing multiple words

For line labels:
- Automatically find the best position for line labels
- Smooth labels if required
- Select the vertical position of the label relative to the line
- Set minimum font sizes and horizontal scaling preferences to fit labels to the paths

NEW GRIDS & GRATICULES GENERATOR

Grids can now be created on any projected or geodetic MAP View, and can be edited after placement.

Choose from 3 grid types:
- Index Grid: Grid created by dividing the map extents into a specified number of cells
- Graticules: Place grid lines at specific degree positions and intervals
- Measured Grid: Plot cells at specific sizes and position

Assign graphic and/or character styles to grid lines.
Omit characters from cell references or start referencing at a designated label combination.
Edit grids and graticules after creation, via the Object > Edit Grid menu item.
Automatically resize grids by dragging the bounding box.

NEW SCALE BAR GENERATOR

More scale bar designs have been added, including double bars for the creation of scale bars in multiple units.
Preview automatically updates to current parameters.
Scale Bars can also be edited after placement, via the Object > Edit Scale Bar menu item.
Automatically resize scale bars vertically via dragging the bounding box.

NEW MAP ATTRIBUTES PALETTE & FUNCTIONS

Editing: Edited values are now immediately stored in the document (no need to click ‘Apply’)
Edit Schema: Edit the column name, column type, column width
Add and delete columns
Assign expressions to columns
Show or hide columns
Make columns editable or read-only
Edit the order in which the columns are shown in the viewer

Properties: New Property Columns allow for the viewing and editing of graphic properties of map objects
PROPERTY ATTRIBUTES

A number of property attribute columns have been included which are available on map layers. This allows the editing of art from within the attribute palette; such as assigning styles and symbology to data, assigning stroke weights, rotations etc. These editable data properties include the following. For a complete list see page 39.

For area layers:
- Vertex Count
- Stroke Weight
- Path Closed (Yes or No)
- Graphic Style
- Perimeter (length of the area perimeter)

For line layers:
- Vertex Count
- Stroke Weight
- Path Closed
- Length

For point layers:
- Horizontal Scale (X scale of original symbol)
- Vertical Scale (Y scale of original symbol)
- Rotation
- Symbol

For text layers:
- Text (actual text item on page)
- Rotation
- Character Style

EXPRESSION BUILDER

Assign attributes or properties to data or make selections based on expressions. Expressions are automatically checked for validity. Construct expressions to use in column editing, object editing and selections. All available columns and an array of operators are available for expression composition.

NEW IMPORT TABLE

All table functions have been replaced by a new function that will import tables and join them to existing attributes. Now accessible from the MAP Attributes palette. Imported tables are automatically joined to matching attributes on the selected layer.

STYLESHEET VALUE RANGES

The MAP Stylesheet Editor now includes the option to assign a range of values to the selected style or symbol.

MAP STYLESHEET LEGENDS

Legends can now be created quickly from all types of MAP Stylesheets.
**DMS SUPPORT**
Importing Delimited Text Data files will accept values in degrees/minutes/seconds format.

**MAP SELECTIONS**
Select by Attribute has been replaced with the MAP Selection Filters palette.
Make selections based on expressions
Add to, remove from and get subsets of current selections
Select and apply multiple selection filters
Selections are saved in the document in list form for subsequent application

**CREATE NORTH ARROW**
Convert selected vector art into North Arrows, automatically aligning the symbol to true north.
North Arrows are stored in the Illustrator Symbols palette.

**IMPORT MAP VIEW**
Import MAP Views and associated layers from other documents with all georeferencing and attributes intact.

**DOUBLE BYTE CHARACTER SUPPORT**
Import and export layers containing attributes or labels in double byte character sets.
Labeling of map objects containing such characters is fully supported, if an applicable font is available.

**UNICODE CHARACTER SUPPORT**
MAPublisher supports Unicode character encoding in MAP Views, MAP Attributes, MAP Stylesheets, and MAP Selection Filters. MAPublisher can also reference Illustrator layers, graphic styles and character styles using Unicode encoding. Unicode support for data formats can be referenced in Appendix 1 page A1/10 & A1/11.

**KML IMPORT/EXPORT**
KML files containing points, lines, and polygons can now be imported and exported using the new MAPublisher KML import/export feature.

**GRAPHICAL INTERFACE FOR CREATING AND EDITING COORDINATE SYSTEMS**
Easily Create, Edit, Remove, and save data source changes in MAPublisher using an easy to understand graphical interface.

**DELIMITED TEXT DATA EXPORT**
Text Writer allows for point coordinates to be exported to a text file along with the attributes associated for the point.
REGISTER IMAGES WITH NON-SQUARE PIXELS
Images which do not contain square pixels will now have the ability to be geo referenced using the improvements made in the register image feature.

KEYBOARD SHORTCUTS
Keyboard shortcuts are available for all MAPublisher tools using native Illustrator Keyboard shortcut functions.

REMOVAL OF ‘MAP COPY/PASTE’
Map data can now be safely copied between MAP Layers via Illustrator’s Copy and Paste functions.

REMOVAL OF LEGEND FILTERS & TABLE FILTERS
As Legend functionality is now all available in Stylesheets, the following filters have been removed in this release: Assign Legend Info, Auto Assign Legend Info, Draw Legend Layer, and Legend Matching Features.

All ‘MAP Table’ filters have been removed in this release. The functionality previously found in Import Table and Join Table can now be found in the new Import Table tool, accessible from the MAP Attributes palette.

Note all legend information held in pre-MAPublisher 7 documents will be converted into new stylesheets on opening of the document. Table information held on table layers in pre-MAPublisher 7 documents will not be retained on opening of the document. Please see the Legacy Conversion section (page 15) for more information.

For users of MAPublisher 6 or earlier, please refer to Appendix 2 for the new methods of completing common MAPublisher 6.x tasks with MAPublisher 7.
Chapter 1
Getting Started

Before using MAPublisher please read this section to ensure that you have a suitable hardware environment, become familiar with the installation procedure, and adequately prepare your system and workspace to make maps with Adobe Illustrator and MAPublisher 7.

The topics covered in this section are as follows:
- System Requirements
- MAPublisher Compatibility Notes
- Installation Instructions
- Registration and Licensing
- The MAPublisher Tools
- Preparing the Workspace
System Requirements

Before installing MAPublisher 7.5, please ensure that you have sufficient system resources, as outlined below:

WINDOWS

- Adobe Illustrator CS2/CS3
- Intel Pentium III or 4 processor, or equivalent
- Windows XP/Vista
- 1 GB of RAM (2GB of RAM Recommended)
- 300 MB of available hard-disk space

MACINTOSH

- Adobe Illustrator CS2/CS3
- PowerPC G4 or above (Intel Mac Recommended)
- Mac OSX 10.4 or higher
- 1 GB of RAM (2GB of RAM Recommended)
- 300 MB of available hard-disk space

MAPublisher requires the enhanced Unicode support of Adobe Illustrator CS2/CS3.

MAPublisher Compatibility Notes

MAPublisher 7.5 is compatible with Adobe Illustrator CS2 & CS3 only. Please read the following important compatibility information for use when opening legacy MAPublisher and Illustrator documents.

BACKWARDS COMPATIBILITY

MAPublisher 7 documents are not backwards compatible with previous versions of MAPublisher. Furthermore, MAPublisher 7.5 documents are not compatible with earlier v7 releases.

MAPUBLISHER 5 (OR EARLIER) DOCUMENTS

Point Data

MAPublisher introduced new standards on dealing with point data in MAPublisher 6. Pre-MAPublisher 6 documents will have font based points converted to symbols on opening of the document.

MAPUBLISHER 6 (OR EARLIER) DOCUMENTS

Grids and Indexes

There is a new Grids and Graticules tool in MAPublisher 7.x. Please note that grids created in previous versions of MAPublisher will need to be recreated with the new tool if the generation of an index is required.
Legend to Stylesheet Conversion

Legend functionality (Assign Legend Info, Draw Legend etc) has been ported into MAP Stylesheets in MAPublisher 7.x. Legend information held in legacy MAPublisher documents will be converted into stylesheets on document open. Subsequently Graphic Styles (for line and area legends), Character Styles (for text legends) and Symbols (for point legends) will automatically be generated and added to the respective Illustrator palettes.

To qualify for legend conversion, legend art in legacy documents must contain the following properties:

a) be of a valid art type: i.e. polygon, path, symbol or text
b) have a legend expression assigned (via Assign Legend Info or Auto Assign Legend Info)
c) have a target MAP Layer

During the conversion process you will be asked to set additional conversion preferences:

1. Determine if target MAP Layers should be immediately assigned to the applicable stylesheet. Checking this option will immediately apply the new stylesheets to map art on target layers, whereas unchecking this option means the new stylesheets will not be applied on document open, allowing you to manually drag target layers into the applicable stylesheet later. Note auto assignment conversions are slower.

2. Determine if you wish to merge similar converted stylesheets (i.e. stylesheets with a matching feature type and original map layer) into a single stylesheet. Note this option will be disabled if it is not applicable.

Tables

MAPublisher Table functions have been removed in this release, being replaced by a new Import Table tool. Table information held on table layers (i.e. ‘MPTables’ layers) will be removed on document open. Therefore ensure that all tables have been joined to the vector art prior to opening the document in MAPublisher 7.x.

ALL MAPUBLISHER DOCUMENTS IN ILLUSTRATOR 10 (OR EARLIER) FORMAT

Legacy Text Conversion

Adobe introduced new methods on dealing with text art in Illustrator CS. Therefore files containing MAPublisher text objects must be converted using Illustrator’s AND MAPublisher’s text conversion utilities.

If the Illustrator Legacy Text Conversion prompt is shown when opening a legacy document, you must click ‘OK’. This will allow MAPublisher to use its own conversion utility to update text items. If you click ‘Update’ the document will be opened, however all attributes associated with this text will be lost.

When receiving the MAPublisher Legacy Text prompt, choose one of the following:

✓ ‘All text art’ to convert both MAPublisher text and regular Illustrator text to the new Illustrator text format.

✓ ‘MAPublisher text art only’ to convert only MAPublisher text to the new Illustrator text format.

✗ ‘Nothing’ to open the file but lose attribute information associated with MAPublisher text elements.
Installation Instructions

Please note that MAPublisher is licensed for use on a single computer and once activated will be node-locked to that computer and will only function on that computer. Therefore, before proceeding with installation and activation on this and the following pages please ensure that you are installing MAPublisher on the computer upon which you intend to use it.

WINDOWS

1. Make sure that you have a compatible version of Adobe Illustrator installed on your computer. If Adobe Illustrator is running, exit the program.

2. **CD version:** Insert the MAPublisher 7 CD into your CD-ROM drive. If Autorun is disabled on your system, navigate to the ‘MAPublisher 7.x’ directory on the CD, and double click the ‘Setup.exe’ file.
   **Electronic version:** Double click the ‘mp7xwi-e.zip’ file to open the WinZip self extractor. When you have unzipped the files proceed to the ‘MAPublisher 7.x’ directory and double click the ‘Setup.exe’ file.

3. Proceed through the installation screens as instructed. You will have options to install documentation and tutorial data. If you choose to install these components these files can be subsequently be found here: *Start > All Programs > Avenza > MAPublisher > Tutorial Data.*

4. Launch Adobe Illustrator. *Please proceed to the section on Registration and Licensing on the following page.*

MACINTOSH

1. Make sure that you have a compatible version of Adobe Illustrator installed on your computer. If Adobe Illustrator is running, exit the program.

2. **CD version:** Insert the MAPublisher 7 CD into your CD-ROM drive. Navigate to the ‘MAPublisher 7.x’ directory on the CD, and double click the ‘Install MAPublisher 7.x’ icon.
   **Electronic version:** Unstuff the ‘mp7xmi-e.dmg’ file if this operation has not been completed automatically. Then proceed to the ‘MAPublisher 7.x’ folder and double click the ‘Install MAPublisher 7.x’ icon.

3. Proceed through the installation screens as instructed. Note that documentation and tutorial data will also be installed. After installation, these files can be found in the *Applications/Avenza/MAPublisher/Tutorial Data.* An Alias to this folder will be created at the end of the installation process which will be placed on your desktop.

4. Launch Adobe Illustrator. *Please proceed to the section on Registration and Licensing on the following page.*

**Note:** You may install different full version releases (ie. 7.x and 6.x) on the same computer if you have two versions of Adobe Illustrator. For example MAPublisher 7.5 with Illustrator CS3 and MAPublisher 6.2 with Illustrator 10. However, you **cannot** have two point-releases of MAPublisher 7.x on the same machine even if you have two different versions of Illustrator. Thus you cannot operate MAPublisher 7.5 with Illustrator CS3 and MAPublisher 7.2 with Illustrator CS on the same computer.
Registration and Licensing

MAPublisher will fail to function until activated. The following instructions are for the activation of single-user licenses of MAPublisher 7 only. If you have purchased a floating license please refer to the floating license installation guide provided with your purchase. MAPublisher 7 is available in both single-user and floating license configurations. Floating licenses are designed to allow an organization to deploy a specific number of licenses that can be used and shared on any number of computers over a network.

**IMPORTANT:** Laptop users with a docking station must activate MAPublisher in the undocked state. All users with both wireless and fixed NIC’s should disable the wireless NIC temporarily before activating MAPublisher and then activate using a wired Internet connection.

**ACTIVATING A PURCHASED COPY OF MAPUBLISHER**

1. To activate MAPublisher 7 you must enter the Serial Number which was provided when you purchased the product. The following guidelines can also be used to re-activate if you have inadvertently deleted your license file from your hard drive.

2. After installation of MAPublisher 7, launch the version(s) of Adobe Illustrator you installed to. The Activation Wizard will appear automatically.

   *If you wish to continue to use Illustrator without MAPublisher, you can cancel this wizard and activate MAPublisher later by navigating to the Help menu in Adobe Illustrator and then to MAP Security > Register.*

   **If you are connected to the internet**, select the ‘I want to activate the software over the internet’ option and click the ‘Next’ button. At the second screen, select the option for ‘I have already purchased MAPublisher and want to activate it now’ and then proceed through the wizard as instructed to complete the activation.

   **If you cannot activate over the internet**, select the ‘I want to activate the software by telephone or email’ option and click the ‘Next’ button. Then go to www.avenza.com/register or email (activation@avenza.com) or phone and provide the Machine ID displayed in the Finish screen. We will then send you an email with a zipped license file attachment. You must unzip this attachment and save the ‘.lic’ file to the appropriate folder*.

**ACTIVATING AN EVALUATION VERSION OF MAPUBLISHER**

1. After installation of the MAPublisher 7 Demo, launch the version of Adobe Illustrator you installed to. The Activation Wizard will appear automatically.

   *If you wish to delay the start of your 14 day evaluation period, you can cancel this wizard. When you are ready to activate MAPublisher, navigate to the Help menu in Adobe Illustrator and then to MAP Security > Register.*

   **If you are connected to the internet**, select the ‘I want to activate the software over the internet’ option and click the ‘Next’ button. At the second screen, select the option for ‘I want to activate a 14 day evaluation version’ and then proceed through the wizard as instructed to complete the activation.

   **If you cannot activate over the internet**, select the ‘I want to activate the software by telephone or email’ option and click the ‘Next’ button. Then go to www.avenza.com/register or email (activation@avenza.com) or phone and provide the Machine ID displayed in the Finish screen. We will then send you an email with a zipped license file attachment. You must unzip this attachment and save the ‘.lic’ file to the appropriate folder*.

2. When you are ready to purchase the software you can re-open the Activation Wizard at MAP Security > Register and follow the instructions listed on the second screen.

   *Windows XP default location: C:\Documents and Settings\All Users\Application Data\MAPublisher 7
   *Windows Vista default location: C:\ProgramData\Avenza\MAPublisher
   *Macintosh default location: Applications/Avenza:MAPublisher 7/MAPublisher Plug-In

Getting Started: Registration and Licensing
The MAPublisher Tools

MAPublisher’s tools can be found at a number of locations in Adobe Illustrator.

The MAPublisher Importers can be found under the **File** menu and using the keyboard shortcuts.

MAPublisher’s Edit MAP Object* function can be found under the **Object** menu.

*for editing Scale Bars, Grids and Graticules (menu item name is adjusted accordingly)

The MAPublisher palettes can be found under the **Window** menu.
The MAPublisher filters can be found under the Filter menu.

4 MAPublisher tools can be found in the main Adobe Illustrator Tools palette.
Preparing the Workspace

Before you can start using MAPublisher, you must first set up your Adobe Illustrator document. It is at this point that you define your page size and units, set your print orientation and generally prepare your Adobe Illustrator workspace.

It is imperative that you establish the desired page size and orientation BEFORE importing map data as MAPublisher will establish georeferencing based on the current page. Editing page dimensions after import will damage georeferencing and may require you to manually correct the geographic parameters.

SETTING UP YOUR DOCUMENT

1. Create a new Illustrator document by selecting File > New, or Select File > Document Setup if you already have a blank document open
   - The Adobe Illustrator Document Setup window appears

2. Select the size to use for your page. Letter (8.5” x 11”) is the default size*. You may wish to change the orientation to landscape for some files. For example, a map of Chile may be best displayed in Portrait but a map of Indonesia may be best displayed in Landscape.

3. Select your desired page units. The default unit type is Points.

4. Ensure the page origin is at 0,0. To do this, select View > Show Rulers. Double-click the top left corner of the rulers where the vertical and horizontal rulers intersect.

For more information and details regarding these operations please refer to your Adobe Illustrator User Guide.

* In step 2 the default page size of 8.5” x 11” is for North American versions of Adobe Illustrator. Other language versions of Adobe Illustrator may have different default page sizes. Consult your Adobe Illustrator User Guide for more information.
Chapter 2
Map Data File Formats

The key to making maps with MAPublisher is the GIS data file formats it supports. GIS files are precise geographic data files that contain vector information and associated data attribute tables.

MAPublisher 7 will import AND export most of the industry leading vector file formats:

**Import Formats**
- CAD (*.dx) (*.dwg)
- ESRI ArcInfo Export (*.e00)
- ESRI ArcInfo Generate (*.gen)
- ESRI Shape (*.shp)
- MapInfo MIF/MID (*.mif / *.mid)
- MapInfo TAB (*.tab)
- MicroStation Design (*.dgn)
- TIGER/Line (*.rt1) (*.bw1)
- Digital Line Graph (*.dlg) (*.opt)
- Spatial Data Transfer Standard (SDTS) (*.ddf)
- Delimited Text Data (*.txt) (*.csv) (*.tsv)
- KML (*.kml)

**Export Formats**
- CAD (*.dx) (*.dwg)
- ESRI ArcInfo Export (*.e00)
- ESRI ArcInfo Generate (*.gen)
- ESRI Shape (*.shp)
- MapInfo MIF/MID (*.mif / *.mid)
- MapInfo TAB (*.tab)
- MicroStation Design (*.dgn)
- Delimited Text Data (*.txt) (*.csv) (*.tsv)
- KML (*.kml)

This section will provide an overview of the formats outlined above, as well as additional considerations when using GIS data with MAPublisher.

For an in-depth analysis of further considerations when using these formats during Import, such as supported version numbers, supported colours and strokes, etc, please see pages A1/2 to A1/10.
AutoCAD Drawing (*.dwg) and Drawing Exchange (*.dxf)
Import and Export

These file types are most commonly created by Autodesk’s AutoCAD product, though other software programs such as Bentley MicroStation and various other computer-aided design (CAD) programs are capable of creating files in this format. There are two formats used by AutoCAD: DXF (drawing exchange format) files, which are large, and ASCII representations of the binary DWG (drawing) files. Logically, both files are identical and, therefore, MAPublisher treats both file types in the same manner. AutoCAD files consist of drawing settings and configurations, as well as a series of entities, or graphic elements, organized into layers. MAPublisher provides broad support for many AutoCAD entity types and options. Prior to import set the colour mode of the Illustrator document to the same scheme used in the colour table of the CAD file (i.e. RGB or CMYK) to ensure colours are imported correctly.

Note the hierarchy of layers in multi-feature imports is by feature type: text layers, then point, then line, then area layers.

ESRI ArcInfo Export (*.e00)
Import and Export

ArcInfo Export files are created by ESRI’s ArcInfo product. A single E00 file describes a complete ArcInfo coverage. The file itself is actually an archive of several smaller files, or sub files, which will have fixed names and follow a predefined data format. MAPublisher will reproduce these sub files as distinct Illustrator layers on import. Therefore importing a single e00 import can result in the generation of point, area, line and text layers.

Note the hierarchy of layers in multi-feature imports is by feature type: text layers, then point, then line, then area layers.

ESRI ArcInfo Generate (*.gen)
Import and Export

ArcInfo Generate files are created by ESRI’s ArcInfo product, and have a simple ASCII ‘from x-y to x-y’ format. Due to its simplicity you can also use a text editor such as Notepad to create text files and save them with a *.gen extension, which can then be imported with MAPublisher.

ESRI Shapefile (*.shp)
Import and Export

Shapefiles are most commonly created by ESRI’s ArcView product although other products, including MAPublisher, are capable of generating files in this format. Shapefiles store both geometry and attributes for features, and a single shapefile will consist of at least three physical files. The .shp portion contains the geometric data, the .dbf contains attributes for the geometric data, and the .shx contains the index information. All three files are required in order to successfully import a shapefile to Adobe Illustrator using MAPublisher. There is also usually a .prj file, which holds the coordinate system information of the shapefile and will automatically be read by MAPublisher on import. If your shapefile folder does not contain a .prj file you will be required to specify the coordinate system in order to fully utilize MAPublisher. The important things to remember when importing shapefiles are that the .shp file must be the one that is selected through the MAPublisher import filter and that all its component files must be in the same folder. You may also find that your shapefile directory comes with two extra files, a .sbn and a .sbx, which hold the spatial index for the geometric data. These two files will not exist unless the shapefile was created with an ESRI product, and are not necessary for successful import with MAPublisher.
**MapInfo Interchange (*.mif/*.mid)**

*Import and Export*

Files of this type are most commonly created by the MapInfo product, though other products, including MAPublisher, are also capable of generating files in this format. These files exist in pairs where each file has the same name but ends in either a .mif or .mid. file extension. The .mif portion contains the vector geometric data, and the .mid contains the associated attributes. Both files are required in order to successfully import a file of this format to Adobe Illustrator using MAPublisher. The important things to remember when importing MapInfo files are that the .mif file must be the one that is selected through the MAPublisher import filter and that both files must be in the same folder. MAPublisher will automatically locate and deal with the .mid file.

**MapInfo Table (*.tab)**

*Import and Export*

The TAB format is a simple, non-topological format for storing the geometric location and attribute information of geographic features, and is an integral part of the MapInfo product. The TAB format defines the geometry and attributes of geographically-referenced features in several files with specific file extensions that are stored in the same folder on disk. They are:

- .tab – main file: table structure in ASCII format.
- .map - the file that stores the feature geometry.
- .id - the file that stores the index of the feature geometry.
- .dat - the dBASE file that stores the attribute information of features.
- .ind - table field indexes (if necessary)

The geometry of each feature is stored as a shape that comprises a set of vector coordinates. The attributes for each feature are stored as a record in a dBASE table (.dat) associated with the shapefile (.map). There is one record in the dBASE table for each feature in the map file.

To ensure successful import, select the .tab component in the MAPublisher importers.

**MicroStation Design (*.dgn)**

*Import and Export*

MicroStation Design files (.dgn) are the native files created by Bentley Systems Inc.'s (and formerly Intergraph's) MicroStation product. Design Files consist of a header, followed by a series of elements. The header contains global information including the transformation equation from design units to user coordinates, as well as the dimension of the elements in the file. Each element contains standard display information, such as its colour, level, class, and style, as well as a number of attributes specific to its element type.

During the import process MAPublisher will reproduce .dgn ‘levels’ as distinct Illustrator layers. Therefore a typical single import will produce one layer for each Level that exists in the MicroStation Design File.

MAPublisher supports the import of MicroStation J (version 7) and V8 files. Files are exported to DGN from MAPublisher as MicroStation J files.

Prior to import set the colour mode of the Illustrator document to the same scheme used in the colour table of the original file (i.e. RGB or CMYK) to ensure that the colours are interpreted correctly upon import.

The hierarchy of layers in multi-feature imports is by feature type in the following order: text layers, then point layers, then line layers, then area layers.
Delimited Text Data (*.txt) (*.csv) (*.tsv)

Import and Export

MAPublisher also supports the import of Delimited Text Data held in a variety of tabular file formats, as long as the data contains coordinate values. File types supported are Text (.txt), Tab Separated (.tsv) and Comma Separated (.csv) files. Import Settings dialog: In order to import point data with MAPublisher you must set parameters by clicking the ‘Settings’ button. This operation is required to choose the columns of the selected attribute file that will be used to derive the X and Y coordinates of the data, and ensure correct georeferencing. These and further settings will be discussed in the Delimited Text Data Settings section on page A1/10.

KML (*.kml)

Import and Export

Keyhole Markup Language (KML) is an XML-based language for managing the display of three-dimensional geospatial data in the programs Google Earth, Google Maps, Google Mobile and WorldWind. The KML file specifies a set of features for display. Each feature always has a longitude and a latitude and can have other data, such as tilt, heading, and altitude. KML shares some of the same structural grammar as GML. KML files are very often distributed as KMZ files, which are zipped KML files with a .kmz extension. KMZ files are not supported in this version of MAPublisher.

TIGER/Line (*.rt1) (*.bw1)

Import only

‘TIGER’ is an abbreviation of ‘Topologically Integrated Geographic Encoding and Reference System’, and was developed by the U.S. Census Bureau. TIGER/Line files are a digital database of geographic features, such as roads, railroads, rivers, lakes, political boundaries, census statistical boundaries, etc., that cover the entire United States. The database contains information about these features such as their location in latitude and longitude, the name, the type of feature, address ranges for most streets, the geographic relationship to other features, and other related information. TIGER/Line files are the public product created from the Census Bureau’s TIGER database of geographic formation. TIGER was developed in order to support the mapping and related geographic activities required by the census and sample survey programs. More information on the TIGER/Line file format and data product can be found on the US Census web page at: http://www.census.gov/geo/www/tiger/

MAPublisher considers the .rt1 or .bw1 file as the TIGER dataset. Even though each county will consist of a series of files with a common base name, there may be a number of different extensions. Remember to select the .rt1 or .bw1 file when importing TIGER data.

USGS Digital Line Graph (*.dlg) (*.opt)

Import only

The United States Geological Survey’s DLG file structure is designed to accommodate categories of spatial data represented on a conventional line map. Node (point), line, and area data types are accepted. The attribute coding scheme is designed to accommodate basic cartographic data categories such as hypsography, hydrography, or political and cultural features, as well as additional thematic data categories.
Digital cartographic products of the USGS are available in the Spatial Data Transfer Standard format, and are generally distributed over the Internet as a means of promoting the standard. For SDTS import, select the ‘catd’ file (xxxxcatd.ddf), which is the index file that contains a description of the other files in the SDTS transfer. Individual DDF files cannot be imported. Generally all SDTS downloads will contain the CATD file.

DATA CONSIDERATIONS

When obtaining GIS data for use with MAPublisher, whether from an online source, commercial vendor, government office or from an internal source within your organization, there are a number of important considerations to keep in mind.

First and foremost you should always endeavour to obtain data in one of the formats supported by the MAPublisher Importers (see pages 21-25). In cases where the file format native to a particular mapping application is not supported by MAPublisher, you can often request the data provider to export a file in one of the supported formats.

When obtaining data you should acquire as much meta-data about the files as possible. MAPublisher deals with data in the following manner: Unprojected data will be imported by MAPublisher with latitude and longitude map anchors, which will therefore range from (x) -180 to 180, (y) -90 to 90. Unprojected data will also import with a non-earth scale.

If you receive projected data you should be aware of the following. MAPublisher will import projected data with a true scale and appropriate map anchors. Unlike unprojected data, these map anchors will not be in lat/long, but rather in a coordinate system appropriate for the particular projection. For most file formats the name of the projection, datum, and units will be recognized by MAPublisher. However if the program cannot find this information in the data, and you wish to subsequently reproject your data, you will be required to specify the coordinate system.

Additionally, please be aware that MAPublisher is a 2D mapping program. Therefore if you attempt to import 3D data with MAPublisher it will be converted to two dimensional artwork by the importers.

NOTE: Data provided in a generic latitude and longitude (unprojected) coordinate system will usually be recognized as a WGS 84 (World Geodetic System 1984) coordinate system by the MAPublisher importers.
Chapter 3

Importing Map Data

The Import filters are the main starting point for most users wanting to work with GIS map data in Adobe Illustrator. These are the filters that must be used to import GIS data files, set the initial map scale and define your cartographic workspace to start making maps.

MAPublisher supports the Import of the following GIS data formats:
- CAD (*.dxf) (*.dwg)
- ESRI ArcInfo Export (*.e00)
- ESRI ArcInfo Generate (*.gen)
- ESRI Shape (*.shp)
- MapInfo MIF/MID (*.mif / *.mid)
- MapInfo TAB (*.tab)
- MicroStation Design (*.dgn)
- TIGER/Line (*.rt1) (*.bw1)
- Digital Line Graph (*.dlg) (*.opt)
- Spatial Data Transfer Standard (SDTS) (*.ddf)
- Delimited Text Data (*.txt) (*.csv) (*.tsv)
- KML (*.kml)

See pages 21 to 25 for a description of these formats.

There are two Import filters available, which will be discussed in detail in this section:

**Simple Import**: This filter is designed to provide a fast way to import one file, or several files of the same data format and coordinate system into Adobe Illustrator.

**Advanced Import**: This filter provides functionality to import a number of files of differing data type and/or coordinate systems into Adobe Illustrator.
Simple Import
File > Import Map Data > Simple

Simple Import
Format - Select the data type you wish to import. This dropdown lists the names of all MAPublisher supported data types.

Dataset - Displays the directory path and filename for the currently selected file(s). You can also manually type in the dataset location here.

Source Coordinate System - Provides a description of the coordinate system and units detected in the data source.

Same as - Check this option in order to assign a coordinate system that matches that of an existing MAP View.

Specify - If the coordinate system of the selected file(s) is known, but it was not automatically generated by the program, click here. This will open the Specify Source Coordinate System function (below).

Clear - Click this button to clear the existing parameters of the source coordinate system.

Settings - Opens a Settings box if the file format requires the input of extra parameters, such as for the import of DGN, DXF, DWG, E00, KML, MIF/MID, Tab and Delimited Text Data (see facing page).

Browse - Opens a Data Source browser to enable the selection of files for import.

Character Encoding - Assign a codec if the attribute information held in the selected dataset uses a double byte character set.

Format - Select the data type you wish to import. This dropdown lists the names of all MAPublisher supported data types.

Dataset - Displays the directory path and filename for the currently selected file(s). You can also manually type in the dataset location here.

Source Coordinate System - Provides a description of the coordinate system and units detected in the data source.

Same as - Check this option in order to assign a coordinate system that matches that of an existing MAP View.

Specify - If the coordinate system of the selected file(s) is known, but it was not automatically generated by the program, click here. This will open the Specify Source Coordinate System function (below).

Clear - Click this button to clear the existing parameters of the source coordinate system.

Settings - Opens a Settings box if the file format requires the input of extra parameters, such as for the import of DGN, DXF, DWG, E00, KML, MIF/MID, Tab and Delimited Text Data (see facing page).

Browse - Opens a Data Source browser to enable the selection of files for import.

Character Encoding - Assign a codec if the attribute information held in the selected dataset uses a double byte character set.

**Related Tools**

Specify Source Coordinate System
Accessed via the Specify button.

Coordinate Systems - Choose a category appropriate to the data to be imported. To view all of the coordinate systems select *All*. For a list of the last 10 coordinate systems used, select *Recent*.

Search - Specify a text string to search the database for coordinate systems. Results are displayed in the "Search" category.

Coordinate System Information - This area shows information about the coordinate systems. (ie. Name, Type, Envelope, EPSG Code). To choose a known source coordinate system select it from this list.

Search - Press this button and your search results will be populated.

Resize - Drag the lower right corner of the palette down to expand the Projection List.

**Matching MAP View**
Automatically opens if there is already a coordinate system in your document which matches the incoming data.

Add to - Add the incoming data file to a matching MAP View in MAPublisher.

Resize MAP View to fit - Check this box to rescale the matching data so that both the selected layer and the incoming data fit inside the page extents.

MAP View list - Select the matching coordinate system that you wish to align the incoming data to.

Fit to page based on new MAP View - Both the matching coordinate system and incoming data will be treated separately in terms of page scaling.
Import Settings

**Delimited Text Data Settings**

**XY Columns** - These two dropdown lists hold the names of all the numeric columns in the selected file. Select the columns from which the X coordinates and the Y coordinates for each point will be read.

**Use first line as a header** - If the first line of the text file you are importing contains column headings, check this box.

**Coordinate Format** - This dropdown list allows the format of the data to be set on import (ie. DMS, Decimal Degrees, Packed DMS).

**AutoCAD DXF/DWG Settings**

**Group Entities By** - Group entities by layer Name or geometry.

**Hatches** - Check this box if you want MAPublisher to read your hatch pattern on import.

**White Lines and Fills** - Enabling the 'Import as is' option will instruct MAPublisher to import the data true to the original colour settings contained in the file. Check the 'Change white lines and fills to black' box to import black lines instead of the files native white lines. Check the 'Create black background' option to incorporate a layer containing a black background, to mimic the AutoCAD environment.

**MapInfo TAB and MIF/MID Settings**

**Pen and Brush Patterns** - Enable this box to view the pen and brush pattern values in the imported attribute table.

**ESRI ArcInfo Export Settings**

**Pen and Brush Patterns** - Enable this box to view the pen and brush pattern values in the imported attribute table.

**MicroStation Design Settings**

**Pen and Brush Patterns** - Enable this box to view the pen and brush pattern values in the imported attribute table.

**KML Settings**

**Allow Random Colour Mode** - Enabling this option will allow Illustrator to generate random colour settings for your data.

**Expand Network Links** - Checking this box will enable the use of network linked KML files.

**Import as Visible Attributes** - When this option is selected the KML-specific attributes will be imported into the attribute table as a visible entities. The KML attributes that will be imported are 'Description' and 'Address' which will display in the MAP Attributes window as kmlDescription and kmlAddress. The description column will show the description of each object and the address column will show the corresponding address for that object. When this option is not selected the attributes will still be imported, however they will not be immediately visible in the MAP Attributes table.

**Importing Map Data: Settings Dialogs**
SIMPLE IMPORT FUNCTIONALITY

The Simple Import function provides a fast, uncomplicated method of importing map data into Adobe Illustrator. Its focus is for the mapmaker who has a single piece of map data, or several smaller files comprising one dataset of the same format and coordinate system, that they wish to simply import quickly.

PREREQUISITES

In order to import data via Simple Import, you must first set up your Illustrator document. Plan for the data that you will subsequently bring in, and set up your Illustrator document accordingly. For instance a map of the world would fit well into a page with a Landscape orientation, whereas a map of South America would fit best into a page with a Portrait orientation. Also plan for the output of the map document if necessary, to ensure that your page dimensions are close to the required size that the document will be printed. It is far easier to set up the page before the map data has been imported, as MAPublisher will interpret these dimensions in the Importer, and calculate a map scale for your document accordingly. If you do edit the size of your document, remember to reset your rulers before opening either Importer in order for MAPublisher to correctly fit the data into the page extents.

Once your page has been set up you can access the MAPublisher Simple Import function under the File menu, at the Import Map Data pullout or by using the keyboard shortcut, Shift+Ctrl+I.

USING SIMPLE IMPORT

OVERVIEW

The dialog itself is split into two sections. The upper section allows you to choose a file format, select the file you wish to import, and enter any additional settings that may be required. The lower section will display the coordinate system of the selected file and allow you to specify this manually if the program has not detected a coordinate system.

ADDING FILES

In order to select a file or files for import you can either leave the Format dropdown as <Auto detect format> or set the dropdown to the file type you wish to import. If this dropdown is left as <Auto detect format>, when you search for your GIS file, all files will be displayed. It is often easier therefore to set the Format dropdown at the required format to ease navigation.

When you have chosen the format, click the Browse button to select your file(s) and then click Open. Alternatively you can type in the full path of the file(s) in the Dataset field. Note that the import of multiple of Delimited Text files is not supported.

NOTE: Data provided in a generic latitude and longitude (unprojected) coordinate system will usually be recognized as a WGS 84 (World Geodetic System 1984) coordinate system by the MAPublisher importers.
SOURCE COORDINATE SYSTEM

Once the Dataset field has been populated with a valid path, the program will read the file(s) to determine the coordinate system and display this in the Source Coordinate System section (see MAP Views on page 58).

If the program returns the message ‘[No Coordinate System Specified]’ for the coordinate system, you may click the Specify button to specify it (MAPublisher will read the coordinate system automatically if the file format supports projection information). In the Specify Source Coordinate System dialog, coordinate systems are separated into Projection categories to ease the process of choosing a coordinate system. Under the Coordinate System category *All* will list all the coordinate systems in the database. For an overview of Projections and Datums see pages A1/30 to A1/39.

If you wish to view the parameters of a certain coordinate system, click the Info button.

CHARACTER ENCODING

In MAPublisher 7, extended and international character sets are supported as attributes on import. To assign a character codec suitable for your selected dataset, choose the appropriate value from the listbox.

FORMAT SPECIFIC SETTINGS

Certain file formats will offer additional configuration parameters which can be accessed by clicking the Settings button. These file formats are ArcInfo Export, CAD DWG/DXF, MicroStation DGN, MapInfo MIF/MID, MapInfo TAB, KML and Delimited Text Data*. Select your file(s) first. If the format accepts additional settings the Settings button will be enabled. Study the Import Settings guide (page 29) for an overview of the meanings of these options.

* Additional settings are only required for the import of Delimited Text data.

DELIMITED TEXT DATA SETTINGS

MAPublisher also allows for the import of delimited text files as point data provided they contain coordinate values. Delimited text import allows the user to import many different formats including: Decimal Degrees, DMS, Degrees.Minutes, Degrees.MinutesSeconds, Delimited DMS, and Packed DMS. MAPublisher supports the import of delimited text files that contain any of the following delimiters between data values: comma, return, end of line and tab.

To import delimited text data, you must choose the Columns to use for your X & Y coordinates from the two dropdowns. Note that only numerical columns will be listed to ease the process of determining the columns to use. If the first line of the text file you are importing contains column headings, check the Use first line as a header checkbox, though MAPublisher will generally automatically detect if this is the case. If the file does not appear to contain column headers, MAPublisher will assign the default headers “Column1”, “Column2” to the attribute columns on import.
IMPORTING DATA

When you have your file(s) selected, and if necessary specified the coordinate system and/or extra settings, you can click **OK** to import.

If MAPublisher finds there is a coordinate system already in your document which matches the incoming data, the **Matching MAP View** dialog will open (see MAP Views, on page 53). If this dialog opens you must choose to either add the incoming data file to a specified MAP View, or create a new MAP View to hold the incoming data.

1. If you specify **Add to**, choose the **MAP View** from the listbox to add your incoming data to. This option will also allow you to rescale the existing and incoming data which will comprise this MAP View in order to fit them all inside the page extents. To achieve rescaling, check the **Resize MAP View to fit** option. If you do not check this option, some of your data may be imported outside of the page extents.

2. If you specify **Fit to page based on new MAP View**, the incoming data will be treated separately from the matching data, as if it was the first import.

RESULTS

The data will be imported into Adobe Illustrator as individual Illustrator layers, one for each feature type in the import. The name of these layers will be the same as the name(s) of the original imported data file with the appropriate feature type extension appended. For instance importing a single polygon file named **world.mif** would produce a single Illustrator layer called **world_area**, which contains the imported file. Additionally this layer can be seen as part of a MAP View, where Illustrator layers are automatically placed as sub-features of specific coordinate systems or MAP Views.
Advanced Import

File > Import Map Data > Advanced

File Name - The directory path of the map file(s) to be imported.

File Numbers - Allows the selection of individual files in order to activate the Edit and Remove buttons.

Add - Allows the selection of files for import by opening the Advanced Import Data Source function (see below).

New based on - Imports all of the files to one of the coordinate systems in the File List.

Use existing - Allows you to import all of the files in a coordinate system that already exists in a MAP View in the document.

Auto scale - If you have multiple files in the File List, and have selected the ‘New Based On’ or ‘Use Existing’ options, check this box to ensure all the files fit inside the page extents when imported.

Create new - Allows you to import all of the files in a new coordinate system. Clicking the ‘Editor’ button opens the MAP View Editor (see page 59).

Related Tools

Advanced Import Data Source

Accessed via the Add or Edit button.

Format - Select the data type you wish to import. This dropdown lists all MAPublisher supported data types.

Dataset - Displays the directory path and filename for the currently selected file(s). You can also manually type in the dataset location here.

Source Coordinate System - This section allows the manual selection of the coordinate system if this information is not held in the data source.

Same as - Check this option in order to assign a coordinate system that matches that of an existing MAP View.

Info - Click this button to view the parameters of a selected coordinate system.

Settings - Opens a Settings box if the file format requires the input of extra parameters, such as for the import of DGN, DXF, DWG, E00, KML, MIF/MID, Tab and Delimited Text Data (see page 29).

Browse - Opens a Data Source browser to enable the selection of files for import.

Character Encoding - Assign a codec if the attribute information held in the selected dataset uses a double byte character set.

Clear - Click this button to clear the existing parameters of the source coordinate system.

Specify - Click this button to open the Specify Source Coordinate System tool (Page 58), enabling you to search for coordinate systems by specifying a text string. Results are displayed in the *Search* category.

Import Settings

See page 29 for the Import Settings dialog.
ADVANCED IMPORT FUNCTIONALITY

Advanced Import provides an alternative method of importing map data into Adobe Illustrator. Its focus is for the mapmaker who has a collection of map data, that they wish to import into Adobe Illustrator at the same time. This function can deal with import of multiple formats and varying coordinate systems, with the dialog providing a list of files flagged for import.

PREREQUISITES

In order to import data via Advanced Import, you must first set up your Illustrator document. Please see the guidelines for setting up your page that are included in the Simple Import ‘Prerequisites’ section (page 30).

Once your page has been set up you can open MAPublisher Advanced Import. This is located under the File menu, at the Import Map Data pullout or by using the keyboard shortcut, Alt+Shift+Ctrl+A.

USING ADVANCED IMPORT

DIALOG OVERVIEW

The dialog itself is comprised of a list box for the display of currently selected files; buttons to Add, Remove, or Edit files for Import; and a section for the specification of an output coordinate system, whether this be in one of the files in the list, a coordinate system in the current document, or a new user specified coordinate system.

ADDING FILES

In order to select a file or files for import first click the Add button. In the Advanced Import Data Source dialog you can either leave the Format dropdown as <Auto detect format> or set the dropdown to the file type you wish to import. If this dropdown is left as <Auto detect format>, when you search for your GIS file, all files will be displayed. It is often easier therefore to set the Format dropdown at the required format to ease navigation.

When you have chosen the format, click the Browse button to select your file(s) and then click Open (only one file format can be opened from this Open dialog). Alternatively you can enter the path of the file(s) in the Dataset field. Note that the import of multiple of delimited text files is not supported.

CHARACTER ENCODING

In MAPublisher 7, double byte characters are supported in attributes on import, allowing such attributes to be used for labeling and export. To assign a codec suitable for your selected dataset, choose a value in the listbox.

SOURCE COORDINATE SYSTEM

If you are aware that your selected files do not contain Coordinate System information, you can either specify it within the Advanced Import Data Source dialog, or you can assign a coordinate system based on an existing MAP View in your document by using the Same As feature. For an overview of Projections and Datums see pages A1/30 to A1/39. Generally most users should ignore the Coordinate System section when choosing the Import files, as the program will read the coordinate system automatically if the file format supports such information.

If you wish to view the parameters of a certain coordinate system, click the Info button.
FORMAT SPECIFIC SETTINGS

Certain file formats will offer additional configuration parameters which can be accessed by clicking the **Settings** button. These file formats are ArcInfo Export, CAD DWG/DXF, MicroStation DGN, MapInfo MIF/MID, MapInfo TAB, KML and Delimited Text Data*. Select your file(s) first. If the format accepts additional settings the Settings button will be enabled. Study the Import Settings guide (page 29) for an overview of the meanings of these options.

*Additional settings are only required for the import of Delimited Text data.

DELIMITED TEXT DATA SETTINGS

MAPublisher also allows for the import of delimited text files as point data provided they contain coordinate values. Delimited text import allows the user to import many different formats including: Decimal Degrees, DMS, Degrees.Minutes, Degrees.MinutesSeconds, Delimited DMS, and Packed DMS. MAPublisher supports the import of delimited text files that contain any of the following delimiters between data values: comma, return, end of line and tab.

To import delimited text data, you must choose the **Columns** to use for your X & Y coordinates from the two dropdowns. Note that only numerical columns will be listed to ease the process of determining the columns to use. If the first line of the text file you are importing contains column headings, check the **Use first line as a header** checkbox, though MAPublisher will generally automatically detect if this is the case. If the file does not appear to contain column headers, MAPublisher will assign the default headers “Column1”, “Column2” to the attribute columns on import.

ADVANCED IMPORT FILE LIST

Once the **Dataset** field has been populated with a valid path and you have clicked OK, the program will close the **Advanced Import Data Source** dialog and either read the selected file(s) to determine the coordinate system, or attach your specified coordinate system to the files. The file(s) will now be listed in the **Advanced Import** dialog.

You can now add more files to this list (for instance adding the next file format) by re-clicking the **Add** button and proceeding in the same manner as specified above.

There are two columns present in the Advanced Import list. The first will display the full path of each file, and the second will display the coordinate system that has either been automatically read by the program or assigned manually. Each file added to the Import list will have a row number that can be clicked in order to select it. This function will allow you to remove a selected file from the Import list; or edit a selected file. Therefore to remove a selected file or number of selected files from the Import list click the **Remove** button.
CHANGING COORDINATE SYSTEMS PRIOR TO IMPORT

If the program displays Unknown for the Coordinate System of a file, you may select the row and click the Edit button to specify it by returning you to the Advanced Import Data Source dialog.

Note that you can only import the listed files in a single coordinate system, even though they may comprise of several. Therefore the Destination MAP View section holds the details of which coordinate system the listed files will be imported in. The coordinate system the file(s) will be imported in will be displayed in the panel in this section, and will show the Name of the coordinate system, its Map & Page Anchors, Scale and Angle for the selected file. These settings will be discussed more in Attributes and Georeferencing.

DESTINATION MAP VIEW

You have three choices when deciding the destination coordinate system for the imported files:

1. You can choose to import all of the listed files in the coordinate system and parameters that exists in one of the listed files. Click New based on and then select one of the files in the coordinate system you require. If you have multiple files in the File List, you can check the Auto scale option to ensure that when the data is imported, it is scaled to fit the current page extents. If you do not check this option, some of your data may fall outside of the page extents during the import process.

2. Choose to import all of the listed files in the coordinate system and parameters that currently exists in the document (for example via a previous import). In this case select Use existing and then select the MAP View containing the desired coordinate system. Check the Auto scale option to ensure the combination of incoming and existing data will be fit inside the page extents, i.e. existing data may be rescaled as a result. If you do not check this option, some of your data may be imported outside of the page extents.

3. Choose to assign another coordinate system completely by first selecting the Create new option, and then clicking Editor. This will open the MAP View Editor, allowing you to specify a coordinate system from a projection list and make numerous page scaling edits. For an in depth look at this tool, see page 59.

RESULTS

When you have your file(s) selected, and if necessary specified the coordinate system and/or extra settings, you can click OK to import. The data will be imported into Adobe Illustrator as individual Illustrator layers, one for each feature type in the import. The name of these layers will be the same as the name(s) of the original imported data files with the appropriate feature type extension appended. For instance importing a polygon file named county.mif and a line file named roads.shp, would produce two Illustrator layers named county_area and roads_line, which contain the imported files. Additionally these layers will be seen as part of a MAP View, where the Illustrator layers will be automatically placed as sub features of a single coordinate system, that being the singular coordinate system specified in the Destination MAP View section of the Advanced Import dialog.
MAPublisher’s ability to import GIS files into Illustrator while retaining both geographic vector and attribute information makes it very easy to produce high quality maps.

This section will explain the principles of georeferencing and attribute information and how these are maintained within MAPublisher. The following related tools and concepts will be examined:

- Property Attributes
- MAP Location Tool
- MAP Attributes
- Edit Schema
- Edit Expression
- Import Table
- Find and Replace Attributes
- Apply Expression
Attributes & Georeferencing - Foreword

GEOREFERENCING

Georeferencing in MAPublisher is based in part on the relationship between Page Anchors and Map Anchors. MAPublisher bases its georeferencing on a tie in point within Adobe Illustrator. During the import process, the software will treat the point at (0,0) in the document (Page Anchors) as being coincident to the lower left corner of the data in real world coordinates (Map Anchors). MAPublisher will use this anchor point in subsequent data transformations, such as rescaling and reprojecting, and will also be used in the creation of grids and to maintain georeferencing on export.

The most common way to set up an Illustrator page is to set the (0,0) point as being the coincident with the lower left corner of the document. When you open a new document in Illustrator, and choose to view the rulers, you will see that the point at (0,0) in document units is at this location. Therefore when MAPublisher imports a GIS file, it will place a lower left point with real world coordinates at this (0,0) point. Consequently a map of the world in Latitude/Longitude, imported into a new Illustrator document with the units set to inches, would produce a tie in point of X = 0°, Y = 0° for the Page Anchors, and X = -180°, Y = -90° for the Map Anchors. From this point on these two points are dynamically linked. Note that in MAPublisher dialogs, Map Units are displayed in the coordinate system of the layer.

ATTRIBUTE INFORMATION

The attribute table that forms part of a GIS map file is one of the most important parts of any data set. It is in the attribute table that we find important information such as street names for lines, zoning or zip code numbers for areas and elevations for points to go along with our vector line, area or point data. Along with vector line, area and point data imported as explained in the previous sections, MAPublisher also imports the attribute data table associated with any vector map file that it supports. Please refer to the ‘MAP Attributes’ section (page 41) for information on viewing and editing attributes.

MAP LAYERS

Throughout this guide, an Illustrator Layer containing georeferencing and/or attribute information will be referred to as a MAP Layer.

Each MAP Layer which can contain attribute information is symbolized in MAPublisher palettes and dialogs with an icon depicting its feature type:

- Area layer  (e.g. county boundaries, urban areas, country outlines etc.)
- Line layer   (e.g. rivers, roads, railways etc.)
- Point layer  (e.g. town and city symbols, railway stations etc.)
- Text layer   (e.g. text labels)
MAPUBLISHER #PROPERTY ATTRIBUTES

New with MAPublisher 7.x is the concept of property attributes for map data. In addition to the attribute values that were created upon data import or within a work session, Area, Line, Point and Text layers will also be assigned a number of additional MAPublisher attribute columns. These ‘Property’ columns (prefixed with a “#”) are designed to indicate the physical properties of map art on the Illustrator canvas. Art can be modified directly from the attribute table by making edits to values in these columns.

The following property columns are attached to valid map layers in this version of MAPublisher:

**Area layers**

- **#AreaDirection** describes the direction as ‘clockwise’ or ‘counter-clockwise’. Editing this value will reverse the direction accordingly.
- **#VertexCount** describes the number of points in the art. This property cannot be set.
- **#Style** describes the Graphic Style in use. Editing this property will apply the selected style to the art.
- **#StrokeWeight** describes the stroke weight of the path. Editing this property will alter the stroke weight of the art.
- **#Perimeter** describes the perimeter of the area in world units. This property cannot be set.
- **#PathClosed** describes whether or not the path is closed (yes or no). Editing this value will open/close the path.
- **#ArtScale** describes the scaling of the area in world units. This property cannot be set.
- **#Name** describes the name of the polygon. Editing this property will change the name in the Layers palette.

**Line layers**

- **#VertexCount** describes the number of points in the art. This property cannot be set.
- **#Style** describes the Graphic Style in use. Editing this property will apply the selected style to the art.
- **#StrokeWeight** describes the stroke weight of the path. Editing this property will alter the stroke weight of the art.
- **#PathClosed** describes whether or not the path is closed (yes or no). Editing this value will open/close the path.
- **#Length** describes the length of the path in world units. This property cannot be set.
- **#ArtScale** describes the scaling of the line stroke. Editing this value will scale the stroke weight.
- **#Name** describes the name of the paths. Editing this property will change the name in the Layers palette.

**Point layers**

- **#HorizontalScale** describes the horizontal scaling of a point object. Editing this value will scale the symbol in the X axis.
- **#VerticalScale** describes the vertical scaling of a point object. Editing this value will scale the symbol in the Y axis.
- **#Rotation** describes the rotation in degrees of the art around it’s anchor point. Editing this value will rotate art.
- **#Style** describes the Symbol in use. Editing this property will apply the selected symbol to the art.
- **#Name** describes the name of the point. Editing this property will change the name in the Layers palette.

**Text layers**

- **#Text** describes the contents of the text. Editing this property will edit text on the page.
- **#TextLength** describes the number of characters in the contents of the text art. This property cannot be set.
- **#Rotation** describes the rotation in degrees of the art around it’s anchor point. Editing this value will rotate art.
- **#Style** describes the Character Style in use. Editing this property will apply the selected style to the art.
- **#Name** describes the name of the text field. Editing this property will change the name in the Layers palette.

Please refer to the ‘MAP Attributes’ section (page 41) for information on viewing and editing property attributes.
MAP Location Tool

Displays the parameters of the currently selected layer.

WX/WY - The X & Y coordinates of the cursor in current Map Units.

Scale 1: - Scale of the current layer.

Map X/Y - Map Anchors.

Units - Units of the coordinate system, if specified.

Latitude/Longitude - The X & Y coordinates of the cursor in degrees.

Angle - Angle of Rotation.

Page X/Y - Page Anchors.

Coordinate System - Coordinate system of the layer, if specified.

Copy Notification - When the location cursor is active you will see this text, enabling you to copy the current X & Y coordinates of the mouse cursor.

FUNCTIONALITY

The MAPublisher Location Tool displays the coordinates of the mouse cursor on the selected layer in current Map Units and in Degrees. When no georeferencing is present on the selected layer, the window will display the coordinates in Page Units. The window will also display the Map and Page Anchors, the Scale, Angle of rotation, and the Coordinate System and Units of the MAP Layer.

The MAP Location Tool also enables the X and Y position of the cursor in the current Map Units (WX and WY) to be copied to the clipboard. An example of a use of this function is that it enables you to build point files in an external text editor; files which can then be re-imported with MAPublisher. Coordinates are copied with the X value first and Y value second, and are delimited by a comma. For example: -79.396527,43.631979

USING THE MAP LOCATION TOOL

To use the MAP Location Tool, click on the icon in Illustrator’s Main Toolbar. With the cursor scroll around your map document, and note how the Map Units update with the location of the mouse. If you wish to stop the location values from updating in the MAP Location window as you move the mouse hold down the Apple key (Mac) or Ctrl key (Windows).

To copy the coordinates of a specific location, ensure you have the appropriate layer selected in the Illustrator Layers palette, and then with the location cursor determine the exact position you wish to copy. Then hold down the Shift key and click on the document. The X and Y position in Map Units will be copied to the clipboard. You can now paste the values into any text editor. Note that you can only copy one set of coordinates. When you shift-click again, the values copied previously will be overwritten.
MAP Attributes
Window > MAPublisher Palettes > MAP Attributes

FUNCTIONALITY
The MAP Attributes palette displays the map attribute and property attribute records for a map layer, which are linked to the map's graphic elements, and makes them available for editing. This palette is also the hub from which you can edit column schemas and visibility, add or delete columns, import tables, find and replace attributes, and apply expressions to selected art. The visible attributes of selected map features will be displayed in the window.

USING THE MAP ATTRIBUTES PALETTE
VIEWING ATTRIBUTES
If features are selected on multiple layers, you can toggle between these layers by choosing from the Layer dropdown. In addition, the number of currently selected map objects on the specified layer will also be reported at the base of the palette. The attribute values displayed in columns in the MAP Attributes window can be sorted in ascending or descending order by clicking the column header. The widths of the columns may be changed by clicking on the column separator and manually dragging it to resize as desired.
EDITING ATTRIBUTES

MAPublisher's MAP Attributes window is a fully editable spreadsheet environment. All attribute values may be edited (except for certain MAPublisher Property attributes (see page 39). To change the value of a cell double-click within the cell and enter the new value such as you would in a spreadsheet program. Keep in mind that you must enter values that correspond with a column's type (i.e. only enter numbers into a column of type “Real” or “Integer”). The edits will immediately be reflected in the map documents database records. Existing attribute records may also be edited or modified by performing a find and replace operation on them (page 43).

COLUMN VISIBILITY

Right clicking (PC) or Ctrl-clicking (Mac) on a column in the window activates an additional menu. You can edit column visibility via the Show/Hide Columns option in this menu, either toggling visibility for individual columns or for all columns. It is also possible to edit the visibility of attribute columns with the Edit Schema tool (page 44).

PROPERTY ATTRIBUTES

The attribute table can also be configured to display property attributes for your datasets (page 39). These attributes describe the current assignment of graphical properties such as the stroke weight, style, rotation and scale etc that is currently associated with the data. These fields are editable and provide the ability to modify a map objects graphical properties directly within the context of the map attribute window itself. To edit a property attribute for a particular map object you may either double click within the appropriate property cell and directly enter a value or choose from an available dropdown list depending on the property type you are editing. Once these changes have been entered into the map attribute window the modified art elements will be graphically updated within the map to reflect these changes.
**Find & Replace Attributes**

*MAP Attributes palette > Find & Replace*

---

**FUNCTIONALITY**

The Find and Replace tool allows for the searching and/or replacing of attribute values and properties contained in the MAP Attributes palette. Note only values in visible columns can be found and/or replaced.

---

**USING FIND AND REPLACE**

Access the tool by clicking the *Find & Replace* button or menu item in the MAP Attributes palette.

---

**FIND ONLY**

To use Find and Replace to simply find values, click on the *Find* tab to enter your search criteria. ‘Find’ criteria can be typed directly into the *Find what* entry field (previous criterias can be selected from the list). A search may be performed on all attributes by default, or only on specific columns contained within the map attribute window by enabling the *Just* option and choosing a column from the list. Criteria may be further refined by enabling the *Case sensitive* and *Match whole word only* options.

Once the search string has been entered click the *Find Next* button in order to perform the search. Search results can be seen in the MAP Attributes palette; the column header and row number containing the first matching record will be displayed in bold text. At this point you may progress searching for individual records by clicking again the *Find Next* button.

---

**FIND AND REPLACE**

To replace records selected through the *Find* operation click on the *Replace* tab. ‘Find’ and ‘Replace’ criteria can be typed directly into the *Find what* and *Replace with* entry fields (previous criterias can be selected from the lists). A find and replace may be performed on all attributes by default, or only on specific columns contained within the map attribute window by enabling the *Just* option and choosing a column from the list. Criteria may be further refined by enabling the *Case sensitive* and *Match whole word only* options.

There are two methods to replace values. The first method requires you to approve each replacement manually by clicking on the *Replace* button so that each instance of the attribute located via the search parameters is successively replaced in the map attribute table. The second method allows for the replacement of all found records simultaneously, accomplished by clicking on the *Replace All* button.

---
In MAPublisher 7 the term **schema** is used to define the structure and makeup of the map attributes table.

**FUNCTIONALITY**

The Edit Schema function lets you edit and manage various components of your data’s map attribute structure, including creating, editing and deleting columns, setting visibility preferences, and assigning expressions. Any changes made to the schema will instantly be reflected in the MAP Attributes window.

**USING EDIT SCHEMA**

Ensure the MAP Layer containing the attributes you wish to edit is selected in the MAP Attributes palette. Then access the tool by clicking the *Edit Schema* button or menu item in the MAP Attributes palette.

Edit Schema will list all of the columns which currently exist in the MAP Layer’s attribute structure, including MAPublisher property attributes (page 39). By default, imported or created attributes will be visible, whereas property columns will be invisible. Please note #Property column structures cannot be edited.

**EDITING COLUMN FORMAT**

To rename a column enter the new text directly into the **Name** field.

Specify a data type by making the appropriate selection in the **Type** list. Please note the following:

- ‘String’ columns can contain attributes that are both alpha and numeric.
- ‘Integer’ columns contain only whole numbers.
- ‘Real’ columns contain numbers carrying decimal values.
- ‘Boolean’ columns contain purely True or False values.

To modify the width (in characters) of ‘String’ type columns, enter a value into the **Size** field. You can also assign a
**Default Value** for all new objects placed on the selected layer by entering text accordingly. Check or uncheck the **Visible** option to edit a column's visibility. Check or uncheck the **Read-only** option to edit a column's read/write status (i.e. values cannot be edited in the MAP Attributes palette if the column is read-only).

To assign an expression to the selected column, for example to populate the column values based on the contents of other columns and/or mathematical formulas, check the **Derive value from expression** option.

Then simply enter a valid expression in the Expression field. The **Expression Validity** icon will report ☑ if the expression entered is valid. Otherwise it will report ☒ and include additional warning notes. Alternatively click on the **Browse** button to enter and edit expressions via the **Edit Expression** tool (page 46).

The following are some examples of basic expressions which can be assigned to columns in **Edit Schema**.

- **“Ontario”** (applied to column = ‘NAME’)
  
  Result: All items are assigned the value “Ontario” in the ‘NAME’ column.

- **“MAP Area 01”** (applied to column = ‘#Style’)
  
  Result: All area items are assigned the value “MAP Area 01” in the ‘#Style’ column and are assigned the Graphic Style “MAP Area 01” on the page.

- **45** (applied to column = ‘#Rotation’)
  
  Result: All point items are assigned the value ‘45’ in the ‘#Rotation’ column and are rotated to 45° on the page.

**ADDING, DELETING & RE-ORDERING COLUMNS**

Stipulations regarding the display order of attribute columns in the map attribute window can be set by reordering the existing list according to your preferences. Any column may be promoted in the list/attribute table by simply selecting it in the list and clicking on the Up and Down button to move it up or down within the list. Columns will display in the MAP Attributes window according to the display order established in Edit Schema.

To create a new column simply click on the **Add** button and input the desired column properties. To delete an existing column choose it from the available list and click on the **Delete** button.

Click the **OK** button to confirm your edits to the attribute structure on the selected layer. These edits will immediately be visible in the MAP Attributes palette.

**EDIT COLUMN**

Edit Schema can also be accessed via the **Edit Column** context menu. In the MAP Attributes palette, select the column you wish to edit and access the tool by right-clicking or CTL-clicking on an cell or attribute column heading. The Edit Schema function will be opened with the same column immediately selected in the column list for editing.

**NEW COLUMN**

Edit Schema can also be accessed via the **New Column** tool. In the MAP Attributes palette, access the tool by clicking the **New Column** button or menu item. The Edit Schema function will be opened with a new column immediately selected at the base of the column list for editing.
FUNCTIONALITY

The MAPublisher Edit Expression tool provides for the entry and edit of expressions for use in the generation of new attribute values and properties, to make selections or to apply styles. Expressions can be entered using the keyboard, and/or by selecting from listed column names, operators and functions.

Edit Expression provides functionality for a number of tools:

- **Edit Schema** (page 44): To create or edit an expression for the generation of values in an attribute or column.
  
  (MAP Attributes palette > Edit Schema > Derive value from expression > Browse)

- **Apply Expression** (page 51): To apply an expression to an attribute or property column for selected art only.
  
  (MAP Attributes palette > Apply Expression> Browse)

- **New/Edit Selection Filter** (page 96): To create or edit expression criteria for use in selecting map data.
  
  (MAP Selection Filters palette > New/Edit Selection Filter > Browse)

- **MAP Stylesheet Editor** (page 75): To create or edit an expression for use in styling map data.
  
  (MAP Stylesheets palette > Edit MAP Stylesheet > Advanced Expression > Browse)

ENTERING EXPRESSIONS

Expressions can be built via the keyboard and/or by selecting from listed column names, operators and functions. Clicking any of the operator buttons will enter that operator into the expression builder. Double-clicking an item from the Object menu will insert that item into the expression. Items are colour coded identifying attributes, constants, and functions. When attribute values are clicked they will automatically format with quotations. When using functions they will format correctly with proper brackets. All methods of entering expression criteria will cause the item to be placed at the current cursor position. Items can be deleted using the keyboard.
Expressions are also case-sensitive. To ignore case in a string comparison, convert all the strings to the same case using the appropriate function.

**VALIDITY**

The validity of the expression will be displayed below the Expression Entry field, and will be updated as you build the expression. The **Expression Validity** icon will report ✓ if the expression entered is valid. Otherwise it will report ❌ and include additional warning notes.

**OPERATOR BUTTONS**

Click to insert an operator at the current cursor position. Available operators are as follows:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(</td>
<td>Open clause operator</td>
</tr>
<tr>
<td>)</td>
<td>Close clause operator</td>
</tr>
<tr>
<td>AND</td>
<td>Logical AND operator</td>
</tr>
<tr>
<td>OR</td>
<td>Logical OR operator</td>
</tr>
<tr>
<td>=</td>
<td>Logical 'equal to' comparator</td>
</tr>
<tr>
<td>!=</td>
<td>Logical 'not equal to' comparator</td>
</tr>
<tr>
<td>&lt;</td>
<td>Logical 'less than' comparator</td>
</tr>
<tr>
<td>&gt;</td>
<td>Logical 'greater than' comparator</td>
</tr>
<tr>
<td>+</td>
<td>Mathematical addition operator</td>
</tr>
<tr>
<td>-</td>
<td>Mathematical subtraction operator</td>
</tr>
<tr>
<td>/</td>
<td>Mathematical division operator</td>
</tr>
<tr>
<td>*</td>
<td>Mathematical multiplication operator</td>
</tr>
</tbody>
</table>

**EXPRESSION COMPONENTS**

Items in the Objects list fall into three categories. Information on a selected item is displayed in the Description panel. Double click to insert an object at the current cursor position. Available objects are as follows:

**<MAP Layer>*

List of #property columns (see page 37)
List of attribute columns**

<table>
<thead>
<tr>
<th>Constants</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#true</td>
<td>Boolean true value</td>
</tr>
<tr>
<td>#false</td>
<td>Boolean false value</td>
</tr>
</tbody>
</table>

* Layer may vary depending on tool. For 'Edit Schema', 'Apply Expression' and 'New/ Edit Selection Filter' the current layer is displayed. In the 'MAP Stylesheet Editor', all layers hosted by the stylesheet are displayed.

** Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABS</td>
<td>Absolute value of a number</td>
</tr>
<tr>
<td>ACOS</td>
<td>Inverse of the cosine of an angle</td>
</tr>
<tr>
<td>ASIN</td>
<td>Arcsine of an angle</td>
</tr>
<tr>
<td>ATAN</td>
<td>Arctangent of an angle</td>
</tr>
<tr>
<td>CONTAINS</td>
<td>True if source string contains search string</td>
</tr>
<tr>
<td>COS</td>
<td>Cosine of an angle</td>
</tr>
<tr>
<td>DEGREES</td>
<td>Converts values from radians to degrees</td>
</tr>
<tr>
<td>ENDSWITH</td>
<td>Returns true is the source string ends with the suffix string</td>
</tr>
<tr>
<td>IF</td>
<td>Based on a conditional statement</td>
</tr>
<tr>
<td>LIKE</td>
<td>Searches the source string using wildcards</td>
</tr>
<tr>
<td>LOWER</td>
<td>Strings converted to lower case</td>
</tr>
<tr>
<td>NUMBER</td>
<td>String values as numbers</td>
</tr>
<tr>
<td>POW</td>
<td>Base to the power of an exponent</td>
</tr>
<tr>
<td>PROPER</td>
<td>Strings converted to capital case</td>
</tr>
<tr>
<td>RADIANS</td>
<td>Converts values from degrees to radians</td>
</tr>
<tr>
<td>REGEX</td>
<td>Searches the source string using a regular expression</td>
</tr>
<tr>
<td>ROUND</td>
<td>Rounded to specified decimals of precision</td>
</tr>
<tr>
<td>SIN</td>
<td>The sine of an angle</td>
</tr>
<tr>
<td>SQRT</td>
<td>Square root of a value</td>
</tr>
<tr>
<td>STARTSWITH</td>
<td>Returns true if the source string starts with the prefix string</td>
</tr>
<tr>
<td>TAN</td>
<td>Tangent of an angle</td>
</tr>
<tr>
<td>UPPER</td>
<td>Strings converted to upper case</td>
</tr>
</tbody>
</table>

** Unique values contained in each attribute column can be viewed in the Description panel.

Descriptions and examples have been provided for each function and parameter in the Description panel.
CONFIRMATION

When you have finalized your expression and it has been validated click the **OK** button. The expression will then be inserted into the expression field of the appropriate tool. The Edit Expression tool can be re-opened if further edits are required.

EXAMPLE BASIC EXPRESSIONS

**EDIT SCHEMA**

"Ontario" (applied to column = ‘NAME’)
Result: All items are assigned the value “Ontario” in the ‘NAME’ column.

"MAP Area 01" (applied to column = ‘Style’)
Result: All area items are assigned the value “MAP Area 01” in the ‘Style’ column and are assigned the Graphic Style “MAP Area 01” on the page.

45 (applied to column = ‘Rotation’)
Result: All point items are assigned the value ‘45’ in the ‘Rotation’ column and are rotated to 45° on the page.

**APPLY EXPRESSION**

"Ontario” (applied to column = ‘NAME’)
Result: All selected items are assigned the value “Ontario” in the ‘NAME’ column.

"MAP Area 01” (applied to column = ‘Style’)
Result: All selected area items are assigned the value “MAP Area 01” in the ‘Style’ column and are assigned the Graphic Style “MAP Area 01” on the page.

45 (applied to = ‘Rotation’)
Result: All selected point items are assigned the value ‘45’ in the ‘Rotation’ column and are rotated to 45° on the page.

**SELECTION FILTER**

NAME = “Ontario”
Result: When applying this filter, all items with the value “Ontario” in the ‘NAME’ column are selected.

POPULATION < 1000000
Result: When applying this filter, all items with values less than ‘1 million’ in the ‘POPULATION’ column are selected.

NAME = “Ontario” OR NAME = “Alberta”
Result: When applying this filter, items with the value “Ontario” OR “Alberta” in the ‘NAME’ column are selected.

NAME = “Ontario” AND POPULATION < 1000000
Result: When applying this filter, only items containing the value “Ontario” in the ‘NAME’ column AND values less than ‘1 million’ in the ‘POPULATION’ column are selected.

**MAP STYLESHEET**

NAME = “Ontario”
Result: All items with the value “Ontario” in the ‘NAME’ column are assigned the selected style.

POPULATION < 1000000
Result: All items with values less than ‘1 million’ in the ‘POPULATION’ column are assigned the selected style.

NAME = “Ontario” OR NAME = “Alberta”
Result: All items with the value “Ontario” OR “Alberta” in the ‘NAME’ column are assigned the selected style.

NAME = “Ontario” AND POPULATION < 1000000
Result: Only items containing the value “Ontario” in the ‘NAME’ column AND values less than ‘1 million’ in the ‘POPULATION’ column are assigned the selected style.

*Note: String values are case-sensitive and must be entered in double quotes (“...”).*
FUNCTIONALITY

Import Table provides the ability to merge external data tables directly into an existing MAP Layer's attribute schema in order to create a single extended attribute table. Three of the most common table formats are supported:

- DBase (*.dbf)
- USGS SDTS (*.ddf)
- Delimited Text (*.csv) (*.tsv) (*.txt)
- Excel (*.xls)

When exporting tables from spreadsheet applications for use with MAPublisher the preferred format to use is *.csv.

PREREQUISITES

In order to successfully import a table into an existing attribute schema you must have both a MAP Layer and a data table which share at least one common attribute column with matching values. The column must be of a matching ‘Type’ (i.e. String, Real, Integer, Boolean) in both the Source and the Destination table.

Access the Import Table tool by clicking the **Import Table** button or menu item in the MAP Attributes palette.

USING IMPORT TABLE

SOURCE TABLE

Click the **Browse** button to select the data table for import. When the file has been selected, select a common column by selecting an appropriate entry in the **Matching Column** listbox.

In MAPublisher 7, double byte characters are supported in attributes on import, allowing such attributes to be used for labeling and export. To assign a codec suitable for your selected dataset, choose an appropriate entry from the **Character Encoding** listbox if required.

If the table contains column names as headers, check the **First line contains column names** option. If it does not contain headers do not select this option and each column will be assigned a default heading name: Column1, Column2, etc.
DESTINATION TABLE

Choose the attribute table that you wish to join the data table to. This can be achieved by choosing a MAP Layer from the **Target Layer** list. When the destination layer has been selected, select a common column by selecting an appropriate entry in the **Matching Column** listbox. This column must match the format and values as the column selected in the **Source Table** section.

ADDITIONAL OPTION

If the **Case-sensitive** option is checked, the column entries from the two matching columns will only be matched by case. For example if you have a mixture of upper or lower case entries in the data table that is mirrored in the destination attribute table you should check this box. If one of the matching columns contains values in lowercase, and the other contains values in uppercase, for example, you should not check this box.

RESULTS

When you click **OK** the data table will be added to the attribute table on the destination MAP Layer and may be viewed in the MAP Attributes palette. Notice that the matching column in your data table has also been added, but has been appended with a ‘1’.
FUNCTIONALITY

The Apply Expression tool allows for the assignment and application of expressions to currently selected art for the purpose of assigning attributes, assigning properties, or transforming artwork. For example, the tool can be used to assign attribute values based on values in other columns, assign graphic styles to selected elements, or transform data on the page via the assignment of a rotation value.

Note that property attributes are dynamic. Changes made to them in the map attribute table are reflected immediately in the graphical properties and on-screen display of the data to which they are linked. Expressions can be generated and applied to data based on the values found in an existing attribute column, providing a one-step process to transform a vast number of different objects in a single operation.

APPLYING EXPRESSIONS

Ensure the data required for the application of the expression is selected, and that layer is selected in the MAP Attributes palette. Then access the tool by clicking the Apply Expression button or menu item in the same palette.

First specify a column from the Apply to list to specify which attribute column the expression will be applied to. The columns listed here are representative of the attribute structure unique to the data layer currently displayed in the attribute table as well as the standard MAPublisher property attributes.

To assign an expression to a column, simply enter a valid expression in the Expression field. The Expression Validity icon will report if the expression entered is valid. Otherwise it will report and include additional warning notes. Alternatively click on the Browse button to enter and edit expressions via the Edit Expression tool (page 46).

The following are some examples of basic expressions which can be assigned to selected data with Apply Expression.

“Ontario” (applied to column = ‘NAME’)  
Result: All selected items are assigned the value “Ontario” in the ‘NAME’ column.

“MAP Area 01” (applied to column = ‘#Style’)  
Result: All selected area items are assigned the value “MAP Area 01” in the ‘#Style’ column. Same items are assigned the Graphic Style “MAP Area 01” on the page.

45 (applied to = ‘#Rotation’)  
Result: All selected point items are assigned the value ‘45’ in the ‘#Rotation’ column. Items are rotated to 45° on the page.

Click the OK button to apply the expression to the selected data, updating the values in the selected attribute column and transforming data as appropriate.
The MAP Views palette is the hub from which many additional MAPublisher features may be accessed. The palette itself will display the Illustrator layers that exist in the current document as sub layers of distinct coordinate systems, or ‘MAP Views’. From this tool you can specify coordinate systems for Illustrator layers, reproject data, edit scales and data placement, merge layers, and export to GIS formats.

During a standard Import process, an Illustrator layer will be created for each feature type automatically, and will be automatically appended with a _point, _line, _area, or _text suffix in the Illustrator layers palette. Certain file types will generate multiple layers, such as the levels found in DGN or DXF, but they will be similarly split up by feature type. A single import of such files will produce a single “MAPublisher View” as an import can only take place in a single coordinate system. Custom MAP Views may be created in order to georeference existing Illustrator artwork.

The following pages will deal with the creation and management of MAP Views, specifying and changing a coordinate system, editing scales and data placement on the page, merging Illustrator layers, and exporting to GIS formats, via the use of the following tools:

MAP Views palette
Layer Name Search & Replace
Merge Layers
Specify Anchors
Source Coordinate System
MAP View Editor
Specify Source/Destination Coordinate System
Import MAP View
Export
Add/Edit Geodetic Data Source
**Map Views Palette**

*Window > MAPublisher Palettes > MAP Views*

**MAP Views** - List of the unique coordinate systems in the document.

**MAP Layers** - An alphabetical list of the layers that comprise each MAP View, symbolized by feature type.

**Lock button** - Click this button to lock or unlock the Layer (mirrored in the Illustrator Layers palette).

**Non-map layers** - Lists the Illustrator Layers that are not part of a specified MAP View, and do not contain georeferencing information.

**New MAP View** - Allows you to create a New MAP View and specify its name and coordinate information.

**Duplicate MAP View** - Will create a Duplicate of the currently selected MAP View.

**Edit MAP View** - Allows you to edit the name and coordinate system of the currently selected MAP View.

**Delete MAP View** - Allows you to delete the currently selected MAP View provided it does not contain any Illustrator layers.

**Source Coordinate System** - Allows you to specify the coordinate system of the currently selected MAP View.

**Specify Anchors** - For manually establishing the 'tie-in' point between Map and Page Anchors (should only be used for new MAP Views or for the correction of georeferencing errors).

**Import Coordinate System From File** - Imports a coordinate system from different file types including, WKT Definitions (*.wkt), MAP Files (*.map), ESRI PRJ Files (*.prj), MapInfo TAB Files (*.tab).

**Export Coordinate System to File** - Exports the selected MAP Views coordinate system to a specified coordinate system file.

**Import MAP View** - Imports MAP Views and associated MAP Layers from other open documents, retaining georeferencing and attribute information.

**Export** - Enables the export of the selected MAP View or MAP Layer to various GIS formats.

**Merge Layers** - Allows the combining of two or more MAP Layers, as long as their attribute structures match. Ctrl select the layers in the MAP Views palette.

**Layer Name Search & Replace** - To search for text within layer names and specify an alternative. Useful for multi-layer imports.

**Load Geodetic Data Source** - Allows the loading of an external data source in .xml format.

**Edit Geodetic Data Source** - Allows you to create new coordinate systems and edit the parameters of existing ones in the data source.

**Related Tools**

**Define Layer**

Automatically opens when dragging a ‘Non-map layer’ into a specified MAP View.

**Specify Coordinate System**

Automatically opens when dragging a MAP Layer to an alternate MAP View, and either the source or destination MAP View has an unspecified coordinate system.

**Define Layer**

- **Feature type** - Select the type of feature that exists on the layer being dragged. This dropdown presents a choice of Area, Line, Point, Text, or Legend layer types.

- **Apply to all** - If you are dragging a number of layers of the same feature type to a specified MAP View, you should check this box.

**Specify Coordinate System**

- **Same as** - Check this option in order to assign a coordinate system to the named MAP View that matches that of an existing MAP View. The coordinate system of the selected MAP View will be displayed below.

- **Specify custom coordinate system** - Check this option and then click the Select button to specify the coordinate system of the named MAP View via the Specify Source Coordinate System dialog (page 58). Once selected, the Projection will be displayed below.
OVERVIEW

The MAP Views palette displays a list of all the layers in the current document and each defined coordinate system. Every ‘MAP Layer’ will be shown in this palette as belonging to a particular MAP View. Illustrator layers that do not have georeferencing information (i.e. layers existing in the document prior to import) are placed in the ‘[Non-map layers]’ category.

Categories are symbolized in the following manner:

- **MAP View** layers which contain georeferencing information.
- **[Non-map layers]** layers which do not contain georeferencing information.

Each layer that belongs to a MAP View is symbolized in MAPublisher palettes and dialogs with an icon identifying its feature type:

- **A** Area layer (e.g. county boundaries, urban areas, country outlines etc.)
- **L** Line layer (e.g. rivers, roads, railways etc.)
- **P** Point layer (e.g. town and city symbols, railway stations etc.)
- **T** Text layer (e.g. text labels)
- **O** Legend layer (for MAPublisher Legend items: North Arrows, Scale Bars, Grids)

FUNCTIONALITY

MAP Views are designed to provide an easy method of accessing dialogs for specifying and changing coordinate systems, for editing scales and data placement on the page, and for exporting to GIS formats. Within the MAP Views palette you are just a few clicks away from merging Illustrator layers, georeferencing existing Illustrator artwork, changing layer names in bulk, and reprojecting data on the fly.
USING THE MAP VIEWS PALETTE

REPROJECTING MAP LAYERS BY ‘DRAG AND DROP’

Using the Map View Editor will be discussed in detail later in this section. The Map Views palette can be used to drag Illustrator layers from one MAP View to another, enabling you to reproject vector art* quickly. For example, two imports may produce two very different coordinate systems. In such a case you can reproject without having to access a dialog, by simply dragging an Illustrator layer from one MAP View to another within in the MAP Views palette. *Raster imagery can not be reprojected with MapPublisher.

If, for example, you have two imported data layers, one in UTM projection, and the other in latitude/longitude, MapPublisher will produce two distinct MAP Views, each holding the associated MAP Layer. If you wish to reproject the layer which is in UTM into Lat/Long, simply drag it from the UTM MAP View and drop it into the Lat/Long MAP View. MapPublisher will automatically reproject the layer to match the destination MAP View.

If you are reprojecting in this manner, and either the origin or destination MAP View does not contain a coordinate system, you will be presented with the Missing Coordinate System dialog after you drag and drop. In essence both MAP Views must contain a coordinate system. Therefore this window will allow you to specify one of the following:
1. ‘Specify custom coordinate system’ allows you to specify the projection of the named MAP View, via the Source Coordinate System function (see page 58)
2. ‘Same as’ allows you to specify the coordinate system of the named MAP View by choosing a coordinate system which already exists in a MAP View in your document.

Important note: Many transformations will inherently cause the loss of precision by the very nature of the complex mathematical calculations that must be performed. Additionally there are differences in precision between MapPublisher and Illustrator. MapPublisher’s calculations are in 64 bit for accuracy, but the results still must be stored as 32 bit for Illustrator. As a result, please be aware that you may lose precision if you drag repeatedly from one coordinate system to another. When determining a coordinate system to use via the drag method, we strongly recommend you use Edit > Undo to revert coordinate systems until you find the appropriate system for your data.

LAYER NAME SEARCH & REPLACE

The Map Views Options list also provides a Search and Replace function, enabling the quick change of names of multiple Illustrator layers. For example e00, dgn or CAD imports may contain a large number of similar named layers. This option will allow you to quickly change the names of all layers that contain a specified character string.

MERGE LAYERS

This palette also provides a fast way of merging Illustrator layers. If you have more than one layer in a MAP View that contain the same attribute structure and data type, this option will allow them to be merged into a single layer. For example your data may have been received in segments, and you therefore find it occupying multiple layers in Illustrator. Simply ctrl-select these layers in the Map Views palette and click the option for Merge Layers. The layers will then be merged to provide a single layer holding your data and its associated attributes.

ASSIGNING GEOREFERENCING INFORMATION TO ILLUSTRATOR LAYERS

Illustrator layers that do not contain georeferencing or attribute information will also appear in this palette under the default MAP View entitled Non-map layers. Such layers can be quickly moved into a specified MAP View with a matching coordinate system. When moving a ‘non-map layer’ into a specified MAP View you will be prompted
by the Define Layer dialog to specify the feature type of the layer you are moving. This functionality allows map features to be manually traced on a non-map layer and then georeferencing information to be quickly assigned to the layer by dragging it to an existing MAP View. Multiple layers may be selected and dragged together to a specified map view by using the ‘Apply to all’ function in the Define Layer dialog.

CREATING NEW LAYERS TO HOLD ADDITIONAL FEATURES

In order to plot points, generate text, use legends, or plot grids, scalebars and north arrows, you will first be required to create extra Illustrator layers to hold this information. This is due to the fact that layers cannot contain more than one feature type. Therefore prior to generating these additional map features, you need to first create a layer in the Illustrator layers palette on which these features will be held. Subsequently in the MAP Views palette you should drag these layers into the MAP View which contains the coordinate system you require to plot the extra features. The Feature Type you should specify for these features in the Define Layer dialog are as follows:

- **T** for Text items. Feature Text Label & MAP Tagger (chapter 8) require you have a Text layer for output.
- **P** for Point symbols. Point Plot (page 68) will not function without a Point layer selected.
- **O** for Legend items. Grids and Graticules (page 88), Scale Bars (page 111) and North Arrows (page 112) must be placed on Legend layers.

DUPLICATING AND DELETING MAP VIEWS

MAP Views can be duplicated if you wish to make placement or projection edits to certain Illustrator layers, while leaving the others alone. This way you could drag the Illustrator layers you wish to edit into the Duplicate MAP View. Additionally MAP Views that do not contain any Illustrator layers can be deleted. Both of these tools can be accessed in the Options section of the MAP Views dialog. You can also delete a MAP View by clicking the Delete button at the base of the palette. Note that these functions act on MAP Views only, and not MAP Layers.

CREATING NEW MAP VIEWS

You are able to create new MAP Views by selecting New MAP View under the Options arrow or by clicking the New button at the base of the palette. This will automatically open the MAP View Editor, which will be discussed in the MAP View Editor section (page 59), allowing you to set up a coordinate system, and enter values for scale, rotation, and page anchors. After you have created a new MAP View, you must use the Specify Anchors option from the MAP Views palette to define the tie-in point between Map Anchors and Page Anchors. Note that you must enter Map Anchor values that are indicative of the unit of measurement used in the chosen coordinate system, which may mean these values are not in degrees or Lat/Longs.

REMOVING MAPublisher INFORMATION

At the end of the project cycle it may be useful to permanently remove all georeferencing and attribute information in the current document. This can now be accomplished by simply dragging your MAP Layer(s) to the [Non-map layers] category in the MAP Views palette. **Note that this function should only be used as a final step as all attributes and geodata will be expunged leaving a “standard” Illustrator file devoid of all map information. Be sure to save a copy of your file before performing this operation.**
Source Coordinate System

MAP Views palette > Source Coordinate System, and
MAP View Editor > Specify (Source Projection Section)

FUNCTIONALITY

There are three possible scenarios in which you would need to use this function:

1. If you imported a file even though the program returned a message of [No Coordinate System Specified] for the coordinate system during the import process.
2. If you had incorrectly specified the coordinate system during the Import process, and wish to remedy this.
3. If you have created a new MAP View and wish to assign a coordinate system to it.

If you wish to maximize the functionality of MAPublisher, it is important that all of your MAP Views contain accurate coordinate system information. For example, you cannot reproject data if the current projection is not specified. If you do not know the coordinate system of your data you must consult your data provider to obtain this information.

USING SOURCE COORDINATE SYSTEM

To specify a coordinate system you must first select the appropriate MAP View in the MAP Views palette, and then select Source Coordinate System located under the Options arrow in the upper right corner of the palette or click on the Specify button in the MAP View Editor Source Coordinate System section.

To access the Specify Source Coordinate System dialog in the Source Coordinate System dialog and the MAP View Editor the Specify button must be selected.

In the Specify Source Coordinate System dialog, coordinate systems are separated into coordinate system categories to ease the process of choosing a coordinate system. Choose the coordinate system category *All* to list all the coordinate systems in the database. If the coordinate system needed cannot be found, then enter a text string in the search field to query the database for coordinate systems. The results are displayed in the *Search* category. For an overview of projections and datums see pages A1/30 to A1/39.

The Source Coordinate System tool also offers a checkbox to enable you to select a coordinate system that already exists in the document. The Same as dropdown will allow you to select from a list of existing georeferenced MAP Views.

If you wish to view the parameters of a certain coordinate system, click the Info button. To edit a coordinate system please refer to page A1/35.
The MAP View Editor can be accessed as part of the **Advanced Import** process (page 33) or from the **MAP Views** palette (page 54).

To access via the Advanced Import process, click the **Create new** radio button in the Destination MAP View section, and then click the **Editor** button to open the dialog.

From the **MAP Views** palette select the MAP View you wish to edit, and then select **Edit** under the **Options** arrow in the upper right corner of the palette. Conversely you can double click the MAP View to open the MAP View Editor.

The function has a variety of purposes. It will allow you to reproject data, transform scales, edit data positioning in the document, change rotation values, and rename MAP Views. Any or all of these functions can be achieved with a single visit to the MAP View Editor. There is also a preview pane where you can see how the edits made to data will affect its extents in the document.
USING THE MAP VIEW EDITOR

PREVIEW PANE

The Preview Pane symbolizes the data extents by a green rectangle and the orientation with an arrow. You can click on this rectangle to move the data to a more suitable position in the document if you desire.

MAP VIEW NAME

When you open the dialog you will see the current name of the MAP View in the Name field, which you can edit if desired. Whether the MAP View Editor is accessed via Advanced Import, or from the MAP Views palette, editing the name here will change the name of the resultant or existing MAP View.

PAGE ANCHORS

Current Page Anchors are displayed in the LL (Lower Left) Corner X/Y fields, in the current document units. As discussed in the section on Georeferencing on page 36, the default Page Anchors are 0,0 in document units. Editing the Page Anchor values will move the data relative to the lower left location of the data. Entering negative values will move the data to the left or down, entering positive values will move the data to the right or up. There are also two graphical ways to edit Page Anchors. Firstly the data can be ‘glued’ to respective positions in the document by clicking on a respective Alignment Control button, of which there are nine positional options. Conversely dragging the green data preview rectangle around the page in the Preview Pane will update the Page Anchor values accordingly. Note that editing Page Anchors will not affect data integrity. It simply means that the lower left corner of the data in coordinate units (Map Anchors) is located at this new document position.

SCALE

The Scale of the current MAP View (or files to be imported) is shown in the Scale field. Generally, MAP Views carrying projected data (i.e. not in Lat/Long format) will carry real world scales. This field is editable allowing you to quickly specify an alternate scale. Furthermore the up and down buttons will allow you to fine tune scales by increasing or decreasing a scale by a single whole number. The Auto Scale button will allow you to quickly fit the data to the page extents if this is required. Clicking this button will edit the scale and page anchors so that it is located in the centre of document.

REPROJECTING

To reproject data in the MAP View Editor the ‘Perform Coordinate System Transformation’ box must be checked. The Specify button in the ‘Perform Coordinate System Transformation’ section must then be selected to enter the ‘Specify Destination Coordinate System’ dialog.

In the Specify Destination Coordinate System dialog projection categories are generally organized according to continents and countries, to ease the process of choosing a coordinate system. The Projection list will show the coordinate systems that belong to the specified Category. When the *All *tab is selected the view will list all of the coordinate systems in the database and if you choose this category, it may take some time to choose the one relevant to your MAP View.

The MAP View Editor also offers a checkbox to enable you to select a coordinate system that already exists in the document. The Same as dropdown will allow you to select from a list of existing georeferenced MAP Views. This function is useful when a series of MAP Views exist of different areas, but even though they have different coordinate systems (i.e. position on the page), you require them all to be in the same coordinate system. Again the Preview Pane will display the new data extents for any new coordinate systems specified in the MAP View Editor.
To match coordinate systems across a number of MAP Views, simply drag the Illustrator layers into the MAP View containing the coordinate system you require, as discussed in the MAP Views palette section. If you wish to view the parameters of a certain coordinate system, click the Info button. To edit a coordinate system please refer to page A1/35.

ASSIGNING A PROJECTION

If you wish to set the current coordinate system of the data, rather than change coordinate system, you can click the Specify button in the Source Coordinate System Section of the MAP View Editor. You must use caution, as this option will set source coordinate systems only, and not serve to reproject your data. Therefore data integrity may be lost if you overwrite the current coordinate system of the MAP View via the use of this utility. Please see page 58 for a description of this function.

SEARCHING FOR A COORDINATE SYSTEM

The Specify Source/Destination Coordinate System dialog allows you to search for coordinate systems based on an entered text string. Searches can be performed on the whole database, or solely in continent and country sub-categories. To use the Specify Coordinate System type a search term into the text box located at the bottom of the dialog and click the search button.

In the ‘Find:’ field enter the text on which to search. For example to find coordinate systems with ‘NAD83’ properties, enter ‘NAD83’. Following the ‘Find:’ field is the ‘in’ field to select an area of the database in which to search. For example to find ‘NAD83’ in the name only, select ‘Names’.

When you have entered the search criteria click the ‘Search’ button. If the search has returned results, these results will be displayed in the Specify Coordinate System dialog in the *Search* category, and can be immediately selected in order to reproject your data or to assign a coordinate system. Search results will be stored in this category until you restart Illustrator or perform another ‘Coordinate System Search’.

ROTATION

A rotation figure can be applied or edited by specifying an angle in the entry field, or by using the ‘clock hand’ to rotate the MAP View graphically. Notice that changes to rotation will be automatically previewed in the Preview Pane, with the green rectangle and arrow depicting the new orientation of the data.

NEW MAP VIEWS

The MAP View Editor is opened by default when creating a New MAP View. This will enable you to quickly specify the name, coordinate system and page scaling for your New MAP View. This functionality will be discussed in detail in How to Georeference an Illustrator file on page A1/42. After you have created a new MAP View, you must use the Specify Anchors option from the MAP Views palette to define the tie-in point between Map Anchors and Page Anchors (see page 55). Map Anchor values must be entered in units that are indicative of the unit of measurement used in the chosen coordinate system, which may mean that they may not always be in degrees or Lat/Long.
**Import MAP View**

*MAP Views palette > Import MAP View From Document*

![Import MAP View](image)

**FUNCTIONALITY**

MAPublisher’s Import MAP View copies a MAP View from one document to another, including all the layers that are tied to that MAP View. This can be a useful tool when merging parts of several documents into a single document. An example might be to import a commonly used inset map.

**PREREQUISITES**

There must be at least two documents open to use Import MAP View. Additionally, one of the documents that is not the current document must contain at least one MAP View.

To access the function, select the *Import MAP View* menu item in the MAP Views palette.

**IMPORTING A MAP VIEW**

The Import MAP View window will show all other documents currently open, along with all the MAP Views they contain. Simply select the MAP View you wish to import into the current document, and click OK to import the MAP View and MAP Layers.
Export
MAP Views palette > Export

Format - Select the export format for the selected layer or MAP View.

Dataset - Displays the directory path for the export of the currently selected layer or MAP View. You can also manually type in the dataset location.

Settings - Opens a Settings dialog for the input of extra parameters (see below).

Browse - Opens a Data Source browser to enable the selection of an export directory.

Character Encoding - Assign a codec if the attribute information held in the selected layer or MAP View uses a double byte character set.

Export Settings

General Settings

Keep format extension - Check this option to export layers with their feature extension (_area, _line, _point, or _text) which may have been appended to layer names during import.

Export visible attributes only - Check this option to export only the attributes that are currently visible in the MAP Attributes palette.

AutoCAD Settings

Release Version - Specify the AutoCAD version number you wish to export to.

MicroStation Settings

Coordinate Units - Specifies how feature coordinates will be interpreted and converted (Master, Sub or Units of Resolution).

Area Fills - Controls whether or not fill linkages will be written out for ellipses, shapes, and solids.
FUNCTIONALITY

MAPublisher supports the export of single MAP Layers or whole MAP Views to various GIS formats, maintaining all georeferencing and attribute information. The following export formats are supported:

- **CAD** (*.dxf) (*.dwg)
- **Delimited Text Data** (*.csv) (*.tsv) (*.txt)
- **ESRI ArcInfo Export** (*.e00)
- **ESRI ArcInfo Generate** (*.gen)
- **ESRI Shape** (*.shp)
- **KML** (*.kml)
- **MapInfo MIF/MID** (*.mif / *.mid)
- **MapInfo TAB** (*.tab)
- ***Microstation Design** (*.dgn)

Exporting a MAP View to CAD or MicroStation format will concatenate all hosted layers into a single file.

PREREQUISITES

The Export function will export single Illustrator layers that are contained in a specified MAP View or all layers contained in a specified MAP View. Therefore both imported and user created MAP Views will contain MAP Layers that are suitable for export to GIS formats.

USING MAP EXPORT

To open the Export function, first select the MAP Layer or MAP View you wish to export in the MAP Views palette. Then click on the Options arrow in the upper right corner of the dialog and select Export "<Layer/MAP View name>". Note you cannot export multiple MAP Views or multiple layers that have been selected individually. Only single MAP Views or single layers can be exported at one time.

Within the dialog select the Export Format you require, and then click the Settings button.

KEEP FORMAT EXTENSION

The MAP Layer or MAP View you are exporting will be the default name of the exported file. However the feature type text (i.e. _area, _line, _point, or _text) appended to Illustrator layers by MAPublisher in the Import process, will be removed during the export process, unless you specify that you wish to keep this. If you wish to keep the feature type text, check the Keep format extension option.

EXPORT VISIBLE ATTRIBUTES

Check this option to export only the attributes that are currently visible in the MAP Attributes palette. If this option is not checked, all attribute columns (including MAPublisher #Property attributes) will be exported.

AUTOCAD SETTINGS

When exporting to AutoCAD click the Settings button to specify the AutoCAD version.
COORDINATE UNITS
When exporting to Microstation click the Settings button to specify the desired unit type.

AREA FILLS
When exporting area type data to the Microstation file format the user may enable/disable fills.

CHOOSING A DESTINATION FOLDER
Most of the export formats will require the selection of a destination folder only. For export to ESRI or MapInfo formats, simply click the Browse button to specify a destination folder. Click the OK button to export your MAP Layer.

In the case of exporting to AutoCAD format you will be required to specify a name for the exported file, and select the file extension (DXF or DWG) to be used. For MicroStation you will be required to specify a name for the exported file. If you wish to export to either of these formats, click the Browse button to name the export file, and then choose the file format from the Format dropdown list.

ADDITIONAL NOTES

VALID AREA DIRECTION (AREA LAYER EXPORTS)
When exporting Area layers to GIS formats, polygon outlines must have a positive ‘Area’ value, whereas holes held inside compound paths (or ‘complex shapes’) must have a negative ‘Area’ value. If you have values for polygons in the ‘#Area’ property column of your MAP Attribute table which contradict these guidelines, you can use the following tools to convert the MAPublisher area calculation from a negative to a positive value or vice versa:

‘Flip Lines’ tool (page 103) for convert multiple areas.
Create a Selection Filter (page 96) to select all elements that have an ‘#Area’ of less than zero (to select negative values) or greater than zero (to select positive values). Then go to Filter > Flip Lines.

#AreaDirection’ property value (page 39) for convert areas one by one.
Select the area to edit and then choose the alternate value for ‘#AreaDirection’ in the MAP Attributes palette.

#TEXT PROPERTY (TEXT LAYER EXPORTS)
It is not possible to export values in the ‘#Text’ property column. An alternative is to create a new string attribute column and assign it an expression of ‘#Text’. See Edit Schema (page 44).

ADD/EDIT GEODETIC DATASOURCE
Please see pages A1/35-A1/39 of the Appendix for further information on how to edit the geodetic datasource.
Having the ability to place points onto a map is a fundamental part of cartography. Points can represent the locations of towns and cities, shops and malls, airports and train stations to name but a few. MAPublisher provides the functionality to create or plot points in vector format.

There may be times when you wish to quickly add a point or a small group of points to your map but you do not have a GIS or ASCII file containing these points ready for import. Alternatively your map may be in a projection that holds coordinates in distance units, yet the coordinates of your point locations are in Latitude and Longitude.

Providing you have a fully specified MAP View, and know the coordinates (in either Decimal Degrees or Degrees, Minutes and Seconds) for the locations you wish to plot, you can use the MAPublisher Point Plotter to have your points automatically added at their correct locations.

The following pages will deal with plotting lat/log points on a projected map page via the use of the following tools:
**MAP Point Plotter**
Point Plotter

*Window > MAPublisher Palettes > MAP Point Plotter*

**Coordinate Entry Boxes** - Enter the coordinates of the point to be plotted in either Decimal Degrees OR Degrees, Minutes & Seconds.

**Scale** - Change the size of the chosen symbol if required. The arrow keys will increase or decrease the scale value by 10% increments.

**Symbol Selection** - Choose a symbol to use. The symbols displayed here will be the same as in the Illustrator Symbols palette.

**Create** - Click to plot a point using the entered values.

**PREREQUISITES**

In order to plot points using the Point Plotter, you must first have a fully georeferenced MAP View in your document, as this function will use the coordinate system of that MAP View in order to generate points. Furthermore you must create a new Illustrator layer in which your points will be placed, as the software will not support multiple feature types on the same layer. Remember once you have created a Point layer, you must drag it into the desired MAP View, specifying "Point" in the Define Layer dialog.

When you have a Point layer created in the correct MAP View, and a Symbols palette you will find useful for this function, you can open the Point Plotter. This palette is located under Window > MAPublisher Palettes.

**USING POINT PLOT**

**SETTING UP THE SYMBOL SELECTION**

The symbols used by Point Plotter are a direct reproduction of those that exist in the Illustrator Symbols palette. To open the Illustrator symbols palette go to Window > Symbols. If you wish to add points to this palette, create your symbols as closed Illustrator objects and simply drag them into this palette. Alternatively open the MAP Symbols file in the Utilities folder on your MAPublisher CD, and drag the symbols into your Illustrator Symbols palette.

**ENTERING COORDINATES**

Coordinate values can be entered in either Decimal Degrees (DD.dd), or Degrees, Minutes and Seconds (DMS.ss). These values are entered into the Latitude and Longitude fields. Lines of Latitude run North-South (the Equator is an example), whereas Lines of Longitude run East-West (the Greenwich Meridian is an example). Positive degree values represent north latitudes and east longitudes. Negative degree values represent south latitudes and west longitudes.
Example Decimal Degree values:

| Latitude Values:  | 12.3456        | 12.3456 Degrees North |
|                  | -12.3456       | 12.3456 Degrees South |
| Longitude Values:| 12.3456         | 12.3456 Degrees East  |
|                  | -12.3456       | 12.3456 Degrees West  |

Example Degrees, Minutes and Seconds values:

| Latitude Values:   | 12d34’56.78”N | 12 Degrees, 34 Minutes, 56.78 Seconds North |
|                   | 12d34’56”S    | 12 Degrees, 34 Minutes, 56 Seconds South    |
| Longitude Values:  | 12d34’56.78”E | 12 Degrees, 34 Minutes, 56.78 Seconds East  |
|                   | 12d34’56”W    | 12 Degrees, 34 Minutes, 56 Seconds West     |

CHOOSING A SYMBOL AND SCALE

When you have entered your values select an appropriate symbol to use. Again the symbols displayed are the symbols that currently exist in the Illustrator Symbols palette. If you wish to scale the symbol used, edit the Scale entry field. Clicking the Up and Down arrows will increase or decrease the value by 10%.

PLOTTING POINTS

Click Create to plot the point in the designated MAP View. To plot subsequent points, edit the Latitude and Longitude, and also choose different points if required.
MAPublisher provides extensive tools for quickly, easily and accurately creating point, line, area and text stylesheets. This function is able to read and work with the data found in the MAP Attribute tables and to apply symbols and styles to map elements according to the legend criteria you specify.

The following pages will deal with the creation and management of MAP Stylesheets and legends via the use of the following tools:

MAP Stylesheets Palette
MAP Stylesheet Editor
**MAP Stylesheets Palette**

*Window > MAPublisher Palettes > MAP Stylesheets*

**MAP Stylesheets Palette**

- **MAP Stylesheet List** - An alphabetical list of the MAP Stylesheets and component MAP Layers in the current document. Both are depicted with their feature type.
- **Lock button** - Click this button to lock or unlock the layer.
- **Other MAP Layers** - Lists the MAP Layers which are not components of any MAP Stylesheet, therefore belonging to a Stylesheet of 'None'.
- **New MAP Stylesheet** - Opens the New Stylesheet dialog.
- **Delete MAP Stylesheet** - Deletes the selected Stylesheet.

**New Stylesheet**

- **Options Menu...**
  - **New MAP Stylesheet** - Opens the New Stylesheet dialog to specify a name and feature type for the new stylesheet.
  - **Duplicate MAP Stylesheet** - Will create a Duplicate of the selected MAP Stylesheet.
  - **Edit MAP Stylesheet** - Will open the MAP Stylesheet Editor dialog.
  - **Delete MAP Stylesheet** - Allows you to delete the selected MAP Stylesheet.
  - **Create MAP Stylesheet legend** - Allows you to create a legend using the selected MAP Stylesheet rules.

**FUNCTIONALITY**

MAP Stylesheets allow you to quickly create and apply legends based on the Styles and Symbols that exist in the respective Illustrator palettes. Stylesheets are created inside a MAPublisher dialog, where specific values contained in the attribute table for the related layer are assigned Illustrator symbology. MAP Stylesheets can be applied to data on both a one to one basis, where specific attribute values are assigned with a specific style or symbol (i.e. Style 1 = Value A) or with attribute value ranges (i.e. Style 2 = Greater than Value B and Less than Value C). Stylesheet information will be saved in the Map Document so that the MAP Stylesheet can be quickly edited later.

**USING THE MAP STYLESHEETS PALETTE**

This palette is the starting point for working with MAP Stylesheets, and is opened by going to *Window > MAPublisher Palettes > MAP Stylesheets*.

The MAP Stylesheets palette contains a list of all MAP Layers. As in *MAP Views*, the icons used for these layers are:

- **A** - Area Layer
- **L** - Line Layer
- **P** - Point Layer
- **T** - Text Layer

By default all MAP Layers will be listed as belonging to a Stylesheet of [None]. When you have created a new Stylesheet you can drag a MAP Layer into it, in order to specify the attributes and symbology you require.
LOADING SYMBOLS AND STYLES

The symbology used by MAP Stylesheets is directly related to the Symbols and Styles which exist in native Illustrator palettes. In order to correctly function, the MAP Stylesheets tool requires that symbology appropriate to the feature type is established in the following Illustrator palettes:

- **Area Stylesheets**: Graphic Styles palette (Window > Graphic Styles)
- **Line Stylesheets**: Graphic Styles palette (Window > Graphic Styles)
- **Point Stylesheets**: Symbols palette (Window > Symbols)
- **Text Stylesheets**: Character Styles palette (Window > Type > Character Styles)

Symbology can be quickly added to these palettes by dragging and dropping artwork from the Illustrator page, or by dragging and dropping symbology from custom libraries.

As an example under **Window > Graphic Style Libraries > Other Library…** navigate to the **Utilities** folder on your MAPublisher CD and load either ‘MAP_AreaStyles.ai’ or ‘MAP_LineStyles.ai’. Then shift-select these styles and drag them into the **Graphic Styles** palette for use in Area and Line Stylesheets.

Similarly you can navigate to **Window > Symbol Libraries > Other Library…** and load ‘MAP_PointSymbols.ai’. Then shift-select these symbols and drag them into the **Symbols** palette for use in Point Stylesheets.

CREATING A NEW STYLESHEET

To create new MAP Stylesheets you must first select **New MAP Stylesheet…** under the **Options** menu, or click the **New** button at the base of the palette. This will open the **New Stylesheet** function, where you are required to specify the name and feature type for the new MAP Stylesheet. Clicking **OK** will place the new stylesheet in the **Graphic Styles** palette for use in Area and Line Stylesheets. If your data is held across a number of layers, all of these layers can be placed inside the same stylesheet for quick update. Note that they do not need to contain the same attribute structures. As long as they are all of a matching feature type they can be placed inside one MAP Stylesheet.

DELETING AND Duplicating STYLESHEETS

You can create as many MAP Stylesheets as you wish within the document. Note that under the **Options** in the MAP Stylesheets palette there are functions to delete and duplicate stylesheets.

You can delete the selected MAP Stylesheets by clicking the **Delete** button at the base of the palette or by selecting **Delete Stylesheet** under the **Options** menu. If you wish to delete a stylesheet you must first drag associated MAP Layer(s) out of the stylesheet, such as into a Stylesheet of [None] or into another Stylesheet. Only at this stage will the Delete option be activated. Note that moving a stylesheet to [None] will not restore the data to its default symbology; it will simply remove the relationship between attribute value and style/symbol.

Select **Duplicate Stylesheet** to create a copy of the selected MAP Stylesheet. Duplicating Stylesheets can be used to create copies of existing stylesheets. Even though the copy will not contain a MAP Layer at first, the style rules which exist between attributes of the original layer and the symbology will be retained. Simply by editing the styles that relate to each value in each stylesheet, you can drag a MAP Layer from one MAP Stylesheet to another in order to output different versions of a map.
CREATING A MAP STYLESHEET LEGEND

A legend can be quickly created using any MAP Stylesheet. Any area, line, point or text MAP Stylesheets can be used to a legend. The legend is created by drawing an area, line, point symbol or displaying the word “Style” (using the character style set by the rule) followed by the expression associated with that MAP Stylesheet rule.

To create a legend using MAP Stylesheets you must first create a **Legend layer**. Create a layer in the Illustrator layers palette, drag this layer a MAP View and define the layer as a **Legend layer**. Then select the MAP Stylesheet that you would like to use to create the legend. Using the **Options Menu** select **Create MAP Stylesheet legend**.

The legend’s font is set by the character palette. Select the font you would like to use for your legend using the character palette before creating a MAP Stylesheet Legend. Legends are fully customizable. If you would like to change any aspect of the legend this is can easily be accomplished. Select your legend and use Illustrator’s **Object > Ungroup**. The legend is now Illustrator artwork allowing you freedom to edit individual elements.
MAP Stylesheet Editor

MAP Stylesheets palette > Edit

FUNCTIONALITY

ACCESSING THE MAP STYLESHEET EDITOR

When you have a MAP Stylesheet created which hosts at least one MAP Layer of the same type, click on the stylesheet name, and go to Options > Edit… Alternatively double-click the new MAP Stylesheet.

The Name of the current MAP Stylesheet will be displayed at the top of this dialog, which is editable. Also a feature type icon will be displayed. To begin, click the Add button to create elements in your MAP Stylesheet.

ASSIGNING A STYLE RULE NAME

The Style Rule Name column will contain the name of each style rule. This can be edited to describe the style rule and/or its intention. For example, style rules could be named “Roads” or “Cities with populations over 200,000”.

SELECTING STYLES AND SYMBOLS

The Style field will contain a list of styles that currently exist in the Illustrator Graphic Styles palette (for Area and Line stylesheets), in the Symbols palette (for Point stylesheets), or in the Character Styles palette (for Text stylesheets). For each rule, choose a style or symbol to use. Note you can only use a specified style once in a single stylesheet. The Move Up and Move Down buttons will move the priority of the selected style up or down the list.

| Column | Lists the attribute column(s) of the associated MAP Layers.
| Range operator | Click to activate the second row to enable the composition of range expressions.
| Expression | Click to edit the expression assigned to each style rule (*see below).
| Expression Mode | Select the style of the display field that is displayed when clicking the Expression field (*see below).

**Simple** Expression
to compose & edit expressions in Simple Mode

- **Simple Expression**

<table>
<thead>
<tr>
<th>Simple Expression</th>
<th>1991</th>
<th>27797</th>
</tr>
</thead>
<tbody>
<tr>
<td>POP1991 &gt; “27797”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>POP1991 &lt;= “568474”</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Advanced** Expression
to compose & edit expressions in Advanced Mode

- **Advanced Expression**

<table>
<thead>
<tr>
<th>Advanced Expression</th>
<th>1991</th>
<th>27797</th>
</tr>
</thead>
</table>

Expression Validity - Indicates if the expression is valid or invalid. If invalid, additional information is reported.
ASSIGNING AN EXPRESSION

The Expression field describes the criteria for applying the style rule. By default, the field displays the currently entered expression, if any. Clicking on the Expression field opens either the Simple Expression panel or the Advanced Expression panel, depending on the Expression Mode and the current expression (see page 44).

To choose the mode in which to compose your expression, select the Simple or Advanced radio button. Then assign an expression for each rule using the guidelines below.

Simple Expressions...

The Simple Expression panel is intended to facilitate quick expression generation. First, choose a Column. You can select from the dropdown list, or manually type in a name.

Choose a Comparison. There are five options available:

- $=$ Equal to
- $>$ Greater than
- $<$ Less than
- $\geq$ Greater than or equal to
- $\leq$ Less than or equal to
- $!=$ Not equal to

Select the Value against which the comparison will be applied. You can pick the value from the dropdown or enter the value manually. Similarly, the value does not have to appear in the list to be valid.

If you chose any Comparison except ‘Equal to,’ (=), you then have the option of extending your expression further. Clicking the Range operator checkbox enables an additional Comparison and Value input pair. As with the first set, you must pick a Comparison and a Value, thus completing your expression.

Advanced Expressions...

The Advanced Expression panel lets you construct more complex expressions.

Simply enter a valid expression in the Expression field. The Expression Validity icon will report ✓ if the expression entered is valid. Otherwise it will report ✗ and include additional warning notes. Alternatively click on the Browse button to enter and edit expressions via the Edit Expression tool (page 44).

The following are some examples of basic expressions which can be entered for styling rules.

- **NAME = “Ontario”**
  Result: All items with the value “Ontario” in the ‘NAME’ column are assigned the selected style.

- **POPULATION < 1000000**
  Result: All items with values less than ‘1 million’ in the ‘POPULATION’ column are assigned the selected style.

- **NAME = “Ontario” OR NAME = “Alberta”**
  Result: All items with the value “Ontario” OR “Alberta” in the ‘NAME’ column are assigned the selected style.

- **NAME = “Ontario” AND POPULATION < 1000000**
  Result: Only items containing the value “Ontario” in the ‘NAME’ column AND values less than ‘1 million’ in the ‘POPULATION’ column are assigned the selected style.

  **Note:** String values are case-sensitive and must be entered in double quotes (“…”).

ASSIGNING A SCALE

The Scale default is 100%. Editing the scale will alter the symbol size or stroke weight depending on feature type.
BUILDING THE STYLE SHEET

For subsequent style rules proceed in the same manner. Click Add, and then specify a Name, Style, Expression and Scale. You can click Apply at any time to preview the results at any stage of building a stylesheet, and also return to edit settings you have made for individual style rules. In order to delete a style rule from the list, click anywhere in its row and click the Remove button.

Click OK to exit the window and to assign the MAP Stylesheet to the associated MAP Layers.

IMPORTANT NOTES

EXPRESSION MODES

The Expression Mode determines which type of expression panel you get when editing a style rule’s expression.

If the Expression Mode is set to Advanced, the expression panel will always be the Advanced Expression panel, irrespective of the expression being edited. If the Expression Mode is set to Simple, the expression panel will be the Simple Expression panel, unless the expression to be edited is not a “simple expression”. A Simple Expression is one that is either empty or includes only one attribute and no more then two clauses. For example:

Simple Expression: AttributeA = 1
Simple Expression: AttributeB < 5 AND AttributeB > 1
Advanced Expression: AttributeC > 1 AND AttributeD > 10

If the current expression is not a Simple Expression, editing it will always result in the Advanced Expression panel.

DYNAMIC STYLE LINKAGE

Once a MAP Stylesheet has been assigned with styles and symbols, those styles and symbols are dynamically linked to their attribute values in the MAP Stylesheet if the expression is a “simple equality”.

A “simple equality” expression is when there is only one attribute and only one clause (an equality comparison). For example AttributeA = 1 is a “simple equality” expression, while AttributeA > 15 is not.

Applying the style from a style rule with a “simple equality” expression manually (i.e. changing a style of a polygon directly from the Graphic Styles palette) will assign the attribute value of that style rule in the MAP Stylesheet. For example, in the case above AttributeA on the modified art would be set to 1. Caution should be used with manually editing the styles of artwork after MAP Stylesheets have been applied if any style rules have “simple equalities”.

Similarly, as styles and symbols which exist in these Illustrator palettes are linked to the related MAP Stylesheet entries, using these styles and symbols to create new artwork will automatically assign the related attribute value to these objects when the same criteria are met.

POINT DATA

Regarding the editing of Point Data, you must use either MAP Stylesheets or the MAP Attributes palette to change symbology. As point data is linked dynamically to the symbols which exist in the Symbols palette, you cannot edit graphical properties manually. Choosing ‘Break Link to Symbol’ from the Symbols palette options will result in the loss of attributes for your point data.
One of the most useful features of MAPublisher is the ability to create labels for map objects using values from the attribute tables. Manually entering and placing labels is not necessary provided that the labeling information is included in the map database of the layer being labeled.

MAPublisher provides two methods of adding labels to your map, both of which contain options to place labels intelligently using defined Label Settings.

One way to create feature labels is to first select all the features you want to be labeled and use Feature Text Label to label all of them by specified attribute values.

An alternate method involves using the MAP Tagger Tool to apply labels individually.

The following pages will deal with the automatic creation and management of feature labels based upon attributes contained in the base GIS data files and MAP Attributes Palette via the use of the following tools:

Feature Text Label
MAP Tagger Tool
Labeling Tools
for Feature Text Label and MAP Tagger Tool

**Source Layer** - Lists the Point, Line and Area layers which can be labeled. For Feature Text Label, only layers containing selected items are listed.

**Source Column** - Select the column that contains the values you wish to use to label the selected features.

**Label Settings** - Click the appropriate button to assign label settings and rules for each layer type (see below).

**Text layer** - For each Source Layer, select the destination text layer you wish to place the generated text labels on.

**Label Settings** - Click the appropriate button to assign label settings and rules for each layer type (see below).

**Line Label Settings**
- **Distance from start** - Controls where the text is located along the line. Auto - will place text at the midpoint for straight lines and find the smoothest portion closest to the midpoint for curved lines. Fixed - will allow for precise placement of text along a line.
- **Adjust label if larger than line** - Specify rules for the scaling of text if the text will not fit onto the text path in its entirety. Click the Up or Down buttons to adjust the order in which the rules will be implemented in the labeling process.

**Area Label Settings**
- **Labels curve with lines of latitude** - For projected layers, choose this option to generate curved text on latitude lines.
- **Adjust label if larger than area** - Specify rules for the scaling of text if the text will not fit inside the area object in its entirety. Click the Up or Down buttons to adjust the order in which the rules will be implemented in the labeling process.

**Point Label Settings**
- **Label Position** - Choose the position of the label relative to the point symbol.
**FUNCTIONALITY**

The Feature Text Label filter allows labels to be added to your map based on the attribute data of the features. Line, Point or Area MAP Layers containing attribute information can be labeled using this filter. All selected features on MAP Layers (which contain appropriate attribute information) can be labeled using this tool. Data selected on multiple MAP Layers can be labeled simultaneously. In addition, you may specify options such as alignment to lines of latitude, minimum font size, horizontal scaling and label position to place labels intelligently.

**PREREQUISITES**

Before using this filter you must create a **Text layer** in your MAP Views palette. Create a new Illustrator layer, and then drag it to the MAP View holding the features you wish to label. Set the feature type to ‘Text’ when prompted. Furthermore it is often useful to set you default text size, justification and font at this stage, as MAPublisher will generate labels based on these settings. Then simply select the features that you want to label and go to **Filter > MAP Legend > Feature Text Label** to access the function.

**FEATURE TEXT SETTINGS**

**SOURCE LAYER & COLUMN**

You must first set the options for MAPublisher to determine the attributes that will be converted to text labels. The **Source Layer** list will show the Area, Point and/or Text layers currently containing selected data.

For each layer, the **Column** dropdown(s) will be populated with the attribute structure of that layer. You must choose a column that holds the attributes you wish to label the data with.

**TARGET TEXT LAYER**

In the **Text layer** dropdown(s), you must specify a Text layer that the labels will be output to. Note you can only output labels to text layers in the same MAP View as the Source Layer.

**LABEL SETTINGS**

MAPublisher provides options to specify label preferences such as label position, alignment to lines of latitude, minimum font sizes and horizontal scaling to best place labels within polygons and paths. These Label Settings are common to **Feature Text Label** and the **MAP Tagger Tool** (page 80).

**LINE LABELS**

MAPublisher will place Line labels intelligently, depending on the curvature and length of the line string. Click the **Line Labels** button to assign MAPublisher Line Label Settings.

MAPublisher will control where text is placed along lines by using the **Distance from start** feature. Selecting **Auto** will place text at the midpoint for straight lines and for curved lines this will find the smoothest portion of the curved line closest to the midpoint. Selecting **Fixed** will allow you to control where text is placed along the line. This option uses the percentage along a line to set where text is placed along lines.
**Flip upside-down labels** is always enable by default and will automatically orient labels correctly if your lines are flipped. Disabling this feature will not flip labels.

You can choose to have the labels follow along the line smoothed line paths by checking the **Line Smoothing** option. If this option is used, MAPublisher will create a smoothed path for each text object in the selected Text layer, and place the text along this path at the specified **Offset** value. The labels can then be dragged and positioned at any position along a line. If the **Line Smoothing** option is not selected, the labels will follow along the original path without being smoothed.

The **Label Position** option allows for the selection of the vertical position of the labels relative to the line. Three options are available for the vertical positioning of text labels: **Baseline**, **Descender**, and **Center**. Select **Baseline** to place labels above the generated text path. Select **Descender** to place the portion of a letter in a Latin-derived alphabet that normally extends below the baseline of a particular font above the generated text path. Select **Center** to place the centre the label on the generated text path.

Labels can be modified if they exceed the length of the line in the current default font size. First check the **Adjust label if larger than line** option to activate the label ‘rules’. Rules are executed by MAPublisher in a hierarchical order, the order of which can be edited by clicking on the rule and then pressing the **Up** or **Down** button.

Checking the **Reduce font size** option will allow you to reduce the size of the font to a specified minimum size in points. Checking **Reduce horizontal scaling** will allow text to be scaled down horizontally by the fraction specified.

**Feature Text Label** also provides an additional option (not applicable in **MAP Tagger**). If ANY of the labels have been adjusted in size due to the activation of a line adjustment rule, ALL labels can be resized to the same size by checking the **Set all labels to the same minimum font size** option.

If no rules are enabled, MAPublisher will not perform any scaling of the label, and when any of the rules specified in the panel cannot be satisfied, MAPublisher will default to placing the label centered over the line. Also note that text generated for Line labels will be automatically orientated above the lines, irrespective of the direction of line digitization.

If you attempt to label an area that is on a line layer (for example, if there are lakes on a river layer), the label will be placed as point text to the right of the first point in the polygon.

**AREA LABELS**

MAPublisher will place Area labels intelligently, depending on the shape and size of the area polygon. Click the **Area Labels** button to assign MAPublisher Area Label Settings.

Decide how you wish to place area labels (i.e. with a high degree of precision or lower degree of precision) by choosing the appropriate **Placement Accuracy** option.

You can choose to have the labels oriented along lines of latitude on projected MAP Views by selecting the **Labels curve with lines of latitude** option. If this option is used, MAPublisher will create text paths that will conform to the lines of latitude that the text is placed at. If this option is not selected, the labels will be placed horizontally.

Labels can be modified if they exceed the size of the area in the current default font size. First check the **Adjust label if larger than area** option to activate the label ‘rules’. Rules are executed by MAPublisher in a hierarchical order, the order of which can be edited by clicking on the rule and then pressing the **Up** or **Down** button.
Checking the **Reduce font size** option will allow you to reduce the size of the font to a specified minimum size in points. Checking **Reduce horizontal scaling** will allow text to be scaled down horizontally by the fraction specified. Checking the **Wrap Labels that are longer than area** option will enter a carriage return at the nearest space in the text (note this option is not available if the ‘Labels curve with lines of latitude’ option is checked).

*Feature Text Label* also provides an additional option which is not available with the *MAP Tagger tool*. If ANY of the labels have been adjusted in size due to the deployment of an area adjustment rule, ALL labels can be resized to the same size by checking the **Set all labels to the same minimum font size** option.

If no rules are enabled, MAPublisher will not perform any scaling of the label, and when any of the rules specified in the panel cannot be satisfied, MAPublisher will default to placing the label centered over the area. In situations with area compounds, MAPublisher will label the largest area in the compound.

**POINT LABELS**

Click the **Point Labels** button to assign MAPublisher Point Label Settings.

You can choose to have the labels oriented along lines of latitude on projected MAP Views by selecting the **Labels curve with lines of latitude** option. If this option is used, MAPublisher will create text paths that will conform to the lines of latitude that the text is placed at. If this option is not selected, the labels will be placed horizontally.

Adjust the **Label Position** by specifying where you want the label to be positioned relative to the point. The nine options in the list allow you to select where the text anchor will be placed.

Note that when any of the point settings specified cannot be satisfied, MAPublisher will default to placing the label to the top right of the point.

**FEATURE TEXT LABEL RESULTS**

When all the **Layer Label Options** have been set and the **Label Settings** have been specified click **OK** to label the selected features.

Labels applied using Feature Text Label will appear in the current default colour, font and font size. For latter text edits, the stroke, fill, font and size of text labels can be changed at any time using Adobe Illustrator’s tools.

**IMPORTANT NOTE:** Due to a known bug in the Adobe Illustrator CS2 text engine, running Feature Text Label on lines and/or generating text that curves with lines of latitude may result in a situation whereby undoing such an operation and subsequently running any other labeling operation causes an **apparent** hang or lockup of Adobe Illustrator CS2. Eventually, Illustrator will come back and the operation will continue so in such cases be accordingly patient. This situation is only known to occur in Adobe Illustrator CS2 and typically happens when more than 500 labels are placed in a single instance. In order to avoid this problem, when working with a large number of labels delete the unwanted labels rather than undoing the labeling operation.

Adobe is aware of this issue. At the time of this writing every possible programatic workaround has been explored by Avenza but due to the severity and nature of this Adobe bug no solution is yet available.

This is not an issue in Adobe Illustrator CS3.
**FUNCTIONALITY**

The MAP Tagger Tool allows labels to be added to your map based on the attribute data of the features. Line, Point or Area MAP Layers containing attribute information can be labeled using this filter. This tool functions similarly to the Feature Text Label filter. However, labels are created here by simply clicking on the feature with the Tagger Tool to generate the label. You also have greater control over the initial placement of the label with this tool because the label is placed where you click, plus the tool also provides the ability to create leader lines for labeling congested areas of the map. In addition, you may specify options such as alignment to lines of latitude, minimum font size, horizontal scaling and label position to place labels intelligently.

**PREREQUISITES**

Before using this filter you must create a Text layer in your MAP Views palette. Create a new Illustrator layer, and then drag it to the MAP View holding the features you wish to label. Set the feature type to ‘Text’ when prompted. Furthermore it is often useful to set your default text size, justification and font at this stage, as MAPublisher will generate labels based on these settings.

The MAP Tagger Tool can be found towards the bottom of the Illustrator Tools palette. Simply double click the tool to create new label settings or to edit settings.

**MAP TAGGER SETTINGS**

**SOURCE LAYER & COLUMN**

You must first set the options for MAPublisher to determine the attributes that will be converted to text labels. The Source Layer list will show all Area, Point and/or Text layers in the current document.

For each layer, the Column dropdown(s) will be populated with the attribute structure of that layer. You must choose a column that holds the attributes you wish to label the data with.

**TARGET TEXT LAYER**

In the Text layer dropdown(s), you must specify a Text layer that the labels will be output to. Note you can only output labels to text layers in the same MAP View as the Source Layer.

**LABEL SETTINGS**

MAPublisher provides options to specify label preferences such as label position, alignment to lines of latitude, minimum font sizes and horizontal scaling to best place labels within polygons and paths. These Label Settings are common to Feature Text Label and MAP Tagger Tool. Please see page 76 for more details.

Note that Label Settings can ONLY be used to label data with the MAP Tagger Tool if the Shift key is held down. Please see the following page for the full list of keyboard modifiers.
TAGGING MAP DATA

When you have set all your Layer Label Options and specified Label Settings, click OK to close the window, thus confirming your settings.

With the Tagger Tool selected click on the map object to label it using the selected column and output text layer.

The following list of keyboard modifiers may be used for additional labeling options:
(note = click map object with MAP Tagger Tool selected).

Labels placed using current Illustrator Type Settings. No MAPublisher Label Settings are applied.
- **L** Line labels are placed at click point and assigned angle of line at click point.
- **A** Area labels are placed horizontally at click point.
- **P** Point labels are placed horizontally at click point.

Labels placed using current MAPublisher Label Settings.
- **L** Line labels are generated using established label rules.
- **A** Area labels are placed at click point and generated using established label rules.
- **P** Point labels are generated using established label rules.
  Note: Using the 'Alt' key has no effect.

Only applicable for Line labels. Labels placed using current Illustrator Type Settings. No MAPublisher Label Settings are applied.
- **L** Line labels are placed horizontally at click point.

Labels placed using current Illustrator Type Settings and leader line created on drag. No MAPublisher Label Settings are applied.
- **L** Line labels are placed horizontally. Leader line connects text to line feature.
- **A** Area labels are placed horizontally. Leader line connects text to line feature.
- **P** Point labels are placed horizontally. Leader line connects text to line feature.

Labels placed using current Illustrator Type Settings. No MAPublisher Label Settings are applied.
- **L** Line labels are assigned angle of line at click point.
- **A** Area labels are placed horizontally.
- **P** Point labels are placed horizontally.

Labeling Functions: MAP Tagger Tool
Chapter 9
Grids and Indexes

MAPublisher contains tools for easily creating map grids and map indexes. Grids can be created for reference purposes, or to follow designated lines such as latitude and longitude, and can also be labeled for indexing. When a labeled grid has been established, MAPublisher is able to generate index files, containing the location of text objects in MAP Layers.

This section of the user guide details the use of the MAPublisher Grids and Graticules and Make Index filters for quickly and easily creating accurate grids and indexes for your map.

The following pages will deal with the automatic creation and management of grids, graticules and indexes via the use of the following tools:
Grid and Graticules
Make Index
Grids and Graticules

Filter > MAP Legend > Grids and Graticules
Object > Edit Grid / Edit Graticules

Grids and Indexes: Grids and Graticules

Grid/Graticule Selection
Click the appropriate button to select the grid type required and to assign settings (see below). Note: Measured Grids can only be created on MAP Views in non-geodetic coordinate systems.

Axis Labels - Solid graphic shows labels will be generated. Click an axis label to toggle all labels on that axis ON or OFF.
Line Labels - Solid graphic shows labels will be generated. Click the line label to toggle it ON or OFF.
Label Direction - Click to reverse the direction that labels increment.
Cell Labels - Solid graphic shows labels will be generated. Click a cell label to toggle all center labels ON or OFF.
Flip Label Axes - Click to flip which axis will be labeled alpha and which numerically.

Number of Columns and Rows
- Specify the number of columns and rows which will comprise the grid.

Pass through latitude - Specify a line of latitude that must be included (this can be any meridian within the data extents).
Pass through longitude - Specify a line of longitude that must be included (this can be any meridian within the data extents).
Don’t label - Checking any of these boxes will not label a specific column or row.

Cell Width/Height
- Specify the dimensions of each cell comprising the grid in the current Units.

Style
- Select a style for the grid lines.

Preset Origin
- Choose this option to select a preset X and Y origin.

Fixed Number of Cells
- Check this option to enforce a set number of columns and rows.

Measured Grid Settings

Latitude Intervals
- Specify the interval for each line of latitude.

Longitude Intervals
- Specify the interval for each line of longitude.

Style
- Select a style for the graticules.

Vertices
- Use the slider to increase or decrease the number of nodes which will be used in the construction of the graticules (use a higher number if graticules will be curved).

Grid passes through point
- Choose this option to select specific coordinates for the X and Y origin.

Append units to labels
- Choose to include labels (i.e. degree symbols) for Line Labels.

Units
- Set the units for ‘Measured Grid’ dimensions if appropriate.

Center Style
- Select the ‘Character Style’ to use for the Center Labels.

Axes Style / Place off grid cell
- Select the ‘Character Style’ to use for the Axis Labels. Select a distance off the grid to place the labels.

Line Style / Place off line
- Select the ‘Character Style’ to use for the Line Labels. Select a distance off the grid to place the labels.

Index Grid Settings

Index Grid

Graticule Settings

Latitude
- Pass through a specific latitude.

Longitude
- Pass through a specific longitude.

Style
- Select a style for the graticules.

Vertices
- Use the slider to increase or decrease the number of nodes which will be used in the construction of the graticules (use a higher number if graticules will be curved).

Preset Origin
- Choose this option to select a preset X and Y origin.

Fixed Number of Cells
- Check this option to enforce a set number of columns and rows.

Measured Grid Settings

Cell Size
- Specify the dimensions of each cell comprising the grid in the current Units.

Style
- Select a style for the grid lines.

Preset Origin
- Choose this option to select a preset X and Y origin.
**FUNCTIONALITY**

The Grids and Graticules tool will generate fully editable grid lines based on a number of user-defined settings.

There are 3 grid types available. Selecting **Graticules** allows you to plot grid lines at specific lines of latitude and longitude which will be automatically curved if applicable. Choosing an **Index Grid** allows you to specify the number of cells that you wish to divide the current grid extents into. Choosing a **Measured Grid** also allows you to place grid lines, but with advanced control over placement, size and alignment.

A number of labeling options exist for each type of grid, allowing grid lines and grid cells to be labeled if required.

Any form of grid plotted with this tool can be subsequently resized using the bounding box of the grid, and any parameter can be specifically edited via the **Object > Edit Grid / Edit Graticules** menu item.

**PREREQUISITES**

Before using this filter you must create a **Legend layer** in your Illustrator layers palette. Create a new layer, and then drag this to the MAP View holding the features on which you wish to plot a grid, remembering to set the feature type to Legend.

**MAPublisher** will use the **Normal Character Style** when generating grid labels. If you wish to use a different text size, justification, font, stroke colour and weight, it is useful to create a new character style at this stage (**Window > Type > Character Styles**). A default grid line style will also be used. If you wish to use an alternate style for the grid lines, add the desired style to the **Graphic Styles** palette prior to accessing the Grids and Graticules function.

The MAP View must have a coordinate system assigned in order to plot a grid. Graticules and Index Grids can be generated for any coordinate system. Measured Grids cannot be generated for unprojected MAP Views (i.e. coordinate systems in Lat/Long).

To access the function select the legend layer and navigate to **Filter > MAP Legend > Grids and Graticules**.

**INDEX GRIDS**

The **Index Grid** option allows grids to be created by dividing the extents of the current MAP View into a specified number of cells. Specify the number of columns and rows which will comprise the grid, and select a graphic style for the grid lines.

**GRATICULES**

The **Graticules** option permits grid lines to be placed at specific degree positions and intervals. Specify a line of latitude and a line of longitude that graticule lines must pass through. Then specify the interval for each subsequent line of latitude and longitude, and select a graphic style for the grid lines. Use the slider to increase or decrease the number of vertices used in the graticules if required (use a higher number if the graticules will be highly curved due to the current projection). The graticule may have a section in one of the corners that you do not wish to label (perhaps there is no data in this graticule, or there is only a small portion of that graticule showing and it does not need to be labelled). The **Don’t label** feature allows you to not label a specific column or row.
MEASURED GRIDS

The Measured Grid option allows for cells to be plotted at specific sizes and position when there is a projected MAP View. The extents of the grid can be modified using this option, thus not being limited to the geographical extents of the current MAP View. The width and height of each cell composing the grid should be specified in the Width and Height fields (you can modify the map units used for these dimensions if required by making an alternate selection in the Units list). A fixed number of cells for columns and rows can be enforced if required. Additionally you can specify a preset X and Y origin for the grid, or choose specific coordinates for a ‘pass-through’ point.

LABELING OPTIONS

A number of Labeling options are available for use in grids and graticules. Axis labels and cell labels for indexing and graticule line labels can be included, the direction of axis and cell labels can be modified and the axes used for alpha and numeric labels can be flipped.

When using graticules on projected world maps, axis and line labels may not display properly (due to the extreme curvature of the graticules at the edges). In this case, it is recommended that axis and line labeling are performed manually. Cell labeling is still supported in this scenario.

The labeling graphic shows the status of axis, cell and line labels (solid labels mean that label is ON, grey labels mean that label is OFF). Click any cell label to switch all cell labels on or off. Click a line label to switch that line label only on or off. Click an axis label to switch the labels on that axis only on or off. Click a horizontal arrow to flip the direction of labels on the top and bottom axes. Click a vertical arrow to flip the direction of labels on the left and right axes. Click a corner graphic to swap which axes are labeled numerically and which are labeled alphabetically.

Choose a Character Style to use for the cell labels (if appropriate) by selecting an entry for Center Style. Choose a Character Style to use for the labels on each axis (if appropriate) by selecting an entry for Axes Style. For axes labels specify a distance away from the edge of the grid that the labels will be placed. Choose a Character Style to use for the line labels (if appropriate) by selecting an entry for End of Line Style. For end of line labels specify a distance away from the edge of the grid that the labels will be placed, and append the current units to each label if required (i.e. add a degree symbol for graticule lines).

ADVANCED OPTIONS

Click the Advanced button to access additional grid extents and labeling options.

Modify the extents of the grid by entering new values for the Lower Left and Top Right position of the grid in the current units.

It is also possible to edit the first value used for cell labels by editing the Start alpha/numeric index at values. Omit alpha characters from cell references with the Do not use characters option, for example it may be useful to omit the characters "I" and "O" for indexing purposes (when entering alpha characters to omit, separate characters with a comma). The Reference label order option can be edited to change the center labels from alpha-numeric (A-1) to numeric-alpha (1-A), or vice versa.
**GENERATING AND EDITING THE GRID**

When you have all the options set, click **OK** to create the grid. The grid will be plotted on the legend layer using the entered parameters.

Use the bounding box of the generated grid (**View > Show Bounding Box**) to resize if required. Resizing grids horizontally or vertically will add or remove component cells in the grid.

After transforming a MAP View containing a grid, the grid will be reprojected/rescaled within its current bounds (the physical extents of the grid on the page is not edited). In this scenario you should use the bounding box to resize the grid to the new bounds.

If you wish to change any parameter without generating a new grid, simply select the grid and access the **Object > Edit Grid/Edit Graticules** menu item. This will re-open the Grids and Graticules function and the current parameters of the bar will be available for editing. You can even choose an alternate grid type if required.

**IMPORTANT NOTES**

Manually editing type position, font, colour etc is not possible on Grids and Graticules in their default grouped state. Manual editing is possible however if you first ‘expand’ the object (**Object > Expand**), though this will negate any opportunity to subsequently edit the art via the Grids and Graticules filter.

Certain projections may cause incomplete grids and/or graticules to be drawn. Such issues may occur if the MAP View is in a polar projection or the extents of the data cross the 180 degree west/east meridian.

If the generation of a grid/graticule causes blank or incomplete results, the following workflow should be executed:

1. Reproject the MAP View to a standard Lat/Long projection (i.e. “NAD27 Lat/Long, Degrees”).
2. Generate your grid or graticules on this MAP View.
3. ‘Expand’ the object (**Object > Expand**).
4. Create a new Area layer in the MAP View. Drag the expanded grid to this new layer.
5. Reproject the MAP View back to the original projection.

*Please see Appendix 2 for more information on working with grids and graticules in MAPublisher 7.*
Make Index
Filter > MAP Legend > Make Index

FUNCTIONALITY

When a MAPublisher 7 Grid or set of Graticules have been created, the Make Index filter can be used to generate an index for your map based on the position of text elements in referenced grid cells. Index files generated using this function are produced as a simple text file, and sorted alphabetically. A typical file would be formatted as follows:

- Melrose Place B-4
- Richview Avenue A-5
- Sesame Street A-4
- Wisteria Lane B-5

PREREQUISITES

In order to facilitate the creation of a map index using this filter you must have created an Index Grid, Measured Grid or set of Graticules using the Grids and Graticules filter. This grid must exist on a Legend layer, and be selected in order to access the function. Note an index will be created even if grid labels are hidden.

The Text layer containing the labels to be indexed must be located in the same MAP View as the grid.

Ensure the grid is selected, then go to Filter > MAP Legend > Make Index to access the Make Index tool.
USING MAKE INDEX

INDEX BASED ON LABEL POSITION

This method will create an index by assigning one index location for each label found on the selected label text layer. For example if the label "High Street" is only found in grid cell A-4, the only entry for "High Street" in the index file would be as follows:

High Street A-4

Select the Make index based on label position button to generate an index using this method. Then choose the Label layer from the dropdown which contains the text you wish to index.

INDEX BASED ON LABEL AND MATCHING FEATURE POSITION

This method will create an index by matching label text on a selected ‘Label layer’ to the indicated attribute on the ‘Feature Layer’, creating an index entry for every grid cell in which the feature can be found. Note that only features that have labels can be indexed. For example if “High Street” passes through grid cells A-3, B-3 and C-4, the grid cells will be sorted alphabetically on one line.

High Street A-3, B-3, C-4

Select the Make index based on label & matching feature position button to generate an index using this method. Then choose the Label layer from the dropdown which contains the text you wish to index. Choose the layer that was used to generate the labels from the Feature layer dropdown. In the Label text matches attribute list, select the attribute column in the selected Feature layer which matches the labels you are indexing.

FORMATTING OPTIONS

If you wish to set additional options to control the formatting of your index file, click the Advanced button.

Choose an option to Sort index by. This will be the ordering of your index entries. The default is the Feature label itself, meaning for example, countries starting with ‘A’ will be listed first. Alternatively, you can choose to index by Grid cell, meaning labels inside the cell marked ‘A-1’ will be listed first.

If you require the software to remove entries that are duplicates (i.e. street names named twice in the same grid cell) you should click the option to Remove duplicate entries.

Make Index also provides an option to specify an Entry Delimeter, being the form of the separator between grid cell and text label for each index entry. You can choose from Tab, Comma, or specify a Custom delimiter.

SAVING THE INDEX FILE

When you have set all of your index options, click the Save As button. This will allow you specify a name for the text file, and the location where it will be saved. You can open this file in a text editor, or place it back into document using Illustrator’s Place function.
Chapter 10
Making Selections

MAPublisher contains tools for selecting data graphically and by attribute values.

The **MAP Selection Filters** tool provides functionality to create, edit and save multiple selection criterias within a palette. These selections can be applied on any MAP Layer, and are saved inside the document.

The **Selection Stats** tool can be used for quickly selecting all features contained in a MAP Layer, for viewing how many objects are selected at a given time, to save a selection and to reverse selections.

The following pages will deal with the automatic selections of map features based upon attribute values and the management of previously recorded selections via the use of the following tools:

**MAP Selection Filters**
**Selection Statistics**
MAP Selection Filters

Window > MAPublisher Palettes > MAP Selection Filters

**FUNCTIONALITY**

MAPublisher Selection Filters allow you to build, edit and apply multiple selection criterias based on the attributes and properties contained in MAP Layers. Selection criterias are created in an expression builder, where you can create an expression to describe the selection you wish to make. Selection filters can be applied to any MAP layer, and are saved in the document so that they can be edited or applied later.

**CREATING A SELECTION FILTER**

The MAP Selection Filters palette is opened by going to Window > MAPublisher Palettes > MAP Selection Filters. This palette will contain a list of all the selection filters in the current document.

Create a new MAP Selection Filter by clicking on the **New Selection Filter** button or menu item. This will open the **New Selection Filter** window.

The **Name** field can be edited to describe the selection filter or its intention. For example, a selection filter could be named “Cities” or “Countries with 80% or higher literacy”. 
The **Expression** field describes the criteria for the selection of feature art. Simply enter a valid expression in the Expression field. The **Expression Validity** icon will report ✔️ if the expression entered is valid. Otherwise it will report 🚫 and include additional warning notes.

Alternatively click on the **Browse** button to enter and edit expressions via the **Edit Expression** tool (page 44).

The following are some examples of basic expressions which can be entered for use as selection filters.

**NAME = “Ontario”**
Result: When applying this filter, all items with the value “Ontario” in the ‘NAME’ column are selected.

**POPULATION < 1000000**
Result: When applying this filter, all items with values less than ‘1 million’ in the ‘POPULATION’ column are selected.

**NAME = “Ontario” OR NAME = “Alberta”**
Result: When applying this filter, items with the value “Ontario” OR “Alberta” in the ‘NAME’ column are selected.

**NAME = “Ontario” AND POPULATION < 1000000**
Result: When applying this filter, only items containing the value “Ontario” in the ‘NAME’ column AND values less than ‘1 million’ in the ‘POPULATION’ column are selected.

Click the **OK** button to create the filter, adding it to the list of filters in the palette.

**EDITING AND DELETING SELECTION FILTERS**

The name and entered expression can be edited. To edit a MAP Selection Filter double-click the appropriate selection filter in the palette, or click on the selection filter in the palette and click the **Edit Selection Filter** menu item. This will open the **Edit Selection Filter** window.

Delete a MAP Selection Filter by clicking on the **Delete Selection Filter** button or menu item.

**MAKING SELECTIONS**

Once MAP Selection Filters have been created they can be applied to a MAP layer. Selection filters can only be applied to one layer at a time. However more than one filter may be applied simultaneously (use Shift or Ctrl to select multiple filters). When applying multiple selection filters, art only has to satisfy one of the chosen selection filters to qualify (i.e. multiple selection filters are combined using the “OR” operator).

Note: when the expression is marked as valid, it is not necessarily valid when applied to a given layer. For example, the expression Country=”Ohio” is only applicable to a layer with the Country attribute. If an expression is not valid for a layer, an error is shown when the selection filter is applied.

There are four methods of applying a selection filter (available as buttons and menu items):

- **Apply as New Selection**: Clears the current selection and selects any art on the current layer that meets the criteria of the chosen selection filter(s).
- **Add to Current Selection**: Adds any art on the current layer that satisfies the chosen selection filter(s) to the current selection.
- **Remove from Current Selection**: Deselects any art on the current layer that is selected and satisfies the chosen selection filter(s).
- **Get Subset of Current Selection**: Deselects any art on the current layer that is selected and does not satisfy the chosen selection filter(s).
Selection Statistics
Window > MAPublisher Statistics > MAP Selection Stats

USING THE SELSTATS WINDOW

Open the Selection Statistics window by going to Window > MAPublisher Statistics > SelStats.

LAYER STATISTICS

On initial opening, this palette will display the total number of Map features that exist on the current MAP Layer, as well as how many are currently selected. As only one feature type is supported per MAP Layer, this dialog will only display the current feature type. Only MAPublisher objects will be displayed in the SelStats window. Objects that are in a [Non-map layer] in the MAP Views palette, will not be recognized in this window.

Selecting objects manually or via a MAP Selection Filter will update the left hand field in this palette. The right hand field will display the total number of Map features that exist on the current MAP Layer.

ALL OR REVERSE

The dialog offers a quick way to select all map features on the current layer. Simply click the A (All) button to select all the Map features on the current layer.

Clicking the R (Reverse) button will reverse the current selection, i.e. all the features that were selected will be deselected, and the features that were deselected will be selected.

SAVING SELECTIONS

The Save button will save the current selection to memory, allowing you to retrieve your selection again later. Only one selection can be saved, and it is limited to the current Illustrator session. A subsequent click on the Save button will overwrite the original saved selection.

Clicking Recall will perform the selection that is saved to memory. Clicking Clear on the other hand, will remove the saved selection from memory.
**ADDITIONAL SELECTION OPTIONS**

This window also offers additional selection tools: \textit{M OR, M AND, \\ & M XOR}.

- **M OR** button will select both the currently selected objects and the saved selection.

- **M AND** button will select the map features in the current selection which are included in the saved selection.

- **M XOR** button will select both the currently selected features and the saved selection if these selections do not overlap. However if the current selection includes any features that are part of the saved selection, those will be deselected when this button will is clicked.
MAPublisher contains several tools for working with Map Line segments.

As the graphics environment offers much more flexibility when working with vector artwork, MAPublisher offers graphics specific line tools, which will be discussed in detail in this chapter.

**Buffer Lines** will allow you to create a buffer around current lines at designated distances in Map Units.

**Flip Lines** can be used to swap the start and end points of lines if these line strings were not originally digitized in a preferable manner.

**Join Lines** can be used to connect line segments into continuous line strings based on a specified attribute column.

**Simplify Lines** will allow you to remove points and add Bezier curves to all or selected lines based on mathematical formulae.

**Join Points** will allow you to join point symbols based on attribute values. This tool will generate a line string joining common points, and is ideal for GPS data.

The following pages will deal with the automatic manipulation and management of line features via the use of the following tools:

**Buffer Lines**
**Flip Lines**
**Join Lines**
**Simplify Lines**
**Join Points**
Buffer Lines
Filter > MAP Lines > Buffer Lines

FUNCTIONALITY

The MAPublisher Buffer Lines filter creates buffer ‘Area’ objects around the linework. This can be useful if you are attempting to calculate distances on each side of a line. An example where you would use this tool could be in the planning of new roads, where the actual width of the highway is a major consideration.

PREREQUISITES

Your MAP Layer must be a Line layer to use Buffer Lines.

Before using this filter you must create an Area layer in your Illustrator layers palette. Create a new layer, and then drag this to the MAP View which holds linework you wish to buffer, remembering to set the feature type to Area.

To use this tool, select the line(s) you wish to buffer, and then go to Filter > MAP Lines > Buffer Lines.

USING BUFFER LINES

You can choose to buffer lines by entering a value or by selecting an attribute column that contains buffer values. The buffering value specified designates the total width of the new area object. For example, a value of 10 would create a buffer of 5 on either side of the selected line. This works on individual lines or a selected set of vectors. The buffer width will be calculated and created assuming the units of measurement to be the current map units.

Set the unit to use for the buffer value from the Units list. Then choose which option to use for the buffer values.

When the Buffer Lines filter is run with the Data by Column option checked, an area width is calculated based on the value(s) related to the selected object(s) in the attribute table. The area will then be constructed based on the line’s attribute value.

When the filter based is run based on a Specify Value, an area object is created as calculated by the specified value.

Choose the Area layer to place the buffer(s), then click OK to generate the areas.
FUNCTIONALITY

The MAPublisher Flip Lines filter reverses the beginning and end points of a line.

Labeling linework in Adobe Illustrator is designed to position labels starting at the beginning of a line, and the orientation of the text depends on the starting point of the line or arc being labeled. As a result, cases can occur where labels are placed upside down or backwards from where you would like them.

In order for the labels to be consistent for a group of lines, flipping some of the lines may be necessary, for example when manually entering text on line segments.

You can flip lines on Line layers and Area layers. In order to use this filter, select the lines you wish to flip, and then go to Filter > MAP Lines > Flip Lines

Note that if you have negative values for polygons in the ‘#Area’ column of your MAP Attribute table (Counter clockwise ‘#AreaDirection’), you can use Flip Lines to convert the MAPublisher area calculation to a positive value. When exporting Area layers to GIS formats, polygon outlines must have a positive ‘#Area’ value.
**FUNCTIONALITY**

The Join Lines filter allows a group of linear features to be joined based on a common value within an attribute column. For example, it may be desirable to join all segments of a particular street by the common attribute of street name in order to create a single line element representing that street. When the Join Lines filter is run a new layer is created containing the joined lines in order to avoid deleting other attributes within the original street layer. The new MAP Layer contains the joined lines with an attribute column representing the joined column.

Join Lines can be very useful for reducing the size of a data file by joining related lines and thus reducing the number of segments and associated data present in the file. It is also very useful to run Join Lines prior to labeling with Feature Text Label in order to reduce the occurrence of duplicate labels.

**PREREQUISITES**

This tool can be executed on selections on Line layers. To access Join Lines, go to Filter > MAP Lines > Join Lines.

**USING JOIN LINES**

In the Join on Attribute dropdown, select the attribute column containing the attributes you wish to join. For example to join lines based on street name, you should select the column containing the street names. This will result in line segments containing the same street name being joined.

In the Destination Layer field you should specify a name for the new Line layer that MAPublisher will create to hold your joined lines.

A Proximity value should be entered and Proximity Units assigned. Units can be specified in map units or page units. Entering a proximity value of zero will only join line segments that are touching. If the distance between the end of a segment and the start of another is greater than the proximity value you enter, these lines will not be joined.

If two line segments in the selection are separated by a distance less than the set proximity value, check the Close Segment Gaps option to create a line segment that connects the two lines.

To generate a single path instead of a compound path whenever a set of joined lines have common endpoints, check Generate non-compound paths if lines have common endpoints to create single paths with common endpoints.

When you have entered your preferences for the join click the OK button. On the newly created Line layer view the layer’s attributes in the MAP Attributes window. Note that the only attribute columns present are the default #Property columns and the attribute column you specified for your join.
**FUNCTIONALITY**

The MAPublisher **Simplify Lines** filter allows for the simplification or generalization of imported vector data. The Simplify Lines function uses the popular Douglas-Peucker algorithm for removing nodes and vertices during simplification. For more information on the Douglas-Peucker algorithm see page A1/40.

Simplify Lines is used to reduce the number of points required to represent a vector-encoded digitized line where the lines are approximated by a stream of X-Y coordinates. The function can be used on **Line** or **Area** layers and removes nodes based upon a proximity value in either **Map** or **Page Units**.

The simplify tolerance (‘proximity’ value) is based on the vertical difference between the begin-end line and points off a line, NOT the distance between anchor points on the line. The Douglas-Peucker algorithm takes the proximity value you give it and iterates through the line vertices to determine the points that fall within the specified tolerance distance off the line and removes those vertices. Once all vertices are determined to be greater than the proximity value off the line the processing ends. A smaller proximity value will generally result in a fewer number of nodes being removed.

**USING SIMPLIFY LINES**

To access the function go to **Filter > MAP Lines > Simplify Lines**. Decide if you wish to enter a proximity value in **Page Units** or **Map Units** by making a selection from the ‘Units’ listbox. Page Units will be simply the units of the current document. Enter a proximity value in the units you have specified by entering a value or by using the slider.

Check **Use Bezier Curves** if you wish to generate curves where nodes have been removed. *Note that many GIS applications do not support bezier curves. If you are planning to export your map to GIS formats you may need to use Illustrator’s Add Anchor Points function.*

It is always a good idea to experiment with different proximity values in order to achieve the desired results particular to your scale and coverage area.
Join Points
Filter > MAP Lines > Join Points

**FUNCTIONALITY**

The **Join Points** filter allows a group of point symbols to be joined to form a line, based upon sorting criteria which exist in the attribute structure of the point layer. For example, it may be desirable to join points that were originally generated by a GPS device, in order to create line elements connecting these points. When the Join Points filter is run a new layer is created containing a line linking each set of common points, with the generated layer containing the same common attribute column that was used to group the points together.

**PREREQUISITES**

Join Points can only function on **Point** layers, and can be used on both currently selected point symbols or all the point symbols on a specified layer. There must be at least two attribute columns on the specified point layer in order to use Join Points. To open the dialog, go to **Filter > MAP Lines > Join Points**.

**USING JOIN POINTS**

From the **Input Layer** dropdown, select the **Point layer** containing the points you wish to join. Then specify if you wish to join **All Points**, or just the **Selected Points** on this layer, by clicking the appropriate radio button.

Specify a name for the **Output Layer** that this function will generate. By default, the program will generate a **Line** layer. To generate an **Area** layer (by linking the line end to the start) check the **Close paths** option.

In the **Group By Column** dropdown, select the attribute column containing the common attributes you wish to join together. For example to join points based on a unique ID, you should select the column containing the common ID names. This will result in point symbols containing the same name being joined together.
As each point that is joined will be represented by a node in a line string you must now specify a logical order by which the points will be joined. For example, it is logical that the point which was captured by a GPS unit first should be at the first node in the line string, with the second and third points being located at the second and third nodes. In order to specify these parameters, you must choose columns by which to sort your points. These should be attribute columns which contain rising alphabetical or numerical values.

In the **Sort By Available Columns** list, select the primary sorting column. This should be the attribute column that contains the best fit for rising alphabetical or numerical values. For example if points have rising values from 1 - 10, the point with a value equal to 1 will be at the start of the generated line, and the point with a value equal to 10 will be at the end of the line. When you have selected the column, click the **Add** button to place the column into the **Sort Order** list. If all the values contained in the first ‘Sort By’ column are unique, you will not be required to set a secondary column.

If the first ‘Sort By’ column contained any similar values, you must specify a secondary column. Again click on a column in the **Sort By Available Columns** list, and then click the **Add** button to place the column in the **Sort Order** list. Similarly third, fourth and fifth ‘Sort By’ columns can be specified in the same manner if previous columns contain similar values. Note that the ‘Sort By’ columns are a hierarchy with the topmost specified column being used for the primary sort, then the second, then third etc.

To move columns up or down the hierarchy after they have been specified, simply select the appropriate column in the Sort Order list and click either the **Up** or **Down** button.

To remove any ‘Sort By’ columns from the hierarchy, select the column in the **Sort Order** list and click the **Remove** button.

Note that a maximum of 5 columns can be used to sort points into a logical order. If the columns specified to sort by do not distinguish an ordering between certain points, the order of these points in the attribute table (i.e. the order in which they were digitized) will be used to determine the order of the nodes in the generated line string.

**RESULTS**

When all the options have been set click the **OK** button to join the points on the specified layer. An **Area** or **Line** layer will be generated, depending on the specified output layer type, which will be placed in the same MAP View as the Input Point layer which has been joined.
Chapter 12

Scale Bars and North Arrows

MAPublisher contains tools for plotting accurate scale bars and north arrows onto your map.

The Scale Bar tool offers a number of different designs that you can choose from, including double-bar designs for the placement of scale bars in multiple units.

North Arrows are created from selected artwork on the page using the Create North Arrow filter, being immediately aligned to true north.

The following pages will deal with the automatic creation and management of scale bars and north arrows via the use of the following tools:

Scale Bar
Create North Arrow
FUNCTIONALITY

MAPublisher contains ten different Scale Bar designs that you may incorporate into your map. After creation, MAPublisher Scale Bars can be subsequently resized via a bounding box (for example to add or remove component intervals). Scale Bars can also be edited by selecting the Object > Edit Scale Bar menu item.

PREREQUISITES

To accurately place a Scale Bar your MAP View must contain accurate georeferencing information and be of a non-geodetic coordinate system (i.e. not in degrees). The MAP Layer on which you intend to place your Scale Bar must be a Legend layer, and be selected and unlocked.

If you require a custom character style to be used for the labels of the Scale Bar, it is also advisable to establish this style (Window > Type > Character Styles) before opening this dialog.

The Scale Bar dialog can be accessed by selecting Filter > MAP Legend > Scale Bar.
ADDING A SCALE BAR

STANDARD OPTIONS

Use the Previous and Next buttons to select the Scale Bar design you require. Note that certain scale bar designs contain two bars and when such a design is selected, the ‘Second Bar’ column of options will be enabled.

In the Units list(s), specify the units that you wish the Scale Bar interval(s) to be based on. The default units are that of the current MAP View.

In the Interval field(s), specify a real-world distance that each interval of the Scale Bar will represent. This figure will be in the Unit you specified in the Units list.

ADVANCED OPTIONS

Click the Advanced button to show or hide additional Scale Bar parameters.

Specify the number of cells in the bar(s) by entering a figure in the Number of labeled intervals entry field.

Depending on the style of Scale Bar you have chosen, you can also specify the Number of horizontal lines that will compose the Scale Bar.

If you wish some of the intervals or cells in the bar(s) to be additionally subdivided, choose a figure from the Number of intervals to subdivide list. The subdivided cells will begin from the left of the bar(s). The Number of sub-intervals that compose each of these cells can be specified in the next list. You can also choose to Add an interval left of zero if required.

LABELING OPTIONS

Choose a Text style for the Scale Bar labels by choosing a style from the list.

The label options allow you to add extra scaling information to the generated Scale Bar. The text that will be generated by this tool is displayed in the Preview Panel when the options are set.

GENERATING THE SCALE BAR

When you click OK the selected Scale Bar will be placed on the legend layer at a default position. You can use Illustrator’s editing tools to move the Scale Bar to a desirable location.

EDITING A SCALE BAR

Use the bounding box of the generated scale bar (View > Show Bounding Box) to resize. Resizing scale bars horizontally will add or remove intervals from the bar(s). Resizing vertically will adjust the width of the bar(s).

If you require a different design to be used for your Scale Bar, or wish to change any parameter without generating a new version simply select the Scale Bar and access the Object > Edit Scale Bar menu item. This will re-open the Scale Bar function and the current parameters of the bar will be available for editing.

Note: Manually editing the type position, font, colour etc. is not possible on Scale Bars in their default grouped state. However, manual editing is still possible if the object is ‘expanded’ first (Object > Expand). Please note, however, that this will remove all opportunity to subsequently edit the art via the Scale Bar filter. Please see Appendix 2 for more information on working with scale bars in MAPublisher 7.
Create North Arrow
Filter > MAP Legend > Create North Arrow

FUNCTIONALITY
The MAPublisher Create North Arrow filter provides the functionality to convert selected symbology into a geographically correct North Arrow. Once the north arrow is created it will be rotated true north, and this property will be maintained through subsequent reprojection or rotation.

PREREQUISITES
The MAP Layer on which the art to be converted to a North Arrow resides must be a Legend layer, and be selected. This Legend layer must be hosted by the MAP View that you wish to base the alignment of your North Arrow on.

CREATING A NORTH ARROW
Select the piece of art that you want to convert to a North Arrow. The art can be any form of artwork which can normally be converted to an Adobe Illustrator symbol. Then select Filter > MAP Legend > Create North Arrow.

On creation the North Arrow will be added to the Illustrator Symbols palette, and the coordinate system of the host MAP View will be used to align the North Arrow correctly.

Note: Sample North Arrow designs are included on your MAPublisher CD. Go to Window > Symbol Libraries > Other Library… navigate to the Utilities folder on your CD and load the ‘MAP_NorthArrows.ai’ file. Drag the required symbol onto your Legend layer and then execute the Create North Arrow filter.
MAPublisher contains tools for working with geographic raster images such as aerial photography and satellite imagery.

The **Register Image** filter allows you to accurately register raster images, with or without georeferencing information, to your vector map data.

The **Export Image** filter provides the functionality to export raster images with georeferencing information attached.

Georeferencing information for such images are usually stored in a separate text file (except GeoTIFF) where the image and its associated reference file have the same file name but a different file extension.

The reference file formats that can be read by Register Image, or written to by Export Image are:

- **World** (*.tfw)
- **Image Report** (*.irp)
- **MapInfo TAB** (*.tab)
- **ListGeo** (*.lgo)
- **GeoTIFF** (*.tif) (a single file containing both the image and its reference data)

The following pages will deal with the import and export of raster imagery via the use of the following tools:

**Register Image**

**Export Image**
Register Image
Filter > MAP Images > Register Image

FUNCTIONALITY

The Register Image filter is used to accurately register raster imagery to your vector data. MAPublisher will study the parameters of the raster image and the coordinate system of a selected MAP Layer in the registration process.

PREREQUISITES

In order for this filter to be functional the raster image MUST be in the same coordinate system as the MAP Layer you wish to register it to. You must therefore check the coordinate system of your imagery with your data provider before attempting to use Register Image.

It is possible to reproject vector data in MAPublisher first (see the MAP View Editor on page 59) if you require your vector data to match your imagery. Alternatively you can use Avenza’s Geographic Imager to reproject the imagery to match the vector data.

When you are certain that both your MAP Layer and your raster image are in matching coordinate systems, you can place the image into Illustrator. It is often useful to first set up a special layer to hold your images. Therefore create a new layer and drag it into the MAP View containing your vector layers. As this new layer will be holding the Image only, you can assign any feature type when you drag the layer to your intended MAP View. Use Illustrator’s Place function (File > Place) to select the image and place it onto your new MAP Layer at a default location.

With the image selected go to Filter > MAP Images > Register Image to access the function.
USING REGISTER IMAGE

REGISTRATION VIA A REFERENCE FILE

To select a reference file click the Load File button and navigate to the folder containing your reference file. The reference file will normally be of the same name as your image, but will have the extension .irp, .tfw, .tab, .lgo or .tif. If your image is a GeoTIFF you should select your image file in order to retrieve georeferencing information, as files of this type will contain both the image and its reference data. Select your reference file and click Open. The values contained in this reference file will be entered automatically into the Image Parameters.

MANUAL REGISTRATION

To manually enter image parameters you must have one of the following available in page units OR map units:

a) The X/Y coordinates of one corner of the image + the Pixel Size.
b) The X/Y coordinates of one corner of the image + X/Y size of the image.

First choose the units you wish to use for entering parameters by making a selection from the Units list.

Set the Corner Coordinates you have known values for, by clicking the appropriate corner of the graphic. Then enter the X and Y coordinates for this location in the adjacent fields.

Next set EITHER the Pixel Size or Effective Map Size. The ‘Pixel Size’ is the value of a single pixel in the units set. The ‘Effective Map Size’ is the X/Y size of the whole image in the units set. Setting either option will update the other accordingly.

Note: MAPublisher’s Register Image now supports the registration of images having non-square pixels.

RESULTS

When you are confident that all values have been assigned correctly, click the OK button.

Providing the coordinate systems of the raster image and the MAP Layer match, and the values you have either entered manually or via a reference file are correct, the image will be scaled and registered with your vector data.
Export Image
Filter > MAP Images > Export Image

FUNCTIONALITY
MAPublisher offers the ability to export previously placed raster files as georeferenced images for use in other programs and/or for archival purposes. This can be useful in a number of ways. For example, when working with an image for which there is no georeferencing file you can use the MAPublisher Export Image function to create a GeoTIFF or other georeferenced image file based upon the coordinate system of the host MAP View.

The Register Image filter can be used to accurately position and scale imagery with vector data. Alternatively you can manually move, scale or rotate imagery to align with artwork in a designated MAP View. If your host MAP View contains accurate georeferencing information you can use Export Image to save raster data to a fully georeferenced image format. It is also possible to convert your vector artwork to a georeferenced raster image.

MAPublisher will export the selected image as a TIF, with a choice of the five reference file formats as discussed at the start of the Working With Images section.

USING EXPORT IMAGE
With the Image selected go to Filter > MAP Images > Export Image.

The Store Geography as dropdown will list the five available reference file formats. A regular TIF file will be generated with a reference file carrying the extension TFW, IRP, TAB or LGO if you choose one of these formats. If you select GeoTIFF from this dropdown only a TIF file will be produced, as this will carry both the image and the georeferencing information.

RESULTS
When you have set all of your export options, click the Save As button. This will allow you to specify a name for the TIF file, and the location where it will be saved. If the format is a TIF and reference file combination, the reference file will carry the same file name and will be saved to the same location as the TIF.

You can subsequently use this image file in imagery applications, such as Avenza’s Geographic Imager, or in other Illustrator documents using MAPublisher.
Chapter 14
Drawing Tools

In MAPublisher, any artwork you create on a specified MAP Layer using Illustrator’s drawing tools will be incorporated into the map data on that layer, and can therefore be rescaled or reprojected with the existing data. If the new artwork is of the same feature type as the MAP Layer, they will be automatically added to the attribute table of that layer. Therefore it is very easy to quickly add features to MAP Layers.

MAPublisher also provides two of its own tools, which are designed to draw rectangular or elliptical areas of specified dimensions in Map Units. The MAP Area Tools will be discussed in this section.

The following pages will deal with the automatic creation and management of spatially accurate rectangles and ellipses via the use of the following tools: MAP Area Tool
**MAP Area Tools**

*Toolbar > MAP Area Tool (Box)  / MAP Area Tool (Ellipse)*

**FUNCTIONALITY**

By using the **MAP Area tools**, areas of exact map dimensions can be quickly added to any MAP Layer and its related attribute table. Whenever an area is created using the MAP Area tools, any objects that fall inside the area (in whole or part) will be automatically selected.

**USING THE MAP AREA TOOLS**

**OVERVIEW**

MAPublisher offers **Ellipse** and **Rectangle** drawing tools. Select whichever shape you require from the main Illustrator **Tools** palette, and select the MAP Layer which contains the coordinate system on which you want to draw the shape.

There are two methods of using the MAP Area tools. As with Illustrator shape tools you can either click and drag to create a shape at an unspecified size. Alternatively you can single click in the MAP document to open the **Add Area** dialog, where you specify exact width and height values for the shape.

**DRAWING VIA CLICK AND DRAG**

To draw shapes at unspecified sizes, click and drag over the Map document while holding down the left mouse button until the desired area has been outlined, as is done with the standard Illustrator area drawing tools. Use the **Alt** key (Windows) or the **Option** key (Mac) to draw from the centre and/or the **Shift** key to constrain the proportions. When you release the mouse button the area will be created.

**ENTERING SPECIFIC DIMENSIONS**

To draw shapes at specified sizes, single click at a point in your Map document at the location from which you wish to plot the shape. The MAPublisher **Add Area** dialog will appear into which you can enter specific dimensions for the area to be drawn. If you wish to have the area centered over the click point simply check the **Center area on click** box. If you do not check this box an area will be drawn from its upper left corner. Click **OK** to plot the shape.

**RESULTS**

Plotting a shape using either of these methods will initially select the features that fall, inside the area (in whole or part). Therefore, these tools can be also useful for selecting features that are within designated distances away from a central location.
Appendices

Appendix 1: TECHNICAL REFERENCE GUIDE ................................................................. A1/1
  GRAPHIC FILE FORMATS ....................................................................................... A1/1
  MAPUBLISHER IMPORT FORMATS ........................................................................ A1/2
  MAPUBLISHER UNICODE SUPPORT .................................................................... A1/11
    Frequently asked questions ................................................................................... A1/13
    Installation/Activation Issues ................................................................................ A1/13
    Memory and Speed Issues .................................................................................... A1/14
    Data Import Issues .............................................................................................. A1/14
    Exporting Issues .................................................................................................. A1/16
    Labeling Issues .................................................................................................... A1/16
    Projection Issues .................................................................................................. A1/17
    Other Issues ......................................................................................................... A1/17
  GIS BACKGROUNDER .............................................................................................. A1/19
  GRAPHICS BACKGROUNDER .................................................................................. A1/21
  MEMORY CONSIDERATIONS ................................................................................... A1/23
  ONLINE LINKS ........................................................................................................ A1/25
    Free Map Data ...................................................................................................... A1/25
    Other Valuable Mapping Links ............................................................................. A1/27
  TECHNICAL SUPPORT OPTIONS ........................................................................... A1/28
    MAPublisher Maintenance Program ...................................................................... A1/29
  ALL ABOUT PROJECTIONS ..................................................................................... A1/30
  CUSTOM PROJECTIONS .......................................................................................... A1/35
  GENERAL TIPS AND HINTS ................................................................................... A1/40
    Creating ASCII Delimited Point Files ................................................................. A1/41
    Joining SDTS Tables ............................................................................................ A1/42
    Rotating Objects Individually in Adobe Illustrator .............................................. A1/42
    Georeferencing an Adobe Illustrator File ............................................................ A1/42
    Tips on Exporting to other GIS Software ............................................................ A1/43
    Tips on Exporting Data Tables ................................................................................ A1/43
    Douglas Peucker Line Simplification .................................................................... A1/44
    Bezier Curves and other MAPublisher Operations ............................................... A1/44
    Creating Symbols for use in Point Stylesheets .................................................. A1/45
    Creating a Stylesheet Template .............................................................................. A1/45
    Creating a Multi-Condition 'IF' statement ............................................................ A1/45
    Notes for Exporting Images ................................................................................... A1/46
    Keyboard Shortcuts .............................................................................................. A1/46
  UNIVERSAL TRANSVERSE MERCATOR (UTM) ZONE MAP ................................ A1/47

Appendix 2: MAPUBLISHER 7 HOW TO’S FOR LEGACY USERS ............................... A2/1
  LEGEND FUNCTIONALITY IN MAP STYLESHEETS ............................................... A2/1
  GRID AND SCALEBAR OPERATIONS ..................................................................... A2/2
  COPY AND PASTE .................................................................................................... A2/3

Appendix 3: UTILITIES AND BONUS FILES ............................................................. A3/1

Appendix 4: GLOSSARY ............................................................................................. A4/1
Appendix 1: Technical Reference Guide

Graphic File Formats

AI

DOQ
Digital Orthophoto Quadrangle (DOQ) are geographic images from the United States Geological Survey (USGS) and are stored in the JPG format. They can be placed by Adobe Illustrator and registered by the MAPublisher Register Image filter. DOQ’s are usually very large files (30-40 MB or more) and will require extremely large amounts of RAM.

DRG
Digital Raster Graphics (DRG) are scanned images of published topographic maps from the USGS stored in TIF format. They can be placed by Adobe Illustrator and registered by the MAPublisher Register Image filter. DRG’s are also usually very large files (30-40 MB or more) and will require extremely large amounts of RAM for any manipulation within Illustrator.

EPS
The Encapsulated Post Script (EPS) file is used to transfer PostScript language artwork between applications (also see PostScript in the glossary section of the User Guide). EPS files are easily opened by Adobe Illustrator because the format is widely supported by most graphics programs. It is the preferred format for export to most illustration and page-layout programs. EPS files are by their nature vector based, but can contain embedded raster graphics and fonts.

GIF
Graphic Interchange Format (GIF) is a colour-indexed graphics format, commonly used for web pages and image file transfer. Adobe Illustrator can export 8-bit indexed-colour or grayscale gifs.

JPEG
Joint Photographic Experts Group (JPEG or JPG) is a compression technique for raster file formats. The Digital Orthophoto Quadrangle geographic images from the USGS are stored in this format, which can be imported by Adobe Illustrator and registered by the MAPublisher Register Image filter. DOQ’s are usually very large files (30-40 MB or more) and will require extremely large amounts of RAM.

PDF
Portable Document Format (PDF) is a standardized format developed by Adobe for use across Macintosh, Windows, DOS, and UNIX platforms. Based on the PostScript Level 2 language, PDF supports both raster and vector graphics.

TIF/TIFF/GEOTIFF
Tagged Image File Format (TIFF or TIF) is a common raster graphic file format that can be imported by Adobe Illustrator. Many raster geographic images from GIS systems are stored in this format, which can be imported by Adobe Illustrator and registered by the MAPublisher Register Image filter. A GeoTIFF is a TIFF file with embedded geographic information identifying its position and scale in world coordinates.

OTHERS
Please refer to the Adobe Illustrator User Guide for other graphics file formats supported by Adobe Illustrator.
MAPublisher Import Formats

This section contains descriptions of the GIS formats supported for import by MAPublisher. Here you will find an overview of the structure of each format, as well as information on supported format versions and elements unique to each data type. Each file format will carry a checklist covering which core elements are supported by MAPublisher during its import. You can also refer to the Frequently Asked Questions section in this guide for information on any issues associated with the various file formats. Also see the File Formats section on pages 22 to 25.

**AUTOCAD DRAWING (*dwg) and DRAWING EXCHANGE (*.dxf)**

There are two formats used by AutoCAD: DXF is a CAD data file format, developed by Autodesk as their solution for enabling data interoperability between AutoCAD and other programs. The Dwg format is used for storing two and three dimensional design data and is the internal format for the AutoCAD Computer Aided Design package. DWG is also the common name for AutoCAD’s proprietary DWG technology developed by Autodesk for their AutoCAD package.

<table>
<thead>
<tr>
<th>Supported Elements</th>
<th>Supported Geometry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical File Extensions</td>
<td>'*.dwg, *.dxf'</td>
</tr>
<tr>
<td>Automated Translation</td>
<td>Yes</td>
</tr>
<tr>
<td>User-Defined Attributes</td>
<td>Yes</td>
</tr>
<tr>
<td>Coordinate System Support</td>
<td>No</td>
</tr>
<tr>
<td>Generic Colour Support</td>
<td>Yes</td>
</tr>
<tr>
<td>Spatial Index</td>
<td>Never</td>
</tr>
<tr>
<td>Schema Required</td>
<td>Yes</td>
</tr>
<tr>
<td>3D Support</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Supported Versions**

- Windows: Releases vrs. R12 to 2007

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The following parameters can be applied to the import:

- **Group Entities** - Group entities by Layer Name or Geometry.
- **Hatches** - Check this box if you want MAPublisher to read your hatch patterns upon import.
- **White Lines and Fills** - Enabling the ‘Import as is’ option will instruct MAPublisher to import the data true to the original colour settings contained in the file. Check the ‘Change white lines and fills to black’ box to import black lines instead of the files native white lines. Check the ‘Create black background’ option to incorporate a layer containing a black background to mimic the AutoCAD environment.

**ESRI ARCINFO EXPORT (*.e00)**

An archive of files that describes a complete ArcInfo coverage. This is either ASCII or compressed into a binary and is used to transfer files between different versions of ArcInfo. It is a commonly found format for freely distributed data such as that found at the GIS Data Depot ([http://www.geocomm.com](http://www.geocomm.com)).

A single E00 file describes a complete ArcInfo coverage. The file itself is actually an archive of several smaller files, referred to as subfiles. Some of these subfiles have fixed names which do not vary from coverage to coverage,
and follow a predefined data format. The remainder of the subfiles contained within an E00 are the info files. These files may contain user-defined attributes, and have names which vary from coverage to coverage.

<table>
<thead>
<tr>
<th>Supported Elements</th>
<th>Supported Geometry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical File Extensions</td>
<td>Aggregate</td>
</tr>
<tr>
<td>Automated Translation</td>
<td>No</td>
</tr>
<tr>
<td>User-Defined Attributes</td>
<td>Yes</td>
</tr>
<tr>
<td>Coordinate System Support</td>
<td>Circular Arc</td>
</tr>
<tr>
<td>Spatial Index</td>
<td>Yes</td>
</tr>
<tr>
<td>Schema Required</td>
<td>Elliptical Arc</td>
</tr>
<tr>
<td>Geometry Type Attribute</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Polygon</td>
</tr>
<tr>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Point</td>
</tr>
<tr>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Line</td>
</tr>
<tr>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Text</td>
</tr>
<tr>
<td></td>
<td>Yes</td>
</tr>
</tbody>
</table>

There are essentially four types of geometry defined in E00 files, which will be reproduced as layers during import: Arcs (lines), Points, Polygons, and Text. Prior to the import process, an additional Setting can be made:

- **Tic points layer** - This option enables you to include an additional layer which will hold the registration points for the imported data. The default is to set to Yes.

**ESRI ARCTINFO GENERATE (*.gen)**

ESRI simple ASCII storage and interchange format. There are three different types of .gen files each with of its own syntax one for points, one for lines, and one for text geometries. This is the format exported by ArcInfo's generate command. The gen files are use by ArcInfo to transfer coverages to other mapping systems.

<table>
<thead>
<tr>
<th>Supported Elements</th>
<th>Supported Geometry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical File Extensions</td>
<td>Aggregate</td>
</tr>
<tr>
<td>Automated Translation</td>
<td>No</td>
</tr>
<tr>
<td>User-Defined Attributes</td>
<td>Yes</td>
</tr>
<tr>
<td>Coordinate System Support</td>
<td>Circular Arc</td>
</tr>
<tr>
<td>Generic Colour Support</td>
<td>No</td>
</tr>
<tr>
<td>Spatial Index</td>
<td>Elliptical Arc</td>
</tr>
<tr>
<td>Schema Required</td>
<td>No</td>
</tr>
<tr>
<td>Geometry Type Attribute</td>
<td>Polygon</td>
</tr>
<tr>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Donut Polygon</td>
</tr>
<tr>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Point</td>
</tr>
<tr>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Line</td>
</tr>
<tr>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Text</td>
</tr>
<tr>
<td></td>
<td>Yes</td>
</tr>
</tbody>
</table>
**ESRI SHAPEFILE (*.shp)**

The ESRI Shapefile is a geospatial vector data format for geographic information systems software. It is developed and regulated by ESRI as a mostly open specification for data interoperability among ESRI and other software products. A Shapefile is a digital vector storage format for storing geometric location and associated attribute information. This format lacks the capacity to store topological information.

A single logical shapefile consists of three physical files, each with one of the following file name extensions:

- *.shp: Geometric data
- *.shx: Index to the geometric data
- *.dbf: Attributes for the geometric data

These extensions are added to the base name of the shapefile, creating separate physical files that must all reside in the same directory. You must select the *.shp file for import. Point, multipoint, polyline, and polygon geometric data can be stored in *.shp files. However, a single *.shp file can contain only one type of geometry. Each entity in a *.shp file has a corresponding entry in the *.shx index file and a corresponding row of attributes in the associated *.dbf file. The order of the entries in each of these files is synchronized. For example, the 3rd geometric entity in the *.shp file is pointed to by the 3rd entry in the *.shx index file and has the attributes held in the 3rd row of the *.dbf.

A single shapefile may also consist of a number of additional files, with the following file name extensions:

- *.sbn / *.sbx: Spatial index files for the geometric data. These two files are only generating by an ESRI product however they are not required by MAPublisher for import and will they be generated when exporting data to the shapefile format.
- *.prj: Spatial coordinate system information.

If a *.prj file exists in your shapefile directory, holding the coordinate system information of the shapefile, this will automatically be read by MAPublisher on import. If your shapefile folder does not contain a .prj file you will be required to specify the coordinate system in order to fully utilize MAPublisher.

<table>
<thead>
<tr>
<th>Supported Elements</th>
<th>Supported Geometry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical File Extensions</td>
<td><em>.shp (</em>.shx, *.dbf, *.prj)</td>
</tr>
<tr>
<td>Automated Translation</td>
<td>Yes</td>
</tr>
<tr>
<td>User-Defined Attributes</td>
<td>Yes</td>
</tr>
<tr>
<td>Coordinate System Support</td>
<td>Yes (if have *.prj)</td>
</tr>
<tr>
<td>Generic Colour Support</td>
<td>No</td>
</tr>
<tr>
<td>3D Support</td>
<td>Yes</td>
</tr>
<tr>
<td>Schema Required</td>
<td>Yes</td>
</tr>
<tr>
<td>Transaction Support</td>
<td>No</td>
</tr>
<tr>
<td>Geometry Type Attribute</td>
<td>SHAPE_GEOMETRY</td>
</tr>
</tbody>
</table>

**Technical Reference Guide: MAPublisher Import Formats**
MAPINFO INTERCHANGE (*.mif/*.mid)

MIF is a published ASCII storage format used by the MapInfo. It is used as a file format for map and database exporting/importing in MapInfo software products. The MapInfo Reference Manual describes the MIF format and all constants it uses for colour, style, symbol, and fill patterns. MapInfo Interchange Format Files are often called MIF or MIF/MID files.

A single logical MIF file consists of two physical files, having the following file name extensions:

- *.mif: Geometric data
- *.mid: Attributes for the geometric data

These extensions are added to the base name of the MIF file, creating separate physical files that must all reside in the same directory. You must select the *.mif file for import.

Each entity in a *.mif file has a row of attributes stored in an associated *.mid file. A single .mif file contains many different types of geometry however, the associated attribute in the *.mid file must have the same number and type of fields for each entity in the *.mif file. The order of the entries in the two files is synchronized. For example, the second geometric entity in the *.mif file has the attributes held in the second row of the *.mid file. The number and type of attributes associated with each entity is specified by the user. There must be at least one attribute field in the *.mid file.

### Supported Elements

<table>
<thead>
<tr>
<th>Supported Elements</th>
<th><em>.mif (</em>.mid)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical File Extensions</td>
<td>*.mif (*mid)</td>
</tr>
<tr>
<td>Automated Translation</td>
<td>Yes</td>
</tr>
<tr>
<td>User-Defined Attributes</td>
<td>Yes</td>
</tr>
<tr>
<td>Coordinate System Support</td>
<td>Yes</td>
</tr>
<tr>
<td>Generic Colour Support</td>
<td>Yes</td>
</tr>
<tr>
<td>Spatial Index</td>
<td>Never</td>
</tr>
<tr>
<td>Schema Required</td>
<td>Yes</td>
</tr>
<tr>
<td>Geometry Type Attribute</td>
<td>mif_type</td>
</tr>
</tbody>
</table>

### Supported Geometry

<table>
<thead>
<tr>
<th>Supported Geometry</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Aggregate</td>
<td>Yes</td>
</tr>
<tr>
<td>Circles</td>
<td>Yes</td>
</tr>
<tr>
<td>Circular Arc</td>
<td>Yes</td>
</tr>
<tr>
<td>Elliptical Arc</td>
<td>Yes</td>
</tr>
<tr>
<td>Ellipses</td>
<td>Yes</td>
</tr>
<tr>
<td>Polygon</td>
<td>Yes</td>
</tr>
<tr>
<td>Donut Polygon</td>
<td>Yes</td>
</tr>
<tr>
<td>Point</td>
<td>Yes</td>
</tr>
<tr>
<td>Line</td>
<td>Yes</td>
</tr>
<tr>
<td>Text</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The following parameters can be applied to the import:

- **Import as Visible Attributes** - Enable this option to view the pen and brush pattern values in the imported attribute table

The MAPublisher MID/MIF importer supports the storage of point, line, polyline, arc, ellipse, rectangle, rounded rectangle, region (polygon), and text geometric data in .mif files. Each geometric entity present in a *.mif file has display properties such as pen and brush width, pattern, and colour. Supported MID MIF properties are as follows:

**MAPublisher** supports the import of line weights (0-7), colours (24 bit RGB), strokes (1-71). It also supports fonts (family, style, justification) for text. In order to use line patterns and fill patterns you must have opened or accessed the style library equivalents. Two library files have been created, 'MIF_LineStyles.ai' & 'MIF_AreaStyles.ai', which provide support for many of the standard MapInfo pen styles (stroke patterns) and brush styles (fill patterns). These files can be found in the utilities folder on your MAPublisher CD. Please refer to your Adobe Illustrator User Guide for details about how to add these libraries to your Adobe Illustrator Style palette.
MAPINFO TABLE (*.tab)

TAB is a proprietary geospatial vector data format for geographic information systems software used by MapInfo mapping products. A minimum of two files are required for the tab format. The .DAT file which stores the attribute data and the .TAB ASCII file which is the link between all other files and holds information about the type of data file. The MapInfo TAB importer is closely patterned after the MapInfo MIF/MID reader and writer. This commonality makes it easy to support both MIF and MapInfo native formats in the same mapping file.

A single logical TAB file consists of a number of physical files, having the following file name extensions:

* .tab : The main file for a MapInfo table, it is associated with the appropriate dat, map, id and ind files.
* .dat : Tabular data for a table in MapInfo's native format
* .id : An index to a MapInfo graphical objects (MAP) file.
* .map : Contains geographic information describing map objects
* .ind : An index to a MapInfo tabular (DAT) file

These extensions are added to the base name of the TAB file, creating separate physical files that must all reside in the same directory. You must select the *.tab file for import.

<table>
<thead>
<tr>
<th>Supported Elements</th>
<th>Supported Geometry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical File Extensions</td>
<td>Aggregate</td>
</tr>
<tr>
<td>Automated Translation</td>
<td>Circles</td>
</tr>
<tr>
<td>User-Defined Attributes</td>
<td>Circular Arc</td>
</tr>
<tr>
<td>Coordinate System Support</td>
<td>Elliptical Arc</td>
</tr>
<tr>
<td>Generic Colour Support</td>
<td>Ellipses</td>
</tr>
<tr>
<td>Spatial Index</td>
<td>Polygon</td>
</tr>
<tr>
<td>Schema Required</td>
<td>Donut Polygon</td>
</tr>
<tr>
<td>Geometry Type Attribute</td>
<td>Point</td>
</tr>
<tr>
<td></td>
<td>Line</td>
</tr>
<tr>
<td></td>
<td>Text</td>
</tr>
</tbody>
</table>

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The following parameters can be applied to the import:

- **Import as Visible Attributes** - Enable this option to view the pen and brush pattern values in the imported attribute table

The MAPublisher TAB importer supports the storage of point, line, polyline, arc, ellipse, rectangle, rounded rectangle, region (polygon), and text geometric data in .tab files. Each geometric entity present in a *.tab file has display properties such as pen and brush width, pattern, and colour. Supported TAB properties match those described for MID MIF files on the previous page.
MICROSTATION DESIGN (*.dgn)

DGN are the native files created for Bently Systems Inc's MicroStation product. These files consist of a header, followed by a series of elements. The header contains global information including the transformation equation from design units to user coordinates, as well as the dimension of the elements in the file. Each element contains standard display information, such as its colour, level, class, and style, as well as a number of attributes specific to its element type. For example, a text element has fields for font, size, and the text string in addition to the standard display attributes.

<table>
<thead>
<tr>
<th>Supported Elements</th>
<th>Supported Geometry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical File Extensions</td>
<td>*dgn</td>
</tr>
<tr>
<td>Automated Translation</td>
<td>Yes</td>
</tr>
<tr>
<td>User-Defined Attributes</td>
<td>Yes</td>
</tr>
<tr>
<td>Coordinate System Support</td>
<td>No</td>
</tr>
<tr>
<td>Generic Colour Support</td>
<td>Yes</td>
</tr>
<tr>
<td>Spatial Index</td>
<td>Never</td>
</tr>
<tr>
<td>Schema Required</td>
<td>Yes</td>
</tr>
<tr>
<td>Geometry Type Attribute</td>
<td>igds_type</td>
</tr>
<tr>
<td>3D Support</td>
<td>Yes</td>
</tr>
<tr>
<td>Aggregate</td>
<td>No</td>
</tr>
<tr>
<td>Circles</td>
<td>Yes</td>
</tr>
<tr>
<td>Circular Arc</td>
<td>Yes</td>
</tr>
<tr>
<td>Elliptical Arc</td>
<td>Yes</td>
</tr>
<tr>
<td>Ellipses</td>
<td>Yes</td>
</tr>
<tr>
<td>Polygon</td>
<td>Yes</td>
</tr>
<tr>
<td>Donut Polygon</td>
<td>Yes</td>
</tr>
<tr>
<td>Point</td>
<td>Yes</td>
</tr>
<tr>
<td>Line</td>
<td>Yes</td>
</tr>
<tr>
<td>Text</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The following parameters can be applied to the import: Note: versions V7 & V8 and supported for import.

- **Group Elements** - Choose how you want to group the elements of the file on import. If you group the elements by level, it may result in a large number of output files. ‘By Level’ is the default.
- **Coordinate Units** - Choose Master, Sub, or UOR as the coordinate units of the features. ‘Master’ is the default.
- **White Lines and Fills** - Enabling the ‘Import as is’ option will instruct MAPublisher to import the data true to the original colour settings contained in the file. Check the ‘Change white lines and fills to black’ box to import black lines instead of the files native white lines. Check the ‘Create black background’ option to incorporate a layer containing a black background to mimic the AutoCAD environment.
- **Other** - Check ‘Drop complex chains’ if you want each component of a complex chain to be returned as its own feature, otherwise all elements of the complex chain will be merged into a single linear feature.

TIGER/LINE (*.rt1) (*.bw1)

Topologically Integrated Geographic Encoding and Referencing (TIGER). TIGER is the United States Census Bureau's format for its digital database of geographic features. TIGER includes both land attributes such as roads, buildings, rivers, and lakes, as well as areas such as counties, ZIP codes, census tracts, and census blocks. Some of the geographic areas represented in TIGER are political areas, including counties, congressional districts, school districts, and ZIP codes. Others are statistical areas, including Metropolitan Statistical Areas (MSA), census tracts, census block groups, and census block. The database contains information about these features such as their location in latitude and longitude, the name, the type of feature, address ranges for most streets, the geographic relationship to other features, and other related information. More information on the TIGER/Line file format and data product can be found on the U.S. Census web page at: http://www.census.gov/geo/www/tiger/
This website contains a detailed description of the current TIGER/Line format, with an explanation of field meaning for each feature type. A detailed description of the TIGER/Line 1998 format, with an explanation of field meaning for each feature type, is available at: http://www.census.gov/geo/www/tiger/tiger98.pdf

<table>
<thead>
<tr>
<th>Supported Elements</th>
<th>Supported Geometry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical File Extensions</td>
<td>*.rt1, *.bw1</td>
</tr>
<tr>
<td>Automated Translation</td>
<td>Yes</td>
</tr>
<tr>
<td>User-Defined Attributes</td>
<td>Yes</td>
</tr>
<tr>
<td>Coordinate System Support</td>
<td>Yes</td>
</tr>
<tr>
<td>Generic Colour Support</td>
<td>Yes</td>
</tr>
<tr>
<td>Spatial Index</td>
<td>Never</td>
</tr>
<tr>
<td>Schema Required</td>
<td>Yes</td>
</tr>
<tr>
<td>Transaction Support</td>
<td>No</td>
</tr>
<tr>
<td>Geometry Type Attribute</td>
<td>tiger_type</td>
</tr>
<tr>
<td>Aggregate</td>
<td>No</td>
</tr>
<tr>
<td>Circles</td>
<td>No</td>
</tr>
<tr>
<td>Circular Arc</td>
<td>No</td>
</tr>
<tr>
<td>Elliptical Arc</td>
<td>No</td>
</tr>
<tr>
<td>Ellipses</td>
<td>No</td>
</tr>
<tr>
<td>Polygon</td>
<td>Yes</td>
</tr>
<tr>
<td>Donut Polygon</td>
<td>Yes</td>
</tr>
<tr>
<td>Point</td>
<td>Yes</td>
</tr>
<tr>
<td>Line</td>
<td>Yes</td>
</tr>
<tr>
<td>Text</td>
<td>No</td>
</tr>
</tbody>
</table>

Supported Versions

USGS DIGITAL LINE GRAPH (*.dlg) (*.opt)

DLG is a fixed field record that may or may not have end of line markers. The DLG file structure was designed to accommodate all categories of spatial data represented on a conventional line map. DLG is a published ASCII format developed by the United States Geological Survey (USGS) Federal Agency and is intended to assist in data exchange with the National Digital Cartographic Data Base (NDCDB).

The DLG reader supports all three distinct types of DLG data:
- Large-scale DLG data (1:24,000-scale)
- Intermediate-scale DLG (1:100,000-scale)
- Small-scale DLG data (1:2,000,000-scale)

The three scales of DLG data are physically formatted into files in one of these ways: standard, optional, and graphics formats. MAPublisher supports both the standard and the optional DLG distribution formats; however the graphics format is not supported. Most DLG data is distributed in the optional format.

The DLG file structure was designed to accommodate all categories of spatial data represented on a conventional line map. Node, line, and area data types are present within the DLG format, along with linkages and attribute codes. Linkages are references to other features within the same DLG data set, used in a variety of contexts. DLG files do not explicitly store attribute values but use a feature coding approach in which unique feature codes are assigned to the different types of features stored within the data set. MAPublisher will look for the extension .dlg or .opt for the input DLG files.

<table>
<thead>
<tr>
<th>Supported Elements</th>
<th>Supported Geometry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical File Extensions</td>
<td>*.dlg, *.opt</td>
</tr>
<tr>
<td>Automated Translation</td>
<td>Yes</td>
</tr>
<tr>
<td>User-Defined Attributes</td>
<td>No</td>
</tr>
<tr>
<td>Coordinate System Support</td>
<td>Yes</td>
</tr>
<tr>
<td>Generic Colour Support</td>
<td>No</td>
</tr>
<tr>
<td>Spatial Index</td>
<td>Never</td>
</tr>
<tr>
<td>Schema Required</td>
<td>No</td>
</tr>
<tr>
<td>Geometry Type Attribute</td>
<td>dlg_type</td>
</tr>
<tr>
<td>Aggregate</td>
<td>No</td>
</tr>
<tr>
<td>Circles</td>
<td>No</td>
</tr>
<tr>
<td>Circular Arc</td>
<td>No</td>
</tr>
<tr>
<td>Elliptical Arc</td>
<td>No</td>
</tr>
<tr>
<td>Ellipses</td>
<td>No</td>
</tr>
<tr>
<td>Polygon</td>
<td>Yes</td>
</tr>
<tr>
<td>Donut Polygon</td>
<td>Yes</td>
</tr>
<tr>
<td>Point</td>
<td>Yes</td>
</tr>
<tr>
<td>Line</td>
<td>Yes</td>
</tr>
<tr>
<td>Text</td>
<td>No</td>
</tr>
</tbody>
</table>

Technical Reference Guide: MAPublisher Import Formats
USGS SDTS (*catd.ddf)

SDTS is the USGS’s robust way of transferring earth-referenced spatial data between dissimilar computer systems with the potential for no information loss. It is a transfer standard that embraces the philosophy of self-contained transfers, i.e. spatial data, attribute, georeferencing, data quality report, data dictionary, and other supporting metadata all included in the transfer. More info can be found at http://mcmcweb.er.usgs.gov/sdts/. Files in the SDTS format will have the extension *.ddf. More information on this format can be found at: http://mcmcweb.er.usgs.gov/sdts/

A group of *.ddf files is normally identified by the catalog file, or *CATD.DDF file, which relates the files of a single SDTS transfer, and binds together all the files with a common prefix. Always select the SDTS file which ends in ‘CATD’, i.e. “HP01CATD.DDF”.

**Supported Elements**

<table>
<thead>
<tr>
<th>Supported Geometry</th>
<th>Supported Elements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical File Extensions</td>
<td>*.ddf</td>
</tr>
<tr>
<td>Automated Translation</td>
<td>Yes</td>
</tr>
<tr>
<td>User-Defined Attributes</td>
<td>No</td>
</tr>
<tr>
<td>Coordinate System Support</td>
<td>Yes</td>
</tr>
<tr>
<td>Generic Colour Support</td>
<td>No</td>
</tr>
<tr>
<td>Spatial Index</td>
<td>Yes</td>
</tr>
<tr>
<td>Schema Required</td>
<td>N/A</td>
</tr>
<tr>
<td>Transaction Support</td>
<td>No</td>
</tr>
<tr>
<td>Geometry Type Attribute</td>
<td>sdts_type</td>
</tr>
<tr>
<td>Aggregate</td>
<td>No</td>
</tr>
<tr>
<td>Circles</td>
<td>No</td>
</tr>
<tr>
<td>Circular Arc</td>
<td>No</td>
</tr>
<tr>
<td>Elliptical Arc</td>
<td>No</td>
</tr>
<tr>
<td>Ellipses</td>
<td>No</td>
</tr>
<tr>
<td>Polygon</td>
<td>Yes</td>
</tr>
<tr>
<td>Donut Polygon</td>
<td>Yes</td>
</tr>
<tr>
<td>Point</td>
<td>Yes</td>
</tr>
<tr>
<td>Line</td>
<td>Yes</td>
</tr>
<tr>
<td>Text</td>
<td>No</td>
</tr>
</tbody>
</table>

KEYHOLE MARKUP LANGUAGE (*kml)

KML is an XML-based language for managing the display of three-dimensional geospatial data in the programs Google Earth, Google Maps, Google Mobile and WorldWind. The KML file specifies a set of features for display. Each feature always has a longitude and a latitude and can have other data, such as tilt, heading, and altitude. KML shares some of the same structural grammar as GML. KML files are very often distributed as KMZ files, which are zipped KML files with a .kmz extension.

**Supported Elements**

<table>
<thead>
<tr>
<th>Supported Geometry</th>
<th>Supported Elements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical File Extensions</td>
<td>*.kml, *.kmz</td>
</tr>
<tr>
<td>Automated Translation</td>
<td>Yes</td>
</tr>
<tr>
<td>User-Defined Attributes</td>
<td>Yes</td>
</tr>
<tr>
<td>Coordinate System Support</td>
<td>Yes</td>
</tr>
<tr>
<td>Generic Colour Support</td>
<td>Yes</td>
</tr>
<tr>
<td>Spatial Index</td>
<td>Never</td>
</tr>
<tr>
<td>Schema Required</td>
<td>No</td>
</tr>
<tr>
<td>3D Support</td>
<td>Yes</td>
</tr>
<tr>
<td>Aggregate</td>
<td>Yes</td>
</tr>
<tr>
<td>Circles</td>
<td>No</td>
</tr>
<tr>
<td>Circular Arc</td>
<td>No</td>
</tr>
<tr>
<td>Elliptical Arc</td>
<td>No</td>
</tr>
<tr>
<td>Ellipses</td>
<td>No</td>
</tr>
<tr>
<td>Polygon</td>
<td>Yes</td>
</tr>
<tr>
<td>Donut Polygon</td>
<td>Yes</td>
</tr>
<tr>
<td>Point</td>
<td>Yes</td>
</tr>
<tr>
<td>Line</td>
<td>Yes</td>
</tr>
<tr>
<td>Text</td>
<td>No</td>
</tr>
</tbody>
</table>

Prior to the import process, additional Settings can be made, which will affect how the selected KML file will import. The following parameters can be applied to the import:

- **Allow Random Colour Mode** - Enabling this option will allow Illustrator to generate random colour settings for your data.
- **Expand Network Links** - Checking this box will enable the use of network linked KML files.
**DELIMITED ASCII TEXT (*.csv, *.tsv, *.txt)**

An ASCII file containing a tabular data where delimiters separate the columns and rows. Common delimiters are commas, spaces, or tabs. Microsoft Excel and many other spreadsheet programs will export data in these formats.

### Supported Elements
- **Typical File Extensions**: *.csv, *.tsv, *.txt
- **Automated Translation**: Yes
- **User-Defined Attributes**: Yes
- **Coordinate System Support**: No
- **Generic Colour Support**: No
- **Spatial Index**: Never
- **Schema Required**: Yes

### Supported Geometry
- **Aggregate**: No
- **Circles**: No
- **Circular Arc**: No
- **Elliptical Arc**: No
- **Ellipses**: No
- **Polygon**: No
- **Donut Polygon**: No
- **Point**: Yes
- **Line**: No
- **Text**: No

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The following parameters can be applied to the import:

- **Axis Column** - Specify which columns contain the x & y coordinates for the point data to be read in.
- **Coordinate Format** - Choose the formatting type of the data you wish to import (*ie. DMS, Decimal Degrees, Packed DMS*)
- **Use first line as header** - Allows the user to enable the first line of the text file to be used as column headings.
MAPublisher Unicode Support

This section contains information regarding Unicode character encoding in MAPublisher. MAPublisher supports Unicode character encoding in MAP Views, MAP Attributes, MAP Stylesheets, and MAP Selection Filters. MAPublisher can also reference Illustrator layers, graphic styles and character styles using Unicode encoding. If you plan to be using an earlier version of MAPublisher you should avoid using Unicode character encoding in these items.

To use Unicode character encoding you require a Unicode compliant font. Macintosh users will have Unicode compliant fonts installed with OS X. Windows users will require Unicode compliant fonts to render Unicode. For more information on Unicode visit [http://www.unicode.org](http://www.unicode.org)

The following tables display Unicode support for data formats that support Unicode in MAPublisher. For each data format there are four areas where Unicode character encoding is can be used. Unicode support for importing and exporting data is different, so for each platform two tables have been created.

1. *File Directory* - when Unicode encoding is used in the path to where the file is located
2. *Filename* - when Unicode encoding is used in the filename
3. *Attribute column name* - when Unicode encoding is used in a column name for attributes
4. *Attribute value* - when an attribute value contains Unicode encoding

### Windows Unicode Support *(Importing)*

<table>
<thead>
<tr>
<th>Data Format</th>
<th>File Directory</th>
<th>Filename</th>
<th>Attribute Column Name</th>
<th>Attribute Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delimited Text</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>CAD</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESRI ArcInfo Export</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESRI ArcInfo Generate</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESRI ShapeFile</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MapInfo MIF/MID</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MapInfo TAB</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MicroStation Design</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KML</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Windows Unicode Support *(Exporting)*

<table>
<thead>
<tr>
<th>Data Format</th>
<th>File Directory</th>
<th>Filename</th>
<th>Attribute Column Name</th>
<th>Attribute Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delimited Text</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CAD</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESRI ArcInfo Export</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESRI ArcInfo Generate</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESRI ShapeFile</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MapInfo MIF/MID</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MapInfo TAB</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MicroStation Design</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KML</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Technical Reference Guide: MAPublisher Unicode Support
### Macintosh Unicode Support (Importing)

<table>
<thead>
<tr>
<th>Data Format</th>
<th>File Directory</th>
<th>Filename</th>
<th>Attribute Column Name</th>
<th>Attribute Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delimited Text</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>CAD</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>FORMAT HAS NO ATTRIBUTES</td>
</tr>
<tr>
<td>ESRI ArcInfo Export</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>ESRI ArcInfo Generate</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>FORMAT HAS NO ATTRIBUTES</td>
</tr>
<tr>
<td>ESRI ShapeFile</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>MapInfo MID/MIF</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>MapInfo TAB</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>MicroStation Design</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>FORMAT HAS NO ATTRIBUTES</td>
</tr>
<tr>
<td>KML</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>

### Windows Unicode Support (Working with Images)

<table>
<thead>
<tr>
<th>Data Format</th>
<th>File Directory (Register Image)</th>
<th>File Directory (Export Image)</th>
<th>Filename (Register Image)</th>
<th>Filename (Export Image)</th>
</tr>
</thead>
<tbody>
<tr>
<td>World File (.tfw)</td>
<td>✓ / ✓</td>
<td>✓ / ✓</td>
<td>✓ / ✓</td>
<td>✓ / ✓</td>
</tr>
<tr>
<td>Image Report (.irp)</td>
<td>✓ / ✓</td>
<td>✓ / ✓</td>
<td>✓ / ✓</td>
<td>✓ / ✓</td>
</tr>
<tr>
<td>MapInfo TAB (.tab)</td>
<td>✓ / ✗</td>
<td>✓ / ✗</td>
<td>✓ / ✗</td>
<td>✓ / ✗</td>
</tr>
<tr>
<td>ListGeo (.lgo)</td>
<td>✓ / ✓</td>
<td>✓ / ✗</td>
<td>✓ / ✗</td>
<td>✓ / ✗</td>
</tr>
<tr>
<td>GeoTIFF (.tif)</td>
<td>✓ / ✗</td>
<td>✓ / ✗</td>
<td>✓ / ✗</td>
<td>✓ / ✗</td>
</tr>
</tbody>
</table>

*When using system encoding on Windows XP*
(for example, using the default Japanese encoding on Japanese Windows XP)

*When using non-system encoding on Windows XP*
(for example, using Japanese encoding on English Windows XP)

### Macintosh Unicode Support (Exporting)

<table>
<thead>
<tr>
<th>Data Format</th>
<th>File Directory</th>
<th>Filename</th>
<th>Attribute Column Name</th>
<th>Attribute Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delimited Text</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>CAD</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>FORMAT HAS NO ATTRIBUTES</td>
</tr>
<tr>
<td>ESRI ArcInfo Export</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>ESRI ArcInfo Generate</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>FORMAT HAS NO ATTRIBUTES</td>
</tr>
<tr>
<td>ESRI ShapeFile</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>MapInfo MID/MIF</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>MapInfo TAB</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>MicroStation Design</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>FORMAT HAS NO ATTRIBUTES</td>
</tr>
<tr>
<td>KML</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>

*Limited support*
(not all combinations of Unicode characters are supported)
Frequently Asked Questions

This section presents a number of frequently asked questions regarding the use of MAPublisher. If the answer to your question is not included here please consult the online FAQs at http://www.avenza.com/products.faq.html or the online MAPublisher Knowledge Base at http://www.avenza.com/mapublisher.knowledge.base.html. In addition, there is a US Census Bureau GIS FAQ database at http://www.census.gov/geo/www/faq-index.html.

INSTALLATION/ACTIVATION ISSUES

The MAPublisher plug-in is in the Plug-ins folder but the filters do not all show up in Adobe Illustrator.

Try exiting out of Adobe Illustrator, deleting the Adobe Illustrator preferences and plugin cache files, and then restarting Illustrator:

- In Windows the preferences and plug-in cache files are most often found in C:\Documents and Settings\username\Application Data\Adobe\Adobe Illustrator XX, but depending upon your version of Windows they may appear in the top level of the Adobe Illustrator folder. In either case they are named ‘AIPrefs’ and ‘Plug-in Cache’.
- On the Macintosh OSX platform the preferences file is most often found in Users\username\Library\Preferences\Adobe Illustrator XX Settings.

Also check under Preferences > Plug-ins & Scratch Disks and ensure that the correct location of your plug-ins folder is indicated.

I try to access the MAPublisher filters, but always receive a message saying MAPublisher cannot obtain a license. What should I do?

1. Check you have registered your copy of MAPublisher and received a license file. MAPublisher will fail to operate until you have received a license file for activation. For further details, please see page 17.
2. If you have purchased a machine-specific or fixed license you must ensure the License file is located in the following directory:
   - Windows XP default location: C:\Documents and Settings\All Users\Application Data\MAPublisher 7
   - Windows Vista default location: C:\ProgramData\Avenza\MAPublisher
   - Macintosh default location: Applications/Avenza:MAPublisher 7/ MAPublisher Plug-In
3. If you have a try-out version of MAPublisher, check that your copy has not expired. To do this, locate the *.lic file in the directory listed above. Open this file in a simple text editor. On the second line will be details of the expiration date of your try-out version. Note that this file has been automatically generated by Avenza and therefore manually editing will not re-activate MAPublisher.
4. If you have moved your license to a new computer you must notify Avenza and request a rehosting. To organize a rehosting email activation@avenza.com and provide your MAPublisher 7 serial number along with the new machine ID. The new machine ID can be found by selecting the Telephone/Email option in the MAPublisher Activation Wizard on the new computer.

How can I move my MAPublisher license to a new computer?

Unless you have purchased a floating license, MAPublisher is licensed for use on one machine only and includes a protection mechanism that prevents activation on more than one computer. If you wish to move your license permanently to a new computer please perform the following steps:

1. Completely remove MAPublisher from the existing computer.
2. Install MAPublisher on the new computer.
3. Launch Adobe Illustrator on the new computer and when the Activation Wizard starts select the Telephone/Email option for activating a purchased license.
4. Note the machine ID that will be displayed and email that 12-digit string along with your MAPublisher 7 serial number to activation@avenza.com and indicate that you wish to move the license to a new computer.
Why does the activation wizard repeatedly open when I have a valid license installed?
If the activation wizard repeatedly prompts you to activate MAPublisher but you have already have a valid licence file from a previous activation installed then you should follow the procedure below.
1. Exit Illustrator
2. Locate your Illustrator preferences file typically named
   “Alprefs” (Windows)
   “Illustrator preferences” (Mac)
3. Once the file is located, delete the file and restart Illustrator.
   This should resolve the problem.

NOTE: This applies to both floating and stand alone license users

Can I run two different versions of MAPublisher at the same time?
You can run different full version releases (ie. 7.x and 6.x) if you have two versions of Adobe Illustrator. For example MAPublisher 7.5 using Illustrator CS3 and MAPublisher 6.2 using Illustrator 10. You cannot run two point-releases of MAPublisher 7.x on the same machine even if you have two different versions of Illustrator.

MEMORY & SPEED ISSUES

Why do I need so much more memory (RAM) than I do with my GIS?
The graphics software environment of Adobe Illustrator loads the entire file into memory rather than just reading it from disk, thus more memory is required. MAPublisher builds a mini-GIS application inside Illustrator so that it can geo-code information and attach data to objects. This also has some overhead. When you are importing a lot of files with MAPublisher into Illustrator, you’ll notice that the amount of available memory will decrease rapidly and your computer loses speed. This is due to the memory management. MAPublisher reserves a fairly large amount of memory for each import-action, which is not always returned when the import is done. The solution is simple: save your file, close it and open it again. It’s not even necessary to close Illustrator itself. By closing the file the reserved memory is properly returned.

How can I improve the speed of my data import?
Many GIS data files are large and when a series of such files is imported, you may find that the import filter starts to run more slowly. This is because scratch and memory allocations are being used up. Try the following suggestions:
• Close the MAP Attributes palette prior to importing data.
• Periodically save your work then close and reopen the file. This will free up the available scratch memory.
• Reduce the maximum number of undos, since they all reside in memory.
• See the Memory Considerations section for other suggestions, pages A1/20 and A1/21.

DATA IMPORT ISSUES

Why do my files appear squashed after import?
They are probably stored in geographic or lat/long coordinates. Data in lat/long usually looks “squashed”. You can project them into an alternate map projection using the MAP View Editor (see pages 57-59).
What alternatives are there for importing a file format not supported by MAPublisher?
We provide a web page that has links to freeware, shareware and commercial GIS data translators at
http://www.avenza.com/support.links.html. If you cannot find the translator that you need give us a call as we may
have other suggestions.

I am having trouble getting my layers to overlay correctly. Both files import correctly when they are
imported alone, but when I import the second file, they do not line up as expected.
They should overlay correctly. Probably they are in different coordinate systems. It is very important that you
ensure that data used within a single mapped area have the same map projection. If different data sets for a
geographic location have differing coordinate systems, the chances are high that they will not overlay on import. If
the files are of differing coordinate systems, any software will give you the same results. If the coordinate systems
are known, you can use the MAP View Editor filter to change all data to a common coordinate system. For more
information about map projections see the British Columbia Government Ministry of Environment tutorial on map

Why do my MapInfo files crash on import or do not import properly?
There are a couple of possible common causes of this. A couple of possibilities may be:
1. How did you transfer the file to the machine where it is being imported? If you have transferred these files from
one operating system to another then you must always use ASCII ftp transfer, or the files may be corrupted. We
have found that you cannot rely on the automatic transfer with all ftp utilities. Some do not recognize the .MID
files as being text. The .mid files may be inadvertently interpreted as binary music files, which often carry the
same file extension. If they are transferred as binary you will have trouble importing them.
2. Were the files compressed? If the files are compressed using a windows ZIP format, you must be careful when
decompressing them. If this is the case and the utility you used was Stuffit, you need to make sure that it was
set for a DOS zip file or the file can be corrupted. The shareware utility ZIPIT found at http://maczipit.com has
been found to be quite good for decompressing windows zip files.

I am having trouble with importing SDTS files. Where am I going wrong?
Be very careful how you receive a xxx.tar.gz file off the USGS website and decompress it. These files are in a binary
format and if you use Smart TAR CR/LF translation it will not import and may cause errors in MAPublisher. Make
sure that you do all FTP transfers as binary. After you receive it, use gzip to decompress it and TAR to further
decompress it. You should have about 20 separate files, look for the ones that end in xxxxCATD.DDF.

Why does my data sometimes vanish?
If you imported some data and it appeared when selected, but when you deselected the data it seemed to vanish,
here are a few things to check:
• You may have inadvertently pressed cut or the delete key. Check under Edit in the menu bar, if the “Undo Clear”
task is available this means that you just deleted something. Select “Undo Clear,” and the data should return.
• Check the order of your layers. Try moving the layer in question to the top of the list of layers in the Layers palette
so that it is drawn on top of the other layers.
• Make sure that current layer is available for viewing in the Layers palette, by having a dot in the left-hand column
under the eye (visualization) and beside the layer name.
• Check that you have colours for the fill and stroke set in the paint palette.
• Check the setting for the stroke width and increase if necessary.
**Why do my shapefiles not import?**

There are a couple of possible causes of this. The two items to check for are:

1. Make sure that you have all 3 required files. There should be a “triplet” for each layer/coverage with the extensions *.dbf, *.shp & *.shx. If you are missing any of these files you will not be able to import your files successfully.
2. If you have transferred these files from one operating system to another then you must always use binary ftp transfer, or the files may be corrupted. We have found that you cannot rely on the automatic transfer with all ftp utilities. Some do not recognize the files as being binary and will transfer them as ASCII.

**EXPORTING ISSUES**

**How do I strip all the attributes from a MAPublisher file?**

Simply drag your MAP Layers into the default MAP View entitled [Non-map layers], and all georeferencing and attribute information will be removed. Note that this function must only be used as a final step.

**What causes missing features when exporting MAPublisher layers?**

If you are using an pre-existing Adobe Illustrator file not created with MAPublisher you must correctly assign MAPublisher status to your layers and data. Only one feature type per layer is supported. The feature type icon next to your MAP Layer in the MAP Views palette is indicative of the features on that layer, and is the feature type which will be applied if the layer is exported. For example if you have Point symbols on a Line layer, they will not be recognized as being MAPublisher objects and will be dropped in the export process.

**Why is MAPublisher exporting the ‘Area’ values as negatives?**

When exporting Area layers to GIS formats, polygon outlines must have a positive ‘Area’ value, whereas holes held inside compound paths (or ‘complex shapes’) must have a negative ‘Area’ value. If you have values for polygons in the ‘#Area’ property column of your MAP Attribute table which contradict these guidelines, you can use the following tools to convert the MAPublisher area calculation from a negative to a positive value or vice versa:

- ’Flip Lines’ tool (page 99) for converting multiple areas.
  Create a Selection Filter (pages 92-93) to select all elements that have an ‘#Area’ of less than zero (to select negative values) or greater than zero (to select positive values). Then go to Filter > Flip Lines.

- ’#AreaDirection’ property value (pages 37) for converting areas at a time.
  Select the area to edit and then choose the alternate value for ‘#AreaDirection’ in the MAP Attributes palette.

**LABELING ISSUES**

**I am having trouble with the MAP Tagger tool? Where am I going wrong?**

This can happen either when the layer or object to be labeled is not available for editing. Check to make sure that the desired layer is available for editing, the features in question are not locked, and you have a Text layer in your document to use to output the text to. In addition, if there is no fill to an area or polygon object the label tool (much like the Illustrator selection tool) can only find the paths defining the unfilled area. Therefore in such cases it cannot ‘find’ the unfilled area and thus cannot label the unfilled area.
PROJECTION ISSUES

How do I know what coordinate system my files are in?
In MAPublisher, the importers will automatically determine the coordinate system of the chosen files, if this information is included in the file header or is located in an associated file (e.g. *.prj). If MAPublisher returns a message of <No Coordinate System Specified> for the Projection, you should first ask your data provider to provide you with this information. Also there are a couple of strong hints that may indicate that a file is in lat/long. Both ArcView and MapInfo tend to store files in lat/long for rapid reprojection. This is why most files derived from such sources are stored in lat/long. A good test to see if a file is in lat/long is to look at the Map Anchor values in the MAP View Editor or in the MAP Location Tool. Typical Lat/Long values will be X between -180 and 180 & Y between -90 and 90.

OTHER ISSUES

How accurate is MAPublisher georeferencing?
At this point in time we are restricted to 32 bit storage for numbers, which allows for 7 digits of precision. The 32 bit storage restriction is controlled by the graphics environment software and not the MAPublisher software. We have asked for this storage restriction to be increased to 64 bit without success. We can and do all our internal calculations in 64 bit for accuracy, but the results still must be stored as 32 bit. MAPublisher’s values are roughly 4.3 billion times more precise than Illustrator’s.
Illustrator is fundamentally an art program. The numbers it uses for its vertex data are more than sufficient to provide precision enough such that the human eye cannot tell the difference, even at its highest zoom level. Unfortunately, MAPublisher must translate its coordinates into Illustrator’s when placing them on the artboard. We do this using mathematical calculations based upon the parameters you provide (e.g. map & page anchors, scale, etc.). When MAPublisher does this, it is, in a sense, compressing its more-precise numbers into Illustrator’s less-precise numbers, and this is where the truncation may occur.
An easier way to visualize this is to think of a pad of grid paper. If this paper were the artboard, Illustrator would only be able to place points where two grid lines meet, but MAPublisher could put points anywhere on the page. However, since Illustrator is ultimately where the information is plotted, when a MAPublisher point is plotted on the page it would get ‘rounded’ to the nearest grid line intersection point.

I am receiving an “Error loading plug-ins” when I start Illustrator. What should I do?
Search for and delete any copies of a file named “Adobefnt05.lst.” If that does not work, search for and delete any copies of a file whose name starts with ‘Adobefnt’ and has a *.lst extension. The Adobefnt *.lst files are cached descriptions of the font environment. They can be rebuilt when needed so it is safe to delete them.

Why do some art objects fail to display completely?
Sometimes drawing with Illustrator’s shape creation tools results in the object not being displayed completely by Illustrator. The object’s geometry is complete because if you set the View to outline (View > Outline) as opposed to Preview you can see that the object is there in its entirety (you can also zoom in and out). However, once you restore the zoom level to the original extents at which the object was created it will no longer appear as a complete shape. The solution to this is to disable the anti-aliasing option in the Illustrator preferences dialog.
**Are there any sources for free GIS data?**
There are a multitude of web sites which offer free GIS data in several different forms. Please see pages A1/22 to A1/24 of this user guide for a list of several free download sites.

**What can cause attribute corruption?**
The most likely cause of attribute corruption (other than the files being corrupted before you got them) is that you have put layers with differing attribute structures into a single layer. As a rule of thumb you should use one layer for each external file that you are importing.

**What can I do when a filter does not appear to work?**
- Make sure that you have highlighted the desired Layer in the Layers palette and that it is unlocked and visible.
- Make sure that what you have asked the filter to do makes sense.
- Try closing Illustrator and deleting your Illustrator preferences file.
GIS Backgrounder

WHAT IS GIS?

A Geographic Information System (GIS) captures, stores, checks, analyzes, and displays georeferenced data about the earth. A GIS uses a database management system (DBMS) to store and link data that relates to the same geographic area. This facilitates the following types of queries:

• what if…?
• what is it?
• where is it?
• what spatial patterns exist?
• what has changed since…?

FEATURES OF A GIS

ANALYTICAL TOOL

GIS systems are used by all levels of governments, academia and business for such diverse purposes as monitoring environmental changes, sales planning, census reporting, municipal zoning, land records, mineral resource management, and mapping telecommunications and cable television utilities. In short, a GIS serves many needs and can be thought of as an analytical tool since it can be used to determine spatial relationships between geographic areas. A GIS contains a database linking spatial data with geographic information and lets you associate information with map features and to create new relationships based on those associations.

AREAS

An area is a closed, bounded object, which encompasses a homogeneous area (e.g., a park).

ATTRIBUTES

Attributes store descriptive information and are stored as sets of characters (including numbers). Attributes are usually considered tabular data.

GEOGRAPHIC DATA

Since a GIS is a digital map database storing both spatial (graphic) and descriptive (tabular) information, the integration of this information provides an opportunity for analysis and communication. Data is stored using the Cartesian system (X,Y coordinates) as follows:

• points are stored as a single X,Y location
• lines are stored as a series of ordered X,Y coordinates
• areas are stored as a string of X,Y coordinates defining the lines that bound the area.

LABELS, SYMBOLS AND COLOUR

Map attributes can be represented by labels, symbols, and colour to make them easy to interpret (e.g. rivers may be represented with blue lines of varying widths depending upon their size).

LAYERS

Map features can be logically grouped into layers of related information. For example, a map could be layered by rivers, soils, mineral deposits, and municipality. This layering makes it easy to perform analysis that overlay geographic features and combine adjacent areas with similar characteristics.
LINES
A line represents the linear shape of a map element, which is too narrow to be an area (e.g., a contour line or road).

MAP FEATURES
A GIS stores two types of map information: spatial information (which describes the location and shape of geographic features) and descriptive information about those features. A GIS links these two types of data and maintains the spatial relationships between the map features. Features are portrayed on two-dimensional maps as points, lines, and areas. For example, a map may contain points representing location information (such as telephone poles), lines representing linear features (such as roads), and areas representing geographic features (such as lakes).

POINTS
Usually represented by a symbol or label, a point is a discrete location which is usually too small to be identified as an area or line (e.g., an oil wellhead or manhole).

SPATIAL RELATIONSHIPS
A map allows you to identify spatial relationships (e.g., a fire tower located inside a park) but it relies on you to derive this information from it.

TOPOLOGY
Topology is a mathematical process for determining spatial relationships. It does this by expressing different spatial relationships as lists of features (i.e. an area is defined by the boundary lines). The primary advantage of this type of data storage is that it is more efficient and permits faster processing of larger data sets.
WHY IS THE GRAPHICS ENVIRONMENT GOOD FOR MAPPING?

Avenza supports the fact that performing map-related graphics tasks is best done in the right environment—a powerful graphics program like Adobe Illustrator. This environment offers practicality, freedom and easy maneuverability for fast, cost-efficient and professional graphic output results. The MAPublisher environment focuses on the map graphics first with the right GIS data management tools to facilitate the map production process in the easiest and most efficient way. This is in direct contrast to traditional GIS software that are designed and written, for the analysis of geographic data, with the graphic map production coming second, almost as an afterthought. This means that as powerful as most GIS’s are for analysis, they were never designed for cartographic or publication quality mapping. Cartographers have long been doing their mapping within graphics environments because they provide tools such as Bezier curves and true CMYK colour separation for publication quality mapping.

FEATURES OF THE GRAPHICS ENVIRONMENT

ACCURATE COLOUR
Colours displayed on screen accurately reflect the colours as they will be printed.

PROPORTионаL SYMBOLOGY
Symbology is accurately proportional to the map area you have “zoomed” into.

VIEWS
You can display your document on–screen in a variety of ways using the View menu commands. For example, you can see a preview of the illustration as you edit, you can view only the outlines of your artwork, or you can preview selected parts of your artwork while displaying the rest as outlines. You can also create and save custom views of your document, retaining a particular magnification level, layering, and other viewing features for later retrieval. You can even display multiple views of a document at several different magnification levels simultaneously.

REDRAWING IS AUTOMATIC
Redrawing of the affected map objects is clean and automatic and impacts only the redrawn portion and possibly some immediately adjacent portions of the map. This eliminates the need to wait while the entire map is re-drawn or refreshed. This applies to text as well as to vector data.

BROAD SELECTION OF FONTS
A broad and flexible selection of text fonts, styles, sizes and enhancement features (e.g., haloing) is available.

PASTE IN FRONT OR BEHIND
When pasting map objects/elements, you have the option of deciding to paste the new object “in front” or “behind” the copied elements at the time of pasting.

POSTSCRIPT PATTERN FILLS
You can use PostScript pattern fills and complex vector strokes. You can sample colours from images and apply them precisely to vector data.
COMPLEX COLOUR TREATMENTS
Even with complex colours you can quickly and accurately create colour ramps with differing depths/intensity of 10%, 20%, etc. These can be set as individual colours on a palette or as a gradient across mapped features.

IMPROVED SYMBOLOGY
Improved symbology (e.g., road treatments and cartographic symbols) than is available in traditional GIS software.

SPEED DRAWING
You can easily turn on and off selected layers of a map to speed drawing. This can be done by turning off specified layers, and/or limiting the display of selected layers to simple vectors with all symbology removed. Not only will this speed the handling of the map, it lets you easily use underlying vectors for reference with no distraction or distortion caused by mapping symbology.

ACTUAL SIZE VIEWING
In addition to standard zooming and panning capabilities, you can view the details on a map at the actual size at which they will be plotted/printed.

RULERS, GUIDES AND ALIGNMENT TOOLS
Rulers with adjustable guides and multi-combination alignment tools are available for use in aligning map objects.

GROUPING AND UNGROUPING
There is grouping and ungrouping functionality. When items are grouped you still retain the option of separately accessing, querying and otherwise working with the individual components of a map group.

STORE RELATED OBJECTS
Individual but related map objects can be “stored” together by groups or by layers or both within the graphic file. This provides additional control and support in handling and organizing the map components.

TEXT PLACEMENT
The graphics environment offers a truly hands-on text placement environment and goes well beyond that of a GIS. For example text can be easily placed along any path or outside the map extents and is fully editable.
Memory Considerations

RAM RECOMMENDATIONS

**Occasional User:** 1 GB of RAM is recommended.
A graphics or GIS user who uses MAPublisher with medium sized data sets with up to 20 layers, minimal text labels, and some low-resolution or small coverage raster images.

**Power User:** 2 GB or more of RAM is recommended.
A professional cartographer who uses MAPublisher daily and works with large urban data sets (including large transportation layers) with 20 or more layers, raster based air photographs, large numbers of text labels, complex fill patterns, etc.

RAM USAGE HINTS

Users often ask us why is so much RAM needed to operate MAPublisher. First of all, Adobe Illustrator requires a significant amount of RAM itself in order to run smoothly. Secondly, map data sets are often large which increases the need for RAM even further. Map data sets contain both vector and attribute data which must be stored in memory. Since we are adding a database to Illustrator this increases the file size, which increases the RAM requirements. MAPublisher builds a mini-GIS application inside Illustrator so that it can geo-code information and attach data to objects. This also has some overhead.

GIS users also often ask why so much more memory is needed with MAPublisher than is with GIS software. The graphics environment software of Adobe Illustrator loads the entire file into memory rather than just reading it from disk, thus more RAM memory is required.

When you are importing a large number of files into Illustrator using MAPublisher, you’ll notice that the amount of available memory will decrease rapidly and your computer loses speed. This is due to the memory management. MAPublisher reserves a fairly large amount of memory for each import-action, which is not properly returned when the import is done. The solution is simple: save your file, close it and open it again. It’s not even necessary to close Illustrator itself. By closing the file, the reserved memory is properly returned.
RAM SAVING TIPS

Since a percentage of the memory is taken for attribute storage, drop any redundant or otherwise unnecessary attribute fields from the map attributes table.

Many sources of street data include paths/vectors that are segmented based on street addressing information. You can use the MAPublisher Join Lines filter to join these into single linear features based on a selected attribute field. Reducing the number of objects (and data records) in the map file will free up memory.

Many GIS data files are large and when a series of such files is imported, you may find that the import filter starts to run more slowly. This is because scratch and memory allocations are being used up. The best solution is to periodically save your work, quit out of Adobe Illustrator and then restart. This will free up the available scratch memory.

The minimum number of undos can be reduced (since they ALL reside in memory).

Use polylined or pre-joined linear feature data sets where available.

In your GIS application strip out the attributes you won’t be using for queries or labeling before importing the data into Illustrator.

You can set a primary and secondary scratch disk under the Illustrator preferences option in order to draw additional storage from a partitioned or multi-drive environment.

Turn off the layer preview icon that appears to the left of each layer name in the Adobe Illustrator layers palette. This can be done by clicking the options menu in the layers palette and then selecting small palette rows in the palette option dialog.
Online Links

Since the Internet is always changing, refer to our web page (www.avenza.com) for the most recent list of relevant Internet sites or do a Google or Yahoo search. As of the writing of this manual all the following links were active and functional.

For Geographic Information System (GIS) users, the appeal of graphics is strong and the increasing ability to discover and share GIS across the Internet is fascinating. The Internet offers a large number of free-access GIS-related websites from which you can access map and information data sets.

For the general public, there’s general information about countries, states, and places; simple maps of areas (e.g., GIF, PS format); lists and maps of Internet resources in an area.

For cartographers and geography researchers, there are cartographic/ GIS base map files (e.g., USGS Demos, DLGs, TIGER); thematic data of a geographic nature (e.g., census data); and complete GIS data sets (e.g., ArcInfo export files).

These lists are readily available, and there is a comprehensive list of free data sites accessible from the MAPublisher Internet home page at: http://www.avenza.com/support.links.html.

FREE MAP DATA

The following are just some of the many sites on the Internet that offer free download of GIS data. Data is available from these and other Internet sites in a wide variety of formats. Please consult the sections in this manual on file formats (pages 20 to 22 & A1/2 to A1/9) to ensure that you obtain usable data.

AUSLIG
Australian national mapping agency offering digital map data, satellite imagery and elevation data. Data obtained here can be used for commercial purposes with permission.
• http://www.ga.gov.au/

CAST
The Center for Advanced Spatial Technologies (CAST), University of Arkansas. Planned free access on the ARKNet statewide network. Among its high–tech offerings, CAST maintains a catalog of Arkansas, U.S. national and global data - e.g., GIS data in areas of archaeology, agriculture and population are downloadable as GIF files across the Internet. Obtain a map of historical land coverage data. Obtain data sets including Environment, Prehistoric and Historic Climate Reconstruction, Historic Census, and Tabular databases.
• http://libinfo.uark.edu/gis/us.asp

DIRECTIONS MAGAZINE DATA CENTER
Directions magazine is an internet-centred publication that provides news, analysis, commentary product information and free map data.
• http://www.directionsmag.com/files

EROS DATA CENTER
The Eros Data Center will be providing FTP access to a variety of USGS digital data sets.
• http://edcwww.cr.usgs.gov
GEOCOMMUNITY & GIS DATA DEPOT
The GeoCommunity and GIS Data Depot are an excellent sources of free GIS data, geographic software (including data viewers, translators and compression utilities) and industry news. This site also has several GIS-related discussion forums. The data found on this site covers most areas of the world.
• http://www.geocomm.com

GEOCONNECTIONS/GEOCONNEXIONS
This site from Canada's Ministry of Natural Resources offers many links to GIS data and other informational resources.
• http://www.cgdi.gc.ca

GEOGRAPHY NETWORK
The Geography Network is an online resource for finding and sharing world-wide geographic content, including maps and data from many of the world's leading providers.
• http://www.geographynetwork.com

GEOGRATIS
Geogratis is a Natural Resources Canada site offering maps, satellite imagery and tabular data.
• http://geogratis.cgdi.gc.ca

GISUSER
Glsuser.com was launched in February, 2004. Their goal is to provide the geospatial technology user with the latest news, resources, and tools affecting the GIS industry.
• http://www.gisuser.com

NATIONAL ATLAS OF THE UNITED STATES
This site is a great source of a wide variety of data files for the United States.
• http://www.nationalatlas.gov/atlasftp.html

DOUG PRICE’S LIST OF FREE DIGITAL GIS DATA
This site based at the Tennessee Geographic Information Council and the University of Tennessee offers an extensive list of data download links from around the world.
• http://www.lib.utk.edu/~tngic/price.html

ROBERT E. KENNEDY LIBRARY @ CALIFORNIA POLYTECHNIC STATE UNIVERSITY
California Polytechnic State University has various links to US-based map inventories.
• http://lib.calpoly.edu/collections/gis/webresources.html

UNITED STATES GEOLOGICAL SURVEY
Department of the Interior – USGS home page. This is the primary source for Digital Line Graph (DLG) files. A must–have resource is the US Geological Survey Digital Format Standards manual published by the USGS.
UNITED STATES FISH AND WILDLIFE SERVICE
The FWS carries a variety of map data in the USGS DLG format.
• http://www.fws.gov

OTHER VALUABLE MAPPING LINKS
The following are some additional places on the Internet where you can find news, reviews, tips and general GIS, cartographic and geographic information.

GIS CAFE
• http://www.giscafe.com

GIS DICTIONARY
• http://www.geo.ed.ac.uk/agidict/welcome.html

GIS LOUNGE
• http://www.gislounge.com

GIS@DEVELOPMENT
• http://www.gisdevelopment.net

UNIVERSITY OF EDINBURGH
• http://www.geo.ed.ac.uk/home/gishome.html

UNIVERSITY OF FLORIDA - GEOPLAN CENTER
• http://www.geoplan.ufl.edu

US CENSUS BUREAU
• http://www.census.gov
Technical Support Options

MAPublisher support is provided free of charge to customers with a current MAPublisher Maintenance Program (MMP) subscription (see page A1/26). All new license and upgrade purchases include a one year MMP subscription. Customers without a current MMP subscription may obtain support from a qualified MAPublisher technical specialist at the rate of US$49 per incident.

TECHNICAL SUPPORT

Please consult the FAQs on pages A1/10 to A1/15, the additional how-to's on the following pages as well as the following online options before contacting Avenza technical support as your situation may be easily addressed by one of the answers contained therein.

MAPUBLISHER ONLINE KNOWLEDGE BASE

The MAPublisher Online Knowledge Base is a searchable online archive that offers a variety of MAPublisher information including newsgroup items, specific solutions and other contributions from Avenza, MAPublisher resellers and other MAPublisher users. The MAPublisher Online Knowledge Base is located at http://www.avenza.com/mapublisher.knowledge.base.html

INTERNET MAILING LISTS

There are two very popular Internet mailing lists that are populated by experienced MAPublisher users worldwide and offer an open forum for discussing problems, solutions, tips and other general issues relating to MAPublisher and cartography. These lists are also monitored by Avenza technical support staff who often participate with a solution or useful discussion item.

- mapublisher-l - This is the main MAPublisher list. Subscribe by sending an email to majordomo@avenza.com with the statement subscribe mapublisher-l <emailaddress> in the body of the message. Substitute your actual email address for <emailaddress>.
- map-mac - This is a very popular mapping list to which many MAPublisher users belong. It is not limited to mac-related discussions. Subscribe by sending an email to majordomo@avenza.com with the statement subscribe map-mac <emailaddress> in the body of the message. Substitute your actual email address for <emailaddress>

ONLINE FAQS

There is an ever-growing list of Frequently Asked Questions and answers on the Avenza website at http://www.avenza.com/products.faq.html which provides an additional source of tips, tricks and general MAPublisher information.

CONTACTING AVENZA TECHNICAL SUPPORT

Avenza offers a number of methods for direct communication with our qualified and experienced technical experts. Please have your MAPublisher registration details handy to get prompt attention and include it in any email correspondence. Support issues are handled on a first come, first-served basis. Avenza does not guarantee a response within any specified time. MAPublisher Maintenance Program subscribers receive free and unlimited support. All others are eligible for support at the rate of US$49 per incident.

- email: support@avenza.com
- online form: http://www.avenza.com/support.form.html
- phone: +1.416.487.6442
MAPUBLISHER MAINTENANCE PROGRAM (MMP)

The MAPublisher Maintenance Program is a subscription-based service plan that guarantees its members:

- unlimited priority technical support - guaranteed same business day (9-4 EST) or next business day response
- unlimited telephone support (+1-416-487-6442)
- free MAPublisher updates
- free MAPublisher version upgrades
- additional discounts and offers available to MMP members only

Your MAPublisher purchase includes a one-year membership in the MAPublisher Maintenance Program so you are well on the way to worry-free use of MAPublisher for the first year and will be able to enjoy all the benefits of the MMP immediately. All MAPublisher Maintenance Program subscriptions begin on the date of purchase and run for 1 calendar year.

Your email address has been automatically entered in the maintenance-l online email list for MMP subscribers so that you are assured of receiving all the latest MMP news and access to all the update and upgrade files. If you purchased your MAPublisher license from a reseller or are the end user but not the person who purchased the software, please contact us at sales@avenza.com to ensure that we receive your email address and add you to the MMP notification group.

RENEWAL

Approximately 6-8 weeks prior to the expiration of your annual MMP subscription you will be notified regarding renewal options. You will be contacted a minimum of 5 times prior to expiration in order to ensure that you have ample opportunity to renew or not at your discretion. You will have the option of renewing your MMP for an additional year at the then prevailing price or canceling without penalty. Of course, if you cancel or let your MMP lapse you will no longer be entitled to the benefits of the program as outlined above and will thus have to purchase future upgrades at the upgrade price.

There is a grace period of approximately 30 days from the time of the MMP expiry during which you may still renew without penalty. All post-expiration renewals will be backdated to the actual expiry date.

LAPSED SUBSCRIPTIONS

Failure to renew your MMP within 30 days from the expiry date will result in a lapsed MMP subscription. Lapsed subscriptions may not be renewed and the licensee will be required to purchase support and upgrades accordingly.

Please direct all MMP questions and purchase inquiries to info@avenza.com.

WISHLIST

As either a new or experienced MAPublisher user we value your opinions on how we can improve our product. Please let us know what functions you would like to see incorporated into future upgrades of MAPublisher.

- email us at wishlist@avenza.com
PROJECTIONS OVERVIEW

Map Projections are attempts to show the surface of the earth, or parts of it, on a flat surface. Some distortions of conformality, distance, direction, scale, and area always result from this process. Certain projections minimize distortions in some of these aspects at the expense of maximizing errors in others, whereas others only moderately distort all of these properties. Additional information on map projections may also be found at http://srmwww.gov.bc.ca/gis/projectiontutorial.html

- **Conformality**: The scale at any point on the map is the same in all directions. Meridians (lines of longitude) and parallels (lines of latitude) intersect at right angles. Projections with these properties are **Conformal**.
- **Distance**: A map has an **Equidistant** projection when it portrays equal distances from the centre of the projection to any other place on the map.
- **Direction**: A map preserves direction when azimuths (angles from a point on a line to another point) are portrayed correctly in all directions. Projections with these properties are **Azimuthal**.
- **Scale**: The relationship between a distance portrayed on a map and the same distance on the Earth.
- **Area**: When a map portrays areas over the entire map so that all mapped areas have the same proportional relationship to the areas of the world they represent, the projection used is an **Equal Area** projection.

PROJECTION CATEGORIES

**Cylindrical Projection**: The result of projecting a spherical surface onto a cylinder. In a typical cylindrical projection, one imagines the paper to be wrapped as a cylinder around the globe, tangent to it along the equator. Light comes from a point source at the centre of the globe or, in some cases, from a filament running from pole to pole along the globe's axis. In the former case the poles clearly cannot be shown on the map, as they would be projected along the axis of the cylinder out to infinity. In the latter case the poles become lines forming the top and bottom edges of the map. The Mercator projection, long popular but now less so, is a cylindrical projection of the latter type that can be constructed only mathematically. In all cylindrical projections the meridians of longitude, which on the globe converge at the poles, are parallel to one another; in the Mercator projection the parallels of latitude, which on the globe are equal distances apart, are drawn with increasing separation as their distance from the equator increases in order to preserve shapes. However, the price paid for preserving shapes is that areas are exaggerated with increasing distance from the equator. The effect is most pronounced near the poles; e.g., Greenland is shown with enormously exaggerated size, although its shape in small sections is preserved. The poles themselves cannot be shown on the Mercator projection.

**Conic Projection**: The result of projecting a spherical surface onto a cone. In a conic projection a paper cone is placed on a globe like a hat, tangent to it at some parallel, and a point source of light at the centre of the globe projects the surface features onto the cone. The cone is then cut along a convenient meridian and unfolded into a flat surface in the shape of a circle with a sector missing. All parallels are arcs of circles with a pole (the apex of the original cone) as their common centre, and meridians appear as straight lines converging toward this same point. Some conic projections are conformal (shape preserving); some are equal-area (size preserving). A polyconic projection uses various cones tangent to the globe at different parallels. Parallels on the map are arcs of circles but are not concentric.
Azimuthal Projection: The result of projecting a spherical surface onto a plane. In an azimuthal projection a flat sheet of paper is tangent to the globe at one point. The point light source may be located at the globe's centre (gnomonic projection), on the globe's surface directly opposite the tangent point (stereographic projection), or at some other point along the line defined by the tangent point and the center of the globe, e.g., at a point infinitely distant (orthographic projection). In all azimuthal projections, the tangent point is the central point of a circular map; all great circles passing through the central point are straight lines, and all directions from the central point are accurate. If the central point is a pole, then the meridians (great circles) radiate from that point and parallels are shown as concentric circles. The gnomonic projection has the useful property that all great circles (not just those that pass through the central point) appear as straight lines; conversely, all straight lines drawn on it are great circles. A navigator taking the shortest route between two points (always part of a great circle) can plot his course on a gnomonic projection by simply drawing a straight line between the two points.

Miscellaneous Projections: Projections that do not fall into the above categories, such as unprojected maps, and rectangular latitude and longitude grids. Also this classification can be applied to modified projections; being altered versions of other projections. Pseudo projections have some of the characteristics of another class of projection. For example the Sinusoidal is called a pseudocylindrical projection because all lines of latitude are straight and parallel, and all meridians are equally spaced. However it is not a truly cylindrical projection because all meridians except the central meridian are curved.

PROJECTION EXAMPLES

CYLINDRICAL PROJECTIONS

- **Peters:** This projection is a cylindrical equal-area projection that de-emphasizes area exaggerations in high latitudes by shifting the standard parallels to 45 or 47 degrees.
- **Mercator:** Has straight meridians and parallels that intersect at right angles. Scale is true at the equator or at two standard parallels equidistant from the equator. The projection is often used for marine navigation because all straight lines on the map are lines of constant azimuth.
- **Miller Cylindrical:** Has straight meridians and parallels that meet at right angles, but straight lines are not of constant azimuth. Shapes and areas are distorted. Directions are true only along the equator. The projection avoids the scale exaggerations of the Mercator map.
- **Oblique Mercator:** These projections are used to portray regions along great circles. Distances are true along a great circle defined by the tangent line formed by the sphere and the oblique cylinder, elsewhere distance, shape, and areas are distorted. Once used to map Landsat images, this projection is used for areas that are long, thin zones at a diagonal with respect to north, such as Alaska State Plane Zone 5001.
- **Transverse Mercator:** These projections result from projecting the sphere onto a cylinder tangent to a central meridian. Transverse Mercator maps are often used to portray areas with larger north-south than east-west extent. Distortion of scale, distance, direction and area increase away from the central meridian.
- **British National Grid:** This is one of many national grid systems are based on the Transverse Mercator projection, and is administered by the British Ordnance Survey. The true origin of the system is at 49 degrees north latitude and 2 degrees west longitude. The false origin is 400 km west and 100 km north. Scale at the central meridian is 0.9996. The first BNG designator defines a 500 km square. The second designator defines a 100 km square. The remaining numeric characters define 10 km, 1 km, 100 m, 10 m, or 1 m eastings and northings.
• **Universal Transverse Mercator (UTM):** Used to define horizontal, positions world-wide by dividing the surface of the Earth into 6 degree zones, each mapped by the Transverse Mercator projection with a central meridian in the center of the zone. UTM zone numbers designate 6 degree longitudinal strips extending from 80 degrees South latitude to 84 degrees North latitude. UTM zone characters designate 8 degree zones extending north and south from the equator. See the UTM Zone Map on page A1/35.

• **Behrmann Cylindrical Equal-Area:** Cylindrical Equal-Area projections have straight meridians and parallels, the meridians are equally spaced, the parallels unequally spaced. There are normal, transverse, and oblique cylindrical equal-area projections. Scale is true along the central line (the equator for normal, the central meridian for transverse, and a selected line for oblique) and along two lines equidistant from the central line. Shape and scale distortions increase near points 90 degrees from the central line. The Behrmann projection uses 30:00 North as the parallel of no distortion.

**CONIC PROJECTIONS**

• **Albers Equal Area Conic:** A conic projection that distorts scale and distance except along standard parallels. Areas are proportional and directions are true in limited areas. Used in the United States and other large countries with a larger east-west than north-south extent.

• **Equidistant Conic:** Direction, area, and shape are distorted away from standard parallels. Used for portrayals of areas near to, but on one side of, the equator.

• **Lambert Conformal Conic:** Area, and shape are distorted away from standard parallels. Directions are true in limited areas. Used for maps of North America.

• **Polyconic:** The polyconic projection was used for most of the earlier USGS topographic quadrangles. The projection is based on an infinite number of cones tangent to an infinite number of parallels. The central meridian is straight. Other meridians are complex curves. The parallels are non-concentric circles. Scale is true along each parallel and along the central meridian.

**AZIMUTHAL PROJECTIONS**

• **Azimuthal Equidistant:** These projections are sometimes used to show air-route distances. Distances measured from the centre are true. Distortion of other properties increases away from the centre point.

• **Lambert Azimuthal Equal Area:** Is sometimes used to map large ocean areas. The central meridian is a straight line, others are curved. A straight line drawn through the centre point is on a great circle.

• **Orthographic:** Are used for perspective views of hemispheres. Area and shape are distorted. Distances are true along the equator and other parallels.

• **Stereographic:** Are used for navigation in polar regions. Directions are true from the centre point and scale increases away from the centre point as does distortion in area and shape.

**MISCELLANEOUS PROJECTIONS**

• **Unprojected Maps:** Include those that are formed by considering longitude and latitude as a simple rectangular coordinate system. Scale, distance, area, and shape are all distorted with the distortion increasing toward the poles.

• **Mollweide:** Used for world maps, is pseudocylindrical and equal-area. The central meridian is straight. The 90th meridians are circular arcs. Parallels are straight, but unequally spaced. Scale is true only along the standard parallels of 40:44 N and 40:44 S.
• **Eckert IV Equal Area**: Used for world maps, is a pseudocylindrical and equal-area. The central meridian is straight, the 180th meridians are semi-circles, whereas other meridians are elliptical. Scale is true along the parallel at 40:30 North and South.

• **Eckert VI Equal Area**: Is also used for maps of the world, and is pseudocylindrical and equal area. The central meridian and all parallels are at right angles, all other meridians are sinusoidal curves. Shape distortion increases at the poles. Scale is correct at standard parallels of 49:16 North and South.

• **Robinson**: Is based on tables of coordinates, not mathematical formulas. The projection distorts shape, area, scale, and distance in an attempt to balance the errors of projection properties.

• **Sinusoidal Equal Area**: Maps in this projection have straight parallels at right angles to a central meridian. Other meridians are sinusoidal curves. Scale is true only on the central meridian and the parallels. Often used in countries with a larger north-south than east-west extent.

### DATUMS AND ELLIPSOIDS OVERVIEW

An ellipsoid is a mathematical figure generated by the revolution of an ellipse about one of its axes. The earth is not a sphere but an ellipsoid distorted by rotation about its axis, with the globe bulging at the equator and flattened at the poles. The actual amount of the flattening is approximately 21.5 km difference between the polar and equatorial radii. Ellipsoidal earth models are required for accurate range and bearing calculations over long distances. For example GPS navigation receivers use ellipsoidal earth models to compute position and waypoint information. Ellipsoidal models define an ellipsoid with an equatorial radius and a polar radius. The best of these models can represent the shape of the earth over the smoothed, averaged sea-surface to within about 100 metres.

Reference Ellipsoids are usually defined by semi-major (equatorial radius) and flattening (the relationship between equatorial and polar radii). Other reference ellipsoid parameters such as semi-minor (polar radius) and eccentricity can be computed from these terms.

A datum is a mathematical model that describes the shape of the ellipsoid, and orientation of coordinate systems used to map the earth. A datum is a smoothed mathematical surface of the earth’s mean, sea level surface. Different nations and agencies use different datums as the basis for coordinate systems in GIS.

Modern datums range from flat-earth models used for plane surveying to complex models used for international applications which completely describe the size, shape, orientation, gravity field, and angular velocity of the earth.

### DATUM EXAMPLES

• **NAD27**: For many years the North American Datum of 1927 was the standard in the United States. NAD27 was based on the Clarke Ellipsoid of 1866, which was developed from ground survey in Europe and North America in the 19th Century. The centre point for NAD27 is Meades Ranch in Kansas, USA.

• **NAD83**: During the 1970’s and 1980’s satellites were able to measure the ellipsoid flattening more accurately (the World Geodetic System ellipsoid of 1984 or WGS84) and a new datum was developed from these measurements called the North American Datum of 1983. The Global Positioning System is based on WGS84. The centre point for NAD83 is the centre of the earth’s mass and uses the GRS80 spheroid which factors in the earth’s equatorial bulge.
MAPUBLISHER PROJECTIONS

MAPublisher contains choices from over 3500 supported coordinate systems, based upon a wide variety of projections, ellipsoids and datums. Coordinate systems are listed in the MAPublisher Specify Source/Destination Coordinate System dialogs according to Projected and Geodetic category headings which are then further subdivided into subcategories according to continent and country name.

Geodetic coordinate systems use Latitude and Longitude to define the position on the Earth and incorporate angular units of measurement such as degrees.

Projected coordinate systems consist of a two or three dimensional system in which each point on the plane is defined by an x,y coordinate and having an origin where the axes intersect. Projected coordinate systems incorporate linear units of measurement for the measurement of area, distance and direction.

SOURCE/PROJECTED COORDINATE SYSTEM CATEGORIES:

The folders listed below represent the default schema for the coordinate system source/destination dialog. Each folder option may be expanded by clicking on the node adjacent to the folder name.

- **ALL**
  (Lists all the coordinate systems available in the database)

- **RECENT**
  (Lists the last 10 coordinate systems used)

- **SEARCH ________**
  (Lists the most recent results of a ‘Search’ operation)

- **GEODETIC**
  (Lists the geodetic coordinate systems in the database)

- **PROJECTED**
  (Lists the projected coordinate systems in the database)

The Search entry box enables you to search for coordinate systems by specifying a text string. The search may be further refined by searching only specific categories found in the adjacent dropdown list.
Custom Projections

WORKING WITH CUSTOM COORDINATE SYSTEMS

A coordinate system within MAPublisher defines a mathematical model of the conversion between a specific location on the earth and a set of coordinates. Coordinate system definitions are specified by a set of parameters that define this mathematical model, including the earth model (ellipsoid or datum), the units used to measure the coordinates, the projection type, and any parameters specific to the projection type. Coordinate systems may be extracted from input feature data sources, may come predefined or may be defined by MAPublisher users. MAPublisher allows output coordinate systems that are different than the input ones to be specified and performs the required coordinate conversions when necessary.

MAPublisher currently contains over 3500 coordinate systems which are defined by a wide range of differing projections, datums and ellipsoids. Even though the current list of selections is comprehensive there may be instances where the end user may wish to add a brand new coordinate system to meet their particular needs, or perhaps to duplicate and modify an existing definition to change the units for example. In either case the coordinate system database file that accompanies MAPublisher may be edited directly by the end user so that new/modified entries can be permanently stored within the defined list of coordinate system options.

CREATING A CUSTOM COORDINATE SYSTEM

You can extend the number of supported coordinate systems in MAPublisher to support the transformation to and from any grid based on one of many supported map projections by adding to the existing coordinate system database. You may wish to transform coordinates to and from a coordinate system that is based on a standard map projection but is not predefined in the list of available MAPublisher coordinate systems. For example, you may wish to specify a coordinate system based on the Transverse Mercator projection with a central meridian value specific to your area of interest, essentially defining a special UTM zone. You can define a coordinate system zone based on standard map projections and required parameters and convert to and from coordinates of any other defined coordinate system.

Within MAPublisher a coordinate system definition is typically arranged and belonging to a coordinate system group. This structure allows you to assemble coordinate systems in a logical convenient manner as opposed to having one long list of coordinate systems. A coordinate system group can consist of an unlimited number of coordinate systems, but must have at least one.

You can load a different coordinate system xml file, add a new coordinate system on it's own, to an existing group, or create a new group and add systems to it. You must enter a unique descriptive name for each coordinate system group and coordinate system to be defined. For each coordinate system you must specify the geodetic datum and map projection it is based upon. You must also specify all of the required projection parameters for a given map projection.

The following section will deal with the process of loading a new coordinate system xml file, defining a custom coordinate system and modifying existing coordinate systems by manually editing the coordinate system XML database. The existing coordinate system definitions are contained within a file named "Avenza.xml" file which is typically located in the following directory:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 7
Windows Vista: C:\ProgramData\Avenza\MAPublisher
Macintosh: Applications\Avenza\MAPublisher 7\MAPublisher Plug-In\Data Source Files

It is recommended that you backup the original versions of this file prior to attempting to edit or modify them.
LOADING A GEODETIC DATA SOURCE

A geodetic data source or coordinate system database can be loaded into MAPublisher, thus greatly extending the coordinate systems available for use. You can load a geodetic database within MAPublisher by choosing “Load Geodetic Data Source…” from the ‘Map Views’ options menu.

EDITING A GEODETIC DATA SOURCE

The current geodetic database within MAPublisher can be edited by choosing “Edit Geodetic Data Source…” from the options menu within the ‘Map Views’ palette and then opening the record or coordinate system to be edited by double clicking on the record itself. Coordinate system objects can be organized via dragging and dropping within the dialog window. Each coordinate system object contains subcategories which contain recently used definitions, search results or all the definitions within that category. Like other databases the columns are resizeable, and when column headings are clicked will sort information alphabetically/numerically.

THE COORDINATE SYSTEM EDITOR

Within MAPublisher, a coordinate system is arranged within a coordinate system category. This structure allows grouping into a logical collection for convenience. You can add a new coordinate system to an existing category or create a new category and add systems to it. You must enter a unique descriptive name for each coordinate system category and coordinate system to be defined. For each coordinate system you must specify the geodetic datum and map projection it is based upon. You must also specify all of the required projection parameters for a given map projection.
NOTE: Each coordinate system must have a unique name in the data source.

When a geodetic or projected coordinate system record is selected and the Edit Object button is clicked, a warning will be present stating you must copy the system before it can be edited. This warning will only appear on coordinate systems which are shipped with MAPublisher. On user defined systems or copies of existing coordinate systems the Geodetic or Projected Coordinate System Editor dialog window will open and the user will be able to make edits to the record. This can also be accessed by double clicking the coordinate system.

Creating A New Coordinate System Category

1. Select Edit Geodetic Data Source from the Options Menu from the MAPublisher ‘Map Views’ Palette.
2. Select the Geodetic or Projected category and then click the New Category button to create a new coordinate system category.

Deleting An Existing Coordinate System Category

1. Select Edit Geodetic Data Source from the Options Menu from the MAPublisher ‘Map Views’ Palette.
2. Select the Geodetic or Projected category and then click the Delete Category button to delete a coordinate system category.

Creating A New Coordinate System Within A Category

1. Select Edit Geodetic Data Source from the Options Menu from the MAPublisher ‘Map Views’ Palette.
2. Select the Geodetic or Projected category and then click the New Object button to create a new coordinate system.
3. In the New Coordinate System dialog box enter a name for the new coordinate system.
   NOTE: The name must be unique.
4. Select and enter the appropriate parameters for the envelope, point style, geodetic value, projection, vertical reference, angular unit, linear unit, and scale factor unit that the new coordinate system is based upon.
5. Press the OK button to create the coordinate system.
6. Press the Save button to commit your update to the geodetic data source file.
Changing An Existing Coordinate System Object

1. Select *Edit Geodetic Data Source* from the Options Menu from the MAPublisher ‘Map Views’ Palette.
2. Select the Coordinate system object, and choose the *Edit Object* button.
3. Enter the modified parameters for the envelope, point style, geodetic value, projection, vertical reference, angular unit, linear unit, and scale factor unit where appropriate.
4. Press the *OK* button to commit your changes.
5. Press the *Save* button to commit your update to the geodetic data source file.

Deleting An Existing Coordinate System Object

1. Select *Edit Geodetic Data Source* from the Options Menu from the MAPublisher ‘Map Views’ Palette.
2. Select the Coordinate system object, and choose the *Delete Object* button.
3. Press the *OK* button to commit your changes.
4. Press the *Save* button to commit your update to the geodetic data source file.

Copying An Existing Coordinate System Object

1. Select *Edit Geodetic Data Source* from the Options Menu from the MAPublisher ‘Map Views’ Palette.
2. Select the Coordinate system object, and choose the *Copy Object* button.
3. Press the *OK* button to commit your changes.
4. Press the *Save* button to commit your update to the geodetic data source file.

Renaming/Moving An Existing Coordinate System Object

1. Select *Edit Geodetic Data Source* from the Options Menu from the MAPublisher ‘Map Views’ Palette.
2. Select the Coordinate system object, and choose the *Edit Object* button.
3. Enter the modified parameters for the identification name.
4. Press the *OK* button to commit your changes.
5. In order to move the coordinate system object, select the record and drag it to another category if necessary.
6. Press the *Save* button to commit your update to the geodetic data source file.
IMPORTING ADDITIONAL COORDINATE SYSTEM DEFINITIONS

In some cases the coordinate system of an image is not listed in the Geodetic Data Source. In such cases, it may be useful to import additional coordinate system definitions. By using the Import Coordinate System from File menu item in the MAPublisher ‘Map Views’ palette Options menu, additional coordinate system definitions can be imported and merged with the existing data source information. MAPublisher imports the following coordinate system file formats: WKT definitions (.wkt), MAP files (.map), ESRI PRJ files (.prj), and MapInfo TAB files (.tab).

EXPORTING A REFERENCE FILE

The defined coordinate system for a Map View can be exported as a reference “.wkt” file via MAPublisher’s ‘Export Coordinate System to File’ option. Select ‘Export Coordinate System to File’ from the Map views palette’s options menu to access the export dialog where you can save the wkt definition.
General Tips and Hints

CREATING ASCII DELIMITED POINT FILES

There may be times when you wish to add a point or a series of points to your map but you do not have a GIS or ASCII file containing these points ready for import. Provided you have the real-world coordinates for the locations you wish to plot *, you can manually create a delimited ASCII file using a text editor (ex. Notepad, BBEdit, SimpleText, Ultra Edit etc.) or a spreadsheet program (ex. Excel, Lotus 123 etc.). This file can then be imported using either Simple or Advanced Import using the ASCII Point Data import format.

One column in the file must contain the X coordinates of the points and another must contain the Y coordinates. You can add as many additional columns as you wish containing additional information to be imported as attribute data.

If you are using a text editor, you can simply type in your data in the following format:

“Column 1 Header”,”Column 2 Header”,”Column 3 Header”...etc
“Column 1 Value 1”,”Column 2 Value 1”,”Column 3 Value 1”...etc
“Column 1 Value 2”,”Column 2 Value 2”,”Column 3 Value 2”...etc

Note that negative values for the X and Y coordinates denote west longitudes and south latitudes, respectively. Also make sure to enter a carriage return using the "enter" key on your keyboard after the last line of data otherwise the last line may be ignored by the MAPublisher Point Importer.

If you are using a spreadsheet application you can enter your point information as a table and save the file in a text format, preferably .csv or .txt, choosing either comma or tab delimiting. The spreadsheet application will format the text automatically. The screenshot below illustrates an example of such a table in Microsoft Excel prior to exporting as a .csv or .txt for import into Adobe Illustrator using MAPublisher.

* The MAP Location Tool can be used to generate the X and Y coordinate values suitable for building ASCII Point Files. See page 40 for more information.
JOINING SDTS TABLES

The following information should be used in conjunction with the MAPublisher Join a Table function.

When working with United States Geological Survey SDTS files it is necessary to join tables frequently in order to obtain the map attribute table you require to make the map you want. This is due to the fact that SDTS data is constructed such that the primary vector data is held separately from the various attribute tables that one might want to use for a particular mapping purpose. The attribute table that comes as part of the vector file usually contains a unique identifier (RCID) for each map element that is used to join it with the other data tables. For example, a particular vector file containing the geography of rivers would contain a data column called RCID. Various data tables containing information such as vegetation, fish counts or flow rates might be available each also with an RCID column. The desired tables are then joined to the initial map attribute table by RCID value using the techniques described in the previous pages.

To find the SDTS tables to join with the vector map file look for the files which have names that start with the same character string as the name of the vector file. MAPublisher imports SDTS files that have the characters “CATD” at the end of the file name. A typical table to import and join with this file might be called HY01CATD.ddf.

Use the MAPublisher table importer with SDTS file type chosen to import these files. When you join layer and table, you do the join based on the column from the layer matched to the RCID column of the table. Several SDTS sample files can be found on your MAPublisher CD in the SDTS_samples folder. Note that the CATD catalog file found amongst the SDTS files explains what each table is.

ROTATING OBJECTS INDIVIDUALLY IN ADOBE ILLUSTRATOR

On some occasions you may wish to rotate selected objects about their own centres rather than as a group about a common origin. This can be accomplished using the native Adobe Illustrator Transform Each function. To use this function, first select the objects you wish to rotate. Then go to Object > Transform > Transform Each. In the “Rotate” box enter a desired rotation value and click OK. Each of the selected objects will be rotated individually about their own centres.

You may also use the #Rotation property column to individually rotate point symbols or text items based on a specified value. See page 37 for guidelines on how to use this function.
GEOREFERENCING AN ADOBE ILLUSTRATOR FILE

If you are using an existing Illustrator file that was created without the use of MAPublisher and as such does not contain any geographic parameters or attribute data, the following steps will enable you to georeference your Illustrator file and ultimately create an attribute-rich and accurate scale and world grid structure for your map. Please note that the steps that follow refer to functions that are outlined in more detail in the body of this user guide. Please familiarize yourself with the main MAPublisher functions and in particular those under the MAP Views section (pages 53-62) before proceeding.

Before beginning to georeference an Adobe Illustrator file you must be in possession of the following information:
1. The real-world scale of your data
2. Details of the coordinate system the data is in (i.e. Projection, Datum etc)
3. The X-Y coordinates of one tie-in point in the coordinate system of your data

When you have this information please use the following guidelines in order to georeferencing data with MAPublisher in Adobe Illustrator.

1. Go to View > Show Rulers. Set the 0,0 point to the lower left hand corner of the page by double-clicking on the cross hairs in the upper right corner.
2. If you have a completed Illustrator vector file go to step 3. Otherwise, place and digitize your raster image.
3. Identify a registration or ‘tie-in’ point in your document. This should be a specific location in your document for which a real-world coordinate location is known or can be easily determined. Record the location of this point in real world coordinates on a piece of paper.
4. Locate the same tie-in point on the Illustrator document page and determine its X,Y coordinates in page units. Record this number as well using Window > Info.
5. You should now have the location of your tie-in point in both map and page units (e.g. –79.5, 43.5 in Lat/Long is located at 4cm, 2cm in the document).
6. Open the MAP Views palette, navigate to the Options section and select New MAP View.
7. Enter a name for the MAP View. Set the Scale to the proper scale of the map (i.e. a set distance in document units divided by a set distance in ground units).
8. Click the Specify button. Choose a projection which matches that of your vector data and click OK.
9. Click OK in the MAP View Editor to apply the information to the new MAP View.
10. In the MAP Views palette, navigate to the Options pullout, and then click on Specify Anchors.
11. Set the Map Anchors to the value of the tie-in location in map units using the values determined in step 3 (e.g. –79.5, 43.5).
12. Set the Page Anchors to the value of the tie-in location in Page Units using the values determined in step 4 (e.g. 4, 2). Then click OK.
13. If you have not previously done so, ensure that each layer in your Adobe Illustrator file contains only one feature type (Point, Area, Line, Text, Legend).
14. In the MAP Views palette drag each of the layers which contain your data in to your new MAP View, ensuring that you set the appropriate Feature Type in the Define Layer dialog.
15. Repeat steps 1-13 for any other coordinate systems which exist in your document (such as inset maps for example).
16. Your document is now a georeferenced MAPublisher file wherein each feature is also georeferenced and capable of accepting attributes using the MAP Attributes function (see pages 41-43). You can also use the MAPublisher Export function to create a GIS file from this newly georeferenced Illustrator map.
TIPS ON EXPORTING TO OTHER GIS SOFTWARE WITH MAPUBLISHER

These strategies do not focus on how to do the procedures, as these are discussed in the Export section (page 61), but more on what you need to know and understand for successful export results.

First and most importantly you need to understand that the MAPublisher export was designed to export MP imported or created data one layer and one feature at a time. Why is it important to know this? MAPublisher only recognizes objects that have been imported by or created with its filters. If a layer was not imported with MAPublisher or is not hosted by a designated MAP View, then MAPublisher will not allow you to export the layer.

If you have an entire layer that was not created by MAPublisher then:
1. Ensure that your layer contains only a single feature type (Point, Area, Line or Text).
2. In the MAP Views palette, check that you have a designated MAP View with a matching coordinate system. If you do not, create a new MAP View (see page 61).
3. Select the layer in the MAP Views palette.
4. Drag the layer to the MAP View containing the matching coordinate system to georeference the layer.

There are also a couple of additional considerations to be aware of when exporting:

Since the current exported vector formats are GIS formats that do not support the concept of Bezier curves you need to compensate for this. If you have Bezier curves in your Adobe Illustrator file they will not be recognized in the GIS software. In order for these features may be represented correctly you will need to add points to these lines in Illustrator first. Simply identify and select any objects that use Bezier curves and then select Object > Path > Add Anchor Points. Repeat this command until the line has a sufficient number of anchor points that the shape of your curves will not be lost on export.

Adobe Illustrator stores the origin of text that has been applied along paths differently from other text objects. We have found the following steps to be the most successful way to get such Text exported to GIS files:
1. Create a new Illustrator layer
2. Select any text that has been created along paths.
3. Drag this text to the new Illustrator layer
4. Select Type > Create Outlines. The text will be converted to vector objects.
5. In the MAP Views palette, drag this layer back into your MAP View, specifying Area as the feature type

You can now export your Text as Area objects. Since the text is no longer text, you can no longer modify the fonts. We recommend that you make a copy of the original text objects before you do this process. These hints on how to transfer Illustrator files are necessary because the graphics environment handles text and curves differently and they need some modification in order for the GIS software to represent these accurately.

TIPS ON EXPORTING DATA TABLES

You can export any data tables that are linked to physical features in MAPublisher.
a) To export as a comma-delimited data table, export the desired features as MapInfo mid/mif format. The export file with the extension .mid will contain your attribute data in comma delimited form.
b) To export as a DBF data table, export the desired features as Arcview shape files format. The export file with the extension .dbf will contain your attribute data in standard DBF format.
DOUGLAS-PEUCKER LINE SIMPLIFICATION

The Douglas-Peucker algorithm was primarily designed to reduce the number of points required to represent a vector line. A common problem in digital cartography and geographic information systems can occur when lines are generated automatically from a mathematical function, which records points at a fixed interval regardless if they are all lying along a straight line. A reduction of the number of points makes for a cleaner and more readable cartographic line. As well in cartographic work within Adobe Illustrator the removal of points along a path can significantly improve the speed of file redraws and reduce the overall file size.

The Douglas-Peucker Algorithm was created in Fortran 66 by David H. Douglas and Thomas K. Peucker at the University of Ottawa in 1970-71. It was extensively tested in 1972 and was publicly communicated in the following article: “Algorithms for the Reduction of the Number of Points Required to Represent a Digitized Line or Its Caricature”, ‘Canadian Cartographer’, Vol. 10, No. 2, December 1973.

There are a number of online resources where more information may be found on the Douglas-Peucker algorithm including http://citeseer.nj.nec.com/hershberger92speeding.html and http://www.cs.unc.edu/~mantler/safesimp/safeset/sld004.html.

BEZIER CURVES AND OTHER MAPUBLISHER OPERATIONS

Bezier curves are defined using four control points. Two of these are the end points of the curve, while the other two effectively define the gradient at the end points. These two points control the shape of the curve. The curve is actually a blend of the control points. This is a recurring theme of approximation curves; defining a curve as a blend of the values of several control points.

Most GIS formats do not usually support bezier curves used in graphics packages such as Adobe Illustrator. As such you will typically find that curved sections of GIS data will be composed of a series of small line segments rather than an actual curve. This is also how such features will first appear in Illustrator when imported with MAPublisher. The MAPublisher Simplify Lines filter can be used to convert this type of feature into a Bezier curve (see page 101).

If Bezier curves are exported from Illustrator using any of the MAPublisher Export filters they will be converted to link and node topology (i.e. the end points of the curve will simply be joined as straight lines). It is therefore necessary to create additional points to curves to retain their true shape. This can be done globally by using the Illustrator’s Add Anchor Points function via Object > Path > Add Anchor Points.

This version of MAPublisher supports Bezier curve features during the following operations:
• Scale and Projection transformations via the MAP View Editor
• Area and length calculations
CREATING SYMBOLS FOR USE IN POINT STYLE SHEETS

A MAPublisher Symbol Library and a National Parks Symbol Library are supplied in the Utilities folder on the MAPublisher CD. You may also find that a search on the internet may be useful for finding additional libraries. If you are required to create new symbols, the steps below will help you to quickly create symbols manually in Adobe Illustrator.

1. Use Adobe Illustrator’s tools for the manual creation of artwork that will comprise the new symbol. If you wish to use a character that are contained in a font library, select the text character instance and go to Type > Create Outlines to convert the text to vector art.
2. Open the Illustrator Symbols palette (Window > Symbols).
3. Select the artwork that will comprise the new symbol and drag it into the Illustrator Symbols palette. Double click the symbol in this palette to assign a name.
4. When MAP Stylesheet Editor is accessed for Point Stylesheets, this symbol will be available in the Style column.

CREATING A STYLE SHEET TEMPLATE

You can create template files with legends to automate the production of a series of similar maps.

The procedure when using MAP Stylesheets is as follows:
1. Create a prototype map using the MAPublisher Stylesheet function to create the desired “look”.
2. Make a copy of your prototype map file. Delete all the layers from the file so that only the designated Stylesheets exist.
3. Save it to a new template file.
4. Use this template file as a base for future maps as follows:
   a) Make a copy of the template file.
   b) Import all map layers into the template file and do any needed processing.
   c) In the MAP Stylesheets palette, drag your MAP Layers into the desired MAP Stylesheets.
   d) Your new layers will be symbolized by the previously defined Stylesheet.

CREATING A MULTI-CONDITION ‘IF’ EXPRESSION

In Edit Expression it is possible to assign symbology to map objects by assigning an expression to the #Style column. In the following example this is achieved by creating a multi-condition IF statement.

In the following example, a point layer represents cities. Each point has the value “Y”, “N” or “C” in the “CAPITAL” attribute column, describing whether the city is a state capital (Y), is not a state capital (N) or is a country capital (C). There are 3 point symbols to assign to the type of point. In this example the following expression can be assigned to the “#Style” column of the point layer.

\( \text{IF}(\text{CAPITAL} = \text{"Y"}, \text{"MAP Symbol 01"}, \text{IF}(\text{CAPITAL} = \text{"C"}, \text{"MAP Symbol 02"}, \text{"MAP Symbol 03"})) \)

Therefore: If the capital is “Y”, assign the symbol “MAP Symbol 01”. If the capital is “C” assign the symbol “MAP Symbol 02”. All other symbols assign “MAP Symbol 03”.

Technical Reference Guide: Tips and Hints
NOTES FOR EXPORTING IMAGES

If the document colour mode is CMYK, exporting an embedded image may result in increased file size compared to RGB mode.

If the image is LINKED consider the following:
1. The image will be exported in the original colour mode of the image irrespective of the current colour mode of the document (i.e. a linked grayscale image in a CMYK document will be exported as a grayscale image, whereas a linked CMYK image in an RGB document will be exported as a CMYK image).
2. A linked image with Alpha channels may be exported in a different colour model. For example a grayscale with 2 alphas will export as an RGB or an RGB with an alpha channel will export as CMYK.

If the image is EMBEDDED consider the following:
1. The image will be exported in the colour mode of document (i.e. an embedded grayscale image in a CMYK document will be exported as a CMYK image, whereas an embedded CMYK image in an RGB document will be exported as an RGB image).
2. Embedded Grayscales do NOT pick up the document colour model (i.e. an embedded grayscale image will be exported as grayscale).
3. The export of embedded Bitmap images is not supported.

KEYBOARD SHORTCUTS

This version of MAPublisher supports the use of keyboard shortcuts in order to increase the efficiency of the user and to make it easier to access commonly used dialogs and menus. By default the Simple and Advanced Import dialogs can be accessed by pressing Shift+Ctrl+I and Alt+Shift+Ctrl+A, respectively. All other MAPublisher tools can have keyboard shortcuts manually set by accessing the Adobe Illustrator Keyboard Shortcut dialog which is located under Edit > Keyboard Shortcuts.
<table>
<thead>
<tr>
<th>UTM Zone</th>
<th>Central Meridian</th>
<th>Longitude Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>177W</td>
<td>180W-174W</td>
</tr>
<tr>
<td>2</td>
<td>171W</td>
<td>174W-168W</td>
</tr>
<tr>
<td>3</td>
<td>165W</td>
<td>168W-162W</td>
</tr>
<tr>
<td>4</td>
<td>159W</td>
<td>162W-156W</td>
</tr>
<tr>
<td>5</td>
<td>153W</td>
<td>156W-150W</td>
</tr>
<tr>
<td>6</td>
<td>147W</td>
<td>150W-144W</td>
</tr>
<tr>
<td>7</td>
<td>141W</td>
<td>144W-138W</td>
</tr>
<tr>
<td>8</td>
<td>135W</td>
<td>138W-132W</td>
</tr>
<tr>
<td>9</td>
<td>129W</td>
<td>132W-126W</td>
</tr>
<tr>
<td>10</td>
<td>123W</td>
<td>126W-120W</td>
</tr>
<tr>
<td>11</td>
<td>117W</td>
<td>120W-114W</td>
</tr>
<tr>
<td>12</td>
<td>111W</td>
<td>114W-108W</td>
</tr>
<tr>
<td>13</td>
<td>105W</td>
<td>108W-102W</td>
</tr>
<tr>
<td>14</td>
<td>99W</td>
<td>102W-96W</td>
</tr>
<tr>
<td>15</td>
<td>93W</td>
<td>96W-90W</td>
</tr>
<tr>
<td>16</td>
<td>87W</td>
<td>90W-84W</td>
</tr>
<tr>
<td>17</td>
<td>81W</td>
<td>84W-78W</td>
</tr>
<tr>
<td>18</td>
<td>75W</td>
<td>78W-72W</td>
</tr>
<tr>
<td>19</td>
<td>69W</td>
<td>72W-66W</td>
</tr>
<tr>
<td>20</td>
<td>63W</td>
<td>66W-60W</td>
</tr>
<tr>
<td>21</td>
<td>57W</td>
<td>60W-54W</td>
</tr>
<tr>
<td>22</td>
<td>51W</td>
<td>54W-48W</td>
</tr>
<tr>
<td>23</td>
<td>45W</td>
<td>48W-42W</td>
</tr>
<tr>
<td>24</td>
<td>39W</td>
<td>42W-36W</td>
</tr>
<tr>
<td>25</td>
<td>33W</td>
<td>36W-30W</td>
</tr>
<tr>
<td>26</td>
<td>27W</td>
<td>30W-24W</td>
</tr>
<tr>
<td>27</td>
<td>21W</td>
<td>24W-18W</td>
</tr>
<tr>
<td>28</td>
<td>15W</td>
<td>18W-12W</td>
</tr>
<tr>
<td>29</td>
<td>9W</td>
<td>12W-6W</td>
</tr>
<tr>
<td>30</td>
<td>3W</td>
<td>6W-0</td>
</tr>
<tr>
<td>31</td>
<td>3E</td>
<td>0E-6E</td>
</tr>
<tr>
<td>32</td>
<td>9E</td>
<td>6E-12E</td>
</tr>
<tr>
<td>33</td>
<td>15E</td>
<td>12E-18E</td>
</tr>
<tr>
<td>34</td>
<td>21E</td>
<td>18E-24E</td>
</tr>
<tr>
<td>35</td>
<td>27E</td>
<td>24E-30E</td>
</tr>
<tr>
<td>36</td>
<td>33E</td>
<td>30E-36E</td>
</tr>
<tr>
<td>37</td>
<td>39E</td>
<td>36E-42E</td>
</tr>
<tr>
<td>38</td>
<td>45E</td>
<td>42E-48E</td>
</tr>
<tr>
<td>39</td>
<td>51E</td>
<td>48E-54E</td>
</tr>
<tr>
<td>40</td>
<td>57E</td>
<td>54E-60E</td>
</tr>
<tr>
<td>41</td>
<td>63E</td>
<td>60E-66E</td>
</tr>
<tr>
<td>42</td>
<td>69E</td>
<td>66E-72E</td>
</tr>
<tr>
<td>43</td>
<td>75E</td>
<td>72E-78E</td>
</tr>
<tr>
<td>44</td>
<td>81E</td>
<td>78E-84E</td>
</tr>
<tr>
<td>45</td>
<td>87E</td>
<td>84E-90E</td>
</tr>
<tr>
<td>46</td>
<td>93E</td>
<td>90E-96E</td>
</tr>
<tr>
<td>47</td>
<td>99E</td>
<td>96E-102E</td>
</tr>
<tr>
<td>48</td>
<td>105E</td>
<td>102E-108E</td>
</tr>
<tr>
<td>49</td>
<td>111E</td>
<td>108E-114E</td>
</tr>
<tr>
<td>50</td>
<td>117E</td>
<td>114E-120E</td>
</tr>
<tr>
<td>51</td>
<td>123E</td>
<td>120E-126E</td>
</tr>
<tr>
<td>52</td>
<td>129E</td>
<td>126E-132E</td>
</tr>
<tr>
<td>53</td>
<td>135E</td>
<td>132E-138E</td>
</tr>
<tr>
<td>54</td>
<td>141E</td>
<td>138E-144E</td>
</tr>
<tr>
<td>55</td>
<td>147E</td>
<td>144E-150E</td>
</tr>
<tr>
<td>56</td>
<td>153E</td>
<td>150E-156E</td>
</tr>
<tr>
<td>57</td>
<td>159E</td>
<td>156E-162E</td>
</tr>
<tr>
<td>58</td>
<td>165E</td>
<td>162E-168E</td>
</tr>
<tr>
<td>59</td>
<td>171E</td>
<td>168E-174E</td>
</tr>
<tr>
<td>60</td>
<td>177E</td>
<td>174E-180E</td>
</tr>
</tbody>
</table>
Appendix 2: 
MAPublisher 7 How To’s For Legacy Users

A number of functions have been redesigned in MAPublisher 7. Users of MAPublisher 6 or earlier should consult the following pages for information on how to perform common legacy MAPublisher tasks in MAPublisher 7.

LEGEND FUNCTIONALITY IN MAP STYLESHETS

BUILDING COLOUR-RAMPS TO CREATE STYLES

You can enhance the look of your maps by using colour ramps, rather than random colours, for your area and line styles. A possible use for this would be in the creation of relief maps.

1. Determine the number of new graduated styles you wish to create.
2. Create two rectangles with the Rectangle Tool aligned vertically, one at the top of the page, the other at the base.
3. Colour the first (top) and last (bottom) elements with the two extreme end colours for the ramp.
4. Select the Object > Blend > Blend Options menu item.
5. Choose ‘Specified Steps’ from the list. Enter the value you determined in the first step minus 2. Click OK.
6. Select the two rectangles. Select the Object > Blend > Make menu item. The legend elements will be blended between the two end colours.
7. Select Object > Expand, then Object > Ungroup.
8. You can then add the new styles to Graphic Styles palette for use in your MAP Stylesheets.

ASSIGNING INCREMENTAL VALUES TO STYLES

It is very straightforward to assign styles to values for stylesheets based on ‘Equal to’ expressions. The following examples can be used as a basis for new stylesheets, providing the functionality which was previously available in the ‘Unique Occurrences’ option in ‘Auto Assign Legend Info’.

Example 1 (Rule 1 assigned first listed value and first style):

1. Create the first ‘Equal to’ rule, using the first listed style, and an expression based on the first listed value in a specified attribute column,
   i.e. “Style A” assigned to “Column X = Value 1”.
2. Click the ‘Add’ button. The second rule will be automatically assigned an incremental expression,
   i.e. “Style B” assigned to “Column X = Value 2”.
3. Keep clicking the ‘Add’ button until all the values OR styles have been used.

Example 2 (Rule 1 assigned first listed value and third style):

1. Create the first ‘Equal to’ rule, using the first listed style, and an expression based on the third listed value in a specified attribute column,
   i.e. “Style C” assigned to “Column X = Value 1”.
2. Click the ‘Add’ button. The second rule will be automatically assigned the first unused style,
   i.e. “Style A” assigned to “Column X = Value 2”.
3. Keep clicking the ‘Add’ button. Assignments will be incremental, but will not include the third style again.
   i.e. “Style B” assigned to “Column X = Value 3”. “Style D” assigned to “Column X = Value 4” etc
CREATING STYLE RULES BASED ON MULTIPLE ATTRIBUTE COLUMNS

‘Assign Legend Info’ previously provided options to assign legend criteria to legend elements based on values in multiple attribute columns. This functionality can now be achieved using Advanced expressions in the MAP Stylesheet Editor. Choose the Advanced option to compose advanced expressions.

The following are some examples of multi-column expressions in a world countries stylesheet (using a string type column named ‘CONTINENT’ and an integer type column named ‘POPULATION’).

CONTINENT=“Africa” AND POPULATION<1000000
Result: only African countries with populations less than one million are assigned the selected style.

CONTINENT=“Africa” OR POPULATION<1000000
Result: all the African countries and all countries with populations less than one million are assigned the selected style.

CONTAINS(CONTINENT,”America” AND POPULATION>1000000
Result: only countries in North and South America with populations more than one million are assigned the selected style.

CONTINENT=“Europe” AND POPULATION>1000000 OR CONTINENT=“Asia” AND POPULATION>1000000
Result: countries in Europe with populations more than one million, and counties in Asia with populations more than ten million, are assigned the selected style.

NUMBER OF UNIQUE ATTRIBUTES

Unique values are displayed in the ‘Simple’ expression builder (see page 72).

Note the default maximum number of values which can be listed is set to 250. To increase the number of values listed in the MAP Stylesheet Editor value listboxes, please complete the following:

• Quit Illustrator
• Open your Illustrator preferences file in a text editor. The default location and name of the preferences file is:
  Windows:  C:\Documents and Settings\<username>\Application Data\Adobe\Illustrator XX\AIPrefs
  Macintosh: Users\<username>\Library\Preferences\Adobe Illustrator XX Settings\Adobe Illustrator Prefs
• Search for the text “MaxValuesPref” (no quotes)
• Edit the listed value from “250” to the required value
• Save the Illustrator preferences file
• Re-open Illustrator

GRID AND SCALEBAR OPERATIONS

EDITING CUSTOM ART

Manually editing type position, font, colour etc is not possible on Grids and Scale Bars in their default grouped state. Manual editing is possible however if you must first ‘expand’ the object (Object > Expand). Note that this will negate any opportunity to subsequently edit the art using MAPublisher’s editing tools.

If you require a different design to be used for your Grid or Scale Bar, or wish to change any parameter without generating a new version, simply select the Grid or Scale Bar and access the Object > Edit Grid / Scale Bar menu item. This will re-open the Grids and Graticules or Scale Bar function with the current parameters of the object for subsequent editing.
Editing the style of text (i.e. text colour, font, alignment etc) used in the Grid or Scale Bar can be achieved by modifying the properties of the style in the Character Styles palette.

Use the bounding box of the generated grid or scale bar (View > Show Bounding Box) to resize. Resizing scale bars horizontally will add or remove intervals from the bar(s). Resizing scale bars vertically will adjust the width of the bar(s). Resizing grids horizontally or vertically will add or remove component cells in the grid.

**EXPORTING GRIDS**

To export a grid you must first ‘expand’ the object (Object > Expand), then move it to an Area layer. Alternatively expand your grid, move the legend layer to the ‘[Non-map layers]’ category, then move it back into the MAP View specifying the feature type as ‘Area’.

**MISSING DATA IN GRIDS ON PROJECTED MAP VIEWS**

Certain projections may cause incomplete grids and graticules to be drawn. Such issues may occur if the MAP View is in a polar projection or the extents of the data cross the 180 degree west/east meridian.

If the generation of a grid/graticule causes blank or incomplete results, the following workflow should be executed:

1. Reproject the MAP View to a standard Lat/Long projection (i.e. “NAD27 Lat/Long, Degrees”).
2. Generate your grid or graticules on this MAP View.
3. ‘Expand’ the object (Object > Expand).
4. Create a new Area layer in the MAP View. Drag the expanded grid to this new layer.
5. Reproject the MAP View back to the original projection.

**COPY AND PASTE**

The ‘MAP Copy/Paste’ function has been removed. You can now achieve the same functionality via Illustrator’s native Copy/Paste tools

1. Use Edit > Copy or Edit > Cut to copy art.
2. Deselect the art.
3. Select the destination layer in the Layers palette
4. Use Edit > Paste in Front or Edit > Paste in Back to paste the art into the new layer at its previous location.

- When pasting to layers which already contain an attribute structure, the destination layer must have an attribute schema which matches the source layer.
- When pasting to layers which contain no attribute structure, the destination layer will be assigned the same attribute schema as the source layer.
- The destination layer can be contained in any MAP View as required.
- The destination layer must be of a matching feature type as the source layer.
- Pasted data will always maintain its attributes. If you paste into a non-map layer, drag this layer into a MAP View, then recreate the schema, attributes will be populated appropriately.
# Appendix 3: Utilities and Bonus Files

The following files may be found in the utilities and bonus files folders on your MAPublisher 7 CD or with your MAPublisher 7 download.

## MACINTOSH AND WINDOWS UTILITIES AND BONUS FILES

### Utilities > Actions

**MAPublisher Actions.aia**  
A custom action set for quick access to MAPublisher windows and palettes.  
*NOTE: Actions for Windows and Macintosh are unique*  
*Windows - MAPublisher Actions_PC.aia  Macintosh - MAPublisher Actions_MAC.aia*

### Utilities > Graphic Styles

**MAP_AreaStyles.ai**  
A custom library of 99 styles, for use in Area Stylesheets.  
**MAP_LineStyles.ai**  
A custom library of 99 style, for use in Line Stylesheets.  
**MIF_AreaStyles.ai**  
A library of MapInfo MIF/MID area styles 1-71, for use in Area Stylesheets.  
**MIF_LineStyles.ai**  
A library of MapInfo MIF/MID line styles 1-77, for use in Line Stylesheets.  
**DGN_LineStyles.ai**  
A library of MicroStation DGN line styles 1-7, for use in Line Stylesheets.

### Utilities > Symbols

**Aeronautical symbols.ai**  
A library of aeronautical point symbols.  
**Bank Symbols #1-#3.ai**  
Three libraries of symbols for major world banks, for use in Point Stylesheets.  
**MAP Symbols #1-#2.ai**  
Two libraries of useful map symbols.  
**MAP_NorthArrows.ai**  
A library of north arrow symbols, for use in the ‘Create North Arrow’ filter.  
**MAP_PointSymbols.ai**  
A custom library of 99 symbols, for use in Point Stylesheets.  
**NPS #1-#2.ai**  
Two libraries of symbols from the US National Parks Service.  
**Parks_PointSymbols.ai**  
A library of symbols composed from the US National Parks Service font library.  
**Subway Line Symbols.ai**  
A library of symbols from the major subway lines in the world.  
**Transit Symbols.ai**  
A library of symbols for the major transit systems of the world.  
**Weather Symbols.ai**  
A library of weather-related point symbols.
Appendix 4: Glossary

If you have difficulty with some of the GIS terminology used in this guide you can also access the following for more information:

http://srmwww.gov.bc.ca/gis/glosstxt.html

A

Accuracy
The closeness of results of observations, computations or estimates to the true values or the values accepted as being true. Accuracy relates to the exactness of the result, and is distinguished from precision, which relates to the exactness of the operation by which the result is obtained.

AGI
Association for Geographic Information.

Algorithm
A set of rules for solving a problem.

ASCII
American Standard Code for Information Interchange, a widely used industry standard code for exchanging alphanumeric codes in terms of bit-signatures.

ANSI
American National Standards Institute, an association formed by the American Government and industry to produce and disseminate widely used industrial standards.

Analog / Analogue
A continuously varying electronic signal. Also refers to traditional paper mapping products and aerial photographs.

Annotation
The explanatory or descriptive alphanumeric text or labels on a map (or artwork), such as street or place names.

Application
A set of computer programs designed for a specific task.

ArcInfo Export
File format with the extension .e00 for files exported from ArcInfo.

Area
A bounded continuous two-dimensional object, which may or may not include its boundary. Usually defined in terms of an external polygon or in terms of a set of grid cells. A fundamental unit of geographical information. See polygon.

Aspect
Individual azimuthal map projections are divided into three aspects: the polar aspect which is tangent at the pole, the equatorial aspect which is tangent at the Equator, and the oblique aspect which is tangent anywhere else. (The word ‘aspect’ has replaced the word ‘case’ in modern cartographic literature).

Attribute
Non-graphic alphanumeric textual information associated with a point, line, or area element in a GIS data set; tabular data associated with geographic features.
**Azimuth**
The angle measured in degrees between a base line radiating from a center point and another line radiating from the same point. Normally, the base line points North, and degrees are measured clockwise from the base line.

**B**

**Base data**
Fundamental cartographic information (e.g. coastlines, political boundaries) in relation to which additional data of a more specialized nature may be compiled or overlaid.

**Bezier Curve**
A Bezier curve consists of two anchor points connected by a curved segment, with at least one direction point and direction line attached to each anchor point.

**Binary**
A number system of base 2. Numbers are represented simply as a series of 0's or 1's in contrast to base 10 number systems that represent numbers using the characters 0-9. For example, the base 10 number 65535 translates to the base 2 number 1111111111111111. Binary numbers are the fundamental basis of computing.

**Bitmap**
A grid of small squares, cells or pixels stored in memory and used to generate an image.

**Boolean**
There are two types of values: true and false. True/false or yes/no usually represent these.

**C**

**CAD(D)**
Computer-Aided Drafting (Design).

**Cadastre**
A public register or survey that defines or re-establishes boundaries of public and/or private land for purposes of ownership and taxation.

**Cartogram**
An abstracted or simplified map for displaying quantitative data for which the base is normally not true to scale.

**Cartography**
The organization and communication of geographically related information in either graphic or digital form. It can include all stages from data acquisition to presentation and use.

**CAST**
Centre for Advanced Spatial Technologies at the University of Arkansas.

**Cell**
The basic element of spatial information in a raster image.

**Character Encoding**
A character encoding consists of a code that pairs a sequence of characters from a given set with something else, such as a sequence of natural numbers, octets or electrical pulses, in order to facilitate the storage of text.

**Choropleth map**
A systematic representation in which colour or shading is applied to areas bounded by statistical or administrative limits.
**Clipping**
A graphic process of cutting lines and symbols off the edge of a display area.

**Colour Ramp**
A graduated range of colours between two extreme colour selections.

**Conformal**
A map projection is conformal when at any point the scale is the same in every direction. Therefore, meridians and parallels intersect at right angles and the shapes of very small areas and angles with very short sides are preserved. The size of most areas, however, is distorted.

**Contour**
A line connecting points of equal elevation.

**Coordinate system**
A graticule, or a Cartesian grid, in which points are located from two (or three) axes which intersect at a point.

**Curvature**
The amount of curve in line as defined by a series of points.

**D**

**Data model**
An abstraction of the real world which incorporates only those properties, being relevant to the application at hand. The data model would normally define specific groups of entities, and their attributes and the relationships between these entities. A data model is independent of a computer system and its associated data structures.

**Database**
A collection of data organized according to a conceptual structure describing the characteristics of the data and the relationships among their corresponding entities.

**Database management system (DBMS)**
A set of computer programs for organizing the information in a database usually containing routines for data input, verification, storage, and retrieval.

**Datum**
Any numerical or geometrical value, surface, line, or point which may serve as a base or reference for other quantities.

**DEM**
Digital Elevation Model. DEM is a raster format used by the USGS to record elevation information. Unlike other raster file formats, DEM cells do not represent colour brightness values but rather the elevation of points on the earth's surface.

**Demographics**
Statistics of birth, death, population, etc.

**Developable surface**
A developable surface is a simple geometric form capable of being flattened without stretching. Many map projections can then be grouped by a particular developable surface: cylinder, cone, or plane.

**DGN**
Native file format of MicroStation from Bentley Systems Inc.

**Digital**
The ability to represent data in discrete units or digits.
**Digital Line Graph**
USGS standard output file format. These files can be in either Optional (.opt, .do) or SDTS (.ddf) form.

**Douglas-Peucker Line Simplification Algorithm**
A method of simplifying line data by removing unnecessary vertices.

**Drag**
To hold down the mouse button while you move the mouse cursor on the screen.

**Drag and drop**
The act of dragging a file with the mouse over another executable file to cause some action on the first file.

**DTP**
Desktop Publishing.

**DWG**
AutoCAD Drawing file.

**DXF**
AutoCAD Drawing Exchange Format.

**E**

**Element**
A fundamental geographical unit of information, such as a point, line, area, or pixel.

**EPS**
Encapsulated Post Script file format The EPS format is used to transfer PostScript language artwork between applications - also see PostScript.

**Equal areas**
A map projection is equal area if every part, as well as the whole, has the same area as the corresponding part on the Earth, at the same reduced scale. No flat map can be both equal area and conformal.

**Equidistant**
Equidistant maps show true distances only from the center of the projection or along a special set of lines. For example, an Azimuthal Equidistant map centered at Washington shows the correct distance between Washington and any other point on the projection. It shows the correct distance between Washington and San Diego and between Washington and Seattle. But, it does not show the correct distance between San Diego and Seattle. No flat map can be both equidistant and equal area.

**F**

**FAQ**
Frequently Asked Question.

**Feature**
A set of points, lines or polygons in a spatial database that represent a real-world entity. The terms feature and object are often used synonymously.

**Feature code**
A set of characters (alpha, alphanumeric or numeric) within the GIS, which uniquely identifies a feature class or group of features.
File
A collection of related information that can be accessed by an assigned name.

Filter
See Plug-in filters.

Folder
A storage area for files within the Macintosh OS, the equivalent of a DOS or UNIX directory.

Format
The way in which data is arranged for storage and for transmission between software and computers.

FTP
File Transfer Protocol.

G

Geographic features
Points, lines, and areas that comprise a map.

Geographic Imager
A suite of spatial imaging tools for Adobe Photoshop.

Geographic Information System (GIS)
Any system designed for the capturing, storing, checking, integrating, analyzing and displaying of spatially referenced data about the earth.

Georeference
To establish the relationship between page coordinates on a planar map and known real-world coordinates.

GeoTIFF
An industry-wide standard for specifying information in TIFF tags which was developed by several organizations within the GIS community. GeoTIFF files are raster images that contain georeferencing information as well as image information in a single file.

GIR
Geographic Information Retrieval.

GIS
Geographic Information Systems.

GPS
Global Positioning Systems.

Grain
The frequency of vertices or points forming a line.

Graticule
The spherical coordinate system based on lines of latitude and longitude.

Great Circle
A circle formed on the surface of a sphere by a plane that passes through the centre of the sphere. The Equator, each meridian, and each other full circumference of the Earth forms a great circle. The arc of a great circle shows the shortest distance between points on the surface of the Earth.

Grid
A set of regularly spaced sample points or an exact set of reference lines over the earth's surface.
**H**

**Header File**
A file associated with an image that contains georeferencing information for the image. File extensions may be TFW or JPW (tiff, jpeg World Files), IRP (Image Report Files) or TAB (Table files).

**Hydrography**
In its most general definition, hydrography is the description and study of seas, lakes, rivers, and other bodies of water with regard to: the measurement of flow and investigation of the behaviour of streams; the measurement of tides and currents, and the surveying, sounding, and charting of those bodies of water (Webster's Third New International Dictionary, 1993).

**Hypsography**
Lines or points which depict the relief of the land or contours or spot elevations.

**I**

**Icon**
An image representing a software function or tool.

**Image**
A graphic representation or description of a scene, typically produced by an optical or electronic device. Examples include remotely sensed or satellite data, scanned data, and photographs.

**Import sequence**
The order of steps required to import data.

**Integer**
A number without a decimal. Integer values can be less than, equal to, or greater than zero.

**Isoline**
A line on a surface connecting points of equal value for any of the characteristics used in the representation of the surface.

**J**

**Join Lines**
A function in MAPublisher for joining a set of linear features based on a common value such as street name.

**JPEG**
Joint Photographic Experts Group, is a lossy compression technique for raster file formats.

**L**

**Label**
Text used to identify a map feature.

**LANDSAT**
The generic name for a series of earth resource scanning satellites launched by the United States of America.

**Latitude**
Angular distance, expressed in degrees and minutes, along a meridian north or south of the equator.
Lat/Long
Latitude/Longitude. Unprojected.

Layer
A designated level in artwork used for storing, organizing and editing graphic or mapping data.

Legend
The section of the map that explains the meaning of the symbols used to depict graphic or geographic elements.

Legend element
A legend key combined with its associated text.

Legend key
The graphic symbol used to illustrate attributes in a legend.

Longitude
The angular distance east or west from a standard meridian to another meridian on the earth’s surface; expressed in degrees and minutes.

Line
One of the basic geographical elements, defined by at least two pairs of X,Y coordinates; usually too narrow to be an area. See also arc, path and vector.

Listgeo
A free utility for examining GeoTIFF header information. It can be used to dump the contents of the GeoTIFF header in human readable form.

Linear scale
The relation between a distance on a map and the corresponding distance on the Earth. Scale varies from place to place on every map. The degree of variation depends on the projection used in making the map.

Lossless/Lossy
Lossless techniques compress image data without removing detail; lossy techniques compress images by removing detail.

M

MacOS
Apple Macintosh operating system.

Map
A graphic representation of features of the earth’s surface or other geographically distributed phenomena.

Map Anchor
The minimum X and Y coordinates of the data files.

Map Coordinates
The X,Y representations of ellipsoidal earth locations on a mapping plane.

Map Extent
The geographic extent of a geographic data set specified by the minimum bounding rectangle.

MAP Layer
A MAPublisher term for an Illustrator layer containing georeferencing information.
Map Projection
A map projection is a systematic representation of a round body such as the Earth on a flat (plane) surface. Each map projection has specific properties that make it useful for specific purposes. Also see Projection.

MAP Selection Filter
Expression criteria used for making a selection in MAPublisher documents.

MAP Stylesheet
A MAPublisher Stylesheet, containing styles based on attribute information.

MAP View
A MAPublisher term for a distinct coordinate system. A MAP Layer must reside within a MAP View.

Marquee
A dashed rectangle drawn with a selection tool used to select multiple objects.

Meridian
A line of longitude running vertically from the north pole to the south pole.

Meta-Data
Data about data typically including information such as currency, accuracy, and extent. Meta-data is typically stored in data models or data dictionaries.

MIF/MID
The MapInfo Map Interchange Format. An ASCII file format pair exported from MapInfo GIS software. The .mif file contains the vector data and the .mid file contains the attribute data

MrSID
MrSID is a file format developed by LizardTech that reduces the size of large, high-resolution images to a fraction of their original size while maintaining the original image quality and integrity.

N

NAD
North American Datum.

Network
Two or more interconnected computer systems for implementation of specific functions or a set of interconnected graphic lines defining some spatial features.

Node
The point or intersection at which areas or lines are joined; endpoints of an arc.

NSDI
National Spatial Data Infrastructure.

O

Orthophoto
A modified copy of a perspective photograph of the earth's surface with distortions due to tilt and relief removed.

Overlay
A set of graphical data that can be superimposed on another set of graphical data through registration to a common coordinate system. The process of laying one set of digital spatial data over another for analysis purposes.
Page Anchor
The location on the page where the map anchor is placed.

Page Extent
Defines a rectangular portion of the graphics page to be displayed.

Page Size
The size of the drawing page.

Parameters
Variable options or choices; boundaries of operations or of an object.

Path
A line/vector defined by a series of points (a string of X,Y coordinates).

PDF
Portable Document Format. Developed by Adobe, a PDF is a file type, which can be used to cross Macintosh, Windows, DOS, and UNIX platforms.

Pixel
The smallest unit of information in a grid cell map or raster image.

Pixel Scale
The real world distance as represented by a single pixel in a georeferenced image.

Plug-in filter
A module supplied separately from the Adobe Illustrator program, usually for creating special effects in artwork. The MAPublisher application plug-in filter is a module that enables the incorporation of GIS and mapping capabilities within the Adobe Illustrator graphics environment.

PMS
Pantone™ Matching System.

Point
A discrete location represented by a symbol or label; usually too small to be displayed as an area or line.

Polygon
Any area bounded by a straight or irregular closed line representing a map component or any other graphic feature.

Polyline
A line made up of a sequence of line segments.

Positional Accuracy
The degree to which a position is measured or depicted, relative to its correct position as established by either other features or by other accurate processes.

Postscript
A page description language built into many desktop printers and virtually all high-end printing systems. See the Adobe Illustrator User Guide for more details.

PPC
Power PC (e.g. Macintosh PowerPC processor).

Precision
That which relates to the exactness of the operation by which the result is obtained. The exactness with which a value is expressed, whether the value be right or wrong.
**Projection**  
The representation on a plane surface of any part of the surface of the earth. Also see Map Projection.

**R**  

**Raster**  
A method for the storage, processing and display of spatial data. Each given area is divided into rows and columns, which form a regular grid structure. Each cell must be rectangular in shape, although not necessarily square. Each cell within this matrix contains an attribute value as well as location coordinates. The spatial location of each cell is implicitly contained within the ordering of the matrix, unlike a vector structure which stores topology explicitly. Areas containing the same attribute value are recognized as such, however, raster structures cannot identify the boundaries of such areas as polygons. Also raster structures may lead to increased storage in certain situations, since they store each cell in the matrix regardless of whether it is a feature or simply ‘empty’ space.

**Record**  
A set of attributes relating to any entity; a set of related, contiguous data.

**Redundancy**  
The duplication of data in a database.

**Remote Sensing**  
The technique of obtaining data about the environment and the surface of the earth from a distance, for example, from aircraft or satellite.

**Render**  
To cause to be or to become, to draw.

**Resolution**  
The number of dots per inch displayed on screen or printed to an output device.

**Rhumb line**  
A line on the surface of the Earth cutting all meridians at the same angle. A rhumb line shows true direction. Parallels and meridians, which also maintain constant true directions, may be considered special cases of the rhumb line. A rhumb line is a straight line on a Mercator projection. A straight rhumb line does not show the shortest distance between points unless the points are on the Equator or on the same meridian.

**RS**  
Remote Sensing.

**Rubber sheeting**  
A procedure to adjust the coordinates all of the data points in a dataset to allow a more accurate match between known locations and a few data points within the dataset. Rubber sheeting, also known as rubber banding, preserves the interconnectivity or topology, between points and objects through stretching, shrinking or re-orienting their interconnecting lines.

**S**  

**SAIF**  
Spatial Archive and Interchange Format. SAIF is a Canadian Draft National Standard for Geomatics data interchange. It is a specification for data, which includes an object-oriented data model, and a language for describing both spatial and non-spatial data.
Scale
The relation between the size of an object on a map and its size in the real world.

Scanner
A device for converting images from maps or photographs of part of the real world into digital form automatically.

Schema
In MAPublisher 7 the term schema is used to define the structure and makeup of the map attributes table.

SDTS
Spatial Data Transfer Standard - a standardized format used by the USGS for transferring earth-referenced spatial data between dissimilar computer systems that includes support for the inclusion of spatial data, attribute, georeferencing, data quality report, data dictionary, and other supporting meta-data within a single file transfer format.

SEA
Self-Extracting Archive, a file compression format for reducing the size of large files for archival or transfers.

Shapefile
The shape file format is a public format that is the native file format for ESRI’s ArcView product. This format can be used to export data with attributes from both ArcInfo and ArcView. From ArcInfo the command at the ARC level to create a shape file is arcshape

Sliver
A gap formed when two lines, which should be contiguous, are slightly separated in a graphical representation or map.

Spaghetti Data
Vector data composed of line segments which are not topologically structured or organized into objects and which may not even be geometrically clean. Spaghetti data can be useful however, if all that is required is a visual image or plot of a map and no spatial analysis is to be performed.

Spatial
Of space, a two or three-dimensional position in space.

Spatial Data
Any information about the location and shape of, and relationships among, geographic features. This includes remotely sensed data as well as map data.

Sphere Coordinates
X,Y locations on the ellipsoidal earth, usually expressed in degrees and minutes.

Spheroid
An ellipsoid of rotation that is flattened at the poles, like the earth.

Spline
A function in MAPublisher that improves the smoothness of curved lines, drops redundant points from paths and changes the anchor points on paths to direction points for further manual modifications.

SPOT
An earth resource satellite with high-resolution sensors launched by France in January 1986.

Static Graphic Files
Unchanging and uneditable graphic files.
Thematic Map
A map displaying selected kinds of information relating to specific themes, such as soil, land-use etc.

Theme
A user-defined perspective on a geographic dataset specified, if applicable, by a name and feature class or dataset name, attributes of interest, or data classification scheme.

Thiessen Polygon
A polygon bounding the region closer to a point than to any adjacent point. The polygons are drawn so that the lines are of equal distance between two adjacent points. Thiessen polygons, also known as Voronoi diagrams and Dirichlet tessellations, are sometimes used as a crude form of interpolation, particularly within the geosciences.

Thinning
Reducing the number of points defining a line while preserving the essential shape of the line. Common weeding algorithms include: distance traversed algorithm, Nth point selection algorithm, angle selection algorithm, William’s point relaxation algorithm and Douglas-Peucker algorithm.

TIFF
Tagged Image File Format, a common raster graphic file format.

Tile
A discrete part of the earth's surface. By splitting a study area into tiles, considerable savings in access times and improvements in system performance can be achieved.

Topographic map
A map showing natural and man-made features as well as relief, often in the form of contours.

Topography
The study of the relief of a given area on the Earth's surface, usually on a large scale, including both natural and man-made features.

Topology
The way in which geographic features relate to each other.

Toponym
The place names of a region or map feature.

Transform
The process of changing the scale, projection, or orientation of a mapped image.

TRIM
A GIS data file format from the Terrain Resource Information Management of British Columbia, Canada.

Ungenerate
The file format created by the ArcInfo Ungenerate function.

UNIX
A general-purpose, multi-user computer operating system.

URL
Universal Resource Locator or Internet address.
USGS
United States Geological Survey.

UTM
Universal Transverse Mercator, a common map projection.

UTM Grid
A grid system based upon the Transverse Mercator projection. The UTM grid extends North-South from $80^\circ$N to $80^\circ$S latitude and, starting at the $180^\circ$ Meridian, is divided eastwards into 60, 6 degree zones with a half degree overlap with zone one beginning at 180 degrees longitude. The UTM grid is often used for topographic maps and for georeferencing satellite images.

V

Vector Linework / Artwork
One method of data type, used to store spatial data. Vector data is comprised of lines, defined by beginning and end points, which meet at nodes. The locations of these nodes and the topological structure are usually stored explicitly. Features are defined by their boundaries only and curved lines are represented as a series of connecting arcs. Vector storage involves the storage of explicit topology, which raises overheads, however it only stores those points which define a feature and all space outside these features is ‘non-existent’.

Vector Data
An abstraction of the real world where positional data is represented in the form of coordinates. In vector data, the basic units of spatial information are points, lines and polygons. Each of these units is composed simply as a series of one or more coordinate points. A line is a collection of related points and a polygon is a collection of related lines.

Vertex
One of a set of ordered X,Y coordinates that constitute a line. A points representing spatial X,Y coordinates that occur along a line between the nodes and help define the shape of the arc.

VPF
Vector Product Format. A binary format used by the US Defense Mapping Agency. It is well documented and can be sued as an internal format and as a transfer format. It carries geographic and attribute information but no display data. VPF files are sometimes referred to as VMAP products. MAPublisher does not support VPF files.

W

World file
A file associated with an image that contains georeferencing information for the image. File extensions may be TFW or JPW (tiff, jpeg World Files), IRP (Image Report Files) or TAB (Table files).

WWW
World Wide Web.

Z

Zone
Any well-defined region of more or less belt-like form.

Zoom
To magnify or reduce the current view of a document.