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Welcome

Avenza welcomes you to mapmaking in the 21st century!

Combined with Adobe lllustrator, MAPublisher has revolutionized the art of mapmaking by allowing spatial data
files to be used to create maps inside a vector graphics program. MAPublisher allows all your cartographic tasks to
be performed where they should be done;in a powerful graphics environment.

MAPublisher 7 improves on the already powerful tools of previous versions by adding additional file support,
additional tools and improvements to existing tools.

This tutorial manual assumes that the user is familiar with Adobe Illustrator CS2, and has at least a basic
understanding of geographic information systems (GIS) terminology and concepts. The exercises in this manual
should be used in conjunction with the MAPublisher 7 User Guide. Note that the numbering of each Tutorial
section matches the corresponding Chapter in the User Guide.

By following these tutorials you will learn how to create maps using the MAPublisher filters in Adobe Illustrator.
This manual covers the steps necessary to build a map and perform fundamental cartographic and GIS tasks.
Together MAPublisher and Adobe Illustrator will give you a totally integrated cartographic design software system
with graphics tools and geographic functions present in the same work environment.

TUTORIAL DATA

All the exercises in this manual will use GIS data supplied in the Tutorial Data folder on your MAPublisher 7 CD
or in the electronic download. Alternatively, if you have installed the Tutorial Data, you can find this in the
Avenza/MAPublisher 7 folder on your hard drive. However we do encourage you to experiment with your own
data to gain additional experience with MAPublisher’s tools and functions.
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Importing Map Data

3-i: IMPORTING A SINGLE MAP FILE

uh W

Start by creating a new lllustrator page in landscape orientation. If you choose to edit the orientation of a
current document, be sure to reset the rulers so that the 0,0 point is at the lower left corner of the page.
Select File > Import Map Data > Simple... to open the MAPublisher Simple Import dialog.

Select Mapinfo MIF/MID from the Format dropdown

Click the “..” (Browse) button to open the data source browser.

Locate and select the world.mif file from the Tutorial Data folder and click Open.

Import
Format: |Maplnf0 MIF/MID "i Settings. .

Dataset: |:\ngram Files\Avenza\MaPublishery Tutorial Data\wmrldmlfl E]

Character encoding: \ Systemn v!

Source MAP View
MaplInfo Generic LatfLong Edit...

Simple Import dialog after selecting world.mif.

Note the Source MAP View (Source Coordinate System) has been automatically read as being Generic Lat/Long.
Click OK.

The Simple Import dialog closes and the selected map file is imported. The map has been imported to

automatically fit to the size of the page.

Notice that in the lllustrator Layers palette there is a new layer called ‘world. Also in the MAP Views

palette there is a new MAP View holding the imported file. See more on MAP Views on page 22.

" @ [llustrator File Edit Object Type Select Filter Effect View Window Help [ 3
vosceaion ot [ e IR @ v W oean [ 8] o im0 A e B) BExfEom  xfon R
‘@806 = World.ai @ 100% (CMYK,/Preview)

e ) Open » (=)
Adobe Illustrator after Simple Import of world.mif.
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3-ii: IMPORTING MULTIPLE MAP FILES AT ONCE

The Simple import filter also allows for the import of multiple map files at a single time. When importing multiple
files, all files must be of the same format, be in the same projection, and be located in the same directory.

Start by creating a new lllustrator page in portrait orientation.

Select File > Import Map Data > Simple... to open the MAPublisher Simple Import dialog.

Select MapInfo MIF/MID from the Format dropdown.

Click the “..” (Browse) button to open the data source browser.

Locate and select the fsatoronto.mif and torontostreets.mif files from the Tutorial Data folder. Use the Apple
key (Mac) or the Ctrl key (Windows) to select the two files, and then click Open.

A wN =

il
Format: | Mapinfo MIF/MID ¥| | Settings..,

Dataset: |n Files)AverzalMapublisher\ Tutorial Data\turuntustreets.mlf| E

Character encoding: ‘ System v!

Source MAP Wiew
Maplnfo Generic LatfLong Edit...

Simple Import dialog after selecting the fsatoronto.mif and torontostreets.mif.

6. Note the Source MAP View (Source Coordinate System) has been automatically read as being Generic Lat/Long.
Click OK to import the map files. The data files will be imported to automatically fit to the size of the page.
8. Notice that in the Layers palette there are new layers called ‘torontostreets’ and ‘fsatoronto’. Also
in the MAP Views palette there is a new MAP View holding the two imported files (Note that the layers are
listed alphabetically under the host MAP View in the MAP Views palette).

N

" @ llustrator File Edit Object Type Select Filter Effect View Window Help
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Adobe lllustrator after multiple import of fsatoronto.mif and torontostreets.mif.
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3-iii: IMPORTING MAP FILES TO MATCH AN EXISTING MAP LAYER

uhwn

No

11.

12.

Start by creating a new lllustrator page in landscape orientation.

Select File > Import Map Data > Simple... to open the MAPublisher Simple Import dialog.

Select ESRI Shape from the Format dropdown.

Click the Browse button to open the data source browser.

Locate and select the worldwest.shp file from the Tutorial Data folder and click Open.

The dialog closes and the selected file appears in the file list in the MAPublisher Simple Import window.

Note that the Source MAP View has been automatically read as being Robinson in Meter.

Click OK.

The Simple Import dialog closes and the selected map file is imported. The data file has been imported to
automatically fit to the size of the page.

Notice that in the lllustrator Layers palette there are new layer called ‘worldwest’ Also in the MAP Views
palette there is a new MAP View called ‘worldwest’in Robinson, which holds the imported file. See more on
MAP Views on page 22.

" @ llustrator File Edit Object Type Select Filter Effect View Window Help <1
vossectn o[ o) suoce [ @ ) ensn [+ w) emsay [0 )% swe| W) BEx(Eom vEoe & ®
[@eoce = WorldEast.ai @ 100% (CMYK/Preview)

2 bayei S [5al [ &l | @ |z

MAP Views \MAP Attributes N

v @ worlawest

1 MAP View EEE
al
Diale
EHo@
Adobe lllustrator after Simple Import of worldwest.shp.
Repeat Steps 2 to 4

Locate and select the worldeast.shp file from the Tutorial Data folder and click Open.

The dialog closes and the selected file appears in the file list in the MAPublisher Simple Import window.

Note that as in the worldwest import, the Source MAP View has been automatically read as being Robinson
in Meter.

Click OK.

Importing Map Data



13.

14.

In the Matching MAP View Found dialog, choose to Add to ‘worldwest’. Then check Resize MAP View to fit.
The Simple Import dialog closes and the selected map file is imported to match the previous import. Notice that the
‘worldwest’ layer has been rescaled so that both itself and the ‘worldeast’ layer will fit inside the page extents.
Notice that in the lllustrator Layers palette there is now an additional layer called ‘worldeast: Also in the

MAP Views palette the MAP View ‘worldwest’ now holds both layers.

" @ llustrator File Edit Object Type Select Filter Effect View Window Help Q@
wiedovecs [ o) suroke [E o) @i e[ W) opser[ron e soe| ) [ | [T e e == e e ] B[R
@6 ~ WorldEast.ai @ 100% (CMYK/Preview)
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Adobe lllustrator after import of worldeast.shp file, with worldwest layer rescaled.

3-iv: IMPORTING MAP FILES WITH AUTO GRAIN

mhwn =

No

Start by creating a new illustrator page.

Select File > Import Map Data > Simple... to open the MAPublisher Simple Import dialog.

Select Mapinfo MIF/MID from the Format dropdown

Click the Browse button to open the data source browser.

Locate and select the greenland.mif file from the Tutorial Data folder and click Open.

The dialog closes and the selected file appears in the file list in the MAPublisher Simple Import window.

Click OK.

Due to this file being complex, in that it exceeds the allowable 32,000 points per path in lllustrator, the Auto
Grain warning dialog appears.

Click OK in this warning dialog.

The Simple Import dialog closes and the selected map file is imported. MAPublisher has calculated the grain
and removed points to give the highest level of detail possible.

Importing Map Data 9



3-v: IMPORTING GIS FORMATS THAT REQUIRE OPTIONAL SETTINGS

There are a number of other file formats in the Tutorial Data folder to experiment with. MAPublisher will deal with
its supported file formats in varying ways, and some will import differently and/or require extra user input. There is
an overview of the file formats supported by MAPublisher in the User Guide.

Create a new document and open the MAPublisher Simple Import dialog.

Select ESRI Arcinfo Export (E00) from the Format dropdown.

Select the capeverde.e00 file from the Tutorial Data folder.

Click the Settings button.

Enable the Include TIC layer setting.

Click OK.

As e00 files are generally an archive of several files, MAPublisher will reproduce an e00 import as distinct
lllustrator layers. Notice therefore that MAPublisher has generated point, area, line and text layers. An extra
layer appended with _tic_point has been created holding tic points, as was specified in the Settings dialog.

Noubkwh=

B @ llustrator File Edit Object Type Select Filter Effect View Window Help Q |
Noscssion i) suoie IR @R [ beah[ - W) Cosng [0 % swe| W) BxEom | wfEom &®
006 ) CapeVerde.ai @ 80% (CMYK/Preview)
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Adobe lllustrator after import of capeverde.e00.
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3-vi: IMPORTING POINTS

The MAPublisher import filters also allow the import of delimited ASCII text files as point data provided they contain
coordinate values. A typical file of this nature might be set up as follows:

“X value”,”Y value”,”Name”,”Population”
“3.4”,75.4” " Metropolis”,”2345000”
“6.54",721.4” "Gotham City”,”1234000”
“6.32”,766.6”,”Smallville”,”54"

The MAPublisher Import Points filter supports the import of delimited ASClII files that contain any of the following
delimiters between data values: comma, return, end of line and tab.

Create a new document and open the MAPublisher Simple Import dialog.

Select ASCII Point Data from the Format dropdown.

Select the azdeci.txt file.

The Settings dialog will open automatically.

Select the columns of the file to be used as the points’ X and Y coordinates, using the X and Y axis dropdown

lists. The dropdown lists are filled with the numeric columns found in your ASCll file. For this file, use

‘Column 6’for the X coordinates, and “Column 5’ for the Y coordinates.

6. (Optional) Set the values by which the X and Y coordinates will be multiplied by before they can be imported
by first clicking the Multipliers button. You can multiply the X coordinates by a different value than the Y
coordinates if you wish. The default for each is 1, which will not change your values at all. Click OK.

7. Leave the Use first line as a header option unchecked, as the first line of this file does not contain column
headings.

8. Click OK.

9. The points are placed on the page as specified. All columns that were in the file are imported as attribute data

for the created points.

uhwn =

" @ ustrator File Edit Object Type Select Filter Effect View Window Help 23
Nossicion | 9) suoke EIR) @ e [t [ ) om0 % e B) BExfEem | v@lom = ®
(@66 = ImportPoints.ai @ 80 (CMYK /Preview)

MAP Views UAIAP Actibutes N 5]

T | B W W] %]

) oo >

Adobe lllustrator after import of azdeci.txt.
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3-vii: IMPORTING MULTIPLE FILE TYPES

NowunpkwhnN

10.
11.
12.
13.

14.

14.

15.

Start by creating a new illustrator page in landscape orientation. If you choose to edit the orientation of a
current document, be sure to reset the rulers so that the 0,0 point is at the lower left corner of the page.
Select File > Import Map Data > Advanced... to open the MAPublisher Advanced Import dialog.

Click the Add button to open the Import Map Data Source dialog.

Select Mapinfo TAB from the Format dropdown.

Click the...” (Browse) button to open the data source browser.

Locate and select the usa.tab file from the Tutorial Data folder and click Open.

Click OK in the Import Map Data Source dialog as you do not need to specify a projection.

The dialog closes and the selected file appears in the file list in Row 1 of the MAPublisher Advanced Import
window.

Click the Add button to open the Import Map Data Source dialog.

Select ESRI Shape from the Format dropdown.

Click the..” (Browse) button to open the data source browser.

Locate and select the canada.shp file from the Tutorial Data folder and click Open.

Click OK in the Import Map Data Source dialog as you do not need to specify a projection.

The dialog closes and the selected file appears in the file list in Row 2 of the MAPublisher Advanced Import window.
In the Destination MAP View section click the New Based On radio button, and then choose usa.tab

from the dropdown. This will base the page scaling on the usa file.

Check the ‘Auto scale’ option. This will ensure all selected files are fitted inside the page extents.

Note: Not checking the ‘Auto scale’ option will base the page scaling on the file selected in the ‘New based on’ listbox
only. Therefore only this file will be fitted to the current page extents, which may cause elements in other selected
files to be placed outside of the page boundary.

File Name |Prnjectinn D ‘

1 iC:\Tutorla\ Data\usa.tab NAD27 Latitude/Longitude, Degree

|"2-_‘ic:\Tut0ri3\ Data\canada.shp MAD27 Latitude/Longitude, Degree
Add... Remove Edit...

Destination MAP View

@ New based on: | usa.tab w| |[Projection 1D: NAD27 ~
——————————————————— | Lstitude/Longitude, Degree

PageAnchors: (0, 0)

Visual Scale: 1 @ 515.276681

Use existing: 'fl lo MAP Views]

Create new: Editor...
Cg = Map Anchors: (-178.21786, 5
Auto scale ’1'8.92481‘ 2

Click OK to import the two files.

The Advanced Import dialog closes and the selected map files are imported. The files have been imported with

both files fitted to the size of the page.

Notice that in the lllustrator Layers palette there are new layers called ‘usa’ & ‘canada’

Also in the MAP Views palette there is a new MAP View holding the imported files. See more on MAP Views on
page 22.

Importing Map Data
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Filter Effect View Window Help [
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Adobe lllustrator after Advanced Import of usa.tab and canada.shp.

3-viii: IMPORTING MAP FILES IN MULTIPLE PROJECTIONS

NounsrwN =

10.
11.
12.

13.

Start by creating a new illustrator page in portrait orientation.

Select File > Import Map Data > Advanced... to open the MAPublisher Advanced Import dialog.

Click the Add button to open the Import Map Data Source dialog.

Select Maplinfo TAB from the Format dropdown.

Click the ...” (Browse) button to open the data source browser.

Locate and select the usa.tab file from the Tutorial Data folder and click Open.

Click OK in the Import Map Data Source dialog as you do not need to specify a projection.

The dialog closes and the selected file appears in the file list in Row 1 of the MAPublisher Advanced Import

window. Note that the Coordinate System of the usa.tab file has been automatically read as being NAD 27 Latitude/
Longitude in Degree.

Click the Add button to open the Import Map Data Source dialog.

Select ESRI Shape from the Format dropdown.

Click the Browse button to open the data source browser.

Locate and select the worldwest.shp file from the Tutorial Data folder and click Open.

Click OK in the Import Map Data Source dialog as you do not need to specify a projection.

The dialog closes and the selected file appears in the file list in Row 2 of the MAPublisher Advanced Import

window. Note that the Coordinate System of the worldwest.shp file has been automatically read as being Robinson
in Meter.

In the Destination MAP View section click the New Based On radio button, and then choose worldwest.shp
from the dropdown. This will base the projection and page scaling on the worldwest file.

Importing Map Data 13



Advanced

File Name Projection 1D ! g
oy UTutoriaI Data/usa.tab NADZ27 Latitude/Longitude, Degree ‘
2 | [Tutorial Data/worldwest.shp Robinson in METER ‘

Add... Remove | Edit...

-Destination MAP View

@ Mew based on: rwnrldwest.shp 5‘ Projection ID: Robinson in m

n e T, METER (custom ID _FME_D)

e X I —— PageAnchors: (0.0000,

O Create new: Editor... 0.0000) A
- Visual Scale: 1:

O Auto scale 71792536.897795

14. Click OK to import the two files in the Robinson projection.

15.

The Advanced Import dialog closes and the selected map files are imported. The files have been imported to
automatically fit to the size of the page. Note that the ‘Auto scale’ option was not required to be checked in the
Advanced Import dialog, as the page scaling was based on the ‘worldwest.shp; which contained larger geographic
extents than the ‘usa.tab’ in all four compass directions.

Notice that in the lllustrator Layers palette there are new layers called ‘usa’ and ‘worldwest’. Also

in the MAP Views palette there is a new MAP View holding the imported files (the MAP View will have the same
name as the first selected file in the Advanced Import list,above). See more on MAP Views on page 22.

" @ lustrator File Edit Object Type Select Filter Effect View Window Help [
noseecion  rit[ o) syoke [ @ v ) enn [« o) oy [io0 % swel ) B xfEon v = °®
[eo 0 = Robinson.ai @ 80% (CMYK/Preview)
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e 4 topescarce NGRS ©)
s GiAPATBIE N ) [ o scection
v Sroke: [ 1ot

Blwe 0 Mmoo g

p— S Defaut Transparency
¥ (7] Mon-mapleyerst > [ESHELS] RN

A a1 Layers [0]
| ® [ [» [FHua o’
T view R ® [ |r Qv O

® [ | [Juwe: o

Ilayers S [oal | &l | @ |/

NEIC

]

@

Open » i
Adobe lllustrator after Advanced Import of worldwest.shp and usa.tab.
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3-ix: IMPORTING MAP FILES TO MATCH AN EXISTING LAYER’S PROJECTION

This exercise will produce the same results as Tutorial 3-viii.

1. Start by creating a new lllustrator page in portrait orientation.
2. Select File > Import Map Data > Simple... to open the MAPublisher Simple Import dialog.
3. Import the worldwest.shp file from the Tutorial Data folder.
4. Notice that in the Illustrator Layers palette there is a new layer called ‘worldwest: Also in the
MAP Views palette there is a new MAP View called ‘worldwest’in Robinson, which holds the imported file.
5. Select File > Import Map Data > Advanced... to open the MAPublisher Advanced Import dialog.
6. Select Mapinfo TAB from the Format dropdown.
7. Click Add, and choose the usa.tab file from the Tutorial Data folder.
8. Click OK in the Import Map Data Source dialog as you do not need to specify a projection.

The dialog closes and the selected file appears in the file list in Row 1 of the MAPublisher Advanced Import
window. Note that the Coordinate System of the ‘usa.tab’ file has been automatically read as being NAD 27
Latitude/Longitude in Degree.

9. Inthe Destination MAP View section click the Use Existing radio button, and then choose ‘worldwest’
from the dropdown. View the coordinate system of this file in the right hand panel.

| File Name |Prnjectinn o] ‘
,_l_iC:\Tuturla\ Data\usa.tab NAD27 Latitude/Longitude, Degree
Add... Remove Edit...

Destination MAP View

(O New based on: |E£ab | Projection ID: Robinson in A
 Teeeeeessssss | METER {custom ID _FME_0)
@ Use exsting: LT PageAnchors: (0, 0)
F Visual Scale: 1 :

Creat K Editor...
Eiesteenl i 71792536.897795

Auto scale Map Anchors: (-16195197.57,

EanniEs 1

10. Click OK to import the file with the Robinson parameters of the worldwest layer.
The Advanced Import dialog closes and the selected map file is imported. The file has been imported and
reprojected to automatically align with the worldwest layer .

11. Notice that in the Illustrator Layers palette there are now two layers, called ‘usa’and ‘worldwest:

Also in the MAP Views palette the MAP View in the Robinson projection now holds both the imported files.

Importing Map Data
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3-x: ASSIGNING A PROJECTION PRIOR TO IMPORT

Start by creating a new illustrator page in portrait orientation.

Select File > Import Map Data > Advanced... to open the MAPublisher Advanced Import dialog.

Click the Add button to open the Import Map Data Source dialog.

Select ESRI Arcinfo Generate from the Format dropdown.

Click the Browse button to open the data source browser.

Locate and select the ukrail.gen file from the Tutorial Data folder and click Open.

Click OK in the Import Map Data Source dialog.

The dialog closes and the selected file appears in the file list in Row 1 of the MAPublisher Advanced Import

window.

With the ukrail.gen row selected, click the Edit button to return to the Import Map Data Source dialog.

9. In Projection Category: Choose By geographical area - Europe from the dropdown to display only European
projections. Then choose British National Grid (ORD SURV GB) (EPSG #27700) in the projection list.

10. Click OK to return to the Advanced Import dialog.

11. In the Destination MAP View section, you can view the chosen coordinate system in the right hand panel.

12. Click OK to import the file in British National Grid.

The Advanced Import dialog closes and the selected map file is imported.

NoubkwhN=
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3-xi: CHANGING A PROJECTION PRIOR TO IMPORT

You should read the section on the MAP View Editor in the User Guide before completing the following exercise.

Start by creating a new lllustrator page in portrait orientation.
Select File > Import Map Data > Advanced... to open the MAPublisher Advanced Import dialog.
Click the Add button to open the Import Map Data Source dialog.
Select ESRI Shape from the Format dropdown.
Click the Browse button to open the data source browser.
Locate and select the ukpoly.shp file from the Tutorial Data folder and click Open.
Click OK in the Import Map Data Source dialog as you do not need to specify a projection.
The dialog closes and the selected file appears in the file list in Row 1 of the MAPublisher Advanced Import window.
Note that the Coordinate System of the ukpoly.shp file is currently Latitude/Longitude in Degree.
8. Inthe Destination MAP View section click the Create New radio button, and then click Editor.
The MAP View Editor will open.
9. The projection list will display all recently used projections, choose British National Grid (ORD SURV GB)
(EPSG #27700).
Ifyou have just begun this tutorial choose Europe from the Projection Category: By geographical area dropdown to
display only European projections. Then choose British National Grid (ORD SURV GB) (EPSG #27700) in the projection
list.
Click OK to exit the MAP View Editor and return to the Advanced Import dialog.
In the Destination MAP View section, you can view the chosen coordinate system in the right hand panel.
8. Click OK to import the file in the British National Grid projection.
The Advanced Import dialog closes and the selected map file is imported.

NoubkwhN=
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Attributes and Georeferencing

4-i: DETERMINING THE COORDINATES OF A SPECIFIC LOCATION

4-

wnN =

Import any map file from the Tutorial Data folder.

Make sure the MAP Layer is selected in the Illustrator Layers palette, and click on the MAP Location Tool |-
button in the Adobe Illustrator toolbar to open the Location window.

Move the mouse cursor to the location whose geographic coordinates you wish to see.

The WX and WY fields will constantly be updated with the coordinates of the mouse cursor as you move the

mouse around the map document. This tool also allows for the copying of coordinates. Determine a location

that you would like to generate coordinates for. Hold down the Shift key and click this location. Open a simple
text editor, and then paste the coordinate values.

: VIEWING AND EDITING MAP ATTRIBUTES

Import the world.mif file from the Tutorial Data folder.

Select all or some of the map’s features.

Select Window > MAPublisher Palettes > MAP Attributes to open the MAP Attributes Window. Check that the
layer dropdown is set to ‘world:

Double click inside a cell and type a new value. Proceed for a number of cells.

All attribute values including property attributes can be edited. MAPublisher creates some attributes which start
with “#”they are also editable (they must be made visible first), however #Area, #Perimeter, #VertexCount and
#Length can't be edited because they are properties of the geometry and can't be edited by changing attributes.
Keep in mind that you must enter values that correspond with a column’s type (i.e. only enter numbers into a column
of type “Real” or “Integer”). The edits will automatically be maintained in the attribute table once entered.

The widths of the columns in the MAP Attributes window may be changed by clicking on the column separator
and dragging it left or right as desired. Double clicking on a column separator will set the column width to the
column attribute with the greatest amount of characters.

Attribute columns may also be sorted in ascending manner by clicking on the column heading.

MAP Artributes @

Layer: | Bworld (220 areas selected) B
‘[nuntry | capital | Arable_Pet IPDpu\ntlcm |Pop_Grw_Rt |Literacy Inflat_Rate | !

- Afghanistan Kabul 12.000000| 16450304.000000 5.200000 29.000000| 92.000000 m
'z |Albania Tirane 21.000000| 3335044.000000] 1.800000 72.000000| 0.000000
'X_Algem Algiers 3.000000 26022188.000000 2.500000 50.000000 20.000000
4 |Andorra Andorra la Vella 2.000000| 53197.000000 2.400000  0.000000 0.000000
-S_Angula |Luanda 2.000000| 8668281.000000 2.700000  42.000000 23.200000
E_Anguilla The Valley 0.000000| 6922.000000| 0.600000 95.000000 4.500000
|7 |Antarctica none 0.000000| 0.000000 0.000000  0.000000 0.000000
rAnngua St. Johns 18.000000 63917.000000 0.400000 89.000000 3.600000
B—Argen[ma Buenas Aires 9.000000/ 32663983.000000 1.100000 95.000000 1345.000000
10 |Armenia [Yerevan | 0.000000 3412000.000000] 0.000000  0.000000 0.000000
11 |Aruba Oranjestad 0.000000| 64052.000000 0.600000  0.000000 5.800000
1z |Australia Canberra 6.000000| 17288044.000000| 1.500000 100.000000 6.900000
13 |Austria Vienna 17.000000 7665804.000000 0.300000 99.000000 3.300000
TAzerbaUan Baku 0.000000| 6811000.000000 0.000000  0.000000 0.000000
15 |Azores [Ponta Delgada | 0.000000 0.000000 0.000000  0.000000 0.000000
16 |Bahamas Nassau 1.000000 252110.000000 1.400000 90.000000 5.400000
|17 |Bahrain Manama 2.000000| 5369974.000000 3.200000  77.000000 1.500000
Tﬁanglsdash Dhaka 67.000000 116601424.000000 2.300000 35.000000 10.000000
19 |Barbados Bridgetown 77.000000| 254626.000000 0.100000,  99.000000 6.200000
20 |Barbuda |saint John's | 18.000000 63917.000000 0.400000, 89.000000 3.600000 4
_ZQ_L_EEIumm Brussels. 24000000 99219}5}.000000 0.100000/ 99.000000! 3.300000 7

220 areas slacted B 7 A K U

Partial view of MAP Attributes Window displaying the attributes of the ‘world’ layer.
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4-iii: ADDING A NEW COLUMN TO A MAP ATTRIBUTE TABLE

N —

Import the world.mif file from the Tutorial Data folder.

Select Window > MAPublisher Palettes > MAP Attributes to open the MAP Attributes window. The window
displays the columns associated with the MAP Attribute records on the currently selected MAP Layer.

Click on the New Column icon at the bottom of the MAP Attribute palette.The Edit Schema window displays
the columns associated with the Map Attribute table on the currently selected layer.

In the Name field, enter a column name, such as“Head_of_State”.

NOTE: Spaces are not accepted for column names, MAPublisher will insert a
input in a column name.

Select “String’from the Type listbox as this column will contain alpha values.

Set a width of 10 (this is the number of characters which can be displayed in the MAP Attributes window) and
click OK.

Specify a default width value for the attribute column if desired.

This will populate each attribute in that column with the specified default value.

Click OK.

The new column is created and can be given values in the MAP Attributes window.

u n

when a space is attempted to be

WS T = I
E] Hbrea & Name ‘%:‘ {D—K‘I
¥ Countiy Type: | sting B ol

Capital =

Aiable_Pot bize o |

Population . ]

£ ) Default Value: o

Literacy Visible

Inflal_Rate

UnempLAate [ Aeadanly

Indust_Gruth

e [ Derive value from expression:

mif_brush_pattein 4

v

Edit Schema window before and after adding the ‘Head_of_State’ column.

4-iv: CHANGING AN EXISTING COLUMN’S PROPERTIES

Open the Edit Schema window and click on the column name whose properties you wish to edit.
Change the Name, Default value fields as desired. You may also change the column type once it has been
created ( for example should you wish to convert a type real column to a type integer column).

Leave the Visible option enabled and the Read-only and Derive value from expression: options disabled.
Click OK.

The column will now have a new name and width.

Attributes and Georeferencing



4-v: EDITING THE VALUES OF A MAP COLUMN

1. Import the world.mif file from the Tutorial Data folder.
2. Using the Edit Schema filter, add a new column, “Annual_Increase”, to the world attribute table.

Set the Type to Integer.
WA Aibutes ®
Layer: | Bworld (220 areas selected) B
sracy |inflat_Rate [unempl_Rate  [indust_Grwin | Continent mif_pen_pattern |mif_brush_pattern | Annual_increase \m

|1 }9.000000]  92.000000 0.000000 6.200000 Asia 2 2 0
2 12.000000 0000000, 0.000000  0.000000 Europe 2 2 0
'3 }0.000000]  20.000000]  26.000000  0.900000 Africa 2 2 0
4 0.000000 0000000, 0.000000  0.000000 Europe 2 2 0
ztz.ooomm 23.200000)  0.000000  0.000000 Africa 2 2 [)
6 )5.000000 4500000 5.000000  0.000000 North America 2 2 0
'7__0.000000) 0000000 0.000000  0.000000 Antarctica. 2 2 0
'8 19.000000] 3600000 5000000 3.000000 North America 2 2 0
|5 }5.000000 1345000000  8.600000  -6.000000 South America 2 2 0
'10_0.000000) 0000000 0.000000 0.000000 Europe 2 2 0
110.000000 5.800000  1.600000  0.000000 North America 2 2 o

220 areas seiscled i /2 A R U

Creating a new MAP Column to hold new values.

Select the ‘'world’ layer in the Adobe lllustrator layers palette.

Select the countries for which you wish to calculate an annual population increase.

Select Window > MAPublisher Palettes > Map Attributes to open the MAP Attribute dialog.

Click on the Edit Schema button ‘;;? and choose the “Annual_Increase” column from the attribute column list
Enable the Derive value from expression option.

Click on the Browse button to open the Edit Expression dialog and expand the Express Components.

Start building the expression by making selections from the Object list in combination with clicking on the
Operator Buttons available at the top of the dialog. Select the ‘Population’ column by double clicking on it.
(the column gets inserted into the edit expression entry box). Click the “*” button and then the “(“ button. Using
the Options list again, select the ‘Pop_Grw_Rt’column by double clicking on it in the list. Click “/* then enter
“100’ using your keyboard. Finally, click “)” to close the expression.

10. The expression in the Edit Expression box should now look like this: Population * (Pop_Grw_Rt/ 100)

11. When you receive the Expression is Valid message Click OK.

12. Click OK again in the Edit Schema dialog to complete the operation.

The selected features’ attributes will be updated. Use the MAP Attributes window to view the changes.

0N U AW

MAP Actributes

tayer  [Alworld (220 areas selected) v
wracy [Infla_Rate |unzmp\_l:\(! [indust_Grwth | Continent mif_pen_pattern | mif_brush_pattern | Annual_increase ‘
1 9.000000 92.000000 0.000000 6.200000 Asia 2| 2 855415
2 12.000000 0.000000 0.000000 0.000000 Europe 2 2] 60030,
'3 }0.000000 20.000000 26.000000 0.900000 Africa 2 2 650554
"4 0.000000 0.000000 0.000000 0.000000 Eurape 2 2 1276
5 2.000000 23.200000 0.000000 0.000000 Africa 2 2| 234043
's  15.000000 4.500000 5.000000 0.000000 North America 2| 2 41
7 0.000000 0.000000 0.000000 0.000000 Antarctica 2 2 0
8 9.000000 3.600000 5.000000 3.000000 North America 2| 2 255
'9 }5.000000 1345.000000 8.600000 -6.000000|South America 2 2 359303
10 |0.000000 0.000000 0.000000 0.000000 Europe 2| 2 0
z 0.000000 5.800000 1.600000| 0.000000 North America 2 2 384
v T R e = 2 a5
220 aras selacted 8L A R Y

Using existing values to edit the values of a new MAP Column.

Attributes and Georeferencing 19



4-vi: MAKING A SELECTION WITH MAP SELECTION FILTERS

b

Import the festreets.mif file from the Tutorial Data folder. This is a line file depicting the major roads of Falls
Church, Virginia.

Making sure the festreets layer is selected, go to Window > MAPublisher Palettes > Selection Filters to open
the MAP Selection Filters dialog.

Click on the Create New Selection Filter button at the bottom of the palette or select the same option from
the palette’s options menu.

Enter ‘Route number’ in the Name entry box.

Click on the Browse button then click the dropdown button to expand the Expression Components.
Double click on the Number column heading in the Objects under fcstreets so that it is entered into the
expression entry box. Click on the “=“button and enter “A25” from your keyboard.

If you want to view the unique values of that attribute column click display unique values. Double clicking on a
unique value will recognize the attribute as a string and enter quotations for you (along with the value).

Click OK.

Click on the Apply as New Selection button to perform the selection.

Result of Select by Attribute for lines with a number value equal to A25.

4-vii: USING ADD TO CURRENT SELECTION TO ADD TO AN EXISTING SELECTION

AW~

Continue working with the festreets.mif file imported previously and select some of the road data.
Make sure the festreets layer is selected, then go to Window > MAPublisher Palettes > Selection Filters.
Select the previously created filter ‘Route number’ from the list in the palette.

Now click on the Add to Current Selection button at the bottom of the palette.

The features that match the expression are added to the selection.

Use the Remove from Selection and Get Subset of Current Selection options to experiment with other
selection types.

4-viii: USING SELECTION FILTERS FOR ADVANCED SELECTIONS

The Map Selection Filters can also be used to generate selections based on a number of attribute columns and criteria.

1.
2.

20

Import the world.mif file from the Tutorial Data folder.
Making sure the world layer is selected, go to Window > MAPublisher Palettes > Selection Filters to open
the MAP Selection Filters dialog.

Attributes and Georeferencing
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Click on the Create New Selection Filter button at the bottom of the palette or select the same option from
the palettes flyout menu.

Enter ‘Population search’ in the Name entry box.

Click on the Browse button.

Now double click on the ‘Continent’ column heading in the Objects list so that it is entered into the
expression entry box.

You may view the unique records contained within that column by clicking on the “Display Unique Values”link in the
Description field portion of the dialog.

Continue with building the expression by clicking on the “=“button and entering “Africa” from your
keyboard or selecting it from the unique values list. Click the "AND’ button and then the “(“ button. Using
the Options list again, select the ‘Population’ column by double clicking on it in the list. Click “>“then
enter ‘1000000’ using your keyboard. Click AND’ and then using the Options list once again, select the
‘Population’ column by double clicking on it. Click“<“ then enter 10000000’ using your keyboard. Finally
click ) “to close the expression.

The final expression should look like this:

Continent = “Africa” AND ( Population > 1000000 AND Population < 10000000 )

Click OK.

Click OK again.

Now click on the Apply as New Selection button to enable the selection.

dropdowns active.

Result of Selection Filter showing African countries with 1-10 million inhabitants.
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MAP Views

5-i: THE CREATION OF MAP VIEWS VIA IMPORT

1. Import any file from the Tutorial Data folder.

2.  Go to Window > MAPublisher Palettes > MAP Views to open the MAP Views palette.

3. AMAP View has been automatically created. It carries the same name of the imported file and holds the
lllustrator layer(s) containing the map data. Each Illustrator layer comprising the MAP View is depicted with an
icon that represents the feature type of the layer.

5-ii: IMPORTING A MAP VIEW FROM EXISTING MAPUBLISHER DOCUMENTS

Open usa48.ai from the Tutorial Data folder.

Open a new blank document.

Select the new document and open the Map View palette via Window > MAPublisher Palettes > MAP Views.
Click the Options arrow in the top right corner of the palette and select Import Map View.

A list of map views will be available from any opened document containing Map Views.

In this case only one Map View ‘usa’is available from the selected Map Views to transfer.

5. Select the usa Map View and click OK.

The Map View is imported into the new document along with any Map Layers in that Map View.

Sl

5-iii: DUPLICATING AND DELETING MAP VIEWS

Import any file from the Tutorial Data folder.
View the MAP Views palette (Window > MAPublisher Palettes > MAP Views).
Select the new MAP View by clicking on its name.
Click the Options arrow in the top right corner of the palette and select Duplicate.
A new MAP View entitled ‘Copy of..." has been created, which at present does not contain any Illustrator layers.
Select the MAP View you created in Step 4.
6. Click the Options arrow in the top right corner of the palette and select Delete.
The MAP View entitled ‘Copy of... “is deleted.
7. Note that you cannot delete a MAP View that contains one or more lllustrator layers. First you would need to
drag these layers to another MAP View.

PO~

b

5-iv: REPROJECTING BY DRAGGING MAP LAYERS INTO ALTERNATE MAP VIEWS

1. Import the world.mif file from the Tutorial Data folder.

2. Import the worldwest.shp from the Tutorial Data folder.

3. You should now have two MAP Views created, one called ‘world’, which is in Latitude/Longitude and holds
the ‘world’ layer, and the other called ‘worldwest; which is in Robinson projection, holding the ‘worldwest’
layer.

22 MAP Views
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‘world’ layer in Latitude/Longitude and ‘worldwest’ layer in Robinson projection.

4. Inthe MAP Views palette click on the ‘worldwest’layer and drag it into the ‘world’ MAP View.
The ‘worldwest’ layer is instantly reprojected into Lat/Long projection and matches the page scaling of the
‘world’layer. Drag it back to the ‘worldwest” MAP View to restore it to Robinson.

rld
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‘world’and ‘worldwest’ layers both in Latitude/Longitude with matching page scaling.

5-v: DRAGGING NEW ILLUSTRATOR LAYERS INTO SIMILAR COORDINATE SYSTEMS

1. Repeat Tutorial 5-iv up to Point 4, where you have two layers in different projections in your document. Use the
Toggle Visibility button in the Illustrator Layers palette to hide the ‘world’layer, therefore having
only the ‘worldwest’ layer visible.

2. Create a new lllustrator layer called ‘Extras, and move it to the top of the layers hierarchy.

3. With the ‘Extras’ selected in the lllustrator layers palette, roughly trace over some features that exist on
the ‘worldwest’ layer using lllustrator’s drawing tools. As these new features will be polygons make
sure that the elements are closed, so that the start and end points of the lines are coincident. Give your new
polygons a red fill.

4. Inthe MAP Views palette click on the ‘Extras’ layer and drag it into the ‘worldwest’ MAP View.
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5.

6.

In the Undefined Layer dialog, select ‘Area’ from the Feature Type dropdown. Click OK.
The ‘Extras’layer is moved to the matching coordinate system of the ‘worldwest’ MAP View.
Repeat this exercise for other feature types if required.

5-vi: DRAGGING NEW ILLUSTRATOR LAYERS INTO DIFFERENT COORDINATE SYSTEMS

Repeat Tutorial 5-iv up to Point 5, where you have two different projections in your document, and the layers
‘worldwest’and ‘Extras’ visible and placed in the ‘worldwest’ MAP View

In the Illustrator layers palette, use the Toggle Visibility buttons to switch off the ‘worldwest’layer, and
switch on the ‘world’layer.

In the MAP Views palette click on the ‘Extras’ layer and drag it into the ‘world’ MAP View.

The ‘Extras’layer is moved to the coordinate system of the ‘world’ MAP View. It has immediately been reprojected
from Robinson to Lat/Long and aligns with the data in the ‘world’ layer.

5-vii: EDITING LAYER NAMES USING SEARCH & REPLACE

Import the capeverde.e00 file from the Tutorial Data folder.

Open the lllustrator Layers palette. Note that there are 5 new layers as this e00 contains multiple feature types.
Note that four of these layers contain the layer name ‘PONET’

View the MAP Views palette (Window > MAPublisher Palettes > MAP Views). A MAP View has been automatically
created, holding the 5 layers.

Click the Options arrow in the top right corner of the palette and select Layer Name Search & Replace...

In the Find what: field, enter PONET: In the Replace with: field, enter ‘Cape Verde’ Then click the Replace All
button.

The text PONET’ has been replaced with ‘Cape Verde’in all applicable lllustrator layers.

5-viii: MERGING MAP LAYERS

W

24

Using Simple Import, import the worldeast and worldwest shapefiles from the Tutorial Data folder.

Select all of the data in the document and open the MAP Attribute Window (Window > MAPublisher Palettes >
MAP Attributes). Toggle between the layers using the Layer dropdown. As both layers are identical in terms of
their attribute structures, it is possible to merge the layers together.

In the MAP Views palette shift-select the ‘worldeast’and ‘worldwest’layers so both are highlighted.

Click the Options arrow in the upper right corner of the dialog and select Merge Layers.

The two layers have been joined together to create a single layer holding all the attribute information. Change
the name of the layer in the lllustrator layers palette if desired, and view the combined attribute table in the
MAP Attributes Window.

Note: Locked layers can not be merged.

MAP Views



5-ix: SPECIFYING A PROJECTION FOR AN IMPORTED FILE

1.

w

Using Simple Import, import the ukrail.gen file from the Tutorial Data folder. Do not specify a projection
before you import the file.

Click on the ‘ukrail’ MAP View in the MAP Views palette.

Go to Options > Source Projection.

Choose ‘Europe’ from the Projection Category dropdown to display by geographical area then choose
European projections. Then choose ‘British National Grid (ORD SURV GB) (EPSG #27700)’in the projection list.
Click OK.

The source projection for the file is the British National Grid. Now that the MAP View has been assigned

its coordinate system, you can subsequently reproject it.

5-x: REPROJECTING USING THE MAP VIEW EDITOR

Open a new document with the size set to Letter, and the orientation set to Portrait.

Import the fsatoronto.mif file from the Tutorial Data folder. This file is in Generic Lat/Long projection.

In the MAP Views palette, click the fsatoronto’MAP View and go to Options > Edit “fsatoronto”...
Alternatively you can double click the ‘fsatoronto’ MAP View.

Change the name of the MAP View to ‘Postalcode Zones'

In the Projection Category dropdown select ‘UTM (NAD 83)".

In the Projection List select ‘NAD 83 UTM, Zone 17 North, Meter. Click the Details button if you wish to see
the parameters of this projection. Note that the Preview Pane displays how the new projection will be fitted
onto the page.

Click OK.

The MAP View has been reprojected to ‘Universal Transverse Mercator, Zone 17 North; in ‘North American Datum
1983 See the section on Projections and Datums in the User Guide for more information. The name of the MAP
View has been changed to ‘Postalcode Zones:

‘fsatoronto’ MAP View in Latitude/Longitude. ‘fsatoronto’ MAP View in UTM Projection.
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5-xi: EDITING SCALE AND POSITIONING

26

Repeat the previous tutorial, so that you have the Postalcode Zones MAP View in UTM.

In the MAP Views palette, click the ‘Postalcode Zones’ MAP View and go to Options > Edit “Postalcode
Zones"...

Alternatively you can double click the Postalcode Zones MAP View.

Edit the Scale to 1: 30,000 by entering “30000 ’in the Scale entry field.

There are 9 buttons in the Alignment Control graphic (LL Corner section). Click the Central button to reposition
the data to the centre of the page.

The Preview Pane shows the new data extents and the Page Anchor values have been automatically updated.
Click OK.

The Postalcode Zones MAP View has been rescaled and repositioned in the centre of the page.

In the MAP Views palette, double click the ‘Postalcode Zones’ MAP View.

Alternatively you can go to Options > Edit “Postalcode Zones”...

In the Angle field enter’-17" for an angle of rotation.

Alternatively use the clock hand in the graphic to achieve the rotation value of 343 degrees.

Click OK.

The data is now rotated and gives a better result for subsequent MAPublisher operations, such as labeling.
Georeferencing has not been affected.

fsatoronto’ MAP View in UTM Projection, rotated -17 degrees, and with a new scale of 1:30,000.
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5-xii: COPYING A PROJECTION FROM ONE LAYER TO ANOTHER

ounkwnN=

11.

12.

Open a new document with the size set to Letter, and the orientation set to Landscape.

Import the worldwest.shp file from the Tutorial Data folder. This file is in Robinson projection.

Select the Canada polygon and assign a fill colour to it.

In the MAP Views palette, double click the ‘worldwest’ MAP View to open the MAP View Editor.

Edit the Scale to 1:250 million by entering 250000000 ‘in the Scale entry field.

Click the Align Top Left button in the Alignment Control graphic (LL Corner section).

The Preview Pane shows the new data extents and the Page Anchor values have been automatically edited.
Click OK.

The ‘worldwest’ MAP View has been rescaled and repositioned in the upper left corner of the page, hence
providing a small locator map.

Import the canada.shp file from the Tutorial Data folder. This file is imported in Lat/Long.

In the MAP Views palette, double click the ‘canada’ MAP View to open the MAP View Editor.

Click the Same As checkbox, and click on the ‘worldwest’ MAP View in the dropdown.

In the Projection List notice how Robinson is automatically selected. Click the Details button if you wish to see
the parameters of this projection.

Click the Align Center button in the Alignment Control graphic.

The Preview Pane shows the new data extents and the Page Anchor values have been automatically edited.
Click OK.

The MAP View has been reprojected to match the projection of the ‘worldwest’ MAP View.

‘canada’ MAP View in Robinson Projection, derived from the projection held in the ‘worldwest’ MAP View.

MAP Views
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5-xiii: CREATING A NEW MAP VIEW

The following tutorial will provide a basic overview of assigning georeferencing information to existing lllustrator
documents. Please see the section on ‘Georeferencing an Adobe lllustrator File’ in the User Guide for more notes
on this subject.

1. Go to File > Open, and open the toronto.ai file from the Tutorial Data folder.

This is a regular Illustrator document digitized in Generic Lat/Long. It contains two lllustrator layers containing
area and line features, which do not contain any georeferencing or attribute information.

2. Inthe MAP Views palette notice there are two Illustrator layers that are in the [Non-map layers] section.

3. Inthe MAP Views palette click the Options arrow in the top right corner of the palette and select New MAP
View... to open the MAP View Editor.

4.  Specify a name for the MAP View. For this example call the MAP View ‘Toronto!

5. Click the Source Projection button. The projection for this file is ‘Generic Lat/Long’ Set the Projection
Category to ‘All Projections’ and scroll through the projection list and select
‘Generic Lat/Long’s, Degrees, -180 ==> +180" Then click OK.

7. The Scale for this file is 1:0.235123 (as the data is in Lat/Long, the scale value is in degrees) so enter‘0.235723
in the Scale field.

8. Click OKin the MAP View Editor to apply the information to the new MAP View.

9. Inthe MAP Views palette, navigate to the Options pullout, and then click on Specify Anchors. This dialog will
establish the tie-in point between Map Anchors (real world coordinates) and Page Anchors (coordinates
in page units).

10. Setthe Map Anchors to the value of a tie-in location. For this example use X=-79.5" and Y = 43.5".

11. Set the Page Anchors to the value of the same location in document units. For this example use X="0; Y =0’
Note: The Map/Page Anchor relationship can be established at any known tie-in point (preferably within the extents
of the dataset you are georeferencing).

12. Click OK to exit the dialog and complete the parameters of the new MAP View.

13. Inthe MAP Views palette click on the ‘Postalcode Zones’layer and drag it into the ‘Toronto’ MAP View.

In the Undefined Layer dialog, select ‘Area’ in the Feature Type dropdown and click OK.
The Postalcode Zones layer is moved to the specified coordinate system of the Toronto MAP View.

14. Drag the ‘Roads’ layer into the ‘Toronto’MAP View, specifying ‘Line’as the Feature Type in the Undefined Layer
dialog.

Both lllustrator layers are now map layers, being in the specified coordinate system of the Toronto MAP View.

15. (Optional). Click on the ‘Postalcode Zones’layer and select all the objects on this layer then open the MAP
Attributes Window (Window > MAPublisher Palettes > MAPublisher Attributes)

Click the New Column button on the bottom of the MAPublisher Attributes window. Change the new column
name to ‘Zone’, the Type to ‘String’ and the size to ‘3% Select the southernmost polygon on this layer and open
the MAP Attributes window. In the ‘Zone’, column enter ‘M5J’and click Apply.

You can proceed in this manner to create attribute structures and enter values for both lllustrator layers.

16. The file has now been fully georeferenced, and can therefore be exported to other GIS formats if required.
With the addition of an attribute structure, you can fully utilize all of MAPublisher’s functions.
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5-xiv: EXPORTING DATA TO GIS FORMATS

1. Using Simple Import, import both the fsatoronto.mif and torontostreets.mif files.

2. Inthe MAP Views palette, click on the fsatoronto’layer, and go to Options > Export ‘fsatoronto’...

3. Inthe Export dialog choose ESRI Shape from the format dropdown, and then click the Browse button. In the
Browse for Folder dialog select a location for your exported file and click OK. The Dataset field will be
populated with the path to this directory.

4. Click OK to export. View the contents of the destination folder. Four new files have been created:
fsatoronto.shp, fsatoronto.shx, fsatoronto.dbf, and fsatoronto.prj. Descriptions of these file extensions can
be found in Chapter 2 of the User Guide.

The ‘fsatoronto’layer has been exported to ESRI Shapefile with all attributes and georeferencing intact, and is
ready to be used in software supporting this format.

5. Inthe MAP Views palette, click on the ‘torontostreets’ layer, open the MAP Attributes palette and click the Edit
Schema button. In the column list keep only ‘Street,'mif_pen_pattern’and ‘#Length’visible.

(Select the other attributes from the column list and uncheck Visible.)

6. Go to Options > Export ‘torontostreets’... In the Export dialog choose Mapinfo TAB from the format
dropdown. Then click the Settings button. Check the option for Export visible attributes only. Click OK.

This will keep only the visible attributes (‘Street, ‘mif_pen_pattern’and ‘#Length’ columns in the exported data table).

7. Click the Browse button. In the Browse for Folder dialog select a location for your exported file and click OK.
The Dataset field will be populated with the path to this directory.

8. Click OK to export. View the contents of the destination folder. Four new files have been created:
torontostreets.tab, torontostreets.dat, torontostreets.id, and torontostreets.map.

Descriptions of these file extensions can be found in Chapter 2 of the User Guide.
The ‘torontostreets’layer has been exported to Mapinfo TAB format with all attributes and georeferencing intact,
and is ready to be used in software supporting this format.

Export “fsatoronto_area™

Export
Format: [ | [settings... i cancolil
Dataset: (C:\Shape Files | E]

Export dialog prior to exporting the ‘fsatoronto’ layer.
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Plotting Points

6-i: PLOTTING POINTS IN DECIMAL DEGREE AND DMS FORMATS

10.

11.

12.

30

Go to File > Open, and open the usa48.ai file from the Tutorial Data folder. This document contains the
conterminous United States. The polygons are on the ‘usa’layer, in a MAP View named ‘usa’ The

specified coordinate system is NAD27 Albers Equal Area.

Create a new lllustrator layer named ‘cities’

In the MAP Views palette drag the ‘cities’ layer into the ‘usa’ MAP View. In the Undefined Layer dialog specify
Point as the Feature Type.

Open the lllustrator Symbols palette (Window > Symbols).

Navigate to Window > Symbol Libraries > Other Library... and load the MAP_PointSymbols.ai file from the
Program Files\Avenza\Mapublisher 7\Utilities\ Symbols folder.

Choose a selection of city symbols in the MAP_PointSymbols palette, and drag them into the lllustrator
Symbols palette.

With the ‘cities’ layer selected in the lllustrator layers palette, open the MAPublisher Point Plotter by going to
Window > MAPublisher Palettes > MAP Point Plotter.

To plot a point for Los Angeles, enter 34.1151 in the Latitude entry field.

Then enter-118.4183 in the Longitude entry field.

Select a desired symbol from the Symbol Selection, leaving the Scale set at 100%. Then click Create.

A point will be plotted at the location of Los Angeles (34.1151 Degrees North, by 118.4183 Degrees West).

To plot a point for New York City, enter 40d41’14.0”N in the Latitude entry field.

Then enter 73d56°39.0”W in the Longitude entry field.

Select an alternative symbol from the Symbol Selection, and change the Scale to 150%. Then click Create.
A point will be plotted at the location of New York City (40 Degrees, 41 Minutes, 14 Seconds North, by 73

Degrees, 56 Minutes, 39 Seconds West).

Plot a final point for Chicago. Its coordinates are 41d50°21”N (Lat) by 87d41’18”W (Long) in DMS format, or
41.8392 (Lat) by -87.6883 (Long) in Decimal Degrees.

Results of using the MAPublisher Point Plotter to create points for Los Angeles, New York City and Chicago.
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Legends and Stylesheets

7-i: CREATING AN AREA STYLESHEET

O 0N

11.
12.

13.

14.

15.

16.

In a new document, import the world.mif file from the Tutorial Data folder.

Open the lllustrator Graphic Styles palette (Window > Graphic Styles in lllustrator CS2).

Navigate to Window > Open Graphics Style Library > Other Library... and load the MAP_AreaStyles.ai file from
the Utilities\ Graphic Styles folder in the Avenza folder.

Select all the graphic styles in the MAP_AreaStyles palette, and drag them into the lllustrator Graphic Styles
palette.

Go to Window > MAPublisher Palettes > MAP Stylesheets to open the MAP Stylesheets palette.

Note the new ‘world’layer has been automatically placed into a stylesheet of None.

Click the Options arrow in the top right corner of the palette and select New MAP Stylesheet...

In the New Stylesheet dialog type ‘Continents1’as the name, and set the feature type to Area. Click OK.

In the MAP Stylesheets palette, drag the ‘world’ layer into the ‘Continents1’ Stylesheet.

Click the ‘Continents1’ Stylesheet and go to Options > Edit “Continents1”...

Alternatively you can double click the ‘Continents1’ Stylesheet.

In the Edit MAP Stylesheet dialog, click the Add button.

Using the Style dropdown choose a colour for Africa from the styles you previously created.

Using the dropdown set the Expression column. Keep the radio button set to Simple. Using the dropdown
menu set the attribute column to ‘Continent’. Use the equal sign for this expression. The Value column will
populate with the contents of the ‘Continent’ column. Select the Value to ‘Africa’

Leave the Scale set at ‘'100%:

Repeat steps 10-14 for each of the subsequent continents. Note that you cannot use the same style more than
once, as one style equals one legend entry.

When you have assigned a style to all of the continents, click the Apply button. If you are happy with the
choices you have made click the OK button.

The styles specified have been applied to the map. The Styles you have used in the Graphic Styles palette, are now
linked to the attribute values you specified.

Save this file as it will be used again in Tutorial 7-iv.

¥
L
3

-
v 1’

Results of applying a MAP Stylesheet to the ‘Continents’ column of the ‘world’ layer.
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Edit "Continents1"

Name: Continentsl A @

Style Rules = )
E] Name | Style | Expressian Scale il |
= Rulel MAP Area 19 Continent = "Africa" 100 EGancel

Rule2 MAP Area 06 Continent = "Antarctica” 100

Rule3 [l MAP Area 07 Continent = "Asia" 100

Rule4 [ MAP Area 11 Continent = "Australia" 100

Rule5 [l MAP Area 23 Continent = "Europe" 100

Ruleb MAP Area 31 Continent = "North America" 100

Rule? MAP Area 25 Continent = "Oceania” 100

m‘ " MAP Area 10 T] " Continent = "South America’ | 4 "“\:/'_

[ 2 : ] “lr

( Add /\ (" Remove | Expression Mode: @ Simple () Advanced
it

Associated MAP Stylesheet of the ‘world’ layer.

7-ii: CREATING A LINE STYLESHEET

O © N O

11.
12.

13.
14.
15.
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In a new document, import the festreets.mif file from the Tutorial Data folder.

Open the lllustrator Graphic Styles palette (Window > Graphic Styles in Illustrator CS2).

Using lllustrator’s Line Segment Tool, create your first legend item by drawing a line on the page. Assign it with
a stroke weight of 2pt, a stroke colour of Red, and a fill of none. Drag this line into the Graphic Styles palette.
Double click the Style and give this new style a name.

Change the colour of the line on the page to Green and drag this version into the Graphic Styles palette, again
giving it a name. Repeat this to generate Yellow and Blue lines in the Styles palette. When you have all your
new styles, delete the line you used to generate your styles.

(You can change the order of our graphic styles within the Graphic Styles Palette similar to the Layers palette.

This will provide useful when managing many graphic styles)

View the MAP Stylesheets palette (Window > MAPublisher Palettes > MAP Stylesheets).

Note the new fcstreets’ layer has been automatically placed into a stylesheet of None.

Click the Options arrow in the top right corner of the palette and select New MAP Stylesheet...

In the New Stylesheet dialog type ‘Road’as the name, and set the feature type to Line. Click OK.

In the MAP Stylesheets palette, drag the festreets’ layer into the ‘Road’ Stylesheet.

Double click the ‘Road’ Stylesheet.

Alternatively you can click the Road Stylesheet, and then go to Options > Edit “Road”...

In the Edit MAP Stylesheet dialog, click the Add button.

Using the Style dropdown choose the Red line from the styles you previously created.

Using the dropdown menu for the Expression column set the column to ‘Number. Use the equal sign for an
operator. The contents for the ‘Number’ column will populate the Value dropdown.

Then set the Value to ‘A25'’

Change the Scale to '200%:

Repeat steps 10-14 for each of the subsequent road numbers, making A37 = Green, A41 = Blue, and A45 =
Yellow. For these three road types, leave each scale at ‘100%’ Note that you cannot use the same style more
than once, as one style equals one legend entry.

Legends and Stylesheets



16. When you have assigned a style to all of the lines, click the OK button.

The styles specified have been applied to the map. The Styles you have used in the Graphic Styles palette, are now
linked to the attribute values you specified. Note that A25 now has a stroke weight of 4pt, as this legend entry was
scaled to 200%.

17. Save this file as it will be used again in Tutorial 7-v.

Results of applying a MAP Stylesheet to the ‘Number’ column of the ‘fcstreets’ layer.

Edit "Road”
Name: Road ) B}
Style Rules
Apply
EI Name Style |Expressiun ISca\e
ulel Style 1 Number = "A25 200 )
2l (€ancel)
ule2 Style 2 Number = "A31 100
lRuIeE! Style 4 Number = "A41 100
Ruled style 2 [3] Number - 3] = 100
( Add ) ( Remove ) Expression Mode: @ Simple () Advanced
— s T

Associated MAP Stylesheet of the fcstreets’ layer.

7-iii: CREATING A POINT STYLESHEET

b

O N O

Repeat Tutorial 3-vi (Importing Points).

Open the lllustrator Symbols palette (Window > Symbols).

Navigate to Window > Symbol Libraries > Other Library... and load the MAP_PointSymbols.ai file from the
Utilities\ Symbols folder.

Select all the symbols in the MAP_PointSymbols palette, and drag them into the lllustrator Symbols palette.
View the MAP Stylesheets palette (Window > MAPublisher Palettes > MAP Stylesheets). Note the new
‘azdeci_point’layer has been automatically placed into a stylesheet of None.

Click the Options arrow in the top right corner of the palette and select New MAP Stylesheet...

In the New Stylesheet dialog type ‘Point Data’as the name, and set the feature type to Point. Click OK.

In the MAP Stylesheets palette, drag the ‘azdeci_point’ layer into the ‘Point Data’ Stylesheet.

Click the ‘Point Data’ Stylesheet and go to Options > Edit “Point Data”...

Alternatively you can double click the ‘Point Data’ Stylesheet.

Legends and Stylesheets
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10.
11.
12.

13.
14.
15.
16.

In the Edit MAP Stylesheet dialog, click the New button.
Using the Style dropdown choose ‘MAP Symbol 36’ from the symbols you have loaded.
Using the dropdown menu for the Expression column set the column to ‘Column 3

Use the equal sign for an operator. The contents for the ‘Column 3” column will populate the Value dropdown.

Then set the Value to ‘airport.
Change the Scale to ‘40%:

Repeat steps 10-14 for the values ‘church; ‘hospital’ and ‘park;, choosing appropriate symbols for each.

When you have assigned the symbology you require, click the OK button.

The symbols specified have been applied to the map. The Symbols you have used in the Illustrator Symbols palette

are now linked to the attribute values you specified.

.
@ '.':'" ...‘.s @. .
=) @@ C
3 C :ﬁ; *

" i

Partial view of applying a MAP Stylesheet to ‘Column 3’ of the ‘azdeci_point’layer.

Edit “MAP Stylesheet 1"
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Legends and Stylesheets

Associated MAP Stylesheet of the ‘azdeci_point’ layer.




7-iv: DUPLICATING STYLESHEETS

N —

Nowvasw

Repeat Tutorial 7-i (or open the file you saved at the end of Tutorial 7-i).

In the MAP Stylesheets palette, click the ‘Continents1’ Stylesheet and go to Options > Duplicate
“Continents1”...

Double click the ‘Copy of Continents1’ Stylesheet

In the Edit MAP Stylesheet dialog, change the name of the stylesheet to ‘Continents2’.

Using the Style dropdowns change the colours used to represent the continents.

When you have assigned a different style to all of the continents, click the OK button.

Now you have two stylesheets relating to one lllustrator layer. In the MAP Stylesheets palette, drag the ‘world_
area’ layer from the ‘Continents1’ Stylesheet and into the ‘Continents2’ Stylesheet.

The new styles specified have been applied to the map. Drag the ‘world’ layer back to ‘Continents1’to
restore the map to its previous colour scheme.

7-v: EDITING STYLES TO CHANGE ATTRIBUTES

Repeat Tutorial 7-ii (or open the file you saved at the end of Tutorial 7-ii).

Using a Selection Filter via Window > MAPublisher Palettes > MAP Selection Filter create a new selection filter.
Select the browse Selection Filter option. Expand the expression components window. Add the ‘Number’
column to the expression by double clicking it from the ‘festreets’ objects list. Click the equal to operator.

In the Description window click display unique values and double click A45 to highlight it and drag to the
Expression window. Notice the typein the column is a string. Therefore quotations must be inserted.

The expression should read Number=“A45" Click OK. This will select all lines on the fcstreets’layer

that have a Number equal to A45. The Yellow line at the lower right corner of the document is the only line that
corresponds with this selection. Note that the colour of this line corresponds with the legend applied in
Tutorial 7-ii.

Open the lllustrator Styles palette and with the line styles you created in Tutorial 7-ii, assign the Blue line style
to this line.

Open the MAP Attributes window, to display the line attributes of the currently selected objects. Note that
‘Wilson Blvd’ now has a Number equal to A41.

Simply changing a style currently used to represent another attribute in the Road stylesheet has changed the
attributes of the selected line from A45 to A41.

7-vi: CREATING A MAP STYLESHEET LEGEND

nhwnN =

Repeat Tutorial 7-i (or open the file you saved at the end of Tutorial 7-i).

In lllustrator’s Layer palette rename ‘Layer 1'to ‘Legend.

Open the MAP View window drag the layer‘Legend' into the ‘world’ MAP View and assign it a Legend layer.
Select the type tool and choose a font you prefer, set the size to 10 pt.

In the MAP Stylesheets palette, click the ‘Continents1’ Stylesheet and go to Options > Create MAP Stylesheet
Legend. In target layer window and choose the ‘Legend’ layer and click OK.

The legend is created and positioned in the SW corner using the typeface chosen at 10 pts.

Stylesheet legends can be created from any stylesheet (area, line, point or text). Stylesheet legends display a symbol
for the type of stylesheet used, the stylesheet rule’s name and the expression used to create the rule.

The MAP Stylesheet Legend can easily be edited, it is an lllustrator nested object.
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Text Creation

8-i: GENERATING LABELS FOR A LINE LAYER USING FEATURE TEXT LABEL

10.

11.

12.

13.

14.

15.

16.
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Import the torontostreetsjoined.mif file from the Tutorial Data folder.

Create a new layer in your lllustrator Layers palette and name this layer ‘Street Names. Then drag this new
layer into the ‘torontostreetsjoined’ MAP View, setting the feature type to Text.

Select a font and text size for the labels you want to create.

Click on the ‘torontostreetsjoined’ MAP Layer in your lllustrator Layers palette, and select the features

you wish to label. In this example simply select one or more of the streets that were just imported.

Go to Filter > MAP Legend > Feature Text Label to open the MAPublisher Feature Text dialog.

In the Text Dialog box you must first set the options for MAPublisher to determine the attributes that will be
converted to text labels. The Source Layer list will show the Area, Point and/or Text layers currently containing
selected data. For each layer, the Column dropdown(s) will be populated with the attribute structure of that
layer. You must choose a column that holds the attributes you wish to label the data with. For this example,
choose ‘Street’. This column contains the name of every street in the selected MAP Layer.

In the Text Layer dropdown(s), you must specify a Text layer that the labels will be output to. For this example
choose the ‘Street Names’ layer.

In label setting we can specify label preferences such as label position, alignment to lines of latitude, minimum
font sizes and horizontal scaling to best place labels within polygons and paths. MAPublisher will place

Line labels intelligently, depending on the curvature and length of the line string. Click the Line Labels button
on the left to assign MAPublisher Line Label Settings.

The Distance from Start option will allow you to specify where along the line you would like the label. Lets
choose Auto and let MAPublisher place the text at the midpoint for straight lines. For curved lines this will find
the smoothest portion of the curved line closed to the midpoint.

By enabling Flip upside-down labels MAPublisher will automatically orient labels correctly, so lets leave this
option enabled.

By checking the Line Smoothing option, MAPublisher will create a smoothed path for each text object in the
selected Text layer, and place the text along this path at the specified Offset value. The labels can then be
dragged and positioned at any position along a line. For this example leave it unchecked because the streets
are very linear.

The Label Position option allows you to select the vertical position of the labels relative to the line. Three
options are available for the vertical positioning of text labels: Baseline, Descender, and Center. Select
Descender to place the labels on top of the generated text path.

Labels can be modified if they exceed the length of the line in the current default font size. First check the
Adjust label if larger than line option to activate the label‘rules. The order for the rules can be changed by
clicking on the rule and then pressing the Up or Down button. Checking the Reduce font size option will allow
you to reduce the size of the font to a specified minimum size in points. We can select 3 for this exercise.
Checking Reduce horizontal scaling will allow text to be scaled down horizontally by the fraction specified.
Leave this at 0.500000.

Feature Text Label also provides an additional option (not applicable in MAP Tagger). If ANY of the labels have
been adjusted in size due to the activation of a line adjustment rule. ALL labels can be resized to the same size
by checking the Set all labels to the same minimum font size option.

Click OK and the labels appear for the selected map features.
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Feature Text Label
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@ Set all labels to the same minimum font size

Feature Text Label Dialog window settings for Line Feature.

8-ii: GENERATING LABELS FOR AN AREA LAYER USING THE MAP TAGGER TOOL

©

Import the fsatoronto.mif file from the Tutorial Data folder.

Create a new layer in your lllustrator Layers palette and name this layer Zone Names: Then drag this new layer
into the fsatoronto’ MAP View, setting the feature type to Text.

Select a font and text size for the labels you want to create.

Click on the MAP Tagger Tool % button in the Adobe Illustrator Tools palette to open the Tagger Tool dialog.
Similar to the feature text label in the previous example, in the Text Dialog box you must first set the options
for MAPublisher to determine the attributes that will be converted to labels. The Source Layer list will show
the Area, Point and/or Text layers currently containing selected data.

For each layer, the Column dropdown(s) will be populated with the attribute structure of that layer. Set the
Column dropdown list to whichever column you wish to draw the labels from. For this example, choose ‘FSA’".
This column contains the name of every Postalcode Zone in the selected MAP Layer.

Set the text layer to output the labels to. For this example choose the “Zone Names’ layer.

Click OK.

With the MAP Tagger icon, click on any feature you wish to label.
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Grids, Graticules & Indexes

9-i: CREATING AN INDEX GRID

11.

12.

13.

38

Import the world.mif file from the Tutorial Data folder.

In your lllustrator layers palette, create a new layer called ‘Grid. Drag this new layer into the ‘world’ MAP View,
specifying a Feature Type of Legend.

Define the visual parameters for the grid by drawing a rectangle with the colour fill to‘None'and choosing a
stroke colour of Blue , drag it to your Graphics Palette and rename it ‘My Grid’. Open the Adobe lllustrator
Character Styles Palette and create a new character style setting the font family, font style, size and character
colour and name it ‘My Grid Font.

Ifyou are unfamiliar with this process please refer to your Adobe lllustrator Users Guide.

Using the MAP Location Tool click an area just above Greenland to set the vertical extent of the grid.

Make sure that the layer you want to place the grid on is selected and unlocked and select Filter > MAP Legend
> Grid & Graticules to open the MAPublisher Grid and Graticules dialog.

Select Index Grid if not already selected. Leave the Number of Columns/Rows as the default of ‘10!

Select ‘My Grid’ from the Style dropdown menu to set the style of grid.

In the Labeling Options the character style ‘My Grid Font’ can be selected for Center, Axes and End of Line
Styles. Notice when the mouse hovers over each menu style the Labeling Box highlights the corresponding item.
Leave Place labels of grid cell and Place label off line by the default of 6pt.

Click on the Append units to Label checkbox. This will generate Index Labels along the axis you set for your map
and ensure they are offset from the grid.

For this exercise we will label just the axes, so in the Labeling Box select all the outer axes locations. Make this
selection by clicking on the numbers in the lower left display. When selected they will turn bold.

Click OK to process the Index Grid based on the entered configuration.

A grid is placed on the map based on your specifications. Each cell carries an alphanumeric identifier. Grids can be
edited by using the bounding box of the grid or select the grid and choose Edit Index Grid from the Object Menu.
Save this file, as it will be used in step 9-iii: Creating an Index: Featured Based.

Grids and Graticules
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Index Grid dialog after configurations have been made.
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A map of the world with an Index Grid.

9-ii: CREATING A GRATICULE

10.

11.

12.

Create a new document in Portrait orientation. Import the world.mif file from the Tutorial Data folder.

In your lllustrator layers palette, create a new layer called ‘Graticule’ Drag this new layer into the ‘world’ MAP
View, specifying a Feature Type of Legend.

Draw a rectangle with no fill and a blue stroke of 1, drag this to the Graphic Palette and name it ‘My Grid..
Make sure that the layer you want to place the grid on is selected and unlocked and select Filter > MAP Legend
> Grid and Graticules to open the MAPublisher Grid and Graticules dialog.

Click the Graticules button. Graticules can be plotted at specific lines of latitude and longitude.

Enter ‘0’ for the Latitude to pass through and’ 0’for the Longitude to pass through.

This will create a graticule that passes threw the Prime Merdian and the Equator.

Enter 20’ for the interval of Latitude and’ 20’ for the interval of Longitude.

This will create 20 degree interval for the graticules.

Set the style to “My Grid” created earlier.

Using the Vertices slider will control the number of nodes to construct the graticule, for now leave the default
setting. Higher numbers should be used if graticules are curved.

The Don’t Label option is used in situations where the projection is creating a curved graticule that may have
a section in one of the corners that do not need to be labelled. An example of this would be there is no data in
this graticule, or there is only a small portion of the graticule showing and it does not need to be labelled. For
this exercise we will not need this option.

Set the labeling to label the Center which are the “70’s in the Label box.

They will turn bold when they will be labelled.

Click OK to process the graticule based on the entered parameters.

A graticule is placed on the map based on your specifications.

Grids and Indexes 39



40

Grids and Graticules
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-160 -140 -120 -100 -B0 -60 -40 -20 a 20 40 60 80 100 120 140 160

A map of the world with a graticule in 20 degree intervals
with a graticule passing threw the Prime Merdian and the Equator.
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9-iii: CREATING AN INDEX: FEATURE BASED

N —

N AW

10.

11.

12.

13.

14.

Open the file you saved at the end of Grid and Graticules Tutorial 9-i.

In your lllustrator layers palette, create a new layer called ‘Text: Drag this new layer into the ‘world’ MAP View,
specifying a Feature Type of Text.

Apply labels to several or all of the countries using Feature Text Label or the MAP Tagger Tool.

Select the Grid layer and then select the Grid.

Select Filter > MAP Legend > Make Index to open the Make Index dialog.

Select the radio button for Make index based on label and matching feature position.

Set the Text Layer dropdown list to ‘Text: Set the Grid Layer dropdown list to ‘Grid’

Click the Features radio button and set the Layer dropdown list to the vector layer that you labeled via Feature
Text Label or the MAP Tagger Tool. For this example the layer you labeled is ‘world’

In the Attribute to Match dropdown, select the attribute column you used to generate your text labels. This is
the attribute column containing the map text.

Indexing by Feature will generate an index entry for every legend cell that the labeled map object occurs in.

If desired, you can check the Remove Duplicate Entries box.

‘Remove Duplicate Entries’ will check instances where the two labels appear in the same grid cell, and
subsequently index only unique text items.

Set the Entry Delimiter to Tabs, and then Sort Output File by Feature Label.

The grid cell locator and feature name in the index file will be separated by a single TAB. The index will be

sorted alphabetically by feature label.

After all of the options have been set, click on the Save As button.

Name your index and click the Save button.

Both dialog boxes close and a text file is created based on the specifications entered in the Make Index dialog.

The index you have just created may be inserted into your map document by creating an Adobe lllustrator text
box and using the Place command (File > Place).

Left: A map of the world with a grid containing index
labels and several counties labeled.

Below: Feature based index file viewed in TextEdit,
sorted by feature label, delimited by TABs and with
Duplicate entries removed. Entries and grid cells are
sorted alphabetically.

8ee6 =] Index.txt
Australia -5, 3-3, 34, 2B

Brozil C-B E-R

Canada B-8

China  H-7
Russio A-9
United States

14, I

, D6,

a,cs,cg c-1@, D-8, D-9, D-18

, 1-7, 1-8, 1-9

9, B-18, C-18, D-1A, E-18, F-9, F-1@, G-8, G-9, G-18, H-9, H-18, 1-8, 1-9, [-1@, J-8, J-9, J-1@
4B, &9, A-1A, B-7, B-8, B-9, B-1@, (-7, [-8, C-9, D-8

[
B-
H-i
A
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9-iv: CREATING AN INDEX: TEXT BASED

1. Repeat steps 1-5 from Tutorial 9-iii.
2. Click the Make index based on label position radio button.
Indexing by label position will generate an index depicting only grid cells that contain a text label.
3. If desired, you can check the Remove Duplicate Entries box.
4. Set the Entry Delimiter to Commas, and then Sort Output File by Grid Cell.
The grid cell locator and feature name in the index file will be separated by a single comma. The index will be
sorted alpha-numerically by grid cell label.
5. After all of the options have been set, click on the Save As button.
6. Name your index and click the Save button.
Both dialog boxes close and a text file is created based on the specifications entered in the Make Index dialog.
7. Theindex you have just created may be inserted into your map document by creating an Adobe lllustrator text
box and using the Place command (File > Place).

O O O = Index.txt
C-5,United States
C-9,Canada

5,Brazil

§,Ching
9,Ruzsia

4, hustralio

D-
H-i
H-
I-

Vi
Text based index file viewed in TextEdit,
sorted by grid cell label, and delimited by commas.
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Selection Statistics

10-i: MAKING SELECTIONS WITH SELSTATS

Import any map file from the Tutorial Data folder.

Make sure the MAP Layer is selected in the lllustrator Layers palette, and select a portion of the map's features.

Go to Window > MAPublisher Statistics > SelStats to open the SelStats window.

The total number of features and the number of features that are selected are displayed.

Note: This tool will only function on MAP Layers.

Click the R button.

The selections made in step 2 are reversed.

Click the Save button, deselect all features, then click Recall.

All features that were selected in step 4 will be reselected.

Deselect all features and make another random selection. Click M OR.

The selected set of features will now consist of both the saved features and the features you just selected.
Deselect all features and make another random selection. Click M AND.

The selected set of features will now consist of the features that are common to the saved selection set and the
selection you just made.

Deselect all features and make another random selection. Click M XOR.

The selected set of features will now consist of the features that are not common to the saved selection set and
the selection you just made.

Selection Statistics
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Line Functions

11-i: BUFFERING LINES USING AN ENTERED VALUE

Import the burlroads.mif file from the Tutorial Data folder. This file has no projection.

Assign the Source Projection to NAD83 UTM, Zone 17 North, Meter (EPSG #26917).

In the Illustrator Layers palette, create a new layer called ‘Buffer Areas’

In the MAP Views palette, drag this layer into the ‘burlroads’ MAP View, specifying Area as the feature type.
Select a few lines to be buffered.

Go to Filter > MAP Lines > Buffer Lines to open the Buffer Lines dialog.

Click the By Entered Value radio button.

Enter 25’in the adjacent text box to represent a buffering value of 12.5 metres on either side of the selected
road(s).

9. Inthe Target Layer dropdown, select the ‘Buffer Areas’layer.

10. Click OK.

The lines that were selected for buffering have been overlayed with new area objects, representing a buffer
created around the original lines of the specified width.

NN AWN =

Burlroads file with buffer objects applied.

11-ii: FLIPPING LINES

There are two methods in MAPublisher to ensure that text labels are oriented correctly when they are attached
to paths. The first is to check the ‘Keep Text Above Lines’ option in Feature Text Label or the MAP Tagger Tool.
Alternatively you can permanently correct any digitalizing irregularities by using the Flip Selected Lines function.

1. Import the torontostreetsjoined.mif file from the Tutorial Data folder.
2. Create a Selection Filter, to select the lines that have a value in the Street column equal to:
‘COLLEGE ST or DUNDAS ST W' the expression will read STREET="COLLEGE ST” OR “DUNDAS ST W “
‘College Street’and ‘Dundas Street West’ will be selected.
3.  Goto Filter > MAP Lines > Flip Lines to run the Flip Lines function.
The selected lines will have their beginning and end points switched. Any labels placed along these lines will now be
oriented correctly.
4. Use Feature Text Label or the MAP Tagger Tool to label these lines.
The selected lines are now labeled and the text is oriented above the lines irrespective settings made within
these dialogs. The orientation of the lines is also permanently corrected.
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11-iii: JOINING LINES BASED ON ATTRIBUTE VALUE

1

2
3.
4

u

Import the torontostreets.mif file from the Tutorial Data folder.

Go to Filter > MAP Lines > Join Lines... to open the MAPublisher Join Lines dialog.

Set the Column dropdown list to ‘Street’in order to join the lines by their street name value.

Enter a name in the Output Layer text box. This will be the name of the new layer containing the joined lines.
For this example type in Joined Streets’

Enter ‘0.0001'in the Proximity text box.

Ensure the Close Segment Gaps & Generate non-compound paths if lines have common endpoint are
unchecked.

Click OK.

A new layer is created wherein all the specified lines are joined based on the specifications set in the dialog.

11-iv: SIMPLIFYING LINES

wN =

ow

Create a new document with the document size set to’Letter’and the orientation set to Portrait.

Repeat Tutorial 5-ix (Specifying a Projection for an Imported File).

Select all of the lines in the ‘ukrail’layer and go to Filter > MAP Lines > Simplify Lines to open the

Simplify Lines dialog.

Check the Map Units radio button in the Proximity section of the dialog, set the Units to ‘mile’ and specify a
Proximity value of ‘10!

Check the Use Bezier Curves option if you want the simplification process to incorporate Bezier curves.
Click OK to start the simplification process.

The selected lines are now simplified based on a proximity value of 10 miles.

! 1

Partial view of the ‘ukrail’ layer before and after implementing Simplify Lines.
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11-v: JOINING POINTS

®

10.

11.
12.
13.
14.
15.
16.

17.
18.

46

Via Simple Import, import the torontostreetsjoined.mif and torontopoints.mif files. After import, ensure the
‘torontopoints’ layer is at the top of the layers hierarchy in the lllustrator Layers palette.

Select all the imported points and open the MAP Attributes window. Note that the ID’ column contains four
unique attributes, identifying points that compose two subway lines, the mainline rail track, and a park
boundary. The ‘LineNumber’ and ‘AreaNumber’ columns contain rising numeric values indicating the number of
each point in its sequence. Note that some points contain matching values.

Deselect all the points. Then access the Join Points dialog by navigating to Filter > MAP Lines > Join Points.

As there is only one point layer in the document, and there are no points selected, leave the Input Layer
section at its default settings.

In the Output Layer section, specify a name for the layer that will contain the joined points. Do not check the
Close Paths option.

In the Group By section, select the ID’attribute column, as this contains the unique attributes that we want to
use to join similar points together.

In the Sort By section, click on the ‘AreaNumber’attribute column, then click the Add button.

In the Sort By section, click on the ‘LineNumber’attribute column, then click the Add button.

Select the ‘LineNumber’ column in the Sort Order section, then click the Up button. This will specify

that we want to the LineNumber’ column to be used as the primary column when determining the ordering
of points in the chain. The ‘AreaNumber’ column will be used as the secondary sorting column, if any points in
the primary column contain matching values.

Click the OK button.

All the points are joined based on the entered parameters. A new Line layer has been created which contains the 4
new line strings. The lines represent two subway lines, the mainline rail track, and the perimeter of a small park.
Select the four lines on the new Line layer and open the MAP Attributes windows. Note that a column named
‘ID'has been created, which contains the values in the ‘Group By’ column.

Note that the small segment with the attribute ‘P43’is the outline of a park area. However, this segment
should be closed. Therefore delete this line string.

Click on the ‘torontopoints’ layer in the lllustrator Layers palette. Then, using Select By Attribute, select all the
points with an ID’ which is ‘Equal to’ P43".

With these points selected, reopen the Join Points dialog.

Specify Selected Points in the Input Layer section.

In the Output Layer section, specify a name for the layer that will contain the joined points. This time, check
the Close Paths option.

Repeat Steps 7-9.

Click the OK button.

The selected points are joined based on the entered parameters. A new Area layer has been created which contains
the polygon. The area represents the perimeter of a small park.

Line Functions



Imported point data, and example of results after using Join Points to create line strings.
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Scale Bars and North Arrows

12-i: CREATING A SCALE BAR

SSYReNOURAWNS
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12.

13.
14.
15.
16.
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18.

48

Go to File > Open, and open the usa48.ai file from the Tutorial Data folder.

Create a new lllustrator layer and rename it “Scale Bar’.

In the MAP Views palette, drag the ‘Scale Bar’ layer to the ‘usa’ MAP View, setting the Feature Type to Legend.
Set your desired font and font size using the lllustrator Character palette. For this example use an 8 pt font.
Open the MAPublisher Scale Bar filter by going to Filter > MAP Legend > Scale Bar.

Choose a desired scale bar style using the Previous and Next buttons.

Set the Advanced Options as follows:

Set the Units dropdown list to ‘Kilometer’.

Enter a Label Interval of 250" kilometers.

Set the Number of Labeled Intervals to ‘4’.

Depending on the Scale Bar you have chosen, you can also select the Number of horizontal lines to use in the
plotted Scale Bar. These settings will create a scale bar that equates cms on the page to kms on the map and that is
0.2 cm high.

Set the Number of Intervals to Subdivide to'1’,and the Number of Sub-intervals to ‘5’.

These settings will create a scale bar that represents a total distance of 1000 km, has 4 main cells each representing
250 km and where the first cell is further divided into 5 smaller cells.

Set the Label Options as follows:

Select the Display Scale value as above

Select the Display page to map units ratio checkbox.

Set the Page Units dropdown list to ‘Centimeter’.

Select the Display units to right of last interval label checkbox. These settings will create a scale bar with
caption labels placed accordingly.

Click OK to create the scale bar. The Scale Bar will be placed on the page according to the defined settings.

Scale 1:20000000

O —
0 250 500 750 1000 kilometers
1 centimeter = 200 kilometers

Usa48.ai file with a MAPublisher generated Scale Bar.
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12-ii: CREATING A NORTH ARROW

1. Import any map file from the Tutorial Data folder.

2. Create a new lllustrator layer and rename it ‘North Arrow’.

3. Inthe MAP Views palette, drag the ‘North Arrow’ layer into the specified MAP View, setting the Feature Type to
Legend.

4. Make sure your‘North Arrow’ layer is the active layer and using the type tool create the letter ‘N’. With the
type selected go to Filter > MAP Legend > Create North Arrow. The type is now a North Arrow. North Arrows can
be created from any art object in lllustrator including symbols and characters. Note that the North Arrow created is
added to the Symbols Palette.*

5. Open the MAP View of the imported file and adjust the Angle to 45.

6. Click the OK button.

The North Arrow will be orientated according to the MAP View it is place in. Therefore any changes made to the
Projection or Angle of the MAP View containing the North Arrow will correspond correctly.

*Sample North Arrow designs have been included on your MAPublisher CD or with your download. Go to

Window > Goodies > lllustrator Utilities > Symbols folder to find the ‘MAP_NorthArrows.ai’ file. For downloaded
copies the Symbols folder is located at Program Files > Avenza > MAPublisher 7 > Utilities > Symbols. Drag the
required symbol onto your Legend layer and then execute the Create North Arrow filter. On creation the North Arrow
will be added to the lllustrator Symbols palette and the coordinate system of the host MAP View will be used to align
the North Arrow correctly.
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Working with Images

13-i: REGISTERING AN IMAGE WITH A REFERENCE FILE

50

Import the southchinasea.shp file from the Tutorial Data folder. After the file imports, give the polygons a fill
of ‘None!

Create a new lllustrator layer called Image’in the lllustrator Layers palette.

In the MAP Views palette drag this layer into the ‘southchinasea’ MAP View. As this new MAP Layer will be
holding the image only, you can assign any feature type when you drag.

Make sure the new Image’layer is highlighted in the lllustrator Layers palette and select File > Place.
Select the sample raster image file, borneo.tif, from the Tutorial Data folder.

Click Place to bring the file into your Adobe Illustrator workspace.

The raster image is brought in at a default position and scale in the centre of the screen.

With the image selected, go to Filter > MAP Images > Register Image to open the Register Image dialog.
Click on the Load File button and select borneo.tfw from the Tutorial Data folder.

The fields are all updated to reflect the data contained in the reference info file.

Click OK.

The image is registered to the selected layer.

Register Image

q‘ Upper Left Placement:
% [108.3375605 | Cancel

Image Size: 854 by 957 pixels Load File...

1Pinel= (0012773 3| °

Effective Map Size:

[ s [ogos142 *
B

| v [1zz2370 [

Register Image dialog with the parameters of borneo.tfw.
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Left: Location of borneo.tif after the image has been placed.
Right: Location of borneo.tif after the image has been registered with MAPublisher.

13-ii: REGISTERING AN IMAGE WITHOUT A REFERENCE FILE

10.
11.

Import the southchinasea.shp file from the Tutorial Data folder.

Create a new lllustrator layer called Image’in the lllustrator Layers palette.

In the MAP Views palette drag this layer into the ‘southchinasea’ MAP View. As this new MAP Layer will be
holding the image only, you can assign any feature type when you drag.

Make sure the new Image’layer is highlighted in the lllustrator Layers palette and select File > Place.
Select the sample raster image file, borneo.tif, from the Tutorial Data folder.

Click Place to bring the file into your Adobe Illustrator workspace.

The raster image is brought in at a default position and scale in the centre of the screen.

With the image selected, go to Filter > MAP Images > Register Image to open the Register Image dialog.
One of the four corners of the image will be what MAPublisher will use as your image’s anchor point
(Upper Left Placement, Lower Left Placement, Upper Right Placement or Lower Right Placement).
Click the Upper Left Placement and enter the values into the placement X and Y textboxes.
X=108.337561, Y=7.781662

Enter ‘0.012773for the Pixel Size.

Click OK.

The image is registered to the selected layer.
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13-iii: EXPORTING A PLACED IMAGE AS A GEOREFERENCED RASTER FILE

10.
11.

12.

52

Import the italy.mif file from the Tutorial Data folder.

Apply a fill of None to the data and change the stroke colour to red with a line weight of 0.25 pt.

Create a new lllustrator layer called Image’in the lllustrator Layers palette, and move the Image layer below
the ‘italy’ layer in the layers hierarchy.

In the MAP Views palette drag the Image’layer into the ‘italy’ MAP View. As this new MAP Layer will be
holding the image only, you can assign any feature type when you drag.

Make sure the new Image’layer is highlighted in the lllustrator Layers palette and select File > Place.

Select the sample raster image file, sicily.tif, from the Tutorial Data folder.

Click Place to bring the file into your Adobe lllustrator workspace.

The image of the Italian island of Sicily is brought in at a default position and scale in the centre of the screen.
Manually drag the image until it fits inside the guide box around the vector outline of Sicily. Use lllustrator’s
Scaling tools to resize the image if desired.

Set the colour mode in which you wish to export the image. If a change is necessary it can be done using the
File > Document Color Mode menu option.

With the image selected, go to Filter > MAP Images > Export Image to open the Export Image dialog.

Select the desired georeferencing output format from the Store Geography As: as dropdown menu. For this
example use ‘GeoTiff.

Note: It is advisable to leave the Export Image settings at the default values when exporting.

Click Save as to name the exported image, choose the export directory, and complete the operation.

The image of Sicily has been exported as a GeoTiff file using the coordinate system of the Image layer.

Export Image

Store Geography A

Export Image dialog with parameters set for the export of sicily.tif.
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Working with Tables

14-i: IMPORTING A TABLE

NoubkwhN=

Import the fsatoronto.mif file from the Tutorial Data folder.

Open the MAP Attributes window and select the option menu.

Select Import Table.

Click the Browse button in the Source Filename and select the avginc.csv file from the Tutorial Data folder.
Click the checkbox to enable First line contains column names.

Leave the default Character encoding as System.

Since there is only one MAP Layer in the MAP View the Destination Target Layer will default to

‘fsatoronto’. The Matching Column dropdown menu will contain matching columns in the Target Layer
chooseFSA’".

Click OK.

The imported table will be joined with the attribute table. To view the changes, open the MAP Attributes window and
select some or all of the map’s features. Note that the additional match column has been appended with a “1” after
the name. (This differentiates the column from the original FSA column in the map attribute table).
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Drawing with MAPublisher

15-i: CREATING SHAPES WITH SPECIFIC MAP DIMENSIONS

10.
11.

12.

13.

14.

15.
16.
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Create a new document. Import the torontostreets.mif file from the Tutorial Data folder.

Reproject the ‘torontostreets’ MAP View to ‘NAD 83 UTM, Zone 17 North, Meter’ (see Tutorial 5-ix).

In your lllustrator layers palette, create a new layer called ‘Buildings’ Drag this new layer into the
‘torontostreets’ MAP View, specifying a Feature Type of Area.

With the torontostreets layer selected in your Layers palette, create and apply a new Selection Filter

(Tutorial 4-vi) to select ‘COLLEGE ST'& 'BAY ST: The exact expression you should use for this is as follows:
STREET =“COLLEGE ST”OR STREET =“BAY ST”

Zoom in to the intersection of these streets. A recommended zoom level is 600%.

In this exercise we will construct an imaginary building at precise map dimensions. Therefore select the
‘Buildings’ layer in the Layers palette, then click the MAP Area (Box) button in the lllustrator Toolbar.
Using the crosshair for this tool, single click on one of the corners of the intersection of the two selected
streets. This will open the Add Area dialog.

As the MAP View is now in UTM, the units displayed in this dialog are in Metres.

Key '50’into the Width field. Enter ‘30’into the Height field. Check the Center area on click option.

These parameters will create a rectangle 50 x 30 metres. The centre of the polygon will be at the point you clicked to
open the ‘Add Area’dialog.

Click OK to exit the dialog and plot the imaginary building.

Use lllustrator’s tools to move the building and rotate it as desired. Then give the polygon a fill colour.

Zoom out to 150%. Presume that this building is an established grocery store. In a recent survey it was found
that on average, the majority of its customers lived within 500 metres of the store.

Select the MAP Area (Ellipse) | & button from the main lllustrator Toolbar. Click on the centre of the building.
Enter ‘1000’ x ‘1000’ for the Width and Height and use the Center area on click option again. Click OK.

A circle is placed which mimics the maximum distance away from the store that the majority of customers live.
Notice that the streets which fall inside this circle, whether entirely or in part, are selected.

The company is planning to construct another grocery store in the same area, and wishes to determine if this
new store (Store B) will take any business away from its original store (Store A).

Use a Select Filter (Tutorial 4-vi) to select ‘BEVERLEY ST’ and ‘QUEEN ST W:

Repeat steps 6-12 for this second building.

Using the MAP Area tools to create polygons and ‘spheres of influence’
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