GE@RAPHIC IMAGER
for Adobe Photoshop

Tutorial Guide
Geographic Imager 4.3 Tutorial Guide

Copyright © 2005–2013 Avenza® Systems Inc. All rights reserved.


Geographic Imager is a registered trademark of Avenza Systems Inc. Adobe, Adobe Photoshop and Adobe Illustrator are trademarks of Adobe Systems Inc. or its subsidiaries and may be registered in certain jurisdictions. Blue Marble Geographics, GeoTransform and The Geographic Transformer are trademarks of Blue Marble Geographics. All other software product names and brands including trademarks or registered trademarks are the property of their respective owners.

This tutorial guide and the software described in it are furnished under license and may be used or copied only in accordance with the terms of such license. The content of this manual is furnished for informational use only, is subject to change without notice and should not be construed as a commitment by Avenza Systems Inc. or its related companies or successors. Avenza Systems Inc. assumes no responsibility or liability for any errors, omissions or inaccuracies that may appear in this book.

Except as permitted by such license, no part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, recording, or otherwise without prior written approval of Avenza Systems Inc.

Avenza Systems Inc.
124 Merton Street, Suite 400
Toronto, Ontario, M4S 2Z2
Canada
Tel: (+1) 416 487 5116  Toll Free (North America): 1 800 884 2555
Fax: (+1) 416 487 7213
Email: info@avenza.com
Web: www.avenza.com
Support Tel: (+1) 416 487 6442
Support email: support@avenza.com

 Portions of this computer program are copyright ©2007 Leica Geosystems Geospatial Imaging, LLC. All rights reserved. Creating compressed files using ECW technology is protected by one or more of U.S. Patent No. 6,201,897, No. 6,442,298 and No. 6,633,688.

 Portions of this computer program are copyright © 1995-2008 Celartem, Inc., doing business as LizardTech. All rights reserved. MrSID is protected by U.S. Patent No. 5,710,835. Foreign Patents Pending.

Geographic Imager 4.3 Tutorial Guide for Adobe Photoshop, July 2013
© 2013 Avenza Systems Inc.
Printed in Canada
In this tutorial you will learn the basics of Geographic Imager by working with a series of tutorial exercises. All of the sub-folders of files, images, data and scripts for the tutorial exercises can be found in the following locations:

**Windows XP**
C:\Documents and Settings\All Users\Documents\Avenza\Geographic Imager\User Guide, Tutorial & Data

**Windows Vista/7/8**
C:\Users\Public\Public Documents\Avenza\Geographic Imager\User Guide, Tutorial & Data

**Mac OS X**
/Applications/Avenza/Geographic Imager/User Guide, Tutorial & Data
Open Images
Opening a spatial image is similar to opening up any other image.

1. In Adobe Photoshop, choose File > Open. Browse to the Tutorial Data folder containing the tutorial images and open EuropeLL.tif and EuropeTR.tif.

2. Make the EuropeTR.tif file the active document and view the Geographic Imager panel. If the panel is not visible, choose Window > Extensions > Geographic Imager.

3. Keep these images open for the next exercise.

Specify a Reference File
A reference file contains coordinates that describe the location, image size, pixel size, and rotation of an image file. It does not contain actual image data.

1. With the EuropeTR.tif file as the active document, click the Reference File Specify... link in the Geographic Imager panel. This specifies a reference file containing geographic coordinate information for the active document.

2. Select EuropeTRref.tfw and click the Open button. The reference file will be listed in the Geographic Imager panel.

3. Keep these images open for the next exercise.
Specify a Coordinate System

Some reference files do not store coordinate system information. Using a world file as a reference file requires that a source coordinate system be specified. For more information on reference files, see Chapter 2 in the Geographic Imager User Guide.

The EuropeTR.tif was originally made in the WGS 84 coordinate system, however it currently has no coordinate system assigned. Specify a coordinate system using these steps.

1. With the EuropeTR.tif file still the active document, click the Coordinate System Specify... link in the Geographic Imager panel. This specifies a coordinate system for the active document.

2. In the Specify Coordinate System dialog box, click the [No Coordinate System Specified] link.

3. In the Select Coordinate System dialog box, expand the Coordinate Systems > Geodetic > World category, select the WGS 84 in the coordinate system list and click OK.

4. Click OK in the Specify Coordinate System dialog box.

This assigns the WGS 84 coordinate system to the active document and is reflected in Geographic Imager panel.

5. Keep these documents open for the next exercise.
Transform a Coordinate System

Transforming a coordinate system transforms a georeferenced source image into a destination georeferenced image with a different coordinate system. In this exercise, the image will be transformed from WGS 84 coordinate system to British National Grid coordinate system.

1. With EuropeTR.tif still the active document, click the Transform button in the Geographic Imager panel.

2. In the Transform dialog box, click the WGS 84 link to select a destination coordinate system. This is different than specifying a source coordinate system. A destination coordinate system is the coordinate system of the image after it is transformed.

3. Expand the Coordinate Systems > Projected > Europe > United Kingdom category, select British National Grid from the coordinate system list and click OK.

This sets the coordinate system that will be used during the transformation. At this point, Geographic Imager automatically selects an appropriate datum shift to be performed during the transformation process. If this datum shift needs to be changed, click the Specify button to open the Specify Datum Shift dialog box and select the desired datum. See page Geographic Imager user guide for an explanation of datum shift.

4. Change the Pixel Size to 1234.8, leave the other options as the defaults.

The pixel size can be changed to any user specified value. This essentially changes the size of the image as each pixel represents a geographic unit. In this instance, the value was chosen to be near the original value.
5. Click the **Transform** button in the Transform dialog box. The image is transformed to a British National Grid projected coordinate system.

6. Make the **EuropeLL.tif** file the active document and click the **Transform** button. The panel displays the coordinate system as WGS84. You'll transform it to British National Grid.

7. Click the Same As check box and select **EuropeTR.tif (British National Grid)** from the Same As drop-down list.

8. Click **Update pixel dimensions to match the selected document** when prompted.

9. Click the **Transform** button in the Transform dialog box to confirm these settings.
Both images are now in the same projected coordinate system (British National Grid) and have the same pixel size.

10. Close all documents without saving before proceeding to the next exercise.
Mosaic Images

In the next set of exercises, several image documents will be mosaicked together, transformed as one image, and exported as multiple image tiles.

1. In Adobe Photoshop, open the EuropeTL.tif, EuropeLL.tif, EuropeLR.tif and EuropeTR.tif files.

2. Make the EuropeTR.tif file the active document, click the Reference File Specify... link in the Geographic Imager panel, choose EuropeTRref.tfw as the reference file, and click Open.

3. Click the Coordinate System Specify... link in the Geographic Imager panel, select one of the other images in the Same As drop-down list to specify the coordinate system as WGS 84 (EuropeLR.tif or EuropeLL.tif) and click OK.

4. Make the EuropeTL.tif the active document and click the Mosaic button.

Notice that EuropeTL.tif is in the British National Grid coordinate system. It will be the destination document, meaning other images will be mosaicked and transformed into it. Available documents can have different coordinate systems, different pixel sizes or contain rotation and still be mosaicked. The images will inherit the coordinate system and pixel size of the destination document.

Note: Transformations during mosaic are not supported when the destination document contains rotation. To mosaic into a destination document containing rotation the images to be mosaicked must have the same coordinate system, pixel size and rotation angle.

A list of available documents for mosaicking are displayed in the Available Documents list of the Mosaic dialog box. You will specify the Mosaic Documents next.

5. Click the Select All button to select all available images and click the double right arrow button to move them into the Selected Documents list. Click the Keep source data on separate layers check box.
The Advanced Transformation Options in the Mosaic dialog box are the same as the Transform dialog box. These options are used to resample the layers, set strip size and leave the layers intact or merge them. In this tutorial, leave them at their default settings. Read more about these options in chapter 4 of the Geographic Imager User Guide.

6. Click OK to complete the mosaic.

The image is mosaicked in the EuropeTL.tif document window with a coordinate system of British National Grid.

Inspect the Adobe Photoshop Layers panel. Notice that the other documents are now mosaicked in the EuropeTL.tif document. The layers are kept intact because you specified it to be. However, there is no need to retain the layer structure and the image will be flattened in the next exercise.

7. Close all documents without saving before proceeding to the next exercise.
Tile Images

1. In Adobe Photoshop, open EuropeMosaic.tif.

2. Click the Tile button in the Geographic Imager panel.

3. In the Tile dialog box, select the By Number of Tiles option, and type 3 into both the Horizontal and Vertical text boxes. This will result in the creation of nine new images.

4. In the Overlap frame, type 10 into both Horizontal and Vertical text boxes. Ensure Pixels is chosen in the Units drop-down list. This creates an overlap with each of its adjacent images.

5. In the Naming drop-down list, select Separate Row/Column Numbers. Each image will contain the name of the original image plus a reference to the row and column to which it represents.

6. Select GeoTIFF/BigTIFF/TIFF from the Reference File Format drop-down list and click OK.

7. Click OK and specify a location (directory) to save the tile images. In this case, use the default file name and click Save. If a TIFF Options dialog box appears, click OK to accept the default settings.

8. When the tile process is completed, navigate to the destination directory and view the tile images. The naming separate row/column numbers format is appended to the file name: the tile EuropeMosaic_1_1.tif belongs in the first row and first column; EuropeMosaic_1_2.tif in the first row and second column; and EuropeMosaic_1_3.tif in the first row and third column, and so on.

9. Close all open documents without saving.
**Georeference an Image**

The image for this exercise is a satellite image of central Rio de Janeiro, Brazil, courtesy of Google® Earth. The image has no georeferencing, however, it has four red pushpins indicating the position of placed ground control points. Using the Georeference command, assign a real world position to each control point.

1. In Adobe Photoshop, browse to the tutorial folder and open *Rio de Janeiro.jpg*.

   Note that in the Geographic Imager panel, the Reference File field is not specified because no corresponding reference file is present in the image folder.

2. In the Geographic Imager panel, click the Georeference button.

   The image is in a Pseudo-Mercator projection (as used in Google Earth and Google Map) but the position of the control points are provided in latitude and longitude format in the WGS84 geodetic system.

3. In the Format frame, click the Specify... link to set the Image Coordinate System.

4. In the Input Format dialog box, click the [No Coordinate System Specified] link to specify the image coordinate system.

5. Expand the Coordinate Systems > Projected > World category, select WGS84 / Pseudo-Mercator and click OK.

6. Back in the Input Format dialog box, click the Use alternate input coordinate system check box to enable this option and click the corresponding [No Coordinate System Specified] link. This ensures that the world values being entered are those of the coordinate system chosen in the next step.

7. Expand the Coordinate Systems > Geodetic > World category, select WGS84 and click OK. In the dialog box that appears, click Convert the points to the new coordinate system.

8. Back in the Input Format dialog box, choose Decimal Degrees (D+ [.d*]) from the Geodetic Coordinates Format drop-down list, change the Geodetic Precision to 6, and click OK.
9. At the top of the Georeference dialog box, click the **Zoom In** button and zoom to the first control point located at the upper-left corner of the image.

**Note:** If the overview window is in the way, close it by clicking the **Show/Hide Overview** button or move it—right-click (or hold Ctrl or Cmd and click) the overview window and drag to a new position.

10. Click the **Add Point** button and click precisely at the tip of the red pushpin number 1 on the image preview (zoom-in more if necessary). This adds a first control point named *Point 1*, a new row is added in the control point table.

11. In the control point table, enter the world coordinate (WX longitude and WY latitude) for Point 1 (top-left):
   - WX= -43.256355
   - WY= -22.872398

12. Using the **Zoom In**, **Zoom Out**, **Zoom to Extent** and **Pan** buttons or the overview window (click and drag to draw new extents), magnify the location of the red pushpin number two on the upper right corner of the image.

13. Click the **Add Point** button and click precisely at the tip of second pushpin.

14. In the control point table, enter the world coordinate for Point 2 (top-right) as follow:
   - WX= -43.243635
   - WY= -22.872597
15. Repeat the same procedure for red pushpin number 3 in the lower right corner of the image. The world coordinate for Point 3 (lower right) are:
   - WX = -43.242564
   - WY = -22.884070

16. Repeat the same procedure for the fourth red pushpin in the lower left corner of the image. Notice that the world coordinates of the fourth point are populated with an estimation based on the position of the other control points.

   Note: The registration Method is set by default to Affine—this method requires a method of three points (usually four for control). When using a higher polynomial degree method (e.g. Cubic Polynomial) more control points are required to determine the image registration. Higher polynomial degree methods can be necessary for distorted images (skewed through scanning process for example), or if the chosen image coordinate system is approximative.

17. Instead of keeping the estimated world coordinates of Point 4 (lower left), change them as follow:
   - WX = -43.255150
   - WY = -22.883450

   The control point table contains several columns on the positioning error of each control point (in pixel or world unit). The world coordinate values entered are considered accurate for this exercise, so any error should be due to the position of the control point on the image preview.

18. To reduce the error values, center and magnify the image preview to a control point to be moved, then click the Select Points button and click and drag the desired location to a more precise pixel position. Look at the error columns in the control point table to see if this improves the positioning accuracy. A WX and WY error of 0.5 meters is very acceptable for this image.

19. Leave the Mode as GCP and click OK. Click Continue using the GCP mode in the command box.
The image is now georeferenced. The Geographic Imager indicates a reference named *Rio de Janeiro.tfw* file and the selected image coordinate system (WGS84 / Pseudo-Mercator). The World (tfw) reference file format is the default reference format. It can be changed in Geographic Imager Preferences (*Panel options menu > Preferences > Default Reference Format*). The Mode (stated in the Georeference dialog box) is GCP and contains the four points that you defined.

20. To save the reference file and image file (although the image itself has not been modified), choose *File > Save* in the Adobe Photoshop main menu. The reference file, *Rio de Janeiro.tfw*, is saved in the same folder as the image file. Click *Proceed with the selected reference format* in the command box regarding the storage of individual ground control points.

21. Close all documents and continue with the next exercise.
**Quick Georeference**

Quick Georeference is a fast method to georeference an image. This method requires two conditions:

- The image is not rotated (image aligned to True North).
- Only two points are needed to georeference, however these points must not contain the same coordinate in either the X or Y pixel or world unit (i.e. two points cannot be aligned on the same X or Y axis on either the image or world system).

1. In Adobe Photoshop, open *EuropeTR.tif*. The image is not rotated and is aligned to True North.
2. In the Geographic Imager panel, click the **Georeference** button.
3. In the Georeferencing dialog box, click the **Add Control Point** button twice. In the table below, type the pixel coordinates (PX and PY) and world coordinates (WX and WY in decimal degrees) of two points located at the Northeast and Southwest corners of the image:

   **Northeast point (Point 1)**
   
<table>
<thead>
<tr>
<th>PX</th>
<th>PY pixel</th>
<th>WX</th>
<th>WY</th>
</tr>
</thead>
<tbody>
<tr>
<td>419</td>
<td>0</td>
<td>1.76</td>
<td>60.00</td>
</tr>
</tbody>
</table>

   **Southwest point (Point 2)**
   
<table>
<thead>
<tr>
<th>PX</th>
<th>PY pixel</th>
<th>WX</th>
<th>WY</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>452</td>
<td>-2.89</td>
<td>54.98</td>
</tr>
</tbody>
</table>

Notice that the world coordinates expand to three decimal places. This happens because the Projected Precision is set to three decimal places.
4. Click the **Quick Georeference** button and select the option **By Two Reference Points (North/South aligned)**.

The image is now georeferenced and two additional reference points are added. If necessary, click and drag the horizontal line below the image view to adjust the size of the table. Notice that there are no pixel or world coordinate errors.

5. In the Format frame, click the Image Coordinate System **Specify...** link.
6. In the Input Format dialog box, click the [No Coordinate System Specified] link. In the Specify Source Coordinate System dialog box, expand the Coordinate Systems > Geodetic > World category, select the WGS 84 coordinate system and click OK.

7. Click OK to close the Input Format dialog box.

The Format frame coordinate information is updated.

8. In the Georeference dialog box, click OK to save the settings.

The document was successfully georeferenced.

9. Keep this image open for the next exercise.
Quick Save to Format

Quick Save to Format is used to save an image into another format. The supported formats are BigTIFF, ECW, ERDAS IMAGINE Raster, Geospatial PDF, GeoTIFF, MrSID, and NITF.

1. With EuropeTR.tif as the active document from the previous exercise, open the Geographic Imager panel options menu and choose Quick Save to Format.

2. In the Quick Save to Format dialog box, choose Geospatial PDF as the Image format and click OK.

3. In the Save dialog box, choose a location to save the Geospatial PDF. Specify the name of the image as EuropeTRdocument.pdf and click Save.

The reference information is saved in the Geospatial PDF file and is displayed in the Geographic Imager panel as the reference. A geospatial PDF contains everything, including the image and reference information.

4. Close all open documents without saving.
**GeoCrop**

The GeoCrop function crops georeferenced images based on defined crop areas.

1. In Adobe Photoshop, open *EuropeLL.tif* and click the GeoCrop button in the Geographic Imager panel.

2. In the GeoCrop dialog box, choose Geodetic from the Unit Type drop-down list. Leave the Coordinate Format as Decimal Degrees and type in the following values:

   **Top-left corner**
   - Long: -5.5 deg
   - Lat: 52.5 deg

   **Bottom-right corner**
   - Long: -4.5 deg
   - Lat: 51.5 deg

The crop area marquee (dashed red border shown in the image preview) is drawn to the coordinates specified above. This functions similarly to the Adobe Photoshop crop tool. You’ll resize it to change the crop area.
3. Click and drag a corner of the crop area marquee to resize it. If needed, click and drag to move it.

![GeoCrop](image)

As the marquee is resized, the corner coordinate values are updated.

4. Click OK to complete the GeoCrop.

![Close all open documents](image)

5. Close all open documents without saving.
Import DEM File

Import DEM files easily using Geographic Imager. Some DEM files contain background or water areas (usually at a zero height) and need to be isolated before it can be styled. To achieve this, background pixels areas have to be defined in the Import DEM file dialog box advanced settings.

1. In Adobe Photoshop, browse to the Tutorial Data folder and open **Yukon Water.dem**.

2. In the Import DEM file dialog box, click the Create New Schema button.

This opens the Edit DEM Schema dialog box. The Schema Name is already populated with the name of the file. It also populates the Lowest and Highest Elevation values according to the DEM’s data range.

3. Since these values do not need to be modified click OK to close the Edit DEM Schema dialog box.

The Select Schema now reflects the data range of the DEM.
4. In the Import DEM file dialog box, click the Advanced button.

The Unique values list is currently set to Display as transparent pixels. The value -32767.00 is a predefined value that represents no data. This value can not be deleted and is common to all DEM files. To display elevations as transparent pixels, populate this list with elevation values.

5. Click the Add new value button. A new value is created. Double-click <new value> and type in a value of 0.

6. Click OK to close the Advanced DEM Schema Settings and click OK to accept the settings of the Import DEM file dialog box to finish the import.
The chosen custom DEM schema maps the range of elevation to the Adobe Photoshop grayscale color-space, displaying the highest contrast possible. A transparent area is visible where all elevations with a value of 0 that was specified in Advanced DEM Schema Settings.

The elevation value of 0 is considered water for this DEM. Since the area that represents water is now transparent, it is now very easy to create a background layer and apply a different color to it (remember that the color-space is grayscale).

7. Create a new layer and rename it to **Background**. Use the Adobe Photoshop Paint Bucket Tool and fill the layer with a black color (R: 0, G: 0, B:0).

In the next tutorial, you will apply a gradient map to the elevation data layer using the Terrain Shader.

8. Keep this document open for the next exercise.
Terrain Shader

Terrain Shader is used to style a DEM file or other image with z-values or to quickly create a gradient map adjustment layer using predefined or user loaded color maps.

1. Continue working with **Yukon Water.dem** from the previous exercise or refer to the “Import from DEM” tutorial for instructions on opening and configuring a DEM file.

2. On the Geographic Imager panel click the Terrain Shader button. This opens the Terrain Shader dialog box.

3. Click the Colorization Schema check box to enable its frame options. The Apply Color Map option is chosen and automatically applies the first color map (or the last color ramp used) in the list. If it's different than what you see in your dialog box, choose the World color map.

![Terrain Shader dialog box]

Note that the Background layer will also be affected since it is visible. The **Create single layer** option is checked by default which creates one gradient map adjustment layer. Unchecking this option will create a gradient map adjustment layer for each layer. The **Use Continuous Color** option is checked by default. It ensures the color ramp has smooth transitions between colors instead of discrete colors.

4. Click the **Import Color Map From File** button in the Terrain Shader dialog box (third button to the right of the color map). Choose the file **Colour Ramp Examples.grd** from the **Tutorial Data** folder.

5. Choose Elevation 3 from the Color Map drop-down list and click Import.
6. Click the Color Ramp drop-down list and choose Elevation 3. Then click the **Edit Selected Color Map** button to open the Edit Color Map dialog box.

![Edit Color Map dialog box](image)

This dialog box shows how the elevation is mapped to the color ramp. Hover over the color ramp to see how the elevation values correspond to the chosen color ramp.

7. Right-click the color swatch of the table entry for Color Stop 1 (at the top of the list) and click Edit Color Stop. In the Select Color for Color Stop dialog box. Enter new color values of Red: 204, Green: 198, Blue: 181.

![Select Color for Color Stop dialog box](image)

8. Click OK to close the color dialog box. Click OK again to close the Edit Color Map dialog box.
9. In the Terrain Shader dialog box, check the **Apply Shaded Relief** check box. Leave the angle at the default value of 45 degrees. Adjust the Intensity to **30** and click OK.

![Terrain Shader dialog box]

Your customized color ramp is applied to the DEM. In the Layers panel, notice that the original DEM (and background) is maintained. The shaded relief and color map layer are at the top of the layers list.

10. Close all open documents without saving.

**Reset Import DEM File Schema and Advanced Settings**

Custom DEM schema settings and Advanced DEM Schema Settings are saved even after Adobe Photoshop is closed. Both settings will be applied to each DEM image opened if values are not deleted.

1. Reopen the **Yukon Water.dem** file (or any DEM file).
2. In the Import DEM file dialog box, choose **Auto-stretched** from the Select Schema drop-down list.
3. Click the Advanced button to open the Advanced DEM Schema Settings dialog box.
4. Choose Display as background pixels from the Unique values drop-down list and select the 0.00 entry (or any other entries). Click the Remove selected value(s) button and click OK to close the Advanced DEM Schema Settings dialog box.
5. Click OK to close the Import DEM file dialog box to finish the import.

Custom DEM schema settings and Advanced DEM Schema Settings are now reset.
Advanced Import

The Advanced Import function imports images and provides useful settings to change reference file, coordinate system, color channel management, DEM schema, adjust image size and extents and even mosaic. It is also useful for quickly cropping large sized images to a specific geographic area which may have initially required a long load time. In this exercise, you’ll import two images of different formats, image sizes, and coordinate systems and then mosaic them together.

1. In the Geographic Imager panel, click the Advanced Import button.

2. In the Advanced Import dialog box, click the Format drop-down list and choose GeoTIFF/BigTIFF/TIFF, and then click Browse (you’ll be choosing a GeoTIFF).

3. Navigate to the Tutorial Data folder, choose boston-east.tif, then click Open. Click OK to close the message box.

The boston-east GeoTIFF image displays in the Import File list and shows that it has a Massachusetts Mainland Zone coordinate system and an 800 x 800 pixel image dimension.

4. Click the Format drop-down list and choose ECW, then click Browse.

5. Navigate to the tutorial data folder, choose boston-west.ecw, then click Open.

The boston-west ECW image displays in the list and shows that it has no coordinate system and a 650 x 650 px image dimension. You’ll use the Advanced Import options to make the images compatible so that they can be used in a mosaic.
6. Make sure boston-west.ecw is highlighted in the file list. Below it, in the Source Coordinate System frame, click the Same As check box.

Only boston-east.tif is available in the coordinate system drop-down list because it is the only other file available in the file list. The coordinate system is updated to Massachusetts Mainland Zone in the file list for boston-west.ecw. Next you'll change the image dimensions for the GeoTIFF image by entering a resample value.

7. Make sure boston-east.tif is highlighted in the file list. Below it, in the Image Extents frame, click the Resample button to open the Resample Image dialog box.

8. Change the width to 650 pixels. The Keep Aspect Ratio option ensures the height is also 650. Click OK.

The Dimensions column values update to reflect the resample size that you just entered.

The Image Extents frame also updates to reflect the resample size.
Lastly, you’ll setup the mosaic option so that the files can be mosaicked together.

9. At the bottom of the dialog box, click the Mosaic into Existing Document check box to enable its frame elements. The boston-east.tif file is shown in the list and will be the destination for the mosaic.

10. Click OK to complete the Advanced Import process.

The two image formats are now mosaicked together to create one seamless image. This is a similar result to a workflow that would have required you to open the images separately, adjust the coordinate system, change the image size, and then create a mosaic.

In the Layers panel, notice that there is only one layer created from the two images. To maintain separate layers, ensure the Keep source data on separate layers option is checked in the Advanced Import dialog box.

In the next exercise, you’ll use Advance Import to import DEM files.

11. Close all open documents without saving.
Advanced Import of DEM files

The Advanced Import function can also import DEM files and adjust its DEM schema settings. In this exercise you’ll also specify coordinates to create a crop of the image.

1. In the Geographic Imager panel, click the **Advanced Import** button.

2. In the Advanced Import dialog box, click the Format drop-down list and choose DEM USGS/CDED ASCII Format, then click Browse.

3. Navigate to the *Tutorial Data\ Rocky Mountain 3D Landscape Data* folder, choose *Rocky Mountains.dem*, then click Open.

   ![Import File List](image)

   The Rocky Mountain DEM displays in the Import File list and shows that it has a NAD83 coordinate system and an 1201 x 1201 pixel image dimension. Below the list, in the DEM Schema frame, the schema is displayed (as Yukon Water). If the DEM Schema is not listed as **Auto-stretched**, click the Specify button and choose the Auto-stretched schema.

4. In the Image Extents frame, click the Crop button. This opens the GeoCrop dialog box.

5. Make sure **Geodetic** is chosen in the Unit Type drop-down list and the coordinate format is Decimal degrees. In the Top-left and Bottom-right Corner frames, enter the following values.

   ![GeoCrop Dialog](image)

   **Top-left Corner:**
   - Long: **-121.180**
   - Lat: **54.695**

   **Bottom-right Corner:**
   - Long: **-121.047**
   - Lat: **54.562**
6. Click OK and then view the file list. The image dimensions are now 638 x 638 pixels (from 1201 x 1201 pixels) according to the crop coordinates you just entered. The DEM Schema also changes to *Crop auto-stretched* to indicate that not all of the values in the DEM are included in the schema.

![DEM Schema Table](image)

You'll save the DEM Schema so that it has a proper name and so you can see its range values.

7. In the DEM Schema frame, click the Specify button.

![Specify DEM Schema](image)

8. In the Import DEM File dialog box, click the green Create New Schema button. Enter *Rocky Mountains Cropped* as the new schema name, then click OK.

![Import DEM File](image)

The elevation range values for the cropped image are 930 meters (lowest) to 2310 meters (highest). Before the crop, the range was 869 meters to 2534 meters. The crop cut some of the lower and upper range elevations.

![Import DEM File](image)

9. Click OK to close the dialog box.
The DEM Schema name is updated in the file list and in the DEM Schema frame below. Its range values are also shown. The image dimensions also updated below in the Image Extents frame.

10. Click OK to import the DEM.

11. Close all open documents without saving.
Export Web Tiles

The Export Web Tiles feature generates image tiles that can be used for online map purposes. An HTML file is created with the web tiles which consists of a web map with the tiles in already in place. Use the Web Tile Export Options dialog box to adjust tile options.

1. In Adobe Photoshop, browse to the Tutorial Data folder and open boston-east.tif. Before an image can be exported to web tiles, it must be in the WGS 84/Pseudo-Mercator coordinate system. The Export Web Tiles feature will conveniently and temporarily transform the image from Massachusetts Mainland Zone to WGS 84/Pseudo-Mercator so that it is compatible.

2. From the Geographic Imager panel, click the Export Web Tiles button.

3. Click Transform the image and proceed with the export.

4. In the Web Tile Export Options dialog box, click Browse and rename the dataset name to index.html. Choose an image format to PNG and choose a World reference file. In the Zoom Level Options frame, choose a Max Zoom of Level 17 - 1.19 meters/pixel and change the number of zoom levels to 3. A total of 76 web tiles will be created. Note that the Min Zoom is Level 15.
5. Click OK to begin the export process.

6. After the web tile export completes, navigate to the export folder you specified and double-click the index.html file to open it in a web browser.

In the export folder, several new folders were created (Z15, Z16, and Z17). These folders hold the PNG images that make up the web tiles and represent the three zoom levels you chose. Also included are TFW world reference files because you chose to create them during export. Creating a reference file is not required, but may be useful if the web tiles were to be repurposed.

7. Close all open documents without saving.
Using Actions with Geographic Imager

This exercise demonstrates how to automate Geographic Imager by recording an action that opens an image and transforms the coordinate system to WGS 84. See Chapter 10 - Automating Geographic Imager for more details.

**Note:** Actions should only be used on the computer it was created on. Actions are not cross platform and use absolute paths.

1. In the Adobe Photoshop menu, choose *Window > Actions* to open the Actions panel.
2. In the Action panel option menu (top right corner), choose *New Set*. Rename it *Open - Transform WGS 84* and click OK. This creates an action set folder to store the action.
3. With the new *Open - Transform WGS 84* set folder selected, choose *New Action* from the Action panel option menu. Rename the action to *EuropeTL to WGS 84*.

   ![New Action dialog](image)

   A function key and colour for the action can be set, however, it is not needed for this exercise.

4. Click Record to create the action.

   Notice that the red Begin recording button in the Actions panel is enabled. From this point on, all operations will be recorded to the action until it is stopped.

5. In the Adobe Photoshop menu, choose *File > Open*. Browse to the Tutorial Data folder containing the tutorial images and open *EuropeTL.tif*.
6. Choose *File > Automate > Geographic Imager: Transform*. In the Transform dialog box, perform a coordinate system transformation to *WGS 84 (Geodetic > World)*.
7. In the Action panel, click the Stop Playing/Recording button. Notice the action steps are recorded beneath the action name.
8. To play back the action, close the image without saving, select the EuropeTL to WGS 84 action and click the Play button in the action panel.

Congratulations, you have completed the Geographic Imager Tutorial Guide. Move onto the Adobe Photoshop exercises in the next section. Also see the Geographic Imager User Guide for detailed info about features.
Adobe Photoshop Tutorial Exercises

The following tutorial exercises use existing Adobe Photoshop functions to manipulate spatial imagery to create affects such as shaded relief, colour ramps, 3D elevation models, false-colour composite and pan sharpened images. In addition, learn how to record measurements with the Ruler Tool and resample and sharpen images.

These tutorial exercises differ from the previous set of exercises because they mainly involve the use of Adobe Photoshop tools, functions and filters. Geographic Imager allows non-native formats such as DEM files, MrSID, ECW and JPEG 2000 to be imported and used with an Adobe Photoshop environment while streamlining the cartographic workflow.

These exercises are only basic examples of what Geographic Imager for Adobe Photoshop is capable of doing. Combined with creative uses of both sets of tools, a wide range of image manipulation techniques are achievable.

Content
Using Actions with Geographic Imager .............................................................. 36
Create a 3D Representation with a Script .......................................................... 38
The Ruler Tool and Measure Tab ............................................................... 40
Create a False-Colour Composite with Multiple Images .................................. 43
Create a False-Colour Composite with Channel Management ....................... 45
Pan Sharpen ................................................................. 48
Resample and Sharpen ....................................................................................... 53
Create a 3D Representation with a Script

This exercise demonstrates how to use a custom script with Geographic Imager to open a DEM, overlay it with an image and to create a 3D effect. See Chapter 12 - Automating Geographic Imager for more details.

1. In Adobe Photoshop, click File > Scripts > Browse. Browse to the Sample Scripts folder, click 3D Overlay Script.jsx, then click Load.

![Image of Script Alert dialog box]

No image are open, so you are prompted to open a DEM. This script also works if a DEM is already open.

2. Click Yes.

3. Browse to the Rocky Mountain 3D Landscape Data folder, click Rocky Mountains.dem, then click OK.

![Image of Import DEM File dialog box]

The Import DEM File dialog box appears.

4. Choose the Auto-stretched schema and click OK.

![Image of Script Alert dialog box]

This script allows you to choose a image to overlay the DEM. If no image is chosen, Terrain Shader can be used to create a color map for it. You'll choose the accompanying tutorial GeoTIFF image to overlay.

5. Click Yes.
6. Browse to the Rocky Mountain 3D Landscape Data folder, click Rocky Mountains.tif, then click OK.

A 3D operation is performed to the Rocky Mountains DEM and the Rocky Mountains GeoTIFF is overlayed on top of it. This image is still considered a dynamic object in Adobe Photoshop and it can be controlled with the 3D panel (Window > 3D) and the Object Rotate Tool and Camera Rotate Tool in the Tools toolbar.

The 3D panel has options to change lighting settings (such as opacity, light source, intensity) and render settings (such as 3D options, cross section, quality). The vertical exaggeration can be adjusted with the Object Rotate Tool and the green axis adjustment.

**Note:** When creating a 3D representation, georeferencing is not maintained.
The Ruler Tool and Measure Tab

Analysis tools can be used to record and export measurements with georeferenced images. This exercise uses the Adobe Photoshop Ruler tool in combination with the Geographic Imager Measure tab located in the panel.

1. In Adobe Photoshop, choose File > Open and browse to the Landsat 7 Multispectral folder and open Band 8 (Panchromatic), 15 meters.tif.

This is an image of downtown Toronto circa 2004. The projected coordinate system is NAD 83 UTM Zone 17N in meters. The Geographic Imager panel displays the pixel size. A precise measurement is dependent on the pixel size. For this example, 1 pixel is equal to 15 x 15 meters and provides a moderately accurate measurement.

Note: Non-square pixels prevent the recording of correct measurements when using measurement tools. This can be rectified by using the Geographic Imager Transform function and changing the Pixel Options to keep pixels square.

2. Before measuring, choose Window > Measurement Log to open the Measurement Log panel. The panel appears either as floating or docked at the bottom of the screen. In the panel options menu the Analysis menu, choose Set Measurement Scale > Custom.

3. In the Measurement Scale dialog box. Set the Logical Length to 15. Type the Logical Units as meters. Note: Up to four decimal places can be entered in the custom field to provide enough accuracy for all images.

The Logical Units box stores what unit the pixel size is in. A custom preset measurement scale is useful when using images with the same pixel size.

4. Click OK to close the dialog box.
5. In the Adobe Photoshop Tools panel, select the **Ruler Tool**. (If it isn’t visible, click and hold the Eyedropper Tool button to display the flyout menu, then choose the Ruler Tool).

6. Take a measurement of a section of Toronto. As shown below, click anywhere on the map and drag the Ruler Tool. Click again to complete the measurement. A measurement line is drawn on the image.

![Image of Toronto map with measurement line](image)

7. In the Geographic Imager panel, click the Ruler tab. Click the Update button.

![Image of Geographic Imager panel](image)

The measurement is shown in page (pixels) and cartesian units (meters) for Segment L1. Next you’ll use the Ruler Tool to measure another segment.

8. Click the Ruler Tool again. Hold the Alt (Win) or Option (Mac) key and hover over the end of the first segment. The icon changes to signify that an additional angled segment can be drawn. Click and draw a measurement that is 90-degrees west of the first segment.

![Image of measurement with 90-degree angle](image)
9. In the Geographic Imager panel, click the Update button again (in the Ruler tab).

A second segment value is updated in the panel. However, this does not record or save your measured distance. You’ll use the Measurement Log panel to record it.

10. In the Measurement Log panel, click **Record Measurements**.

![Measurement Log panel](image)

For the above example, the distance recorded is approximately 2800 meters (Length column). Your results may vary depending on how long of a ruler line you drew. Three measurements are recorded: Total length, segment 1 and segment 2.

All measurements can be exported to a tab delimited Unicode text file (select desired rows and choose Export Selected button in the Measurement Log panel options menu).

11. In the Measurement Log panel, select the three measurements. Click the Measurement Log panel options menu and click Export Selected. Rename the output file to **measurements.txt** and save it to your Desktop.

12. Open the measurements.txt file to see what the values look like when exported.

13. Close all documents without saving.

**Note:** Remember the resolution of the image will reflect how accurate the measurements will be. Analysis tools cannot be used with non-square pixels because each side has a different length.
Create a False-Colour Composite with Multiple Images

Another powerful remote sensing tool in Adobe Photoshop is the ability to create a false-colour composite image. Multispectral images contain information inside and outside the visible electromagnetic spectrum. To use this information, the wavelengths outside the visible spectrum need to be reassigned to the visible spectrum so that it is visible to the human eye. This tutorial will create a false-colour composite of downtown Toronto and surrounding suburban areas.

Often multispectral satellite images will consist of several grayscale images, with each image containing one of the wavelengths or bands of the electromagnetic spectrum. These images need to be combined into one image. The Adobe Photoshop function called *Merge Channels* merges images to create false-colour or true-colour composites. You may easily identify distinct features by their unique spectral signature.

1. In Adobe Photoshop, browse to the *Landsat 7 Multispectral* folder and open the following images:
   - Band 2 (Green), 30 meters.tif
   - Band 3 (Red), 30 meters.tif
   - Band 4 (Near Infrared), 30 meters.tif

   **Note:** When creating false-colour composites, images must be of the same image resolution and have the same spatial extents. If the images need to be cropped, it is recommended to use the Geographic Imager GeoCrop function to assure that the extents of the images remain consistent.

2. From the Windows menu, choose *Channels* to open the Channels panel.

3. In any of the active document windows, click *Merge Channels* from the Channels panel options menu.

4. In the Merge Channels dialog box, choose *RGB Color* in the Mode drop-down list and ensure there are 3 channels. Click OK.
In the Merge RGB Channels dialog box specify the following channels:

- **Red**: Band 4 (Near Infrared), 30 meters.tif
- **Green**: Band 3 (Red), 30 meters.tif
- **Blue**: Band 2 (Green), 30 meters.tif

Click OK to complete the merge.

**Note:** A reference file called Untitled-x.tfw (the x value may change depending on if you have other reference files named something similar) is created in the default reference format specified in the Geographic Imager Preferences dialog box.

A false-colour composite image with georeferencing is created. The band combination chosen makes vegetation appear in shades of red because vegetation reflects a lot of near infrared light. The brighter the red, the healthier the vegetation. Urban areas appear blue-grey. The bright red areas at the top of the image belong to the prestigious Rosedale Golf Club.

Close all open documents without saving.
More about Landsat 7 band combinations

<table>
<thead>
<tr>
<th>R,G,B</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3,2,1</td>
<td>The “nature colour” combination. It provides the most water penetration.</td>
</tr>
<tr>
<td>4,3,2</td>
<td>Standard “false-colour” combination. Vegetation shows in red.</td>
</tr>
<tr>
<td>7,4,2</td>
<td>The “nature-like” combination. Sand, soil and minerals show in multitude of colour. Fires would appear in red. It provides clear imagery in desert region.</td>
</tr>
<tr>
<td>7,5,3</td>
<td>The “nature-like” combination. Sand, soil and minerals appear in variety of colour.</td>
</tr>
<tr>
<td>5,4,1</td>
<td>Good for agricultural studies. Healthy vegetation shows in bright green colour.</td>
</tr>
<tr>
<td>7,5,4</td>
<td>Provides best atmospheric penetration. Vegetation shows in blue. Useful for geological study.</td>
</tr>
<tr>
<td>7,3,1</td>
<td>Rocks may appear in variety of colour. Good for the geological study.</td>
</tr>
</tbody>
</table>

Note: Some multispectral images may be provided as a single image that stores extra channels (called alpha channels in Adobe Photoshop). To create false-colour composites from these images in Adobe Photoshop, the channels must first be split into single gray scale images (Channels panel option menu > Split Channels). Then channels can be merged and reordered as described above.

Create a False-Colour Composite with Channel Management

Creating a false-colour composite image with an image that contains an extra band of information (alpha channel) is best done with Geographic Imager Channel Management.

1. In Adobe Photoshop, browse to the Landsat 7 Multispectral folder and open All bands.tif.

This image is similar to the previous exercise, except that it has all the bands (channels) already merged into it. You’ll use Geographic Imager Channel Management to create a false-colour composite.
2. From the Geographic Imager panel, click the Channel Management button.

The current Color Mode is Grayscale Color which explains why the image is displayed as such.

3. Click the Color Mode drop-down list and choose RGB Color.

The Gray Band is assigned a channel role of Red, Band 2 is assigned Green, and Band 3 is assigned Blue. You’ll change the visibility of the Gray Band and reassign the channel roles for bands 2, 3, and 4 to create the correct false-colour composite appearance.
4. Click the Visibility check box for Gray Band to disable it. Click the Visibility check box for Band 4 to enable it.

The new channel roles will follow the ones used in the previous exercise (RGB - 4, 3, 2).

5. Click the Band 4 Channel Role (it is set as Alpha 1) and choose Red in the drop-down list. Change the Band 3 Channel Role to Green. The Band 2 Channel Role should automatically update to Blue.

6. Click OK to confirm the reassignment of channels.

A false-colour composite image using Channel Management is created. These changes are reflected in the Geographic Imager Channels panel.

7. Close all open documents without saving.
**Pan Sharpen**

Another useful tool Adobe Photoshop provides is the ability to intelligently resample images. Pan sharpening (short for panchromatic sharpening) the use of a single band to increase the spatial resolution of a multispectral image. A multispectral image contains a higher spectral resolution of a panchromatic image, while often a panchromatic image will have a higher spatial resolution than of a multispectral image. A pan sharpened image represents the best of both worlds which is essentially a sensor fusion that gives a multispectral image higher spatial resolution.

1. In Adobe Photoshop, browse to the *Landsat 7 Multispectral* folder and open the following images:
   - Band 8 (Panchromatic), 15 meters.tif
   - Band 1 (Blue-green), 30 meters.tif
   - Band 2 (Green), 30 meters.tif
   - Band 3 (Red), 30 meters.tif

In this exercise, the panchromatic image will be combined with a multispectral image in true colour, however, any false-colour composite combination can be used.

2. From the Window menu, choose *Channels* to open the Channels panel.

3. In any 30 meter resolution active document window (Band 1, 2 or 3), click *Merge Channels* from the Channels panel options menu.

   **Note:** If Band 8 is chosen, Merge Channels will be disabled.

4. In the Merge Channels dialog box, select *RGB Color* in the Mode drop-down list and click OK.

5. In the Merge RGB Channels dialog box specify the following channels:
   - Red: Band 3 (Red), 30 meters.tif
   - Green: Band 2 (Green), 30 meters.tif
   - Blue: Band 1 (Blue-green), 30 meters.tif

6. Click OK to complete the merge.
Since the merged image is at 30 meter resolution, it is necessary to resample it to match the resolution of the panchromatic image (15 meter resolution).

7. With the merged document window active, choose Image > Image Size.

8. Ensure Constrain Proportions and Resample Image check boxes are checked. Choose Bicubic (best for smooth gradients) as the resampling method.

9. In the Pixel Dimensions frame, select Percent from the units drop-down list.

10. Enter 200 in the width dimension and click OK to complete image scaling.

11. From the Image menu, choose Mode > Lab Color.
12. In the Channels panel options menu, click **Split Channels**.

The merged image is split into three images: Lightness, a and b.

The split images have a “_Lightness”, “_a”, or “_b” added to the end of the document name. The a and b channels carry green-red and blue-yellow information respectively. Our process is to substitute the panchromatic image for the Lightness channel.

The following step involves some trial and error. The intent is to make the image brightness and contrast match the Lightness channel as much as possible. Ignore areas of water or vegetation and concentrate on roads and buildings. Often panchromatic images contain data that extend into the infrared, therefore vegetation and areas of water appear differently. The higher resolution of the panchromatic image, the more contrast it will appear to have.

**Note:** Ignore vegetation and areas of water because panchromatic images often contain near infrared data.

13. Make **Band 8 (panchromatic), 15 meters.tif** active and create a Brightness/Contrast adjustment layer. Choose **Layer > New Adjustments Layer > Brightness/Contrast**. Click OK to accept the default name and settings.

14. In the Brightness/Contrast settings (Adjustment panel), adjust Brightness to +100 and Contrast to +35.

15. Create a second adjustment layer. Choose **Layer > New Adjustments Layer > Levels**. Click OK to accept the default name and settings.
16. In the Levels settings (Adjustment panel), change the midtone input level to 0.9 and the highlight input level to 230.

![Levels Settings](image)

17. To properly merge channels, the layers need to be flattened first. Choose Layer > Flatten Image.

18. In the Channels panel options menu, click Merge Channels. In the Merge Channels dialog box, select Lab Color in the Mode drop-down list and click OK.

![Merge Channels Dialog](image)

19. In the Merge Lab Channels dialog box specify the following channels:
   - Lightness: Band 8 (Panchromatic), 15 meters.tif
   - a: Untitled-1_a
   - b: Untitled-1_b

![Merge Lab Channels Dialog](image)

**Note:** The Untitled documents were created from splitting the channels in step 14. Untitled documents may not be appended with the number 1, however, be sure that the final character corresponds to the channel e.g. a = “Untitled-4_a”.

20. Click OK to complete the merge.
21. Choose Mode > RGB to convert the image back to RGB mode.

22. Leave the document open for the next exercise.

**Note:** This exercise is a guide to enhance images for display or printing purposes, this method involves subjective judgment to pixel colour adjustments and should not be used for scientific purposes. The colours of the pan-sharpened image will look different from the original RGB image because panchromatic data (from Landsat 7) extend into the infrared, most notably vegetation and areas of water.
Resample and Sharpen

Adobe Photoshop sharpen filters can increase the detail of the image. The Sharpen filter menu has a variety of sharpening tools. These tools also involve some trial and error to achieve enough sharpening without overdoing it. Two sharpening filters are explained below.

The Unsharp Mask

This filter sharpens an image by increasing contrast along the edges of an image. It locates pixels that differ in value from the surrounding pixels, this option can be modified by changing the threshold. The radius of the region to which each pixel is compared is also an option that can be modified.

Smart Sharpen

This filter has more advanced controls not available in the Unsharp Mask filter. This filter will allow control over the amount of sharpening that occurs in shadow and highlight areas. The document should be viewed at 100% to get an accurate view of the sharpening.

- **Amount**: Sets the amount of sharpening. A higher value increases the contrast between edge pixels, giving the appearance of greater sharpness.
- **Radius**: Determines the number of pixels surrounding the edge pixels affected by the sharpening. The greater the radius value, the wider the edge effects and the more obvious the sharpening.
- **Remove**: Sets the sharpening algorithm used to sharpen the image. Gaussian Blur is the method used by the Unsharp Mask filter. Lens Blur detects the edges and detail in an image, and provides finer sharpening of detail and reduced sharpening halos. Motion Blur attempts to reduce the effects of blur due to camera or subject movement. Set the Angle control if you choose Motion Blur.
- **Angle**: Sets the direction of motion for the Motion Blur option of the Remove control.
- **More Accurate**: Processes the file more slowly for a more accurate removal of blurring.

In the Smart Sharpen dialog box, click the Advanced option to display the Shadow and Highlight tabs. Adjust sharpening of dark and light areas using these tabs. If the dark or light sharpening halos appear too strong, reduce them with these controls, which are only available for 8-bits and 16-bits-per-channel images:

- **Fade Amount**: Adjusts the amount of sharpening in the highlights or shadows.
- **Tonal Width**: Controls the range of tones in the shadows or highlights that are modified. Move the slider to the left or right to decrease or increase the Tonal Width value. Smaller values restrict the adjustments to only the darker regions for shadow correction and only the lighter regions for highlight correction.
- **Radius**: Controls the size of the area around each pixel that is used to determine whether a pixel is in the shadows or highlights. Moving the slider to the left specifies a smaller area, and moving it to the right specifies a larger area.
1. With the image still open from the previous exercise, choose Filter > Sharpen > Smart Sharpener.

2. Set the following parameters in the Smart Sharpen dialog box:
   - Set the Amount to **15%**
   - Set the Radius to **2.0** pixels
   - Set Remove to **Lens Blur**
   - Check the **More Accurate** check box

3. Click OK.

Features appear to have more detail when compared to the image prior to sharpening. Again, this will involve some trial and error if the results are not satisfactory, experiment with settings if more sharpening is needed.

Congratulations, you have completed the Adobe Photoshop Tutorial Exercises. For more in-depth information on Geographic Imager tools and features, see the Geographic Imager User Guide and also online at www.avenza.com.