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In this tutorial you will learn the basics of Geographic Imager by working with a series of tutorial exercises. All of the 
sub-folders of files, images, data and scripts for the tutorial exercises can be found in the following locations:

Windows XP
C:\Documents and Settings\All Users\Documents\Avenza\Geographic Imager\User Guide, Tutorial & Data 

Windows Vista and Windows 7
C:\Users\Public\Public Documents\Avenza\Geographic Imager\User Guide, Tutorial & Data

Mac OS X
/Applications/Avenza/Geographic Imager/User Guide, Tutorial & Data
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Open Images

Opening a spatial image is similar to opening up any other image. 

1.	 In Adobe Photoshop, choose File > Open. Browse to the folder location of the tutorial images and open 
EuropeLL.tif and EuropeTR.tif.

2.	 Make the EuropeTR.tif file the active document and view the Geographic Imager palette. If the palette is not 
visible, choose File > Automate > Geographic Imager: Show Palette.

3.	 Keep these images open for the next exercise.

Specify a Reference File

A reference file contains coordinates that describes the location, image and pixel size, and rotation of an image file. 
It does not contain actual image data.

1.	 With the EuropeTR.tif file as the active document, click the Reference File Specify... link in the Geographic Imager 
palette. This specifies a reference file containing geographic coordinate information for the active document. 

2.	 Select EuropeTRref.tfw and click the Open button. Once opened, the reference file will be listed in the Geographic 
Imager palette.

3.	 Keep these images open for the next exercise.

Tutorial Exercises
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Specify a Coordinate System

Some reference files do not store coordinate system information. Using a world file as a reference file requires that 
a  source coordinate system be specified. For more information on reference files, see Chapter 2 in the Geographic 
Imager User Guide.

The EuropeTR.tif was originally made in the WGS 84 coordinate system, however it currently has no coordinate 
system assigned. Specify a coordinate system using these steps.

1.	 With the EuropeTR.tif file still the active document, click the Coordinate System Specify... link in the Geographic 
Imager palette. This specifies a coordinate system for the active document. 

2.	 In the Specify Coordinate System dialog box, click the Browse button.
3.	 In the Select Coordinate System dialog box, expand the Coordinate Systems > Geodetic > World category, select 

the WGS 84 coordinate system and click OK.

4.	 Click OK in the Specify Coordinate System dialog box to finalize the selection. This assigns the WGS 84 
coordinate system to the active document.

5.	 Keep these documents open for the next exercise.
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Transform a Coordinate System

Transforming a coordinate system transforms a georeferenced source image into a destination georeferenced 
image with a different coordinate system. In this exercise, the image will be transformed from WGS 84 coordinate 
system to British National Grid coordinate system.

1.	 With EuropeTR.tif still the active document, click the Transform button in the Geographic Imager palette.
2.	 In the Transform dialog box, click the Browse button to select a destination coordinate system. This is different 

than specifying a source coordinate system. A destination coordinate system is the coordinate system of the 
image after it is transformed.

3.	 Expand the Coordinate Systems > Projected > Europe > United Kingdom category, select the British National Grid 
coordinate system and click OK. 

This sets the coordinate system that will be used during the transformation. At this point, Geographic Imager 
automatically selects an appropriate datum shift to be performed during the transformation process. If this 
datum shift needs to be changed, click the Specify button to open the Specify Datum Shift dialog box and select 
the desired datum. See page Geographic Imager user guide for an explanation of datum shift.

4.	 Change the Pixel Size to 1234.8, leave the other options as the defaults. 
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The pixel size can be changed to any user specified value. This essentially changes the size of the image as each 
pixel represents a geographic unit. In this instance, the value was chosen to be near the original value.

5.	 Click the Transform button in the Transform dialog box. The image is transformed to a British National Grid 
projected coordinate system.

6.	 Make the EuropeLL.tif file the active document and click the Transform button.
7.	 Click the Same As option and select EuropeTR.tif (British National Grid) from the Same As drop-down list.
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8.	 Click Yes when prompted to update the pixel dimensions to match the selected document (e.g. for the purpose 
of mosaicking). Do not check the Always use the current selection check box.

9.	 Click the Transform button in the Transform dialog box to confirm these settings.
Both images are now in the same projected coordinate system (British National Grid) and have the same 
pixel size.

   

10.	 Close all documents without saving before proceeding to the next exercise.
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Mosaic Images

In the next set of exercises, several image documents will be mosaicked together, transformed as one image, and 
exported as multiple image tiles.

1.	 In Adobe Photoshop, choose File > Open. Open the EuropeTL.tif, EuropeLL.tif, EuropeLR.tif and EuropeTR.tif files.
2.	 Make the EuropeTR.tif file the active document, click the Reference File Specify... link in the Geographic Imager 

palette, and choose EuropeTRref.tfw as the reference file. 
3.	 Click the Coordinate System Specify... link in the Geographic Imager palette, select one of the other images in the 

Same As drop-down list to specify the coordinate system as WGS 84 and click OK.

4.	 Make the EuropeTL.tif the active document and click the Mosaic button .

Notice that it is in the British National Grid coordinate system. This will be the destination document, other 
images will be mosaicked and transformed into this document. Images can have different coordinate systems, 
different pixel sizes or contain rotation and still be mosaicked. The images will inherit the coordinate system and 
pixel size of the destination document.

Note:	 Transformations during mosaic are not supported when the destination document contains rotation. To 
mosaic into a destination document containing rotation the images to be mosaicked must be have the same 
coordinate system, pixel size and rotation angle.

5.	 A list of available documents for mosaicking are displayed in the Available Documents list of the Mosaic dialog 
box. Click the Select All button to select all available images and click the double right arrow button to move 
them into the Selected Documents list. 
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The Advanced Transformation Options in the Mosaic dialog box are the same as the Transform dialog box. These 
options are used to resample the layers, set strip size and leave the layers intact or merge them. In this tutorial, leave 
them as the default settings. Read more about these options in Chapter 4 of the Geographic Imager User Guide.

6.	 Click OK to complete the mosaic.

The image is mosaicked in the EuropeTL.tif document window with a coordinate system of British National Grid.

Inspect the Adobe Photoshop Layers panel. Notice that the other documents are now mosaicked in the 
EuropeTL.tif document. The layers are kept intact, however, since there is no need to retain the layer structure 
for the next exercise, the image will be flattened.

7.	 Click Layer > Flatten Image.
8.	 Keep the EuropeTL.tif document open for the next exercise and close the other open documents.
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Tile Images
1.	 With the mosaicked image the active document, click the Tile button in the Geographic Imager palette. 

2.	 In the Tile dialog box, select the By Number of Tiles option, and type 3 into both the Horizontal and Vertical text 
boxes. This will result in the creation of nine new images.

3.	 In the Overlap frame, type 100 into both Horizontal and Vertical text boxes. Ensure Pixels is chosen in the Units 
drop-down list. This creates a 100 pixel overlap with each of its adjacent images.

4.	 In the Naming drop-down list, select Separate Row/Column Numbers. Each image will contain the name of the 
original image plus a reference to the row and column to which it represents.

5.	 Select GeoTIFF Files from the Reference File Format drop-down list and click OK.

6.	 Click OK and specify a location (directory) to save the tile images. In this case, use the default file name and click 
Save. If a TIFF Options dialog box appears, click OK to accept the default settings.

7.	 When the tile process is completed, navigate to the destination directory and view the tile images. The naming 
separate row/column numbers format is appended to the file name: the tile EuropeTL_1_1.tif belongs in the 
first row and first column; EuropeTL_1_2.tif in the first row and second column; and EuropeTL_1_3.tif in the first 
row and third column, and so on.

8.	 Close all open documents without saving.
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Georeference an Image

The image for this exercise is a satellite image of central Rio de Janeiro, Brazil, captured on Google® Earth. The image 
has no reference file, however it has four red pushpins indicating the position of the image control points. Using the 
Georeference function, assign a real world position to each control point. 

1.	 In Adobe Photoshop, choose File > Open. Browse to the tutorial folder and open the file Rio de Janeiro.jpg. Note 
that in the Geographic Imager panel, the Reference File field is not specified because no corresponding reference 
file is present in the image folder. 

2.	 In the Geographic Imager palette, click the Georeference button .

The image is in a Pseudo-Mercator projection (as used in Google Earth and Google Map) but the position of the 
control points are provided in latitude and longitude format relative to the WGS84 geodetic system.

3.	 In the Format frame, click the Specify... link to set the Image Coordinate System.

4.	 In the Input Format dialog box, click the Specify button to specify the image’s coordinate system.

5.	 Expand the Coordinate Systems > Projected > World category, select WGS84 / Pseudo-Mercator and click OK.

6.	 Back in the Input Format dialog box, click the Use alternate input coordinate system check box to enable this option 
and click the corresponding Specify button. This ensures that the world values being entered are those of the 
coordinate system chosen in the next step.

7.	 Expand the Coordinate Systems > Geodetic > World category, select WGS84 and click OK.

8.	 Back in the Input Format dialog box, choose Decimal Degrees (D+[.d*]) from the Geodetic Coordinates Format 
drop-down list, change the Geodetic Precision to 6 and click OK.
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9.	 At the top of the Georeference dialog box, click the Zoom In button  and zoom to the first control point 
located at the upper-left corner of the image. 

Note:	 If the overview window is in the way, close it by clicking the Show/Hide Overview button  or move it—
right-click (or hold Ctrl or Cmd and click) the overview window and drag to a new position.

10.	 Click the Add Point button  and click precisely at the tip of the red pushpin number 1 on the image preview 
(zoom-in more if necessary). This adds a first control point named Point 1, a new row is added in the control 
point table.

11.	 In the control point table, enter the world coordinate (WX longitude and WY latitude) for Point 1 (top-left):
•	 WX= -43.256355
•	 WY= -22.872398

12.	 Using the Zoom In , Zoom Out , Zoom to Extent  and Pan  buttons or the overview window (click 
and drag to draw new extents), magnify the location of the red pushpin number two on the upper right corner 
of the image. 

13.	 Click the Add Point button  and click precisely at the tip of second pushpin.

14.	 In the control point table, enter the world coordinate for Point 2 (top-right) as follow:
•	 WX= -43.243635
•	 WY= -22.872597
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15.	 Repeat the same procedure for red pushpin number 3 in the lower right corner of the image. The world 
coordinate for Point 3 (lower right) are: 
•	 WX= -43.242564
•	 WY= -22.884070

16.	 Repeat the same procedure for the fourth red pushpin in the lower left corner of the image. Notice that the world 
coordinate of the forth point are populated with an estimation based on the position of the other control points.

Note:	 The registration Method is set by default to Affine—this method requires a method of three points (usually 
four for control). When using a higher polynomial degree method (e.g. Cubic Polynomial) more control points 
are required to determine the image registration. Higher polynomial degree methods can be necessary for 
distorted images (skewed through scanning process for example), or if the chosen image coordinate system 
is approximative.

17.	 Instead of keeping the estimated world coordinates of Point 4 (lower left), change them as follow:
•	 WX= -43.255150
•	 WY= -22.883450

The control point table contains several columns on the positioning error of each control point (in pixel or world 
unit). The world coordinate values entered are considered accurate for this exercise, so any error should be due 
to the position of the control point on the image preview. 

18.	 To reduce the error values, center and magnify the image preview to a control point to be moved, then click 
the  Select Points button  and click and drag the desired location to a more precise pixel position. Look at the 
error columns in the control point table to see if this improves the positioning accuracy. A WX and WY error of 
0.5 meters is very acceptable for this image.

19.	 Leave the Mode option as GCP mode and click OK. Click No to the warning message regarding the mode.
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The image is now georeferenced. The Geographic Imager indicates a reference named Rio de Janeiro.tfw file and 
the selected image coordinate system (WGS84 / Pseudo-Mercator).

20.	 To save the reference file and image file (although the image has not been modified as such), choose File > Save 
in the Adobe Photoshop main menu. The reference file, Rio de Janeiro.tfw, is saved in the same folder as the image 
file. Click Yes in the warning message regarding the storage of point data

21.	 Close all documents and continue with the next exercise.



16 Geographic Imager 3.0 Tutorial Guide

Quick Georeference

Quick Georeference is a fast method to georeference an image. This method requires two conditions:

•	 The image is not rotated (image aligned to True North).
•	 Only two points are needed to georeference, however these points must not contain the same coordinate 

in either the X or Y pixel or world unit (i.e. two points cannot be aligned on the same X or Y axis on either the 
image or world system).

1.	 In Adobe Photoshop, open EuropeTR.tif. The image is not rotated and is aligned to True North.
2.	 In the Geographic Imager palette options menu, choose Preferences. The panel options menu button is located at 

the top-right corner of the panel. 
3.	 Uncheck the Use internal referencing format if available check box and click OK.

4.	 In the Geographic Imager palette, click the Georeference button. 

5.	 In the Georeferencing dialog box, click the Add Control Point button  twice. In the table below, type the pixel 
coordinates (PX and PY) and world coordinates (WX and WY in decimal degrees) of two points located at the 

Northeast and Southwest corners of the image:

Southwest point (Point 2)
PX = 0, PY = 452
WX = -2.89 WY = 54.98

Northeast point (Point 1)
PX = 419, PY pixel = 0
WX = 1.76, WY = 60.00

Notice that the world coordinates expand to three decimal places. This happens because the Projected Precision 
is set to 3 decimal places.
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6.	 Click the Quick Georeference button and select the option By Two Reference Points (North/South aligned).

The image is now georeferenced and two additional reference points are added. If necessary, click and drag 
the horizontal line below the image view to adjust the size of the table. Notice that there are no pixel or world 
coordinate errors. 

7.	 In the Format frame, click the Image Coordinate System Specify... link.
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8.	 In the Input Format dialog box, click the Specify button. In the Specify Source Coordinate System dialog box, 
expand the Coordinate Systems > Geodetic > World category, select the WGS 84 coordinate system and click OK.

9.	 Click OK to close the Input Format dialog box.

The Format frame coordinate information is updated.

10.	 In the Georeferencing dialog box, click OK to save the settings.

The document was successfully georeferenced.

11.	 Keep this image open for the next exercise.
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Convert to GeoTIFF
1.	 With EuropeTR.tif as the active document, open the Geographic Imager palette options menu and choose 

Convert to GeoTIFF. 
2.	 In the Save dialog box, specify a name and location to save the GeoTIFF. Specify the name of the image as 

EuropeTRCrop.tif and click Save.

The reference information is saved in the new GeoTIFF file and is displayed in the Geographic Imager palette.

3.	 Keep this document open for the next exercise.
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GeoCrop

The GeoCrop function crops georeferenced images based on defined crop areas.

1.	 With EuropeTRCrop.tif as the active document, click the GeoCrop button in the Geographic Imager palette.
2.	 In the GeoCrop dialog box, choose Geodetic from the Unit Type drop-down list. Leave the Coordinate Format as 

Decimal Degrees and type in the following values:

Top-left corner		  Bottom-right corner
Long: -2.766 deg	 Long: -1.655 deg
Lat: 56.094 deg		 Lat: 55.229 deg

The crop area marquee (dashed red border shown in the image preview) is drawn to the coordinates specified 
above. This functions similarly to the Adobe Photoshop crop tool. Resize it to change the crop area.
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3.	 Click and drag a corner of the crop area marquee to resize it.

As the marquee is resized, the corner coordinate values are updated.

4.	 Click OK to complete the GeoCrop.

5.	 Close all open documents without saving.
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GeoCrop Import

The GeoCrop Import function is similar to the GeoCrop function in the previous exercise. The difference is that an 
image does not have to be opened before cropping. Instead, GeoCrop Import opens the GeoCrop dialog box first, 
then crops the image during an Adobe Photoshop import. It may be useful for images that would require a long 
load time.

1.	 In the File menu, choose Import > GeoCrop Import.

2.	 In the GeoCrop Import - Select a file dialog box, select the EuropeLL.tif file from the Geographic Imager tutorial 
data folder and click Open.

The GeoCrop dialog opens with a preview of the EuropeLL.tif image.
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3.	 In the image preview, click and drag the mouse to draw a crop marquee. Change the Unit Type to Geodetic.

The Top-left and Bottom-right Corner boxes are populated with the coordinates from the crop marquee.

4.	 Click OK to complete the crop.

The image is imported and cropped.

5.	 Close all open documents without saving.
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Import DEM File

Import DEM files easily using Geographic Imager. Some DEM files contain background or water areas (usually at 
a zero height) and need to be isolated before it can be styled. To achieve this, background pixels areas have to be 
defined in the Import DEM file dialog box advanced settings.

6.	 In Adobe Photoshop, browse to the Tutorial data folder and open Yukon Water.dem.
7.	 In the Import DEM file dialog box, click the Create New Schema button . 

This opens the Edit DEM Schema dialog box. The Schema Name is already populated with the name of the file. It 
also populates the Lowest and Highest Elevation values according to the DEM’s data range.

8.	 Since these values do not need to be modified click OK to close the Edit DEM Schema dialog box.

The Select Schema now reflects the data range of the DEM.
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9.	 In the Import DEM file dialog box, click the Advanced button.

The Unique values list is currently set to Display as transparent pixels. The value -32767.00 is a predefined value 
that represents no data. This value can not be deleted and is common to all DEM files. To display elevations as 
transparent pixels populate this list with elevation values. This is not required for this exercise.

10.	 Choose Display as background pixels from the Unique values drop-down list and click the Add new value 
button . A new value is created. Double-click <new value> and type in a value of 0. 

11.	 Click OK to close the Advanced DEM Schema Settings and Click OK to accept the settings of the Import DEM file 
dialog box to finish the import.
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The chosen custom DEM schema maps the range of elevation to the Adobe Photoshop grayscale colour-space, 
displaying the highest contrast possible. The Advanced DEM Schema Settings created a layer titled Background 
where all elevations with a value of 0 are displayed as black. If multiple values are used to display background 
pixels, each value will be a different shade of black.
Since the water layer is now isolated, use Adobe Photoshop tools to assign it a different colour. Similarly, a 
gradient map can be applied to the elevation data layer.

12.	 Close all documents without saving.

Reset Import DEM File Schema and Advanced Settings

Custom DEM schema settings and Advanced DEM Schema Settings are saved even after an Adobe Photoshop 
session is closed. Both settings will be applied to each DEM image opened if values are not deleted.

1.	 Reopen the Yukon Water.dem file (or any DEM file).
2.	 In the Import DEM file dialog box, choose Auto-stretched from the Select Schema drop-down list.
3.	 Click the Advanced button to open the Advanced DEM Schema Settings dialog box.
4.	 Choose Display as background pixels from the Unique values drop-down list and select the 0.00 entry (or any 

other entries). Click the Remove selected value(s) button  and click OK to close the Advanced DEM Schema 
Settings dialog box.

5.	 Click OK to close the Import DEM file dialog box to finish the import.
6.	 Close the document without saving.

Custom DEM schema settings and Advanced DEM Schema Settings are now reset.
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Using Actions with Geographic Imager

This exercise demonstrates how to automate Geographic Imager by recording an action that opens an image and 
transforms the coordinate system to WGS 84. See Chapter 10 - Automating Geographic Imager for more details.

Note:	 Actions should only be used on the computer it was created on. Actions are not cross platform and use 
absolute paths.

1.	 In the Adobe Photoshop menu, choose Window > Actions to open the Actions panel.
2.	 In the Action panel option menu (top right corner), choose New Set. Rename it Open - Transform WGS 84 and click OK. 

This creates an action set folder to store the action.
3.	 Select the new action set folder and choose New Action from the Action panel option menu. Rename the action 

to EuropeTL to WGS 84. 

A function key and colour for the action can be set, however, it is not needed for this exercise.

4.	 Click Record to create the action.

Notice that the red Begin recording button in the Actions panel is enabled. From this point on, all operations will 
be recorded to the action until it is stopped.

5.	 In the Adobe Photoshop menu, choose File > Open. Browse to the folder location of the tutorial images and 
open EuropeTL.tif.

6.	 Choose File > Automate Menu > Geographic Imager: Transform. In the Transform dialog box, perform a coordinate 
system transformation to WGS 84.

7.	 In the Action panel, click the Stop Playing/Recording button. Notice the action steps are recorded beneath the 
action name.

8.	 To play back the action, close the image without saving, select the EuropeTL to WGS 84 action and click the Play 
button in the action panel.

Congratulations, you have completed the Geographic Imager Tutorial Guide. Move onto the Adobe Photoshop 
exercises in the next section. Also see the Geographic Imager User Guide for more detailed information.
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Adobe Photoshop Tutorial Exercises

The following tutorial exercises use existing Adobe Photoshop functions to manipulate spatial imagery to create 
affects such as shaded relief, colour ramps, 3D  elevation models, false-colour composite and pan sharpened 
images. In addition, learn how to record measurements with the Ruler Tool and resample and sharpen images.

These tutorial exercises differ from the previous set of exercises because they mainly involve the use of Adobe
Photoshop tools, functions and filters. Geographic Imager allows non-native formats such as DEM files, MrSID, ECW 
and JPEG 2000 to be imported streamlines cartographic work flow.

These exercises are only examples of what Geographic Imager for Adobe Photoshop is able to do. Combined with 
creative uses of both sets of tools, a wide range of image manipulation techniques are achievable.
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Generate Shaded Relief

Creating shaded relief has always been a popular cartographic effect. It represents terrain with variations of tone 
that give it a three dimensional effect. With Geographic Imager, common digital elevation model (DEM) formats 
supported in Adobe Photoshop can be used in a streamlined manner. This exercise explains the steps needed to 
create a shaded relief effect using a DEM and exporting it as a georeferenced image.

1.	 In Adobe Photoshop, open Rocky Mountains.dem from the User Guide, Tutorial & Data\Tutorial Data\Rocky Mountain 
3D Landscape Data folder.

2.	 In the Import DEM File dialog box, use the Auto-stretched schema. A brief description of the schema is 
displayed in the dialog box. For more information, see Chapter 12 - DEM Schema in the Geographic Imager User 
Guide. Click OK.

3.	 Chose File > Scripts > Browse and navigate to the following location:
..\User Guide, Tutorial & Data\Tutorial Data\Sample Scripts

4.	 Choose the Shaded Relief.jsx script and click OK. This script can be used on any DEM to create the shaded relief effect.

This is what the script does:
•	 The image is converted to an 8-bit RGB from a 16-bit grayscale image. This mode is needed to apply the lighting 

effects used later.
•	 The image is then selected and copied to the clipboard.
•	 An alpha channel (Alpha 1) is created, filled with the colour white and the selection is copied to the alpha channel.
•	 A new layer called Bump Map is created with the blend mode set to Overlay and filled with the colour white.
•	 The Filter > Render > Lighting Effects filter is then applied to the Bump Map layer. These lighting effects create 

shadows and highlights that represent shaded relief.
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Experiment with the Lighting Effects filter settings. Choose Filter > Render > Lighting Effects to open the filter dialog 
box. These settings were generated by the script and can be used as a starting point for a custom effect. Notice 
that the script sets a northwest light source. Please note that the Texture Channel must be set to the alpha channel 
(Alpha 1) created with the original image. Click OK to apply these custom lighting effects. The lighting effects can be 
applied multiple times for increased contrast.

5.	 In the Geographic Imager palette options menu, click Convert to GeoTIFF. 

GeoTIFF is compatible with other GIS software. 
Note:	 Geographic Imager 3.0 cannot save to DEM formats at this time. Instead, save the georeferencing in one of 

the supported formats (GeoTIFF, TFW, TAB, etc).

6.	 Leave it open for the next exercise. 
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Apply a Colour Ramp

Adobe Photoshop provides excellent support for creating, customizing and editing gradients. Avenza has provided 
some gradients that can be used for colour ramps. This exercise explains the steps needed to apply a colour ramp to 
a DEM.

1.	 Open or continue with the image saved from the Generate Shaded Relief exercise.
2.	 Ensure the Options toolbar is visible (if not, choose Window > Options).
3.	 In the Options toolbar, click the Gradient tool and click the colour ramp to open the Gradient Editor dialog box.

4.	 Click the Load button, navigate to the Geographic Imager Tutorial folder and load Colour Ramp Examples.grd

Gradients are added to the Presets. Hover over the gradients to see their names (Elevation 1 to 7).

Note:	 The gradient maps provided are all using equally spaced colour ranges. To better depict some areas of a 
DEM, irregular colour ranges may give a better result.

Note:	 The image histogram (choose Window > Histogram) illustrates the distribution of pixels per colour intensity 
level, which is directly related to the DEM height distribution. It can be used as a guide to construct colour 
maps adapted to the DEM.

5.	 Click OK to close the Gradient Editor.
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6.	 In the Layers panel, select the Rocky Mountains.dem layer (not the Bump Map layer). The gradient map will only 
be applied to the selected layer.

7.	 Create a new gradient map adjustment layer by choosing Layer > New Adjustment Layer > Gradient Map. Name 
the layer Colour Ramp, leave the Mode as Normal and click OK.

An adjustment layer called Colour ramp with a default gradient is created. The advantage of creating the 
gradient on the adjustment layer is that it can be edited (multiple times) without affecting the original image.
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8.	 In the Adjustments panel, click the colour ramp drop-down list to choose one of the preset colour ramps.

The shaded relief image is coloured with the chosen colour ramp. Experiment with available gradients or create 
your own. Select any gradient to apply it to the image.

Note:	 In Adobe Photoshop CS3, a gradient map can be chosen immediately after creating a new adjustment layer. 

Note:	 Setting the Blending Mode to Difference will prominently display the difference in elevations. This mode 
compares the difference between pixel values; large differences lighten the colour and small differences 
darken the colour. This will alter the colour ramp so it is best used for display purposes only. It can be used as 
an indictor that the colour ramp displays the elevation differences in the detail required.

Experiment with these gradients or create your own. Select any gradient to apply it to the image.

9.	 Close all open documents without saving.
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Create a 3D Representation with an Orthographic Texture

Note:	 This tutorial can only be run on Adobe Photoshop CS4 and on a computer with a video card that supports OpenGL 
to make use of the 3D functionality. In Windows, choose Edit > Preferences > Performance to see if your video card sup-
ports it. In Mac OS X, choose Photoshop > Preferences > Performance. GPU settings are enabled if supported.

How to run the script using the sample data:

1.	 In Adobe Photoshop, choose File > Scripts > Browse and navigate to the following locations:
..\User Guide, Tutorial & Data\Tutorial Data\Sample Scripts

2.	 Select the Rocky Mountains.jsx script and click Load.

The script will run and perform the following tasks automatically:
•	 Open a DEM
•	 Create a 3D plane from the data
•	 Modify the vertical exaggeration of the 3D scale
•	 Position the 3D model
•	 Load and drape a texture image (ortho image) on the 3D model
•	 Set the final 3D model position
•	 Modify Canvas size for final output
•	 Add a new layer and draw a gradient to represent the sky

Note:	 When creating a 3D representation, georeferencing is not maintained.

The 3D elevation model is now ready for the final output.
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For an additional effect, the 3D elevation model can be viewed in stereoscopic 3D.

1.	 In the Adobe Photoshop menu, choose 3D > Render Settings.
2.	 In the 3D Render Settings dialog box, check the option for Stereo type.
3.	 If viewing the image using classic red-blue glasses, specify the Stereo type to Red/Blue. If using a lenticular lens 

select Vertical Interlaced.
4.	 Set the Parallax to 80. Parallax adjusts the distance between the two stereo cameras. A higher value increases 

the three-dimensional depth but reduces the depth of field, making items ahead or behind the focal plane 
appear out of focus. 

5.	 The Focal Plane determines the position of the focal plane relative to the center of the image bounding box. 
Negative values move the plane forward and positive values move it backward. Leave the Focal Plane at its 
default of 0.

6.	 Click OK to complete the 3D render settings.

The image is now ready for stereoscopic 3D display.
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Modify the Rocky Mountains.jsx elevation model script to accommodate user data. This script is only compatible with 
Adobe Photoshop CS4. To perform this tutorial with data other than the sample data, the following parameters 
need to be satisfied:

•	 A DEM and texture image are needed of the same area to create one 3D model
•	 One of the images should be transformed to match the other images size, pixel size, and coordinate system
•	 The script needs to be modified to reflect the location of the images.

1.	 In the operating system file browser, go to the following location:
..\User Guide, Tutorial & Data\Tutorial Data\Sample Scripts

2.	 Open the Rocky Mountains.jsx script in a text editor.
3.	 At the beginning of the script, there are two paths that need to be modified to enable this script to be used with 

custom data. Modify the appropriate paths depending on the operating system (Windows or Mac).
•	 Modify the first path (yourPath) to specify the location of the elevation model (DEM, DTED)
•	 Modify the second path (yourPath2) to specify the location of the texture or image to be draped over the 

elevation model

4.	 Once the correct paths are modified, save the script using a different file name. Run the saved script by 
choosing File > Scripts > Browse. Find the location of the saved scripts and click Load.

5.	 Review your image and make adjustments to the script as necessary.
6.	 Close all open documents before continuing with the next exercise.



37Geographic Imager 3.0 Tutorial Guide

The Ruler Tool

Analysis tools can be used to record and export measurements with georeferenced images. These tools were 
originally introduced in Adobe Photoshop CS3 and were designed for the medical community. They also serve as 
valuable tools for cartographers.

1.	 In Adobe Photoshop, choose File > Open and browse to the Landsat 7 Multispectral folder and open Band 8 
(Panchromatic), 15 meters.tif.

This is an image of downtown Toronto circa 2004. The projected coordinate system is NAD 83 UTM Zone 17N in 
meters. The Geographic Imager palette displays the pixel size. A precise measurement is dependent on the pixel 
size. For this example, 1 pixel is equal to 15 x 15 meters and provides a moderately accurate measurement.

Note:	 Non-square pixels prevent the recording of correct measurements when using measurement tools. This can 
be rectified by using the Geographic Imager Transform function and changing the Pixel Options to keep 
pixels square.

2.	 From the Analysis menu, choose Set Measurement Scale > Custom.
3.	 In the Measurement Scale dialog box. Set the Logical Length to 15.
Note:	 Up to four decimal places can be entered in the custom field to provide enough accuracy for all images.

4.	 Type the Logical Units as meters. 

The Logical Units box stores what unit the pixel size is in. A custom preset measurement scale is useful when 
using images with the same pixel size.

5.	 Click OK to close the dialog box.
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6.	 Before measuring, choose Window > Measurement Log to open the Measurement Log panel. The panel appears 
either as floating or docked at the bottom of the screen.

7.	 In the Adobe Photoshop Tools panel, select the Ruler Tool . If not visible, click and hold the button to display 
the flyout menu). It is also accessible by choosing Analysis > Ruler Tool.

8.	 Take a measurement of a section of Toronto. As shown below, click anywhere on the map and drag the Ruler 
Tool. Click again to complete the measurement. A measurement line is drawn on the image.

9.	 In the Measurement Log panel, click Record Measurements.

For the above example, the distance recorded is approximately 2720 meters (Length column). Your results may 
vary depending on how long of a ruler line you drew.

The Ruler Tool is not the only tool used to record measurement. Use the Lasso, Magic Wand and Quick Select tools 
to select an area and click the Record Measurement button to record it to the Measurement Log. All measurements 
can be exported to a tab delimited Unicode text file (select the desired rows and click the export button in the up-
per right corner of the Measurement Log panel.

10.	 Close the document without saving.
Note:	 Remember the resolution of the image will reflect how accurate the measurements will be. Analysis tools can 

not be used with non-square pixels because each side has a different length.
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Create a False-Colour Composite

Another powerful remote sensing tool in Adobe Photoshop is the ability to create a false-colour composite image. 
Multispectral images contain information outside the visible electromagnetic spectrum. To use this information, the 
wavelengths outside the visible spectrum need to be reassigned to the visible spectrum so that it is visible to the 
human eye. This tutorial will create a false-colour composite of downtown Toronto and surrounding suburban areas.

Often multispectral satellite images will consist of several greyscale images, with each image containing one of the 
wavelengths or bands of the electromagnetic spectrum. These images need to be combined into one image. The 
Adobe Photoshop function called Merge Channels merges images to create false-colour or true-colour composites. 
You may easily identify distinct features by their unique spectral signature.

1.	 In Adobe Photoshop, browse to the Landsat 7 Multispectral folder and open the following images:
•	 Band 2 (Green), 30 meters.tif
•	 Band 3 (Red), 30 meters.tif
•	 Band 4 (Near Infrared), 30 meters.tif

Note:	 When creating false-colour composites, images must be of the same image resolution and have the same 
spatial extents. If the images need to be cropped, it is recommended to use the Geographic Imager GeoCrop 
function to assure that the extents of the images remain consistent.

2.	 From the Windows menu, choose Channels to open the Channels panel. 
3.	 In any active document window, click Merge Channels from the Channels panel options menu.

4.	 In the Merge Channels dialog box, select RGB Color in the Mode drop-down list and click OK.
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5.	 In the Merge RGB Channels dialog box specify the following channels:
•	 Red: Band 4 (Near Infrared), 30 meters.tif
•	 Green: Band 3 (Red), 30 meters.tif
•	 Blue: Band 2 (Green), 30 meters.tif

6.	 Click OK to complete the merge.
Note:	 A reference file called Untitled-1.tfw is created in the default reference format specified in the Geographic 

Imager Preferences dialog box.

 

A false-colour composite image with georeferencing is created. The band combination chosen makes vegetation 
appear in shades of red because vegetation reflects a lot of near infrared light. The brighter the red, the healthier 
the vegetation. Urban areas appear blue-grey. The bright red areas at the top of the image belong to the prestigious 
Rosedale Golf Club.

7.	 Close any open documents without saving.
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More about Landsat 7 band combinations

R,G,B Description

3,2,1 The “nature colour” combination. It provides the most water penetration.

4,3,2 Standard “false-colour” combination. Vegetation shows in red.

7,4,2 The “nature-like” combination. Sand, soil and minerals show in multitude of colour. Fires would appear in 
red. It provides clear imagery in desert region.

7,5,3 The “nature-like” combination. Sand, soil and minerals appear in variety of colour.

5,4,1 Good for agricultural studies. Healthy vegetation shows in bright green colour.

7,5,4 Provides best atmospheric penetration. Vegetation shows in blue. Useful for geological study.

7,3,1 Rocks may appear in variety of colour. Good for the geological study.

Note:	 Some multispectral images may be provided as a single image that stores extra channels (called alpha chan-
nels in Adobe Photoshop). To create false-colour composites from these images in Adobe Photoshop, the 
channels must first be split into single gray scale images (Channels panel option menu > Split Channels). Then 
channels can be merged and reordered as described above.

Pan Sharpen

Another useful tool Adobe Photoshop provides is the ability to intelligently resample images. Pan sharpening (short 
for panchromatic sharpening) a single band is used to increase the spatial resolution of a multispectral image. A 
multispectral image contains a higher spectral resolution of a panchromatic image, while often a panchromatic im-
age will have a higher spatial resolution than of a multispectral image. A pan sharpened image represents the best 
of both worlds which is essentially a sensor fusion which gives a multispectral image higher spatial resolution.

1.	 In Adobe Photoshop, browse to the Landsat 7 Multispectral folder and open the following images:
•	 Band 8 (Panchromatic), 15 meters.tif
•	 Band 1 (Blue-green), 30 meters.tif
•	 Band 2 (Green), 30 meters.tif
•	 Band 3 (Red), 30 meters.tif

In this exercise, the panchromatic image will be combined with a multispectral image in true colour, however, any 
false-colour composite combination can be used.

2.	 From the Windows menu, choose Channels to open the Channels panel. 
3.	 In any 30 meter resolution active document window (Band 1, 2 or 3), click Merge Channels from the Channels 

panel options menu.
Note:	 If Band 8 is chosen, Merge Channels will be disabled.
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4.	 In the Merge Channels dialog box, select RGB Color in the Mode drop-down list and click OK.
5.	 In the Merge RGB Channels dialog box specify the following channels:

•	 Red: Band 3 (Red), 30 meters.tif
•	 Green: Band 2 (Green), 30 meters.tif
•	 Blue: Band 1 (Blue-green), 30 meters.tif

6.	 Click OK to complete the merge.

Since the merged image is at 30 meter resolution, it is necessary to resample it to match the resolution of the 
panchromatic image (15 meter resolution).

7.	 With the merged document window active, choose Image > Image Size.
8.	 Ensure Constrain Proportions and Resample Image check boxes are checked. Choose Bicubic (best for smooth 

gradients) as the resampling method.
9.	 In the Pixel Dimensions frame, select percent from the units drop-down list.
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10.	 Enter 200 in the width dimension (height automatically changes to 200 due to constrain proportions) and click 
OK to complete image scaling.

11.	 From the Image menu, choose Mode > Lab Color.
12.	 In the Channels panel options menu, click Split Channels.

The merged image is split into three images: Lightness, a and b.

The split images have an “_L”, “_a”, or ,”_b” appended to the end of the document name. The a and b channels 
carry colour information and the idea is to substitute the panchromatic image for the Lightness channel. Adobe 
Photoshop CS3 users will not see docked windows, only floating ones.

The following step involves some trial and error. The intent is to make the image brightness and contrast match the 
Lightness channel as much as possible. Ignore areas of water or vegetation and concentrate on roads and build-
ings. Often panchromatic images contain data that extend into the infrared, therefore vegetation and areas of water 
appear differently. The higher resolution of the panchromatic image, the more contrast it will appear to have.

Note:	 Ignore vegetation and areas of water because panchromatic images often contain near infrared data.

13.	 Make Band 8 (panchromatic), 15 meters.tif active and create a Brightness/Contrast adjustment layer. Choose Layers > 
New Adjustments Layer > Brightness/Contrast.

14.	 In the Brightness/Contrast settings (Adjustment panel for CS4), adjust Brightness to +100 and Contrast to +35 
and click OK.
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15.	 Create a second adjustment layer. Choose Layers > New Adjustments Layer > Levels.
16.	 In the Levels settings (Adjustment panel for CS4), adjust the midtone input level to 0.90 and the highlight input 

level to 230 and click OK.

17.	 To properly merge channels, the layers need to be flattened first. Choose Layer > Flatten Image.
18.	 In the Channels panel options menu, click Merge Channels. In the Merge Channels dialog box, select Lab Color in the 

Mode drop-down list and click OK.

19.	 In the Merge Lab Channels dialog box specify the following channels:
•	 Lightness: Band 8 (Panchromatic), 15 meters.tif
•	 a: Untitled-1_a
•	 b: Untitled-1_b

Note:	 The Untitled documents were created from splitting the channels in step 14. Untitled documents may not be 
appended with the number 1, however, be sure that the final character corresponds to the channel e.g. a = 
“Untitled-4_a”.

20.	 Click OK to complete the merge.
21.	 Choose Mode > RGB to convert the image back to RGB mode.
22.	 Leave the document open for the next exercise.
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Note:	 This exercise is a guide to enhance images for display or printing purposes, this method involves subjec-
tive judgment to pixel colour adjustments and should not be used for scientific purposes. The colours of 
the pan-sharpened image will look different from the original RGB image because panchromatic data (from 
Landsat 7) extend into the infrared, most notably vegetation and areas of water.
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Resample and Sharpen

Adobe Photoshop sharpen filters can increase the detail of the image. The Sharpen filter menu has a variety of 
sharpening tools. These tools also involve some trial and error to achieve enough sharpening without overdoing it. 
Two sharpening filters are explained below.

The Unsharp Mask 

This filter sharpens an image by increasing contrast along the edges of an image. It locates pixels that differ in value 
from the surrounding pixels, this option can be modified by changing the threshold. The radius of the region to 
which each pixel is compared is also an option that can be modified.

Smart Sharpen

This filter has more advanced controls not available in the Unsharp Mask filter. This filter will allow control over the 
amount of sharpening that occurs in shadow and highlight areas. The document should be viewed at 100% to get 
an accurate view of the sharpening.

•	 Amount: Sets the amount of sharpening. A higher value increases the contrast between edge pixels, giving the 
appearance of greater sharpness.

•	 Radius: Determines the number of pixels surrounding the edge pixels affected by the sharpening. The greater 
the radius value, the wider the edge effects and the more obvious the sharpening.

•	 Remove: Sets the sharpening algorithm used to sharpen the image. Gaussian Blur is the method used by the 
Unsharp Mask filter. Lens Blur detects the edges and detail in an image, and provides finer sharpening of detail 
and reduced sharpening halos. Motion Blur attempts to reduce the effects of blur due to camera or subject 
movement. Set the Angle control if you choose Motion Blur.

•	 Angle: Sets the direction of motion for the Motion Blur option of the Remove control.
•	 More Accurate: Processes the file more slowly for a more accurate removal of blurring.

In the Smart Sharpen dialog box, click the Advanced option to display the Shadow and Highlight tabs. Adjust sharp-
ening of dark and light areas using these tabs. If the dark or light sharpening halos appear too strong, reduce them 
with these controls, which are only available for 8‑bits and 16‑bits-per-channel images:

•	 Fade Amount: Adjusts the amount of sharpening in the highlights or shadows.
•	 Tonal Width: Controls the range of tones in the shadows or highlights that are modified. Move the slider to the 

left or right to decrease or increase the Tonal Width value. Smaller values restrict the adjustments to only the 
darker regions for shadow correction and only the lighter regions for highlight correction.

•	 Radius: Controls the size of the area around each pixel that is used to determine whether a pixel is in the 
shadows or highlights. Moving the slider to the left specifies a smaller area, and moving it to the right specifies 
a larger area.
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1.	  With the image still open from the previous exercise, choose Filter > Sharpen > Smart Sharpen.
2.	 Set the following parameters in the Smart Sharpen dialog box:

•	 Set the Amount to 15%
•	 Set the Radius to 2.0 pixels
•	 Set Remove to Lens Blur
•	 Check the More Accurate checkbox

3.	 Click OK.

Features appear to have more detail when compared to the image prior to sharpening. Again, this will involve some 
trial and error if the results are not satisfactory, experiment with settings if more sharpening is needed.

Congratulations, you have completed the Adobe Photoshop Tutorial Exercises. For more in-depth information on 
Geographic Imager tools and features, see the Geographic Imager User Guide.
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