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Welcome

Avenza welcomes you to mapmaking in the 21st century!

Combined with Adobe Illustrator, MAPublisher has revolutionized the art of mapmaking by allowing spatial 
data files to be used to create maps inside a vector graphics program. MAPublisher allows all your cartograph-
ic tasks to be performed where they should be done; in a powerful graphics environment.

MAPdata Canada allows users of MAPublisher to create projects using data from all the Canadian provinces 
and territories.

This tutorial manual assumes that the user is familiar with Adobe Illustrator and has at least a basic
understanding of geographic information systems (GIS) terminology and concepts. The exercises in this 
manual should be used in conjunction with the MAPublisher 7 User Guide and Adobe Illustrator CS2/CS3, 
however the datas itself may be used with any version of MAPublisher and either Adobe Illustrator or 
Macromedia Freehand. 

By following these tutorials you will learn how to import, reproject and stylize the MAPdata Canada data.  
This will show the user the basics of creating maps using MAPublisher in Adobe Illustrator. Together        
MAPublisher and Adobe Illustrator will give you a totally integrated cartographic design software system 
with graphics tools and geographic functions present in the same work environment.

TUTORIAL DATA

All the exercises in this guide will use GIS data supplied in the Tutorial Data folder on your MAPdata Canada  
DVD or in the electronic download.  The data used in this guide is a sample from the MAPdata Canada pack-
age. 



1-i: IMPORTING MAPDATA CANADA FILES

1. Start by creating a new Illustrator page in portrait orientation=lettersize
2. Select File > Import Map Data > Simple… to open the MAPublisher Simple Import dialog
3. Select ESRI Shape from the Format dropdown
4. Click the ‘...’ (Browse) button to open the data source browser
5. Locate and select all the data in the MAPdata Canada Sample folder and click Open

6.  Note the Source Coordinate System is currently undetected.  This can be set at this point in the process 
 or after the data has been imported.  To set the Source Coordinate System in the Import dialogue click the   
 Specify button
7. The Specify Source Coordinate System dialogue will open.  To set the correct coordinate system for 
 MAPdata Canada please navigate to the following location in the dialogue: 
 Coordinate Systems > Geodetic > North America > Canada > NAD83 (CSRS)

8.  Click OK in the Specify Source Coordinate System dialogue to confirm the coordinate system
9. Click OK in the Simple Import dialogue to import the data
 The Simple Import dialog closes and the selected map files are imported. The map has been imported to 
 automatically fit to the size of the page
10. Open the layers palette and ensure that the area layers are on the bottom, the line layers are in the middle,   
 and the points are at the top of the illustrator layer hierarchy
11.  Notice that there is one new data layer in the Illustrator Layers palette for every imported file. There is
 also a MAP Views palette under which all the imported data layers reside. 
12. To open the MAP View Palette go to Window > MAPublisher Palettes > MAP Views.  See more on MAP   
 Views on page 53 in the MAPublisher User Manual or contact Avenza Support (http://www.avenza.com/  
 support.html)

MAPublisher Tip: The source coordinate system is the coordinate system associated  with the data in it’s current state. This information is derived 
either from the data itself or may be obtained and assigned manually. Always obtain this information from your data provider.

Importing MAP Data
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2-i: COORDINATE SYSTEM TRANSFORMATIONS

1. The data has now been imported and it is ready to be projected.  To do this double click on the MAP View   
   that holds the newly imported data and your MAP View Editor will open.
2. Rename your MAP View by entering “Niagara Tutorial”
3. In the MAP View Editor there is a section for the Source Coordinate System where you can specify or change  
 it.  This can be used if the coordinate system was not set when importing the data or it needs to be changed
4. To project your data from its current unprojected coordinate system (NAD83 (CSRS)) to a projected coordinate  
 system enable the Perform Coordinate System Transformation checkbox

5. In the Perform Coordinate System Transformation section select the Specify button.  
6. The Specify Destination Coordinate System dialogue will open.  The destination coordinate system depends on  
 your mapping purposes.  For this exercise please navigate to the following location in the dialogue: 
 Coordinate Systems > Projected > UTM > NAD83 (CSRS) > NAD83 (CSRS)/UTM zone 17N
	 Note:	This	coordinate	system	will	not	work	for	all	MAPdata	Canada	data	as	it	is	specific	to	a	UTM	Zone
	 location.		For	more	information	on	UTM	Zones	please	go	to	page	A1/47	in	the	MAPublisher	User	Manual.
7. Click OK in the Specify Destination Coordinate System dialogue and then again in the MAP View Editor.
 The data will now be projected into NAD83 (CSRS)/UTM zone 17N

Data unprojected in NAD83 Lat/Long

Data projected in NAD83/UTM Zone 17N

Projecting Your Data
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1.  The Graphic Styles needed for this exercise will have to be loaded before the next step.  To do this go to   
 Window > Graphic Styles.  Now go to Open Graphic Style Library > Other Library... Browse to the Tutorial  
 folder and select the graphic styles.ai file
2. When the new graphic style palette (with the imported styles) opens, shift select them all and drag them into the  
 Graphic Styles palette
3. Go to Window > MAPublisher Palettes > MAP Stylesheets to open the Stylesheets palette
4. Click on the “Create New MAP Stylesheet” button at the bottom of the palette and call it “Road” with a feature  
 type of Line
5. To stylize data in this stylesheet drag the ontario niagara roads-j_line layer into the Road stylesheet and double  
 click on the Road Stylesheet

3-i: APPLYING STYLESHEETS TO YOUR ROADS

Applying Stylesheets to Your Data

Roads before MAP Stylesheets Roads after MAP Stylesheets

6 Applying Stylesheets to Your Data

6. Click on the Add button to add the first rule. Change the name of this rule from ‘Rule 1’ to ‘Highway’.  Use the  
 “Highway” Graphic Style that was added in step 1 as the style for this rule. 
7. Select the “Highway” style from the style dropdown list.
8. Click on the advanced expression option and then select the expression drop down and the browse button
9. In the Edit Expression window click on the expand Expression Components and then double click on the   
 “Class” attribute column heading found in the “Objects” list followed by “=” which is a button located on the  
 top of the dialogue.  In the description window select  “Display Unique Values” and select “HI”
 The expression should look like this: CLASS= “HI”
10. Click OK in the Edit Expression window
11. Now add rule 2 and call it Streets using the Graphic Style “Streets”
12. In the Edit Expression window double click on the “Class” attribute column heading followed by “=”.  In the  
 description window select  “Display Unique Values” and select “ST”
13. Following this expression click on “OR”.  Finish the expression to match the following:
 CLASS= “ST” OR  CLASS= “BT” OR  CLASS= “CON”
 This expression says that we want to stylize streets, bridges & tunnels, and connector roads
14. Click OK in the Edit Expression window and in the Edit Stylesheet window
 This will apply the select graphic styles to the requested attributes



1. Click on the “Create MAP Stylesheet” button and call it “Railway” with a feature type of Line
2. To stylize data in this stylesheet drag the ontario niagara rail_line layer into the Railway stylesheet and double  
 click on the Railway Stylesheet
3. Click on the add button to add a rule.  This rule will be called Railway and it will use the “Rail Lines”   
 Graphic Style
4. Click on the advanced expression option and then select the expression drop down and the browse button
5. In the Edit Expression window double click on the “Owner” followed by “=”.  In the description window select  
 “Display Unique Values” and select “CN”
6. Following this expression click on “OR”.  Finish the expression to match the following:
 OWNER= “CN” OR  OWNER= “CPR” OR  OWNER= “NS”
7. Click OK in the Edit Expression window and in the Edit Stylesheet window

3-ii: APPLYING STYLESHEETS TO YOUR RAILWAYS

1. Click on the “Create MAP Stylesheet” button and call it “Utilities” with a feature type of Line
2. To stylize data in this stylesheet drag the ontario niagara utility_line layer into the Utilities stylesheet and   
 double click on the Utility Stylesheet
3. Click on the add button to add a rule.  This rule will be called Utility and it will use the “Utility Lines” Graphic  
 Style
4. In simple expression mode click on the expression drop down menu and create the following expression:
 “DESCRIPTIO = Power Transmission Line”
5. Click OK in the Edit Stylesheet window

3-iii: APPLYING STYLESHEETS TO YOUR UTILITIES

1.  The Symbols needed for this exercise will have to be loaded before the next step.  To do this go to    
 Window > Symbols.  Now go to Open Symbol Library > Other Library... Browse to the Tutorial    
 folder and select the symbols.ai file
1. Click on the “Create MAP Stylesheet” button and call it “Places” with a feature type of Point
2. To stylize data in this stylesheet drag the ontario niagara places_point layer into the Places stylesheet and   
 double click on the Places Stylesheet.
3. Click on the add button to add a rule.  This rule will be called Places and it will use the “Places” Graphic   
 Style.
4. Click on the expression drop down menu and create the following expression:
 “REGIONNAME = Ontario”
5. Modify the scale to be 150%
6. Click OK in the Edit Stylesheet window

3-iv: APPLYING STYLESHEETS TO YOUR PLACES
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Applying Graphic Styles to Your Data

1. Select the entire water layer and ensure that you have selected the fill in the Illustrator tool bar.
2. Open the swatch palette and select a blue colour for the fill.
3. Select the stroke in the Illustrator tool bar and select “none” so there is no stroke.
4. Perform the same task for the boundary layer replacing the blue with a light brown

4-i: APPLYING GRAPHIC STYLES WATER AND BOUNDARY 

1. Create a new layer called “Legend”
2. Drag this layer into your MAP View and assign it a feature type of Legend
3. Select one of the Stylesheets in order to export to a legend
4. Click on the options button in the MAP Stylesheets palette and select “Create MAP Stylesheet Legend”
5. Select the target layer as the Legend layer created in Step 1
6. The MAP Stylesheet legend will be placed in the lower left corner of your page
7. This object can be ungrouped and modified if needed.  To do this select the object and ungroup twice

5-i: PRODUCING A LEGEND FROM YOUR STYLESHEETS 

Creating Legends and Scale Bars

1. Click on the “Create MAP Stylesheet” button and call it “Airport” with a feature type of Point
2. To stylize data in stylesheets drag the ontario niagara airports_point layer into the Airport stylesheet and double  
 click on the Airport Stylesheet.
3. Click on the add button to add a rule.  This rule will be called Airport and it will use the “Airports” Graphic  
 Style.
4. Click on the expression drop down menu and create the following expression:
 “CODE = CSYN”
5. Modify the scale to be 75%
6. Click OK in the Edit Stylesheet window

3-v: APPLYING STYLESHEETS TO YOUR AIRPORTS

8 Applying Graphic Styles to Your Data



1. Create a new Illustrator layer and rename it Scale Bar.
2.  In the MAP Views palette, drag the Scale Bar layer to the Niagara Tutorial MAP View, setting the Feature   
 Type to Legend
3.  Set your desired font and font size using the Illustrator Character palette. For this example use an 8 pt font.
4.  Open the MAPublisher Scale Bar filter by going to Filter > MAP Legend > Scale Bar
5.  Choose a desired scale bar style using the Previous and Next buttons
6. Set the Advanced Options as follows:
7.  Set the Units dropdown list to Kilometer
8.  Enter a Label Interval of 5 kilometers
9.  Set the Number of Labeled Intervals to 5
10.  Set the Number of Intervals to Subdivide to 1, and the Number of Sub-intervals to 5
 These settings will create a scale bar that represents a total distance of 25 km, has 4 main cells each 
 representing 5 km and where the first cell is further divided into 5 smaller cells
13.  Set the Label Options as follows:
14.  Select the Display Scale value as above
15. Select the Display page to map units ratio checkbox
16.  Set the Page Units dropdown list to Centimeter
17.  Select the Display units to right of last interval label checkbox. These settings will create a scale bar with
 caption labels placed accordingly
18.  Click OK to create the scale bar. The Scale Bar will be placed on the page according to the defined settings

5-ii: PRODUCING A SCALE BAR 

Labelling Your Data

1.  Create a new layer in your Illustrator Layers palette and name this layer Road Names. Then drag this new   
 layer into the ‘Niagara Tutorial’ MAP View, setting the feature type to Text.
2.  Select a font and text size (8 pt recommended) for the labels you want to create using the Illustrator Character  
 Palette
3.  Using the MAP Selection Filter, select the roads to label.  A selection filter is used to select data based on an 
 attribute.  Making sure the ontario niagara roads-j layer is selected, go to Window > MAPublisher Palettes >  
 Selection Filters to open the MAP Selection Filters dialog.
4. Click on the “Create New Selection Filter” button at the bottom of the palette.  This filter can be named   
 “Roads” in the Name entry box.

 Data does NOT	have	to	be	selected	using	selection	filters,	you	may	use	manual	selection	as	well.		For	the	
	 purpose	of	this	exercise	selection	filters	are	used	to	locate	the	specific	roads	to	label.	You	may	select	based	on		
	 groups	such	as	road	class,	or	in	this	case	via	individual	names.

5.  Click on the Browse button then click the dropdown button to expand the Expression Components.
6.  Double click on the FULL_NAME column heading in the Objects under ontario niagara roads-j so that it is  
 entered into the expression entry box. Click on the ‘ = ‘ button and select “Display Unique Values” in the 
 description section. Select “20 Hwy” from the list.
7. Now select the “OR” function and repeat step 6 3x by inserting “Concession 2 Rd”, “Chippawa Creek Rd”, and  
 “Sodom Rd” for the road name. The finished expression should read as follows:
 FULL_NAME=	“Concession	2	Rd”OR		FULL_NAME	=	“20	Hwy”	OR		FULL_NAME=	“Sodom	Rd”	OR			
	 FULL_NAME=	“Chippawa	Creek	Rd”
8.  Click OK twice.
9.  The requested roads should now be selected.  To re-select the data click on the Apply as New Selection button  
 to perform the selection.
10. Go to Filter > MAP Legend > Feature Text Label.
11.  In the Feature Text Label Dialog box you must first set the options for MAPublisher to determine the attributes  
 that will be converted to labels. The Source Layer list will show the Line layer containing the selected data.

6-i: GENERATING LABELS FOR AN LINE LAYER USING FEATURE TEXT LABEL
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12.  The Column dropdown will be populated with the attribute structure of that layer. Set the
 Column dropdown list to whichever column you wish to draw the labels from. For this example, choose   
 Full_Name. This column contains the name of every road in the selected MAP Layer.
13.  Set the text layer to output the labels to. For this example choose the Road Names layer.
14. In label setting we can specify label preferences such as label position, alignment to lines of latitude, minimum
 font sizes and horizontal scaling to best place labels within polygons and paths. MAPublisher will place
 Line labels intelligently, depending on the curvature and length of the line string. Click the Line Labels button
 on the left to assign MAPublisher Line Label Settings.
15.  The Label Type option will allow you to specify how you would like the text placed on the Map. The “Follow  
 line” option will place text to the orientation of the line and the “Don’t follow line” option will place all text
 horizontally on the page.
16.  The Distance from Start option will allow you to specify where along the line you would like the label. Lets
 choose Auto and let MAPublisher place the text at the midpoint for straight lines. For curved lines this will find
 the smoothest portion of the curved line closed to the midpoint.
17.  By enabling Flip upside-down labels MAPublisher will automatically orient labels correctly, so lets leave this
 option enabled.
18.  By checking the Line Smoothing option, MAPublisher will create a smoothed path for each text object in the
 selected Text layer, and place the text along this path at the specified Offset value. The labels can then be
 dragged and positioned at any position along a line. For this example leave it unchecked because the streets
 are very linear.
19.  The Label Position option allows you to select the vertical position of the labels relative to the line. Three
 options are available for the vertical positioning of text labels: Baseline, Descender, and Center. Select
 Descender to place the labels on top of the generated text path.
20.  Labels can be modified if they exceed the length of the line in the current default font size. First check the
 Adjust label if larger than line option to activate the label ‘rules’. The order for the rules can be changed by
 clicking on the rule and then pressing the Up or Down button. Checking the Reduce font size option will allow
 you to reduce the size of the font to a specified minimum size in points. We can select 3 for this exercise.
21.  Checking Reduce horizontal scaling will allow text to be scaled down horizontally by the percentage specified.
 Leave this at 50%.
22.  Click OK.
23.  The roads that were previously selected have now been labeled.

6-i: GENERATING LABELS FOR AN LINE LAYER USING FEATURE TEXT LABEL - Con’t

10 Labelling Your Data

Labelled roads using Feature Text Label



1.  Create a new layer in your Illustrator Layers palette and name this layer ‘Place Names’. Then drag this new  
 layer into the ‘Niagara Tutorial’ MAP View, setting the feature type to Text.
2.  Select a font and text size (10 pt recommended) for the labels you want to create.
3.  Click on the MAP Tagger Tool button        in the Adobe Illustrator Tools palette to open the Tagger Tool dialog.
4.  Similar to the feature text label in the previous example, in the Text Dialog box you must first set the options
 for MAPublisher to determine the attributes that will be converted to labels. The Source Layer list will show
 the Area, Point and/or Text layers currently containing selected data.
5.  For each layer, the Column dropdown(s) will be populated with the attribute structure of that layer. Set the
 Column dropdown list to whichever column you wish to draw the labels from. For this example, choose 
 ‘Ontario Niagara Places’.
 This column contains the name of every location in the selected MAP Layer.
6.  Set the text layer to output the labels to. For this example choose the ‘Place Names’ layer.
7.  Click OK.
8.  With the MAP Tagger icon, click on any feature you wish to label.

6-ii: GENERATING LABELS FOR AN POINT LAYER USING THE MAP TAGGER TOOL
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Labelled places using the MAP Tagger Tool


